« first day (3052 days earlier)      last day (2044 days later) » 

12:02 AM
From video of BIOS update process:
> The System BIOS 1st/2nd PSP data is being updated.
Hmm... So the AMD Platform Security Processor has firmware stored in the BIOS flash?
I guess this is basically the firmware for the Ryzen built-in security processor, which, among other things, can serve as a TPM.
> The System BIOS 1st/2nd Boot Block is being updated.
I think that's for recovering the BIOS in the event of corruption.
> The System BIOS [1st|2nd] EC firmware is being updated.
@bwDraco on the left-hand side: with MU-MIMO; on the right-hand side: without MU-MIMO
red = 100% packet loss spikes. black line = ping (notice spikiness with MU-MIMO)
Like I said before, most modern systems have an EC for certain functions like always-on USB ports for charging.
@HornOKPlease Hmm... that looks like a firmware bug.
red line along top = jitter
Might be an issue with the Annapurna chipset, or more likely, the Qualcomm Atheros QCA9984 wireless radio, used in the R9000...
yeah, possibly, but I don't recall having this issue before the latest fw update
and I never touched or even saw the MU-MIMO flag before today, so I think it was default enabled
12:12 AM
(because I've never had any issues like this on my R7800)
I also have access to a debug page now (a forum mod on Netgear forums mentioned it) and it lets you tweak the fan curve for the little onboard fan (it's a very small fan) so I tried forcing it on, and it lowered the temps of the hottest chip on the chipset, the 5 GHz chipset, to 55 C
and the CPU usage is 2 to 5% per core on the main SoC
the 5 GHz chip was 59 C before so I don't think the fan helped
CPU usage at about 5% on my R7800 (via the debug page, too).
(Qualcomm IPQ8065)
it could also be my client devices that can't handle MU-MIMO (at all, or the particular implementation used by Netgear)
at the moment the only client devices I have are Apple :P
well I could try my Razer Blade
also, this problem has persisted for a long time, because I've gotten into the habit of turning off wifi on my iphone when I call into a meeting, so I don't get put on wifi calling -- which causes the call to drop out ><
it definitely affects all the Apple devices I own
Telnet access... looks like at least it's limited to the LAN. Not accessible over the Internet.
(tested from my server)
(use same password as you'd use to log into the router's Web interface)
I was concerned about security.
I'm not planning on modding this router. Logging out and disabling Telnet.
The router supports a maximum of 65,536 concurrent sessions.
> Enable 11k
(disabling this will break Smart Roaming on our EX7500 extender, since that relies on 802.11k)
> System Uptime 17:03:10:50
Oh, wow.
> Enable LAN/WAN Packet Capture
...and it can write to a USB device. OMG.
I wonder if Wireshark is able to open the resulting output...
> There are no USB devices connected to the router!
But the router's control panel shows the drive!
Ah. It needs to be on USB port 2.
...yup. pcap files.
(accessing the drive over the router's built-in SMB server)
I don't have Wireshark handy.
1:01 AM
Well... installed Wireshark on Stolas, stopped the capture... and wow. All the activity on the network is visible.
Enough experimentation. I'm removing the drive and uninstalling Wireshark.
So... when might this feature come in handy?
(I have a certain amount of authority over our home network, but I'm not abusing it to spy on my parents :P)
Well, that was fun.
1:36 AM
@bwDraco possibly useful to provide proof of illegal activity if it comes out as sufficiently unencrypted to get an idea of what was being done (maybe the main transaction is encrypted but DNS queries and traffic shaping gives you an idea) - can help if you have a guest network for example
like if you want to know whether someone staying at your house / nearby is doing illegal torrenting on your network
my Shadow server is hosted in New York
great pings on fiber tho :P
so many things are working a lot better now that MU-MIMO is disabled; I feel like I can use my Internet connection wirelessly again
I knew it wasn't the WAN side or the core of the router because ethernet has always been free of packet loss or significant jitter
user image
@Bob one of my former personalities has hacked a billboard! :D
@HornOKPlease, I'm wondering if you want to change your username back to "allquixotic".
1:54 AM
So, in conclusion, if your wifi is good and you have a ~6ms ping to the public Internet on your fiber, it appears that you can actually get "imperceptibly like native" responsiveness in Shadow
definitely not suitable for twitch FPS, but more than fine for panning the camera in a 3d mmo
Cloud gaming?
@bwDraco I will
@bwDraco ya
(because this is kinda confusing to me and would prefer to write "@allq")
(you may want to change your avatar to reflect that, too)
2:01 AM
Hello, should I migrate this thread to here? Not sure how much it is a good fit for AskUbuntu:
Q: Protecting WSL-Ubuntu so that only port 443 will be unfiltered in a correct way (using WSL only for Ansible)

JohnDoeaI use WSL basically just for Ansible (which as far as I know requires only port 443 to be unfiltered to work properly). With Ansible I Can continuously orchestrate architecture, and deploy relative changes to all my remotes IaaS machines from my own PC. I desire to protect my WSL as much as I ...

It's a question involving both Windows and Ubuntu. I'd probably flag for migration.
(use a custom mod attention flag "migrate to <site name>")
the only thing between me and a familiar username and profile pic is caching
meow – welcome back, @allquixotic!
(not sure if that pinged you because the change may not have propagated to the chat servers yet)
it didn't ping me yet
2:12 AM
That Maine Coon is adorable.
that's my kitty
I know :)
...and the change just registered.
Ya. I gave it a kick
@bwDraco indeed, as it is such a question I flagged commenting that it might require migration, but here is best you think, not to information security? I can also delete and re publish --- maybe in Information Security SE...
2:15 AM
I wouldn't put it on Information Security.
IMO it's more of a configuration question.
Redirect me to the right place if this is not the place for this question, but I need to do something like traceroute/tracepath/tracert, but I have no admin privileges and I do not have traceroute/tracepath/tracert installed. All I have is Java, Python, cygwin, and Windows 7, and I can put things in my home directory but I cannot do full installations. Do you have or know of a way to do traceroute/tracepath/tracert given these limitations?
Why isn't tracert available?
It should be part of the base Windows install.
Also, is your avatar corrupt? Try uploading it to Imgur on Stack Exchange.
It's returning HTTP 400 with a JSON message indicating an error:
> Unsupported get request. Object with ID '1562342057384865' does not exist, cannot be loaded due to missing permissions, or does not support this operation. Please read the Graph API documentation at developers.facebook.com/docs/graph-api
2:36 AM
I am kind of in a security sensitive/paranoid, sandboxed, locked down environment.
Work machine?
Q: How do I do traceroute/tracepath without any admin privileges?

Sacha T RedRedirect me to the right place if this is not the place for this question, but I need to do something like traceroute/tracepath/tracert, but I have no admin privileges and I do not have these utilities installed. All I have is Java 8, Python 3, cygwin, and Windows 7. I can set local environment v...

Use caution if this is a corporate machine. If this is part of your job, contact your IT helpdesk for assistance.
@allquixotic The packet capture feature is not capable of capturing large packets, so quite a bit of data is lost. I ran Speedtest.net and did not see the 28-30 MB/s of data I expected at the full speed of our Internet connection.
2:56 AM
No time.
3:18 AM
@SachaTRed can you download stuff from the internet?
there's a source code package too if you want to compile
I don't think you can use ICMP (at all?) without admin rights, but you can definitely use UDP if the network allows; if not you'd have to implement some kind of TCP-based traceroute o_O
3:31 AM
...weeeeeeeeeeeeelp. HP increased the amount of memory dedicated to the Radeon Vega processor graphics to 2 GB in this BIOS update. I'm not a fan of this change because it means only 6 GB is available to applications.
This can't be configured by the user in the BIOS setup.
Yes, this will improve graphics performance because it's a fixed block of memory used as framebuffer, but I don't game a lot on this machine and I run virtual machines on it.
(AMD-V remains enabled after the update, so no need to change that setting)
Let me see if I can find any patch notes for this BIOS update...
@bwDraco that seems like a super shady thing to do without prompting users or giving them a choice
also, IMO, the shared system memory framebuffer should start at 1 GB and scale up if it becomes full (due to high screen resolution or application demand) by powers of 2, and occasionally shrink if utilization decreases
like, don't constantly resize it by a few bytes at a time, but give it a modest window at first, then occasionally resize it
(I'm assuming a resize has a severe performance cost relatively speaking)
(but do note that I do occasionally exceed 1 GB of framebuffer usage, albeit not by a substantial amount)
GPU-Z is sitting at 458 MB dedicated, 92 MB dynamic right now.
I suspect users are doing more than a bit of gaming on these laptops (and they are in fact stellar performers for eSports games like League of Legends), but this change is rather inappropriate for my use case.
Windows and its drivers do adapt to available memory, so baseline memory usage has dropped a bit.
The memory is soldered, and HP does not offer a 16GB option with the Ryzen 7 2700U.
3:53 AM
it'd be funny if Apple tried to increase their profit margins by moving to cheaper Ryzen processors while charging the same amount
they probably could, and bill it as "moar cores!"
(even with a custom build)
Reconfigured Firefox to use 2 content processes (previously 3). This will reduce performance a bit, but Firefox apparently will still happily saturate all eight hardware threads when loading multiple heavy pages.
Mozilla's Quantum technology is pretty impressive, being able to saturate a 4C/8T processor with just two content processes. But they need to fix their crappy battery life...
Interesting. In Firefox 64 with the new Task Manager (about:performance), energy usage is tracked. Looks like Mozilla is actually working on improving the browser's energy efficiency.
yesterday, by bwDraco
@Bob The thing that was holding them back was tying architecture to process. They've now decoupled the two so they don't wind up getting tied up by stuff like the 10nm problems.
@allquixotic Radeon Software 2019?
4:11 AM
.@FirefoxNightly is now officially my dev browser. It’s gotten so much better and faster since the last time I used it a couple yrs ago. 🔥
(blog post was one day before the launch of Quantum)
> It takes advantage of modern hardware, parallelizing the work across all of the cores in your machine. This means it can run up to 2 or 4 or even 18 times faster.
I have yet to see it fully saturate 16 threads even when loading dozens of tabs at once, though.
("18 times faster" references the then-flagship Intel HEDT processor Core i9-7890XE, which has 18C/36T)
@bwDraco oddly I'm spiraling pretty close to using stuff similar to what you use, in part :P
I'm 100% Firefox for browser (used to be Chrome), and have been gaming on a Vega 20 for a while :)
albeit on macOS
I've never bought an AMD CPU in any form factor though (unless one is in an embedded system somewhere, but definitely not a desktop/laptop/phone)
and other than my RX 580 which I used to try out macOS eGPU, the last desktop Radeon I owned was a HD7970
Hmm... it looks Firefox can saturate 16 hardware threads under certain limited conditions, but something is bottlenecking the browser.
Could be the network.
(tested with 34 tabs and true process-per-tab (dom.ipc.processCount=1024, which is process-per-tab for all intents and purposes)
On Astaroth, Ryzen 7 1800X overclocked to 3.95 GHz.
4:30 AM
@bwDraco ("18 times faster" references the then-flagship Intel HEDT processor Core i9-7980XE, which has 18C/36T) (source)
(and I have no means by which I could feasibly connect an Ethernet cable to Astaroth)
@allquixotic I'm curious, what made you switch to FF?
I'd like to, but at this point I've been using Chrome for half a decade and too lazy to learn how to use FF.
I used to use Firefox when I was like 10 or something, because my mom used to
4:46 AM
My father's been using Firefox as far back as version 1.5.
I really like being able to select and operate on multiple tabs at once, a feature added in Firefox 64.
(to be fair, Chrome has had this feature for several years)
5:00 AM
@rahuldottech @Bob
@rahuldottech @Bob runs several thousand tabs (though no more than a few hundred may actually be loaded). Firefox is the only modern browser able to do this without running out of memory.
This addon, which uses Firefox's native tab discarding mechanism, may be useful if you have lots of tabs and are memory-constrained.
(if you notice how Chrome for Android or Chrome OS may reload tabs that were not recently used, it's because they're discarded in essentially the same fashion)
(FWIW, that add-on should theoretically also work on Chrome and Edge)
6:01 AM
@bwDraco ahh
@bwDraco I never have more than like a hundred. Too many tabs annoy me. ;p
And the only time I even reach a hundred is when I'm doing research or something
6:22 AM
@rahuldottech he switched cause containers
@Bob as in, docker stuff?
@rahuldottech as in, browser sessions
Argh, it's annoying how YouTube only has 1.75x as an option on some videos and most just jump from 1.5x to 2x
stupid stupid stupid
7:00 AM
@ThatBrazilianGuy I think it's your relative position to a pre-defined landmark. Not sure.
7:33 AM
Too bad there isn't a wreath emoji (yet). (I'm pretty sure the writer would have used such an emoji if it existed.)
But emoji in an headline, let alone in text, is very uncharacteristic of a newspaper as prestigious as The New York Times.
7:57 AM
(in print, the headline was "Twitchy Riders Beg: Re-Deck the Holland")
8:22 AM
...the display assembly on my OnePlus 3T is starting to separate a bit from the device chassis ._.
(the display, digitizer, and glass are fused together)
Looks like a fairly common issue with this device.
Probably caused by localized heat and repeated thermal cycling causing the adhesive to fail ._.
@bwDraco How is Quantum now? FF flavors afaik don't have as much traction and stability as Chrome variants.
Noticeably better performance and generally stable, but still has some tendency to leak memory and has high power usage.
In other news... my Discover secured credit card has graduated and I'm getting my security deposit back, plus a credit line increase πŸŽ‰πŸŽ‰πŸŽ‰πŸŽ‰πŸŽ‰
(details on Matrix)
8:54 AM
Cool. Morning.
@bwDraco I need an analytics dashboard for that. Do you know how to make one?
Eh, I just use Task Manager and watch memory usage.
9:11 AM
can taskmanager do forecasting from tasklist logs? Not yet, right.
Whoops, misread the question :p
9:31 AM
Who knows powershell (and where is @BenN recently?!)
I constantly have
> Microsoft.PowerShell.Management\Test-Connection : The service cannot be started, either because it is disabled or
because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422)
At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\\PSModule.psm1:6146 char:22
+ ... connected = Microsoft.PowerShell.Management\Test-Connection -Computer ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (:) [Test-Connection], COMException
Cept I'm not sure what exactly can't start D:
@Nick IME Chrome is, if anything, less stable
Or at least I've seen crash screens for Chrome more often. Devtools does that.
@djsmiley2k He's been in chat but quiet :)
@Bob could it just be that you use chrome more frequently and the application cache buildup is higher? I thought excessive page thrashing and non-responses came from too many resources being utilized by individual browser tabs.
@bertieb i think he has exams
Fair dos
I know that feel
Although my Chrimbo exams are done for now
9:41 AM
@Nick ...you do realise you're talking to the guy with like 10k tabs spread across 5 firefox instances?
And a grand total of maybe 5 chrome tabs open at a time, usually just 1-2?
@Bob 2k tabs run on just one processor thread!!??
@Nick Not true. Firefox Quantum is fully multithreaded.
From what I'm reading, regular Ff has a limit to a few hundred tabs, but that was 5 years ago.
@Nick 5 years makes a lot of difference
@bwDraco This has little to do with quantum
it worked fine even before e10s
e10s made i better
54 greatly improved load speed with many tabs
quantum ... did very little actually
quantum wasn't some magical change, marketing aside
most of the changes actually happened from ~50 onwards
10:13 AM
i still miss the tab groups
The biggest change in Quantum itself is that each tab has multithreaded rendering.
The idea is to go beyond process-per-tab, by being able to process and render individual webpagea in a multithreaded manner.
In Firefox 64, just two content processes can saturate eight hardware threads.
That's the theory. In practice it doesn't help nearly as much as the 10 versions of changes leading up to it.
It just overshadows those other changes due to branding.
With Firefox, unlike with, say, Chrome or Microsoft Edge, the idea is that instead of wasting memory duplicating data structures for every single tab, you make each tab more heavily threaded, and let a small number of processs handle many tabs, for a performance advantage with lower memory usage.
Nonetheless, the "18 times faster" claim could not be substantiated, perhaps due to network latency limitations; I was not able to push the Demon to sustained 100% CPU utilization even with process-per-tab and 30+ tabs being loaded at once.
(if it can't fully utilize a Ryzen 7 1800X, it won't fully utilitze a Core i9-7980XE)
10:54 AM
Anyone know if Virtualbox VDI files are copy-on-write like qcow2?
Couldn't find much with a brief search for "vbox vdi copy on write".
@forest Is this for recovery?
@Bob how far we've come: youtube.com/watch?v=szdbKz5CyhA
@Nick Nah, someone is asking on Information Security whether or not files can be securely deleted from a VDI image. If it's CoW, then I'll be able to answer that it's not.
Thing is, I only use QEMU (and its format, qcow2, is CoW), never VirtualBox.
I don't think it's explicitly copy-on-write, you should check some docs from the creators to make sure though. VBox has something like session-saves, saved information may be used to retrieve a lot of things.
11:10 AM
11:32 AM
seriously if i hear noddy holden scream "IT'S CHRIIIIIIIIIIIIIISSSSSTMAAAAAAAS" one more time I will violently murder someone
11:49 AM
Just yell this is Sparta and kick them down a well
in slow motion?
3 hours later…
3:12 PM
/me sighs
3:50 PM
/me cries
/me tries
/me dies
4:49 PM
@forest VDI isn't copy-on-write AFAICT, unless you have differencing images (e.g. snapshots). However, you can expose TRIM support to the VM. If you do so, any trim/discard commands will cause the hypervisor to deallocate the trimmed areas from the backing storage (IOW the VDI will shrink as space is trimmed). This is not part of the standard VirtualBox interface, though, and must be enabled through VBoxManage.
> VBoxManage storageattach "<VM name>" --storagectl "<storage controller name, typically something like SATA>" --port <port number on the controller> --discard on --nonrotational on
the gray areas are when my MBP was genuinely asleep, and the areas in between were "power naps" when the "Sleeping" MBP (on AC adapter) would wake up for a bit to allow background services to execute
and apparently pingplotter activates during those power naps (as does things like the update checker)
5:24 PM
Yay, my site is number one for people trying to connect to an IPC share!
5:45 PM
The ultimate ploy to get rep: stackoverflow.com/questions/8425421/…
Ugh my best friend is such an asshole
I am so pissed right now
6:15 PM
@djsmiley2k What causes the error to appear?
Next time it happens try running $Error[0].Exception.ToString() so we can get more information
2 hours later…
8:36 PM
@BenN it's complicated, to say the least lol but sure, I'll try that on monday if I remember about this :D
9:15 PM
I'm Peppa Pig!
9:31 PM
wow it's quiet here.
That's awfully early for you.
@JourneymanGeek night shift?
@bwDraco or late
@JourneymanGeek Ow.
You're not really a night owl, are you?
9:56 PM
it's the shifts.
@JourneymanGeek wait where do you work again I forgot
Last I remember was the school
Ah I remember
i read alcohol.
instead of school
10:23 PM
i only had 2 drinks D:L
but.... it's 14.4C in here D:
@djsmiley2k it's 2°C here
in the house?
@djsmiley2k yes
The heating situation here is... Complicated
Well, it's slightly higher in my room
But yeah
I'm wearing a wooly hat, so god knows what you must be in o_O
@rahuldottech naw
I work in for the government, indirectly
10:53 PM
@Bob: Is there a way to restart the Firefox WebExtensions process without restarting the whole browser?
I just had an extension glitch on me and stop pages from loading correctly. I terminated the WebExtensions process, and extensions now no longer work. Can I get the browser to restart the process and reload the extensions without having to close and reopen the browser?
11:26 PM
am I allquixotic yet?

« first day (3052 days earlier)      last day (2044 days later) »