« first day (3220 days earlier)      last day (90 days later) » 

2:14 AM
0
Q: Is it safe to remove windows OS now that I have installed two linux distros?

Jack MooreI have recently installed ubuntu 18.04 (4 months ago) and Kali Linux (1 week ago) successfully alongside Windows 10 Pro. I used Rufus to get Ubuntu and the Win32 Image writer for the Kali distro. I have tested ubuntu and kali and both are working great. My question is: is it a good idea to remove...

 
 
3 hours later…
5:24 AM
@WinEunuuchs2Unix I could have, but I didn't...
Also: once you edit, it gets bumped out of the queue and doesn't need any more reviewing...
@WinEunuuchs2Unix lemme try.
 
5:42 AM
@Fabby Thanks but it's too late. Problem has been solved.
 
Urgh...
Shouldn't you be sleeping by now?
 
6:18 AM
0
Q: OpenVPN Server not allowing clients to ping or connect to any websites

Lachie GrantI am actually using Windows on the client, but the server is Linux and that's where I believe the problem to be. I recently set up a VPN service on my VPS (Ubuntu 18.04) according to Digital Oceans guide (How To Set Up an OpenVPN Server on Ubuntu 18.04) I used the same server for both the CA an...

 
7:00 AM
0
Q: How do I resize partitions when I don't have physical access to a remote server?

FabbyI have a: cloud instance remote server Virtual Machine ... of Ubuntu to which I don't have physical access and I need to resize mounted partitions like / and /boot that I cannot dismount! All the tutorials / answers I can find on-line are telling me to boot a USB or a DVD or ... but I can't...

 
7:22 AM
@terdon: as a U&L / AU straddling mod: the above would be (with slight modifications) be a good one for U&L as wall, but as they're very allergic to Cross-posts there, *would it be bad taste to copy-paste (with said modifications) over there as well?
Hi Benny!
 
Hey Fabby, Hey all, Good morning!
\o/
 
0
Q: Raise visibility of self-answer by awarding bounty to self

FabbySo I posted a brilliant Q and A on how to resize partitions when you don't have physical access to Ubuntu as I'm seeing this happen all the time and couldn't find any specific answers here on how to do that. If anyone visiting meta has posted something similar, please feel free to close it as ...

 
8:00 AM
It's me again! I modified my answer that I asked folks here to delete yesterday: askubuntu.com/a/1160395/248158. I had to comment out some lines in ~/.bashrc to make sure the terminal window title doesn't change if ,for example, I change directories. So, if it isn't unethical, I'm asking for undelete votes and for whoever downvoted (at my request) to undo the downvotes!
 
8:24 AM
@DKBose undelete vote cast. Upvote can only be done after undeletion, so ping me again once undeleted.
cc @WinEunuuchs2Unix @ElderGeek @EliahKagan
 
9:00 AM
@Fabby okay will do so!
 
@DKBose Not yet! :D ;-)
 
@Fabby if you edited it considerably, it might. Remember that many modern systems don't have grub or any bootloader other than the EFI one. So if you were to post on U&L, it would be great to give a grub-free answer.
By the way, your question mentions cloud and VMs, but there it is trivial to change the partition through the cloud/VM settings, isn't it? Why would you go to the trouble of booting through an ISO?
 
:51133742Thanks for the response. Kulasandra told me it would be cross-posting.
@terdon Because I've had 2 questions by 2 people not being able to do that in the last 2 days.
 
It would, yes, but not if you modified it.
@Fabby From a VM?
 
@terdon One a VM, but without access to the Hyper-V Hyper visor and one a VPS with only ssh access, but having a cPanal console.
 
9:13 AM
Or a cloud instance? The cloud providers give you some sort of management interface, don't they? And the VM is easy to boot from another ISO as you say in your footnote. It seems like wasted effort to do what you describe for a VM. It's the perfect solution for a bare metal machine, of course.
@Fabby Ah, a VM you don't control. I see.
 
Exactly! >:-)
Apparently it's very niche, but no good answers exist neither
I'm going to drop trying to make it into a canonical answer that will attract more visitors to the site...
Or maybe if I research installing Lionux without grub straight from EFI.
I have: rEFInd, then grub, then custom kernel...
(well, when booting Ubuntu.) Tried Manjaro 18 and it looks very good! no nVidia issues! just detects and installs!
So I might be decamping to U&L soon...
0:-)
(as an asker of questions instead of a poster of answers: the level of knowledge there is just ... well... at another level.)
 
I haven't used grub or any other bootloader than EFI since switching to arch.
 
@Coditoergosum I'd like to inform you that the first post you reviewed here as "no action needed" was spam. No harm done, it is deleted now, but next time please look more closely. Thanks.
 
10:15 AM
@ByteCommander thanks accepted and upvoted. I remember it was possible if you:
1. Posted a Q&A,
2. deleted your anwser
3. posted a bounty
4. undeleted your answer
5. Awarded yourself the bounty.
(which was really unethical and why I asked.)
 
@Fabby Are you sure about that? I don't think you could ever award a bounty to an answer owned by you.
Of course, if you want to draw attention to your question, then offering a bounty is a great way of doing that! It just costs you some rep.
 
@terdon I'll have to ask ShadowWizard. He told me about the above.
I don't even want to try if the above still works because of well. science...
because it would be mad scientist science!
>:-)
 
OK, I guess it may well have been true.
 
10:39 AM
It might still be true because some of the logic in the SO back-end is... Let's say: convoluted
 
10:51 AM
@ByteCommander sorry
 
it's okay, just wanted to inform you for the next time.
 
11:16 AM
@DKBose done
@Fabby ^^
 
still 3 downvotes here @WinEunuuchs2Unix @EliahKagan @ElderGeek
 
Thank you all very much!
 
11:39 AM
0
Q: How to find IP address of HDP-Sandbox(on VirtualBox VM)?

MikiBelavistaMy host is Ubuntu. When I log in to HDP-Sandbox ip addr show gives me 5: eth0@if6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default link/ether 02:42:ac:12:00:02 brd ff:ff:ff:ff:ff:ff link-netnsid 0 inet 172.18.0.2/16 brd 172.18.255.255 scope global eth0...

 
12:00 PM
0
Q: dos2unix is unable to convert typescript file to unix format

NoshiiiI recorded my current session using script command and all information was saved in typescript file but when i opened it using vim there were a lot of ^M due to carriage return. So i tried to convert this file in UNIX format using dos2unix command but i was unable to do so. It was giving this err...

 
 
2 hours later…
1:44 PM
@DKBose Happy to unvote :) I think it is better this way to change answer. Plus I upvoted too :P
 
@WinEunuuchs2Unix thanks!
 
2:10 PM
Windows updates nuked my carefully designed boot manager (rEFInd).
Had to boot an ISO and drop to an EFI shell and do it manually again
 
sudo apt purge windows. :D
 
@Bahamut I still need it to change my keyboard backlights.
P.S. You remind me of someone else...
I'm going to ping him now.
 
2:40 PM
0
Q: How to make this bash script more efficient?

CrashFiveI have to run these commands on my servers before and after an OS upgrade to verify everything is still the same as expected for safety measures. Can I get someone to help improve this script for me? #!/bash/sh touch /tmp/preUpgradeSystemInfo.txt service --status-all >> /tmp/preUpgradeSystemIn...

 
This question uses the tag freeze which doesn't seem to exist for me? askubuntu.com/questions/1160662/…
@Fabby Let me see if I can find you a good Q&A on "How to backup a Desktop PC" it will no doubt cover that step...LOL :P
 
2:57 PM
@Fabby At first I was joking about your own backup Q&A. But I did find a Q&A on backing up EFI which I just did for myself: askubuntu.com/questions/698980/…
 
0
Q: Check if a specific file with a specific name is running?

The Chem XI am wondering is it possible to check if a specific file with a specific name is running? I see a lot of various cases that show PID's rather than a filename but would rather take a filename route. For instance lets say a file called test.php is being executed via PHP command (in this case lets ...

 
3:15 PM
@WinEunuuchs2Unix Nah, Window$ deletes the entries from the NVRAM.
so the disk stuff is all still there, but it doesn't show in the boot order any more and the EFI firmware is useless for that, so I have to boot into an EFI shell as I manipulate that directly.
 
3:36 PM
@Fabby That's scary stuff. I haven't booted to Windows in many months. I wonder if I will suffer the same fate?
 
@WinEunuuchs2Unix Just a bcfg add 0 fs4:\EFI\refind\refind_x64.efi "rEFInd Boot Manager"
 
@Fabby I'm lost. What screen to you type: bcfg add 0 fs4:\EFI\refind\refind_x64.efi "rEFInd VBoot Manager" in? My BIOS doesn't provide a command prompt.
 
Boot to an EFI shell: The real stuff Low-level access
 
I don't ever recall booting to an EFI Shell.
BIOS allows me to pick which EFI to boot and I place Ubuntu above Windows.
 
@WinEunuuchs2Unix Get the rEFInd ISO
@WinEunuuchs2Unix Mine only allows me to pick HDDs, not individual files on the HDD.
 
3:42 PM
why do I need an rEFInd ISO for the sole purpose of fixing what it breaks in the first place? :P
 
@WinEunuuchs2Unix Windows broke the NVRAM.
rEFInd fixed it (well, the EFI shell that comes with it)
 
All ram is volatile so Non-Volatile RAM (NVRAM) is non-sensical. It must be EEPROM or something like that.
 
EEPROM is different technology and really slow
 
Must be similar chips to my SSD then It's really fast.
 
That's like saying ... EEPROMS, NVRAM, HDD and SSDs are the same: they store bits permanently
:D :D
 
3:45 PM
HDD is analog though (right word?) The rest are chips.
 
4:21 PM
0
Q: Ubuntu 16.04 no sound Hardware found

Dadong ZhangMy computer has lost sound maybe after an upgrade and when I check the sound settings it turns out no hardware: I have tried this: sudo alsa force-reload Unloading ALSA sound driver modules: (none loaded). Loading ALSA sound driver modules: (none to reload). And then: sudo modprobe -v snd-h...

 
4:35 PM
@WinEunuuchs2Unix in your answer about config files, you could also mention the config files of regular applications (mostly in ~/.config, some in ~/.local and some in the home folder) that probably are better off not being edited directly but rather via the application's GUI.
 
4:49 PM
@DKBose Sounds like an opportunity for you to add a new answer to the thread :) Your answer can be "User Configuration Files" whereas mine can be deemed "Root Configuration Files". Someone else has already posted a second answer so the more the meerier right? A fourth person might post an answer on gsettings too. That can be considered "configuration" in a loose sense.
 
@WinEunuuchs2Unix okay!
 
5:33 PM
@DKBose Thanks and upvoted. Now waiting for @Fabby to add his two cents (two pence): askubuntu.com/questions/1160728/…
 
6:09 PM
Rutger Hauer just died :(
 
I guess I'm ill-informed to ask who he was?
 
6:58 PM
@WinEunuuchs2Unix On that answer, how do you feel about "System-wide configuration files are usually in /etc and owned by root" as the first sentence? I was going to just make this edit, but from the comments I got the sense that you want to avoid making the answer more complicated. So I'm asking instead.
I admit the wording I propose is more complicated, but only a little bit, and I think avoids inadvertently telling users who want to edit configuration files in their home directories--which is a common situation and there are often many such files--to do so as root.
 
@WinEunuuchs2Unix The villain of the best Sci-Fi movie ever made:
Blade Runner
@Rinzwind 5 days ago according to wikipedia.
Rutger Oelsen Hauer (Dutch: [ˈrɵtxər ˈulsə(n) ˈɦʌuər]; 23 January 1944 – 19 July 2019) was a Dutch actor, writer, and environmentalist. He acted in both Dutch and English-language TV series and films. His career began in 1969 with the title role in the Dutch television series Floris. His film credits include Flesh+Blood, Blind Fury, Blade Runner, The Hitcher, Escape from Sobibor (for which he won a Golden Globe Award for Best Supporting Actor), Nighthawks, Wedlock, Sin City, Confessions of a Dangerous Mind, Ladyhawke, Buffy the Vampire Slayer, The Osterman Weekend, The Blood of Heroes, Batman Begins...
 
@Fabby I remember him from the Lady Hawke movie but not from Blade Runner.
@EliahKagan Why don't you post an answer targetted on the directories configuration files can be found in? I'll upvote it. Besides /etc I'm often going into /lib/systemd/system-sleep It would be cool to see many answers from many people. Still waiting for @Fabby to cough up his two cents worth :P
 
@WinEunuuchs2Unix My 0,02€ were to upvote your answer! :P
 
@WinEunuuchs2Unix DK Bose's answer covers the user-specific aspect of that. I might post an answer covering sudoedit, though, which can safely and conveniently be used with just about any text editor (including graphical text editors like Gedit) without requiring the editor itself to be run as root. I've got to go afk real soon, though, and I don't know when I'll get around to this. So if someone else were to write such an answer... that would be even better!
 
7:17 PM
@Fabby Thanks my friend. It was interesting to note about 1/2 hour ago someone downvoted my answer and the question at the same time. They didn't however downvote the other two answers. Guess they ran out of two rep points (are they like 0,02€) to keep being negative :P
@EliahKagan Ping me when you write your answer and I'll upvote it. I'm liking the different techniques that are surfacing when it comes to configuration files. I've always approached things the same way and always used gedit.
@Fabby I breifly looked at your NVRAM and apparently it's like a Windows 2003 thing and not applicable to me on Windows 10?
 
@WinEunuuchs2Unix Thanks -- assuming I write an answer, I'll let you know! :)
 
@Fabby it sure was :)
@WinEunuuchs2Unix he was the evil head of board member in Batman Begins.
 
8:14 PM
@WinEunuuchs2Unix It's a hardware thing and part of the UEFI standard.
 
8:33 PM
@Fabby I got the impression it's for old computers. Newer ones need to use BCDEDIT or something like that.
 
 
2 hours later…
10:51 PM
@WinEunuuchs2Unix Yeah, for windows, but the variables are not stored on disk but in NVRAM...
(sorry for the late reply: was on a DR Test that went TITSUP
Total Inability To Serve Uniform Poweron
 
11:33 PM
@Fabby It's hard for me to wrap my mind around a problem that has never happened. I'll just have to forget NVRAM ever existed :)
 

« first day (3220 days earlier)      last day (90 days later) »