« first day (1890 days earlier)      last day (2480 days later) » 

6:51 AM
Yeah, so the next line was not quoted at all, it was obvious really I guess
2 hours later…
9:34 AM
I guess so... voted
1 hour later…
10:42 AM
Can anyone edit this and make it an answer? askubuntu.com/questions/950890/… Thanks!
It's like bordering on a NAA.
Need dem 2k repz :|
10:59 AM
@BhargavRao ugh done but I would rather delete that answer. Wish I had voted unclear instead of dupe on the question. Now the crappy question won't be deleted. I'll have to edit that as well. And we don't want people to log in as root and use root password
It's unclear why they would have to do that
root has no password in Ubuntu by default
which effectively disables the account until a password is set, for good security reasons
@Zanna \o/ .... Now I know the trick, I'm a Ubuntu hacker.
hahaha yeah no point trying to hack the root account, go straight for the user account
That's the second step. :P
First I hack the root and then I hack the shoot.
This is a link only answer (NAA), right? askubuntu.com/questions/378661/…
I downvoted and voted to delete the answer and left a comment on the question because I doubt that they meant the root password (it's very unlikely) and edited the question extensively just in case it doesn't get deleted
@BhargavRao isn't that just a request for information?
@BhargavRao that's an answer
I can expand it very slightly and it will be fine
@Zanna gotcha.
@Zanna if we re-word it something like:
> You need have a look at the template file "cert.cfg". That same one file name occurs in two different calls of certtool, where the purposes of the calls are complimentary to one another. Check if this is the same template file in both cases. At least you should pay attention to the "ca"-instruction in each case.
That'd make it an answer.
11:15 AM
hmm I'm not going to flag it because Thomas' answer is... unclear
I am going to edit it
> To do that, you open the terminal, type python, then hit the Enter button
You people give some real good basic advice here :D
I remember a mod telling me in TL that they're not a SO mod, hence they need to be kind.
@BhargavRao sure, I'm just editing the poorly formatted question to get a better idea of what's needed :)
Teacher's Lounge, a place where mods communicate with each other.
11:22 AM
oh sorry, place for grownups XD
@Zanna that can never be achieved on SO. :D
we really don't like people to log in as root :D
Only real hackers like me should be doing that. :p
hahaha yeah obvs
you could always suggest an edit to the openssl post and get some rep :P
wait I don't understand this answer O.O
@Zanna too lazy to wait :(
11:32 AM
I am here to your edit isn't it bro
lol, that'd be some semi sock activity. :D
hehe I am still suspicious of the user who posted a first question yesterday which got instantly answered by another nearly new user, and the answer got accepted as soon as the timeout finished, even though it was really an LOA to convoluted installation instructions (unnecessary as the app is in repositories) so there's no way OP could have installed it and tested it for their purpose that quickly imho, and at the time of the accept, that answer had zero upvotes and
a critical comment from me, while two other answers had been posted and upvoted (both requiring no new package installation and easy to instantly test)
I really want to nuke the tag but got no traction on meta
if we need that tag it should at least have a proper name
12:42 PM
Hi. Can you give a link (again?) to one of the posts? I had read your talking about how something seemed "socky" before, but I wasn't sure which posts you had been referring to.
@Zanna if they have SO profiles, link em up. I'll dig through them.
1:06 PM
Thanks :)
Hmm, not much data on SO to investigate :(
thanks for cleaning :)
oh well :(
Did you flag them on AU?
Lemme know as to what happened to your flag.
@EliahKagan here's the post
I didn't flag because I thought it was more likely just coincidence
Should I be flagging?
1:36 PM
Good luck to my flag
That's new to me second "review" showed up although review was completed
Didn't get ya.
1:58 PM
I'm sorry! Do you mean the last message?
Review completed 25 mins ago:
Zanna reviewed this 23 mins ago: Reviewed
Hizqeel reviewed this 25 mins ago: No Action Needed
I am surprised the system recorded my review of the post although it had already been reviewed while I was editing the Q and other answers
So the queue needs 2 users to review, right?
No, only one in First Posts
Hah, then it's some race condition.
The "Review completed" notice records the time when the first reviewer finished too
Worth a meta post......
> How could this user review an item after it was reviewed? What happened here will blow your mind.
2:02 PM
@BhargavRao I've often clicked the back button and seen somebody else reviewed before I finished, but never seen my review get counted and displayed there nonetheless
@BhargavRao lol
It's been almost a year since I reviewed that queue. So I've forgotten everything :|
You have plenty of other stuff to review :)
I find it very hard to review that queue, but I try to do so when I can because I find it's reviewed poorly here
yep, loads of crap.
I've heard there's way more work for mods on SO now because many people have stopped noticing the review link since the redesign. Is this true?
First Posts and Late Answers are quite hard ones to review IMO.
@EliahKagan it costed us an election....
2:07 PM
I will take that as a yes. :)
Is SE going to add text to the links so they're more visible?
The CV, SE, RO and LQP queues are reviewed mostly OK imho, but the FP & LA queues are mostly just No Action Needed-ed by a handful of people. I guess they are flagging the obvious stuff which is good. Maybe my expectations are unreasonable or inappropriate for those queues
@BhargavRao O.O
Lemme tell you the entire story. The mod queue was quite close to 0 from the last year November elections till the redesign, after that the custom flag queue was quite normal, but the NAAs and the VLQs just exploded. We used to have 400 of them in the queue at any given point of time. (800 once). So the mods started to handle those and the custom ones started to grow.
Soon suggested edits queue broke as well, Shog randomly increased the limit to 500, but it still wasn't enough. We started to get custom flags asking for edits. Finally, we hit 1.3k flags in the queue and decided to have elections. Now it's back to sub 100 levels.
@EliahKagan They told they're "looking into it".
I really like this proposal:
A: Please change the review icon back to a text link

canonGo for a hybrid, imo. When accompanied by an icon, the text doesn't have to be as big as the first-class links.

They've made it worse now.
2:14 PM
Q: The new review icon isn't an improvement

canonTylerH mentioned here that he likes the new review icon (currently in A/B testing): That icon is the same, isn't it? For pity's sake, can we replace that icon or just add some text? Now it has a red dot. Great. Even the red dot's meaning isn't clear; there's no way to infer its actual meanin...

Omg. Thanks for the story (excuse slowness - on mobile as I went out)
I see what you mean.
> Hey, something's up with the stapler chat bubble thing! Office supply threat level: cabernet?
Btw, that new comment flag unification didn't help as well. That blew up the comment flags to around 500 within 24 hrs of it's introduction.
I find the icons on Stack Overflow very confusing. It feels like I'm in an RTS I've just begun playing, rather than a QA site whose interface I never had a problem with before. When I highlight a code block in a post I have to remind myself that Ctrl+K just indents by four spaces, rather than self-destructing the units I have selected.
2:18 PM
Now things are quite stable, though.
@BhargavRao still feels wrong to flag the mildly unkind comments as rude or abusive, which is apparently what I'm meant to do :/
The only times I've visited SO since this happened, I've just run away as fast as possible
@EliahKagan lol
Well if you know a comment has got to go, but for whatever reason don't like the flag reasons, you can use a custom mod comment. I don't know how moderators would respond to such flags, but unlike with custom post flags, custom comment flags add to the flag count of unexpired flags that automatically deletes the comment without moderator intervention (and for posts with some words and phrases, deletes the comment immediately).
But unlike post flags, comment flags with the rude/abusive reason that result in comment deletion (either automatically or through moderator action) don't take rep away from the commenter or anything.
yeah I have to remind myself of that
do only custom flags automatically delete comments if there are several of them?
No, all comment flags do that. Occasionally you might not want it with a custom flag (if you really needed to avoid that outcome you could use a custom moderator intervention flag on the post itself and explain the situation)... but you pretty much always want it with any other kind of comment flag.
2:29 PM
I've noticed (and used) the fact that certain words cause the comments to be deleted (I don't like "accept my answer!" comments. I can't remember what I flagged them as before, but now I use "no longer needed" (regardless of whether the answer was accepted))
jokerdino once mentioned that someone had flagged one of my comments as "helpful"
@EliahKagan that's what I thought; I misunderstood what you said first
"accept", "+1 ...", any obscenities have that. "thank you" and "it worked" have a length limit.
phew, just had enough time to fix the missing quote.
@Zanna That's.... not what flagging is for! Maybe they didn't know about the comment upvote arrow, or didn't have the rep to use it, and thought you were supposed to use flags that way... Still, it's an honor to have had your comments flagged as helpful! :)
Comment flags are also marked helpful (and thus are no longer raised on the comment) when the post itself--that the comment was attached to--is deleted. Comments on deleted posts can still be flagged (or flagged again), though, and those flags are not instantly marked helpful. I don't know what happens if you flag a comment on a deleted post and then the post is undeleted and deleted again before the flag is handled.
@EliahKagan haha yeah! :) it made me laugh
@EliahKagan haha maybe we should investigate that...
@Anwar I've unprotected your question How can I get octal file permissions from command line? as it turns out there was only one answer that ever needed to be deleted (the other needed editing, if anything--at least it benefited from it--and it was undeleted after I edited it). The one deleted answer is for a different OS but not spam or anything like that. Of course you can just re-protect the question if you have reason to think protection is still needed.
2:42 PM
my favourite command :) (the one to get octal file permissions)
(reminds me of good times when jokerdino Anwar and I were just starting on this self-answer query cleanup. We started out using the Ubuntu Regulators room, but for some reason we kept getting bothered by people wanting to do other things in there (although it had been unused for a long time) including running an (annoying imho) bot, so we moved to this room and renamed it (I didn't want to be a crusader) and now Regulators has been frozen for inactivity for a very long time)
1 hour later…
3:47 PM
I was writing a lovely answer to that question when muru hammered it sigh
I don't think it's even a dupe
it's a two part question and the dupe is only to the second part
really it's a 3 part question, or anyway I was writing a 3 part answer
4:06 PM
@Zanna Which question?
Q: How do I enter a directory on a different hard drive using cd in the terminal?

idknuttinI have ubuntu 16.04 installed on my ssd and I have a hdd where I keep all of my c++ files and programs. Ubuntu recognizes that I have the hdd. When I am in the terminal and want to access my c++ files on the hdd how do I get the directory? I tried using cd then the name of the drive but that didn...

Why might that be a duplicate of the question it's duped to now? I don't understand.
I have a hammer that can open that question
the last part asks how to do what the target explains I think
otherwise, it's not a dupe at all
So the idea is you don't want to get into a hammer-war, but let it be reopened by regular reopen votes? Normally I'd immediately cast a reopen vote there, but you haven't cast a vote to reopen and I'm wondering if there's something I'm missing.
I would vote to reopen, but I have this hammer, and I have a conflict of interest as I've written an answer!
I doubt a war would ensue. muru would probably leave it
4:11 PM
The part of the answer that addresses the question of how to cd to another drive is a tiny detail of the answer, and--more importantly--is far from a complete answer to how to figure out what path to use. I have not yet read your answer draft (or even looked at it... I'll get to it though...), but I have cast my reopen vote.
I'm going to reopen that question as I think it's really not a dupe
If you're worried about conflict you could always also comment to explain why you don't think it's a dupe.
4:27 PM
good idea...
I posted my answer :S
back to doing whatever I should be doing
The other thing that came to my mind, though it was no substitute for figuring out if the question is really a duplicate was: Do you compose your answers in the web-based interface? If you've been composing an answer when a question is closed, the system lets you post it within a certain (short) time after the question is closed. I have not observed this in action for a while but I believe the system still behaves this way.
@Zanna Thanks. I'll read it.
@EliahKagan I was writing my answer there yeah, but the orange bar appeared saying "this question has been closed. No further answers will be accepted
Huh. So the other thing is, rather than having the question be a duplicate, I think the second of the OPs questions should just be removed. On reflection I'm guessing that's why muru duped it. That could just be edited out with a comment explaining the un-duping and a link to the previous dupe target. It could all be in one short self-contained comment, which conveniently for me would have to be posted by you to fully make sense. :) :)
@EliahKagan oh, thanks! I didn't mean to ask for that.
ok, comment upcoming tries to channel Eliah Kagan for awesome commentness
I'm not sure if that's best though. (Though my opinion is that it is.) As far as I'm concerned, it's up to the OP, you, and muru -- or whichever of the three of you acts first if none of the others care -- or of course instead to the community at large if a more general preference forms, which I doubt will happen here.
4:34 PM
Someone else answered the question explaining how to set the directory as default, so I can't edit it out now as it would invalidate their answer. But I can take out the "second question" wording which screams close me as too broad
Hmm, maybe muru was right to have duped it. Though I think editing or commenting about its excessive breadth when it was first posted would've been the best solution.
In effect it seems like this new question is the broader one, so assuming we keep it open, we could dupe the older one to it. The thing is, the answers to the older question really don't answer the question of how you figure out what to type in to change directory to an external drive.
muru is generally right...
I feel bad giving OP of this question nothing but a dupe like that
clearly they are a bit lost in the filesystem and would have to search further to find what they need
I edited the original question (and upvoted it along with the answer)
I've commented on both questions, linking them to each other. If either does need to be closed, that should make it easier to figure out, and if not, the links in the comments may help people find what they need.
I saw :)
Do we still want more information from the OP? It seems to me that this is no longer necessary--if it ever was.
4:45 PM
I doubt it, since they accepted dessert's answer and making the answers more specific to OP's scenario won't help anyone else imho
I've flagged the big comment as not needed (actually, I used a custom flag, as I wasn't sure the reason would be clear). Besides being noise, I fear its presence will make people think they have to post their own question to figure out what their external drives are called, rather than just reading this question's fully general answers. The first comment, which is specific to the question and helps clarify what is going on, I have left alone.
I agree with that
It occurs to me that, if someone wants their terminal windows to open to the volume automatically, perhaps the particular automatic mounting option they really want is for udisks to mount the volume automatically when they log in. You might consider adding something about that option to your answer.
oh hmm yeah. I was worried they would open a terminal and something bad would happen because the device was not mounted
You could also have the terminal run the udisks command when it opens... but I don't think anybody would actually want that.
4:59 PM
Yeah I don't think so either... I don't know how to make udisks do something on login
maybe you should be adding an answer ^_^
@EliahKagan Oh, speaking of muru being right most of the time, it turns out that the apt command does, by default, delete .deb files after it installs them. I still don't know why I have cached .debs but I guess they're .deb files that were automatically downloaded as a separate step from when I manually told apt to upgrade to them. Anyway I'm convinced that I was mistaken to think apt did not automatically delete these files.
well, I have the .deb files there for the stuff I've installed on this system
so I'm confused
@Zanna I might do so, though I would have to look up how to make udisks automatically mount the drives on login. :)
because I did check when I read that question
Yeah, so did I. But when I tried installing a package I had never installed, the .deb wasn't there. It's a desktop system and I have it set up to automatically download important updates. I suspect that those packages are the ones not being removed even after I install them by running sudo apt upgrade.
@muru Thanks. I'm don't know why .debs I've installed or upgraded with apt sometimes to remain in /var/cache/apt/archives, as I don't seem have custom configuration to prevent their removal. But I noticed if I download a .deb (sudo apt install --download-only <package>) then install it (sudo apt install <package>), the file remains, so maybe the files left over are package upgrades that were automatically downloaded (which I have configured to occur) and manually upgraded. Thomas: I've added my duplicate vote but still think it could be useful if you added the above information. — Eliah Kagan yesterday
5:07 PM
I read your comment yesterday and pondered, since then, I have been confused, but confusion is productive
I'm not totally sure, though. I am willing to post a question about this, but it may be a while since I've been working on my answer to your question about that script that tries to run lepton on (just) arbitrarily named JPEG files, and I'm unlikely to make any other AU posts that require significant research, responding to requests for information, etc., until I'm done with that. So you should definitely post a question about this yourself, if you feel like doing so.
@EliahKagan I found an old post about doing this, but really it just suggests using startup applications. The issue with using fstab is that it will get upset if it can't find the drive. If both drives are in the machine, then not being able to find the drive would indicate bigger problems I think, but if it's an external drive and might not be connected, then we don't want to use fstab I think ponders
well now the directory is empty, so I'm just going to conclude that I'm losing my mind and carry on
6:02 PM
Q: What is our site policy on code/command edits?

Kaz WolfeDoes this site have any sort of canonical policy regarding command/code edits? Or, more exactly, when proposing an edit to code or a command (or just directly editing it as per 2k privileges), where do we draw the line for editing code? Basic typos? Major revisions?

6:18 PM
@Zanna (muru is talking about... this incident) which happened while I was asleep. I owe muru many drinks...
6:35 PM
I custom-flagged a comment because it was obsolete (and confusing because of being obsolete), the flag was declined, but the comment was deleted o.O
2 hours later…
8:06 PM
the answer here is clear (I made quite an extensive edit to it) but I don't understand how that would fix this!
8:52 PM
The last two days I don't seem to understand anything in the CV queue. Skip, skip, skip
Don't understand the posts? Or the close reasons? I skip lots of posts I don't understand or where I'm not sure, but if there's no discernible reason for a question to be closed, I would choose Leave Open (and, in some situations, post a comment).
Yes, I mean I don't understand the posts :)
I'm also voting to Leave Open a lot lately :/
9:27 PM
As discussed in main chat, this question is really an XY problem -- apparently there are other ways to install Waterfox besides from the .tar.bz2 file, including through a .deb file. As a secondary matter, I doubt general compilation instructions would be sufficient for compiling something like Firefox. They're not really sufficient for Firefox. Actually building a fully-featured modern web browser is somewhat nontrivial.
Q: How do I install Waterfox?

L-tuThe Waterfox web browser is a 64-bit-only open source project based on Firefox. I would like to see how is the performance compared to Firefox, apparently its better. Being new to Linux, it's a challenge when it comes to packages that are not .deb. On the official site, Waterfox is provided as ...

So I think we should reopen that question.
ugh I don't like that closure at all
9:41 PM
found it searching for anything that would shed light on this one
karel's answer assumes it's the same issue as this
maybe correct... not sure it's clear enough...
@Zanna in general I don't like questions saying "how do I install X" to be duped to that question even if they do have to be compiled from source, because how many times do you compile something using the generic procedure and it works perfectly and you don't have to do anything weird or unexpected or complicated or significantly non-generic? Like 1 time out of 10? 20?
10:20 PM
(spying on the transcript: I always custom flag comments if there will be any doubt that it's "no longer needed" without context. Mods have to review comment flags anyway (ie there's no pleb queue for them) so it may as well be a custom flag and it seems like it's easier to make it easier to review that way. But I don't know what mods see)
going to bed ugh so late
interesting approach... askubuntu.com/questions/951093/…
hehe wonder which part worked (or which part caused the error)
probably the symlink part
11:00 PM
The other thing about How do I install a .tar.gz (or .tar.bz2) file? is that its answers, while valuable, don't comprehensively explain how to compile software from source even for cases where nothing is especially complicated or difficult. I consider the CompilingEasyHowTo to be a better resource than that question, and even it would benefit from more on how to ascertain and install dependencies.
11:45 PM
Wow yeah... I think even one really long answer I wrote on how to compile Poppler had slightly more generically useful info than the top voted posts
Maybe you should post an answer to the generic compiling question based on the broadly applicable parts of that answer, then.

« first day (1890 days earlier)      last day (2480 days later) »