« first day (2377 days earlier)      last day (969 days later) » 

1:25 AM
@terdon I think you were both well-meaning; my guess is that they were quoting the underscore to mimic your quoting of it in your second echo. Seems like their main point was to say "quote", as a general rule, ignoring or looking past your post history.
 
1:45 AM
please consider voting to reopen:
1
Q: What process is listening on a port?

Marina Ala[root@SERVER ~]# netstat -tulpn | grep 44316 tcp 0 0 :::44316 :::* LISTEN - [root@SERVER ~]# lsof -i | grep 44316 [root@SERVER ~]# rpcinfo program version netid address service owner 100000 ...

 
 
6 hours later…
7:59 AM
@JeffSchaller I just find it funny given that I am actually quoting the damn things everywhere except the final $var"_" example.
 
;-)
 
Here’s another question that seems to have slipped off the re-open radar:
0
Q: How to tell if the CPU supports hyper threading

TheAmigoI know it should be a simple matter of grep -wl ht /proc/cpuinfo but that's not always accurate. I have an i5-7440HQ CPU which doesn't support hyper-threading (Intel, WikiPedia, and my BIOS agree on this). Yet /proc/cpuinfo and dmidecode both show that hyperthreading is supported (but disable...

 
 
4 hours later…
12:32 PM
@GAD3R @dr01 please be careful when voting to migrate something. This questio is comepletely off topic on Super User. First because it isn't a programming problem (it might become one if the OP edits to include some code, or anything that could be used by a programmer but it isn't now) and, more importantly, the first rule of migration is we don't migrate crap.
That's a crappy question for us, so it's hardly nice of us to dump it on some other site.
 
12:55 PM
ok, understood :) Thanks for pointing this out.
 
1:51 PM
@dr01 No worries :)
@Kusalananda great minds think alike :)
What is the output of a simple ls in that directory? Is the file shown as a regular file? I am asking to make sure that the No such file or directory is a globbing error and not indicative of a damaged file system. — terdon ♦ 1 min ago
I wonder if the filesystem needs to be run through fsck? I may be corrupted. How did the file acquire that name? — Kusalananda 1 min ago
 
:-)
 
@terdon you left off the second half of that quote ;-)
 
@StephenKitt ?
 
“great minds think alike, and fools seldom differ” :-P
3
 
That's not the first "ghost file" question we have on this site.
Wierd
 
1:59 PM
@StephenKitt Grrrr :P
 
@terdon I knew you’d like it!
 
Could it be that it's a network share that's gone away?
 
That's an interesting question though. The file name is not the problem.
@Kusalananda There would be a .nfs file for that, wouldn't there? I wouldn't expect that sort of name.
terdon@tpad foo $ ls -l
total 0
-rw-r--r-- 1 terdon terdon 0 Apr 12 17:00 '?j?Z?R?C1_000c.jpg'
terdon@tpad foo $ cp \?j\?Z\?R\?C1_000c.jpg ff
terdon@tpad foo $ ls
 ff  '?j?Z?R?C1_000c.jpg'
Nothing special about the name.
 
No, the name is not the problem.
Nor the font or anything else related to that.
The shell is able to expand the glob, but then mv can't get to the file.
 
@Kusalananda Could the filesystem itself have problems using non-ASCII characters?
I think so, right?
 
2:05 PM
This means that readdir lists it but the path cannot be open-ed or stat-ed
 
Never seen that.
 
@lgeorget Oh? And can we draw any conclusions from that?
 
I was thinking that the directory itself (its entries) had been cached somehow, before a fileserver went away.
 
Hmm my conclusion is the same as Kusalananda
Broken filesystem
 
Hey, well done @Kusalananda!
@Kusalananda man you rock! that was it. Since I have btrfs on both ends, I kinda forgot that there is samba in between. I tried ssh-ing into the server and doing it there and it worked fine. So samba apparently had problem with the name while btrfs didn't. Could you write it as an answer so I can accept it (if you want the reputation that is) :) — Paladin 1 min ago
Bloody hell. It's always smb.
 
2:06 PM
There you go. Guesswork at its finest.
 
@Kusalananda Congrats :)
@terdon Hmm yeah, UTF-8 -> Latin-1 -> UTF-8 wierd conversions
and... samba stuff >.<
 
Ah, so I was only partly right.
I don't feel confident writing an answer on this one. You guys take it.
 
Hum, that's just a guess too, I'm not sure what happened at all
 
@Kusalananda Why? Just explain what made you think of a networking issue and then add what the OP said.
 
Alright.
I still don't understand why the globbing pattern expanded to something that wasn't usable by the Samba share though.
 
2:18 PM
Maybe the parent directory is not inside Samba
Hmm wait
the filesystem is not actually detached, that's just Samba not understanding the filename asked for
so it makes sense
Globbing to expand a pattern does not require opening each file in the directory, only openng the directory and doing the getdents syscall on it
 
Sounds like you might be building a pretty decent answer.
 
That's why the output of ls -il *000c.jpg is a bit wierd
ls: '?j?Z?R?C1_000c.jpg': No such file or directory is the error thrown by syscall stat
but the file is listed anyway
Somthing which is not clear though is how ls is able to list the owner, size and access time of the file...
 
Well, it's only the access to the file through its name that is the problem.
What I think happened with the globbing is that the shell got whatever Samba was giving it, i.e. the wrong name.
 
@Kusalananda Precisely, but stat requires the filename
Ah got it
the stat syscall works
the problem is that mv receives the output samba gives
whereas ls uses the name returned by getdents
 
2:36 PM
How are you testing?
 
strace ls and strace ls -l for now
that's mainly guesswork
 
@lgeorget Yeah, but on what?
@lgeorget Ah, you're just looking on their output on a regular file to see the syscalls. Gotcha
 
@terdon on a "normal" filesystem for now. I must set up a samba shared folder to test
Now I don't understand why find . -inum 213915 -print0 | xargs -0 -I '{}' mv '{}' 000c.jpg did not work
 
@lgeorget No, mv receives what the shell get from Samba for the expansion of the glob.
... which is still the wrong name.
@lgeorget Because mv still accesses the file through its name.
 
@Kusalananda yes, that's what I meant, although that was weirdly phrased
 
2:40 PM
Ah, sorry
 
no, my bad, I'm not being clear here, because not everything is clear to me
I'm thinking aloud guys, bear with me :p
 
The file has a valid directory entry, inode number and everything. It's just its name that you can't actually use.
 
But the name is used by ls for the stat system call
you need the filename to do stat and a file descriptor for fstat
but the file descriptor is only obtained through open which requires the filename
so I wonder what ls did in this case to be able to display the owner and other attributes
 
2:56 PM
@lgeorget I don't have the GNU coreutil's sources at hand at the moment, so I can't check to see what ls is actually doing there... Yes, it's a bit of a mystery.
 
Here you go
I was looking at them
the interesting boolean is format_needs_stat line 3081
Well, I'll do my tests and I'll come back if I found something instead of spamming here with random thoughts
 
3:14 PM
I'm noticing that GNU mv says cannot stat 'filename': No such file or directory if the source file does not exist. It does not say cannot move...
Which indicates that the lstat() may succeed, but the rename() may fail... or something.
Is Samba passing through lstat() calls to the host filesystem maybe?
 
@Kusalananda But what would cause the error in ls -il, then?
@Kusalananda The "cannot move" message seems to originate from copy.c git.savannah.gnu.org/gitweb/?p=coreutils.git;a=blob;f=src/…
there's an interesting comment above that line
so you're right, stat succeeds but rename fails
(assuming the OP is using GNU, by the way)
 
With a BTRFS filesystem, it's likely Linux, and hence GNU coreutils.
I'll leave this here. I've added a link to this discussion in my answer and I'll see later if you or someone else can resolve the details.
 
4:00 PM
Would this question be on-topic and good enough for the Unix/Linux stack? It unclear for the EE folks, but maybe it's clear for the Linux folks.
-2
Q: CAN data using Socket CAN?

lalliIn my project, I need to read CAN data and place that data onto another tool which is developed under Linux. As of my research I came across that Linux kernel supports socket CAN stack. Is it possible to read/write CAN data using Socket CAN stack and place that data on to the tool that is devel...

 
@NickAlexeev As it stands, it would probably be closed quickly with reason "unclear what you ask"
and too broad also
It's not clear if it's a programming question, a question about Linux network stack, ...
 
4:24 PM
Actually, this might turn out to be an interesting question:
-1
Q: Why terminal command duplicate on my ssh terminal?

DjinnHere is the problem: I run some commands on a terminal in my localhost computer(bash, Archlinux). In another terminal (log on a remotely server), command i write execute also on my localhost terminal. My server is a Gentoo distrib, running on Virtualbox (bridged network, different ip and mac...

 
4:44 PM
@terdon It's a bit difficult to follow...
 
@Kusalananda Very. But that's the language barrier I think. The OP is obviously not a native English speaker and is having trouble writing clearly. On the other hand, the various details mentioned suggest they're not just some clueless newbie who doesn't know which terminal they're writing in.
I mean, they're running Gentoo in a VM running on Arch. That implies a certain level of competence right there. Not to mention the fact that they know about bridge mode, systemctl, tmux, echotty etc. Finally, and most importantly, they use emacs so they can't be all bad!
So I think that if we help the OP express it better, there is likely a good question under the language issues.
 
@terdon There probably is a good question there, but I have no idea what it is....
 
Yeah, me neither. As far as I can tell, the OP seems to be writing something in emacs on the host and it also appears in the terminal of the guest. Some sort of weird focus sharing bug from their DE?
Is that even possible?
No idea.
 
Could also be a display corruption bug. Maybe OP is actually seeing it in both places.
@terdon I don't think it's possible to have two windows both focused (when you only have one pointer—with two, you can definitely have two windows focused). But I'm not enough of an X11 expert to be sure
 
Same here.
Which is why I suspect there's something interesting going on. I have no idea how the VM could possibly receive input from the host unless it were sucha focus issue though.
 
4:51 PM
@derobert yeah that’s my impression too, you need MPX for multiple pointers and multi-focus
Multi-pointer X (MPX) is a part of X input extension and previously a modification to the existing X.Org implementation of the X Window System. MPX provides multiple independent pointers at the windowing system level. These pointers are all connected to one computer. Unlike many other multi-pointer applications and toolkits, MPX allows many existing X11 applications to run unmodified, whilst still providing additional input features. For instance, multiple users can simultaneously operate different applications at the same time. Some applications do not work as expected due to limitations in the...
 
@StephenKitt multi-pointer support is normally configured in, I've used it before...
Some window managers even handle it. Some.
 
@derobert yup
but you generally know you’re using it
 
Yeah. And even with it, I'm pretty sure keyboard input only went to one window
 
I was discussing it a few months ago with the input and spice developers
 
Dammit, I want to edit to clarify but I can't understand enough to do so. Ideally, I would like to get the OP in chat so we can understand what they need.
 
4:55 PM
in the context of a copy-paste/focus vulnerability
but I can't remember the details off-hand
 
Or maybe just some screenshots showing the problem...
There are X11 terminal emulators that support things like multiple tabs, or use one process for multiple windows... I could see one of them having a bug where input is duplicated. Or output.
OTOH, you'd think if gnome-terminal or kterm were broken that badly, we'd know about it.
 
or a forgotten screen share
 
@Djinn you can join us in chat if you would like to discuss how to improve your question.
 
 
1 hour later…
6:02 PM
@terdon @terdon Thank you , i will pay more attention
 

« first day (2377 days earlier)      last day (969 days later) »