« first day (2356 days earlier)      last day (920 days later) » 
00:00 - 20:0020:00 - 00:00

12:04 AM
i have another issue: i am out of smokes
 
@Serg Exactly. And if any of it interests you, you can certainly do research on your own.
:(
:)
Time for dinner here. See you guys later. Keep swinging for the fences, eventually you'll hit one out of the park! :-D
 
lol, nice expression
 
@Serg I've finished the bash equivalent of the python purge kernels I had suggested you write last week: askubuntu.com/questions/892076/…
 
12:26 AM
LOL, i was just tried explaining to a guy for 5 minutes the joy i derive from.programming
he is a chemistry major
kind of felt that it was borning a bit to him
 
12:42 AM
0
Q: Have Linux recognize custom extensions

M.GThis question is for a school project so i'm not looking to just be given a block of code or anything, just some direction on how to go about my work. I want to be able to have my own custom file extension recognized within the OS(for example textfile.hello) and be able to do things such as maki...

 
Not everyone finds joy in programming.... maybe 1%. Many accountants though will find joy in Excel macros but not consider that programming when really it's a form of high-level programming.
In that case you could say 10% enjoy programming?
 
12:58 AM
well, it is an arbitrary number.
 
1:12 AM
haha yeah totally arbitrary and deduced by beer and not research statistics.
 
@cl-netbox I meant the answers were all like "don't do it"
 
Why did someone downvote my question which seems non-threatening and not garbage (in my mind)? askubuntu.com/questions/892076/…
 
Why did alligator cross the golf course ? His hole was in one
(if you didn't get it, hole-in-one is a golfing term when you send ball into hole with one strike)
Why did alligator cross the golf course ? He was trying to catch birdie
 
haha I think most people know what "hole in one" means :p
 
1:41 AM
There's plenty of foreign people in chats
lol , foreign
Let's just say . . . international
I am used to the Chinese way of saying things
If you're non-chinese you're a foreigner all the same
 
@WinEunuuchs2Unix : I wish the person that did a selective kernel purge script, the one I pointed you to on launchpad, would let me try it. As far as I can determine, without actually trying it, it should be pretty good. He is hung up about getting money for it, and we have argued the point to death, over a period of many many months.
 
@DougSmythies I think I remember that case . . .
 
@DougSmythies People looking money should avoid Linux altogether :)
 
@DougSmythies What is actually going on ? What actually do you need ? Just to have a script which will remove a specific kernel based on version ?
 
We all need money of course but I would make it on Windows, Microsoft business apps, Google, IBM, etc. and use Linux as a hobby / learning experience.
 
1:44 AM
We debated on the doc team e-mail list, and privately. He seemed to always miss my, and many other peoples, point.
 
@DougSmythies you have a post about it somewhere, right ?
I mean, askubuntu question
 
For myself, I want to be able to selectively purge kernels, and almost always newer kernels than the default, because I am always working with the latest release candidate series. Also, when I do a kernel bi-section I end up with about 15 kernels just for that.
@ Serge, I do not recall if there is a post on askubuntu about it. The person enetered a couple of launchpad bugs. wait a sec for links...
 
OK . . . interesting . . .
@DougSmythies @WinEunuuchs2Unix just a small question . . . why necessity for a script , instead of a more manual way with dpkg --remove ?
 
@WinEunuuchs2Unix : now I just wait until I don't need an entire series anymore and then do this: sudo apt remove linux-headers-4.9.0-bi?? and sudo apt purge linux-image-4.9.0-bi?? for example.
@serg, because I have so many. Currently ~~65 on my main test server.
 
@Serg apt-get purge clears out all configuration files whereas remove leaves them behind. Granted they are small but still...
 
1:53 AM
How interesting . . .
 
@serg : Management just annoying and time consuming is all.
 
apt-get purge also calls dkms to remove nvidia drivers, etc.
 
Oh. I don't care on a server.
 
@DougSmythies I've begun rewriting the script for low-latency and rc-stock kernels but I still have that display-auto-brightness project on the go as I mentioned earlier. It will take some time....
 
How did a user with 116 rep reject my edit?
http://askubuntu.com/review/suggested-edits/686426
 
1:55 AM
@serg. I want to purge so as to prevent leaving "rc"s behind for dpkg -l | grep linux-im
 
dkms controls more than just nvidia, a server could have drivers for broadcom or realtek wifi / ethernet.
 
@WinEunuuchs2Unix : All I can say is that I have never had a problem.
 
@DougSmythies As far as I know, kernels don't have "rc" files
$ cat /var/lib/dpkg/info/linux-signed-image-4.4.0-66-generic.list
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/linux-signed-image-4.4.0-66-generic
/usr/share/doc/linux-signed-image-4.4.0-66-generic/changelog.Debian.gz
/usr/share/doc/linux-signed-image-4.4.0-66-generic/copyright
/usr/lib
/usr/lib/linux
/usr/lib/linux/vmlinuz-4.4.0-66-generic.efi.signature
 
Oh, they are the question owner.
 
That's all there is
 
1:57 AM
@DougSmythies Fair enough... however apt-get purge linux-image..." and apt-get purge linux-headers...` are the accepted solutions in all the Q&A's I've read.
 
@luk3yx yep, exactly that
 
Where did half the question go on my suggested edit?
 
@WinEunuuchs2Unix : Kernel names can be anything. I only use "stock" before any customization.
 
@Serg Your list is missing `ls /boot/*4.4.0-66* which is about 50 MB of stuff.
 
@WinEunuuchs2Unix : O.K. yes, we agree.
@serg, wait, I'll show any example, if I can find one.
 
2:00 AM
@luk3yx also, you removed OP's command-line output and pasted it into pastebin. That's not exactly considered a good idea for edits. It's ok onyour own posts,but not on other people's
 
@serg: example:
ii linux-image-4.11.0-041100rc1-generic 4.11.0-041100rc1.201703051731 amd64 Linux kernel image for version 4.11.0 on 64 bit x86 SMP
ii linux-image-4.11.0-rc1-stock 4.11.0-rc1-stock-217 amd64 Linux kernel, version 4.11.0-rc1-stock
rc linux-image-4.4.0-62-generic 4.4.0-62.83 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
rc linux-image-4.4.0-63-generic 4.4.0-63.84 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
 
@DougSmythies Anyway I've just modified the code on my end to remove -generic however it breaks the file size calculations and error messages pop up. It would still allow you to remove your stock and low-latency kernels if you do that though.
 
@Serg Okay. Why isn't it?
 
@Serg : it is the great many "rc"s when I have a legacy of 100s of removed kernels that I hate. So I purge them.
 
@DougSmythies I don't think those are configuration files. . . .I'll make some research on that. You just made me interested in this question
@WinEunuuchs2Unix yes, because it's kernel package itself. Other stuff, is modules / drives which is in different package
 
2:05 AM
@WinEunuuchs2Unix : I know you mentioned you have other pressing stuff to do. I just got excited earlier today when I saw your question. I am fine using my current method.
 
@DougSmythies The original concept was 99% of the people were using -generic kernels and hiding the phrase on each line made it easier to read and less redundant. I'll whip up a version that includes all non-generic kernels for you. The non-gui version will take more research time for me though.
 
@luk3yx I would say it can be considered as destructive edit - removing information user provided and putting it into pastebin. I was searching meta just now for a post on this topic, but I cannot find it. Actually, this would be a good question. Go ahead and ask
*ask on meta, I mean
 
@Serg Okay.
Can someone change the image to HTTPS here? I can't for some reason.
https://askubuntu.com/a/247838/495653
 
@luk3yx edited, uploaded via imgur's https
 
@Serg Thanks.
 
2:13 AM
@luk3yx do you want me to show you how to do that ?
 
@Serg I have been. The edit button was greyed out on that one.
 
@DougSmythies ok the rewrite is completed... now I have to create new screen shots and update code in answers already posted.
 
hold on, what did i want to look up just now . . .
ah, some sort of programming language ?
Oh, got it !
I wanted to look up BSD
Jeeeeezus. My memory sucks today
MHAAAAHWAAAWAAHAHAHA
Quite an ambitious project
And you are asking for a volunteer for a job like that ?
 
@Serg I just found out how to do that. I'm still relatively new, I guess...
 
Yeah, hover over the item and use permalink
 
2:22 AM
My meta question is posted: meta.askubuntu.com/q/16815/495653
Have I reached the maximum amount of pending edits?
 
0
Q: Why is moving someone else's code output in a pastebin considered destructive?

luk3yxI have attempted to edit this post, however the edit was rejected. After asking on the Ask Ubuntu general chat room, one of the kind users said that it is considered a destructive edit to move command line edits to a pastebin, unless it is your own post. Why is this?

 
@DougSmythies OK Q&A has been updated to support low-latency and rc-stock kernels plus everything else under the sun :)
If the solution works consider upvoting me from zero up closer to ~500 mark top contender on this old Q&A :D askubuntu.com/questions/2793/…
 
2:40 AM
@WinEunuuchs2Unix you mentioned in your question that the duplicate doesn't provide easy solution. Is synaptic not easy ?
Oh, I see. You're asking for a method without having external tools installed
Guys, what do you call websites, where like construction companies or businesses make project proposals, and then the manufacturing companies make bids/offers ?
 
@Serg I should have said "Bash with Zenity Radio List" answers only to totally prevent duplicate candidates :p
 
3:17 AM
@Serg I bet $100 whatever they come up with is backdoor'd.
3
 
@WinEunuuchs2Unix : O.K. I'll try it.
 
Let me know if you need any other changes.
 
@WinEunuuchs2Unix : Seems very good. There is some problem purging linux-image-4.11.0-rc1-stock thou. I think it tried, but it is till there. So I tired again, but got some error. Other 7 or so kernels deleted just fine. Note: This is a VM, and I made a clone to work on, so that I can easily go back to the start point (~15 kernels) and try again. (Currently, not sure how to copy and paste from my VM to show you the error. Might have to continue tomorrow.)
 
3:33 AM
Spanish: The h is silent English: Many letters can be silent French: All letters are meaningless, every living thing is born without reason
LOL.
 
haha
 
@WinEunuuchs2Unix : linux-headers-4.11.0-rc1-stock are gone, but other stuff for linux-image-4.11.0-rc1-stock is still there, and on /boot.
doug@desk-dev:~$ ls -l /boot | grep 4.11
-rw-r--r-- 1 root root 206087 Mar 5 15:39 config-4.11.0-rc1-stock
-rw-r--r-- 1 root root 37079253 Mar 11 15:19 initrd.img-4.11.0-rc1-stock
-rw-r--r-- 1 root root 3729407 Mar 5 15:39 System.map-4.11.0-rc1-stock
-rw-r--r-- 1 root root 7390816 Mar 5 15:39 vmlinuz-4.11.0-rc1-stock
Out of time for the moment.
 
@NathanOsman chinese: no letters at all, only characters and pronounciation depends on dialect
@NathanOsman or has a vulnerability that will at somepoint show up in CVEs
 
@DougSmythies I'll have to install Kernel 4.11 rc1 and test it myself. I've yet to install Kernel 4.10.1 so I'll do both at the same time and report back. It could also be apt-get purge doesn't see the links to images in /boot when you compile your kernel manually. I could try that later but I need to read up on how to make a kernel first.
 
not sure if jealousy or stupidity
 
4:02 AM
@ElderGeek since you asked about checking Community's activity on meta: askubuntu.com/users/-1/community?tab=activity
 
tumblr can be sooooooooo sloooow sometimes
 
4:25 AM
59
Q: Does an ISO27001 audit require users to reveal their passwords?

v_suktMy company's system administrator is asking for our passwords for an ISO audit and my VP IT operations support says it's mandatory for ISMS (ISO27001). Can someone confirm if this is true?

 
4:57 AM
@DougSmythies I completed installation and purging of Kernels 4.10.1 and 4.11.0 rc1 and encountered similar problems to your rc-stock. I've updated the answer with what to do: askubuntu.com/questions/892076/…
 
5:33 AM
@WinEunuuchs2Unix : I never use apt-get install to install kernels. I only use "sudo dpkg -i linux-header_bla_bla.deb linux_image_bla_bla.deb" and never have an issue. Sometimes I do see something about "The link /vmlinuz is a damaged link", but it has never actually been a real issue. I would never ever do "sudo rm /boot/*4.10*".
I re-installed the 4.11rc1 headers, then booted the kernel, just to prove it wasn't messed up or partially removed. Then I booted again into 4.4.0-66-generic and removed 4.11 manually: sudo dpkg -P linux-headers-4.11.0-rc1-stock linux-image-4.11.0-rc1-stock.
No errors or wanrings.
warnings
I re-installed the kernels:
sudo dpkg -i linux-headers-4.11.0-rc1-stock_4.11.0-rc1-stock-217_amd64.deb linux-image-4.11.0-rc1-stock_4.11.0-rc1-stock-217_amd64.deb
and then manually purged them this way:
sudo apt purge linux-headers-4.11.0-rc1-stock linux-image-4.11.0-rc1-stock
also without and errors or warnings.
any not and
 
@DougSmythies Yes I use "sudo dpkg -i *.deb" to install the two header files and image file too. "apt-get install" was a super bad typo on my part. The rm-kernels script will also use "sudo apt-get purge linux-image-4.11.0-rc1-stock linux-headers-4.11.0-rc1-stock" so there should not be any errors as well.
 
@WinEunuuchs2Unix : I'll try the script method again.
 
5:51 AM
@DougSmythies I've taken out the "experimental kernel" section of the answer until we can nail this one down. I can change the order in the script to remove headers before images and to use "apt" instead of "apt-get" if necessary.
 
@WinEunuuchs2Unix : Same result as first test. linux-image-4.11.0-rc1-stock is not even appearing in the list as something it (meaning apt, when it asks for yes or no) wants to remove, even though I selected it (meaning from the radio button list). The header file does appear, and is removed.
 
@DougSmythies I had the same problem with "linux-image-4.10.1-041001-lowlatency" not appearing in apt-get purge even though the headers showed up. I should be able to fix your problem by fixing my own.
 
@WinEunuuchs2Unix : O.K. I am looking at the script, but not seeing what is wrong.
 
@DougSmythies No worries because I can reproduce the problem on this end I can figure it out. Probably not until tomorrow though it's already 11pm here and my brain starts to fade.
 
6:06 AM
@WinEunuuchs2Unix 10p.m. here, and I am done also. Anyway thanks for your script.
 
I'll ping you tomorrow after I revise it.
 
 
1 hour later…
7:11 AM
@DougSmythies I found the bug and updated the answers. The second last line of the script had to be replaced with this: ` echo "dummy- $list" | xargs bash -c '</dev/tty apt-get purge "$@"'` For some reason xargs was dropping the first parameter passed to apt-get so I put in a dummy first parameter.
 
@WinEunuuchs2Unix : O.K. I'll try it in the morning.
 
@DougSmythies Sounds good. Thanks for your help in testing and suggestions for improvements.
 
8:09 AM
0
Q: How to know the number of stations connected to each SSID in bash?

JarvisIs there any Linux command for wireless clients to know the number of stations connected to each WiFi SSID ? How can I do this in bash ?

 
8:39 AM
@muru probably you know this already, but last night SE re-ran the conversion to catch the hostmar links - 2000 posts were updated. I am just mentioning it because I'm still finding them in the etherpad (seems to be just the ones already marked i so far, so maybe it's deliberate)
 
8:51 AM
@Zanna in this first 580 or so links?
 
@muru the block of them from 599 and right at the end (I checked and unlink-ified all the ones at the end)
where I'm working at the top all clean so far
 
@Zanna oh, those are from the original query. I didn't delete from the pad, just shunted them down
Maybe they should be deleted
 
anyway whatever you want to do, the SEDE data is fresh now
:)
 
@Zanna so fresh that the query is returning nothing for me no. :/
 
o.O
 
9:06 AM
@Zanna data.stackexchange.com/askubuntu/query/edit/638497 and the older revisions consitently return 0 rows for me
 
yeah... same
wth
well that's not right! there is plenty of stuff not fixed
 
And I removed the older query output from the pad, so with the current list, hopefully you shouldn't see icon-related problems
There are a few posts which have been edited though
 
yeah I was working from the query at first so some of that will be my fault
anyway using the pad is working great now, thank you for setting it up and cleaning the data
wth happened to the data o.O
the other two queries I'm using aren't doing anything weird
 
Posted on meta:
0
Q: Did something change in SEDE's data?

muruOver on Ask Ubuntu, we have been using this query to find out old posts with non-imgur images. It was working alright before this weekend, but now it's returning 0 rows. What's going wrong?

Let's see if anything turns up. In the meantime, I'm out of {delete,down} votes, so I'll probably retire for the day
 
I better check the 10k tools hahahaha
RIP zanna's meagre stash of delete votes
 
9:31 AM
@Zanna 0_0
I don't run out of em.
I mean in theory, on SU, even if I can't
 
Now I get 21, so I don't always run out, but I usually do
 
I usually review >10 low quality posts for one thing
 
0
Q: Avoid GRUB Rescue on Boot

Tijan ManandharAfter reinstalling Ubuntu again on the machine, the GRUB Rescue screen appeared as it says hd1 not a known file system. I did the following steps: set prefix=(hd0,gpt7)/boot/grub set root=(hd0,gpt7) insmod normal normal This led me to boot Ubuntu. And I did my GRUB update too. But the main pr...

 
 
2 hours later…
11:17 AM
0
Q: Simple "kiosk" - StartX with one application says no protocol specified

Patrickmy aim is to have a Ubuntu laptop which starts one application and the users cant use the mouse or keyboard. First thing to do was find out the command to start the program. This is this command. export DISPLAY=:0 && pidof cvlc 2>/dev/null >/dev/null || cvlc --fullscreen --no-video-title-show r...

 
 
1 hour later…
12:34 PM
0
Q: How to make sound works on Mozilla Firefox 52?

Tiago PimentaI use Lubuntu, which I believe do not use pulse-audio, or uses a container for that, I do not know, but it seems to use alsa well. Since I upgrade to Firefox 52, which do not accept plugins anymore, the sound stoped working, and it show a tip to fix that, but when I click on it, the site does no...

 
12:48 PM
0
Q: Unable to increase max number of open files on a redis service process, any idea why?

Itai GanotI have an Ubuntu 16.04 server which runs a redis server. For some reason I'm unable to enforce number of open files limit on the process and when it starts, it starts with 4081 instead of 100001 as I'm trying to configure. systemd is the service manager which manages the services on the machine...

 
 
1 hour later…
2:04 PM
@Seth thank you for the Community status link (user -1)
 
user136984
2:30 PM
I don't know why, but my internet is really slow at the moment...
 
user136984
@jokerdino: Gone so quick? You appeared in the list and the moment you landed you dropped off it! :D
 
user136984
It was quite a funny sight actually.
 
@ParanoidPanda I'm sure you'll figure it out.. ;-)
 
3:04 PM
@ParanoidPanda slow internet could be sign of CIA Vault 7 software stealing all your secrets in the background... oops shouldn't say that might make you paranoid :p
 
Geez almost 20% of my rep points come from bounties... I should change my name to Bounty Hunter :D
Starred @ByteCommander
@Seth Can I nominate a new set of badges for bounties? ie bronze @ 100, silver @ 500 and gold @ 2000 or something like that? My proposed name would be "Bounty Hunter"
 
Good afternoon ! :)
 
@WinEunuuchs2Unix Why not rep vampire, as you figuratively suck the points out of others through their bounties... ;-)
 
3:21 PM
@ByteCommander rep vampire works if I coerced them to post bounties only in areas of my niche knowledge base :)
They would have to be questions like "where do I find the cheapest beer and smokes?" or "which website has swimsuit models?"....haha
 
3:35 PM
@WinEunuuchs2Unix : There is still an issue with the selective kernel removal script. For some types of kernels, there are two header packages an "all" one and a architecture (i.e. 32 bit or 64 bit, and low-latency or generic) one. It is only removing (or purging) one of them. For example it removes the generic but not the all. For my 4.11-rc1 example, there is only one header package and it purges that kernel entirely.
 
@DougSmythies Hmmm... don't know the solution off the top of my head but I'll dig into today.
 
@WinEunuuchs2Unix : Is it O.K. with you if I go onto the bug report I referenced and mention that someone is working on a selective kernel removal script? That guy claims to have addressed all of these issues, including having something that works on headless servers, via SSH. My objective would be to get him to give up on his quest for money, and let me test his version.
 
@DougSmythies Feel free to link to any of my Q&A anywhere in Stack Exchange. The more people that try out the scripts the better they become with more input.
@DougSmythies How did you discover the header all files were left behind but the generic files were deleted? For example I used apt list command and grep to see what is still installed. I had used the script to remove (purge) 4.4.0-59 and 4.4.0-62. However I had left 4.4.0-63 untouched. When I run apt list I get:
rick@dell:~$ apt list --installed | grep 4.4.0-59

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

───────────────────────────────────────────────────────────────────────────────
rick@dell:~$ apt list --installed | grep 4.4.0-62

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

───────────────────────────────────────────────────────────────────────────────
rick@dell:~$ apt list --installed | grep 4.4.0-63

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
So for 4.4.0-63 we see two headers and two images installed. For the others that were deleted nothing shows up. Do I have to refine my search somehow?
 
3:57 PM
@WinEunuuchs2Unix : Note before: I have been cleaning up my clone VM, so not much garbage is left. So, I was down to just a few kernels left. In the below listings notice the header files for -53 and -64 are still there, but shouldn't be.
doug@desk-dev:~$ dpkg -l | grep linux-im
ii linux-image-4.4.0-51-generic 4.4.0-51.72 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-57-generic 4.4.0-57.78 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-66-generic 4.4.0-66.87 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
 
I have the residual "all" files too from when the script was broken last night:
$  dpkg -l | grep linux-head
ii  linux-headers-4.10.1-041001                          4.10.1-041001.201702260735                    all          Header files related to Linux kernel version 4.10.1
ii  linux-headers-4.11.0-041100rc1                       4.11.0-041100rc1.201703051731                 all          Header files related to Linux kernel version 4.11.0
ii  linux-headers-4.4.0-63                               4.4.0-63.84                                   all          Header files related to Linux kernel version 4.4.0
I'll reinstall 4.10.1 and 4.11.0 rc 1 today and retest with the new script version.
 
4:12 PM
@WinEunuuchs2Unix : I'll double check, by doing another kernel.
 
@DougSmythies Now I see the problem. In version 1 it would do "apt-get purge linux-headers-www.x.y-z*" In version 2 when support was added for "-generic" it became "apt-get purge linux-headers-www.x.y-z-generic" so the "all" was missed. If I revert back to first purge format then "all", "generic", "lowlatency","rc1-stock", "amd64" and "386" headers will ALL be deleted for "linux-headers-w.x.y-zzz".
 
4:27 PM
@DougSmythies Someone could have linux-headers-4.4.0-63, linux-headers-4.4.0-63-generic and linux-headers-4.4.0-63-lowlatency. When purging linux-headers-4.4.0-63-generic we don't automatically want to remove the "all" file linux-headers-4.4.0-63 because that would break linux-headers-4.4.0-63-lowlatency. Am I right in this theory?
^^^ Any of you apt-get purge linux-headers... experts feel free to jump in :)
 
@WinEunuuchs2Unix : Very good point. Yes, I think you are right. I'll add that combination to my test desktop VM's.
 
@DougSmythies In any case the way the modified script now works it will never purge the header all file.
 
@WinEunuuchs2Unix you can propose new badges on meta
 
@Seth Thanks for that. What do you think of the idea of a bounty badge though? i like it because almost 20% of my rep points come from bounties but will others not be so keen on the idea?
I don't want to promote a non-win scenario.
 
I think I like the idea.
But I'm sure it has been proposed before.
 
4:39 PM
It depends on the arguments :)
 
Oh well in that case my procrastination engine switches into high-gear and I go back to coding :)
 
163
Q: Bounty Hunter badges

Joel CoehoornI suggest two new badges: Greedo - first bounty earned (bronze) Boba Fett - earned 2000 rep through bounty (silver) Imported from Uservoice ticket, "Bounty hunter badges", originally posted by Jon Skeet.

 
^^^ Yeah that Q&A has tons of comments already. No need for me to add my 2 cents.
Thanks @Seth you're a treasure trove of knowledge :)
 
5:08 PM
:)
 
Meanwhile, I'm a treasure trove of derp :p
 
I think that's George's job...
 
@GeorgetheDev wassup?
 
Well, he's not a frequent guest in the chat, so I have to substitute for him
Although don't ask me to eat fish . . . Not my favorite
 
George does lots of work on the mainboard though... reminds me of when I was younger... like in October 2016...haha
 
5:18 PM
Fish is good for you.
 
Seven days without fish makes one weak....
 
@JacobVlijm i know but i have fear of bones in fish sinclce childhood. Had a couple stuck in my throat
 
^^^ I stole that slogan from the fish&chips restaurant on the corner... I'm not that bright :p
 
@WinEunuuchs2Unix is it fishy pun time ?
 
5:20 PM
So you have a bone to pick with the fish eh?
 
@Serg he's here now
 
@Serg aaargh. That is not good for you.
 
What pun! Who me? :)
 
@WinEunuuchs2Unix I let.old grudges against fish swim away
 
How do you strip the last word from a variable when the word deliminator is "-" and not space?
 
5:22 PM
@WinEunuuchs2Unix use awk
 
use awk.... (aren't we missing something after the word awk? :p)
 
Just use awk :)
 
awk -F "-" '{print $NF}'
 
Of course python is better.
 
hey, im writing on phone , with type.speed of.7 turtles per second
@JacobVlijm awk is shorter tho
 
5:25 PM
Ok, ok...
 
@Serg Thanks but that prints the last word, the goal was to remove the last word :(
 
0
Q: pm-utils can't shutdown on ac / battery change [Shutdown on battery loss]

PatrickThis script is not executed. #!/bin/sh . "${PM_FUNCTIONS}" command_exists shutdown || exit $NA case $1 in true) shutdown -h now "battery mode"";; false) shutdown -c "ac mode";; *) exit $NA;; esac exit 0 Saved in /etc/pm/power.d/battery.sh. And it has execution permissions chmo...

 
Ubuntu does not like AMD+NVIDIA...
 
@Serg nvm thanks for your help but I found this: echo "one two three" | awk '{$NF="";sub(/[ \t]+$/,"")}1'
Hmm needs some work because the answer should be: "one-two" but the answer is "one two":
$ echo "one-two-three" | awk -F "-" '{$NF="";sub(/[ \t]+$/,"")}1'
one two
awk and sed really warp my mind...
 
5:41 PM
@WinEunuuchs2Unix um, that's over complicating things, I think
 
@Serg I'm working on a solution based on your original answer... hang on
 
$ echo "one-two-three" | awk -F '-' 'BEGIN{OFS=" "}{$NF="";print}'
one two
@WinEunuuchs2Unix there, mush butter
You can specify output field separator OFS to be instead of being same as what you say in -F
 
last_word="-"$(echo "$choice" | awk -F "-" '{print $NF}')
echo $last_word
prefix=${choice%$last_word}
echo $prefix
header_count=$(find /usr/src/linux-headers-$prefix* -maxdepth 0 -type d | wc -l)
echo $header_count
 
Or even shorter: echo "one-two-three" | awk -F '-' 'BEGIN{OFS=" "}{$NF=""}1'
 
-generic
4.10.1-041001
3
-generic
4.4.0-63
2
It's all working now...perhaps three lines is lazy programming but I can live with the solution to get problem fixed fast.
 
5:48 PM
Now, the big question: do I be lazy today, and just spend the day at work watching TV series/youtube/whatever , or spend some time coding and working on my side project, or try to read textbook/do truth table computation/write lab report draft ?
Frankly, I don't want none of these. All I really want is to sleep. Curl up with my pillow and listen to ASMR
eh, I should write myself a script that rolls dice for me
There . . . six-sided dice in python:
$ python -c "import random;print random.randint(1,6)"
2
$ python -c "import random;print random.randint(1,6)"
4
 
Ubuntu seems to just not like dual GPUs...
 
But it sure does love dual CPUs . . hue
 
@Serg SLEEP. It will make you happier.
 
Oh, by the way, yesterday I was watching a livestream of couple favorite youtubers. There were tons of Brazilians. One guy's name was BR HUEHUEHUE
@JacobVlijm technically , cannot sleep at work, although i probably could take a nap
 
@Serg On your to-do list you should have had the option of going out and buying smokes so you don't run out like you did last night :P
@Zacharee1 Ubuntu LOVES dual GPU's as long as one of them is Intel Hybrid and the other is nVidia OR AMD which are never used.
 
6:01 PM
@WinEunuuchs2Unix I'm safe for today. 4 in my cigarette box, and I work until 3 pm. Only 3 hours left to go, and I smoke only 2 during work hours on Sundays. Already had one, so that's 3 for me for the road
And even if I don't have any at home, I still have plently of pipe tobacco
 
ohhh... the sherlock holmes type that smokes a pipe... I"ll have to give you the new nick-name "The Great Python Detective" :)
Don't tell @JacobVlijm we'll keep that ^^^ a secret between us ;)
 
totally not going to ping @JacobVlijm to tell him about it . . . .oops
 
My revenge will be terrible. Terrible really.
 
Almost scared. Almost :3
 
it's like Ubuntu is scaling back the higher power GPU to be as bad as the low-power one, even though I can't even enable the low-power monitors
let's see if 16.10 will let me have more than two screens
 
6:12 PM
@DougSmythies OK code has been modified to handle multiple headers when -generic and -lowlatency are installed. Make sure you are running this version with comment "Modified: March 12, 2017" : askubuntu.com/questions/892076/…
^^^ Credit to @Serg for "getting the last word in" with his AWKword programming skills :p
 
Scary python, run at your own risk !!!: python3 -c "print(''.join( [ chr(i) for i in [78, 101, 118, 101, 114, 32, 103, 111, 110, 110, 97, 32, 103, 105, 118, 101, 32, 121, 111, 117, 32, 117, 112, 46, 32, 78, 101, 118, 101, 114, 32, 103, 111, 110, 110, 97, 32, 108, 101, 116, 32, 121, 111, 117, 32, 100, 111, 119, 110]]))"
 
wat
 
shhh, you've been warned
 
this server's slow enough
I think I might have to clean-install...
 
6:38 PM
christ
it's still unpacking stuff
@TheXed you're the one with NVIDIA buying experience, right?
lol
I was about to say I found a card without an analog output, but it has DVI-I
why is that lol-worthy?
I guess I'm just that bored
HALP
 
@Zacharee1 throws hammer at Zach Did that halp ?
 
no
 
Oh, well, lol anyway
 
sigh
hey it's down to X
and now it's on the L's, which are usually last...
 
X gonna give it to ya ?
 
6:41 PM
hue
 
sorry, couldn't help but make the joke. Also, watching CAH right now
 
ooh it's setting up now
fonts are borked now
 
6:55 PM
3PM already? o_O
now it's " eading state information"
 
Hmmm I need one upvote to take me from the bottom of 10 people with 1 vote (like me) to get to my own list of 2 upvotes hint: askubuntu.com/questions/2793/…
 
@Zacharee1 yeah, and it's 1:05 in Denver
Sundays go by fast
 
@WinEunuuchs2Unix, couple concerns with your Zenity script for kernels.
First, it's only going to remove kernels that were installed through apt, which is not a fair assumption to make. Some people use compiled or custom kernels, which don't register themselves through the standard package system.
 
@KazWolfe I'm working with @DougSmythies who is testing this with his own compiled kernel.
 
What you should be doing in this case is probing for all the kernels, and then checking if/how they need to be uninstalled.
be it a simple rm or using apt.
 
7:10 PM
@KazWolfe kernels are installed through dpkg not apt at least all the ones I've installed.
 
@WinEunuuchs2Unix You manually download the DEBs and run dpkg -i on them?
 
The check for kernels is based on images installed in /boot.
dpkg and apt aren't searched for available kernels.
 
Right, but you need to remove them through apt.
(unless they weren't installed through apt, in which case a simple rm will suffice)
 
Yes I use apt-get purge which it appears everyone else does too at least on that thread
 
You're missing my point. You can't purge custom kernels most of the time.
 
7:13 PM
using rm won't invoke dkms update to remove drivers for nvidia, broadcom and realtek though.
 
Then you need to manually do that as well.
 
@KazWolfe Like I said Doug is already using the script to purge his custom kernel he compiled himself 4.11.0-rc1_stock
 
That can't be possible.
Unless he installed it through a DEB file, your program would choke on that.
 
When he comes back next to report on his progress I'll try to remember to ping you with ^^^ so you can see what he says.
 
Point is, you can't uninstall a kernel through APT if it wasn't installed through APT/DPKG.
 
7:16 PM
Hopefully anyone with the skill to compile their own custom kernel can look at the bash source and modify it to their needs of deleting extra stuff here and there.
 
You'd be surprised.
 
In any respect my script does the same as the canned packages with 498 upvotes and does it faster. If the issue comes up where my script doesn't work for an individual I'd be happy to modify it to address their fringe environment.
 
@KazWolfe but if apt thinks a different kernel is installed it may end up removing some of your custom files.
 
-1
Q: chmod 400 command returning "No such file or directory" error. Trying to launch an instance through AWS

CulturedI CraneCODE: root@crane-linux:/home/crane/Downloads# sudo chmod 400 ~/home/crane/Downloads/mykey.pem chmod: cannot access '/root/home/crane/Downloads/mykey.pem': No such file or directory root@crane-linux:/home/crane/Downloads# ls discord-0.0.1.deb mykey.pem torguard-latest-amd64.deb root@crane-linu...

 
@Seth That is also very possible, depending on how the custom kernel was installed.
huh, that was interesting.
I just used Ubuntu Tweak to nuke old kernels, and it only called update-grub once.
 
7:20 PM
now I have no ethernet
wtf Ubuntu
 
Hmm... I'll have to take out my bragging rights that I only call update-grub once then :p
 
or, it did for me.
YMMV
 
@KazWolfe OK I rewrote the introduction taking out update-grub is only called once and put in the selling point that native Ubuntu bash is used so people that didn't install kernels with apt or dpkg can modify the source more easily :D
 
1
Q: Can apt-get purge be done with just apt?

g3blvI'm a bit confused around apt-get and apt. Is apt an replacement of apt-get or just a similar tool? The reason why I'm asking is because it seems like most of the basic functionality in apt-get is also available in apt but there doesn't seem to be an apt equivalent to apt-get purge. What I like t...

 
7:37 PM
I think I might try an experiment, and put my email in my profile.
 
loads his spambot I'm ready, Seth. Any minute now ^_^
 
Well, as far as emails go, there's really not that many people that send emails , if ever. I had my email in the profile for a while. Over years, most of the people who contacted me only found me through github , or when I voluntarily gave them my email
And it's been . . . . like 4 or 5 people only
over the course of 2 and something years
 
@Seth I see you closed the Ubuntu One question and noted it on the etherpad list - are you checking them all? Would it be easier for you if I do something different to making them not clickable? If I can do anything in a better way, please let me know...
 
@Zanna naw I'm just editing a few here and there. If you spot something that needs mod action just use a flag or other moderation tooling you have :)
 
7:47 PM
of course :) thanks a lot!
 
@WinEunuuchs2Unix : Catching up on all the comments.
 
@Serg I email my to-do list for work to my work email. When at work I'll email my home email with to-do's :p
 
@KazWolfe : I only ever make .deb files and only ever use dpkg -i for my custom kernels. I would never do anything different in my Ubuntu environment.
 
@Zanna btw, it's fairly easy to open any of those non clickable links. triple click, then right click -> go to
 
@DougSmythies Sounds good. BTW @KazWolfe has concerns the script won't work for some custom kernel scenarios and I told him you were testing such a beast.
 
7:50 PM
@DougSmythies huh, interesting.
 
@Seth oh that's neat!
 
@DougSmythies it is best to make answers as general as possible
@WinEunuuchs2Unix why not simply carry a pocket notebook ?
 
@Serg : Note sure what you are referring to.
 
@Serg Or use any number of apps that do that.
 
@Serg email is simpler.... you don't have to pack it with you so you can't forget it.
 
7:54 PM
@DougSmythies Kaz mentioned that kernels can be installed in a non deb way. What i mean,.is that he is right and your case isnt the only that may need to be addressed
 
@Serg. Oh.
 
Holy cow I just noticed Daylight Saving Time kicked in and I lost an hour of Sunday laziness :(
 
@WinEunuuchs2Unix It kicked in at 2 AM
 
@KazWolfe : The reason I do it the way I do is specifically to avoid any possibility of confusing dpkg or apt.
 
APT is just a frontend to DPKG
 
7:57 PM
pretty much that ^
 
Scurries around the place setting time on non-internet connected clocks
 
It would just make removing custom kernels a bit simpler, I'd guess. The point still stands though, not everyone installs custom kernels through APT.
I just drop them in whenever I need one without doing any sort of packaging or the like.
 
I'm afraid I've never even used a release candidate so a custom kernel is far far from my plans.
 
00:00 - 20:0020:00 - 00:00

« first day (2356 days earlier)      last day (920 days later) »