« first day (2020 days earlier)      last day (1845 days later) » 

1:00 PM
yup
 
...which Verizon is pretty much obligated to provide for as long as he holds the account. Not sure how they cope with someone using several hundred gigabytes a month, as that is enough to noticeably impact performance for other users...
 
@DavidPostill Thank you. I will take note of that.
 
Should I be worried if PayPal tries to send mail to my server, but my postfix is declining because I disabled SSLv3?
 
Windows tells me I've used 42 GB of data over Wi-Fi over the last 30 days.
That's just this laptop.
My phone's used another 4.29 GB, and my tablet reports 11.15 GB over the last 30 days.
 
Bob
@xrstf There are many things that do not make sense without context in that sentence.
 
1:05 PM
Sure, it's just a 3 Mbps cable Internet plan, but it sure seems to get used a lot...
 
Bob
What kind of server is this? Email? Web? What?
Do you have a mail address?
 
Porn.
2
 
Bob
Is PayPal sending mail to this address, or just randomly opening connections to this server?
 
Firefox: 18.5 GB.
Steam: 16.7 GB.
Thunderbird: 2.55 GB.
 
And did it really come from PayPal?
 
1:07 PM
It's shocking how much data usage can come from just browsing the web.
18.5 GB of data from Firefox on this laptop alone.
 
@Bob this is what postfix logs to my mail.log: h.xrstf.de/f/i72erq5ad1c7npzm4mj0/raw
 
This is precisely what Windows is reporting in the Settings app.
 
Bob
@DavidPostill That's something a bit harder to judge, and is usually the job of the MTA.
@xrstf Also, how did you disable "SSLv3"?
Are you aware that the "SSLv3" cipher suite is still in use and considered secure, if not preferred?
SSL 3.0 the protocol is vulnerable.
SSLv3 the cipher collection are still in use in TLS 1.x.
 
The protocol is the problem, not the cipher suites.
 
1:10 PM
At 112 bits of security, even triple DES is still generally considered secure (even though it is much slower than hardware-accelerated AES).
 
tbh i'm no expert with these things and mostly follow guides until these mail tester services say my mail server is fine. :/
 
Bob
@xrstf Hm. Doesn't look immediately wrong.
 
i wanted to go to opensmtpd for its easier configuration, but i had issues getting it to work on ubuntu 14.04, so I stuck with postfix until u16.04 comes out.
i was able to receive paypal mails successfully on the server in the last weeks. not sure if that is just paypal probing me or if they have something noteworthy to say.
 
Bob
@xrstf It probably retries with an unencrypted channel.
Maybe.
 
shudder The U word
 
Bob
1:14 PM
@qasdfdsaq Eh, the vast majority of email is unencrypted.
And encryption of emails is fairly pointless without end-to-end encryption (PGP, GPG, etc.) anyway.
 
it happened 6 times today: h.xrstf.de/f/y537vku29klizg0cl3qy/raw
 
Argh stop cursing!
 
It's so easy to use up so much data.
 
@xrstf Contact PayPal support and report back
 
firefox is 30gb for me
but my usage is skewed, I have something like 188gb for backups ;p
 
1:19 PM
Nexus 9.
 
Bob
@OliverSalzburg Ha, that sounds like it'd end up being like one of your typical support conversations :P
 
Nexus 5X
 
Bob
@xrstf You should remove the TLS protocols from smtpd_tls_mandatory_protocols
 
Bob
1:22 PM
> Listing the protocols to include, rather than protocols to exclude, is supported, but not recommended.
 
Bvckup? Backups. Cyberduck and mountain ducks is what I use to grab stuff off my file server.
 
And people say I'm on my phone too much -_-
 
@qasdfdsaq Wi-Fi?
 
Nah, my mobile network's faster than WiFi
 
Bob
@xrstf You should also remove them from smtpd_tls_protocols
 
1:24 PM
More details from the phone:
 
doesn't that make things worse if i start to support SSL again?
 
Mostly app installs.
 
Bob
@xrstf Hm what?
 
(The device was set up just three weeks ago.)
 
Bob
Read the docs I linked.
 
1:26 PM
oh, yes, i misread you.
 
Bob
Basically, you should use smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3 and smtpd_tls_protocols = !SSLv2, !SSLv3
 
yeah i got i :)
shouldn't change anything wrt paypal, though, right?
i'm just removing implicit default values.
 
Bob
@xrstf Probably not, but it's good practice anyway :P
 
i'm all for good practices
 
Bob
Also, your actual error is no shared cipher
 
1:30 PM
i read that, but the "SSL3_GET_CLIENT_HELLO" lead me to believe that paypal is doing an ssl3 handshake and that the error is therefore not in the ciphersuite i offer.
but then again, i have no idea.
 
Bob
Wait. Hold on.
@xrstf ...why do you have a line break in your tls_high_cipherlist?
 
copy-paste from my ssh window.
 
Bob
Ah.
Related:
7
Q: Disable SSLv3 in Dovecot --> TLS handshaking failed: no shared cipher?

quanta Ubuntu 12.04 OpenSSL 1.0.1-4ubuntu5.20 14 Mar 2012 Dovecot 2.0.19 The situation is I'm trying to disable SSLv3 in Dovecot by adding !SSLv3 to the ssl_cipher_list: ssl_cipher_list = EDH+CAMELLIA:EDH+aRSA:EECDH+aRSA+AESGCM:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH:+CAMELLIA256:+AES256:+CAMELLIA...

I suspect you're only enabling TLSv1.2 ciphers.
But the OpenSSL cipher list is a pretty obscure format :\
 
i was using de.ssl-tools.net/mailservers/xrstf.de to verify my tls settings.
 
Bob
@xrstf Sorry, I can't read that :\
 
1:36 PM
sorry, remove the leading "de." to ge the english version.
 
Bob
@xrstf If I were to guess, I suspect your issue is with only including ECDHE and kEDH ciphers
 
could very well be. can i use a more relaxed ciphersuite from something like mozilla.github.io/server-side-tls/ssl-config-generator or do i need special ones for mail traffic?
 
Bob
@xrstf I wouldn't know that, sorry.
Trying to find a good source.
For the most part, I wouldn't be overly concerned about it.
As I said above, the important part isn't server-to-server encryption. You really want client-to-server and end-to-end (PGP, GPG).
server-to-server is only for the absolute most paranoid
and only really works when you control (or influence) both ends
 
well i will try to tintermediate ciphersuite.
 
Bob
@xrstf The list here seems decent if you trust them: blog.tinned-software.net/…
EDH+CAMELLIA:EDH+aRSA:EECDH+aRSA+AESGCM:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH:+CAMELLIA256:+AES256:+CAMELLIA128:+AES128:+SSLv3:!aNULL:!eNULL:!LOW:!3DES:!MD5:!EXP:!PSK:!DSS:!RC4:!SEED:!ECDSA:CAMELLIA256-SHA:AES256-SHA:CAMELLIA128-SHA:AES128-SHA
You can move the EDH ciphers further down the chain if you wand to optimise for performance.
 
1:45 PM
with ~3 mails per day, performance is not an issue ^^
thanks a bunch :)
 
Bob
Note that EDH is equivalent to DHE, and EECDH is equivalent to ECDHE
@xrstf The Mozilla intermediate list looks like it'd also work.
It's also more optimised (better order, etc.).
But I don't know how mailserver requirements differ from webserver.
 
20
Q: You hate <s>hats</s> reputation? Klick here to get rid of it

Vogel612Soo... I recently read a meta-post about the inherent problems of reputation. It listed some things like: Confirmation bias. Demotivating for low-rep users. Hubris and elitism of high-rep users over low-rep users. Incorrect representation of competence. ... So I thought to myself: "How would ...

 
Bob
Oof.
@xrstf That list doesn't disable EXPORT. I think it was before logjam...
 
the "modern" list does disable export.
 
Bob
@xrstf I meant the list from the blog (dovecot).
The Mozilla intermediate list looks good.
The modern list won't work for you.
Yea, I'd recommend using the Mozilla intermediate one.
 
1:53 PM
how come the modern one wouldnt work? it seems to include non-ec ciphers like DHE-RSA-AES128-SHA.
(just out of interest)
 
Bob
@xrstf That's still DHE
 
oh. ah.
 
Bob
@xrstf I mean, it might work. SSLv3 had DHE.
But IIRC people used to disable it...? shrug
You could always try modern and lower it if you keep getting errors.
 
i could, but for now i'd rather have something that works. ^^
 
2:15 PM
 
2:34 PM
The mechanical keyboard I have has this tendency to register certain keypresses (especially Space) twice. Might have something to do with the light actuation force (Cherry MX Brown, 45cN tactile).
 
Takes a while to get used to typing on a mechanical.
You might be bottoming out?
 
Probably not 100% used to it because I've been using dome-switch and scissor-switch boards for so many years.
Yes, I do bottom out, but I'm not quite slamming on the keys like some do.
I can't reasonably expect to bring such a big keyboard with me every time I leave for campus simply to get used to it, though. The box will not fit in my Osprey Meridian 22 backpack.
I'd actually be best with Cherry MX Clear keyswitches if bottoming out is really a serious issue, but keyboards with these keyswitches are very hard to find.
 
I tend to suggest blues as a starter keyboard
and no you don't need to use them all the time
 
Blue is too noisy for my taste.
 
just be aware of why and it gets easier
but that also means you know when the switch actuates
and the feel of it
 
2:42 PM
attn: plz do smth cc: you, your coworker, your manager, your boss, his boss, CTO, CFO, CIO, CEO, your mom, her boss...
 
Bear in mind that I do about 60-70 wpm so bottoming out hard is really not even a possibility.
This is not to say that I don't bottom out, but my fingers don't slam on the keys.
 
@ThatBrazilianGuy and the office cat...
 
I've been typing a bit gentler since I got this keyboard, but it'll still take some getting used to.
 
@JourneymanGeek OMFG @allquixotic WORKS HERE?!?!
 
2:45 PM
The key travel is significantly longer than most membrane keyboards; this is normal.
 
@JourneymanGeek I try a subtle "Hello $person-who-wrote me and everyone else" as the opener to my replies, but so far no one noticed. Or pretended not to.
 
Already, though, the old ROCCAT Isku feels mushy to my fingers.
 
lol
I think I was running a shitty keyboard from some wierd brand before my BW
 
I'm not getting another keyboard just for the clicky sound.
The tactile detent is enough.
Guess I'll sign up for an account at TypeRacer soon.
 
3:04 PM
I dunno if I've ever used a mechanical keyboard..
 
Bob
3:32 PM
Eh, browns were/are my first/only. Never had issues with it.
But my old Dell membrane (dome) one actually felt pretty similar
 
Still choosing what kind of MicroSD card to buy.
Not sure what's killed every one of my cards so far, but the endurance cards don't go big enough and the big ones I don't trust enough.
Also hearing rumours of the Galaxy S7 having/not having an SD slot
 
4:40 PM
have you run into the high capacity SD cards that don't work in some devices issue?
 
5:03 PM
@qasdfdsaq My first keyboard was a teletype
Around 1976 ;)
 
5:34 PM
@Burgi Nope.
 
5:56 PM
@DavidPostill You're showing your age again
 
@qasdfdsaq I know ;)
The very first program I wrote was to play the game of Nim (in Basic IIRC) - 6th form "special computer module" - I think it was part of our Maths A Level or something. There were no Computing O or A Levels in those days ...
We had to travel to another school to use use their timeshare terminal. We didn't have one :/
Maybe it was part of General Studies. I also had to write some Cobol on punched cards.
You youngsters have it easy by comparison.
 
6:12 PM
I had to do C++ throughout most of my college career.
The fact that we have it easy these days makes us lazy :\
I'm trying my damn hardest to make up for that, though.
 
Hello all
 
Who's this @Al guy?
 
Are the following folders within /home/hstevens safe to remove? .config, .cache, .fonts, .gnome, .gnupg, .local ?
 
@bwDraco I used Fortran and Algol at Uni. C, C++ and Java came later
 
6:17 PM
I'm trying to take up JavaScript, but never seemed to find the time to do it.
 
@onebree .cache maybe.
 
You shuold probably ask H Stevens.
 
Begone, Clippy!
 
@qasdfdsaq I am Hunter Stevens :-)
 
I thought you were onebree
 
6:18 PM
Is that a name or something?
 
I went by Hunter Stevens on SO for a few months, but recently went back to onebree because it is cooler.
 
Why would you want to remove all those dot directories?
 
To remove the evidence that he/she/it is stealing someone else's identity!
 
@jokerdino Because if they are not needed, why use them?
 
6:21 PM
@onebree Each of those folders have a reason for existing. Config stores settings for your user, cache is cache, gnupg I believe is your keyring and .local is localized settings for your software or something.
 
@jokerdino Cool, thanks!!!
 
Are you using Ubuntu?
 
centos 7
 
6:36 PM
Things are getting flagged here. Please calm down and think before you post ;)
2
 
This whole conversation is off-topic, idle, and problematic. I advise all participants to switch topics or just end it here.
 
@david, can you babysit this room? I gotta go now.
 
60 messages deleted
 
Why was that done?
2
 
@jokerdino I'm around on and off for the the next few hours. I won't be watching the whole time.
 
6:41 PM
4 mins ago, by 200_success
This whole conversation is off-topic, idle, and problematic. I advise all participants to switch topics or just end it here.
 
How often do you hang around in this chat room?
 
Oh My God. It's Judge Dredd.
 
Okay, toodles all. Back to Ruby room, where it is quieter/nicer
 
@200_success That was way over the top.
4
 
Guess I need to poke @JourneymanGeek to add "Taylor Swift" to the list of channel topics next time he's around >_>
 
Randomly popping in and mass deleting messages is not cool. We did steer away from controversy.
 
+1 ^^^
 
Wasn't random. A message was flagged. That conversation wasn't going to be on-topic.
 
@200_success You must not spend much time on SE Chat. Off-topic is the norm.
3
 
Given that the topics listed are "Cats dogs, foxes", it seems pretty obvious the "topic" in here is generally fairly relaxed and about anything
 
6:47 PM
@200_success What if I tell you we goof around like that in this room?
 
My apologies then. I'll undelete a bunch of stuff.
 
I doubt you can undelete things.
 
Missed the whole dispute here. What happened?
 
Crap. Indeed, there is no undelete.
 
Be our guest for a week and see how random this chat room goes.
 
6:49 PM
Idle chatter, started to veer into sexism.
 
@jokerdino Or just look at the history/transcript
 
@qasdfdsaq He can't.
 
@200_success Which stopped at some point, didn't it?
 
@200_success One message was flagged and you delete 60? The vast majority of those were on topic for this room. There were a couple of dodgy ones and we (me as a room owner and @jokerdino as a regular mod here) were dealing with those.
 
@qasdfdsaq Not a mod. I can't access this information.
 
6:50 PM
@ThatBrazilianGuy I'm referring to jokerdino suggesting 200_success hanging around to get an idea of "topic"
 
@qasdfdsaq Oh, ok.
 
Sorry, I was wrong. I'll get out of here.
 
@200_success I understand your intention to steer this room from random chatter but let's not mass delete messages in a new chat room.
Aw, he scooted away.
 
Well that happened escalated quickly.
 
Next time, @qasdfdsaq watch what you say.
 
6:52 PM
"Off-topic" is not the issue but we do not want to discuss anything which can reasonably be considered offensive, including sexist, racist, or otherwise discriminatory content.
 
@jokerdino Really now?
 
@jokerdino: qasdf has had a history of issues in this room and had been suspended from chat in the past.
 
It was something you said that led to this situation.
 
I've warned you all before. If you post something that gets flagged we get visited by a horde of mods. Please think before you post.
12
 
Responding to someone saying they're getting loads of atetntion because they're the only woman in the room by pointing out they're not.... is offensive?
@bwDraco: Last I checked, so have you.
 
6:53 PM
@qasdfdsaq You know it wasn't just that what you said.
 
@DavidPostill Well, it's hard to know what might be flagged.
 
What did I do? I was absent at the time of this incident.
@DavidPostill Needs to be pinned.
 
@FaheemMitha I've heard of drive-by flaggings as well. I may have contributed once.
 
In a circle of friends it might not be uncool to say that, but with a stranger in a chatroom... It is.
 
At least in part it seems semi-random. I've seen plenty of really offensive stuff that didn't get flagged.
 
6:54 PM
I thought we all were a great big circle of friends :-(
 
In SE chat rooms, just to be clear.
 
@FaheemMitha Yup.
 
Don't say anything that will intentionally or unintentionallly hurt or offend others.
 
@jokerdino That's always a good rule.
 
I'm offended by onebree claiming she's the only woman in the room.
You don't see me whining about it.
@bwDraco No I'm not. I've said so before.
 
6:55 PM
@FaheemMitha If anybody posts anything that someone else in the room could reasonably object to they may get flagged. It's that simple. That includes personal insults, swearing directed at individuals and overly sexist remarks and probably a bunch of other stuff too.
 
@jokerdino Though it can be hard to know what will offend others.
@DavidPostill Hmm. "reasonable" is not a well-defined term.
 
@FaheemMitha Some pepple have literally flagged images for being too big.
 
Clearly, there is stuff that would be way over the line.
 
Oct 17 '15 at 18:57, by DragonLord
@tereško Sorry, but I have to flag this for mod attention. The animated GIF is 73 MB in size, which is dragging my connection down.
 
@qasdfdsaq That's annoying.
 
6:56 PM
@FaheemMitha Most of us have some clue about which can and which can't be aired out in a public chat room like this.
 
Is this an issue?
 
@jokerdino Some clue, sure. A definitive indicator, no.
 
I once flagged saw someone flag a message that basically said "Haha karma".
 
@bwDraco 73 MB is too much. I would have deleted or at least stopped it from onebox-ing.
 
And the flag was honoured and the person banned.
 
6:57 PM
72 MB is indeed a lot. But that sounds like a job for an automated system. I'm surprised there isn't a built-in limit.
 
2 mins ago, by qasdfdsaq
I'm offended by onebree claiming she's the only woman in the room.
 
@ThatBrazilianGuy This offends me.
 
Hey, can I object to @ThatBrazilianGuy's images being too big then?
 
@FaheemMitha Chat just dumbly oneboxes images from outside sources and does not check image size.
 
@bwDraco Well, maybe it should. Another wishlist item for the long suffering SE Software Engineers.
 
6:59 PM
Anyway, please be mindful of what you say. You do not want to be alienating people on discriminatory grounds.
I was not supposed to stay so late. Damn you all.
 
7 mins ago, by bwDraco
"Off-topic" is not the issue but we do not want to discuss anything which can reasonably be considered offensive, including sexist, racist, or otherwise discriminatory content.
 
Thanks Drags.
 
Remember there's people from all around the world. Different cultures. What you might find just a little goofy might sound rude and offensive to others.
 
I am out.
 
@ThatBrazilianGuy Yes, that's part of the problem.
 
7:04 PM
Got a pretty annoying problem with my home desktop right now :( It won't boot anymore after upgrading from a 2700K to a 3770 i7
It'll show the Intel boot logo, but won't let me enter the BIOS and after a while it just reboots
 
Sounds like typical behaviour after you change a SATA adapter - are you sure you're set up in the same mode as the old board?
 
Well, I changed the CPU, then the system wouldn't boot. Then I realized I had to update my BIOS for the CPU to work, so I changed the CPU back, updated the BIOS, then put the new one back in
So, yeah, fun times
 
Oh, same motherboard...
 
Yeah
No SATA drives connected right now. I'd just like to get into the BIOS :P
 
That's odd. Where is the Intel boot logo coming from?
Is it an Intel board?
 
7:08 PM
Yeah :D
 
And have you done a CMOS reset?
 
I'm trying the recovery boot jumper config right now
Which I'm assuming is the equivalent
 
Umm... could be I guess? :-P
I pretty much always have to do a BIOS/EFI reset after changing a CPU in an existing board
 
Let me check how to do it properly, because this didn't do anything
Nope. Let's just cut the power and remove the battery :P
 
That's pretty much the first thing I do :-P
 
7:15 PM
I don't get it why I'm always fucking things up so badly when I mess with this machine
 
Have you considered not messing with this machine? :-P
 
I'm sure this is hardly the end of it. When I put the old CPU back in earlier, I wasn't able to boot. SSD was no longer detected
Which happens every single time I change anything on this machine
Then it magically starts working again
 
It's raining cats and dogs and our cable modem is having absolutely zero trouble maintaining the connection. All the signal numbers are excellent.
If this was DSL, we'd be offline by now.
 
The worst part is, I assumed the new CPU is a 3770K, but it's just a 3770 :(
If it was the K, the board would be at the max specs it is capable of and I would never have to touch it again for an upgrade
Now there's still that tiny K to get :P
Alright, 5 minutes without battery enough?
 
Yeah should be
 
7:20 PM
Let's go for it then!
 
And you're sure your new CPU is listed in the compatibility list for the BIOS you upgraded to, right?
 
It is
When I now press the power button, the system turns itself off instantly
 
o_0
 
I'm assuming that isn't great
Eh, I just held the button down and now it powers up
Haha \o/ We have BIOS
But now It only has 16 GB RAM and they run at 1333 Mhz O_o
Okay, got that sorted out. Now I connected the SATA drives again, back to reboot loop, but now even before the Intel logo is shown...
 
7:37 PM
A bit embarrassing, but can I get help with these instructions? freeswitch.org/jira/browse/…
I am good with Step 2, but IDK how to do step 1. (Newbie at sysadmin)
 
@OliverSalzburg o_0
"only" 16GB RAM, I'm assuming that means some is missing?
 
Should be 32. I changed some profile in the performance settings, rebooted, then I had all 32 at 1600. I rebooted again, now I'm back to square one
 
Sounds like a memory controller issue in that case. Which can quite easily be causing reboot loops
Try reseating the RAM and/or taking out two sticks
Less strain on the memory controller might get you a bit further and/or rule out problems with that subsystem
 
Okay, never mind then :-)
 
I tried that earlier, didn't have an impact on the issue. But let me remove 2 sticks again
 
7:49 PM
Before or after the BIOS reset?
 
Before
Now I reseated the RAM, took out 2 modules, nothing helps. Still the same reboot loop as initially
Which is weird, because it seemed to work right after the reset
This is nice:
> Warning:
BIOS version 0035 includes support for 3rd Generation Intel® Core™ processors. Due to structural changes in this BIOS version, once a board has been converted to this version or later, it will no longer be possible to downgrade the BIOS to version 0028 or earlier. Attempting a BIOS downgrade to a previous version may fail – the board BIOS will remain at its current version.

To fully enable support for these processors, follow the special BIOS update steps at Updating the BIOS on 6 Series chipset desktop boards.
The link in the last paragraph is dead
 

« first day (2020 days earlier)      last day (1845 days later) »