« first day (1684 days earlier)      last day (1618 days later) » 

8:42 AM
@JosephWright Added to my bookmarks!
 
 
1 hour later…
9:44 AM
@DavidCarlisle Great! How did you like it? I don't mean just the interval ;-)
 
Hello friends!
What's wrong with this question?
6
Q: How does one install TeX Live in Windows 8?

JohnI have Windows 8. I just downloaded the TeX Live distribution from CTAN. When I double click on install-tl.bat, I receive the following error message: PATH=C:\Users\JAKEFI~1\AppData\Local\Temp\7zOFD2B.tmp\tlpkg\tlperl\bin;C:\Progra m Files\7-Zip\;C:\Program Files\Internet Explorer;;C:\Windows\sy...

I think it is clear enough to get an answer
I have the very same problem with tex live installation
Am I supposed to ask another question or what?
This is urgent
Thank you!
 
10:10 AM
@ArthurReutenauer production was great of course:-) the screening wasn't quite as I'd expected, It was more of a cinematic rather than theatrical experience, I'd expected to be more aware of the stage, but actually the photography tended to zoom in close on the singers so the view was quite unlike the view you'd get from the hall. Not necessarily a bad thing, just different:-)
 
@Gigili I said:
What exactly did you download? On Windows, you need the .zip file, which you should extract then run the installer. From your error, I wonder if you tried to run the installer without extracting the files. — Joseph Wright ♦ Oct 6 '13 at 6:44
We then had no more feedback, so the question seemed to be unclear (would have been mod-closed during an answer-the-unanswered session)
@Gigili There is no problem I know of installing TL in Win8. Note that since that question was posted there is now a executable download that self-extracts the installer and auto-runs everything
 
10:33 AM
@Gigili The problem was clear: Perl was missing from the OP's system. How to install Perl on a Windows box is off-topic for this site.
 
10:44 AM
@JosephWright Sorry, I didn't pay enough attention to the comments there
@JosephWright It's been a day I am trying to install Tex Live but to no avail
I installed perl, as @egreg suggested (it was mentioned in another question as well) but he problem is still there.
I need to install Tex Live ASAP to start writing my thesis
Here is the error I get, but please note that it is not the same error. I did try to install more that three times and each time I get a new error according to the changes I've made before installation to fix the previous error!
 
11:24 AM
@JosephWright Can you please open and close this again as a duplicate ?
1
Q: matlab figures in pdf

veniAll the pdf figures created using matlab are extremely small. To be more precise, the blank space is too large wrt the figure. Although I use almost all the space of a single page, the figure is small. Any ideas? Thank you in advance!

It is currently closed as off-topic but we have an identical copy given in the comments.
 
11:44 AM
@Gigili Pick a different mirror: looks like a download issue
@percusse Done
 
OK, thanks.
 
12:09 PM
Cool, some lawyer mailed me, apparently I inherited about 9.6 million dollars from Michael Böttcher.
 
@Johannes_B So you can leave your work and come to Darmstadt! Beer for everybody!
 
@egreg If i had a relative named Michael who died in a car accident and really left me 9600k dollars, i would gladly pay for the whole conference, free beer and wine included.
 
@Johannes_B might not be enough to pay @egreg's wine bill
 
I'm having trouble using the mailmerge package with the scrlttr2 class. So I was trying to find an example online, but have not done do thus far. Does anyone have an example link?
@Johannes_B What, only 9.6 million dollars?
 
@Johannes_B ooh bring me to Darmstadt then. :)
 
12:23 PM
@FaheemMitha Yep, only 9.6 million.
@PauloCereda Once i really inherit that amount of money, i'll get a private jet, fly to brazil, get a helicopter, land it in your back yard, and then we will fly to the conference. ;-)
 
@Johannes_B oooooooooooh
Can we have an helicopter in the shape of a duck?
 
@PaulGessler -- oh, sometimes i just can't resist rising to the bait.
 
@PauloCereda ^^
 
@PauloCereda We need this thing ^^^^^^^^
@JosephWright You are an active package maintainer and part of the L3 team. Do you want to write something regarding latex-community.org/forum/…
 
12:39 PM
@Johannes_B or just answer yes;-) there was a question about the same here the other day (from cfr?)
 
@DavidCarlisle I wanted a bit L3 promotion ;-)
 
@Johannes_B ah with the docstrip question I thought it was asking about documenting/packaging a class rather than what to use in the tex macros.
 
@DavidCarlisle I am not even sure if docstrip works the same with L3. I never had the time or effort to take a closer look.
 
@Johannes_B Yes, for LaTeX2e they broadly still hold
 
@Johannes_B yes completely unchanged it doesn't care what is on the code sections can be 2e or 3 or perl or anything.
 
12:47 PM
@Johannes_B YEEEES
 
@PauloCereda Duck-drone
@DavidCarlisle @JosephWright Any of you want to write an answer, or should i summarize your comments?
 
@Johannes_B I don't:-) I can only handle one forum at a time:-)
 
@DavidCarlisle You have been unjustly served.
 
@FaheemMitha as usual!
 
@DavidCarlisle As usual.
 
1:09 PM
@David: Talked to Microsoft just now, I know less than I knew before calling them. :)
 
@PauloCereda all of them?
 
@DavidCarlisle Of course. :P
 
@PauloCereda do they know about ducks?
 
@DavidCarlisle Nothing. Those bastards. :)
 
@PauloCereda I tried microsoftstore.com/… it said it knew nothing, did I mean "deck" but now it's popped up a live chat box asking if I want to chat to a "microsoft store tech" what should I do....
 
1:39 PM
@DavidCarlisle "do you have any USB-powered duck?" :)
 
@clemens I am a little bit surprised that the following raises an error with the frozen TL14. Is that supposed to work here? c.f. golatex.de/…
		\documentclass{article}
		\usepackage{chemmacros}
		\begin{document}
		\ch{"\OX{a,\ox{0,Cu}}"}
		\ch{\ox{0,Cu}}
%\begin{reactions}
%	\ox{0,Cu}
%\end{reactions}
		\end{document}
@clemens Ah, the quotes are missing. That is a bit hidden in the doc.
 
@Johannes_B you need to escape \ox: \ch{"\ox{0,Cu}"}. Otherwise 0 is interpreted as subscript
 
2:01 PM
RIP Christopher Lee. :(
 
 
1 hour later…
3:19 PM
Does anybody know if there are any tools out there that will convert a BibLaTeX database to a BibTeX database?
Specifically, since BibLaTeX databases can have a lot more data fields, is there something that would convert a BibLaTeX database into a database that just has the standard BibTeX data fields, rearranging the information when necessary? So, for example, since BibLaTeX has both title and subtitle, is there a tool that would combine these two fields into title in the conversion process?
 
@AdamLiter wouldn't it be simpler just to write a matching bst file using the extra fields?
 
@PauloCereda Just read that he made some heavy metal. Just listening to "The Bloody Verdict of Verden" but i cannot watch. Watching the music video is cruel.
 
3:36 PM
@DavidCarlisle I suppose so. I've never actually looked that closely at a .bst file. The reason I ask, though, is that a friend and I are toying around with the idea of trying to start and maintain a bibliography file that would hopefully become a comprehensive bibliography file for linguistics. It seems like a waste of time that individuals all go through the process of starting and maintaining their own bibliography file.
So the idea was to try to start a bibliography file (probably on GitHub) that everyone could help maintain, rather than everybody individually maintaining their own bibliography file.
But I suppose maintaining and distributing a bst file along with the bibliography file could work for those who use natbib and BibTeX.
 
4:01 PM
Eating integral biscuits! :)
I wonder if mathematicians eat integral cookies and derive. :)
 
4:22 PM
Any of the TikZ people around? :)
 
@PauloCereda I'm here!
 
@DavidCarlisle <3
 
@PauloCereda I've got a badge.
 
@DavidCarlisle :)
@David: do you believe is there a way to add a striped background to a mdframed environment?
:)
Since one of the frame methods for mdframed is powered by TikZ, I think one could inject code. :)
 
\setlength\linethickness{1cm}\color[gray]{.2}\multido(0,0)(0,1){10}{\line(1.1){‌​2}}
 
4:32 PM
@DavidCarlisle wow
 
@PauloCereda you'd have to add clipping somewhere of course
 
@DavidCarlisle :P
First comment is priceless:
> In Russia, Stack Overflows You
 
@JosephWright I found the obituary of Hermann Zapf on today's International NYT that I was given on the train. I pasted a copy on my office door.
3
 
4:53 PM
@egreg oh
 
5:31 PM
@PauloCereda And now I'm getting my wine!
 
5:41 PM
@egreg oooh :)
Good wine!
 
6:36 PM
This is what happens after five weeks of not being around:
user image
4
Who is gonna read 43 messages? Not me!
 
@GonzaloMedina The main site (SO) gets 8k mod flags a day ;-)
 
@JosephWright That deserves no less than a "Holy guacamole!".
I see some changes in the main site, in chat and in the user profiles. It looks nice!
 
6:52 PM
@GonzaloMedina +6663? lol
Anyone knows stuff about minted + pygmentize? I installed it but it's still complaining.
Do I need to reboot? ¬_¬
@GonzaloMedina Welcome back by the way!
@egreg Come back! I need your help.
 
@Alenanno Thanks!
@Alenanno What kind of complaint?
 
@GonzaloMedina Well the error is "You must have `pygmentize' installed to use this package." but the fact is... I have it installed. If I do "which pygmentize" in the terminal, it tells me the path "/usr/local/bin/pygmentize"
 
have you tried Bruno's code? I'm probably doing something silly: `! Font \foo has only 7 fontdimen parameters.
`
 
So... it's not seeing it.
 
@Alenanno did you use --shell-escape?
 
7:00 PM
@DavidCarlisle Yes, I don't have any error about the escape.
 
@Alenanno Are you using latex + --shell-escape to process the document? (pdflatex won't work with minted IIRC).
 
The engine? Let me try.
Nope, same error.
Latex, pdflatex and xelatex.
 
@Alenanno What error exactly?
 
@Alenanno so does pygmentize actually run without error on the terminal eg if youu have foo.tex what does pygmentize foo.tex do?
 
7:02 PM
That error. :D
@DavidCarlisle In the terminal it works fine. O_o
 
@Alenanno I give up then!
 
@DavidCarlisle Don't give up! T_T
 
@Alenanno well what does the log say
 
Let me see.
 
@Alenanno So running latex --shell-escape foo.tex from a terminal gives the desired output with no errors?
 
7:05 PM
I don't know where to look. But in the end it says this:
./Prova2.tex:16: Package minted Error: Missing Pygments output; \inputminted wa
s
probably given a file that does not exist--otherwise, you may need
the outputdir package option, or may be using an incompatible build tool.

See the minted package documentation for explanation.
Type  H <return>  for immediate help.
 ...

l.16 \end{minted}

This could be caused by using -output-directory or -aux-directory
without setting minted's outputdir, or by using a build tool that
changes paths in ways minted cannot detect.
 
@DavidCarlisle Indexes from 1 not 0 :-)
 
as @GonzaloMedina said don't use an editor do it on the terminal (first)
@JosephWright ah of course, I should downvote Bruno:-)
 
I still get this
! LaTeX Error: Something's wrong--perhaps a missing \item.
>_>
 
@Alenanno that's presumably not the first error (and later errors are typically spurious)
@Alenanno whats this: runsystem(rm "Prova2.pyg")...executed.` ?
 
@DavidCarlisle I don't know. This is the first time I've been using pygments.
I've just installed it. :P
 
7:10 PM
@GonzaloMedina: Muchas gracias, my friend. :)
 
:Tex Alenanno$ latex --shell-escape Prova2.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=latex)
 \write18 enabled.
entering extended mode
(./Prova2.tex
LaTeX2e <2014/05/01>
Babel <3.9l> and hyphenation patterns for 79 languages loaded.
(/usr/local/texlive/2014/texmf-dist/tex/latex/standalone/standalone.cls
Document Class: standalone 2012/09/15 v1.1b Class to compile TeX sub-files stan
dalone
(/usr/local/texlive/2014/texmf-dist/tex/generic/oberdiek/ifluatex.sty)
 
@PauloCereda ¡De nada!
 
@GonzaloMedina When you have some spare time, poke me in Skype, I have interesting facts to tell you about my Spanish adventure. :)
 
@DavidCarlisle Check this out: github.com/vonavi/minted/issues/75
He changed two characters in the minted.sty package? Why do I need a hack? It seems weird.
 
@Alenanno ah OK mac weirdness:-)
 
7:15 PM
@Alenanno I was having dinner
 
@egreg My Mac is complaining about not having pygmentize, but I have it installed in "/usr/local/bin/pygmentize"
>_>
 
@Alenanno did that github hack work for you?
 
@Alenanno I tried today some minted document and it worked.
 
@DavidCarlisle I haven't tried it yet. I wanted to keep it as a last resort. Maybe I installed pygmentize not properly. @egreg how did you install it? I did "sudo easy_install pygments"
 
@Alenanno I guess I did the same way; do you have homebrew?
 
7:20 PM
@egreg How do I check?
 
@Alenanno which -p python
 
which: illegal option -- p
usage: which [-as] program ...
 
@Alenanno Still with tcsh? Then remove -p
 
Sorry, I have to go. I'll be back in a bit. Thanks for the help everyone!
 
7:33 PM
@egreg What is tcsh? :P Well removing the -p, it gives "/usr/bin/python"
 
@Alenanno Try reinstalling pygmentize
@Alenanno The terminal runs a shell; old versions of Mac OS X had tcsh by default, newer ones use bash.
In tcsh the -p option to which is illegal.
 
@egreg Would you mind telling me how to reinstall it? I spent 10000 hours trying to install it.
 
@Alenanno What happens if you say pygmentize -V?
 
Pygments version 2.0.2, (c) 2006-2014 by Georg Brandl.
 
@Alenanno 2.0.2?
 
7:43 PM
@egreg That's what it says. :P
 
@Alenanno OK, now I have 2.0.2 too. Let me try a test.
 
@egreg Ok!
 
@Alenanno No problem.
 
@egreg It works?
 
@Alenanno Yes. Try this file testminted.tex
\documentclass{article}
\usepackage{minted}
\begin{document}
\begin{minted}{latex}
\LaTeX
\end{minted}
\end{document}
Run with pdflatex -shell-escape testminted.tex
 
7:51 PM
@egreg Same error. You know what, I'm going to reboot. It's worth a try (although I'm skeptical).
 
Hi does anyone have any knowledge/experience with ffmpeg and/or issues with parameters of .jpg files?
 
@Alenanno the github issue was that the version of which being picked up was not reporting pygmentize found so it won't matter what version of pygmentize is installed you need to either get a newer which or change the tex to expect whatever the mac test is returning
 
@Alenanno Look in the .log file for every occurrence of runsys
 
Ok, rebooted and still the same. But running @egreg's file gave a different error (undefined control sequence), which can be ignored I guess
 
@AlanMunn I use ffmpeg now and then, but not wth .jpg. I might try. :)
 
7:55 PM
@egreg Look:
This could be caused by using -output-directory or -aux-directory
    without setting minted's outputdir, or by using a build tool that
    changes paths in ways minted cannot detect.

    runsystem(rm "Prova2.pyg")...executed.
Also earlier in the .log, this appears:
runsystem(pygmentize -l latex -f latex -F tokenmerge -P style=default -P comman
dprefix=PYGdefault -o "_minted-Prova2/FBFD123F4093DAE0A2D202C7519BDA7B0E5B2C291
4AA74E7AA040A22ADA5B4FF.pygtex" "Prova2.pyg" )...executed.
 
@PauloCereda Here's the problem: I'm trying to create an .mp4 out of an image + a .wav file. I can do it with the loop function but it seems very sensitive to the image properies: with a photo from my phone, it works, but with an image created from LaTeX and converted from png to jpg it doesn't.
 
@AlanMunn Interesting: how are you converting PNG to JPG?
 
@PauloCereda I've tried using convert, GraphicConverter and Preview.
 
@Alenanno This shouldn't happen. Try running the following with pdftex -shell-escape
\immediate\write20{}
\immediate\write20{******}
\immediate\write18{echo $PATH}
\immediate\write20{******}
\bye
@Alenanno Please, report the terminal output
 
@egreg Ok.
 
7:58 PM
@PauloCereda I've also tried to convert from pdf to jpg using Preview.
 
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdftex)
 \write18 enabled.
entering extended mode
(./Prova2.tex

******
/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/ImageMagick/bin:/usr/texbin
******
 )
No pages of output.
Transcript written on Prova2.log.
That is the Terminal output, @egreg
 
@AlanMunn I see. What's the error ffmpeg raises?
 
@Alenanno Try changing echo $PATH with pygmentize -V
 
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdftex)
 \write18 enabled.
entering extended mode
(./Prova2.tex

******
Pygments version 2.0.2, (c) 2006-2014 by Georg Brandl.
******
 )
No pages of output.
Transcript written on Prova2.log.
 
@Alenanno So pygmentize can be seen from the shell escape. I don't know what more to say.
 
8:10 PM
@egreg Did you install Pygments from Terminal?
 
@egreg the github issue points to a bad which code.google.com/p/minted/issues/detail?id=75
 
@Alenanno I just did pip install pygmentize --upgrade
 
Ah with pip. I didn't use pip.
But I suppose it makes no difference?
 
@DavidCarlisle That's really an old minted version: I don't think it does which -s any more.
By the way, which -s is legal only on tcsh
And which pygmentize && echo "found" returns found
 
Indeed, there is no such line in minted.sty
 
8:15 PM
@egreg yes, obvious solution: install Windows?
 
@DavidCarlisle lol
 
@DavidCarlisle I have no problem with minted and pygmentize. :P
 
@egreg nor me:-)
 
>_>
@egreg How do I uninstall Pygments?
from Terminal I mean :P
Or can I just reinstall on top?
 
@Alenanno What version of Mac OS X are you running?
 
8:21 PM
10.10.3
I've just installed pip. I'm going to try with that.
 
@Alenanno Well, I'm still on 10.9
 
@egreg Oh
 
@Alenanno I could try on my dad's iMac, but not now.
 
@egreg Thanks. No problem about that.
 
@Alenanno so what happens if you change \immediate\write18{which "#1" && touch "\jobname.aex"} to \immediate\write18{touch "\jobname.aex"}
 
8:32 PM
@DavidCarlisle Where?
 
@Alenanno simpler, in your document after loading minted add \renewcommand{\TestAppExists}[1]{\AppExiststrue}
 
@DavidCarlisle Still the same error.
 
2 hours ago, by David Carlisle
@Alenanno I give up then!
 
8:47 PM
@DavidCarlisle Eheh :(
 
Texlive install script from the website of TeXlive still tries to download version of 2014 ... did I miss something? Isn't it available yet?
 
2
Q: How do I get TL15?

GausslerThis question is extremely localised in time, but I decide to try asking it anyway: On the TeX Live website, it is claimed that TL15 has had an early release. However, if I go to the download page (which, according to the bottom of the page, was last updated in 2014), the Windows installer there ...

 
@Johannes_B: Ah, that's helpful... why isn't this updated on TeXLive site ... grumpy BlackForester
 
@ChristianHupfer takes a while to mirror all that stuff:-)
 
9:06 PM
@DavidCarlisle Yes, apparently. dante.ctan.org/tex-archive/systems/texlive/tlnet seems to be the only mirror which is accepted by install-tl without reporting a version mismatch between requested (2015) and repository version (2014)
 
@ChristianHupfer Don't overload the Dante archive or you'll go to Inferno.
 
@egreg Somehow i like and don't like how that sounds. :-)
 
@egreg He needs his Virgil. :)
 
@egreg: Abandon all hope ;-)
 
@ChristianHupfer yes but they always ask individuals not to use that
 
9:16 PM
@DavidCarlisle I'll wait till tomorrow then
 
@ChristianHupfer if you were desperate you could have obtained it from a pretest mirror any time in last month or so:-)
 
@DavidCarlisle I'll don't buy that pretest TeXLive 2015 -- it's scratched ;-) I am not despaired to that extent
 
@ChristianHupfer A teljes verzió sokkal karcos
 
@DavidCarlisle I forgot my Hungarian phrasebook in my Suaheli (:-P) classroom this evening ;-)
 
@ChristianHupfer you should be better prepared, you never know when to expect the spanish inquisition.
 
9:25 PM
@DavidCarlisle Nobody expects the Spanish inquisition ... with its comfy chair
 
@DavidCarlisle Which of course means “your hovercraft is full of eels”.
 
@egreg Your Hungarian is no better than your Italian, I see.
 
@DavidCarlisle You (i think it was you) have written something about the effects of setting club- and widowpenalty and its real effect on the OR yesterday or somewhere within the last few days. Is there any more verbose thing on site or in any FAQ or ... Can you (or anybody reading this) think of anything?
 
@Johannes_B or me?
 
@DavidCarlisle ;-)
 
9:36 PM
19
A: What are the downsides of \widowpenalty10000 \clubpenalty10000?

David CarlisleThe main downside is that it masks the problem and makes it less likely that you apply a better fix. If you are processing thousands of pages and don't want to hand correct that's a good thing, but if you are just doing a single book or thesis or something, it's better to see them and adjust by h...

 
@DavidCarlisle Ah, thanks. I have seen this yesterday checking the scrbook tag. And there really is a comment by barbara :-)
 
@DavidCarlisle Every Hungarian phrase has to do with hovercrafts and eels, that's well known.
 
9:49 PM
@egreg Il mio aliscafo è pieno di anguille. :)
 
10:03 PM
@PauloCereda La me batana xe pina de bisati.
 
@egreg Wow!
 
@PauloCereda Batana is a typical fisherman's boat with a flat keel; bisato is the name of the eel in our dialect; xe means ”is”; pina is “full”; me is “mine”.
 
@DavidCarlisle @DavidCarlisle Yes, that's my experience as well, although I usually watch the show live of course ;-) Glad you enjoyed it in any case.
 
10:17 PM
@ArthurReutenauer probably the cinema was better choice for an 11 year old: quite a late finish and some of the interval clips probably helped in understanding. (subject matter and language not exactly targeted at an 11 year old english audience:-)
 
@DavidCarlisle Puccini is unsuitable for everybody, not only for 11 year old boys. :P
 
@egreg David should let M play with vim. :)
 
@egreg on his trombone he's playing some real music, I'm sure you would approve:
@PauloCereda do you think @egreg will get to the end ^^^ ?
 
@DavidCarlisle Of course. :)
 
@DavidCarlisle Not beyond the 10 second mark.
 
10:29 PM
@egreg stick to the Puccini:-)
 
10:48 PM
@egreg I manually removed "Pygments-2.0.2-py2.7.egg" from my /Library/Python/2.7/site-packages folder, and then did "sudo pip install Pygments". It installed it and re-added its folders in the path above, but the folders are two (it was one before) and they have different names? I still have the error, but this was peculiar so I wanted to let you know. :D I'll write to the developer anyways to see if he has any suggestions.
 

« first day (1684 days earlier)      last day (1618 days later) »