« first day (1336 days earlier)      last day (1839 days later) » 

1:37 AM
Am I losing it, or is the tooltip when hovering over question titles new?
 
1:57 AM
@Patrick always been there
 
So I am losing it. Wonderful
 
2:08 AM
0
A: using inotify to monitor access to a file

TobiasAccording to Gilles on Super User: Simple, using inotifywait (install your distribution's inotify-tools package): while inotifywait -e close_write myfile.py; do ./myfile.py; done This has a big limitation: if some program replaces myfile.py with a different file, rather than writing to...

“It's simple but has two important issues: Events may be missed (all events in the loop) and initialization of inotifywait is done each time which makes this solution slower for large recursive folders.” – Wernight (Fixing that post is on my todo list. Don't hold your breath.) — Gilles 24 secs ago
neat, I get to downvote one of my posts by proxy!
 
@Gilles flags
 
 
1 hour later…
3:21 AM
-15 points in meta page. That's something new :)
-15
A: How to handle people impersonating other people by choosing the same display name

Evan CarrollThis issue could be resolved if there was a UNIQUE constraint in the database on display names: http://dev.mysql.com/doc/refman/4.1/en/constraint-primary-key.html

 
3:36 AM
@Ramesh Not really. First, its from 2010. Second, I'm pretty sure I could find a much lower score...
 
@derobert, I found -157 votes for a question,
This question seems so interesting. May be we need one like this for our site too. :)
366
Q: Jon Skeet Facts

Bill the LizardI'm looking for Chuck Norris Facts style answers. In case anyone is curious, this question was inspired by Jon's own comment to this question. EDIT: If you're into cryptography, you may enjoy these facts. Now with official sanction from the powers that be!

 
That's quite amazing.
 
This Stephane Chazelas guy is rather impressive.
 
-194
A: Can we have the ability to retract a close vote before it closes?

Jeff Atwooddeclining -- you can always cast a reopen vote if the post gets closed. Also note that all close votes automatically expire after two days. (and for that matter reopen votes, or any other vote that attempts to reach a threshold -- otherwise, over an absurdly long period of time, say 10 years, e...

... there we go, meta answer with -194.
Worst answer ever given on meta, so far as I can find.
:-P
 
3:42 AM
the tty supports non-western characters?
 
@Braiam most everyone uses the framebuffer terminal now, I think
 
@Braiam Using the text console, it's supported but limited. See unicode_start(1) and consolechars(8).
Incidentally, the best unicode support I've encountered in an x terminal emulator is rxvt-unicode aka urxvt.
 
@etherfish well, I'm asking about the TTY... apparently I have to use console-setup to change the input anyways...
 
@derobert, is this solution correct?
0
A: What is the Linux command to display how many file names in the directory end in two digits

RameshWithout wc -l if you want you can use the tree command as below. tree -P "*[0-9][0-9]" foldername/ Testing Inside one of my folders, I created 3 files that ends with double digits. First, I issue ls to see all the files. bash-3.2$ ls 1aga21 abcd kshexp.ksh new.txt temp temp1 temp12...

I mean the edit part based on your comment to the question.
 
4:06 AM
@Ramesh No idea, I've never used the tree command. In fact, I don't even have one...
 
4:35 AM
@Braiam For what it's worth, there is a separation between the tty and the console driver. For example, fbcon and vt are different. It may be very relevant to what you're trying to do to be concious of which one you're using. A lot of distros now use fbcon by default. I find it slow and obnoxious, so I use vt driver instead. The fbcon driver supports all the unicode glyphs in the loaded font.
@Braiam I just discovered a novel named program named vt-is-UTF8(1) that can be used to identify if the console is running in unicode mode or not.
 
slm
5:04 AM
@Gilles yeah he's pretty prolific guy on the interwebs. I find him all over the place fixing and correcting ppl and things....
 
 
4 hours later…
8:45 AM
@etherfish - haven't heard of that one, but I believe luit can do the same, and if you've got X and xterm installed you've probably got it too. What it definitely can do, however, is translate UTF-8 in-stream for a terminal device that doesn't support it. It's pretty cool.
 
 
2 hours later…
10:21 AM
@mikeserv wow, thanks for the luit tip. I had never heard of it. I can't say enough good things about rxvt-unicode, incidentally. The only downside I've encountered is that it uses perl for it's embedded, optional scripting. software.schmorp.de/pkg/rxvt-unicode.html
 
@etherfish How is that a downside? Sounds like an advantage to me.
 
I like it - but I haven't used it since I switched to Terminology.
It's amazing.
 
I still remember being blown-away when I first ran Enlightenment 13.3 on my old pent200 + matrox millenium ii over 15 years ago.
 
For the console, maybe have a look at kmscon - I love it. ptys and multi-seat in framebuffer.
Yeah - and since (is it Samsung?) got behind the e-project, they've been pumping out updates like crazt.
 
So, looking at the Terminology features, the two that surprise me are the, A, OpenGL/GL-ES rendering and "Can stream media from URLs." (what on earth is that?) What prompted you to switch to it?
 
10:26 AM
@terdon - I agree. Definite plus.
Well...
 
I don't know perl is all. I'd have preferred python. But, that's a personal preference. I still love and enjoy rxvt-unicode, perl interpreter and all.
 
I don't either, but any scripting language backing a shell can't hurt.
This is how I set my background:
`printf '\033}bp%s\000' \
'http://hdwalldesktops.com/wp-content/uploads/2014/02/background-backgrounds-high-resolution-abstract-picture-background-wallpaper.jpg'`
 
Terminal. My shell is zsh. :)
 
My bad. Very true.
I use it too most of the time, but all of the scripting I try to do in dash.
1
A: Can I see images and watch movies inside the terminal emulator

mikeservTerminology is what you want. For instance - I want to change the background of my terminal? printf '\033}bp%s\000' \ 'http://hdwalldesktops.com/wp-content/uploads/2014/02/background-backgrounds-high-resolution-abstract-picture-background-wallpaper.jpg' What does it do? It emulates a s...

 
Why dash? (Out of curiosity.)
 
10:31 AM
Fast. And I learn more.
Two decades - (three now?) ago Unix imploded because of all of the different implementations and implementation-specific options - not to mention lawsuits.
I think it can regain supremacy - especially now that Microsoft has imploded. But it won't do it via repeated mistakes. And anyway, soapbox aside, it's what I know.
 
Fair enough. Re: different implementations, variants, and options.. I've managed to intentionally limit the environments I work on to those that use gnu coreutils, etc. :)
What you know is a great reason.
I was asking because, as they say, "You can learn something new from anyone." And, your Terminology, luit, etc. comments were spot on.
 
That's probably the way it will go, but the gnu guys are bleedingheart goodguys, the posix folks have money.
So I try to hedge my bets when I can.
Hey, I say that too!
That was a touch of humor, by the way, though I do say it.
And I wish I did know more about zsh internals - the stuff that really interests me about it are the built-in curses and tcp interfaces. You could write your own window manager in native zsh, connect to it remotely and do compile the script into a binary - at least that's what I think the native compiler does.
 
wow, so, from your linked question above - the dude that mention pysixel. I'd never heard of sixel. madness. I remember the old tek graphics interpreter code in xterm, but not sixel.
 
Yeah, that was Graham.
Look at his profile - he's got a lot of good answers.
 
zsh is similar to vim in many ways. Lots of clever shortcuts and details littered here and there. For example, to, get a list of numbers from 0 to 10, you just use {0..10} - but, if you need them 0 padded, just do {00..10} and you get 00 01 02 03 .. etc.
The chore is learning and remembering them.
 
10:47 AM
I know. I only know a handful of commands very well in total, all of the shell specific stuff is too daunting for me yet, I guess. But what I have found is sticking to basics tends to give me a different avenue toward solutions than my betters sometimes have.
And I meant Graeme - sorry for Americanizing your name, guy, if you're watching.
I linked the terminology answer though because of the YouTube links at top. That's why I switched.
 
@etherfish That one is not restricted to zsh, bash does the same.
 
11:03 AM
@terdon is that new? I remember using it as an example before. Well, if anything, I'm glad bash supports it as well. It's a useful feature.
 
@etherfish They may well have taken it from zsh. I seem to recall it came with bash 4 but that's just a vague impression. For all I know, it's been there for years.
 
 
3 hours later…
1:37 PM
@Patrick It happens to us all.
 
1:56 PM
May anyone take a look here? It's about packaging in Debian from the scratch...
 
2:35 PM
@nullgeppetto you generally need to build in a clean chroot or other custom minimal build environment. see sbuild, pbuilder, or similar.
@nullgeppetto I'd check out the hello package in Debian. apt-get source hello.
@Seth so, how do you like being a AU maintainer?
 
I've got to run at the moment, but I'll answer that later :)
 
@FaheemMitha AU maintainer? you mean AU moderator?
 
@Braiam damn, i keep getting that wrong.
my excuse that I had a more than averagely tiresome day in this best of all possible worlds. I think I've been more than usually out of it today - I misread a figure as being 10 times larger than it actually was.
@Seth Ok, thanks. I think the people here who are thinking of applying as mods would be interested.
As you might know, this site is having a mod election shortly.
 
3:00 PM
Is it possible to retract my downvote without upvoting?
 
yeah
 
How to do it? I downvoted a question thinking to ask the OP to fix the format. But I fixed the format rather. So, I just clicked on the upvote again and it went to +1.
 
click again
 
ok that works. Thanks!
 
3:29 PM
Wow, another answer migrated to SO...
1
Q: How to see if I connected to an ephemeral port?

d33tahI'm working on a port scanner that uses Linux connect system call and when I'm scanning localhost, sometimes I get false positives due to kernel allocating me the source port for the connection that is equal to the destination port. Is there a way to tell if

I'm beginning to think all our 3k users have read neither what can I ask nor meta.
 
@derobert, that's sad. But I always get confused on which questions belong to here, AU and superuser. They are pretty close.
 
(Meta would of course be this and this)
@Ramesh A lot of questions could be on all three...
 
@derobert, yeah. As long as the questions are answered, they can belong anywhere :)
 
btw, someone doesn't want you to read 20k @derobert :P
 
@derobert, I always prefer to vote to close as long as there is some vote on the question by power users :)
 
3:37 PM
Topic-wise, AskUbuntu is mostly a subset of us. (We'd probably consider some questions about Ubuntu the organization off-topic here). We're mostly a subset of Superuser (though they'd probably consider our scripting questions off-topic).
@Braiam Aha! That's how they protect their spots on the top rep list :-P
@Ramesh you really oughtn't do that...
 
I should upvote my post more so @Ramesh upvotes them :S
 
@derobert, you are right. But I tend to be supportive in maintaining our site :)
@Braiam, sure thing.
 
@Braiam Who voted isn't AFAIK public, so you could just go around claiming all your score=1 answers are either Gilles or slm upvoting, and your score=2 answers are both. Should gain you a lot of Ramesh-rep :-/
 
@derobert darn, stop spoiling my evil plans about how to get rep
 
@Ramesh Not trying to pick on you (or anyone for that matter).
But it appears that we're (as a site) confused about what's on topic...
 
4:03 PM
@derobert well, that one fits both here and on Stack Overflow. It might get better answers on Stack Overflow though. I wouldn't have closed it personally but it doesn't shock me either.
 
@terdon I thought that when a question fits on several sites, we generally defer to the OP's judgement of where they want it. Especially since I think at some point someone grabbed data and checked that often the OP loses the question when its migrated
 
@derobert True and that shouldn't have been migrated anyway, too crap. "s there a way to tell if", if what?
 
Yeah. It needs some editing.
 
I am guessing that not everyone voted to migrate. Can't see it now but there were probably various close reasons used. Especially since Gilles, slm and Anthon were involved, all of whom know the scope quite well.
 
Yeah. Too bad the site doesn't show all the reasons. Though I think if they used a custom reason, the comment would remain (unless they deleted it, of course).
Actually, if the three of them did not vote to migrate, I don't think it'd be migrated...
I don't remember the threshold to migrate, its at least 3/5, if not 4/5.
 
4:11 PM
No idea. I'm guessing someone first voted to close as unclear (which it is, really) and then someone else as off topic=> so and the rest followed suit.
 
@terdon Yeah. Not sure how that is logged. I think they're in order though, so Gilles probably voted first.
 
my priorities when closing something are normally: unclear -> too broad -> opinion based -> off topic -> duplicated. I evaluate a question in that order, that's why is weird seeing me voting as duplicated
 
Which is why I'm guessing he voted as unclear.
 
btw forgot to paste this here:
in Tavern on the Meta on Meta Stack Exchange Chat, 15 hours ago, by Shog9
It's gotta be done, but... Don't spend all your time on it.
for anyone that wants to run as mod ^
in Tavern on the Meta on Meta Stack Exchange Chat, 15 hours ago, by Shog9
You'll just end up regretting it.
 
Hah, yeah. It'll be boring, except when a spammer shows up, and I get to be drunk on power. Presuming I win the election, of course.
 
4:38 PM
@derobert you'd never make it as a politician. You're supposed to show your true colors after you win, not before :-)
 
4:57 PM
@derobert oh yes.
@Patrick :-)
 
@Patrick I'll take "you'd never make it as a politician" as a compliment.
 
@derobert Yes, you're just not slimy enough. :-)
 
I mean, I'd have been worried if you suggested (for example) I'd be a good fit for Congress.
 
@derobert you're too productive to fit in with congress
 
@Patrick Congress is very productive. They, for example, are experts at producing campaign contributions.
And corruption!
 
5:02 PM
@Patrick don't worry, is scientifically demonstrated that users start to answer less questions once they become mods
 
@derobert So, will you take bribes? "Close this question for 20 rep".
 
@Patrick Good question. Though I think actual corrupt people want something different from Imaginary Internet Points.
 
@Patrick Of course not. Bribes are illegal. You first need to form a RepSuperPAC, and then you can contribute unlimited rep to my mod election campaign, provided of course you don't officially coordinate it with me.
 
@FaheemMitha Those people don't hang out on SX :-)
 
And the fact that I closed the question would be a pure coincidence.
 
5:05 PM
@Patrick Probably true.
@derobert It sounds like you have it figured out.
 
@FaheemMitha Exactly. And my hypothetical competitors slm and terdon haven't, which is why you should vote for me :-P
 
@Patrick Why would you want a question closed?
@derobert :-)
 
@FaheemMitha Probably something boring, like it was about the wrong editor.
 
so three contestants so far for the election?
 
@Ramesh There are? Has anything been actually posted?
 
5:12 PM
Nopes. I am saying just by looking at the chat window.
@Braiam, are you contesting?
 
Nominations should start Monday. At least, that's what the 6-star comment says.
I think the normal timing is something around a week
 
I think its a week of nominations, then a week for each successive round. It will probably take us a couple of weeks.
Damn iPad, can't edit to fix the typo.
 
@terdon Edit last message is in the mobile menu
 
@terdon <insert here rant about mobile chat>
 
Time frames for election stages are in:
 
5:24 PM
And where the hell is the mobile menu then? Grrrr
 
@terdon There is a menu button on the bottom left, under the text (message) entry box
 
Ah, there it is, right the only button on the screen with Menu written on it.
 
Is it gonna be like House of cards? :P
 
5:47 PM
Why a 3 TB partition when formatted in a Ubuntu 8.10 system recognizes only 800 GB? Is it because of file system type or the partition table limitation?
 
@Ramesh Details?
ext2/3/4 have supported >1TB filesystems for a while.
 
@Ramesh - GPT vs mbr.
 
@derobert, I had a 3TB external HDD. I formatted it in RHEL6 system. Now, when I connected to Ubuntu 8.10 system, it did not recognize it.
 
Yeyyy, I changed a disk and now it boots in emergency mode
 
@Ramesh Ok, that's an entirely different question....
 
5:52 PM
sounds like a good question for the site :-)
 
@Patrick, sure. will post it :)
 
@Ramesh Not recognizing it could be anything. Like, for example, using ext4 features that the old Ubuntu didn't know about. Or the old Ubuntu or the hardware not supporting large disks. Or...
Indeed, as @Patrick points out, questions go on the site.
 
@derobert, yeah. I formatted it as ext3 file system.
I will do it now.
 
ext3 gained features as well
 
People, do you know of a magic tool that tries to automatically fix whatever booting problems I may have?
 
5:53 PM
A master boot record (MBR) is a special type of boot sector at the very beginning of partitioned computer mass storage devices like fixed disks or removable drives intended for use with IBM PC-compatible systems and beyond. The concept of MBRs was publicly introduced in 1983 with PC DOS 2.0. The MBR holds the information on how the logical partitions, containing file systems, are organized on that medium. Besides that, the MBR also contains executable code to function as a loader for the installed operating system—usually by passing control over to the loader's second stage, or in conjun...
 
@mikeserv, I believe it has something to do with GPT and MBR only. But I will post it as a question with more relevant details. :)
 
@Rojo Hiring a sysadmin at careers.SE? :-P
@Rojo That's the only one that magically does it. Other than that, post a question.
 
Any disk greater than 2tb needs a gpt partition table. And if your 800mb output is coming from ... gparted ... well, I've been there.
 
The magic tool could be the power switch. To turn off the machine :p
 
@mikeserv Only if it has 512-byte sectors. In theory, if it actually reported the 4k sectors it has, you could use 16TB disks with MBR partitioning.
@mikeserv but its definitely possible that ancient Ubuntu doesn't understand the GPT partition table that RHEL put on there
 
5:58 PM
off to lunch. Will post the question after lunch :)
 
That's what I meant by been there. I learned the difference the hard way with an ubuntu boot disk and 2tbs of video...
 
Blahh
 
That was my last ubuntu boot disk, by the way.
 
@mikeserv Wow, did it actually destroy the disk, not just fail to read it?!
 
No it failed to read it. And I had no idea why.
It only displayed an empty 800mb partition.
That was a couple years ago.
 
6:03 PM
It should be possible to read the data use a loop device, btw. Or device-mapper. You just need to map the partition somehow.
 
I'm surprised I have any hair left - I had no idea what was going on, but for several hours I thought it destroyed it.
dm is a good idea.
 
I think dm existed back then... If not, loopback devices surely did.
 
You can get a pretty simple idea of the nature of the problem by just running gdisk on it.
Certainly they did - but I had no idea what was going on.
And ubuntu wasn't helping any.
 
@mikeserv Indeed. And that'd definitely be an unpleasant few hours wondering WTF happened to my data.
 
Yeah. All 2tbs.
 
6:06 PM
I'm surprised 8.10 doesn't have GPT support, though. Seems recent enough.
 
Anyway, I managed some crazy octopus wire situation with every spare drive I could acquire at the office and wound up with all the data spread out over 5 or 6 of them by the next day.
 
@mikeserv hah, yeah, dm would have been much eaiser :-P
 
I don't think it did til 10 or so, but that might be wrong. I dunno. It was my last ubuntu boot disk. Agreed. But you gotta learn somehow, I guess.
I like other peoples' problems a lot more.
 
I'm not sure when I first had to use GPT on a server, because the RAID array exceeded 2TB.
I guess maybe it was post-2008.
I read the Ubuntu version wrong first time, thinking 'august 2010' instead of 'october 2008'
 
Ah right.
 
6:11 PM
Dear Ubuntu,

Next time, please use 4-digit years like sane people. Thanks.
 
They'll just add that to the bug tracker and get right on it.
 
Well, they need to change something soon, as they've almost used up the alphabet.
 
Maybe they'll start iterating the second letter.
 
They never actually did A or C, I believe. And they've already done W. And they already used H twice. And they did B out of order. This, come to think of it, is about the right amount of buggyness for your typical Ubuntu release, so it fits perfectly.
Maybe they'll do numbers next. 1llustrious 1guana, anyone?
(or should that be 1llu5tr10u5 1gu4n4)?
 
...anyone...?
 
6:17 PM
@derobert LTS release in collaboration with backtrack.. er.. kali!
 
@casey Hah, that'd be perfect.
Though I don't think actual security people write like that, except as a joke. Maybe in collaboration with Gentoo?
 
most people running kali dont seem to be security people, if the ones I see posting about it are representative users anyway
 
True.
 
@Rojo - I've never tried it, and I don't recommend it not only for that reason but also because the idea sounds a little far-fetched, but I've seen a lot of people referring to some ubuntu thing called bootfix script or something like that.
 
even the "super secret hacking lab" at penn state (the one whose walls are all glass with big floor to ceiling blackout curtains on the inside) are using something not-kali iirc
 
6:22 PM
Boot-Repair I guess.
 
@mikeserv I hate that thing...
 
and i think it has a better name actually, like "penetration testing simulation lab"
 
makes people thing that repairing boot is easy
 
I believe you. I do too and this is the closest I've ever been to it.
 
@mikeserv Thanks, I'll take a careful look
 
6:24 PM
Well, often times booting is pretty easy - a lot easier than grub anyway - but this is just... I dunno... way too many layers of abstraction, I think.
 
Personally, I've always just used a debian-installer disk in recovery mode, and then chroot in and run grub, etc. from there.
 
grub (even grub2) isn't so bad if you keep a minimal config such that you can actually follow and understand what its doing
 
I wish I could figure it out - it's pretty awesome all of the stuff it can do. But, I just rEFInd generally.
 
I haven't actually had grub2 break for a while, at least in any way that wasn't a silly mistake on my part (e.g., didn't bother installing grub on the 2nd disk in a mirror, of course the Debian scripts take care of that now)
 
My grub2 config is literally my grub-legacy config with the necessary keywords changed
 
6:27 PM
I mostly just use the Debian default grub2 config.
 
@derobert I would probably do something like that but funky setup needs a bit of help
 
@casey You must have a really funky setup, because those scripts handle a lot of weirdness.
 
Yeah. I was watching some video - I think it was Poettering - talking about how Redhat uses their own grub config - mostly just grub legacy stuff - he said that the grub2 config script is a script that writes a script.
 
since boot/root is on a raid mirror, I have boot entries for both disks in the mirror so I could in theory boot with either half of the array down
 
@casey ... and that'd be a wrong config. grub2 understands mdadm mirrors. You should boot off the mirror.
 
6:29 PM
meh, for me grub works the way I expect it to work... unless I expect it to be so smart
 
I think grub2 even understands "complicated" RAID geometries like RAID5 now.
 
@derobert I know. last time I let grub2 try though it renumbered all my md arrays and caused quite a bit of problems. My setup is "legacy" at this point (2011 install) and it works, so I don't mess with that part of it
 
@casey Yeah, a lot of wisdom behind if it isn't broken...
 
But it is. It's smarter than me anyway. Do info grub - it's amazing. So I rEFInd. I can usually drop a file in a folder without issue.
 
menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-a121fba0-0471-426f-9ef6-dc88d0807d52' {
        load_video
        insmod gzio
        insmod part_msdos
        insmod part_msdos
        insmod part_msdos
        insmod part_msdos
        insmod diskfilter
        insmod mdraid09
        insmod ext2
        set root='mduuid/a1b8efea2114fd9928a5f279815d333e'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint='mduuid/a1b8efea2114fd9928a5f279815d333e'  187cd
... that's what Debian generates currently for the main boot entry.It loads part_msdos a few too many times (harmless), but manages to boot off the RAID.
 
6:33 PM
@derobert mm... why repeating insmod?
oh, maybe once for each disk...?
 
@Braiam It's harmless, so the script takes the dumb approach of just repeating the line for each disk
 
@derobert yep. Its somewhat funny though knowing how much trouble I went to setup this layered raid/lvm stuff in 2011, all by hand with some trial and error, had issues with my eventual update to grub2 and more (still not 100% resolved) errors with a transition to systemd. And today I could do a fresh gentoo install and have all of that with no trouble at all, and 100% proper to current best practices.
 
@casey I hate to tell you, that all just worked in Debian back then :-P
 
@derobert Oh, I know. I've been running lvm since linux supported it and mdraid off and on. I had other reasons for gentoo but my experience using it all in debian is how I got it working there.
 
@casey - if you mean current systemd best practices those are never current or best for very long.
 
6:36 PM
@mikeserv tell me about it... That is one transition I really wish I had not decided "I have a day to kill...."
 
Yeah, in that day you might it make it through the man pages.
 
I could un-transition, but right now my system boots, so I don't really care to mess with it more
 
When I set up the laptop for that pool project, I went with systemd, on a fresh install. I tried converting one fairly simple system over, and that got weird issues. Haven't tried any more.
 
Better stay where you are... It's really cool too - systemd is pretty awesome.
 
I've been happy with systemd on that pool laptop.
 
6:37 PM
But what maniac came up with their plain English scripting language?
It's the whole dictionary...
 
@derobert thats the feeling I get. If I wiped this system and reinstalled the base, I think it would be in a much better state than what I have now
I may do that... after I make a fresh backup onto my 8tb e-sata array
 
I plan to move another one over when I get a chance. I look forward to never fighting sysv init again to get local fs -> ethernet -> bridge -> some remote fs -> openvpn -> other remote fs in the right order again.
 
Gentoo does have that other thing that seems ok... I don't remember what it's called though...
 
openrc
 
It's their own init.
 
6:40 PM
Yes. Some people wanted Debian to adopt it.
 
I considered that after writing my first unit file - which wound up being 4 unit files. But just getting through those 4 gave me a vested interest I guess.
 
wait, writing a unit file sold me on systemd. Much nicer than a init script!
 
Maybe - but at least the init script was a single file and put in a single folder.
 
so is the unit file
 
systemd has this whole maze of dependencies. You didn't have to write supporting units?
 
6:43 PM
nope, I was only starting one daemon
a webserver to serve the pool management app
 
Any of you ever deal with Charter cable internet?
 
Oh - now that it is very good at. This is a pretty good article on the whole thing and is close to what my experience was last year as well when setting up bcache: lwn.net/Articles/584175
Yeah - I had Charter in MO and HI - wait - is Roadrunner Charter? I don't think so. Just MO then. But it was years ago.
 
I got an automated email from then claiming a suspected AUP violation for "hacking", so I called them and they would only give me the most vague, non-helpful information on why they sent that email.
 
I got one of those from cox once. So I switched to leech-only on the public trackers.
And I only use one private tracker.
 
@casey Hah, someone probably sent them a stupid complaint.
Hmmm, going through the new package list, this one looks interesting:
p xcape <none> 1.1-1
Configure modifier keys to act as other keys when pressed and released
xcape allows you to use a modifier key as another key when pressed and released
on its own. Note that it is slightly slower than pressing the original key,
because the pressed event does not occur until the key is released. The
default behaviour is to generate the Escape key when Left Control is pressed
 
6:51 PM
@derobert weird chars there
 
Yeah, copy & paste got some box drawing characters from the terminal
 
someone should really send me a .5TB disk :/
 
@Braiam what for?
 
@casey lets say I suck at partition schemes and now I can only use 70% of my hdd real capacity :(
 
LVM!
 
7:05 PM
yeah, when I get a new disk I will use it
 
For the record, I would like to go back in time and lick some sense into my self 8 years ago when I started throwing code for all a certain customers domains into one monstrous subversion repo.
10k commits and 5 gigs of history later I have just spent all day splitting out projects into 27 separate git repos with semi-sane histories. It doesn't help that my branching scheme in subversion appears to have been completely arbitrary and the methods I used to merge them changed every couple years.
 
@Caleb how can you lick some sense? I know you can lick a plane but "some sense"
:P
 
which plane?
 
@Braiam The technique involves a whip; 'nough said?
 
@Caleb O_o
 
7:08 PM
Whips do have tongues. Just say'in.
 
@Caleb We were all young and foolish once. Sometimes we grow out of it.
Hi, how are you? Long time no see.
 
@FaheemMitha If only it was just once.
@FaheemMitha Swamped, but alright all things considered.
 
@Caleb Good to know. You haven't been around you much recently.
 
7:28 PM
Am I missing something here? There is no mount point specified and that is the reason for the folders not showing up right?
sudo mount //192.168.0.2/radio music -o user=RaspberryPi
 
@Ramesh There is a mount point there: music.
But it's a relative path.
 
@Caleb, yeah you are right. my bad. I did not notice it.
 
7:51 PM
steps to reproduce: ha ha.
 
8:27 PM
@Ramesh well it was almost a decade ago
I remember when I asked my dad to spend a few hundred dollars for a 300 MB disk
He declined and I got a 20 MB disk instead
and that was a 100% improvement from what I had
 
The first system I got was having 40 GB hd and it was pretty costly at that time.
 
The first system I got to play with had no disk, just a boot rom and 64 KB RAM
 
still the BIOS screen looks like this only.
:)
 
that wasn't the bios, that was the OS :)
 
9:12 PM
That reminds me of this:
I'm sure some of you guys would enjoy that :)
 
9:48 PM
@casey - I had a similar experience. My dad caved when the pirated beta Win 95 I installed after downloading it from a local bbs onto our double-spaced 128MB disk corrupted the disk's partition table to the point that we had to perform a low-level format in BIOS.
 
@Seth Wow, I wonder how long it'd take me to remember how to use one of those... I sure don't remember much Apple II BASIC.
10 PRINT "HELLO WORLD"
20 GOTO 10
or did Apple II basic not have quotes? Don't recall :-(
 
Win 95's official release saw the advent of Drivespace packaged with DOS 7 - if only we'd known...
Of course, if we had, I might never have found room to unarj that copy of Jazz Jackrabbit I downloaded after Win95...
 
10:21 PM
win95 is what drove me to linux and where I discovered the power of a real command interpreter
I was happy to start win 3.1 when I cared to, but absolutely rejected the idea of booting into it that win95 introduced.
primarily because none of the games I played cared for the presence of windows. I just needed DOS and my various tuned command.sys and autoexec.bat for each game :)
 
None of them worked in Win95. himem was an asshole even before it - at least the id releases typically managed their own memory - but not alongside any settings in those two for Win's memory management.
Alas, I didn't discover linux for many years to come. But I did play Jazz Jackrabbit.
But it was those things that drove me - well, those things and x,zmodem - to learn the cli.
 
@mikeserv yep, loved id with its own MM and protected mode as part of the of the program
 
ditto that.
All glorious 8mbs of it.
I tried Legend of the Green Dragon a couple years ago - there were like 40,000 players. I went back a second day to play through my turns - but not a third. I remember trying to imagine what a bbs host handling that kind of load would look like. It looked like a fat paycheck for USR, I thought. And the phone company, I guess.
 
10:50 PM
@Seth - That video is hilarious. "I don't get it. I also don't get the 1970s"
 
11:29 PM
@FaheemMitha I have answered your question, but the answer turned out to be a bit... long. So I've posted it here.
@mikeserv I know right. I laughed at that part too.
Does anyone get the impression here that the OP wants to only mount a specific drive?
2
Q: How to automatically mount an USB device on plugin-time on an already running system?

Foo BarI know how to use /etc/fstab to automatically mount devices on boot or when doing sudo mount -a, which works perfectly fine. For example, here is my current line for my device UUID=B864-497A /media/usbstick vfat defaults,users,noatime,nodiratime,umask=000 0 0 How do I achieve automatic mountin...

I answered the question anyway, but somehow I feel he only wants to auto mount that particular one.
 
11:53 PM
@Seth - I think UUID=B864-497A says it all.
 

« first day (1336 days earlier)      last day (1839 days later) »