« first day (3498 days earlier)      last day (528 days later) » 

12:07 AM
REFRESH! There are 7625 unanswered questions (90.0114 answered)
 
 
2 hours later…
1:41 AM
If you have answered the questions, but are looking for code critique, you may want to ask at codereview.stackexchange.com. — Chris 57 secs ago
 
2:13 AM
0
Q: Chain of Responsibility pattern for updating coordinates of moving objects

prestokeysPrimaryCoordinates are the coordinates in meters. SecondaryCoordinates are the coordinates in decimeters, with the origin located at the primary coordinates. TertiaryCoordinates are the coordinates in cm, with the origin at the secondary coordinates. The Position of an object, depending on its...

 
2:47 AM
@pacmaninbw I'll let you handle your comment
See new version — MYK 10 hours ago
 
3:30 AM
 
 
2 hours later…
5:32 AM
Monking
@pacmaninbw Either the question should be closed so it can be fixed, or it should stay as-is. Telling the user the question is not up to standards but not giving them room to improve it is giving them the option between a rock and a hard place.
 
Monking
 
If the question wasn't ready for review yet, it's possible the answers were premature.
 
 
2 hours later…
7:15 AM
0
Q: Does this Java projects follow the MVC pattern?

David MooreI am writing the Restaurant Management homework which must be following the MVC pattern. My Menu model has two parts: Drink menu and Food menu. With Food menu, it separates into three different types of menu: Breakfast, Lunch and Dinner menu. About the Drink menu, it also divide into two differen...

 
 
5 hours later…
11:45 AM
This is more related to codereview.stackexchange.comEmil 39 secs ago
@Emil I'm not sure about that, OP says his code is not working ("I am getting an error on the read from file"). CodeReview is for working code. — matszwecja 38 secs ago
 
12:17 PM
0
Q: Pllow plugin adding support for the QOI image format

gazohPillow is a popular library for handling images in Python. My code adds support for the QOI image format to Pillow. Aside from loading and saving QOI images, my goal was to write a streaming decoder and encoder deriving from PIL.ImageFile.PyDecoder and PIL.ImageFile.PyEncoder respectively, which,...

 
 
1 hour later…
1:32 PM
Is there a reason you want to simplify it? If you don't have actual issue with it this is probably off-topic and might be more suitable for codereview.stackexchange.com — Yevhen Kuzmovych just now
 
2:09 PM
@Mast @Peilonrayz I have changed my comments the question is closed.
 
I'm not sure what I have to do with that section of the page.
 
@Peilonrayz You told me to take care of the comments.
Rather my comments
@Mast The answers were premature, it was originally voted down.
 
Since SE didn't ping me when MYK responded, I notified you that your comment on the answer could be invalid.
 
Ah.
I have removed my roll back as well.
 
2:46 PM
Is this a code review question? Those are mostly off-topic here. Why do you want to replace map/filter with reduce? Why are you writing the no-op filter(l => l) function? You have various syntax and compiler errors in this code but you don't seem to be asking about them, so it's hard to know how to proceed. — jcalz 42 secs ago
 
3:44 PM
Questions about refactoring working code are not on-topic for Stack Overflow. It might be on-topic for Code Review, but check their rules before posting: codereview.stackexchange.comMichael 33 secs ago
 
@Michael when suggesting users post on CR it would be great if there was also a suggestion like "Please read the relevant help center pages like 'What topics can I ask about here?' and 'How do I ask a good question?". In the current form the code above would likely be closed as off-topic because it is missing context. — Sᴀᴍ Onᴇᴌᴀ 12 secs ago
If your code works as expected but you need some input for refactoring then please post this question on the codereview site. — Peter Csala 16 secs ago
 
4:05 PM
0
Q: How to write this code snippet cleaner with less returns

inconnuI have the following code: val resultA = getA() val resultB = getB() if (resultA.size > 1) { logger.error { "Result A is too big." } return Status.Error } else if (resultB != true) { logger.info { "Result B is false." } return Status...

 
Before you post at Code Review, make sure to read A guide to Code Review for Stack Overflow users, as some things are done differently over there - e.g. question titles should simply say what the code does, as the question is always, "How can I improve this?". Be sure that the code works correctly; include your unit tests if possible. You'll likely get some suggestions on making it more efficient, easier to read, and better tested. — Toby Speight 45 secs ago
@GuruStron the question needs work before it's suited to Code Review. You should have pointed the asker at A guide to Code Review for Stack Overflow users, as some things are done differently over there - e.g. we need a good description of the purpose of the code to give context, and question titles should simply say what the code does (the question is always, "How can I improve this?"). It's important that the code works correctly; include the unit tests if possible. — Toby Speight 12 secs ago
@inconnu, Before you post at Code Review, make sure to read A guide to Code Review for Stack Overflow users, as some things are done differently over there - e.g. question titles should simply say what the code does, as the question is always, "How can I improve this?". Be sure that the code works correctly; include your unit tests if possible. You'll likely get some suggestions on making it more efficient, easier to read, and better tested. — Toby Speight 36 secs ago
 
5:13 PM
If only people would take good advice.
And read the fr*!#@$ help center.
Or meta. Or make any attempt at all.
 
5:41 PM
Monking
 
If you want help improving working code, you should post the complete working code on CodeReview.SE. If you do decide to do so, please delete the question here. — NathanOliver 21 secs ago
 
 
1 hour later…
7:54 PM
0
Q: B spline formula interpreted in R

su sahini have this formula for a quadratic spline which can be defined in terms of the truncated polynomials. Bδ(x) = 1/δ^2 * ((x−0)^2+ −3(x−δ)^2+ +3(x−2δ)^2+ −(x−3δ)^2+) I was wondering if someone could explain me how to interpret this and if it is possible to calculate without using any libraries. Suc...

0
Q: Show entire current line in popup over current line in no-wrap text

EnlicoEventually, I've come up with a solution to a question I asked on vi.stackexchange. Here I come to review it. My intention is to show, everytime the cursor is not moved, the whole text of the current line over the current line in a popup that just don't cares about adjacent windows. This clearly ...

 
8:20 PM
0
Q: Cousins in binary tree

C4PSo i'm doing leetcode #993 and i tried writing a code for it but i get a wrong answer for some reason. question: Given the root of a binary tree with unique values and the values of two different nodes of the tree x and y, return true if the nodes corresponding to the values x and y in the tree ...

0
Q: Configuring SQLite3 for best efficiency as a persistent cache

O. JonesI'm using SQLite3, via php's extension module, to create a persistent object cache for WordPress. It's intended for use on modestly sized sites that don't have access to redis or memcached. Why use this? To give smaller WordPress installations access to similar performance-enhancing tech as the ...

0
Q: Component-wise double precision multiplication in Go

SiennaD.I'm working on porting the bullet3 physics engine to Go to learn more about physics simulations. I'm working through some of the convex hull computing code, and I've reached a component-wise, double precision multiplication class in the original C++ code. I'm not familiar with this type of low-le...

0
Q: Finding children and grand-children (managed Employees) from a List

RandyIn my CacheManager I have this code that parses AllEmployees to get a list of employees that you manage: internal List<EmployeeInfo> GetManagedEmployees(string id) { return AllEmployeeList.Values.Where(x => x.ManagerId == id && !x.IsDeleted && !x.IsNonState).ToList(); } Then I call that meth...

 
8:45 PM
0
Q: Cleaner way to work with 2D arrays of `Maybe`s?

naiveaiI'm solving the Advent of Code in Haskell, and I started on Day 1. While the problem itself is fairly simple, I found it a little difficult to figure out how to parse the input format, which is a list of integers separated by blank lines, if I wanted to handle errors properly. 1 2 3 4 5 6 7 8 ...

 
Right, it's advent of code time again.
 
9:36 PM
0
Q: Display Knight's Tour via Tkinter by changing button colors (location) through time

cajunlatThe below code goes through the Knight's Tour (touching every square once); however, I want to display the results graphically using tkinter. No matter how I adjust the code, the board displays with all the squares colored. I have been working on this for over a week using multiple different way...

 
10:01 PM
0
Q: My Upsert endpoint needs some changes

nightowl21I've made a controller that has an Upsert endpoint. [HttpPost] public async Task<IActionResult> Upsert([FromBody] ParameterLim parameterLim) { (...) var existingParameterLim = await _ParameterLimRepository.Get(parameterLim.Id); if (existingParameterLim == null) { parameterLim.Cr...

 
10:27 PM
0
Q: What pattern, factory or abstract factory, should I use to create various string-differentiated objects?

EdzijuI've got a Node class and different descriptors for these nodes. A category distinguishes these descriptors: Math category: AddNode, MultiplyNode Parameter category: FloatNode, IntNode The category is of type string because I want my editor to display a list of categories followed by descriptor...

 
10:52 PM
0
Q: C++ : Payment platform that takes in two types of cards and checks for authorization and pin verification. Please look for semantic/logical errors

BellisimomegC++ : Payment platform that takes in two types of cards and checks for authorization and pin verification. Please look for semantic/logical errors. #include <cstdlib> #include <iostream> #include <functional> #include <vector> enum class CardType { PISA, BlasterCard, }; class Card { publi...

 
11:10 PM
You may want to post your code on codereview.stackexchange.com — Marcin Orlowski 51 secs ago
 

« first day (3498 days earlier)      last day (528 days later) »