« first day (3129 days earlier)      last day (58 days later) » 

12:00 AM
REFRESH! There are 7943 unanswered questions (89.2498 answered)
 
Duga is a bot
 
Ok sorry.
 
If you click on the profile you'll see more info
@Fmbalbuena Probably won't be done today D:
 
@Peilonrayz ok so maybe tomorrow or Sunday.
 
I have things I need to do tomorrow so yeah Sunday.
 
12:05 AM
@Peilonrayz ok so i'm not bored. (I have a bit of this SE site experience)
 
12:21 AM
@Fmbalbuena Ah good. You've probably picked the worst week to ask me to review. I've moved house this week. I've not been so physically exhausted in a long time XD
 
LuL
 
12:39 AM
0
Q: Shunting Yard Calculator - Extended to negative, complex, etc

ParadoxMy code is here: https://pastebin.com/GAxunw7A This project is based off the shunting yard algorithm and has additional features such as negative value parsing. It's like a scientific calculator. I am looking to improve this project by getting rid of potential errors and optimizing code. I have t...

 
1:08 AM
As per the topic list for Stackoverflow: if your code works, but you want to improve it, this is the wrong place to ask. Head on over to codereview.stackexchange.com instead. — Mike 'Pomax' Kamermans 23 secs ago
 
1:55 AM
Code Review is for this type of question. — user17242583 37 secs ago
 
2:19 AM
0
Q: Is there a way to write this better? javascript*

Sr.FirckAll 3 ids are basically the same button but different divs, but I had to rename them to accomplish what I was looking for. is there a way to write this better? any help is much appreciated it $(document).ready(function(){ $("#open_iptvbasic").click(function(){ $("#iptv-channel-slideou...

 
 
1 hour later…
3:26 AM
 
 
3 hours later…
6:09 AM
What's your question? Does this code not work? If it works but is "not optimised", Code Review is the site for code review — ForceBru 55 secs ago
 
6:57 AM
I could be wrong, but with all due respect, this belongs on CodeReview, not really StackOverflow. — Amir Afghani 43 secs ago
 
 
2 hours later…
8:37 AM
0
Q: is Label of <SubEnum> in List<SubEnum> field of <OtherEnum> - simplest checking

Andrzej WięcławskiHere is some sample data: "SubEnum" enum Element { H("Hydrogen"), C("Carbon"), O("Oxygen"); public final String label; //getter & setter } "OtherEnum" with searching method enum Compound { WATER("L_Water", Arrays.asList(Element.H, Element.O)), ...

 
9:02 AM
0
Q: Azure Functions (.NET 5 - Isolated) with duplicated OpenAPI specifications

phwtI'm developing a REST API using Azure Functions with .NET 5 (Isolated) and I want to add an OpenAPI spec for each route. But it looks like this: namespace AzureFunctionsREST.API.Functions { public class ReporterFunction : BaseFunction { private readonly IReporterRepository _report...

 
 
1 hour later…
10:10 AM
Note that since you seem to be looking for general improvements on working code, this appears to more appropriate for CodeReview – be sure to check their question guide first, though. — MisterMiyagi 22 secs ago
 
 
2 hours later…
11:58 AM
0
Q: Custom implementation to provide an immutable range of a container without copying it

David TóthI needed to pass a const reference to part of a std::vector without copy. I posted the previous version in my earlier question, thank you for the great support! As far as I know this version supports not only std::vectors but any kind of iterator based continuous containers! Some research, partic...

 
 
1 hour later…
1:06 PM
Monking
 
2:04 PM
0
Q: Deleter for Simple Expression Tree in C++

Desmond GoldI have created a simple abstract class called expr_node which will serve as a base class for any expression-related nodes. My goal is to create a simple deleter that can delete the allocated memory from the derived class in which would be recursive in some cases. Rules and constraints (NOTE: for ...

0
Q: Minimize sum of array after performing K operations(Python)

Sparsh GargGiven an array of integers,find minimum sum obtained after performing K operations.In this context operation involves choosing an element a[i],multiply it by 2,at the same time,choose another element and divide by 2. My approach is able to find the minimum sum by carrying out the following opera...

 
2:26 PM
possible answer invalidation by phwt on question by phwt: codereview.stackexchange.com/posts/270437/revisions
@MisterMiyagi thank you for introducing me to CodeReview!. I had no idea about it. — Melly 43 secs ago
 
0
Q: Python program to convert decimal to binary

user252238I wrote a program with Python that converts decimal positive numbers to binary and puts the result in a list. I have a problem with decimal 0 because the result I get is [] instead of [0]. It works just fine with every number except for 0. How can I improve it to make it work with 0 too? This is ...

 
3:20 PM
0
Q: Trying to generfiy custom command handling logic in java

bwyleglyI'm working on a PoC of a ES & CQRS system. I have defined following classes to represent commands and events that represent an output of command being handled public class CreateEstateCommand extends Command {} public class ChangeEstateOwnerCommand extends Command {} public class EstateCreated...

 
3:37 PM
@CaptainObvious How often do you have the author remove the question while you are writing a comment in the first questions queue?
 
4:35 PM
0
Q: Improving generic A* algorithm performance

DavidSo here is my A* algorithm. I tried hard to implement it generically, but come up only with one idea to use lambdas for heuristic and next nodes (neighbours / successors) functions. I know that using good heuristic function is the key to speed up, but here i'm trying to squezze everything from cu...

 
5:12 PM
"I received a code review from a colleague and they said it would be better to separate out the DOM manipulation code into a class method for readability, i.e. so it wasn't all inside the constructor." - not just that, but it also shouldn't be called from inside the constructor. The constructor should only concern itself with setting up the instance properties. That way, your subclass can finish initialisation before the method is called. — Bergi 32 secs ago
 
 
2 hours later…
7:06 PM
0
Q: Interface Segregation Principle

smgriswI have a base view model which implements an Mode View View model pattern. public interface IBaseViewModel<T> { #region public properties BaseViewModelProperties BaseVMProps { get; set; } T Model { get; set; } #endregion #region public methods Task Init(); Task In...

 
 
1 hour later…
8:30 PM
I seems since, you have working code and are seeking recommendations for improving the code It seems to me this question is more suited to be asked in the Code Review Forum. Code Review is a question and answer site for peer programmer code reviews. Please read the relevant guidance related to how to properly ask questions on this site before posting your question. — itprorh66 44 secs ago
 
 
2 hours later…
10:03 PM
0
Q: C++ template and inheritance - Generic Sqrt Decomposition

Abhay Raj SinghSo I tried implementing a easily extendable solution for Sqrt decompostion, I deduced that only identity value, operation and block update logic change and rest of the code is same. So i created 3 functions T identity() T operation(const T&a, const T&b) T block_update_calc(const T old_block_val...

 
If your code is working and you just want it to be review, ask the question at Code Review. — Rabbid76 12 secs ago
 
10:26 PM
possible answer invalidation by David on question by David: codereview.stackexchange.com/posts/270452/revisions
 
@Duga Basically looked ok, but it was mentioned in the answer, so rolled back and commented.
 
@pacmaninbw Nice catch
 
11:20 PM
Thank you
 
11:34 PM
If your code is now working fully, you may want to post your code on Code Review, because there are many inefficient things about your code. Note that the rules on Code Review are different than Stack Overflow. You may want to read this: A guide to Code Review for Stack Overflow usersAndreas Wenzel 41 secs ago
 

« first day (3129 days earlier)      last day (58 days later) »