« first day (2466 days earlier)      last day (1849 days later) » 

00:00
RELOAD! There are 6377 unanswered questions (90.0941% answered)
00:44
0
Q: if someone have a codes for this in c# please

Sachithra Udayanga a program to calculate the monthly pay for the employees in an organisation. The input to the program includes the employee name and category, number of hours worked in the month, the number of days of authorised leave and the pay rate per hour. The pay scheme is as follows: Executives are entit...

01:25
0
Q: Managing Excel Tables (ListObjects) with OOP Approach (Second follow up)

Ricardo DiazThis is a follow up to this question and this question Objective: Manage what happens when users interact with Excel Tables (ListObjects) Code incorporates: Mathieu's suggestions: ITables: Refactored interface and it's implementation Tables: Hide SheetTables collection and exposed as a Shee...

 
1 hour later…
02:25
possible answer invalidation by Tobi Alafin on question by Tobi Alafin: codereview.stackexchange.com/posts/236388/revisions
 
2 hours later…
05:21
AFAIK, GitHub uses different code review approach. Just push using normal commands and create a pull request. So you don't need to set up anything extra. — Gangaraju 51 secs ago
05:49
0
Q: Can I use IDisposable by treating abstract concepts such as colors as resources?

stealegiThere are the following class: class ConsoleForegroundColor : IDisposable { public ConsoleForegroundColor(ConsoleColor color) { OriginalColor = Console.ForegroundColor; Console.ForegroundColor = color; } public ConsoleColor OriginalColor { get; set; } public...

06:08
I guess Code review Stackexchange is right place to ask this question — Prasad Telkikar 9 secs ago
Each lowest-level if/else branch is doing something different, and I see no way to do a refactor to simplify things. By the way, given that your code be already working, and you just want some suggestions on how to improve it, your question really belongs on our sister site, Code Review Stack Exchange. — Tim Biegeleisen 37 secs ago
Up to three awaits in a single function smells fishy to me, and I agree with reposting to Code Review. — Ken Y-N 57 secs ago
06:40
Duplicate lines _urlService.AccessCodeInUrlExistsAsync and _urlService.GetAccessCodeFromUrlAsync used in both if and else part. You can call those first to avoid duplicate code. I too agree your code belongs to codereview.stackexchange.com — MKR 44 secs ago
06:55
I'm voting to close this question as off-topic because it’s asking for a codereview.stackexchange.com. — deceze ♦ 55 secs ago
07:51
0
Q: Refactor PHP | Laravel Code, Optimisation needed to make code clean

Syed Ameer HamzaI have made some notification preferences in which there are 4 major preferences SMS PUSH FAX EMAIL And then there are some specific templates such as booking-accepted and within booking accepted there are again these 4 notifications. So what I have to do I need to check 1st priority notifi...

0
Q: Asking for test: Calculator function javascript

Migats21I have made a code that can run a calculation from text. When I tested it, I didn't find any bugs. You are sharper than me. Maybe you can discover some bugs in this code. When you know some improvements to this code. It would be nice when you let me know. I also made a calculator with this code....

08:51
0
Q: Extending PHP REST API Controller design to complex routes

sanjihanI am putting together a php Rest API service that uses Controller and Command pattern to handle requests. Firstly, in Apache config I redirect all requests to a single end point, /api/v1/index.php. RewriteEngine On RewriteRule ^/api/v1/([^/]*)/([^/]*)/* /api/v1/index.php/?command=$1&subcommand=...

09:32
0
Q: A C++ echo server using epoll

JiuI created a basic echo server with a stub client using epoll. Full project: https://github.com/arkceajin/EpollSocket.git As a newbie of epoll socket programming. I wanna know is there any potential issue. Especially the core part below. #include "abstractsocket.h" #include <arpa/inet.h> #include

09:50
@Duga Looks like a manual rollback of his own edit...
 
1 hour later…
11:01
Maybe re-title "Best" to "More" or "Most", as it now appears seeking opinion. Also, if all of your code samples work without a problem, consider Code Review. — usr2564301 46 secs ago
11:12
Monking
11:33
0
Q: Better Filtering on Java Streams

edwinI need to run filtering on nested Lists and return a List of items from back I will put a sample code here with my model import lombok.Data; import java.util.List; import java.util.stream.Collectors; class Scratch { public static void main(String[] args) { ParentModel parent = n...

12:13
0
Q: Refactor method to Java 8

Tishy TashI have a method that iterate a list of maps if a certain element is found then set value of certain variables and break the loop. I'm trying to revamp this into Java 8. And further if it can be improved, please suggest. public static void doAction(List<Map<String, String>> decisionTree, String c...

12:33
0
Q: C++ Calculator for complex numbers - follow-up

chrysaetos99After following the suggestions from the first question on that topic (link), I'd like to show you the result now: #include <iostream> class ComplexNumber { private: double real; double imaginary; public: ComplexNumber operator+(ComplexNumber b) { ...

0
Q: Find outlines of a tile collection

PaperBirdMasterOn a game I'm working curently I keep on memory a simplified representation of the map which only have solid and non-solid cells. I need to get the outline of the shapes that adjacent cells might create, something like this: I do not have a 8×8 array of bools on memory but a container of cell1...

13:03
This sounds good Nitika. I'll try this. But I'm not sure whether my code tech lead will be very happy during the code review. I'll update you. — Tanzeel 1 min ago
I'm voting to close this question as off-topic because it should be migrated to codereview.stackexchange.comNicktar 37 secs ago
13:25
possible answer invalidation by Tishy Tash on question by Tishy Tash: codereview.stackexchange.com/posts/236577/revisions
14:14
0
Q: Huge integer class using base 256

Richard MaceAfter a hiatus, I have returned to coding in C++. In an effort to learn some of the newer aspects of the language and for exercise and 'up-skilling', I am writing some simple classes and this HugeInt (huge integer) class is an example. Looking on the web there are a number of implementations, wh...

14:29
Monking
15:15
0
Q: Count minimum adjacent swaps - HackerRank New Year Chaos

BlascoWe need to find the minimum number of adjacent swaps required to order a given vector. The maximum number of swaps that an element can carry out is 2. If the vector can not be ordered under this conditions, we should output "Too chaotic", else we should output the total number of swaps required. ...

15:35
I think that a code structure question may be too opinion based for this site. This site is for code that is not working and needs to be fixed. You question is certainly valid, but I think it might be a better fit for the Code Review Stack Exchange as it's goal is to review code and provide insight on how you can make you code better. The goal here is to make broken code work. — zero298 19 secs ago
0
Q: Rust/WebAssembly VS pure JavaScript benchmark in Node.js

7hibaultI've wanted to try Rust and WebAssembly for a while. I recently realized that I could try both at the same time by compiling Rust to WebAssembly. I wanted to know what the performances of something like that would be so I came up with a simple test : Make a few mathematical operations in pure ...

15:54
I'm voting to close this question as off-topic because it belongs to codereview.stackexchange.comToto 1 min ago
1
Q: correct coding structure in React.js?

Kevin BryanI'm new to react and I'm still using the life cycle methods, so my question is since componentDidMount() acts like a constructor I'm planning to initialize everything there: render() { return ( <div className="done-container" style={this.style().taskContainer}> <

16:32
Since your code works but needs optimization, this might be a good question for Code ReviewG. Anderson 31 secs ago
16:54
Monking
How do you define "better"? Is your code working and you want feedback on it? If so, we have another site for that. — Fred Larson 58 secs ago
17:15
Here on Stack Overflow were handling errors or issues with code. For a code review or optimization please post at Code Review. — Klaus D. 1 min ago
17:57
0
Q: Substitution Cipher: Which One?

David PetersonI'm a beginner and I have a question(somehow silly and stupid :) )...Today I decided to challenge myself and I came around the challenge that wanted me to create a program that ciphers (or encrypts) the message using the substitution cipher method...I solved the challenge by myself but mine is wa...

18:37
-1
Q: Better way to refactor this using lodash

chimmypSo I have this function and I feel like there is a better use case using utility functions from lodash. The function goes as follows: requiredVendor(vendors, vendorTrade) { return vendors .map(vendor => vendor.vendor.trades.filter(trade => trade.name === vendorTrade)...

18:57
-1
Q: How can I make the following code faster?

YossarianI am trying to optimize code for a challenge in codewars but I am having some trouble making it fast enough. The kata in question is this. The description is explained in a detailed way in the link I have given and I do not reproduce it here not to bloat the question. My attempted code is the fol...

-1
Q: Best way to open a file in Python

WebucatorI use the following function for opening files in Python: def file_path(relative_path): folder = os.path.dirname(os.path.abspath(__file__)) path_parts = relative_path.split("/") new_path = os.path.join(folder, *path_parts) return new_path I call it with a relative path, like th...

-1
Q: Set boolean flag to true if a varia ble with given value appeared twice in for each loop

MatleyHow to write this with clean code rules: orderLines is a list - mapped objects from JSON in a given ORDER. I want to check if SECTION is appeared the second time in my for loop I have to set then my flag sectionAppearedSecondTime to true because in each IF I have to invoke another method (setLi...

 
2 hours later…
20:49
I think you should take this over to code review (codereview.stackexchange.com). There's a lot of redundant code and some extraneous selects that could really be tightened up. This will also help show where things are going wrong. — Ryan B. 18 secs ago
21:20
This is a question for stack exchange code review. Please ask there. — Train 59 secs ago
@AlexeiLevenkov, with all due respect, there must be "best practices" for implementing C# libraries. Especially in regard to what to do about methods that take a long time to complete. Perhaps the caller of the library is responsible for dealing with the problem? It would not surprise me if there is a document (I could not find it, but that doesn't mean someone doesn't know the location). Also, were you suggesting that my linked question from codereview is better posted here? Thanks! — Dave 51 secs ago
@Train it doesn't belong there either, code review is code, there's no attempt here. — Çöđěxěŕ 37 secs ago
@Train Please don't recommend sites you're not familiar with. Code Review only accepts complete, working code - the OP hasn't even written anything yet. — EJoshuaS - Reinstate Monica 8 secs ago
@Train Why would this belong on Code Review? There's not even any code here to review. — EJoshuaS - Reinstate Monica just now
 
1 hour later…
22:46
Please check Which site? for a wider variety of issues. Code Review Stack Overflow is not the place for unspecified improvements. — Prune 30 secs ago

« first day (2466 days earlier)      last day (1849 days later) »