« first day (1046 days earlier)      last day (41 days later) » 

12:42 AM
I was under the impression that all optimisations at dyalog were supposed to preserve behaviour with floating point numbers
 
 
6 hours later…
6:28 AM
@Adám I meant that +\ could still use memoization even if the elements aren't simple. I do agree that iterating over simple scalars must be more efficient than non-simple ones.
      nested←1⍴¨1000/1
      cmpx '∊+/nested' '+/∊nested'
  ∊+/nested → 3.3E¯5 |   0% ⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕
* +/∊nested → 9.7E¯6 | -71% ⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕
      cmpx '∊+\nested' '+\∊nested'
  ∊+\nested → 1.6E¯2 |    0% ⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕
  +\∊nested → 1.6E¯5 | -100%
 
7:26 AM
This one is quite interesting:
      cmpx '(⊂''>^<v'')⍳¨s' '''>^<v''⍳s' ⊣ s←(?1000⍴4)⊃¨⊂'>^<v'
  (⊂'>^<v')⍳¨s → 1.5E¯4 |    0% ⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕⎕
  '>^<v'⍳s     → 1.5E¯6 | -100%
 
8:24 AM
I don't think it's very golfy though
Despite getting rid of 22 whole bytes while bug fixing
Edit 23 bytes golfed
 
 
2 hours later…
10:15 AM
dyalog apl 17.1 installation fails on ubuntu 19.10. installer complains package libtinfo5 not installed. any help would be appreciated.
 
 
2 hours later…
12:35 PM
@Sherlock9 you don't need that 1, and 1↓ if you just require that the input be a vector always
 
@dzaima I don't know, this test case still says that's broken tio.run/##SyzI0U2pTMzJT///v/pR31RP/…
 
@Sherlock9 if that's the wrong output, it's still just as wrong as your current answer
 
Meant this one, pardon me tio.run/##SyzI0U2pTMzJT///v/pR31RP/…
Or f 0 0
 
@Sherlock9 ah yep, that's indeed a problem
 
Let me know when you figure it out
I've been bug fixing all day
 
 
2 hours later…
2:33 PM
TIL x⌹x=x finds the mean of a list vector.org.uk/sixteen-apl-amuse-bouches
 
2:49 PM
@KritixiLithos Ooh that's fascinating
 
 
2 hours later…
4:34 PM
@aierl i guess asking the obvious first would be a start - do you have libtinfo5 installed? (apt show libtinfo5)
ah, i see - libtinfo5 has been replaced with libtinfo6 in Ubuntu 19, probably making it not installed by default. it still should be installable manually though
 
@dzaima Thanks for the tip it worked by installing it manually. :)
 
4:49 PM
hm, the 17.1 deb file does have libtinfo5 as a dependency, so it should've been installed automatically along with Dyalog
 

« first day (1046 days earlier)      last day (41 days later) »