« first day (4602 days earlier)      last day (112 days later) » 

6:15 AM
@UlrikeFischer I guess there will be a PR today?
6:39 AM
@JosephWright Yes, I only need the tests working (I seem to miss always at least one)
If you view the PDF of this Overleaf project in Overleaf, the lines are not continuous: https://www.overleaf.com/read/qxbgqwvnjsqs

The same happens in the test PDF.js viewer at https://mozilla.github.io/pdf.js/web/viewer.html which makes me wonder: is PDF.js wrong in some way, or is this a glitch in the patterns library? Any ideas welcome!
6:59 AM
@yo' does it look ok in a local viewer?
(where can it be seen in the mozilla.github.io pdf you link to?)
Looks OK in the pdf viewers I have, too.
There is a hint of the break during very fast redraws in okular.
But, in inkscape:
Maybe I do something wrong when importing...
@Rmano Indeed. And in chrome's viewer I could not zoom sufficiently well, and in the most zoomed in version, there were some rendering issue so that it looked shifted.
I use to blame antialiasing for these things, although normally okular is one of the worst at it. "Sub-pixel" antialiasing corrections are normally the culprits.
7:13 AM
^ From chrome...
@mickep Yep, it does
@mickep You need to download the PDF and open it in the test viewer
@mickep I don't think so. This used to be how it looked like in PDF.js too... then at some moment it got slightly better
I'm used to this kind misalignments with circuitikz, too (never in print). You have two lines of the same thickness, starting and stopping at the same point, and one of them is blurred by the antialiasing mechanism and the other not. Visually it creates a kind of step.
@yo' Ah, that is why I did not understand that pdf :)
@mickep yeah, sorry for not being clear about this!
well, my (non-educated) guess is that the repeated pattern actually overflows it's square in the way how patterns implement it, and the PDF.js viewer ignores the part that overflowing. But I have no idea (not even whether what I just wrote makes sense...)
@yo' Oh, no worries.
7:19 AM
okular at 5000% + gimp at 800%, showing a similar glitch as @mickep above. Rounding error in antialiasing would be my guess
@Rmano this is fine with me. The uncontinuous lines is what I find bothersome...
@yo' Maybe a line cap problem? I don't have a lot of time now to check if the pattern is built in a way that the lines touch or the line caps touch...
Could indeed be that one wants to avoid overlap in case one uses transparent colors.
7:52 AM
@mickep that's an interesting point! Still I'm thinking, shifting the pattern by a half would avoid the need for the corners and could lead to a better experience. Easier said than done though...
@yo' I have some vague memory that in MetaFun, for line hatching, we added a macro that draws straight lines that are sufficiently long, and then clip them to the path in the end. But I might remember wrongly.
@yo' this looks similar to vertical rules vanishing in colortbl, when they "touch" coloured panels but shift by a pixel or two and vanish. I find an explanation of not my fault usually covers all variants of the issue.
8:14 AM
@mickep yeah, for patterns, this is an issue of universality (everything is a pattern that repeats) vs. good display (lines should be simply lines, cropped/clipped to the filled area)
@DavidCarlisle "not our fault" seems like a good way for us to deal with this issue in our team :D
9:01 AM
@yo' it looks like a bug in the pdf viewer. They seem not to use the BBox to clip, but the XStep and YStep values, and so the lines can't overlap correctly to avoid such artifacts.
9:18 AM
@Rmano oh no, KDE apps :)
@yo' you can try with this example: it uses much longer lines on the second page. In acrobat one can see a difference in the rendering (depening on the zoom) but in overleaf there are still gaps:


\pgfdeclarepatternformonly{longnorth east lines}{\pgfqpoint{-5.01cm}{-5.01cm}}{\pgfqpoint{5.01cm}{5.01cm}}{\pgfqpoint{3pt}{3pt}}%

\pattern[pattern=north east lines] (0.25,3.5) rectangle (3.5,5.5);

\pattern[pattern=longnorth east lines] (0.25,3.5) rectangle (3.5,5.5);
10:18 AM
@PauloCereda Hi, Mr. Duck! Thanks for the carrot. Here, have one as well: <3
11:17 AM
@PhelypeOleinik is it expected that \UseHook grabs arguments?

A: \UseHook{blub-A}abc

B: \UseHook{blub-B}abc

@UlrikeFischer Yes, \UseHook and \UseHookWithArguments just expand the underlying macro. The difference is that \UseHookWithArguments does cleanup if the hook isn't declared
@PhelypeOleinik interesting, one then has to be a bit careful with the naming of new hooks ...
11:40 AM
Is something like \ttfamily at pgfplots latest versions furthermore forbidden?
every axis label = {font=\ttfamily\footnotesize, text=red}, % nothing happens...
ymin=0, ymax=11,
\addplot plot coordinates { (1, 5)  };
@UlrikeFischer Why with naming? Well, I could add a check for arguments in both \UseHook... functions, but I don't see a real benefit. I could be persuaded otherwise
@PhelypeOleinik Naming is not the best word. I came across the problem as I had in the sec-tagging code hooks and changed the declaration to take arguments and got horrible errors when a forgotten \UseHook started to eat them.
11:57 AM
@UlrikeFischer In my original implementation both would work the same, so not my fault I guess :)
@UlrikeFischer Checking if a hook takes arguments needs just a \tl_if_empty:c test, so not that slow if you think I should add
@PhelypeOleinik what do you mean by checking if it takes an argument? Isn't that simply a difference between \UseHook and \UseHookWithArguments and the first should simply not grab arguments? Ah no, the hook code can contain references to the arguments and so \UseHook is simply wrong, right?
@UlrikeFischer Yes, the hook is implemented as a regular macro, so it will grab arguments when expanded. The check would prevent \UseHook from expanding the macro of a hook that takes arguments
@UlrikeFischer Also, nothing stops you from doing \NewHookWithArguments{foo}{9} then \UseHookWithArguments{foo}{1}.... Results may come with an extra dose of debugging fun :)
@PhelypeOleinik that means that if a hook with argument is declared, then \UseHook{hook}{arg1}{arg2} will work like \UseHookWithArguments{hook}{2}{arg1}{arg2}?
@UlrikeFischer Exactly
12:13 PM
@UlrikeFischer, @PhelypeOleinik One for the team list?
@JosephWright you mean @PhelypeOleinik
I thought you upgraded the duck...
@UlrikeFischer No, let @PauloCereda deal with this one ;-)
(Maybe you should)
@JosephWright I'm writing
12:22 PM
@PhelypeOleinik but I'm not saying there is a problem, I only try to understand all the consequences and ponder if there are cases where they could give problems.
@UlrikeFischer I don't think there's a problem either. People just need to take care of using the right number of arguments in the call to \UseHook[WithArguments]. It's more or less the same situation as writing (note the number of :n) \msg_error:nnnn { pkg } { name } { arg1 } and spending hours trying to figure out what's going wrong
Not that I have ever done something like that ;-)
@PhelypeOleinik :)
@PhelypeOleinik I like to give a TF-boolean only one branch.
@UlrikeFischer Oh yes, that too :)
@JosephWright @UlrikeFischer So, mail or nah?
@PhelypeOleinik My concern is that it somewhat undermines saying you need \UseHookWithArguments, because, well, you don't
12:38 PM
@JosephWright No, you don't. In fact I had that implemented as a copy of \UseHook until I changed to add cleanup
@JosephWright It's only really needed if you don't know if the hook is declared or not
@PhelypeOleinik As long as that's clear in the docs
@JosephWright The docs currently omit this implementation detail, it just says that for hooks with arguments you need \UseHookWithArguments
@PhelypeOleinik OK, so perhaps check on the team list: I'd certainly missed this
@JosephWright sent
12:54 PM
A: How to set tiny font in axis labels with pgfplots

esddSet the compat option before label style: \documentclass{article} \usepackage{pgfplots} \pgfplotsset{ compat=1.3, tick label style={font=\tiny}, label style={font=\tiny}, width=6.5cm, height=5.5cm} \begin{document} Normal text \begin{figure}[!ht] \centering \begin{tikzpicture} \begin{a...

tick label style={font=\tiny\ttfamily},
label style={font=\tiny\ttfamily},
^^^^^ this works
1:44 PM
Really? I thought the math mode kills all settings, so I needed

tick label style={/pgf/number format/assume math mode=true,},
y tick label style={font=\ttfamily},
@cis Ah yes --- they were so tiny I didn't notice ;-P, sorry
This is a bit strange for me:

Does "assume math mode=true" not mean: "Put the math-mode ON" ?
@Rmano If you find that too tiny, so what would you say here... :()
2:02 PM
@cis 😮 🔍🔍🔍
2:58 PM
@Rmano -- There are definitely gaps, very small ones, in the panel on the left. I'm looking at an enlarged version of your posted .jpg, using the Firefox browser (updated just an hour ago) on an Ubuntu Linux laptop.
This is how I see it at maximum magnification (Firefox too, v114, on a Manjaro Linux)
@mickep -- (in browser again) there's a tiny left-edge discontinuity about a third of the way down on the second-from-left rule.
3:16 PM
ooh I bought the TLC3 book too
I am a poor duck
Maybe Phelype and I could ask for silly royalties
3:50 PM
@DavidCarlisle, @SylvainRigal, @egreg -- I reconstructed an example of the padding around a colored element and added it to my non-% answer. Let me know if you think it can be improved.
4:02 PM
@PauloCereda Now you need a bigger apartment for a stronger bookshelf!
@PauloCereda I bought the TLC3 ebook because I already have problems with the amount of math books
@barbarabeeton Yes, indeed.
@StefanKottwitz One cannot have too many of these...
2 hours later…
6:30 PM
Can I post a google-drive-link here, so that the animated gif comes?
@DavidCarlisle Now you know, why I needed 52 numbered counters.
6:44 PM
@UlrikeFischer We ready to merge the PR?
@cis This looks ... interesting =)
I animated this. But I can't upload the too large gif-file here.

@cis What does it represent? It takes amazingly long for all cards to be drawn at least once
Yes, the film lasts 1min:28sec; what I know after making a mp4-file from that with ffmpeg.

It shows: If you choose 441 times a card from 52 cards, you should have yield about 99% of all 52 cards.
@JosephWright i think so, I made the change Frank requested.
6:56 PM
@cis so it is to visualise statistics in some way, or probability calculations?
@cis not really, that just shows you needed 52 numbers
@DavidCarlisle At least it is a nice use case for LinotypeGamePiEnglishCards Roman =)
@JasperHabicht Yes, correct.
I solved that by
`stepcounter(CardNo1), stepcounter(CardNo2), ..., stepcounter(CardNo52)`
@UlrikeFischer OK, I'll merge unless you ant to?
7:33 PM
@JosephWright you can do it, I have to cook now ...
@JosephWright oh I just see more comment from frank
@JosephWright nothing looks pressing, so you can merge.
1 hour later…
8:55 PM
:( My computer crashed while I was starting a TeX run (empty battery), now the file is empty :( And no, I got no backups...
phew, I guess I can restore most of the stuff... Not sure whether I already got the latest version of the file back from btrfs, but I got something to work with...
@Skillmon -- Condolences. What input method do you use? (emacs keeps a copy periodically with a name beginning with #, That has saved my skin many times!)
@barbarabeeton VIM, it usually keeps a swap file, not sure what happened to it...
I guess I accidentally removed that when I opened the file with VIM after booting back up and found it empty.
9:14 PM
@Skillmon Oops
@UlrikeFischer Done - we are good-to-go
Evil TeX deleting files.
@JosephWright it was a new draft for the sorting code... I think I have an even better version now, if I manage to completely restore it.
@Skillmon Ah, oh
@JosephWright -- Something funny going on on the main page, I answered a question, answer was accepted (about ten minutes ago) but the list of questions hasn't been updated. The "old" listing of the question has the checked answer acknowledged, but it's still listed in its original order with the time and identification of the OP. Peculiar.
@JosephWright -- Just checked again. Time on the "newest" question shown is 49 minutes.
@JosephWright The only thing I'm not sure about yet is, whether to keep it like I got it now, or introduce more of a hybrid sort... Currently the code builds the initial sublists as the biggest streak of correctly ordered elements (with the first two elements maybe swapped if they were ordered reversed). That way the number of necessary merges is reduced (in the best case -- already ordered input -- this is close to O(n), in the worst case the worst case of Mergesort should apply, O(n log n)).
The alternative would be to run an insert sort to build the initial sublists of up to n elements (and enlarging them if there is a streak following), and then mergesort. But I'm not sure whether this additional complexity is warranted.
@Skillmon Probably not: we were talking at the team meeting about how people use l3regex for ... stuff ... and how the performance there looks to us (particularly the longer standing team members)
@Skillmon I think we can live with O(n log n)
9:27 PM
@JosephWright Complexity will be higher than above's estimate in reality because of the way we have to traverse the lists in TeX and have no O(1) access.
@Skillmon Sure, but that's always the case
@Skillmon Well, no expandable O(1) access ;)
@JosephWright well, yes, and I do not dare touching Bruno's unexpandable quicksort.
9:43 PM
@Skillmon Hic sunt leones
@JosephWright dracones
10:33 PM
@TeXnician - Is there a way we can discuss the arara issues outside of comments?
@StarBlooming arara issues? Well, if you want to discuss content, then it's best to focus on the Q&A format of the main site. After all, that's what the site is for. Obviously I have misunderstood what you meant with “the above” in your comment under your question.
My apologies for any misunderstanding my posting may have caused.
@StarBlooming As I said in the comments section: I won't engage in an question-update → answer-update → question-update → answer-update cycle because that's not how the site works. And there are more qualified people than me (e.g. @PauloCereda) to help you with your rule's content. I did the support for the basic misunderstanding in your question. If you open a new question with different focus you maybe get more attention from those people who can help you with the rule's content.
@StarBlooming Editing a question to refine it further and further (and as I mentioned in the comments, your question basically shifted from a “I don't understand arara's error and why it does not find mydialog in the directive” to a “I've got a custom rule that does not work” which requires a much more in-depth review of the rule's Java content) is not going to draw much new attention from potentially knowledgeable people.
Again, my apologies ... as a novice, there is a larger issue at play that is not appropriate for discussion on SE. I'm glad to delete my entire post if that would prevent any misinterpretation of how my post developed and progressed. I was trying to resolve how arara can be used for something that it may not have been designed for, so I may have misinterpreted what was outlined in the manual. Is there a way we can discuss further on a non-SE platform?
10:50 PM
@StarBlooming No, please don't delete your post. The entire point of a Q&A site like this is to build a knowledge database so that people can learn from the questions (and answers) of others. And there is nothing to apologize for, really, it's just that this site has a certain way how things work and I have tried to point out how your edits do not fit in with that concept.
@StarBlooming It is entirely fair to ask questions like yours but it is not fair to expect one person (be it me or someone else) to be able to answer everything. I was able to answer a fair share of the configuration part of your question but I may not be the most knowledgeable person to solve your arara rule content issues. That's why it would be in your best interest (in terms of getting an answer for that) to ask a new question with what is basically your last edit to the question.
@StarBlooming And yes, there are non-SE platforms to discuss arara issues. The Island of TeX has multiple Matrix rooms (even one dedicated to arara), all linked in the arara repository: gitlab.com/islandoftex/arara (and even the manual, fwiw). Whether you have more luck asking there than posting a question here on SE is something which is up to you (the number of arara developers and users on this site is far larger than the number in that chatroom).
@StarBlooming If you want to solve a specific arara problem, then ask questions on the site as @TeXnician is explaining. If you want to ask about whether doing some particular kind of task is well suited to be done with arara, then it's possible that asking that in chat might give you an answer (i.e. "yes, it's a good use case" or "no, it's not a good use case".) Or as @TeXnician says, maybe the IslandofTeX site might be better suited for that kind of question.
@TeXnician - Your postings were VERY much appreciated and helpful. I am working on a much large issue that is irrelevant for code, and is NOT appropriate for discussion on SE. My ORIGINAL thought, that I may have neglected to detail, was to find a way to discern the non-zero exit codes that have plagued my projects recently. I was attempting to use the arara Dialog boxes as a way to display those codes, and possibly discern what is happening with my LaTeX projects.
Obviously, it turned out much differently than I had hoped.
@AlanMunn To be fair to @StarBlooming (and give context to this chat), he did ask about a specific arara problem and I have answered in a way that can be considered incomplete at best. My stance is just that his chances of getting an answer to a specific subproblem I did not cover (“fix the rule”) won't be seen by editing the question to focus on that specific subproblem which itself would be well-suited for a follow-up question.
@TeXnician Yes, I understand that; I was mainly responding to the comment that they may have been trying to do something with arara that it wasn't designed for and asking about whether such a use case was reasonable is something that chat might be able to answer. But it sounds like they really should just ask a new question as you're suggesting.
@StarBlooming Well, displaying non-zero exit codes using arara rules is actually non-trivial. Because arara does mangle with the exit codes on purpose (see the documentation on that). There is even an open arara issue about this topic because there are use cases to see the specific exit code.
11:05 PM
@AlanMunn - My apologies ... I've never used the SE chat before, did not even realize it was an option. It's a great resource!
@AlanMunn Ah, now I get it. My reading comprehension seems to degrade right now, seems to be getting late here :)
@StarBlooming If all you need is to get the specific exit code (and don't need the dialog boxes), maybe it would be easier to make a feature request in the arara repository to include the specific exit code in the log (that is generated with the -l flag). Actually, this does seem like a very reasonable thing (and I'm not sure why the real exit code is not logged).
@TeXnician - Re: "There is even an open arara issue about this topic because there are use cases to see the specific exit code." That is Sssooo interesting ... would have save me (and perhaps us all) a bit of trouble if I had known. From my naive view point, the issue of exit codes could perhaps be an opportunity for arara. Is it correct to say that discerning the exit code is a bit of a gap right now in LaTeX, or is there in fact a way to fInd out what those values are?
@StarBlooming Well, no, this has nothing to do with LaTeX. It's just arara that discards the exit codes for a reason (so that you know by looking at arara's exit code whether a process failed or arara itself had an error). The processes that arara actually calls (and you can see the command-line arara uses to call them in the log) do provide exit codes as implemented by the respective tools.
@TeXnician - Given that having a non-zero exit code STOPs all arara processing, I naively thought the natural thing would have been to display those values via arara. A BAD assumption on my part!
@TeXnician - My apologies, but how may I find or see the non-zero exit code now?
@StarBlooming Well, yes, a non-zero exit code stops arara with a specific exit code, i.e. arara will discard the tool's exit code to signal scripts that call arara that it's a tool failure and not an arara failure. But as I said, your assumption that there would be some way to get the exit code does not seem to far off, so maybe you can suggest it to the developers that exit codes at least would be logged.
@StarBlooming Well, you can't from arara. But arara tells you which tool fails (there is a “FAILURE” line in the output). You can then look into the log file to find the actual command arara was running and run that specific command again to see the exit code in your shell.
11:16 PM
@TeXnician - Re: "so maybe you can suggest it to the developers that exit codes at least would be logged." - how would I do that?
@StarBlooming Well, usually you would open an issue in the arara repository. But I can open that for you to save some of this discussion.
@TeXnician - Re: "But I can open that for you to save some of this discussion." This is all so far away from my work and research that I would appreciate any assistance that anyone can provide ... I am on a kind of clock to resolve so many issues ... code is a tool of my research ... but not the end product.
LaTeX has proved to be incredibly productive for my research ... until fairly recently. My entire diversion toward the exit code has cost me time that I don't have if I am to finish what I am attempting to do.
@StarBlooming Understood and done (see above). Note that this is a long-term solution (requiring an implementation and shipping an update). If you need help with your immediate problem, you can ask a question on the site whether someone has an idea how to implement something you want. I just recalled the rule method unsafelyExecuteSystemCommand (see arara documentation) which does not let you see the exit code of other rules but lets you execute custom commands and returns the correct exit code.
@StarBlooming Yes, LaTeX tends to cause some diversions into coding-specific aspects. And just as a hint for the next time you ask questions: try to avoid xy problems because answerers may be able to solve your issue without restricting themselves in the means you have chosen. There are many people on this site who have fairly creative ways to tackle the underlying problems ;)
@TeXnician - Thank you ... I am so overwhelmed by what I can perceive you mean ... but can only guess at what you mean ... I will have to research the unsafelyExecuteSystemCommand directive you jus mentioned.
@TeXnician - Please understand that w/o LaTeX I would have made far less progress on my work and research than I have ... I'm just attempting to restart the pace at which I was able to progress up till now.
@StarBlooming Just to be clear, it's not a directive in arara terms (directives are the lines at the top of your TeX file like % arara: pdflatex). It's not a rule either (rules are the YAML files that follow a certain pattern to describe a command sequence). It's not a command either (a command to arara is one of the execution steps). It's a rule method (a method that can be used in the Java code of a rule).
In turn, that means that to use it you will still have to write a custom rule around it but you will be able to get the command's exit code in that rule. What you will lose, iirc, is that the output is printed to the terminal window (but you would need to check that). However, it's only one particular tool available within arara's rule method body and others may have more ideas ;)
@StarBlooming Good luck with that :) And to make sure that I progress well enough on my projects tomorrow, I'll try to grab some sleep ;)
11:32 PM
@TeXnician - This is an entirely new resource that was heretofore totally unknown to me. I recently made the switch from LaTeX to LuaLaTeX which has created it's own issues ... and I'm at the point where I may have to reexamine all my exiting 25K lines of code b4 I can proceed. A major time investment that I only hope I'll be around to complete.
@TeXnician - Thank you for your assistance. Let me know what you think I need to do to resolve my existing post.
@TeXnician - For what it is worth, considering how important the Amazon (the basin, not the business) is to the birds highlighted in the arara documentation, my research is about how to 1) place a specific value on preserving the rainforest, and 2) placing a specific cost on any clearing of that rainforest. This is something that is only inadvertently addressed in our current assessment of climate change, and why I am chafing-at-the-bit to complete my work and research.
@TeXnician - have a good sleep!
To those that are familiar with this chat ... Is there a direct link to where we are now?
(This is my first time here and I'd like to know how to get back!)
@StarBlooming You can always get to chat from the "hamburger" menu at the far right of the main site:
Never mind ... I've copied the chat.stackexchange.com/rooms/41/tex-latex-and-friends link, and it appears to link here...
11:47 PM
@AlanMunn - Thanks ...
This is all so amazing ... where have I been?
@StarBlooming Well presumably saving the rain forest while we discuss cricket, ducks, and repeat chatroom memes :) Oh and sometimes we discuss TeX too.
Considering how NY City has experienced the fallout form the wildfires in Canada, I cannot work fast enough ... thank you for all your help.
@StarBlooming You're welcome.
Do people 'sign off' from these chats?
Oh ... I see the Leave room link above ...

« first day (4602 days earlier)      last day (112 days later) »