« first day (3918 days earlier)      last day (137 days later) » 

4:01 AM
wrt tex.stackexchange.com/q/606083/202780 the Oxford comma is the Devil's own comma. There. I said it.
 
 
2 hours later…
6:28 AM
I don't know why, but I'm (again) not at home for TUG and will have to watch the youtube videos after the fact :(
TUG seems to be very talented in scheduling the conference in the same week the family has planned their vacations... Or my family is just very talented at hitting the same week. Either way, it starts being a pattern...
 
 
1 hour later…
7:31 AM
Why was this question closed? It seems perfectly clear.
5
Q: How to install LuaSQL for Lua(La)TeX on Windows with MikTeX

dslaI would really like to be able to pull data directly from ODBC databases into LuaLaTeX and it seems as if the LuaSQL package is the way to go. But for the life of me, after a couple of days of trying, I cannot get it to install, even for a standalone Lua installation. I have tried installing vi...

 
8:21 AM
Jul 6 at 8:56, by samcarter_looks_forward_TUG'21
Will there be a party when siunitx reaches a 3 digit subversion number?
^^^ party is getting closer?
 
 
1 hour later…
9:31 AM
@samcarter_looks_forward_TUG'21 :)
 
@JosephWright /poke
 
 
2 hours later…
12:01 PM
@FaheemMitha best ask about it on meta...
@FaheemMitha but the answer is as usual: because a sufficient number of people voted to close it.
 
12:33 PM
@Skillmon I don't care enough. Anyway, it's an old question.
 
12:56 PM
@FaheemMitha I don't know why it was closed with that reason, but it is more or less a combination of at least three different questions (~>Needs more focus?): How to compile a Lua library on Windows? (~>Off topic) How to find Lua libraries I installed in LuaTeX (Missing some information how and where they were installed, but in basically all cases a duplicate) and (not yet written since the OP didn't get that far) why can't precompiled libraries for Lua 5.0 be used in LuaTeX (again off-topic).
I don't think that I would have voted to close it, but I'm not surprised that people did either.
 
@MarcelKrüger Why is the third one off-topic?
Oh, never mind. If there's a version mismatch, it doesn't make sense to complain about it.
This is a long shot, but has anyone ever seen this message when using LuaTeX?
> LuaSQL: there are open cursors
Looks I might need to do a MWE for this one. Dammit.
 
@FaheemMitha Well I see your point. You could say that "LuaTeX uses Lua 5.3" (5.2 when the question was asked I think) would be a on-topic answer, then the follow up "why can't precompiled libraries for Lua 5.0 be used in Lua 5.2" is off-topic.
 
@MarcelKrüger I was assuming the poster would know which version of Lua was being used in a given version of LuaTeX. And if so, one should use matching versions, I suppose.
 
@FaheemMitha Before closing a database connection you have to close all cursors. But this might fit better into SO than TeX.SX.
 
@MarcelKrüger In this case, it was just one cursor, I think. And I closed it. But I think I need to get an MWE first. Or as M as possible.
 
 
1 hour later…
2:15 PM
@MarcelKrüger That was a new term to me. But I know almost nothing about SQL.
 
@MarcelKrüger ooh a cursor
 
@PauloCereda @TeXnician Do you happen to have an idea why arara would find a rule if started from the command line, but not from within texstudio? This problem came up in topanswers.xyz/tex?q=1862
 
@samcarter_looks_forward_TUG'21 could you check the log? There might be some hints on the first lines about rule location...
 
@PauloCereda Good idea! I'll ask the user.
@PauloCereda Thanks!
 
Morning, @PauloCereda. We've seen that snuggly duck before.
 
2:27 PM
@samcarter_looks_forward_TUG'21 Thank you! Poke me so I can investigate...
@barbarabeeton ooh
@samcarter_looks_forward_TUG'21 it's from TeX Live, right? So the rules should be in place... oh wait! It's version 3.0?!
 
@PauloCereda texlive with arara version 3.0a
 
@samcarter_looks_forward_TUG'21 I cannot remember any perks with that version wrt paths, but there can have other nuisances...
 
@PauloCereda Let's hope that the log files will give some clue
 
@samcarter_looks_forward_TUG'21 I think the logs weren't too useful in version 3. :)
@samcarter_looks_forward_TUG'21 in other news, could I ask you a favour? :)
 
@PauloCereda sure!
 
2:34 PM
@samcarter_looks_forward_TUG'21 will poke you, thanks :)
 
@PauloCereda ... which makes we wonder why version 3? It says texlive2021. Shouldn't this have version 6?
 
@samcarter_looks_forward_TUG'21 Ha! So that might be the issue! He has different path settings...
@samcarter_looks_forward_TUG'21 indent wasn't part of 3.0, it appeared in 4.0 IIRC...
 
@PauloCereda yes, the log files seem to confirm the version problem.
 
@samcarter_looks_forward_TUG'21 hmmmmm I think I know
@samcarter_looks_forward_TUG'21 user has distro TL and vanilla TL
@samcarter_looks_forward_TUG'21 distro TL is outdated, vanilla TL is 2021
 
2:56 PM
@PauloCereda yes, but if the binary is called with the complete path, shouldn't this make sure that the tl21 is used?
Process started: "/usr/local/texlive/2021/bin/x86_64-linux/arara" --verbose --max-loops 3 --log "basic"

__ _ _ __ __ _ _ __ __ _
 / _` | '__/ _` | '__/ _` |
| (_| | | | (_| | | | (_| |
 \__,_|_|  \__,_|_|  \__,_|

arara 3.0a - The cool TeX automation tool
Copyright (c) 2012, Paulo Roberto Massa Cereda
All rights reserved.
 
@samcarter_looks_forward_TUG'21 Yes, it should... but I don't know... this is strange...
@samcarter_looks_forward_TUG'21 let's brute force it:
java -jar /usr/local/texlive/2021/texmf-dist/scripts/arara/arara.jar --verbose --max-loops 3 --log "basic"
@samcarter_looks_forward_TUG'21 still, if arara works and his PATH has issues, it will pick the old binaries and TeX tree...
 
@PauloCereda Thanks! Passed on the suggestion.
@PauloCereda Brute force seems to work :)
 
3:12 PM
@samcarter_looks_forward_TUG'21 it's definitely a PATH problem then. :) This solves half of their problem... :)
@samcarter_looks_forward_TUG'21 see if the user can run this: bash -c env | grep PATH
 
3:34 PM
@PauloCereda The user has PATH=/home/tejas/.local/bin:/home/tejas/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/usr/local/texlive/2021/bin/x86_64-linux/ My guess would be it will first look into folders like /usr/local/bin where there are probably links to the texlive2017 installation from the ubuntu installation, so it never get to search your texlive2021 which is at the very end of the path
 
@samcarter_looks_forward_TUG'21 That's correct!
@samcarter_looks_forward_TUG'21 My guess would be that TL17 would be in /usr/bin.
 
3:53 PM
@AlanMunn Databases are handy, though sometimes annoying. I'm surprised you've managed to escape knowing about them.
@MarcelKrüger If I can reproduce the problem without TeX I was thinking DBA SE.
 
@FaheemMitha I'm not particularly active on either site, so I'm not the best person to ask. But to me it sounds like an issue which is about usage of the client side library which is off topic for DBA SE.
 
@FaheemMitha are you explicitly closing your cursor?
And a database cannot be closed properly if there are active cursors (as per the documentation and source code)...
 
@FaheemMitha The kinds of data I have to deal with don't really need such knowledge.
 
4:08 PM
@PauloCereda No. But I thought the code I was using closed it for me. And I've never had a problem with this code before. I've used it many times.
@MarcelKrüger Perhaps so.
@AlanMunn In my experience DBs are generally useful. At any rate they beat effing spreadsheets.
@PauloCereda I guess the obvious thing is to go back and look at the library again and see what the deal with the cursor is.
 
@FaheemMitha Well my first published paper was a database of acoustic properties of building materials programmed on an Apple II, but then I lost interest. :)
 
@AlanMunn Apple II, you say? That would be a museum piece now.
Possibly a valuable museum piece, I don't know.
@AlanMunn Not very closely connected to linguistics.
 
@FaheemMitha Indeed. It was cutting edge at the time.
 
@AlanMunn Revolutionary.
 
@FaheemMitha No, I worked as a programmer at a university civil engineering research centre for 6 years.
 
4:15 PM
@AlanMunn Oh. How was it? I suppose that was before you became a linguist.
 
@FaheemMitha Yes it was. It was interesting work, very varied, because I would work for a variety of different professors who all did very different things.
 
@AlanMunn Well, it's good that it was a positive experience.
@MarcelKrüger @PauloCereda So, from keplerproject.github.io/luasql/manual.html#cursor_object
> A call to fetch after the last row has already being returned will close the corresponding cursor.
I think that's what I was depending on. I'm mildly curious what is going on here, so I think I'll dig into it a little bit. Perhaps a problem with the last row?
 
@FaheemMitha Without seeing the code there is nothing I can tell you about that.
 
@MarcelKrüger I didn't expect you could. Hence the MWE.
 
4:33 PM
This makes disturbing reading - theguardian.com/commentisfree/2021/jul/22/…
If anyone wants to comment.
We have it bad enough over here.
 
5:33 PM
@FaheemMitha "He knows that you toy with exponentials at your peril." What a scary reality eh?
 
5:43 PM
@JosephWright so you can duck out and leave some unsuspecting person to field the Q&A session at the end?
2
 
@DavidCarlisle that's an argument for prerecording ;-)
 
@DavidCarlisle quack
 
6:07 PM
@PauloCereda dinner
 
@DavidCarlisle oh no
 
6:26 PM
@samcarter_looks_forward_TUG'21 ooh youtube.com/watch?v=xw7T2hV4WlA
2
 
6:48 PM
@BryanK. It's a scary world. Are you in the UK?
 
7:28 PM
@FaheemMitha Well, with regards to resources and environment impact we could well do with losing a few million.
 
@Plergux We?
 
@FaheemMitha The Earth.
 
@Plergux I think you mean the human race. The Earth doesn't care, one way or the other.
But with 7 billion or whatever it is, a few million doesn't really make any difference.
 
@FaheemMitha or that. I think people tend to conflate the two. At least they talk a lot about "Saving the Earth" when what is really needed is saving the people. Or rather saving the rest of the ecosystem from the humans.
 
@Plergux Humans tend to overrate their importance.
They're basically very uppity monkeys.
I hope you're doing well in Iceland. Assuming you're there now.
 
7:35 PM
@FaheemMitha Quite.
@FaheemMitha Yes, we're doing okay. We had removed all restrictions but there has been a bit of a backlash. A combination of lots of tourists and apparently the Jensen vaccine was crap :p
 
@Plergux Johnson vaccine?
Or Johnson and Johnsons vaccine.
 
@FaheemMitha It's the same. It's called either Johnson & Johnson or Janssen.
 
@Plergux I see.
 
@FaheemMitha at least according to the CDC :p
 
@Plergux What does the CDC have to do with it?
 
7:40 PM
@FaheemMitha Well, it's the Centre for Disease Control. cdc.gov/coronavirus/2019-ncov/vaccines/different-vaccines.html
 
@Plergux I didn't realise they were in charge of naming the vaccines. :-)
 
7:58 PM
@PauloCereda :D They should make a movie!
 
8:11 PM
@PauloCereda you got super secret duck mail :)
 
8:46 PM
@UlrikeFischer @DavidCarlisle Did you get GitHub notifications/e-mails/... related to failed GitHub Actions in the 2e repo about 10 minutes ago?
 
@MarcelKrüger no, I see no mails. But I'm not sure if I enabled all notifications. Which one are relevant?
 
@UlrikeFischer GitHub has a special setting for "GitHub Actions" notifications. They are the relevant ones.
@UlrikeFischer But it might be that you didn't get anything. I think the default is to only notify the user who triggered the actions in question.
 
@MarcelKrüger not as far as I can see. I am only occasionally online at present
 
9:06 PM
@DavidCarlisle Looks like I have to look into sending notifications manually then...
 
@MarcelKrüger well I didn't get notifications about travis either.
 
@UlrikeFischer They went to the latex3-commits@tug.org list.
 

« first day (3918 days earlier)      last day (137 days later) »