« first day (3564 days earlier)      last day (54 days later) » 

1:31 AM
Hi, everyone, some of you here may have tried this out using xelatex
\documentclass{article}
\usepackage{unicode-math}
\setmathfont{XITS Math}
\begin{document}
X $a+b=c$ Y
\end{document}
With lualatex it works OK, but, apparently I modified something when updating and now it doesn't work with xelatex :(
 
 
5 hours later…
6:55 AM
@JosephWright I guess so. Still I'm unsure what to do with line 1608. I'll remove 1618 in my PR (want to take a look what else can be made a bit faster).
@JosephWright realized the line numbers don't fit the latest master, because those are the line numbers of my PR, if you want to take a look at the code where the test seems either missing or is superfluous, it is github.com/latex3/latex3/blob/… and github.com/latex3/latex3/blob/…
 
7:47 AM
@PabloGonzálezL with xelatex it works fine for me, it fails with xelatex-dev as unicode-math no longer can remove code added by amsmath from the begin document hook.
 
 
1 hour later…
cis
9:11 AM
@ FontForge

Is there a way to add a info-text in FontForge? I think, I could need that sometimes.
 
9:44 AM
I am using TeXShop with pdflatexmk in order to not have to manually run bibtex every time (pdflatexmk does it for me). Unfortunately, whenever I make a mistake and write incorrect LaTeX, something gets messed up in the auxiliary files, causing pdflatexmk not to compile anymore until I delete the aux files. Is there a better workflow?
 
cis
@Szabolcs At arara, I use the clean-rule mostly.
 
@Szabolcs how do you stop latex when you make such a mistake?
 
@Szabolcs I have no such problem with latexmk --- it normally runs to the end with nonstopmode and then recompiles when something changes. It's true that sometime you have to clean manually (latexmk -C file) especially when changing babel options and the aux file must be deleted (or add a space and save again, that is).
 
10:06 AM
@JosephWright are you there?
 
10:21 AM
I don't stop it manually. I let the IDE (TeXShop) handle it.
Basically, I make a mistake, I compile, then of course LaTeX prompts for input. But this is happening in the IDE. So if I correct the mistake, and re-compile, the IDE automatically kills and re-runs LaTeX (or rather latexmk)
At this point I typically see output like this: pastebin.com/1wriW5TS (I changed the document name to mydocument, don't actually use that silly name :)
I guess I need to read the latexmk docs in detail ... no time for that now, as at this time it's quicker to just delete aux files. I really should do that after done with this project
I do see the suggestion about the -f option in the error message, but complete processing every time would slow things down a lot
 
@UlrikeFischer Hi
 
@JosephWright we are in the zoom meeting now. want to join?
 
@UlrikeFischer Sorry, can't: some work things have come up
 
@JosephWright ok. no problem.
 
@UlrikeFischer ooh :)
 
@samcarter_left_tex.se ooh
 
@PauloCereda Looks delicious, doesn't it?
 
@samcarter_left_tex.se :)
 
@PauloCereda Good theory! (I love this special effect that makes the video look as shaky as if it was recorded during a bumpy ride with the millennium falcon :) )
 
@samcarter_left_tex.se ooh speed :)
 
yo'
11:49 AM
Hi all! (Back from vacampation)
 
@yo' Welcome back! How was your vacation?
 
yo'
@samcarter_left_tex.se very busy, when you volunteer at a scout camp :)
 
12:09 PM
@yo' I see :) Did you celebrate World Scout Scarf Day?
 
yo'
@samcarter_left_tex.se technically yes :) we were returning from the camp, and we usually wear the scarf for travelling.
 
@yo' Excellent timing then :)
 
yo'
@samcarter_left_tex.se yep :)
 
12:26 PM
@UlrikeFischer regarding the new hooks, will the page color shipout stuff also be hookable? Because if I then also make the memoir trimmarks via the shipout hooks then perhaps they can live together (stacked appropriately) or something like that (haven't looked into the details yet)
 
@daleif not quite sure what you mean, but we are looking at \pagecolor: it is currently at the wrong place, at least for pdflatex, it overwrites stuff.
 
@UlrikeFischer We will fix that :)
 
Anybody got any experiences with cross-compiling for mac on a Linux box?
 
@UlrikeFischer exactly. In memoir we have a class option to add trimmarks (say if you're using B5 to be printed on A4), then adding \pagecolor will leave the color box on top of the trimmarks. This is a very old issue
 
@daleif as @JosephWright wrote: we will fix it, we have an internal issue about this. The pagecolor should always be before the shipout/background hook, so you can use this hook for the crop marks.
 
yo'
12:31 PM
just wanted to VTC a question only to realize that the list of close reasons makes even less sense than when I last tried :(
 
@UlrikeFischer Also in l3color: I'll probably add 'a bit later'
 
yo'
@DavidCarlisle We're coming there (still unable to give specific dates though)
 
@Skillmonlikestopanswers.xyz Depends a bit what you are trying to compile. If it is not too complicate (regarding libraries etc.) the linux binary might simply work on mac, too.
 
@UlrikeFischer As far as I know this is the only memoir hook into shipout. The package and file hooks (that you mailed me about should be mappable to the kernel macros, perhaps with a note that one might want to use the kernel functions instead as they can offer more control than the memoir interface
 
@Skillmonlikestopanswers.xyz From memory, the tests are needed as there needs to be special handling for the 'first pass': you could speed up by using a dedicated 'first sep' function
 
12:36 PM
@samcarter_left_tex.se well, I have never really used a Mac and no access to one, so I really don't know what to look out for. The program is indeed not too complicated (335 lines, six libraries).
The AUR seems to contain some osxcross variants... Not sure whether it's worth it though :)
 
@Skillmonlikestopanswers.xyz I could offer to test with an old osx, if this would be any help
 
@samcarter_left_tex.se well, you could only test if it starts up and throws the correct errors, I can't (am not allowed to) send you the data to actually test the program on :(
 
Hello
How put the char in specific place? For example i need unicode\symbol("1234) from fontnamefile.ttf put on page 1 in 30pt == x and 40 pt ==y , how getkerning ?
 
@pronto you could do so using TikZ and its page anchors. Search for absolute positioning, you should find some solutions.
 
I must create a latex document
but I need create my own kerning in lua
;(
 
1:32 PM
Hello @PauloCereda :)

Sorry for bothering but I would be grateful if you don't mind taking a look at my arara question here https://tex.stackexchange.com/q/557131/2288
 
@Diaa Hi. :)
@Diaa I will take a closer look later on. :)
 
@PauloCereda Thanks in advance :)
 
@AlexG animate breaks currently when compiled with latex-dev as it patches \document in an incompatible way to the new hook system.
\documentclass{article}
\usepackage{animate}
\begin{document}
blb
\end{document}
! Extra \endgroup.
\document ->\endgroup
 
@UlrikeFischer Oh dear
 
@JosephWright ? it is harmless, we know that by now. Actually the animate code says "not sure whether still needed at all", (and imho it isn't) so it is a good opportunity to clean up the code ;-)
 
2:13 PM
@UlrikeFischer Ok. I am going to change this.
 
@UlrikeFischer On windows are OK, but wsl/fedora
! Package fontspec Error: The font "XITS Math" cannot be found.

For immediate help type H <return>.
...

l.4 \begin
{document}
?
kpathsea:make_tex: Invalid filename `XITS Math/OT', contains ' '

Package fontspec Warning: Font "XITS Math" does not contain requested Script
(fontspec) "Math".

kpathsea:make_tex: Invalid filename `XITS Math/OT', contains ' '
kpathsea:make_tex: Invalid filename `XITS Math/B/OT', contains ' '
kpathsea:make_tex: Invalid filename `XITS Math/OT', contains ' '
 
2:36 PM
@UlrikeFischer Solved fc-cache -r :) ...Apparently it's still broken by using lualatex-dev
! Package filehook Error: Detected unknown definition of \InputIfFileExists.
Use the 'force' option of 'filehook' to overwrite it..
 
3:01 PM
@PabloGonzálezL yes we know about this, there is already an issue open for filehook, at lualatex-math will need an update too.
 
3:16 PM
@UlrikeFischer Do we need that package with the new Kernel updates?
 
@PabloGonzálezL I don't think so, imho you can do everything with the new hooks. There is actually a reimplementation filehook-ltx which defines most of the commands, it you load it first it will also suppress the filehook loading and then unicode-math works again.
 
cis
0
Q: FontForge: How to add a personal info text

cisIs there a way to add a info-text in FontForge? I think, I could need that sometimes. I mean something like that:

 
Everyone applyinf for the job?
 
@JosephWright not this time :)
 
@JosephWright Trying to answer: What would be your initial response to the following example user support request: "Your docker container keeps crashing."?
 
@StefanKottwitz "Prove it." :)
 
3:50 PM
@StefanKottwitz I saw that one: seems a rather unusual question
 
@PauloCereda "Please provide a MWE." ;-)
 
@StefanKottwitz LOL
@JosephWright I like the way you use "unusual" instead of "wacky" or "weird" or... :)
 
@JosephWright where did you saw it?
 
@JosephWright The webpage doesn't load here. Which position are they hiring for?
 
@UlrikeFischer Twitter
 
3:52 PM
@PauloCereda Said the unusual duck. :-D
 
@StefanKottwitz quack :)
 
@MarcelKrüger 'Product Specialist
> Overleaf is looking for an outstanding Product Specialist to help us continue to provide first-class support to our growing community, focused on the support and onboarding of our institutional and enterprise customers. This is a remote, full-time role, ideally based in either the UK or EU.
 
@JosephWright "outstanding"
 
@PauloCereda Another word for wacky.
 
I like how they want a product specialist without you knowing about their inner workings. :)
@JosephWright so UK is not in EU anymore?!
@StefanKottwitz ooh
 
cis
3:55 PM
0
Q: genealogytree: How to use braces as the standard connection style?

cisHow can I use a curly brace (in black) as the standard connection style in genealogytree? That means: How to change the default (which is these green lines). \documentclass{article} \usepackage[T1]{fontenc} \usepackage{lmodern} \usepackage[all]{genealogytree} \begin{document} \begin{tikzpictur...

 
I wanna use outstanding in more sentences from now on.
 
@PauloCereda ER, no
 
@JosephWright oh no
 
@PauloCereda Quarantined.
 
@StefanKottwitz oh no
In other news, my GPS miraculously began to work.
 
3:59 PM
@PauloCereda Did you delete the .aux file?
 
@StefanKottwitz I've no idea what I've done, really, but it worked. That surely makes me an outstanding product specialist. :)
 
@PauloCereda If you omit the "no idea" part.
 
@StefanKottwitz :)
 
@PauloCereda outstanding idea!
 
@Skillmonlikestopanswers.xyz ooh
 
4:06 PM
@PauloCereda try "ooh outstanding!" next time
 
@StefanKottwitz ooh outstanding
 
@PauloCereda You're hired!
 
@StefanKottwitz YES
 
@PauloCereda You got a rose on today's Bachelor TV series episode.
 
@StefanKottwitz ooh
 
4:10 PM
@PauloCereda ("... outstanding!")
 
@StefanKottwitz ah that one :)
 
 
1 hour later…
5:15 PM
@Skillmonlikestopanswers.xyz I hope to look at your PR later today
 
6:02 PM
@JosephWright The latest LMTX version is most likely incompatible with expl3's intarray... (mailman.ntg.nl/pipermail/ntg-context/2020/098973.html) ("Most likely" means it breaks in LuaMetaLaTeX, but I haven't tested a ConTeXt example yet.)
 
@MarcelKrüger Presumably we could use Lua as the implementation here, and simply avoid fontdimens? Could be the LuaTeX path, so we would see the same 'gain' in LuaLaTeX?
 
@JosephWright Sounds good, I'll write a draft implementation.
 
6:43 PM
@JosephWright saw your comment (and replied). Will include some small tests.
@JosephWright should the test directly test \__keys_trim_spaces:n or should I use some interface level code which will need the correct behaviour?
 
@samcarter_left_tex.se -- Animal crackers! Yes! By the way, the Providence zoo has a new baby two-toed sloth; I saw it in the news just a few days ago.
 
@JosephWright went for the top-level approach (seems cleaner for such tests)
@JosephWright I don't mean the tests in general just the test for an empty \l__keys_module_str, it seems like the \tl_set:Nx \l_keys_path_str on line 1623 might result in the wrong path if \l__keys_module_str is empty (but I don't know how to correctly test this)
@JosephWright now some tests for ctex are failing, but I honestly don't know what's happening there.
 
7:24 PM
@Skillmonlikestopanswers.xyz that happens not the first time.
 
@UlrikeFischer yes, I remember that there was another time when I didn't know what was happening.
 
7:38 PM
@Skillmonlikestopanswers.xyz Indeed
@Skillmonlikestopanswers.xyz Not Our Fault
 
@JosephWright not mine! Build worked with all checks, I altered a single .lvt and .tlg because you requested it, now a completely unrelated test fails.
@JosephWright let's blame @DavidCarlisle for a change!
 
@Skillmonlikestopanswers.xyz Sure: it's an update thing, I think (can't reproduce locally, probably have to wait until tomorrow)
 
@JosephWright got a three to four times faster \__keys_parent:o code (but it needs 24 lines of code instead of 9...)
 
@Skillmonlikestopanswers.xyz A few lines are OK :)
@Skillmonlikestopanswers.xyz Speed-ups will help here long-term, so it's all good
Everyone watching the snooker?
 
@JosephWright and it won't work in an f-type expansion (the current implementation would, but this is never used, it only gets used inside of c, v, and x)
 
7:46 PM
@Skillmonlikestopanswers.xyz It's internal, so only has to work in places that are required
 
@JosephWright It fails locally for me. Should I update the test file?
 
8:03 PM
@PhelypeOleinik Do you know what's changed?
 
@JosephWright In the test file, some penalties between characters (and a (load cache: extra_lmromanslant10-regular.luc)). But no idea what caused the change
@JosephWright the load cache seems to be some luaotfload change...
 
@PhelypeOleinik someone got a fast mirror?
 
@PhelypeOleinik Could be
 
@PhelypeOleinik which test fails?
 
@Skillmonlikestopanswers.xyz I use ftp.fau.de. Germans are efficient :-)
2
@UlrikeFischer ctex002 (in contrib)
 
8:07 PM
@PhelypeOleinik I use the same, but haven't updated today...
 
@PhelypeOleinik in the develop branch?
 
@UlrikeFischer No, the master branch in latex3/latex3
 
@Skillmonlikestopanswers.xyz There wasn't anything noteworty, as far as I remember
 
@PhelypeOleinik except for the stuff breaking ctex002?
 
8:09 PM
[Mon Aug  3 08:44:48 2020] update: biblatex-publist (55801 -> 56028)
[Mon Aug  3 08:44:50 2020] update: bitter (55952 -> 56026)
[Mon Aug  3 08:44:54 2020] update: forum (55952 -> 56025)
[Mon Aug  3 08:44:59 2020] update: install-latex-guide-zh-cn (55849 -> 56027)
[Mon Aug  3 08:45:11 2020] update: luatexja (55207 -> 56029)
[Mon Aug  3 08:45:14 2020] update: texlive-docindex (56011 -> 56023)
[Mon Aug  3 08:45:16 2020] update: texlive-scripts (56012 -> 56024)
[Mon Aug  3 08:45:25 2020] update: updmap-map (56012 -> 56024)
@Skillmonlikestopanswers.xyz No CTeX or luaotfload ^^^
 
@PhelypeOleinik strange.
 
@PhelypeOleinik @Skillmonlikestopanswers.xyz there was an update for luatex-ja yesterday, it could have hit travis now.
 
@UlrikeFischer that sounds more like it.
 
@UlrikeFischer But would it affect CTeX?
 
@PhelypeOleinik well the log on travis loads it, so yes.
 
8:12 PM
@UlrikeFischer Ah
 
@PhelypeOleinik Sounds like you should check it in
 
@JosephWright Okay. I'll commit to master then @Skillmonlikestopanswers.xyz can git-magic to his branch
git magic should exist...
 
@PhelypeOleinik you could send a PR to Torvalds.
 
@Skillmonlikestopanswers.xyz At least he would have a laugh at my C code :-)
 
@barbarabeeton Oh, the baby sloth is so cute!
user image
4
 
8:26 PM
@PhelypeOleinik I just tried: it fails after the luatexja update and it is quite obviously a wanted change.
 
@UlrikeFischer Okay, I've just pushed an update
@UlrikeFischer What does the change do (apart from removing the penalties)?
 
@PhelypeOleinik they seem to force the loading of some font caches.
 
@JosephWright sorry to nudge you, but did you look at the empty string test in l3keys yet? (I just really want to make sure there is nothing slipping through here)
 
@Skillmonlikestopanswers.xyz I'll take another look
@Skillmonlikestopanswers.xyz Didn't I say that this was to do with watching out for the special case of a first loop?
 
@JosephWright the strange thing is, it is only used in one branch on the first loop, not in the other...
(or better, it is only used on the non-looping branch of the first call)
@JosephWright so, yes, you did, but it didn't make sense to me (maybe I'm missing out on something really obvious here)
 
8:53 PM
@samcarter_left_tex.se -- But he's upside down! I'm sure the keepers are just going crazy!
 
@Skillmonlikestopanswers.xyz I'll have to look again, then: just sorting something else
 
9:12 PM
@JosephWright I think I'm calling it a day for now. I'm in line 2591 and my concentration (and eyes) is lacking. Maybe I'll find some time tomorrow looking through the rest for things which can be tuned up a bit without changing the system too much (in that regard I'm pretty hesitant).
 
@Skillmonlikestopanswers.xyz Good plan: I want to finish some colour stuff ATM
 
 
1 hour later…
10:21 PM
@UlrikeFischer No version checking will ever cover the most... exotic cases :-)
 
@PhelypeOleinik ;-).
 

« first day (3564 days earlier)      last day (54 days later) »