« first day (3446 days earlier)      last day (54 days later) » 

6:21 AM
The US President seems to try to be as disgusting and obnoxious as possible. It's like he's entered a contest.
It's really strange. Politicians don't normally act like this.
 
 
2 hours later…
8:12 AM
@JosephWright New speed comparisons for the next expkv version. I'm currently at 1.535 times of keyval for an empty list, 1.778 times for a single key, and 1.588 times for 100 keys. This makes expkv the third fastest implementation for an empty list (simplekv being a bit faster), and the second fastest for one key or more. All that while still being category active robust and brace bug free.
 
8:38 AM
@PauloCereda Did you know that Stack Exchange supports Vim keybindings?
12 hours ago, by barbara beeton
@PauloCereda -- New Zealand is fortunate to have such an empathetic and competent head of state.
@barbarabeeton Being a current resident in New Zealand, I can assure that the local government here is just as incompetent as in any other country.
 
9:00 AM
@Skillmonlikestopanswers.xyz so I win! (Your last sentence is just details:-)
 
@HenriMenke OH MY
 
@PauloCereda You can enable them in preferences.
 
@HenriMenke Thank you!
 
@PauloCereda they should rename that menu option as "inflictions" rather than "preferences", no one would prefer vi bindings, that would be silly...
 
@DavidCarlisle oh
 
9:04 AM
@DavidCarlisle no, you don't. I'm expandable!
 
@Skillmonlikestopanswers.xyz how are you feeling today, mr. rabbit?
 
@PauloCereda a bit less angred, as expkv is flourishing. But my productivity in the university took a big hit yesterday, and I'm not sure how long it'll take for it to recover.
 
@Skillmonlikestopanswers.xyz Word issue sorted?
 
@HenriMenke which keybindings are supported? Since I have VIM-like bindings in my browser via a plugin, I'm somewhat unsure whether I should give them a try.
@JosephWright not yet. Since I don't have admin rights I can't do a reinstall on my own and have to wait for the responsible technician to spare a minute.
I just exported my Outlook-profile to have a backup for the reinstallation. Upon exporting I got the following error "Filename invalid". That was the default filename provided by Outlook itself!
 
9:24 AM
@Skillmonlikestopanswers.xyz addons.mozilla.org/en-US/firefox/addon/textern ? "It's all text" was easier to use, but still, being able to lauch vim for whatever text entry box is quite a plus.
 
@Skillmonlikestopanswers.xyz details:-)
Just installing the new chrome flavoured edge.....
 
@DavidCarlisle ew
 
@PauloCereda you rather I stuck with the IE-flavoured version?
 
@DavidCarlisle FF <3
 
@Rmano the plugin I use (Tridactyl) already supports launching vim for any text-box via the keybinding Ctrl+I
 
9:32 AM
@PauloCereda FF nightly is my default browser but checking things work on other browsers is actually what I'm supposed to be doing.. And I'd guess edge will catch up rapidly with chrome in the next year or two.
 
@PauloCereda I second FF
@DavidCarlisle in spying?
 
We've just had a long email about which tools we are and are not allowed to use for work data ...
Oddly, web browsers don't get mentioned
 
@Skillmonlikestopanswers.xyz no in user base. This is work not the place for unsubstantiated rumours.
@JosephWright z... come up?
 
@DavidCarlisle Yup
 
I found an error which coincides with the time my bug this morning was. Was an error thrown by Office's Licensing Service. But it was only thrown once yesterday and once today. Though I had 10 crashes yesterday and 2 today.
 
9:34 AM
@DavidCarlisle We have MS Teams, BlackBoard Collaborate and something called Echo360
 
@JosephWright more or less coincidentally we'd switched to microsoft teams for more or less everything before this started.
 
@DavidCarlisle Similar here, though we have separate student-facing tools (BlackBoard, as I said)
 
@JosephWright we simplify that by not having students
 
@JosephWright allowed or disallowed?
 
@Skillmonlikestopanswers.xyz Not allowed: our official position is Teams
@Skillmonlikestopanswers.xyz I don't have a work-provided laptop, so they get a lot less say about my setup
 
9:37 AM
@JosephWright do they really expect you to work from home without giving you a laptop or did you just not want one as you have your own?
 
@DavidCarlisle ooh
Teams is confusing
 
@JosephWright hey, same setup here. It seems quite a standard... and I am happy because both work ok in Linux. What happened with z... ?
TL20[romano:~/texlive2020] 5s % tlmgr update --all --self
tlmgr: package repository texlive.info/tlpretest (not verified: valid signature with expired key)
 
@PauloCereda so are students
 
@DavidCarlisle ooh
 
Oops, what happened to my TL2020 pretest? Let's dig it...
 
9:39 AM
@Rmano there is discussion this morning about keys on tl list
 
@DavidCarlisle Like most academics, it's understood that we'll have our own laptops or possibly desktops at home; I know a few colleagues did say they'd have to go in to collect their work deskstops ...
 
@DavidCarlisle Ah ok I'll wait
 
@JosephWright ooh
 
@Rmano It's not allowed; my employer has had a couple of issues with data protection (have been in the media so I can say) and is very worried about further breaches; they focus on the technical side, but the human factor is where the issue arises
 
@DavidCarlisle And confused, too.
 
9:40 AM
CAMBRIDGE ANALYTICA
ooh it has Cambridge in it
 
@PauloCereda or rather, they were in Cambridge
 
@Skillmonlikestopanswers.xyz The Vim part of the keybinding is essentially limited to j and k for navigating lists.
 
@DavidCarlisle We were asked what we'd need to work from home; my lpatop is suffering a bit, so at some stage I might be asking for a contribution for a new one. (I have some work that really needs a more powerful system, but I'm not sure work will spring for a MacBook Pro ...)
 
@MarcelKrüger, hi! I need your help with fontawesome5. Is there a way to force dvilualatex to use the Type1 version of the font? Yes, I need Lua and DVI output. Currently I fail to convert the dvilualatex-generated DVI to PS with dvips.
 
we get ok-ish laptops on a 4year cycle (normally) (mine's a three year old dell lattitude i7) people who regularly work from home can also get monitors etc for home, I don't so I grabbed the screen from my desk as we packed up the office. With cable to the house and bpn into the machines at work don't really need that powerful machine here, although a bit of extra speed always welcome:-)
 
9:57 AM
@DavidCarlisle @JosephWright I just run into a curious error trying to debug a l3build test failure. The following document fails to compile for me with xelatex --parse-first-line - but only if the aux-file doesn't exists:
\documentclass{article}
\usepackage{hyperxmp}
\begin{document}
 blblb
\end{document}
! Argument of \hyxmp@first@char@i has an extra }.
 
@AlexG you'd be best not to load luaotfload at all if using dvips, although as that's in everyjob that may take a bit of fiddling to achieve
 
@DavidCarlisle What do I have to do for this? I am lost :(
 
@UlrikeFischer works for me, oh is \documentclass actually first or do you have a blank
 
@DavidCarlisle no blank line. If I add e.g. a line with % before it is works again, so a work around is easy. (The test had \input{regression-test} there and this fails too).
 
@AlexG simplest is to have a file luaotfload-main.lua alongside your document that just says error() then latex will skip the lua font setup
 
10:06 AM
@DavidCarlisle I'm not sure if this is a good idea. Imho most font packages which are luatex aware will be quite surprised if luaotfload is suddenly missing.
 
@DavidCarlisle Thanks! Though it doesn't sound like a clean solution. Shouldn't it simply be removed from the format for dvilualatex?
 
@UlrikeFischer It's not l3build's fault ...
 
@JosephWright well it's l3build which inserts the --parse-first-line option ;-). It took me a bit time to find the problem as everything worked with with xelatex alone.
 
@AlexG No, as its not impossible to have a dvi driver that can cope (in fact I think I saw one advertised last year) It would be best if it converged on the same dvi conventions as xetex then xdvipdfmx would work, but more likely is that the dxdvipdfmx maintainers extend to support the luatex dvi output. Either way it's not latex's job to decide:-)
 
@UlrikeFischer Er, not here
 
10:11 AM
@AlexG disabling is a quick test that what you want to do is possible it#s also possible to let it load as normal but have an in-document declaration that resets the font callbacks not to use it but I'd have to think a bit harder to set that up than I have time for now
 
@DavidCarlisle Ok, I will first try the brute-force method you suggested.
 
@JosephWright you mean you don't use the option? Then where does it come from? I can clearly see %&-line parsing enabled. in the l3build logs.
 
@UlrikeFischer I mean if I use your example and run xelatex test from the command line, I get the same error
@UlrikeFischer That's the default
 
@UlrikeFischer yes but @AlexG wants to surprise them as if they are not surprised and load an opentype font, it'll fail later, so it may as well fail earlier so you can force them to take the latex code path
 
@JosephWright oh, you are right. It happens also without the option. But when I call from winedt I get it only when I add the option on the spot.
 
10:23 AM
@DavidCarlisle Actually, in the end, I want to use dvisvgm, not divips. It claims to be able to embed OTF. Thus, I am not forced to use Type1. But, dvisvgm fails nonetheless: WARNING: font file '[FontAwesome5Free-Solid-900.otf]:script=latn;' not found. Maybe I should ask M. Gieseking.
 
@UlrikeFischer So WinEdt is deliberately suppressing it
 
@JosephWright no, I mean I normally don't use the option, but when starting a compilation I have a dialog where I can enter stuff like --jobname=blub or --recorder or whatever additional option I want. And when I add there --parse-file-name then the compilation fails.
 
@UlrikeFischer Strange; like I say, that's the default behaviour anyway
 
@AlexG This will lead to lots of problems and is not supported, but try
\expandafter\def\csname ver@fontawesome5-utex-helper.sty\endcsname{DUMMY}
\expandafter\def\csname ver@fontawesome5.sty\endcsname{DUMMY}
\usepackage{fontawesome5-generic-helper}
\expandafter\let\csname ver@fontawesome5.sty\endcsname\undefined
\usepackage{fontawesome5}
\expandafter\let\csname ver@fontawesome5-utex-helper.sty\endcsname\undefined
 
@JosephWright well, my university wants to actually use that and purchased a bunch of licenses...
@HenriMenke then I'll pass on those and continue using my plugin.
@HenriMenke thanks for the info.
 
10:37 AM
@Skillmonlikestopanswers.xyz Lots have; it's a question of what is sanctioned (and therefore has contracts in place)
 
@JosephWright considering the news from last week regarding it makes me wonder whether that's a good decision.
 
@Skillmonlikestopanswers.xyz I suspect a lot of people in formal IT work are ... having 'fun'
 
@DavidCarlisle bah
> Bill Gates has more dollars than you have seconds left in your life.
OH NO
 
@JosephWright I found the real source of the problem. hyperxmp is trying to get the date by using \filemoddate{\jobname.aux} if \filemoddate is defined (which is only for xelatex the case), and later fails if it gets an empty result here. The winedt behaviour must have been cause by remaining older aux-files.
 
@JosephWright @DavidCarlisle ^^ WHAT
 
10:54 AM
@PauloCereda LOL
 
@UlrikeFischer Ah, right
 
@AlexG yes for svg you'd think that at least referencing otf fonts should be relatively easy, even if it doesn't embed them, but the driver needs to understand the extended filename syntax.
 
@MarcelKrüger Thank you. Finally I want to use dvisvgm which claims to be able to use OTF.
 
@PauloCereda He succeeded, Theresa May did not lead Britain out of the EU. Scientific proof of the power of spoon bending.
 
@DavidCarlisle ooh spoons
 
10:58 AM
Reinstalling Office didn't help. Now I swiped the user-config using some Microsoft tool (why again am I trusting any software this lowsy corporation provides?). Let's see whether it still crashes.
 
@DavidCarlisle Perhaps dvisvgm can even convert and inline them. I need to read about font map files. Maybe a properly crafted .map file can help dvisvgm to find the OTF file? Where could I read about map-file syntax?
 
@AlexG it supports the extended dvi produced by xetex, it might be interesting to take a simple example that uses opentype and use dviasm to compare the xetex and luatex dvi output it may be possible to make luatex output look like it came from xetex...
 
@DavidCarlisle I am going to make an xdv and a dvi.
 
@DavidCarlisle @AlexG It will not be done with understanding the filename syntax. LuaTeX doesn't write the glyph index but the character index (aka the index in the characters array, generally the codepoint) into the DVI file. For characters which have a Unicode mapping in the font this is probably something you can work with in SVG files, but for other characters the fontloader applies an arbitrary mapping into Unicode's private use area.
So these glyph indices are basically useless if you don't export additional information from LuaTeX.
 
@DavidCarlisle xelatex --no-pdf + dvisvgm --exact --zoom=-1 --font-format=woff2 <xdv file> perfectly works on the example code (to follow). The otf font is converted and inlined into SVG:
\documentclass{article}
\pagestyle{empty}

\usepackage{fontawesome5}

\begin{document}
\faArrowRight\faArrowLeft
\end{document}
 
11:14 AM
Still crashing with reset-user config. :(
 
dviasm output on the XDV:
[preamble]
id: 7
numerator: 25400000
denominator: 473628672
magnification: 1000
comment: ' XeTeX output 2020.04.07:1306'

[postamble]
maxv: 633pt
maxh: 407pt
maxs: 3
pages: 1

[font definitions]
fntdef: "/home/grahn/bin/texlive/2020/texmf-dist/fonts/opentype/public/fontawesome5/FontAwesome5Free-Solid-900.otf" at 10pt

[page 1 0 0 0 0 0 0 0 0 0]
xxx: 'pdf:pagesize default'
down: 633pt
push:
  down: -605pt
  down: 575pt
  push:
    down: -540pt
    push:
      right: 77pt
      fnt: "/home/grahn/bin/texlive/2020/texmf-dist/fonts/opentype/public/fontawesome5/FontAwesome5Free-Solid-900.otf" at 
 
@MarcelKrüger hmm so need to stick with Hello World examples where the Unicode mapping is guessable :( Or persuade you add an act-like-xetex option... ?)
@AlexG note Marcel's comment above though...
 
@DavidCarlisle That's beyond me :(.
This is what dviasm says about the dvilualatex generated DVI.
[preamble]
id: 2
numerator: 25400000
denominator: 473628672
magnification: 1000
comment: ' LuaTeX output 2020.04.07:1318'

[postamble]
maxv: 633pt
maxh: 407pt
maxs: 3
pages: 1

[font definitions]
fntdef: [FontAwesome5Free-Solid-900.otf]:script=latn; at 10pt

[page 1 0 0 0 0 0 0 0 0 0]
xxx: 'header=l3backend-dvips.pro'
push:
  push:
    push:
      right: 77pt
      down: 63pt
      fnt: [FontAwesome5Free-Solid-900.otf]:script=latn; at 10pt
      set: ''
    pop:
  pop:
pop:
Isn't it just a matter of correctly setting up file paths to make dvisvgm happy?
 
@AlexG No, the issue is that making sense of the '' requires information dvisvgm doesn't have.
 
All my Word crashes so far:
06.04.
08:56	Opening an internal document of the chair -> crash
12:56	Switched to reading mode in a short document and back to editting mode -> crash
13:02	Started a new file on, documenting all the crashes I'll experience over the time -> crash
13:06	Retried starting the above mentioned file -> crash
16:28	New File with one sentence. Switched to reading mode with inverted colour. Switched window to FF and back -> crash
16:30	Opened the crashes log, switched to FF and back -> crash
16:35	Crashes log opened and added the last two crashes. Saved and wanted to close Word, upon closing -> crash
 
11:22 AM
@Skillmonlikestopanswers.xyz Something is badly wrong with your PC ...
 
@Skillmonlikestopanswers.xyz That cannot only be Word's fault :)
 
@MarcelKrüger I see. So, there is no simple solution :(.
 
@JosephWright the technician logged into the local administrator account and reinstalled Office. Tried with a few documents without issues. I opened some documents under my user's profile without any changes to the settings (Windows didn't remove my user settings despite the reinstallation) and it still crashed. I wiped my user's settings using some MS tool and it still crashes.
@mickep You're right. Most likely it's also Microsoft's fault. I didn't do anything weird with any of their products. Only changed some settings through the graphical user menus of their <curse replacement> programmes. Still crashes.
 
@Skillmonlikestopanswers.xyz hardware fault in the disk with your user data? Not sure why you blame Microsoft particularly. It is clearly very specific to your machine as Word has a Billion users and clearly most of them are not having this issue.
3
 
@Skillmonlikestopanswers.xyz Well, I'm not going to argue with you about that, but my guess is non-compatible hard ware. I have not used Word for many many years, but I know others who do, and they usually have no problems with crashes. Good luck, anyways! :)
 
11:28 AM
@DavidCarlisle Yup, it's very odd
 
@MarcelKrüger where is xdvipdfmx or dvisvgm getting the mapping from?
 
@DavidCarlisle Which mapping?
Both in DVI files for classical fonts and in XeTeX's XDV files the glyph values are directly the glyph indices written into the PDF file, so there is no need to apply any mapping.
 
@MarcelKrüger sorry ignore that comment I misread the dviasm output (or at least forgot whether I was looking at luatex or xetex output:-)
 
@DavidCarlisle why I specifically blame Microsoft? Because it works within another user account. I don't have issues with any other installed software, only Microsoft Office Word bugs. The disk on which the OS is installed is new. I didn't change any exotic setting and only changed settings through the graphical menus provided by Microsoft. Nothing exotic here, no tinkering with any strange settings. Only changed some colours and disabled transparancy.
 
@DavidCarlisle Having an act-like-xetex option would need either a full XDV driver or at least an extra pass to rewrite all glyph nodes to use glyph indices as values. That should be doable but some work (as long as no virtual fonts are used). Of course that option would require a driver which allows big glyph indices even in a normal DVI file.
 
11:34 AM
@mickep hardware can't be the problem. Another user account on the same machine isn't affected by the bug.
 
@Skillmonlikestopanswers.xyz you seem predisposed to the idea that it's a word bug so nothing much else can be suggested. Odd that it only affects you though.
@MarcelKrüger yes probably easier to just write pdf as normal then externally convert the pdf to svg?
 
@DavidCarlisle Maybe. I'll have to look into dvisvgm to see how separate the formats are handled.
 
@MarcelKrüger But I guess we could output a map that connects the  in the set above with the GID. Perhaps dvisvgm could add an option to use such a map.
@Skillmonlikestopanswers.xyz you probably infected your word version with the ihateword-virus and now it is in intensive care.
 
@DavidCarlisle and only Word. What else would you suspect? I can root out hardware fault. With another user on the same machine it doesn't crash (just logged off my regular user and used another one, started Word and switched back and fourth for 5 minutes without crashes). I'm honestly clueless on what else should cause the bug except for Windows+Office and my user settings...
 
@UlrikeFischer dvisvgm has a number of font map related options.
 
11:45 AM
@Skillmonlikestopanswers.xyz have you cleared your temp files and potential settings under %APPDATA%?
 
@PauloCereda I ran a MS tool from their official website which resets user options and registry of Word. Didn't manually clear temp files though.
 
@AlexG yes, and imho the author is quite willing to extend dvisvgm. So I suggest that you ask him, if he sees a way to use such a dvi and which additional info he would need.
 
@UlrikeFischer Ok, I am going to ask a question on the main site.
 
@AlexG I would write the dvisvgm author directly.
 
11:52 AM
@UlrikeFischer He gets informed about [dvisvgm]-tagged questions and is usually quite responsive.
 
@AlexG ah, ok.
 
@PauloCereda ok, now I ran that tool again, and went through AppData clearing everything Office related that looked disposable. Afterwards opening a new file and editing it a bit, changed away and back into Word a few times. It went unresponsive for a few seconds, but now it seems stable (for now)
 
@Skillmonlikestopanswers.xyz <3
 
We'll see how it fairs.
@DavidCarlisle since clearing the Temporary files and other setting files located in AppData seems to fix the issue (for now), I'm now 100% sure that Word/MS is to blame. Any objections or suggested corrections for that stance?
 
@Skillmonlikestopanswers.xyz I know nothing at all about windows, I pretty much only use it via cygwin:-)
 
12:06 PM
Ok, after it worked pretty good with a completely new file (which wasn't the case before clearing AppData), opening the crash-table file I started back when I had the buggy behaviour (it only includes a single table, nothing fancy) and trying to edit that one does again crash Word. I'm really fed up.
I'm now giving it some time to see whether it'll recover and get responsive again on its own, but I don't have much hope.
 
12:21 PM
Sorry everyone, if I'm annoying currently.
 
@Skillmonlikestopanswers.xyz /hug
 
yo'
12:42 PM
@Skillmonlikestopanswers.xyz It's not worrying me, for one. I understand the feeling, and we need some place to vent. As long as you don't really expect constructive replies and a lot of interaction, it's completely fine with me :-)
 
@yo' while I'm grateful for any constructivism, I don't expect it. Thanks for your understanding!
 
Hello all ducks, quick question (I don't get it in the forum). The extension .ltx , when is it used? (apart from format creation)
 
@PabloGonzálezL ooh a question
 
@PabloGonzálezL when you do touch foo.ltx.
 
@PabloGonzálezL It can be used anywhere. Is is specifically intended to be a latex file (as opposed to a tex file) but that distinction is largely lost, since we all use .tex for our latex files.
 
12:54 PM
My query is of the informative type, is it similar to the case of the mathematical mode plain TeX - > $...$ , LaTeX -> (...)?
@AlanMunn I have the impression that I read it somewhere, but, now I can't find the link or the pdf with the information
 
@PabloGonzálezL well, TL2019 frozen has 4027 .ltx files in the texmf-dist.
 
@PabloGonzálezL whenever you like, Some people used to suggest always using ltx for latex files and tex for plain but most people use tex for latex files (so you can omit the extension)
 
@PabloGonzálezL It's really just a convention that didn't catch on much.
 
Find the dog. :)
 
@PabloGonzálezL in the format it's specifically used for default settings that can be over-riddeden with a local cfg file
 
12:59 PM
@PauloCereda found it
 
@Skillmonlikestopanswers.xyz ooh rabbit skills
 
@AlanMunn Thanks, that's what I needed to know :)
 
@Skillmonlikestopanswers.xyz by the way, from yesterday: twitter.com/paulocereda/status/1247248267433390088
 
@PauloCereda searching for ones prey is one of the primary abilities a predator should have.
 
@DavidCarlisle Is it an extension proposed by Leslie L? or was it designed for internal formats?
 
1:01 PM
@PabloGonzálezL no we added the ltx use in the format, but at the time it wasn't uncommon for people to use ltx for documents
 
@DavidCarlisle So, as a file extension, it exists from the beginning?
 
@PabloGonzálezL you can give your document any extension you want so it doesn't really exist from any time
user image
2
@PauloCereda Those green dogs can be hard to spot in the grass.
 
@DavidCarlisle ooh :)
@DavidCarlisle ^^ there he is. :)
 
second hyperxmp bug with xelatex ;-(. grr
 
@UlrikeFischer oh no
 
1:08 PM
@PauloCereda that one looks like photo editing to me.
 
@DavidCarlisle ooh
 
Hi... It really seems an HW problem to me; I had this kind of problem once (on Linux!) and resulted that the HD has a stripe or whatever it's called that was failing (I run a bootable disc test and it found the problem in about half an hour). The intermittent nature of the problem was because the faulty part had some system library on it, and when it touched there... boom.
Or memory --- high memory faulting (this is faster to check).
 
@PauloCereda oh, I get forwarded to Twitter :)
@Rmano shouldn't a RAM bug also affect other programs randomly? Will have to run chkdsk, but I need admin rights for it... Doesn't matter, will check.
 
GitHub Pages is temporarily down for maintenance. not seen that before.
 
@Skillmonlikestopanswers.xyz Yes --- if the other program is using a lot of memory. Linux will crash almost immediately with a memory problem, because it caches things very aggressively; don't know about a modern Windows (older ones didn't cache a lot).
 
1:28 PM
@Rmano well, the Linux cache will be emptied if a program needs the memory. And the kernel contains an out-of-memory killer you can activate to prevent your whole system from crashing/freezing if a program is really hungry.
@Rmano and caching aggressively is a good thing on healthy hardware as unused RAM is wasted RAM anyways.
 
@Skillmonlikestopanswers.xyz Yes, I know --- I am happy about it (I even answered to a Windows user once on askubuntu who was worried because in Linux "memory is almost full")... caching is good (unused memory is a waste). But it makes Linux very sensitive to memory bugs (which is also a good thing: the sooner a HW bug hits the better).
 
@Skillmonlikestopanswers.xyz Caching aggressively led to the great toilet paper shortage of 2020. :)
8
 
@AlanMunn ROTFL
 
@AlanMunn you are missing the capitals: "The Great Toilet Paper Shortage"
 
@DavidCarlisle It seems it's back
 
1:36 PM
@UlrikeFischer True. My 2 minutes are over though, so no chance to edit.
 
@AlanMunn ooh edit
 
@DavidCarlisle Ah
 
Hi mr. koala!
ooh royal chroma key
 
@PauloCereda I liked the Star Trek one
 
@JosephWright amazing, isn't it? :)
user image
3
 
2:19 PM
@PauloCereda @UlrikeFischer thought she was the Queen of the latex team.
 
@DavidCarlisle ooh
 
2:35 PM
I see @MarcelKrüger is handling the dvisvgm problem in his usual speed ;-)
 
I ran the Windows built-in tool to check the disk. Windows says it is fine. Slowly losing options here.
@DavidCarlisle oh, I forgot, you most certainly loose. People tend to load xkeyval and boom you're slowed down by factor 20.
lose* you're not loose.
 
2:51 PM
@UlrikeFischer Sounds promising.
 
3:03 PM
@FaheemMitha -- Whoever said that creature was normal? I see no evidence.
 
Fear of the dark, fear of the dark!
 
@HenriMenke -- Oh, sorry to hear that. At least it seems to be more polite than many.
@Skillmonlikestopanswers.xyz -- Outlook! You have my entire sympathy. When I retired, I lost about 20 years' worth of carefully filed references, unfortunately kept within the mail system.
 
@barbarabeeton better look out! (terrible pun intended)
@barbarabeeton well, currently I'm satisfied with Outlooks behaviour. Word is annoying me...
 
@Skillmonlikestopanswers.xyz Oh lucky lucky your: no IMAP ?
 
@JosephWright the university uses Exchange servers.
 
3:22 PM
@Skillmonlikestopanswers.xyz So do we, but we have IMAP, so those of us who wish can use alternative approaches (you can anyway using a WebDAV translator ...)
 
@Skillmonlikestopanswers.xyz -- For "security", AMS further obfuscated all links in mail text. So anything that looked like an address or a url became unretrievable on export, never mind the binary hamburger that is Word-based text. So basically all TUG/TUGboat mail archives have been lost. (That activity was formally approved by AMS, as long as it wasn't carried out on company time.) It leaves me at a great disadvantage w.r.t TeX/TUG history.
 
@JosephWright I think I can access it through IMAP externally as well, but I haven't tried that yet (I used to fetch my mail via POP3 as a student)
@barbarabeeton one should think AMS would be more intelligent and not base all of its communication on questionable formats :)
 
3:55 PM
@JosephWright Yes, thankfully us too. But increasingly the admins are pushing people to use Teams. I just got an email with a memo that I'm supposed to read in Teams instead of just sending the memo....
 
@AlanMunn Teams is... interesting.
 
@AlanMunn That's ... weird
@AlanMunn I thought Teams was basically Skype?
 
@JosephWright I have no idea. So far I've successfully managed to avoid even knowing what it does. :)
@JosephWright I suspect that reading a memo in Teams leave some sort of marker that you opened the file.
 
@AlanMunn Oh goody, read reciepts
 
@JosephWright Exactly. Next will be sitting in the corner for misbehaviour.
 
4:05 PM
@PauloCereda -- Skunks are actually quite friendly and cuddly, but it's best not to assume that with an individual skunk unless you know it's been housebroken or descented.
@Skillmonlikestopanswers.xyz -- The decision was made by non-techy users who didn't consult the systems folk, and then the rest of us had to adapt.
 
4:18 PM
@AlanMunn -- No, not all of us do. For TUGboat, .tex is plain, .ltx is LaTeX, and .ctx is ConTeXt. (I don't think there's anything else, although eplain also shows up at times.)
 
@JosephWright no it seems to be different (and they are killing off skype for business so more people will be moving to teams)
 
cis
@ p g f p l o t s

If I say e.g. 'ybar' in the axis-environment, I will get a bar chart.

Question: Is there a key for a normal "line-plot"?
 
@barbarabeeton good job you don't have longer documents needing \include :-)
 
@cis sharp plot I think, but that is the default.
 
@DavidCarlisle Skype for Business never worked for me, I just use normal Skype ...
 
4:25 PM
@Skillmonlikestopanswers.xyz -- Are you sure?
 
cis
Yes, I know. I have the problem in a MWE (not mine), with `ybar stacked` in the axis environment.

I want to add a line `\addplot[] coordinates {(0,0) (8,50)};`

And then he says to me:

! Package pgfplots Error: could not access the 'point meta=explicit' for coordi
nate 0: its value is empty. Please add suffixes for every coordinate in order t
o specify explicit point meta. The suffixes must have the form '(x,y) [meta]' .
 
@JosephWright it really needed setting up at a business level, we used it for all inter-office video conferencing not so much for chat but everything switched to teams now, even more so since we are all at home.
 
@DavidCarlisle Oh, it was (I think), just wouldn't work for me :)
 
cis
@TorbjørnT. :()
See above
It makes my ping a code, I fear
 
@cis That's a completely unrelated issue, just do what the error message says. Because you have point meta=explicit, you have to provide an explicit meta value, of the form specified. So you need e.g. \addplot coordinates {(0,0) [1] (8,50) [2]};
@cis Or perhaps \addplot [point meta=none] coordinates {(0,0) (8,50)}; .
 
4:32 PM
@barbarabeeton Yes that makes sense for you to do that.
 
cis
@TorbjørnT. Mhhh, this `\addplot coordinates {(0,0) [1] (8,50) [2]};` gives me another "nice" bar...

`\addplot [point meta=none] coordinates {(0,0) (8,50)};` that was my first try... :()
 
@cis Complete example please, I don't want to guess.
 
cis
@TorbjørnT. Ok, but I have warned you - it is not my MWE. I only worked with it to answer the question of a user....
Mom...
\documentclass[a4paper,12pt]{article}
%\usepackage{graphicx}
%\usepackage{tikz}
%\usepackage{tabularx}
\usepackage{pgfplotstable}
\usepackage{pgfplots}

% ================
% Problem  "nodes near cords in die Mitte" ist wohl ab v1.9 default;
% siehe  ipfs-sec.stackexchange.cloudflare-ipfs.com/tex/A/question/…
% \pgfplotsset{compat=1.9}  % geht
\pgfplotsset{compat=newest} % geht auch
% siehe aber auch unten "every node near coord/.append style={...}"
% ================

\begin{document}
 
@cis \addplot [sharp plot,stack plots=false,point meta=y] coordinates {(0,0) (8,50)};, except that the line is behind the bars (got a hint from tex.stackexchange.com/questions/69938)
 
cis
4:49 PM
@TorbjørnT. Mmhh, not bad... But it writes my "50" in the diagram.
 
@cis Somehow didn't notice that. It's the nodes near coords obviously. Try \addplot [nodes near coords=,sharp plot,stack plots=false,point meta=y] coordinates {(0,0) (8,50)};
 
cis
@TorbjørnT. Ah, very good. Thx.
 
cis
5:25 PM
...
...
...

A general question: Does somebody use a "mobile version of TeXLive on a USB-stick"?
I this possible?
 
cis
@AlanMunn Ahhaaa.... ;)
 
5:56 PM
@JosephWright do we already have something to get back the current time in "PDF" format: D:20200407195354+02'00'?
 
@UlrikeFischer Er, just the timestamp one
 
@JosephWright what do mean by timestamp? \c_sys_minute_int?
 
cis
6:30 PM
@PauloCereda @PauloCereda Please programm a arara-rule for finding out: "What was before the Big Bang?"
 
@cis We already know, we simply query CBS TV guide. :)
 
cis
@PauloCereda :()
 
cis
6:45 PM
I programmed a nice application example
using `% arara: sagetex`
( https://tex.stackexchange.com/questions/520683/arara-sage-a-sagemath-rule-for-arara?r=SearchResults&s=1|54.4280 )
% arara: pdflatex
% arara: sagetex
% arara: pdflatex

\documentclass[a4paper]{article}
\usepackage[margin=1cm]{geometry}

\usepackage{pgfplots}
\pgfplotsset{compat=newest}

\usepackage{sagetex}
\begin{document}
\section{Eingangsdaten}
\begin{sageblock}
n = 2000
p = 0.2
\end{sageblock}

\section{Graph mit Sage}
\begin{sageblock}
import scipy.stats
binom_dist = scipy.stats.binom(n,p)
Layout = dict(frame=False, axes_labels=['$k$','$B(k,{},{})$'.format(n,float(p))])
\end{sageblock}
\sageplot[width=.5\textwidth]{
 
yo'
8:05 PM
@PauloCereda that organ pipes!
 
@yo' nice, isn't it? :)
 
yo'
@PauloCereda so crazy!
btw, quite a number of my recordings will go out tomorrow and the day after for Maundy Thurdsay and Good Friday.
 
@yo' woooo
 
yo'
I have to make and post-process 3 of them to be ready tomorrow evening, and I dunno when I'm gonna do it :D
 
9:13 PM
@barbarabeeton I don't think it's healthy if one is loose. But I can't be sure, I've never met @DavidCarlisle in person (and as soon as I do I have to buy him a beer, sooooo...)
 
9:29 PM
@Skillmonlikestopanswers.xyz -- @DavidCarlisle is really a fine fellow and I'm sure you'll enjoy your beer together. But it may take a bit to be able to understand him, unless you're used to non-radio-standard English pronunciation. He's quite intelligible in writing, even with his idiosyncratic typing, but as far as the spoken word, I find him to be much more understandable after lunch.
 
I bring a good news for you all. Pluralsight makes its videos free only in April. Please download as many as you can. Make your hard drive full. :-)
 
9:41 PM
@barbarabeeton sorry if you foreigners struggle with spoken English.
 
10:09 PM
@DavidCarlisle if we meet we'll see whether I can understand you :)
@JosephWright may I interest you in 25% faster key=value parsing?
 

« first day (3446 days earlier)      last day (54 days later) »