« first day (3712 days earlier)      last day (136 days later) » 

12:34 AM
Question: Why is \SI{\sim 14}{\degree} giving the message "Missing character: There is no ∼ (U+223C) in font rm-lmr10!"
That worked fine in pdflatex with the same font settings!
Wait, did I change something?
runs a diff
 
@Canageek \sim is expanding to character hex 223C (∼) obviously the definition in pdflatex is different as no character has code higher than hex FF in pdftex
@Canageek unicode-math in use?
 
@DavidCarlisle That might be the issue, I tried to do something using it, so I'm putting everything back and seeing it if compiles
 
@Canageek $\sim$ works in lualatex with or without unicode-math (using computer modern 8bit fonts or latin-modern-math in unicode-math case, so you have some font setup somewhere that is breaking it....
who needs those pesky accents (or curly braces) anyway
13
Q: Why does the EU-UK trade deal have the 7-bit ASCII table as an appendix?

NzallI just noticed this on Twitter: https://twitter.com/thejsa_/status/1343291595899207681 Fun fact: the EU-UK post Brexit trade deal text includes a copy of the 7-bit ASCII table on page 977, just in case you happen to need it Related tweets also show references to Netscape Navigator 4.x and SHA-...

7
 
1:01 AM
@DavidCarlisle Found and fixed it! You would have put me on the right track if I hadn't already seen the problem in the diff
Missing character: There is no α (U+03B1) in font clmr2j8t10!
Missing character: There is no ω (U+03C9) in font clmr2j8t10!
Missing character: There is no ł (U+0142) in font clmr2j8t10!
Missing character: There is no ’ (U+2019) in font clmr2j8t10!
Missing character: There is no α (U+03B1) in font clmr2j8t10!
Missing character: There is no ω (U+03C9) in font clmr2j8t10!
Missing character: There is no Č (U+010C) in font clmr2j8t10!
Missing character: There is no ž (U+017E) in font clmr2j8t10!
Missing character: There is no Š (U+0160) in font clmr2j8t10!
Now that doesn't help me with these. The Greek letters I get, did I had to remove the \DeclareUnicodeCharacter{03B1}{\chemalpha} when using luaLaTeX
But Š? Č?
I don't even know how to wirte those in LaTeX
 
@Canageek sorry 1 in the morning is a bit hard to debug with no test file, and I'm about to turn in:-)
 
@DavidCarlisle Sleep well! I found some of the problems, I'm searching my input files for each of these characters one by one and replacing them with the LaTeX command for them and that seems to work
 
 
3 hours later…
4:00 AM
@ShreevatsaR -- Thanks! No, I hadn't seen it. (A lot of familiar names there.)
 
 
5 hours later…
8:49 AM
@MarcelKrüger any idea why travis fails in the new branch? Locally it works.
@MarcelKrüger ah, just found it. It fails with the reference fontloader.
 
I only patched the individual files which got propagated into the packed fontloader, but the prepackaged "reference" fontloader is not fixed yet.
 
@MarcelKrüger the question is if we should fix it too and update or wait for an update in context.
 
@UlrikeFischer Yes, that's intentional since I thought that when the reference loader is explicitly selected it shouldn't use a patched loader instead.
@UlrikeFischer I think we should wait, especially since the last fix was released after only a few hours, so there's a reasonable chance that it's not a long wait anyway.
 
@MarcelKrüger yes sounds sensible. I need to check what I did in lualibs anyway -- I seem to have updated it only locally.
@MarcelKrüger which reminds me: I always wonder if we can dare to drop the unicode library in lualibs, currently I always reenable it manually. (If yes then we need a replacement for this in the luaotfload-latex file: ` local backslash = unicode.utf8.char (0x5c)`).
@MarcelKrüger oh and another question: In fontloader-basic-gen.lua I have a line caches.namespace = 'generic-dev' which sometimes is caches.namespace = 'generic' (depending on the branch). Which one is correct? And how is this handled?
 
9:16 AM
@UlrikeFischer I would be in favor of dropping the unicode library. Where is the local backslash line? (It can change to local backslash = ut8.char(0x5c) or just local backslash = string.char(0x5c) since it's just ASCII)
 
@DavidCarlisle ooh let's blame the colonies
 
@UlrikeFischer The idea was to use a different cache in the dev branch to ensure that when the format changes, the database doesn't rebuild everytime we switch between dev and normal. It is adapted for the current branch by l3build tag.
 
@MarcelKrüger I changed in the dev branch. And I will then drop the unicode library, and we can see if someone complains ;-)
@MarcelKrüger ok, I will try to remember this (or perhaps better put a note in the build file so that I remember to check before a ctan upload ...).
 
 
2 hours later…
11:40 AM
Where do I find info about the TikZ "open triangle 60" arrow? I can not find it in the manual - maybe because multiple word search in mac Preview woks poorly. -and google is not really helping me. Maybe it is the same as "Triangle[open]" !? -but then what about "open triangle 45", "open triangle 90" and others?
 
@UlrikeFischer Did you update your branch? It occured to me you only need to merge master into it
 
@JosephWright I imported l3backend-pdf.dtx into it, but currently only locally. So I could revert this.
 
@UlrikeFischer Merge looks fine here, so you should be able to do it no issues
 
@JosephWright ok, then I will merge master in my branch.
 
11:56 AM
@hpekristiansen "arrow tip specification" around page 202
@hpekristiansen will be something like [-{Triangle[open,angle=60]}] (not sure about the exact names now)
There is a Triangle[angle=60:1pt 3] in pag. 216, but on the spot I can't find the exact definition of the angle parameter.
Found! ^^^^
(this is from the very last manual, updated this morning)
 
@Rmano: Thanks - I can still not find "open triangle 60". You can see it in use e.g. here: tex.stackexchange.com/questions/576661/disappearing-arrowhead and google also shows some usage, but I can not find it described anywhere.
@Rmano: Do you know what " 3" means in "Triangle[angle=60:1pt 3]"?
 
12:19 PM
@Rmano tikz has a manual?
 
@DavidCarlisle you could ask a question on the main site
 
@hpekristiansen that 3 means how much the arrow tip changes with the linewidth (it's called line width factor in the manual snippet above)
 
12:36 PM
@UlrikeFischer I would but can't find the ask a question button
 
@DavidCarlisle Can't you call a link with emacs? tex.stackexchange.com/questions/ask
 
@UlrikeFischer I was taught not to follow suspicious links posted on the internet
 
@hpekristiansen open triangle 60 is defined in the arrows library (which this answers load). But while the arrows library is still available it is considered deprecated, see the intro to the "arrow tip library" documentation.
@DavidCarlisle ups, and I clicked yesterday on your link, I should be more careful.
 
@UlrikeFischer naturally you can trust me
 
@DavidCarlisle ooh
@DavidCarlisle who needs a manual when you have a golden badge? :)
 
1:18 PM
@PauloCereda have I mentioned that I have a gold badge?
 
@DavidCarlisle ooh
 
we had snow for 5 minutes
 
@DavidCarlisle we will perhaps have a bit on thursday or friday.
 
1:36 PM
Is the multibib [1] package compatible with biblatex?

[1]: https://ctan.net/macros/latex/contrib/multibib/multibib.pdf
I cannot find anything in their docs
If not, how can I have multiple bibliographies with biblatex (and biber backend)?
 
@ComFreek biblatex can do this out of the box. Have a look e.g. at the refsection environment
 
@ComFreek no it is not compatible (and quite unneeded, you can print as many bibliographies as you want with biblatex).
 
@samcarter_prepared_for_xmas I've seen that, and I don't think it suits my needs. I'd like to have multiple bibliographies, such that the text before can cite any entry in any of them.
so refsection is too restrictive
 
@ComFreek For more options, see section "3.7.4 Bibliography Sections" of the biblatex doc
 
@ComFreek then use refsegment, or a filter or ...
 
1:45 PM
refsegment sounds better than refsection
but still, in one refsegment environment I cannot cite things from another refsegment
I'd be okay with standard biblatex + manual \fullcites, but \fullcite doesn't output the citation key (e.g. [1]), hence I began looking for alternatives
 
@ComFreek sure you can.
 
Hm, now biber build/main always produces a truncated XML file main.bcf:
  <!-- SECTION 0 -->
  <bcf:bibdata section="0">
    <bcf:datasource type="file" datatype="bibtex" glob="false">mybib.bib</bcf:datasource>
  </bcf:bibdata>
  <bcf:section number="0">
    <bcf:citekey order="1" nocite="1">blablub</bcf:citekey>
^^^ This is what main.bcf ends with
[0] Config.pm:311> INFO - This is Biber 2.16 (beta)
[0] Config.pm:314> INFO - Logfile is 'build/main.blg'
[183] biber-MSWIN64:340> INFO - ===
[243] Utils.pm:411> ERROR - build/main.bcf is malformed, last biblatex run probably failed. Deleted build/main.bbl
[244] Biber.pm:132> INFO - ERRORS: 1
never mind!
biblatex + refsegments works now, thanks!
 
2:18 PM
With biblatex I now have two refsegments 1 and 2. One bibentry cited in 1 has a `note` field, which in turn cites a bibentry cited in 2.
The result is that the latter bibentry appears when in the bibliographies for both refsegments.
How can I overcome this?
I've looked at biblatex's filters, but they seem to not be powerful enough to prevent such "recursion". I'd be fine with excluding a bibentry manually from a bilbiography. Is this possible?
 
@ComFreek why would you want to overcome this? How should the reader find the second entry when you hide it in some other bibliography far away?
 
@UlrikeFischer The bibliographies are all consecutive in my document. Think of an academic CV with bibliographies "theses", "workshop contributions", "journal articles".
Now if an entry in, say, theses has a note field citing a workshop contribution, that workshop contribution shouldn't go under theses.
 
@ComFreek and how can a reader know where to look for it? As a reader I don't want to have to skim through 3 or 4 bibliographies to find a reference. Beside this: if you separate by type or topic you shouldn't use refsegment as filter but type or categories or keywords.
2
 
Re first question: good point
 
 
2 hours later…
4:21 PM
@JosephWright the expl3 documentations all claim before the index "numbers
underlined point to the definition" but there are no underlined numbers ...
 
5:05 PM
@wtsnjp ^^ hi! From our upcoming manual. :)
 
5:36 PM
@PauloCereda -- "PDF" = "Portable Document Format", not "... File". (Do you need a "disinterested" reader?)
 
@barbarabeeton thanks, I was actually lazy to change all occurrences and was wondering if anyone would catch it. Apparently, I forgot we have an awesome bnb around. :)
 
@PauloCereda Hello Mr. Duck
 
arara/docs/chapters on  docs [!]
➜ ack --tex "Portable Document File" --count
building.tex:0
deploying.tex:0
license.tex:0
logging.tex:0
mvel.tex:0
rules.tex:0
yaml.tex:0
configuration.tex:0
introduction.tex:0
cli.tex:0
concepts.tex:0
methods.tex:0
@barbarabeeton ^^
@PabloGonzálezL Hello, Pablo!
@barbarabeeton thanks for the review. :)
 
@PauloCereda Question, since you have become an expert in Lua after finishing your thesis (right?)...How the hell can I print "Hello Duck" in red?
 
@PabloGonzálezL You need an escape code, hold on.
 
5:47 PM
@UlrikeFischer Probably comes from some LaTeX2e file orginially
 
print("\27[31mQuack\27[0m")
@PabloGonzálezL ^^
 
@PauloCereda Mmm, I was looking a little bit at the code of culttex that works with colors (win/linux), but, it is very over what I can understand :(
*cluttex
@PauloCereda The sequence escape is the same as used in Perl?
 
@PabloGonzálezL No idea, but it's pretty much the norm.
 
@PauloCereda -- very good.
 
@PabloGonzálezL at the end of the day, one cannot escape these codes... :(
 
5:53 PM
@PauloCereda True :(
@PauloCereda So I know how I can do it...While windows cmd does not support this by default, the new Windows Terminal does :)
@PauloCereda To all this in Windows Terminal it works very nice albatross -a tc 0x1F332
 
@PabloGonzálezL ooh <3
 
@JosephWright Do you know the browser cows use? Moo-zilla
:)
 
@PauloCereda :)
 
@JosephWright any updates?
 
5:57 PM
@PauloCereda On?
 
@JosephWright the real life parrot sketch
Talking in code :)
 
@PauloCereda :)
@PauloCereda Not yet: have some 'admin' aspects first
 
@JosephWright oh
 
6:13 PM
@JosephWright yes:-)
@UlrikeFischer so the statement is true.
 
@JosephWright how do one translate this in a more or less suitable expl3-conditional?
\newcount\foo
\def\test#1{\afterassignment\testi\foo=0#1 \testi}
\def\testi#1\testi{\if X\detokenize{#1}X%
                   \else \foo=0 \fi
  \ifnum \foo >0  \typeout{Number}\else\typeout{no number}\fi
}
@DavidCarlisle which shows that true and meaningful is not the same ;-)
@JosephWright does this looks ok? (it works, I only wonder if I miss some sensible function here):
\int_new:N \l__my_tmpa_int

\cs_new:Npn \l__my_ifnum_aux #1 \q_stop
  {
    \if:w X\tl_to_str:n{#1}X
    \else: \int_zero:N \l__my_tmpa_int
    \fi:
  }
\prg_new_conditional:Npnn \my_is_digit_test:n #1 {p,T,F,TF}
 {
   \tex_afterassignment:D \l__my_ifnum_aux
   \l__mytmpa_int=0#1 ~ \q_stop
   \int_compare:nNnTF { \l__my_tmpa_int } > { 0 }
    {
      \prg_return_true:
    }
    {
      \prg_return_false:
    }
 }
 
6:32 PM
@UlrikeFischer Would all be low-level: we don't have an interface for \afterassignment
 
@UlrikeFischer Thanks. I expect that "\usetikzlibrary{arrows.new}" is also deprecated!? I can only find a download link for a pdf starting on page 258 (assumably part of old TikZ manual) ( google.com/… )
 
6:43 PM
@hpekristiansen I'm not @UlrikeFischer, but yes --- you should use arrows.meta. You can probably define your arrows with the ./tip keys. If you open a question with a suitable MWE somebody will help you for sure...
 
Question: is there a good "intro to LuaTeX for people who just want to write documents and possibly play with some font features" rather then "I know lua and want to do crimes against god and nature by combining it with LaTeX in strange and unnatural ways?"
 
@Canageek if you are only interested in fonts, read the fontspec manual. You don't need more.
 
@UlrikeFischer Wait, I thought fontspec was a pdflatex thing?
 
@Canageek I wrote fontspec not fontenc
 
@UlrikeFischer Ohhhhhhh,
 
7:39 PM
I'll get that set up before delving into why Miljanić, Ognjen Š renders fine in the body of my document but not my works cited and hope the problem goes away
 
8:28 PM
You know what would be really great? If someone had defined font shape commands like way back as a standard and every font used them. So if you provide say, SMALL CAPS I don't have to redefine how that works every time I change fonts or move from pdflatex to lualatex
That would be REALLY NICE
 
9:10 PM
@Canageek that gets a lot better in the latex 2020 release
@Canageek but you can't force a font designer to make every character design that you want (unless you are paying of course:-)
 
@DavidCarlisle But that won't fix legacy packages, will it? Like, if I am using pdflatex and want to move from Baskerville to cfr-lm they use different ways to specify small caps, right? (Doing that from memory)
 
@Canageek Baskerville died in 1775, it's a bit late to ask him to design some new font shapes
 
@DavidCarlisle No, but if I had a time machine I could force every package maker to if they supported small caps or proportional figures to use the same command so I don't have to hunt down and replace each command when moing fonts
 
@Canageek but the latex 2020 release has a new way of handling font shapes like small caps so it is now at least possible to consistently specify things if the fonts exist
@Canageek the neatest thing would have been if lowercase, caps-and-small-caps, uppercase had been a separate axis and you could independently specify caps-and-small-caps, bold, italic in the current font family and it just worked, but even now most font families just do not have that large a range of styles and the font space if split up on that many axes is just too sparse, now it's possible but a bit wasteful back then it was not feasible
 
@DavidCarlisle Ah, here is the example:
`Baskervaldx ` : \textosf (osf, proportional)
`cfr-lm`: \postyle or \textpo{} proportional, oldstyle
How hard would it for all font packages them to agree to use the same command for that?
Time machine, set up a standard for that in the 90s, save everyone a headache
@DavidCarlisle I'm just talking about one font using \textosf and one using \textpo. Sure if I'm using a font family where they don't have old style numbers those won't be defined, but why do I have to do a find and replace every time I move fonts when they have the same features and I want to USE that same feature?
 
9:22 PM
@Canageek well define your own command \myoldstyleprop in the preamble. Then you have only one place to change. Or even better define a semantic command like \emph .
 
(I've fixed that now, now I just need to figure out how to tell LaTeX to stop being dumb and using ϰ for κ
@UlrikeFischer There often ISN'T a sementic meaning, and yes, I could do that but I still don't see why a standard for these things would be so hard.
@UlrikeFischer Like note = {V3.7.0} just looks better in non-old style numerals, there isn't a meaning for that.
 
@Canageek well as I say latex only this year is defining a standard set of letters for for different font weights etc so before that different font designers had to extend the system to match their own font sets. Like all latex packages often a package author makes their own packages and commands because they don't like some existing set so packages diverging is more or less expected. Then every now and then somethings get standardised and things fall back in to line
@Canageek I don't know the details of those two packages but access to old style numbers may be quite different at the font level, sometimes in a completely different font, or in the same font in "non digit" odd locations or in the same font but chosen by some font feature or ... making this always be accessed by the same interface isn't trivial even if the package authors had that as a goal.
 
@DavidCarlisle Right, imagine how much less work it would be if someone had said, lets always make these font features use the same name
@DavidCarlisle Ahh, in this case they are the same. In fact the packages have some very similar features and use different names each time. In fact, I've yet to find any two font packages that use the same names for any font feature.
 
@Canageek but you can't. Opentype fonts have lots of features and lots of glyphs. classic tex fonts have no features and at most 256 glyphs and are usually already full with no spare slots for variant shapes, so you have to code things completely differently
 
@DavidCarlisle I'm just talking about the user-level commands here. I have no idea what is going on behind the scenes when I write \textpl{69}, I just know I type that and the numbers look how I want. So you could specify that every package that provides proportional, lining, numbers provides the command \textpl
@DavidCarlisle Basically, have the packages do what Ulrike Fischer suggested, but do it at a package level instead chat.stackexchange.com/transcript/message/56582813#56582813
 
9:33 PM
@Canageek and you think than everyone would have obeyed and used only the proposed names?
 
@UlrikeFischer If it was done early enough, sure. It is easier then thinking up your own commands every time.
 
9:44 PM
@Canageek it is only relatively recently that there have been a reasonable number of fonts available with compatible range of font styles. We could not have standardised that when the NFSS axes were standardised.
 
@DavidCarlisle OK, fair. Just frustrated after having to redo quite so many commands moving from one package to another, again
 
@Canageek the model for luatex/fontspec is mostly that you don't need custom font packages at all, you simply point it at the opentype fonts and (if they are there) things like bold or old style numbers are just all in standard places, it is really a lot more consistent than the classic (pdf)tex font position.
 
@DavidCarlisle That is fair. A lot harder to figure out how to do things in it then say, cfr-lm that has nice tables of commands.
Arrrggggg
\usepackage{newcomputermodern}\usepackage{chemgreek}\selectchemgreekmapping{fontspec}
\changechemgreeksymbol{fontspec}{lower}{kappa}{κ}\selectchemgreekmapping{fontspec}
YOU WORK FOR MATH MODE, WHY DO YOU NOT WORK FOR BODY TEXT
/me kicks fonts in their metaphorical existance
 
@Canageek stop doing Chemistry and (therefore) use a more standard font setup (that has at least some commands I recognise)?
 
@DavidCarlisle Hah, fair. I'm trying to use κ for denticity (How many times a ligand binds to a specific atom), since that is what every chemist knows as kappa (GREEK SMALL LETTER KAPPA). But for some reason the code cgnieder gave me loads ϰ (GREEK KAPPA SYMBOL, the cursive form of the same letter)
Which looks like some weird x no chemist will know what to do with
And I found chemgreek HAS an interface to remap one letter SWEET. I do that and....it half wokrs
Screw this, I'm making a MWE and hoping someone else bails me out
 
9:57 PM
@Canageek JOSEPH.....
 
10:18 PM
0
Q: How do I get chemgreek to use κ instead of ϰ with fontspec and newcomputermodern?

CanageekYesterday I appeared to find the perfect bit of magic code for my thesis, however, I noticed LaTeX is using the cursive version of kappa (ϰ) instead of the symbol chemistry uses for denticity (κ). ϰ is GREEK KAPPA SYMBOL and κ is GREEK SMALL LETTER KAPPA. MWE: \documentclass[]{article} \usepackag...

 
10:32 PM
@Canageek if I add a paragraph ϰ) instead of the symbol chemistry uses for denticity (κ) to your document then I get:
 
@DavidCarlisle throws up hands I copy and pasted them from Wikipedia.
 
and Missing character: There is no ϰ (U+03F0) in font [NewCM10-Book.otf]:mode=node; so it looks like the newCM font only has the cursive kappa and has it in the slot of the non cursive one
 
@DavidCarlisle Then how does the second example work?
Like, I can SEE that symbol there it just only shows up in math mode for some reason
 
@Canageek all the kappa in that image look the same don't they?
 
@DavidCarlisle Not the Math Mode one
 
10:36 PM
@Canageek it looks like an x not a k to me
 
@DavidCarlisle I'm looking at the screenshot right now? First line, second last character?
Second screenshot?
 
Should I remake the MWE to only have the kappas in it?
@DavidCarlisle Is that with the first MWE or the second MWE?
 
@Canageek ah first I guess, give me a sec....
 
@DavidCarlisle We get the same result then! First only gives the x one
 
10:42 PM
@Canageek \setbox0\hbox{\chemkappa$ \chemkappa$}\showbox0 produces
> \box0=
\hbox(4.6+0.22)x11.04, direction TLT
.\TU/NewCM10-Book.otf(0)/m/n/10 κ
.\mathon
.\TU/NewCMMath-Book.otf(1)/m/n/10 𝜅
.\mathoff
 
@DavidCarlisle What does that mean? I see one looks italic and the other doesn't, and the (0) vs (1) difference....
 
@Canageek so it has loaded two variants of the font with the different font mappings, at this point Ulrike could probably give you a low level luaotfload way of forcing things but the chemisty macros might have a higher level interface available I assume it's just working in math as it is using mathcode to map the characters
 
@DavidCarlisle Not in the manual, I'll see if its obvious from the code
 
@Canageek or simply cheat and use egreg's package, let me see if that works...
 
@DavidCarlisle I don't think that some luaotfload can help here, the text font doesn't have the symbol, so you have to switch to math. Egreg's suggestion with \ensuremath sounds ok.
 
10:49 PM
@UlrikeFischer couldn't you force .\TU/NewCMMath-Book.otf(1)/m/n/10 to get used in text (the font that works in math)
 
@DavidCarlisle you mean \setmainfont{NewCMMath-Book.otf}? well yes, but I doubt a bit that there is a bold and italic version.
 
11:06 PM
Can I file a bug report on that font for encoding the wrong character in the wrong slot?
 
@Canageek The developer of NewComputerModern is very active, it seems: I guess that a feature request for a character variant/stylistic set would be the right path.
 
@egreg I'm confused about what is going on, since when I install the font and open Character Map
 
@Canageek The Character Map doesn't tell you the whole truth about OpenType fonts.
 
It shows U+03BA as the K like one, and nothing at U+03F0
@egreg Ahhhh
 
@Canageek Take into account that \chemkappa uses by default the glyph from the text font in text; in the text font the shape is “x-like”. That's why I told about a possible character variant to apply.
 
11:22 PM
@egreg Ah, so it isn't the otf file that is missing things, it is how it loads it into LaTeX?
(Also wondering where it is hiding the x-like one since U+03F0 is empty)
 
@Canageek Sorry, I don't get it. If you ask for U+03BA in text mode you get the glyph that happens to be there in the current font, so the “x-like” one. How the font realizes the glyph corresponding to a character is up to the font designer.
@Canageek There's no law that imposes the Greek kappa to be “kappa-like” or “x-like”.
@Canageek It's a fact that the Greeks prefer the “x-like” shape.
 
@egreg Found it, it is hiding in NewComputerModernMath.otf
 
@Canageek yes, that's why egreg suggested to use math. But if you want your kappa-like glyph also in the text font, you should make a feature request.
 
@Canageek Or, at least, Antonis Tsolomitis. ;-)
 
Right, but the unicode standard shows https://util.unicode.org/UnicodeJsps/character.jsp?a=03F0 and https://util.unicode.org/UnicodeJsps/character.jsp?a=03BA

You can USE whichever you want, but you should code them at standardized code points to make things easy on everyone. Just...don't use the code point you don't like.
(This is like the two styles of g, isn't it? I'm betting there is no clear way of specifying one in unicode, is there?)
 
11:31 PM
@Canageek Sorry, but you're reading too much. Historically, the Greek letter kappa has two slightly different shapes and the font designer chooses one of them. The distinction between letter and symbol has been made up by Unicode and they got it grossly wrong, I'm afraid.
 
@egreg Ahh, so they should issue and update flipping which is which?
 
@Canageek unicode really doesn't like changing things, forcing automatic changes in the entire planet's document corpus is a bit scary:-)
 
@egreg Effing heck. They don't even seem to have separate unicode points for single-storey and double-story g
@DavidCarlisle Makes sense, but they didn't even get ENGLISH right!
 
@Canageek No, there is a single GREEK SMALL LETTER KAPPA (as a character entity). The shape the corresponding glyph has is font depending.
 
@Canageek exactly a g is a g if the font designer decides to make all letters look like cows that is up to the designer
 
11:33 PM
This is why I only ever take ASCII input in my programs since at least I KNOW there are no flaws with it
 
@Canageek The Unicode people, aware that there are two main shapes in use, tried to fix this by assigning arbitrarily one shape for the letter and one for the “symbol”. That's wrong, but now it's the way it is.
 
@Canageek Unicode Greek has several issues (epsilon and theta show similar problems with (in tex terms \theta and \vartheta being swapped) basically the initial greek assignments were done by English speaking mathematicians and didn't really work so well for actual greek greek
 
@egreg That is...*sigh* Honestly this whole make Unicode semantic was kinda badly designed since no one uses it, it means search doesn't work most of the time, and it breaks SO many things when you paste from document to document.
OH LOOK THIS DOCUMENT USES HYPEN AND THIS ONE USES HYPEN-MINUS, NOW SEARCH ISN'T GOING TO WORK AT ALL EVER
 
@Canageek compared to what went before it is a vast improvement
 
@DavidCarlisle At least ASCII doesn't have security holes. I mean, sure it only does like, two languages, but I don't have to worry about it having security holes....
 
11:37 PM
@Canageek when i started using tex even passing a source file to Germany was problematic as any of {}%\ could get arbitrarily changed according to different bitnet/janet gateways
@Canageek but you can't choose your style of g
 
@DavidCarlisle Yeah, but I don't have to worry about an accent breaking an input file since it is actually two characters in a trenchcoat
 
@Canageek who needs accents:-)
 
@DavidCarlisle I mean, I'm pretty sure I can't answer that or it won't be safe for me to visit Quebec ever again >.>
sings One of these things is not like the other
 
@Canageek isn't that like saying y is not like t as it has a descender?
 
@Canageek Or Québec? ;-)
 
11:42 PM
@DavidCarlisle More that the mu is in a totally different style then the others.
@egreg The only province to open defy the Canadian constitution.
 
@Canageek possibly but I don't know greek (as opposed to mathematical) conventions well enough to know whether that should be expected
 
@DavidCarlisle The mu looks like it was written on a typewriter, all the others are in a totally different style.
@DavidCarlisle No idea, but it seems to be the only letter written in that style
damn, Greek Wikipedia uses sans serif fonts
 
@Canageek I don't get that from αμβ I get
 
@DavidCarlisle that is the \ensuremath{\textrm{ αμβ }} version
I noticed that the mu fit in better with the rest of the chemical name in the answer yesterday and wanted to see if I could move all the Greek letters into that style. Answer: No
 
Oh I just stuck αμβ in a text paragraph in your test file
 
11:48 PM
@DavidCarlisle That this was one MWE after that ^^
And testing shows it isn't worth pushing futher
 
@Canageek not been back to the question for ages:-)
 
@DavidCarlisle Oh I accepted the answer hours ago, I was trying to build on it
 
@Canageek do you have to use new computer modern?
 
@DavidCarlisle Not sure, it is the default in the university template and I don't hate it. Better then Times New Roman for sure
 
@Canageek didn't have an answer at all last time I was there...
@Canageek oh surprising, it is a relatively new font as far as I know, I think I only became aware of it this year
 
11:50 PM
@DavidCarlisle it starts with "new" so shouldn't it be at 200 years old?
 
@DavidCarlisle Oh, I missed the new. The university thesis template uses Latin Modern and the question I got yesterday suggested newcomputermodern. Anything that is close enough to Computer Modern should be fine, it just makes it easy to use non-italic Greek letters
 
@Canageek sure but a one man effort to compile a font family covering all European scripts and mathematics is a huge undertaking and it's not surprising if a few odd assignments get made in early releases.
 
@DavidCarlisle THAT makes sense. And hey, if it means I can strip out some of the workarounds I needed for Latin Modern
Wait, is there a way to see if NewComputerModern has old style numbers?
 
@Canageek the open type feature shows onum so it should be there.
 
Hmmm
\usepackage{newcomputermodern}
\defaultfontfeatures{Numbers=OldStyle}
Isn't that the way you do that?
 

« first day (3712 days earlier)      last day (136 days later) »