« first day (3644 days earlier)      last day (44 days later) » 

7:41 AM
This has to have been written using SWP: \textit{\index{...}\index{...}\textbf{\index{...}}} whyyyyy?
 
 
4 hours later…
12:02 PM
@egreg I had the eqnarray discussion with one of my emeritus professors, they insisted on using it as it is mentioned in the Springer information to authors material (apparentlly Springs messes with it to "fix" the spacing, not sure if there are any special consequences).
I know the "fix" what Word Scientific used for eqnarray destroyed matrices.
 
12:14 PM
@MarcelKrüger You've been busy :)
 
@JosephWright I thought that too ;-)
 
@UlrikeFischer Didn't know the work was happening :)
 
12:30 PM
@JosephWright I thought that something was happening, but didn't expect so much ;-)
@JosephWright I meant "move away from zref" not xref (but actually I think it should be l3ref in the end, the x doesn't make much sense imho).
 
@UlrikeFischer Oops, yes
 
@UlrikeFischer I just wanted to write an answer about that :)
@UlrikeFischer Do we have any documentation about the naming scheme for such components? I seem to remember some discussion at some point, but I can't find it now.
 
@MarcelKrüger which components? l3 modules?
 
@UlrikeFischer Yes.
 
@MarcelKrüger I don't think that there is a documentation. Basically it should fit, be short if possible, and not in the prefix list (which I didn't check ...).
 
12:41 PM
@MarcelKrüger We've gone for l3... generally, but beyond that not much
 
@UlrikeFischer @JosephWright Ok, thanks.
 
 
2 hours later…
2:34 PM
what is that core reason why latex can’t tell you that when you do \begin{frame} but have no \end{frame} (in beamer) that is the problem? In my dream world “Error: missing \end{frame}” would be the error message (also asked in topanswers chat)
instead you get
Runaway argument?
\let \AtEndDocument \@firstofone \@enddocumenthook \@checkend {docume\ETC.
! File ended while scanning use of \beamer@collect@@body.
<inserted text>
\par
<*> test3

? H
I suspect you have forgotten a `}', causing me
to read past where you wanted me to stop.
this is just using
\documentclass{beamer}

\begin{document}
\begin{frame}
\end{document}
 
@Anush Because the frame environments collects everything until the \end{frame} as argument, so the effect is more or less what you'd get with
\documentclass{beamer}

\begin{document}
\frame{
@Anush You'll get similar errors with verbatim (pretty much any verbatim environment), tabularx, align: all collect the body of the environment as argument
 
that is interesting, thank you
the upshot is that the error messages are less useful than they might be
what would need to change/be added for pdflatex to be able to report “Error: missing \end{frame}” ?
 
@Anush The error is reported by TeX, not by LaTeX or beamer, so the error is pretty low level. But it actually tells you a lot (although understanding that is not that easy). It says “File ended while scanning use of \beamer@collect@@body”, which was exactly what happened: it was collecting the body of an environment, but the file ended before that
@Anush It might be possible using \everyeof or some trick like that, but it's really hard and not too robust
 
@PhelypeOleinik true but I guess the key problem is that it doesn't tell you where it started collecting from. That is it doesn't report the line number of \begin{frame}
as far as I can tell
 
@Anush xparse improves a bit on the situation by not showing you some internal macro like \beamer@collect@@body. If you try this:
\NewDocumentEnvironment { mygrabenv } { +b }
  { contents:(#1) } { }

\begin{mygrabenv}
 
2:48 PM
@PhelypeOleinik only the latter should put us off :)
 
Runaway argument?
\begin
! File ended while scanning use of \environment mygrabenv .
<inserted text>
                \par
<*> test.tex

?
Which is a bit less cryptic
 
why can't it give you the line number of where it started collecting?
 
@Anush because it collects line by line (if I remember correctly), so at this point TeX (which reports the error) doesn't know about environments or where it started collecting
 
hmm
looks like a bug to me :)
 
@Anush Definitely not a bug, rather an implementation limitation. Depending on how it grabs the environment (if it's line by line) it may be able to catch an end of file, with some degree of confidence
 
2:53 PM
yes sorry I overused the word bug
but the key point is that there is no higher level error reporting mechanism
so you just get whatever TeX reports
 
@Anush Yes, because it's hard with reasonable performance. You can get a scanner of some sort that looks token by token, but then it would take ages to process a single environment (and the amount of code would be nontrivial for not much gain).
@Anush Much easier is to get a text editor that highlights matching (or in this case non-matching) \begin-\end pairs
 
@PhelypeOleinik yes that makes sense
 
@daleif Unsure whether it works with hyperref
 
3:28 PM
@egreg I don't think they're using hyperref for their book. Say you suggesting that the springer fix has issues with hyperref?
 
3:58 PM
@daleif eqnarray has issues to begin with; just fixing the spaces isn't sufficient.
 
4:09 PM
@PhelypeOleinik I think biblatex got bitten by your toplevel-order problem: github.com/plk/biblatex/issues/1066
 
@UlrikeFischer Hm, indeed!
@UlrikeFischer (also \LogHook prints something to the terminal...)
 
@PhelypeOleinik I even didn't know that there is \LogHook command, always use \ShowHook ;-)
 
@egreg right, just seems the journals don't care, they just want the manuscripts for their printed versions. Though I think all books we've done in the last 5 years or so with our local university press have been dual, we delivered a color hyperlinked pdf and a pdf for printing with all links in black (just in case hyperref changed the line breaking)
 
4:42 PM
Mac users: have you ever encountered generic App icons showing up in the Dock? If so, did you manage to solve it? None of the "solutions" I've found by googling have worked. The icon is correct in the Finder.
 
@AlanMunn Nothing suspicious in High Sierra, but I recently went ballistic and reset my Dock and Launchpad configs. :)
 
@PauloCereda By removing the com.apple.dock.plist?
This is what it looks like (Firefox)
 
@AlanMunn It was something more drastic, let me find it, hold on...
@AlanMunn Ouch!
@AlanMunn it was this: defaults delete com.apple.dock; killall Dock
For Launchpad: defaults write com.apple.dock ResetLaunchPad -bool true; killall Dock
 
@PauloCereda Yes, it's very annoying. You don't realize how useful the icons are until you lose one.
 
@AlanMunn I definitely can relate!
 
4:48 PM
@PauloCereda Wow look what this did:
 
UH-OH
SORRY SORRY SORRY
 
:) But that's progress. It's definitely reset the dock entirely.
But alas, the FF icon remains generic.
 
@AlanMunn: someone suggested this
sudo rm -rfv /Library/Caches/com.apple.iconservices.store; sudo find /private/var/folders/ \( -name com.apple.dock.iconcache -or -name com.apple.iconservices \) -exec rm -rfv {} \; ; sleep 3;sudo touch /Applications/* ; killall Dock; killall Finder
 
@PauloCereda Very fittingly, the ? icons are all Office programs! :D
 
@AlanMunn it's always a surprise. :)
 
4:50 PM
@PauloCereda That looks more promising. It definitely smells like a caching problem.
 
@AlanMunn Indeed, I would exclude the touch part which is IMHO useless...
 
@PauloCereda Yes, I was wondering what that was supposed to do.
 
@AlanMunn Probably something along the lines of triggering cache rebuild...
 
@PauloCereda Yay! That solved the problem.
 
@AlanMunn Yay!
 
4:55 PM
 
WOO FIREFOX
 
Now I just need to add back the stuff I use.
@PauloCereda Thanks a lot. Where did you find this suggestion? I didn't see anything like that in my searches.
 
@AlanMunn I searched "mac icon cache rebuild" and there was a GitHub gist. :)
 
@PauloCereda Ah, that makes sense. I wasn't searching for cache, but I should have.
 
@AlanMunn Been there, done that. :) Living inside a Linux box makes us sentient of any issue, even if it sounds wacky or unlikely.
 
5:23 PM
@DavidCarlisle xspace, sigh ... tex.stackexchange.com/questions/567286/…
 
5:48 PM
@JosephWright I blame Morten
@Anush you quit too early, see I get:
 
@DavidCarlisle ooh not Ulrike
 
Runaway argument?
\UseOneTimeHook {enddocument}\@kernel@after@enddocument \@checkend {d\ETC.
! File ended while scanning use of \beamer@collect@@body.
<inserted text>
                \par
<*> dd367

?

*\end{document}

! LaTeX Error: \begin{frame} on input line 4 ended by \end{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...

<*> \end{document}

?
 
@DavidCarlisle :)
 
@DavidCarlisle <insert a link to that song...>
 
@Anush what other programming languages do you use, do you know C for example? error reporting from C preprocessor macros give even less context than tex
 
5:59 PM
@DavidCarlisle Same as \bool_if:nTF not working properly ;)
 
@DavidCarlisle well played. :)
 
6:24 PM
The Dover Display typeface: tinytype.co/type/dover-display
 
@AlanMunn I found OnyX very useful in such situations.
 
@samcarter_is_at_topanswers.xyz ooh I know this app
 
@PauloCereda a saver of life :)
 
6:40 PM
@DavidCarlisle I can program in C although I do most in python these days
 
@samcarter_is_at_topanswers.xyz Ah, yes, that's true. I've used it before too.
 
In 2013, University of Minnesota geography student Daniel Crawford composed “A Song of Our Warming Planet,” a solo cello piece built on climate data. The pitch of each note corresponds to the average annual surface temperature of a year in the range 1880-2012 in data from NASA’s Goddard Institute of Space Studies; each ascending halftone represents roughly 0.03°C in planetary warming.

“Climate scientists have a standard toolbox to communicate their data,” Crawford said. “We’re trying to add another tool to that toolbox, another way to communicate these ideas to people who might get more ou
 
7:04 PM
@Anush OK so TeX is a macro language like the C preprocessor not a compiled language like C. In C the preprocessor expands all macros first so if you get an error you typically just see the expanded form with no trace of which macros expanded. At least with tex you get (or can get) a full traceback of all expansions that got to this point.
 
@DavidCarlisle ooh referential transparency
 
@PauloCereda or "dinner" as we call it here.
 
@DavidCarlisle oh no
 
7:36 PM
@PauloCereda Hello from Fedora
 
@JosephWright OOH
@JosephWright post install? :)
 
@PauloCereda Firefox then TB then TW then will see
 
@JosephWright Ah. :)
 
@PauloCereda Also updates: I only managed to get 32
 
@JosephWright Sorry, I saw the wrong release date... it's 27 or 28 this month...
 
7:55 PM
@PauloCereda sudo ./install-tl
 
@JosephWright no user-based?
I am trying this approach nowadays.
 
@PauloCereda I don't like having software in ~ on principle: what if I need to lend the machine to someone else?
 
@JosephWright I create a personal folder in /opt and then install things there.
 
@PauloCereda From my Windows background, of course, / feels natural but it's not really encouraged
@PauloCereda I've never got the /opt business ...
 
@JosephWright No root (/), please. :)
@JosephWright It's like a directory for "third-party stuff", but one can use to his heart.
[paulo@cambridge opt] $ ls -lha
total 12K
drwxr-xr-x.  3 root  root  4,0K jun  5 19:43 .
dr-xr-xr-x. 18 root  root  4,0K abr 22  2020 ..
drwxr-xr-x.  6 paulo paulo 4,0K jun  6 05:49 paulo
lrwxrwxrwx.  1 root  root    53 jun  5 19:43 texbin -> /opt/paulo/applications/texlive/2020/bin/x86_64-linux
 
8:00 PM
@PauloCereda Well yes, but I mean that that's what /usr/local is for (OK, the original idea was that /usr was what is now called /home, but there we go)
 
@JosephWright Yes, but in my case /opt/paulo/applications/texlive is a user-install, so I don't need root. :)
@JosephWright also, if you go with /usr/local: always calls tlmgr with sudo /usr/local/.../tlmgr (full path).
 
@PauloCereda Really? I'll bear that in mind
 
@JosephWright I know Mac is just sudo tlmgr...
 
@PauloCereda I guess it's because I use Linux on a cluster, and there all software is installed by root or is in ~/bin, so that's how I think
@PauloCereda Indeed
@PauloCereda Don't I just need to fix the PATH for root?
 
@JosephWright apparently we broke maxima :(
 
8:04 PM
@DavidCarlisle ??
 
@JosephWright PATH for root?! Heavens!
@JosephWright See my post-install for texlive.sh and /opt/texbin...
 
@PauloCereda I'll take a look
 
@DavidCarlisle what is maxima?
 
@JosephWright apparently they use mylatex.tex to make custom formats for tex output and the end hook stuff had broken the patching in of \dump (Ive asked for a test case but my reply is waiting moderator approval, I got CC'ed in to teh middle of a thread...)
@UlrikeFischer math software that's older than egreg
6
 
@UlrikeFischer symbolic math thingy software, IIRC
 
8:07 PM
@PauloCereda i think I've mentioned before that I find the whole way Unix sets the path very ... odd. With a Windows background, I see the system having a path and individual users adding to it, but the administrator user having some random shortened version
@DavidCarlisle Nothing on the team list?
@PauloCereda Might need to adjust the screen zoom here: FF is pretty small
 
@JosephWright Yes.
@JosephWright It's wacky...
 
@JosephWright I probably just need to update mylatex.ltx (if I can remember what it does)
 
@JosephWright Oh... set the LCD thingy
 
@DavidCarlisle :)
 
See my post install. :)
 
8:12 PM
@DavidCarlisle did we really miss that mylatex contains \def\document{\endgroup? I thought I had searched all texmf for this ;-(.
 
@JosephWright that really is spectacularly old, public release 1994 but that was just really the 2e update, it had been used for 2.09 for 5 years before that I think
@UlrikeFischer I always try to forget mylatex.ltx is there.
@UlrikeFischer just looked for .cls and .sty ?
 
@DavidCarlisle I don't remember what I searched for exactly.
 
Good afternoon/evening from North Carolina.
 
@UlrikeFischer Oops
@PauloCereda GitKraken installed, cloning a few repos
 
8:35 PM
@LaTeXereXeTaL Evening! Ciao!
@UlrikeFischer Recently found also in biometrika.cls
 
@PauloCereda OK, I'll try your /opt approach :)
@egreg Oh bgoody
 
@JosephWright And another pearl: \def\arabic#1{{\rm\expandafter\@arabic\csname c@#1\endcsname}}
 
@egreg Eeek
 
@PauloCereda What's the equivalent of four-fingers up on the Mac? I've found the multiple desktops ...
 
8:41 PM
@egreg but that is not in texlive so it is not my fault ;-)
 
@UlrikeFischer :)
 
@UlrikeFischer The curious thing is that the redefinition of \document simply removes the part related to setting \language and I can't think to any reason for it, but I could only go back to 2007.
 
Anyone else installed Thunderbird recently? I see they've switched back to having reply-below as the standard setting :)
I guess only geeks install TB and we all want reply-below
Thought at work I've had to put up with above ...
 
@egreg or they copied from some older version where the setting wasn't there? But I guess some more problems with old classes will pop up in the next time.
 
@UlrikeFischer is it clear what to fix, I can remove the endgroup so the format makes but the resulting document ends within a group, I should have paid more attention to hook code changes:-)
 
8:56 PM
@DavidCarlisle you could use the patch Frank added for dinbrief in firstaid. (he adds an additional \begingroup).
 
@UlrikeFischer I think I'm done with Greek for Unicode (phew)
@UlrikeFischer I checked with Apostolos Syropoulos and he said 'forget about 8-bit' :)
@UlrikeFischer Good plan
 
@JosephWright ;-)
 
@UlrikeFischer thanks I'll look tomorrow.
 
@egreg How are things in Italy?
 
9:03 PM
@PauloCereda Couldn't see anything about ''LCD''
 
@DavidCarlisle but I'm not sure, why it should be different to simply removing the \endgroup. Does mylatex patch more?
 
@UlrikeFischer on the initex run \document is patched to \dump (thats when you get the endgroup error) then on the main document run everything is skipped until you get to begin document but currently that's now running in an extra group level. I'm too tired to really look, I'll forward a mail in case you are interested, but no need to look I'll sort it out tomorrow:-)
 
9:19 PM
@DavidCarlisle I saw some parts of the discussion on the list on sourceforge. But I don't know how the initex call is done today, it seems not to work for me to read in the second file.
 
9:39 PM
@UlrikeFischer latex -ini \&latex mylatex.ltx format works for me (\& just needed for bash)
 
@LaTeXereXeTaL Not really good. :-(
@UlrikeFischer Especially if written like that!
@LaTeXereXeTaL And in NC?
 
@DavidCarlisle I manage it now too, but only in the bash. The windows cmd resisted and refused to preload a format.
 
@egreg The pandemic is worsening here too.
 
 
2 hours later…
11:16 PM
@DavidCarlisle Does your quote still apply if the documentation is lying?
 
@Canageek certainly
 
Documentation: "If you put something between" "or' 'then the input will be treated as normal text, exceptthat spaces are not allowed and have to be input with~"

Me: Cool \ch{ "0.5"}

LaTeX: Let me format the heck out of that for you
Me: FRACKKKKKKKKKKKKKK
 

« first day (3644 days earlier)      last day (44 days later) »