« first day (3642 days earlier)      last day (40 days later) » 

12:23 AM
Woof. I moved from low-quality jpegs to the full quality png images for this chapter and my thesis is now 75 MBs for 66 pages of content.
Also, wow it takes a long time to add pngs to the document compared to jpegs
 
@Canageek jpg can be more or less included into pdf but png requires a relatively complicated conversion. there is a library that lets you pre-convert to pdf quite efficiently specifically made for pdftex inclusion it's name escapes me but I'll look
 
@DavidCarlisle Cool! That is a large part of the reason I moved most of them to low-quality JPEGs for day to day work, to make compiling faster.
I probably could use high-quality JPEGs for most of this, I'll see if it makes much of a file size difference at the end. This chapter will be the vast majority of the file size anyway, the others will only have 5-6 images per chapter
 
@Canageek I am fairly sure I didn't dream it, was discussed on texlive list a year or two back but It's too late at night and my search foo has deserted.
 
@DavidCarlisle No worries. If you happen to come across it let me know
 
12:38 AM
@Canageek but even using imagemagic convert and making pdfs and including them is likely quicker than including the pngs (which means doing the conversion each time)
 
@DavidCarlisle Both are still slower then using [draft] though, which is what I do when I don't need to see the images.
 
@Canageek oh sure, yes.
 
I only compile it with pngs when sending it to my boss and committee or when I want to make it extra shiny for someone
 
 
1 hour later…
1:55 AM
Oh, dear! There's a tropical storm "Epsilon" sitting in the Atlantic. If it strengthens, will mathematicians have to choose another Greek letter to represent something very small?
3
 
 
4 hours later…
5:47 AM
@barbarabeeton we have Barbara raging here... pledgetimes.com/… ;-)
 
5:57 AM
user image
2
 
 
2 hours later…
yo'
8:27 AM
@barbarabeeton Fortunately it's the majuscule Epsilon!
 
@UlrikeFischer, @DavidCarlisle Back on the Unicode business, do we want to raise this with the team?
 
@JosephWright yes why not (or a gh issue but perhaps team first)
 
@DavidCarlisle Indeed: it's more policy I think
 
@JosephWright the thing one will have to test is if it clashes with cmap/mmap which adds cmaps too. But pdfx activates it too (and loads even more a extended sets of definitions), so probably it is fine.
 
8:55 AM
@AlexG Wait a minute, two new (101) users asking the same question and using the SAME example image? cc@JosephWright
I didn't notice it at all.
0
Q: Beamer: Plotting a curved line to illustrate user trip

someoneHow do I plot a curved line similar to this one in beamer. I'm demonstrating user's trip in a slide.

:55883368 Eheh
 
@UlrikeFischer Next on the 'to think about' list for Greek: how to handle something like
  \LGR
  \`{a} \'{a} \~{a} \"{a} \^{a} \={a} \H{a} \.{a} \r{a} \u{a} \v{a}
  \b{a} \c{a} \d{a}
  $\mapsto$ \MakeUppercase{%
  \`{a} \'{a} \~{a} \"{a} \^{a} \={a} \H{a} \.{a} \r{a} \u{a} \v{a}
  \b{a} \c{a} \d{a}
  }
@UlrikeFischer I'm minded to say 'tough, won't work, it's not Greek' from the POV of the new code
 
@JosephWright sorry, my greek is here missing some info ;-). I see that with greek some of the accents disappear when uppercasing, but what "is not greek" from your point of view?
 
@UlrikeFischer :)
@UlrikeFischer Transliteration at the font level means that from the POV of a tl-based case-changer, this isn't Greek at all: the codepoints are all ASCII
@UlrikeFischer It looks Greek in a PDF, but not when you are examining each character
 
9:14 AM
@JosephWright well in a type1 font codepoints are often ascii, and it copy&paste ok. But I understand the problem, uppercasing input that relies on transliteration is hard. It probably wouldn't work with xetex + some mapping either.
 
@Alenanno homework season again... (happens twice a year. Just wait and see).
 
@UlrikeFischer Back with the starting point being very different: if you are looking for UTF-8 bytes, then finding an a is tricky :) I guess I could add some code to 'check the current font encoding', it's certainly doable
 
If someone is interested in MetaPost/Fun, there's a new chart module for ConTeXt that seems to provide quite some nice starting points.
2
 
@JosephWright wouldn't it work if the code would locally do (if LGR is detected) \def\`{}\def\'{} etc?
 
@UlrikeFischer That's more-or-less what Günter does, I think, although you have to allow for the dipthong business - but of course as I'm setting stuff up expandably, can't do \def :)
@UlrikeFischer I've not written anything yet for pdfTeX and Greek, so it could go more-or-less that way, yes
@UlrikeFischer I'm trying first to get a few more test cases as I seem to have missed the dipthong stuff, but it is a bit complex as I'm not sure that's what Unicode say is supposed to happen ...
 
9:33 AM
@Rmano Yeah I've been on this site for quite a few moons but only recently came back so I think I kind of forgot about the homework phenomenon. I didn't recognise this one to be honest.
 
9:53 AM
@JosephWright I didn't really mean that you should do it in the code. More that if someone really uses transliteration, they could add it e.g. to a font encoding hook. On the whole, I think it is okay, if we restrict some things to "sane" input (like utf8).
 
10:21 AM
quack
 
@UlrikeFischer Probably can be one for the future (although biblatex will likely drive something)
@PauloCereda quack
 
@JosephWright ooh a duck
 
@Rmano It would just be interesting what kind of course they are taking :)
 
10:36 AM
@samcarter_is_at_topanswers.xyz netiquette? ;-)
 
user image
2
ooh bunnies
 
@samcarter_is_at_topanswers.xyz ooh an international day
 
@PauloCereda intergalactic would be better :)
 
10:46 AM
@PauloCereda Slackware?
 
@JosephWright Inside the bucket? :)
 
@PauloCereda :)
 
 
4 hours later…
2:46 PM
@Rmano -- Oh, my! It's raining here too, but rather quietly.
 
Hurricanes, floods, elections and other catastrophes... :(
 
@egreg Talking of TeXworks oddities, see my latest mail to MacTeX/TW/TL mailing lists :)
 
3:16 PM
@JosephWright can you not specify a shell as the command for texworks to run then see what environment is there?
 
@DavidCarlisle He could enable Lua scripting
Palladium is back...
 
@PauloCereda socially distanced and running at 10% capacity
 
@DavidCarlisle ooh
 
@PauloCereda can you spot Joseph palladiumpantomime.com
 
@DavidCarlisle ooh I saw a puppet
> Feeling bad about feeling bad can make you feel even worse.
Oh no
 
3:40 PM
@DavidCarlisle I guess, but what's odd is that everything except Biber is happy
 
@JosephWright in which sense biber is unhappy?
 
@UlrikeFischer In the sense it can't find my file, so perhaps more accurately, I'm unhappy
@UlrikeFischer I have a symlink: works fine from the Terminal but not from within TeXworks, but only for Biber, as BibTeX has no issues. I assume it's some weird internal thing for one of the two binaries
 
@JosephWright you mean It complsins that it can't find the bcf? Or can't it find the bib?
 
@UlrikeFischer The .bib, I have no issue with the .bcf
@UlrikeFischer I've tried to explain on the TL list :)
 
@UlrikeFischer Mac has Darwin running underneath, and the mascot is a platypus. Biber has a beaver as mascot, so they are clearly having a quarrel about the computer usage...
3
@DavidCarlisle ^^ technical analysis
 
yo'
3:53 PM
@PauloCereda will not say anything, and the others please rejoice with me as I found a solution to a long-standing issue with latexmk. The solution is to place \typeout{} and the right place in the document. Well, would you expect that?
 
@JosephWright I'm out currently, will look later.
 
@yo' ooh oh no I cannot say
 
yo'
@PauloCereda this you can say :-)
 
@PauloCereda the fittest will win?
 
@yo' ooh
@UlrikeFischer probably the platypus as it's probably part duck :)
 
4:09 PM
@PauloCereda :)
 
4:22 PM
@JosephWright but biber can find bib files which are not symlinked, e.g. biblatex-examples.bib?
 
@UlrikeFischer Good question ... let me check
@UlrikeFischer Seems not ...
 
@JosephWright and what about files you call by path?
 
@UlrikeFischer Yes, does find something based on an absolute path
 
@JosephWright so it sounds as if the problem is with texmf search?
 
@UlrikeFischer Yes, seems so; I wonder if there is are missing variables or something
@UlrikeFischer TeXworks has quite a 'stripped down' path, for example (if I run \sys_get_shell:nnN { echo ~ $PATH } { } \l_tmpa_tl for example)
@UlrikeFischer Ah, it's path differences I think
 
4:37 PM
@JosephWright but it is curious. According to the docu it uses kpsewhich. That shouldn't change should it?
 
@yo' line wrapping in log files most likely, one of @JosephWright's favourite subjects
 
@DavidCarlisle Oh joy
 
@yo' ^^ I told you he'd be happy
 
yo'
@DavidCarlisle exactly! latexmk joins a line with the following when parsing the log file whenever the line has the full length.
 
@UlrikeFischer I think what's happening is for BibTeX, pdfTeX, etc., the kpse library is linked to the binaries, so they don't find it on the path. But Biber is basically doing kpsewhich XXXX using the path, so if the path is wrong, it fails
 
4:40 PM
@JosephWright I can't get anything to compile with TeXworks at all. With the latest version it says "pdflatex is not properly configured" (using the default prefs).
 
@yo' getting that right (most of the time) caused so many issues in l3build
 
yo'
@DavidCarlisle yeah, I can see how this is a painful situation...
 
@AlanMunn the message should be "sorry I am not emacs"
 
@AlanMunn Oh. I've literally installed everything in the last week or so ... MacTeX first, then TeXworks from the main download location
 
@yo' the fun part is that luatex wraps one character earlier given the same settings, except when it doesn't
 
4:41 PM
@JosephWright That's what I have too.
 
yo'
@DavidCarlisle ah yeah, saw this in the latexmk code
 
@AlanMunn Strange!
 
@JosephWright It has worked for me in the past when I've tried it.
 
@DavidCarlisle ooh
 
4:46 PM
@JosephWright Ah, now I see it was using ancient preferences. I thought I had restored the defaults. Now it works. I'll see if I can replicate your Biber behaviour
 
@AlanMunn :)
@AlanMunn I think what's happening is the that TeXworks actually calls a shell behind the scenes, and that shell has a very conservative path
 
Meanwhile, in Linux land... everything works.
4
@JosephWright ooh a Tory path
 
@JosephWright Yes, I can replicate it; my .bib file in a sym linked texmf folder.
 
@PauloCereda Indeed
@AlanMunn Ah, you are up to the same as me :)
 
@JosephWright And yes, it's only biber, because packages in my local texmf are found correctly
 
4:50 PM
@JosephWright Does it work when invoked through arara?
 
@AlanMunn Quite: I think it's because Biber is written in Perl so isn't linked to web2c, but rather calls kpsewhich 'as normal'
@PauloCereda Let me check
@PauloCereda Need the Java SDK, won't be long
 
@JosephWright Oopsie, sorry. :)
 
@JosephWright but why is kpsewhich not found? Isn't that in the same place as the other binaries?
 
@UlrikeFischer Yes, it is, but I think TeXworks does it's own search for the tools, so is running <full-path-to>/pdflatex $fullname
 
@JosephWright that makes sense. So you need to extend the path somehow.
 
4:56 PM
@PauloCereda I can't get arara to work with it at all. Maybe the configuration is weird.
@PauloCereda Error is: `/Library/TeX/texbin/arara: line 8: kpsewhich: command not found
Error: Unable to access jarfile `
 
@AlanMunn Ah I reported that in the TL list... it's a TW problem.
 
@PauloCereda Not fixed yet, I guess.
 
@AlanMunn Nope. A possible workaround is to start TW from shell.
 
@AlanMunn I think that's the same issue
@PauloCereda I'm going to dig into the TW sources
 
@JosephWright did you try the launch-whatever setting samcarter mentioned?
 
5:06 PM
@JosephWright You could also fund ArTeXmis. :)
 
@UlrikeFischer No: mainly what I'm interested in is working out the general issues: I can live with fixing by using the command line, but 'ordinary' users can't be expected to mess about with archaic stuff
 
@JosephWright zsh + spaceship prompt
 
@JosephWright yes, I just saw the suggested fix in the tl-list and it doesn't sound as something one should inflict to users.
 
@JosephWright: you know, you could use % arara: pdflatex: { branch: developer } too. :)
 
@JosephWright Yes, starting TeXWorks from the terminal allows biber to find my bib file.
 
5:19 PM
@AlanMunn woo
@JosephWright I joined the biber fun.
How does one pronounce biber?
Bee + bear?
 
@PauloCereda Not like the singer (at least in English)
 
@AlanMunn wait a minute, there's a singer?!
Must Google her/him/it/them
 
@PauloCereda Better belieb it
 
@AlanMunn OH NO THAT ONE
 
5:33 PM
@AlanMunn ooh
 
@PauloCereda I go with 'bib-er'
 
@JosephWright ooh
 
@JosephWright Really? I would say 'bye-ber' 'bib-er' should have two b's...
@JosephWright Etymology vs. orthography
 
@AlanMunn I guess, but it's a BibTeX replacement, and that's definitely 'Bib' not 'Bye'
@AlanMunn :)
 
@JosephWright @AlanMunn [recurring joke] it's spelt 'biber' but it's pronounced 'Throatwobbler Mangrove'.
 
5:40 PM
@AlanMunn I guess we should ask PLK ... it's his program after all
 
@JosephWright Is he a native English speaker?
 
@AlanMunn How about XeTeX? I know that Jonathan Kew goes with 'Zee-TeX', but another UK-based friend says 'Ex-Ee-TeX' (which makes sense)
 
@JosephWright It's kai-me or kee-me? :)
 
@AlanMunn Not sure, but does it matter? It's a name
 
@JosephWright he's dressed like an Englishman. :)
Toodle pip cheerio
 
5:44 PM
@JosephWright I guess it matters to some extent, although obviously there's variation. But names are often pronounced in the local language convention. We say Paris with an 's' and initial stress, for example.
 
Exempli gratia
I will shut up now
@barbarabeeton ^^ OH NO
 
@AlanMunn True, but then we say 'Leghorn' not Livorno, so I don't think names-of-places are a good guide
@PauloCereda OH MY GOD
@PauloCereda /quacks in anguish
 
@JosephWright /joins quack
 
@JosephWright I guess so. It's a very un-English last name, (or at least I've never encountered it) which is why I asked.
 
@AlanMunn I initially imagined he was not from the UK, but when I've interacted with him he's always given a UK vibe, and the video (accent + alma mater) seem pretty conclusive
 
5:49 PM
@JosephWright True.
@JosephWright Yes, and I realize now he does philosophy of language. I've seen the name but never made the connection.
@JosephWright The interview is really interesting btw.
 
@AlanMunn Yes, I'll probably try to watch later - at the moment, I'm still getting a handle on the Biber business
 
@JosephWright And he says "bib-er" like you. :)
 
@AlanMunn Ah, I handn't found it on a quick sweep
 
@JosephWright One the XeTeX question, we have a question on that: tex.stackexchange.com/questions/274617/…
 
@AlanMunn :)
 
5:55 PM
My two cents: I would go for bib-er, on account of it being a short form of "bibliography", or at least that's what I imagine. But then again, a) not an English native speaker, b) usually can't resist calling it bee-ber (like Bieber), and c) insists on pronouncing LaTeX as ley-tex (like latex) because let's face it, if you tell people that you're writing your thesis with Bieber and latex you get much more interesting reactions XD
 
This bloke is evil ^^ :)
 
@Plergux :)
 
@Plergux :D
 
6:25 PM
@AlanMunn -- Interesting interview, but the transcription was a beast.
 
@PauloCereda, @AlanMunn Seems we have a conclusion: there needs to be some form of manual interface to set the PATH for GUIs
 
@JosephWright I was just looking at texdev.net/2015/07/30/making-custom-loaders-expl3-aware to get some code for KOMA to avoid problems in a expl3 package. But this here simply explodes, \@pushfilename seems to grab the xdef as argument. Is that meant to work?
\documentclass{scrartcl}

\csname @pushfilename\endcsname
\expandafter\xdef\csname @currname\endcsname{scrsize11pt.clo}%
  % Main loader, including \input or similar
  \InputIfFileExists{scrsize11pt.clo}{}{}
\csname @popfilename\endcsname


\begin{document}
aaa
\end{document}
 
@JosephWright Yes, although I don't like this approach too much... We will fix it for ArTeXmis.
 
@PauloCereda Well it seems TeXShop and TextMate basically work that way - of course they are both Mac-exclusive
 
@JosephWright Hmmm perhaps we could go with a Lua script at boot time (TW already supports it)
 
6:37 PM
@UlrikeFischer Modulo needing some \makeatletter, yes, at least yes with TL'15 era \@pushfilename
@UlrikeFischer First time I've wanted TL'15 in a while - luckily I've kept it all on the new laptop
@PauloCereda Maybe: read path then?
@PauloCereda Do you have a new enough Mac for the development?
 
@JosephWright Yes, something along the lines of a pathmunge.
@JosephWright Probably, I am three OS versions behind, but still doable.
 
@PauloCereda Ah, cool
@AlanMunn Interesting part about writing in TeX vs Word - I guess PLK must work in an area where the effort of converting is worthwhile. Also likely doesn't have lots of collaborators complaining ...
@PauloCereda Upside of all of this: I now have Java set up for arara
 
@JosephWright yay
 
6:57 PM
@JosephWright Scrooge McDuck?!
 
Hi everyone, I'm getting an undescribed error in my code overleaf.com/5442623619dcckrnqvrcyj
 
@Mathemanic it has no error just one warning:
 
Problem is, the output looks good. I am not sure why Overleaf is highlighting the code red. I got the code from this answer: tex.stackexchange.com/questions/492049/…
Oh thanks David. Is there anything I can do to the code to make the warning go away?
 
@Mathemanic but if you mean the red squigge underlinethat is unrelated to tex just your spell checker, turn it off in the menu in the left side bar
@Mathemanic you changed it? it now has errors No \begin{document} command was found. Make sure you have included \begin{document} in your preamble, and that your main document is set correctly.
 
7:08 PM
@JosephWright "there needs to be some form of manual interface to set the PATH for GUIs" switch to texstudio, this has a field in the preferences to adjust the path :)
 
^ This is how it looks on my end David, a big chunk of code is red with no explanation why
\begin{document} is line 61
 
@Mathemanic there was an 8 in the preamble, i deleted it. I see no highlight region, it highlights in blue if I select text. vvv
 
@samcarter_is_at_topanswers.xyz I've been using TW for a long time, I liked the pared-down interface ...
 
@Mathemanic maybe you need to ask overleaf support
 
@samcarter_is_at_topanswers.xyz I've been trying to explain on the MacTeX list that for myself it's not an issue, it's more that I want to solve the general issue so other (new) users are not bitten
 
7:13 PM
@JosephWright well the \csname-version can't work (anymore?), \@pushfilename ends with a command which expect two tokens and then a filename, so only \xdef\@currname{...} works.
 
Interesting, thanks @DavidCarlisle!
 
@JosephWright There's not a lot of joint work in philosophy, so complaining collaborators aren't likely to be much of an issue. And depending on the material it's mainly text (although he does mention that his thesis work involved attribute value matrices which would be quite a mess to convert to Word.)
@JosephWright Luckily in linguistics journals there's more acceptance of LaTeX or PDF at least, although it depends a bit on the area.
 
Oops. I had typed that extra 8 when I was trying to press the PrtScn button 🤦‍♀️. Thanks for fixing it
Still getting red highlight over a large portion of my code, but sent Overleaf a message to get more information
 
7:40 PM
@UlrikeFischer I'd have to check the old definition
 
@JosephWright I can check tomorrow too,
 
> \@pushfilename=macro:
->\xdef \@currnamestack {{\@currname }{\@currext }{\the \catcode `\@ }\@currnam
estack }.
@UlrikeFischer ^^^
 
@JosephWright so it changed and this broke the csname variant.
 
@UlrikeFischer Yes: we now have something trailing: not my fault, @PhelypeOleinik?
 
8:06 PM
@JosephWright hm but expl3 contains code to add this extension, so what happens you load expl3 first and then check \@pushfilename in tl15?
 
\documentclass{scrartcl}

\csname @pushfilename\expandafter\endcsname
\expandafter\xdef\csname @currname\endcsname{scrsize11pt.clo}%
  % Main loader, including \input or similar
  \makeatletter
  \InputIfFileExists{scrsize11pt.clo}{}{}
  \makeatother
\csname @popfilename\endcsname


\begin{document}
aaa
\end{document}
@UlrikeFischer ^^^
@UlrikeFischer Just needs an \expandafter so there is \xdef then a single token
 
@JosephWright yes that works. Will you edit the blog?
 
@PauloCereda I've been reading Adam Maxwell's views on notarizd binaries :)
@UlrikeFischer Sure
@UlrikeFischer Fixed
 
@JosephWright nice, thanks. It is good to have a more or less "official" reference.
 
@UlrikeFischer Sure: I am happy to fix these things
 
8:39 PM
@JosephWright why does blubA work and blubB fails with an error?
\documentclass{article}
\begin{document}
\newenvironment{blubA}[1]{abc#1}{cde}
\newenvironment{blubB}[1]{abc}{cde}
\ExplSyntaxOn
\text_purify:n {\begin{blubA}{zzz}ccc\end{blubA}}
\text_purify:n {\begin{blubB}{zzz}ccc\end{blubB}}
\ExplSyntaxOff
\end{document}
 
@UlrikeFischer Hmm, looking now
 
8:58 PM
@UlrikeFischer My fault:
\ExplSyntaxOn
\cs_new:Npn \__text_end:n #1 { \cs:w end#1 \cs_end: }
\text_declare_purify_equivalent:Nn \end { \__text_end:n }
\ExplSyntaxOff
 
@JosephWright that works (but I won't try to understand why ...).
 
@UlrikeFischer Simple: I forgot to expand the \end part to include end in the name!
 
9:26 PM
@JosephWright Might have been, but definitely not on purpose... I'll check
 
@JosephWright simple ;-). Fragile commands (with optional arguments) are removed by hyperref, but with \text_purify they errors:
\documentclass{article}
\usepackage[unicode]{hyperref}
\begin{document}
\newcommand\blub[1][]{abc}
\ExplSyntaxOn
\pdfstringdef\hyptest{\blub[abc]}
\show\hyptest
\text_purify:n {\blub[abc]}
\ExplSyntaxOff
\end{document}
 
@PhelypeOleinik It's OK, I've sorted it: my fault
 
@JosephWright I knew it ;-)
@JosephWright Though it seems the expl3 patch to \@pushfilename does expect the following \xdef to be there... Not good
 
@PhelypeOleinik Well yes
 
@JosephWright One more for my filename stack rework (if that ever happens)
 
9:32 PM
@UlrikeFischer Ah, right: the issue is that \newcommand doesn't include a \protect :(
@UlrikeFischer I guess I'll need to search for \@protected@testopt
 
@JosephWright It's tricky because \@pushfilename wants the old \@currname and the expl3 patch wants the new one, and I was told that TeX doesn't allow one definition with two meanings :-)
 
@JosephWright you could also say "not supported", after all the hyperref behaviour isn't really sensible either, only that it doesn't error. (I'm only trying to access the behaviour, and to document it together with the differences.).
 
@JosephWright do you need to patch \@pushfilename from expl3 ? since it's in the format anyway shouldn't the format just define it the way that's needed?
 
@DavidCarlisle the definition is now in the format, the patch was done in older versions.
 
@UlrikeFischer well yes, I know but...
 
9:40 PM
@DavidCarlisle you mean if these \@expl@@@hook@curr@name@push@@n{}` etc commands are needed?
 
@UlrikeFischer actually I'm not sure what I mean was just thinking aloud, will look again at the code...
 
 
2 hours later…
11:35 PM
I'm sitting here in a virtual meeting of physics teachers and I just plugged LaTeX again.
 

« first day (3642 days earlier)      last day (40 days later) »