« first day (3279 days earlier)      last day (49 days later) » 

4:10 AM
@yo' I hope they won't put them on pizza.
 
 
3 hours later…
6:56 AM
@DavidCarlisle uff, I'm relieved, I feared you had found a recipe of pizza with rubber duck topping.
 
@UlrikeFischer I looked
@UlrikeFischer I need to fix this....
0
A: Unable to compile with includegraphics using jmlr.cls

David CarlisleThere were some adjustments to filename handling in the latest latex release, to support spaces and non ascii characters in filenames. It's clashing with the class presently so for now you can undo the support for additional characters in filenames, then if I use example-image which is a standard...

 
@DavidCarlisle I see that Q also shows that interfaces from version 1 of siunitx are still needed
Oddly enough, I was just checking performance of v1/v2/v3-alpha ...
v3 0.00172 seconds (6.1e3 ops)
v2 0.00478 seconds (1.74e4 ops)
v1 0.0155 seconds (4.42e4 ops)
for \benchmark{\SI{0.234e3}{\joule\per\mole\per\kelvin} }
 
@UlrikeFischer ^ don't tell @CarLaTeX
@JosephWright what's it not doing that it did before?
 
@DavidCarlisle Well v1 was just all horrible hacked together stuff, so it's generally super-slow
@DavidCarlisle For v3, I've written a new data storage approach for numbers: unlike units, they are not open-ended so I'm not using a prop. The parsing is all revised to be faster. And crucially I've altered the font control entirely.
@DavidCarlisle In v1/v2, I have effectively \hbox{\ensuremath{...}} to set stuff, so there is always font selection. New plan is to introduce a box only if one is requires: it should make fonts work much better but of course will mean I get some complaints
@DavidCarlisle I plan to use the rollback business to continue to have v2 around, and I'll likely add v1 as well to be on the safe side
 
7:26 AM
@DavidCarlisle it worked ;-). But I had to change the "submitter id".
@DavidCarlisle what is the class doing?
 
7:52 AM
@UlrikeFischer I had to change that in one I did
@UlrikeFischer no idea, I was just packing up to drive to work, I'll look later. I tested it worked in an older texlive so just guessed the set@curr@file fix..
 
8:31 AM
@UlrikeFischer oh the class is one of Nicola's
 
@DavidCarlisle oh, I can look in a few minutes, but Marcel broke tagpdf ...
 
@UlrikeFischer That is the benefit of a having someone else with write access they can always be blamed
 
@DavidCarlisle the class has \def\Ginclude@graphics#1{% ...
 
@UlrikeFischer when is jpg not equal to jpg :-)
@UlrikeFischer yes
 
@DavidCarlisle looks likes as if she is trying to use a different picture in print mode. Is a sensible interface for such conditionals possible?
 
8:43 AM
@DavidCarlisle Cool
 
@UlrikeFischer I expect so but I probably can't look for a bit.
 
9:10 AM
@DavidCarlisle ooh
@DavidCarlisle ooh
@JosephWright ooh
@yo' ooh
@DavidCarlisle you are mean
 
@DavidCarlisle OMG
 
9:36 AM
@CarLaTeX I thought you would like it
 
@DavidCarlisle I've signed up, given them a one-tier level: we'll see if anyone pays anything!
 
 
1 hour later…
10:56 AM
@JosephWright hmm can we stop forks mailing latex3-commits?
 
@DavidCarlisle I'll look at it: we had this discussion before
@DavidCarlisle Easiest would be just to send pass/fail mails to the committer: that's the standard set up
 
@JosephWright actually the occasional one wouldn't be so bad but if there were lots of forks it could easily swamp us:-)
 
@DavidCarlisle Reading the docs, they've set everything up nicely so pull requests and the like don't trigger emails, but that only works if you don't over-ride, which we of course do
 
@JosephWright where is this latex3-commits mailing list?
 
11:18 AM
@JosephWright spaces in filenames in xetex, is that affecting the 2e versions too?
 
@DavidCarlisle mark them as spam :)
 
@DavidCarlisle I know what the issue is ... give me about five minutes
@DavidCarlisle It seems that there is a subtle difference in \filesize compared to \pdffilesize: I think it's that business about the different C function for dealing with file names. XeTeX treats quotes as part of the name, pdfTeX/(u)pTeX do not
@DavidCarlisle See my fix
 
@JosephWright given rest of web2c filehandling dropping quotes would be more reasonable \input{foo"ba".tex} inputs foobar.tex doesn't it?
@JosephWright will look...
 
@DavidCarlisle Yes, it does, although I'd have to check what the primitive does in XeTeX ...
@DavidCarlisle That is all fine with XeTeX, but \filesize doesn't work the same way :(
@DavidCarlisle I guess we should look to fix this .. though it's easily sorted at the macro layer once you know
 
11:36 AM
@JosephWright I was planning to delay adding quotes in the 2e version for somewhat related reasons, while it's all in tex's web2c file handling it is OK to quote the basename and path etc even if you end up with "./foo"/"bar".eps but oddly enough ghostscript chokes if you ask it to make "./foo"/"bar"-converted-from-eps.pdf and the svg package has similar difficulties with converted filenames. I think we need to make the internal structures be unquoted, and just add quotes at the end
 
yo'
A growing family :)
user image
3
 
@yo' ooh! <3
 
@DavidCarlisle In expl3, I've gone for 'tidy up then pass quoted if required', so strip them back off where is required
 
@JosephWright yes trouble is I don't know what random packages for svg inclusion (or random Journal Classes from Nicola) are doing with image filenames until we break them, but on balance, if we pass them unquoted things will work except possibly filenames with spaces, whereas if we pass them unexpected quotes no files work
 
@DavidCarlisle Sure, that makes sense at a 2e level
 
11:45 AM
@JosephWright but not what we are doing, need some time to adjust stuff: tex.stackexchange.com/a/513321/1090
 
12:04 PM
how do you format times (durations) in latex? \SI{4}{\minute} \SI{35}{\second} ?
can you combine that somehow to get a 4:35 format or something like that?
 
user image
2
@DavidCarlisle ^^ Joseph is taking a walk in the park
 
12:31 PM
@MarcelKrüger I'm not quite sure, but I think that current output of the issue47-mac-only-font-family (and of the other mac related test failure) is actually correct.
 
@UlrikeFischer Both outputs aren't wrong, the question is just if the fontloader is aware that it loads the same font twice. Getting `\testname˙ means that LuaTeX loads the font twice which is a bit slower, but normally that shouldn't be a problem. I'm not quite sure why this is affected by the lookup method.
 
@MarcelKrüger that explains it. So we see a side effect of returning to a texmf. I will recreate the tests for now and also ttcfontindex where only the font numbers have changed.
 
12:57 PM
@sollniss On the border of siunitx use ...
@DavidCarlisle, @UlrikeFischer Looking forward to views on the space busines
 
1:17 PM
@JosephWright well it sounds as if we need a larger and systematic test environment with all sort of cases ;-). I'm getting lost in the quotes or no quotes question ;-)
 
1:44 PM
@MarcelKrüger looks as if I shouldn't have remade the ttcfontindex test, the font numbers are different on travis ;-(. But beside this: the colored test doesn't work for me, the BungeeColor1.ttf in harf mode hangs.
 
@UlrikeFischer For L3, we are starting with a clear position (file names get quotes by \file_full_name:n, which should be applied to any file name before use)
 
@UlrikeFischer My system agrees with Travis that the font numbers didn't change...
 
@JosephWright yes and this is sensible. But from your mail I got the impression that there is not much hope to get identical behaviour on the engine/backend level everywhere. So probably some backend/engine files along with some abstraction is needed - secret plan ;-).
@MarcelKrüger how are the numbers /F25 etc in the pdf created? Why should it be different for me?
 
2:03 PM
@UlrikeFischer I think I might have good news soon. :)
 
@UlrikeFischer They are the LuaTeX fontids of the first loaded font which uses the font dictionary. I don't know why they are different, maybe a Windows thing? Do you have a different format which loads additional fonts?
 
2:17 PM
@UlrikeFischer Oh, well before that: expl3 will 'know' about this by the end of the day
@UlrikeFischer On 'can we make it the same', I've already run into this, and as I don't know C nor why things are set up like they are, it's tricky
 
@MarcelKrüger bingo. If I compile a hello world with lualatex I get /F15 and with lualatex-dev /F25. And it is not luaotfload, it must be the secret plan ... @JosephWright does expl3 initialize some fonts?
 
@UlrikeFischer Er, just Bruno's data storage ones ...
@UlrikeFischer Yes, that shows in the Secret Plan test changes
 
@JosephWright but only in luatex/xetex probably as with pdftex cmr is they are there anyway. But with the unicode engines they are additional.
 
@UlrikeFischer Yes, exactly
 
2:40 PM
@UlrikeFischer They would probably increase fontids of fonts loaded afterwards anyway because in TeX every size needs a separate font, so every size reserves one fontid.
 
@DavidCarlisle Do you want to do the Travis-CI magic?
 
@UlrikeFischer ooh database is almost ready, I guess. :D
 
@JosephWright OK but can't do that here, can look this evening
 
@DavidCarlisle ooh
 
@DavidCarlisle Sure, no problem: I'm going to do some more on spaces leter
@DavidCarlisle I take it from your team mail that you favour simply not having any quotes until required, so I could adjust expl3 to work that way: in some ways, makes most sense
@DavidCarlisle Also reminds me about Karl's request about \input (and presumably \openin and \openout ...)
@DavidCarlisle I guess I should try to track down the bug ...
 
2:59 PM
@JosephWright yes that occurred to me as well.
@JosephWright by the way if the variable SS is a space type a%SS%b.tex shows a b.tex at the cmd prompt so it's not absolutely essential to have quotes (although simplest way to set SS is to use set SS=" " which has quotes
 
@DavidCarlisle Er, fair enough
 
@UlrikeFischer Can you test the colored test again with the latest push?
 
@DavidCarlisle Point is there's no supported way on Windows to create a file with quote marks in the name, so for cross-platform use it's safest to treat it as 'banned'
@DavidCarlisle I agree that in many ways we leave XeTeX alone, use pdfTeX without quotes for \pdffilesize, etc. and call it 'done'
 
@JosephWright yes although that isn't my worry it's things like
0
Q: svg package failing to work after update

TeoFed89I can't compile the book I've been working on anymore after a general package update. I restricted the issue to a recent version of the svg package (Oct. 10). In this MWE: % !TeX spellcheck = it_IT % !TeX TS-program = lualatex % !TeX encoding = UTF-8 \documentclass{scrreprt} \usepackage{svg} \...

 
@DavidCarlisle Sure: like I said, best to strip out quotes at the expl3 end?
@DavidCarlisle If we drop quotes to the last second, we get consistent behaviour and it's easier to pass to other tools
 
3:08 PM
@JosephWright where currently we end up quoting crystal just in case and that gets used in a generated filename './svg-inkscape/"crystal"_svg-tex.pdf' which blows up.
 
@DavidCarlisle Sure, got it: at least expl3 wouldn't quote there anyway ;)
 
@JosephWright that's the conclusion I'm coming to, yes.
 
@DavidCarlisle OK, I'll adjust in expl3, and I think I will look at \input ...
 
@JosephWright yes if we only quoted if there was a space it would happen less often but still likely to end up with "inner" quotes in this sort of pipeline, if we don't quote then the package can quote the entire path once it has constructed it. (of course if it changes to do that and unquotes first to be safe then it doesn't matter if we quote or not...)
 
@DavidCarlisle expl3 does that already, just adds them if required, but I think a tidy up might be safest
 
3:15 PM
@JosephWright yes I know but making an error less likely to occur isn't necessarily a good thing
 
@DavidCarlisle Sure, so like I said I'll remove the quotes, only add them internally for \input and the like
 
3:34 PM
@DavidCarlisle I don't think to like to eat rubber on pizza :)
 
@MarcelKrüger it compiles now. I get a number of failures with config-harf: again the font change, a number of lua data reference 792 have a different number (perhaps also format related ...) and in the math some shift. I think I will checkout as master-harf and run the tests from there.
@PauloCereda you are fast ;-)
 
@UlrikeFischer A Lua table is on its way. :)
 
@UlrikeFischer Teh lua data reference numbers might also be system dependent, so maybe we want to filter them. What kind of shift do you get with math?
 
@MarcelKrüger I hadn't look until the end, there is more. The diff says:
Vergleichen der Dateien .\BUILD\TEST-CONFIG-HARF\math.tlg und .\BUILD\TEST-CONFIG-HARF\MATH.LUAHBTEX.LOG
***** .\BUILD\TEST-CONFIG-HARF\math.tlg
   15:  ..\glue(\lineskip) 0.0
   16:  ..\vbox(550.0+0.0)x345.0, glue set 507.94574fil, direction TLT
   17:  ...\write-{}
***** .\BUILD\TEST-CONFIG-HARF\MATH.LUAHBTEX.LOG
   15:  ..\glue(\lineskip) 0.0
   16:  ..\vbox(550.0+0.0)x345.0, glue set 509.94553fil, direction TLT
   17:  ...\write-{}
*****

***** .\BUILD\TEST-CONFIG-HARF\math.tlg
   18:  ...\glue(\topskip) 1.85997
@MarcelKrüger when I run the tests in a branch "master-harfnode" all tests in config-harf pass with the exception of the math test which still shows this diff.
 
3:56 PM
@UlrikeFischer Can you look which font file is used for Amiri?
 
@UlrikeFischer that seems good :):):)
 
@MarcelKrüger c:/texlive/2019/texmf-dist/fonts/truetype/public/amiri/Amiri-Regular.ttf
 
@UlrikeFischer And I assume your system is up to date. Then I don't see why LuaTeX would break the line differently... Odd.
 
4:18 PM
@MarcelKrüger well "up to date" is not always clear - the luahbtex version could be different as I have to install it manually. Could you run the math test and sent me the full log?
@MarcelKrüger any idea about the fontdata problem and luaotfload.aux.slot_of_name?
 
@UlrikeFischer Yes, fontdata is called tfmdata in that function.
 
@MarcelKrüger so ` local hbdata = tfmdata.hb`
 
@UlrikeFischer You got mail.
@UlrikeFischer Right, I pushed the fix.
 
@MarcelKrüger ooh
 
4:44 PM
hm, looking at the paragraph tracing our demerits are different:
you: `@ via @0 b=48 p=0 d=13364`
me : `@ via @0 b=48 p=0 d=3364`
@PauloCereda that looks very nice!
 
@UlrikeFischer <3
 
5:11 PM
user image
3
@JosephWright ^^^
 
yo'
@PauloCereda and btw... in my office
user image
3
 
@yo' Yay
 
yo'
@PauloCereda Finally I have a rubber duck on my desk, so I can debug all the LaTeX issues...
 
@yo' :)
@UlrikeFischer ooh chemistry
 
@yo' Wow, I'm envy!
 
5:24 PM
@yo' it's so green, is it ill?
 
@UlrikeFischer Tests showed that \adjdemerits are inserted on my system. That seems off if there is only one line.
 
@JosephWright hm
 
yo'
5:40 PM
18 hours ago, by yo'
Well, as rubber is solidified sap, you can safely say that rubber ducks are vegetables.
 
@yo' but, what if they are made from some oil-based polymer? Then they are made from dinosaur corpses!
 
@Skillmon ooh dinosaurs
 
@PauloCereda it gets really disturbing when you realize that playing with plastic dinosaurs means playing with dinosaurs made out of dinosaurs.
 
@Skillmon ooh a jurassic loophole
This is intriguing
 
@PauloCereda Frankenstein's dinosaur.
 
@PauloCereda Oooh
 
@PauloCereda was the first thing that came to my mind (not that episode, though)
 
@PauloCereda Grrr, dine-o-saw
 
5:58 PM
@MarcelKrüger that looks really odd. I can't imagine why this should happen. Do you get it with luatex too?
 
I just did an experiment where I could get similar behaviour even with regular tex: If the first line is very loose, \adjdemerits got inserted.
 
@MarcelKrüger how is the code?
 
@UlrikeFischer Take
\tracingparagraphs=1
\tolerance=1000
\hsize=2.5in
\noindent ferred to be called---% error has been fixed!
was happiest when he was at work
typesetting beautiful documents.
\vskip 1in
\hrule
\vfill\eject
\bye
In the second pass, the first line gets d=29881, where b=131, p=0, so (131+10)^2=19881 and 10000 get added as adjdemerits, even if the second line isn't determined yet.
 
6:15 PM
@MarcelKrüger I get this too. So why don't I get it in the math text file?
 
6:30 PM
@UlrikeFischer If I only knew. Are there any other differences in the log file?
 
please how two write to lines in the same cell in a table
 
@MarcelKrüger there are differences. The most obvious that I have a newer expl3 and xparse. But the fontspec versions are the same. Which development version of luahbtex do you have? mine is Development id: 7195.
 
\begin{tabular}{|c|c|c|}
\hline
رقم التمرين & ملاحظات
\\
\hline
$01$
&
تعالج حالتين فقط
\\
\hline
$02$
&
يعالج كاملا، لكن هنالك بعض الأفكار المتكررة وبالتالي يمكن الإشارة اليها وتركها للطالب ثم نراقب العمل في الحصة التي تليها
\\
\hline
\end{tabular}
 
@PolineSandra c columns are single line use p{3cm} then each cell is a parbox of that width
@PolineSandra you have specified three columns but just seem to have two columns of data in each row?
 
6:47 PM
there is just two I do a mistake
where I must write p{3cm} ?
 
@PolineSandra so then \begin{tabular}{|c|p{5cm}|} for example
@PolineSandra but actually your example looks more like a list than a table, why not use \begin{enumerate} instead?
 
but the name of the second column is not in the center how to do ?
I thanked that a table is better
 
@PolineSandra \multicolumn{1}{c}{heading} would set the heading in a centred one-line cell
@PolineSandra lists have many advantages, not least that if the items get long they can break over a page as they are just normal text paragraphs.
 
what I write is remarks about exercices
i canto to say
is the exercise 1 we do 2 cases
I the second all the exercise
the third only one case
....
what is better ?
a table o enumerate ?
 
@PolineSandra I can't read the text and I don't know how long it is so I can't say, but if it needs to be longer than a page I'd definitely use a list
 
6:57 PM
no it will takes only one page
where I must put
\multicolumn{1}{c}{heading}
 
7:10 PM
@PolineSandra that is the text replace heading by your arabic heading text
@JosephWright isn't it enough to do
notifications:
  email:
    if: fork = false
    recipients:
  .....
 
7:28 PM
could hide the email address in a variable but I think end result is same that notifications are disabled on forks, I don't think the above means do the default notification on forks, I'm trying to see if I can omit the entire customisation in forks something like
notifications:
    if: fork = false
      email:
        recipients:
          - latex3-commits@tug.org
        on_success: change
        on_failure: always
        on_start:   never
I may experiment a bit ..
 
@UlrikeFischer I have 7207. I'll try updating expl3 and friends.
 
@PauloCereda how's your yaml :-)
 
@DavidCarlisle Ah, I thought the conditional had to be inside the email part
 
@DavidCarlisle :)
 
@JosephWright well that isn't clear from the doc (or not clear to me at least) as i say O may set up a throw away repository and experiment...
@PauloCereda we want to notifications to go to the team list but forks of the repository to have standard settings....
 
7:30 PM
@DavidCarlisle ah hold on
notifications:
    latex3:
      email:
        recipients:
          - latex3-commits@tug.org
        on_success: change
        on_failure: always
        on_start:   never
@DavidCarlisle ^^ does this work?
 
@PauloCereda oh not if: repo= latex3 just latex3: ?
 
@DavidCarlisle seems so, only the owner name suffices. :)
 
@PauloCereda not that I don't believe you, but is this documented anywhere? what if my name was email or slack ?
@JosephWright I suppose we could try it anyway:-)
 
@DavidCarlisle I saw somewhere in the documentation, or an issue, or Google thingy. Hold on...
 
I always read documentation
2
 
7:39 PM
@DavidCarlisle Email Carlisle :)
Not as catchy as iPad Mittelbach though. :)
 
@DavidCarlisle Cool
 
@DavidCarlisle you are right, if it is.
Should you just reduce spaces?
notifications:
  if: branch = master
    email:
      recipients:
       - latex3-commits@tug.org
      on_success: change
      on_failure: always
      on_start:   never
notifications:
  if: repo = latex3/l3build
    email:
      recipients:
       - latex3-commits@tug.org
      on_success: change
      on_failure: always
      on_start:   never
notifications:
  if: fork = false
    email:
      recipients:
       - latex3-commits@tug.org
      on_success: change
      on_failure: always
      on_start:   never
notifications:
  if: commit_message = "hope Joseph does not see this"
    email:
      recipients:
       - latex3-commits@tug.org
      on_success: change
      on_failure: always
      on_start:   never
 
@PauloCereda this one is possibly best as can easily be copied to different repos., I'll give it a try ...
@PauloCereda ?
 
@DavidCarlisle sometimes YAML complains about indentation, I am not sure if that was the case... Let me check.
 
@DavidCarlisle you learned that from me ;-)
 
7:52 PM
@DavidCarlisle I think we got the if thingy in the wrong place!
That's why it's not working.
notifications:
    email:
      if: fork = false
      recipients:
       - latex3-commits@tug.org
      on_success: change
      on_failure: always
      on_start:   never
@DavidCarlisle ^^
I think now it's okay. The other YAML code was invalid.
 
@PauloCereda That's what I'd been trying: I suspect it kills email for the forks ...
 
@PauloCereda ah that's same as the one in the example, but what's the effect then on notifications inforks, that it is disabled or that you get the default behaviour of email to committer
 
@DavidCarlisle @JosephWright good question. I was focused on the invalid YAML thingy. :)
 
@DavidCarlisle Exactly
 
@DavidCarlisle we could add another condition to the... conditional... :)
 
7:56 PM
if travis had a magic variable for the committer email we could add an if:fork = true branch to set the notifications, but I didn't see that anywhere
 
@DavidCarlisle set an env var?
The documentation covers it.
 
@PauloCereda that was my plan for this evening:-) but I can hide the email address so email: secure: kjaojcacacacacac which will mean that the email won't work on forks but (I think) means the file is essentially broken on forks with email: set to an unresolved varuiiable>
 
if fork = false AND env(BLAME) = Ulrike
@DavidCarlisle ooh
 
@PauloCereda never read documentation, bad things happen
5
@PauloCereda I tried reading this but it didn't mention yaml syntax anywhere
 
@DavidCarlisle I took the liberty of testing it against a checker. :)
 
8:07 PM
in the Welsh language text, for “y diwrnod ymadael” substitute
“diwrnod cwblhau’r cyfnod gweithredu”, ;-)
 
@PauloCereda so why can't I have an if: clause under notifications ?
 
8:21 PM
Hello! I am completely inexperienced with TeX but I'm responsible for a system that, among many other things, uses it to generate PDFs and I appear to have broken that functionality. I'm not 100% sure where to start with asking for help; I'm on Ubuntu 18.04 and it seems that upgrading from Ubuntu 14.04 is when I introduced the error (I know, this implies a lot of other issues; please set that aside :P).
 
@nthall You using the TeX that comes from Ubuntu? Not one you've installed separately?
 
@JosephWright yep!
 
@nthall show a log file with the errors and someone can probably give you some clues
 
@nthall Missing expl3, which is odd as you have xparse. Did you install texlive-full?
 
8:34 PM
@JosephWright when was Undefined control sequence \__msg_kernel_new:nnnn added, how come you can get that without a missing file expl3.sty error first?
 
@DavidCarlisle It's not a TeX log, it's rubber: I guess some mangling
 
@JosephWright yes so..
 
@DavidCarlisle Don't ask me!
 
@nthall do you have the original .log file as written by tex, not rubber's filterd view of it?
 
yes, i've got texlive-full installed
 
8:36 PM
@nthall Hmm, like @DavidCarlisle says, need the 'raw' .log file
 
i don't know where to look for the original logs from tex.
 
@nthall also why is xparse.sty here /proj/media/assessments/templates/math/assessment/xparse.sty not in your standard ubuntu texlive tree?
@nthall normally in the same directory as the document unless you rbuild system deletes them...
@nthall find . -name \*.log if all else fails:-)
 
@DavidCarlisle not sure! i've never had to tinker with the workings of this subsystem before; the file says it was generated with the docstrip utility, and the first non-comment line is \RequirePackage{expl3}[2012/07/16]
 
@nthall that's an old one
if you have a newish texlive it should say `\RequirePackage{expl3}[2018-04-12]
` (but without your full log I'm not sure which texlive release you have with ubuntu)
 
@DavidCarlisle Sound old even for the Ubuntu version given
 
8:44 PM
@nthall but it should not be in your local build area it should be in your tex tree in my case /usr/local/texlive/2019/texmf-dist/tex/latex/l3packages/xparse/xparse.sty but the root for a system texlive is probably /share/texlive or whatever.
@nthall so I would guess you have a local old copy of xparse that is masking the system installed one and it will be enough to simply delete that (or move it if you are not trusting random internet advice to delete things)
@nthall what does kpsewhich -all xparse.sty report if given at the commandline? (it should echo all the copies of that file that it finds)
 
$ kpsewhich -all xparse.sty
/usr/share/texlive/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
(right before running that, i renamed the "odd" xparse.sty, probably explains why it's not in that list)
 
@nthall yep that's the real one, but rubber was running in a specific location and/or specific TEXINPUTS enviornment variable and found /proj/media/assessments/templates/math/assessment/xparse.sty which isn't the right one
@nthall so what happens if you re-run your document now?
 
about to test that
well i'll omit the warnings that are confusing to me but seem to not be the real issue; here's the meat of it:

process 13813 (pdflatex) returned 1
There were errors compiling tmpCZ9fXT.aux.
tmpCZ9fXT: File ended while scanning use of \\fancyfoot.
tmpCZ9fXT: Emergency stop.
 
@nthall if rubber hasn't deleted it there will be a tmpCZ9fXT.log lying around somewhere that would help. debugging without seeing the code and only seeing 1% of the log file is a bit of a challenge:-)
on the face of if the error there means your document has \fancyfoot{something with no closing brace so it ran off the end of the document looking for } but it is not impossible that it is some unrelated earlier error that threw it off track
 
8:59 PM
no logfile under that name anywhere ;_;
 
@nthall it probably cleans up, I haven't used rubber but it must have an option not to delete the generated files. or if the tex file is there just run pdflatex tmpCZ9fXT.tex directly
 
there's a file there with no .tex extension; running pdflatex on it gives a lot of output but the relevant part at the bottom is

)
Runaway argument?
{\bfseries \scriptsize \par \makeatother \par \usepackage {babel} \begin \ETC.
! File ended while scanning use of \\fancyfoot.
<inserted text>
\par
<*> tmpCZ9fXT

?
well, what seems like the relevant part, anyway.
 
@nthall that's the one can you put it all in a gist
 
@nthall but if the file tmpCZ9fXT does have {\bfseries \scriptsize followed by a blank line and then never a matching } the error is in your tex generation not in the tex setup, but let me look at the log you just posted...
 
9:09 PM
in case it matters, i ran the command a second time, redirecting output to a file, since the first time i was in some interactive mode and had trouble exiting out, and this was an easier way to get the text where i wanted it anyway
ok, so, i will have to check the source files for stray brackets essentially?
 
@nthall yes it's a trick it says to type \end to get out of that but you need \stop
 
ah, that makes sense (i'm a vim user)
 
Bob
Where is a good place to share a useful tool? I wrote a hammerspoon script that I use for completing my SublimeText--Skim integration. Should I just make a question then answer it?
 
@nthall yes the log loogs good until that error so on the face of it it''s just reportung an error as there is an error:-) the file loads pgf package then xparse then apparentlly has \fancyfoot{
@nthall If I had known that I wouldn't have helped you at all:-) (I have used emacs since about 1987:-)
 
indeed there is a line like you described in the tmp file, so there's an error in the step that substitutes strings from teh original source file (creating the tmp file). ugh boy ok, thank you so much!
 
9:15 PM
@DavidCarlisle you can. :) I am just not sure if a map of map of map syntax is correct. Let me check something.
@DavidCarlisle what is puzzling me is that if cannot be a map since it has an assigned value.
 
@PauloCereda I think it's some pre-yaml filter thing hang on...
 
@DavidCarlisle oh that's okay, I am puzzled by the indented part below. :)
 
@PauloCereda yaml indentation is like python indentation or bash \\ quoting, you just randomly double it up until things work (I think that's the official policy anyway)
 
@DavidCarlisle yes, but I am challenging that the structure is not valid. :)
if:
  a: 1
  b: 2
This is a valid map.
if: foo
  a: 1
  b: 2
This isn't. :)
 
@PauloCereda but I don't think it's yaml map my understanding is that the if: filter just deletes stuff and so long as what remains is yaml it's all good
 
9:26 PM
@DavidCarlisle ah I see what you mean! In that case...
 
@PauloCereda ... ignore the doc and just try checking it in and see what happens?
 
@DavidCarlisle documentation is the root of all evil. :)
 
@PauloCereda that's why I build this every day:
find . -name \*.html | wc -l
13757
 
@DavidCarlisle ooh
@DavidCarlisle I read the docs and there seems to be no preprocessing, so the YAML is probably unmarshalled as it is.
 
@PauloCereda I'll look again tomorrow probably too late to think about it now
 
9:44 PM
@DavidCarlisle no worries :)
 

« first day (3279 days earlier)      last day (49 days later) »