« first day (2227 days earlier)      last day (2723 days later) » 

8:50 AM
@cfr Surprisingly, they are defined by tikz (in tex/generic/pgf/frontendlayer/tikz/tikz.code.tex) using the \alt macro of beamer without declaring any dependency for beamer (seems wrong somehow).
Also means that its apparently not possible to customize the behavior, since \alt ist hardcoded in there.
It somehow would make a lot more sense if the overlay aware path macros would be defined by a separate tikzlibrary that required beamer. And you should be able to control their behavior with something similar to \setbeamercovered.
At the moment you can actually use \node<1>{} in any document using tikz and it will somewhat surprisingly result in an error about the undefined control sequence \alt.
9:08 AM
@Maeher How odd
@Maeher I guess comes from the fact Till originally wrote both pieces of code 'together' (or at least the beamer/pgf bits: beamer doesn't load TikZ)
9:21 AM
@Maeher Reprot to the TikZ maintainers, I guess
9:54 AM
@JosephWright get the beamer maintainers to offer to maintain tikz as well, to keep things in sync?
10:12 AM
@JosephWright I suppose I should make latexrelease load luaotfload when moving the date forwards, so I need to put the everyjob code into latexrelease with some suitable guards :(
10:42 AM
@JosephWright I guess I should. Though looking at the open issues from 2013 in their bugtracker, I'm not exactly confident that it will be addressed. ;)
3 hours later…
1:43 PM
@Maeher TikZ is trying to be beamer compatible. Not the other way around.
Since beamer is not changing (in the eyes of old pre-Joseph Wright development team) you only need overlay awareness.
@percusse Certainly not changing much even now (small steps where they are safe/sensible)
\node<1>{} is syntax error for any TikZ code sans-beamer anyhow. But you can alter what \alt does to hack in.
@JosephWright I'm sure there will come a time when you will say, you know what? I can convert this spagetti into L3keys beauty.
so when do we see l3ynote package on CTAN ?
@percusse There are about 8k lines; certainly a rewrite is tempting, but I feel far too risky (also I'm busy enough)
@percusse There's the whole style sheets business to solve for that
@JosephWright Ah yes.
@percusse Sure, it's just not the syntax error I would be expecting. I'm not certain what the best solution would be, but defining macros using another package without making sure its available seems wrong to me.
But I don't really care that much.
What I really wanted was to modify the behavior of overlay aware tikz nodes. Because the current behavior is suboptimal for my use case.
1:51 PM
@Maeher Why not ? Don't you enjoy slowly revealing TikZ pictures in your presentation?
Turns out that's not possible at the moment.
yes, in fact I do
What is your use case that doesn't fit?
you can't do that well at the moment, because a node that is not currently on the slide simply does not exist. That causes a lot of problems. The picture changes size, so I have to take care that it does not jump around. I cannot use relative positioning anymore, because the nodes suddenly don't exist.
@JosephWright I'm sure you are relieved to know where that 0.00002pt came from.
@DavidCarlisle Indeed
1:54 PM
@Maeher That's a different problem about frames jumping around right?
no, not really
I can get the result I want by putting \visible<> around my nodes
and I would like to be able to configure tikz/beamer to behave that way with the overlay aware path commands
So if I understand correctly, you refer in the current slide to a node that becomes visible in the later slides. Is that about right?
I want all nodes to always exist just not be visible
that happens quite often
That's by design of beamer. Not a TikZ problem. If you make things overlay-aware. Beamer reads only the stuff that are defined at that slide. And makes multiple copies by advancing the slide number
hm, I think you are misunderstanding
1:58 PM
possible. But I feel that you want to hack beamer not TikZ.
well, not exactly. The problem is the definition of the overlay aware node command. I will have to replace them.
With what for example?
\node (a) {a};
\node<3->[left=of a] (b) {b};
\node<2->[left=of b] {c};
This should work in my opinion, but does not
because b is undefined when c is placed for the first time
Are you familiar with overlayarea?
This is exactly why they have been invented
not in detail, how would it help with the fact that the node is undefined?
maybe I'm misunderstanding what it's for
2:09 PM
@Maeher That won't help with the undefined behavior. But if you change the order of definition and dependency you won't get any jumpy behavior and the graphics will stay the same.
You have to do that when designing the figure anyways. A burden on the user unfortunately. I would kill for that feature too but it's not there. I wasted a good chunk of time for my phd defense presentation for similar stuff.
But again, I would have wasted that time on other things anyways in the name of procrastination
To me that seems like a (suboptimal due to harcoded sizes of the overlayarea) workaround for a design flaw :)
That's not a design flaw in my opinion you look for a unicorn :)
You can define dummy nodes in the beginning of the picture and draw on top of them later for example.
Well, not really, I have found out how to fix it to behave like i want it to by now
it's a single line actually
it's just that it messes with internal definitions of tikz
So if you don't want the visible part what do you do redefine it ?
that line I just wrote is the redefinition
the original line is
2:16 PM
Yes, but if I want to go back to \alt behavior what do I need to do ? Reredefine it ?
Well, that's more complicated, yes :)
In my opinion, it would make sense to make this configurable with a command like \setbeamercoveredtikznodes{invisible} or something like that
Note that your solution is actually processing the nodes at each slide. But only switching it's visibility.
So from bounding box calculation to other details you are actually altering the definition of the picture.
\alt on the other hand completely ignores the code itself as if it is not there.
that's kind of the point :)
I'm not suggesting that only switching visibilty is a solution to a problem, I'm saying I want to have the ability to choose which behavior I want.
Well, I wouldn't really want that but you can make your definition a bit more flexible
Then you can you use with visible or alt
Maybe I'm the only person in the world who wants invisible nodes, I don't know.
2:25 PM
Well you are one too many to ignore that feature :)
@Maeher despite the fact that the thing you are redefining is defined in tikz, looks more of a beamer feature request than a tikz one
I was just checking how other covered settings are done in beamer so I could maybe write a short package that (consistently with other beamer settings) adds this feature by redefining the internal tikz command.
I think you just don't like typing the extra \visible stuff.
yes, that's pretty much it :)
Ooh soon you will feel the wrath of emacs and vim knights ...
I have defined shortcuts for that on texniccenter. So that's for me the psychological limit in terms of keyboard wizardry.
2:31 PM
It just also seems inconsistent with other overlay stuff in beamer. I mean, the standard overlay for lists and stuff is not \only... they always take up space :)
@Maeher No. The blocks also take space as they appear.
That's why you need \begin{frame}[T] to align them etc.
@DavidCarlisle ^^^^ You have really strange colleagues I have to say. I have to parse the syntax of ?SYTRF of LAPACK. I have been unpacking that packed output since last 3 days :)
@percusse in python?
@percusse I guess I do not use blocks very often, at least not (dis)appearing ones
@DavidCarlisle Yep. I know that output is intended for use with ?SYSV, ?SYTRI but still that's quite some clever way of storing output heh.
@Maeher Yeah. Being a package author is really difficult. You have consider everyone.
Well almost everyone
@DavidCarlisle This is just one of the sanitizers it goes on and on :) Hopefully I'll dump it to SciPy repository and never look at it again
@percusse For me blocks seems to take up space whether they are visible or not
^^^ the a jumps between the first and second slide, not between the second and third
2:50 PM
@percusse at some point I should contact you offline about python interfaces....
3:24 PM
Strange question: I have a truetype font that only contains four chars. (1) how do I figure out which slots in the font these char are, (2) how do I then ask for these specific slots in a doc? Currently testing using xelatex (the font contains four logos)
@egreg slowcoach:-)
@daleif if you know the glyph names you can access them by name and don't need to know the numbers at all
@daleif At they in the PUA? (So 'anything goes')
@daleif otfinfo -g NAME.ttf shows the glyph names also in TrueType fonts.
@egreg seems like referendums are a dangerous game to play not just for British governments?
@egreg uniF030 through uniF033
what is the interface for accessing the glyf (can this work on pdflatex as well, going to truetype means I'm loosing latex+dvips users in my application, no big deal, but loosing pdflatex users is something I'd rather not)
3:32 PM
@daleif so if you know that you know the answer to your question in this case?
@DavidCarlisle I still don't know how to access a glyf by name
@daleif well by number you could just use \char"F030 but for pdftex you must have remapped the font to some 0-256 range so it's wherever you mapped it, by name in xetex you use...
@DavidCarlisle Ok, for a xelatex test I could just use \XeTeXglyph\XeTeXglyphindex"uniF030"
@daleif yes that (was just checking the syntax:-)
@DavidCarlisle interesting, the \Xe... works in xelatex, `\char"F030" does not (should it work in xelatex?)
3:38 PM
@daleif \symbol{"F030}
@daleif well assuming that the glyph called uniF030 is encoded in slot hex F030 yes (do you get a missing character warning in the log?)
@egreg nope (still testing through xelatex), guess it is non-standard
@DavidCarlisle no errors, just a box in the PDF
$ otfinfo -g AULogoReg.ttf
@daleif So the font has strange names that don't correspond to the slot.
@daleif doesn't that mean they are encoded in slots 2,3,4,5 so \char2
@DavidCarlisle nope. If I open it in fontforge it says 258 (0x102) through 261 (0x105)
BTW: is is complaining about missing chars in the log, just not the console log. Will look again tomorrow.
3:46 PM
@daleif Something like this might give you the numbers

\advance\count255 1
\iffontchar\test\count255 \the\count255={\test\char\count255}\endgraf\fi

@daleif yes that's the tex way
@daleif oh ok but not hex F030 though in anycase:-) so \char258 should work
4:14 PM
Persuant to this question tex.stackexchange.com/questions/342494/… I want to see if XeLaTeX would make things easier for me but dont have much of a clue how all this fits together so have a few small question to get things set up
I am using Doxygen that produces LaTex output, currently I use MiKTex to ccompile
Google tells me MiKTeX supports XeLaTex
@Toby I added a possible way for getting automatically the names.
So is it possible to alter the Doxygen LaTeX output such that MiKTeX h"handles" it with XeLaTeX? or is XeLaTeX much different ?
Thanks @egreg
(Im currently operating under the idea that XeLaTeX is just another variation of Tex, like LaTeX is...)
@Toby On the other hand, if a symbol is not in amssymb, you're again with the problem of finding a suitable font supporting it.
I guess the thing was I looking for a way to reduce the amount of TeX script in my documentation comments. As it is the comments are easy to read in source AND in PDF, with lots of TeX script in there it makes it harder to read in the cource, without it the PDF won't compile >.<
@Toby If we assume reasonably common maths symbols, they will be available in the AMS fonts
4:24 PM
@Toby XeTeX is like TeX, XeLaTeX is like LaTeX: yes, we know this is not straight-forward!
LOL, thanks @JosephWright my TeX foo is very very small ATM
@Toby We've got something explaining it, but in a nutshell XeLaTeX allows you to use all of Unicode with TeX. You still need a font with the right symbols though ...
And XeLaTeX is like LaTex, but would LaTeX compile with a XeLaTex compiler?
@Toby Practically, you run xelatex instead of latex
4:28 PM
Hm, OK - ATM I don't really "run" latex, Doxygen produces a bunch of tex files and whatnot and I run the make.bat (Im on windows) it also outputs...
Ill check what's inside that now
@Toby 'Like' as in 'you can treat as identical other than in certain specific places'
@Toby Presumably somewhere there's a setting that says latex or perhaps pdflatex
OK so the bat is about 30 lines, with a few pdflatex calls. Guess Ill try replacing them with xelatex and see what happens! :-)
4:54 PM
Think Im slowly getting there with it, when compile it says it cant find xetex-def though, and that I have the wrong DVI mode. I googled on the former issue and found, from some pretty old posts that xetex-def is not used any more so I used graphics-def. Now it still complains about it but carrys on anyway. Hunting for info on DVI mode now (currently ps2PDF)
Hm no luck unfortunately, the Doxygen LaTeX requires too much modification
5:11 PM
Hi to all.
Dear @egreg excuse me lot lot for saturday night. Unfortunately I have a bad internet connection and often falls on the network. Excuse me again also because I have written in Italian language.
I will write soon. Goodbye and have a nice day. I hope that his day yesterday went well. With estimates. Sebastiano.
Regards to all.
5:48 PM
Is there something like a \let for lengths? For example, I would like to do \setlength{\textwidth}{\textheight} and have \textwidth get updated whenever \textheight gets changed, but I would still like to be able to do \setlength{\textwidth}{4in} to break the link between the two.
@StrongBad That's not how \let works ...
@JosephWright you are right. I guess it is closer to how \def works. Is there a way to do it?
@Sebastiano Quite well, thanks. 653 voters showed up, about 80%
3 hours later…
8:27 PM
@StrongBad it's not really how def works either (it's just weird:-)
@StrongBad you could do \textwdith=\textheight or \def\textwidth{\textheight} or \let\textwidth\textheight which all have some effect but none of them have the effect that you said. You really want to use grouping to "break the link"
9:03 PM
Question: anyone know what this error message means? ! Argument of \@xfloat has an extra }.
<inserted text>
l.400 \begin{figure}[h]
I'm guessing the RSC packages have done something dumb....
@StrongBad Looking.
This is why LaTeX should suppresses some of this pointless font stuff; there are hundreds of lines of it preventing me from finding what is actually wrong.
9:20 PM
@Canageek usually it means the class hasn't been updated for a change I made in 1993 to \@xfloat to support colour.
@DavidCarlisle: missed me? :)
@PauloCereda no, who are you?
@DavidCarlisle some duck. :)
@PauloCereda dinner!
@DavidCarlisle oh no
9:23 PM
@Canageek do you load color (or xcolor) ?
@DavidCarlisle Yeah, the template does. \usepackage[usenames,dvipsnames]{xcolor}
@Canageek I had to add an extra \color@vbox to \@xfloat and ` \color@endbox` to \@endfloatbox to keep colours in the float, these are \relax unlesss colour is loaded when they are an extra group, so if a class redefines \@xfloat but not \@endfloat and bases it on a latex2.09 definition from 1985 you get mis-matched {} when you load colour. that was perhaps the major incompatibility between latex2e and 2.09, but doesn't come up so often these days....
@Canageek is the class available? i could have a quick look...
@DavidCarlisle It is the template from here: rsc.org/globalassets/05-journals-books-databases/…
@Canageek dare I look? :-)
@DavidCarlisle But I've commented out mhchem, times,mathptmx
@DavidCarlisle Apparently it is a copy of @JosephWright's work
@DavidCarlisle But it is the template that loads xcolor, so it probably isn't broken by default, probably something I've done
9:36 PM
@Canageek well I'd blame him even if it wasn't, being as it's Chemistry.
@Canageek i was just going to say same, I had to fake a widetext.sty but template loads color and has a figure so...
Oh, that is in the packages folder
Removing the comments
%% Package required for equal height while in 2 columns format
\typeout{Package widetext error: Install the flushend package which is
a part of sttools bundle. Available from CTAN.}

%% Package required for onecolumn and twocolumn to exist on the same page.
%% and also required for widetext environment.
@Canageek didn't matter I just made a one line file that did \newenvironment{widetext}{\par}{\par}
@Canageek my version is simpler:-)
@Canageek well I'll look if you can tell me what to change to make it break:-)
@StrongBad You can define a property list for lengths linked to a particular one

  \tl_set:Nx \l_strongbad_dependent_length_tl { \cs_to_str:N #1 }
  \prop_new:c { g_strongbad_dependent_ \l_strongbad_dependent_length_tl _prop }
  \keys_set:nn { strongbad/dependent } { #2 }

\keys_define:nn { strongbad/dependent }
  unknown .code:n =
   \prop_gput:cVn { g_strongbad_dependent_ \l_strongbad_dependent_length_tl _prop } \l_keys_key_tl { #1 }

So far I can't break it copying more and more of my document into it
9:56 PM
@Canageek see perhaps I fixed it:-)
@DavidCarlisle But my document does not work at all yet
@Canageek well there is always the direct user error possibility \begin{figure} ... { \end{figure}
@DavidCarlisle Checked that. Easy as both are highlighted in red
@Canageek well you or a package has got a mismatched brace in a float such as figure, other than that I can't really say!
@DavidCarlisle I'm going through with a machete now
"Is this 100% needed to compile? No? Delete"
10:08 PM
@Canageek good thing is we can blame @JosephWright for the time it's costing you.
10:20 PM
Found the code block that breaks it
There is an unmatched \twocolumn[ somewhere
@Canageek or any optional argument inside the [] of \twocolumn since latex doesn't match [..] use \twocolumn[{....}] to make nested [] safe
@DavidCarlisle No, as in, when I was copying text in, I missed the end of that environment.
I really think helpful error messages would be a big boon to LaTeX
People would lynch the GCC people if they gave this cryptic feedback...
@Canageek Not exactly what I meant: the 'print like' stuff is their own!
@JosephWright Print like?
@Canageek don't compare tex to gcc compare it to the C pre-processor, make 1000 lines of nested #define and see how clear the error messages are if you get one wrong.
10:32 PM
@DavidCarlisle Yeah, but normal humans have to use LaTeX
Not programming demigods ;)
@Canageek The bits that I recognise are more about the 'advice' side of things (cf. achemso, where there is advice but not really an attempt to look like the printed journal)
@Canageek well they shouldn't be using a macro processor if they want high level diagnostic output.
@JosephWright Ah, OK
@DavidCarlisle Is there a way to get high level diagnostic output?
@Canageek yes write a typesetting system in a compiled language and using a modern scripted customisation layer rather than a 1970's text macro expansion paradigm......
10:50 PM
Now I just need to figure out why my text runs off the bottom of the page, on every single page
11:01 PM
mhchem? Disabling mhchem was the problem?
@Canageek not done any chemistry since 1979, so not a package I've used much :-)
@DavidCarlisle Lets just say it isn't normally used for layout to my knowledge, so I was rather surprised when turning it back on fixed a page layout issue.
11:18 PM
@barbarabeeton :
looks like a bug to me, you could report it to stix.. — David Carlisle 1 min ago
@DavidCarlisle -- yup. thanks. there's also the bug with the slashed zero. i've been told to post that to the sourceforge issue tracker. which i will do as soon as i can find my password.
Last thing I need to figure out: what the heck is wrong with this table
If I use table* then it looks even worse then this.
@Canageek it's over-full by two columns, but hard to say just from the output
11:43 PM
@Maeher How odd. [I realise this was already said, but it bears repeating.]
Decided to take the easy route and split it into two tables
Then it decided to insert a ton of space before the final column and I don't know why
@Canageek tabular* ?
@DavidCarlisle Yes.
@Canageek so presumably that was the only place where you have glue added (\extracolsep` aka \tabskip)
@DavidCarlisle Probably, but I wouldn't count on it due to template
@DavidCarlisle I don't use that deliberately anywhere.
At least before the spacing was even
11:52 PM
@Canageek using tabular* without adding \extracolsep is basically an error it specifies the table should stretch while giving it no possibility to do so
@DavidCarlisle Ok, where do I put it?
@Canageek usual form is {@{\extracolsep{\fill}}ccccc@{}}
So like \begin{tabular*}{\textwidth}{@{\extracolsep{\fill}}l*{5}{c}@{}}
@Canageek yep
@DavidCarlisle That didn't change anything
11:55 PM
@Canageek but if those lines are \hline then the table is overfull so tabular* won't do any stretching
@Canageek as I was writing:-)
@DavidCarlisle OK, so one less column or use \small
@DavidCarlisle My Phoenician may be rusty, but the alphabet is easy to remember.
@Canageek something like that
@egreg :-)
@DavidCarlisle Got it! Was the \multicolumn I had at the bottom; was too long and stretching things

« first day (2227 days earlier)      last day (2723 days later) »