« first day (1886 days earlier)      last day (812 days later) » 

 
1 hour later…
7:18 AM
sed -r '/Numix/,$ s|^"([0-9]+)","(.*)"\r|https://askubuntu.com/questions/\1\t\2|' file.csv
expression I used to clean the query this time ^
but I am stupid, I had to delete the lines before Numix when I imported the sheet, because I forgot to use -n
(first question we haven't made a card for is "Numix Circle does not work on blahblahblah". There aren't any other questions that mention it in the query atm)
 
7:55 AM
the Trello scrum backlog sheet is misbehaving o.O
I can't paste anything into it
 
8:41 AM
I can't paste anything into any Google Sheet
gah! Any ideas?
 
9:57 AM
sed -rn '/Numix/,$ s/(.*)\t(.*)/\tTo be reviewed\t\2\t\1/p' old.csv > new.csv
I did this ^ then I imported it into the sheet using the "replace data at selected cell" option
thus bypassing the copy & paste problem
but the script will only upload about 25 things at a time so I'll have to stop it from trying to upload them all by putting some blocking text in the first column
(sorry readers, I just document this stuff in case it helps me or someone else figure out how to do it next time)
\o/ it's working
 
oops, I thought this was about the movie :P
 
lol
 
Well it is, if you mean the movie Raiders of the Lost Downboat that will be made about the adventures of reviewing and site cleanup on Ask Ubuntu!
 
I can't wait
The young crowd have been hitting the CV queue (and @edwinksl has been reviewing everything I see) so it's gone down to a reasonable level again, so maybe it's a good time to start work on a new batch :)
 
10:55 AM
OK done, we have exactly 250 shiny new cards in To Be Reviewed
the last card is #2501 (sorry I broke the numbering somewhere with my inept tinkering)
 
o.O
it's like bad bash satire
 
Unfortunately, not everything that should be satire is.
 
11:27 AM
But speaking of satire, I fear a few of my own old posts may be bad APT satire and I'm not sure how best to search for them. There are a lot of posts on the site that recommend using * after the install, remove, or purge action in apt-get or apt, as though the argument were a glob. But it's not interpreted as a globbing character, it's interpreted as a regular expression metacharacter.
Most of the posts providing such wrong advice are not my posts but I remember learning that APT uses regexes after coming to this site and I think some of them may be mine. I've been commenting, voting, and as appropriate (which is more rarely, in this case) editing some of these posts lately. So I should certainly be fixing my own! How do I find them?
 
you could try this search and use the "newest" filter?
I really need to read to understand this better. I am not sure exactly how APT uses regex. I've been thinking that it interprets the expression with some intelligence, checking various ways it can match. Where's the best place to read about this?
 
11:44 AM
@Zanna Thanks. I was hoping there was a way to search for apt-getfollowed by arbitrary characters followed by (mainly) remove or purge followed by one or more spaces followed by [A-Za-z0-9._:=-]+ (roughly speaking) followed either by * or \*.
That's really approximate. I do not intend it as "this exactly!" Also I should learn how to write proper SQL queries and match with regular expressions in them.
 
haha I know what you mean
I don't know how to use regex in SQL either :S
 
Are there books for people who know programming and non-database-related system administration but not SQL? Setting up, administering, populating, and querying databases is an area I want to know way more about.
Some posts that advise to do things like purgeing wine* have been repeatedly upvoted even though they're quite dangerous. I'm afraid that some of my own posts are like this... and also I'm afraid they may have been quoted or derived from in other people's posts.
 
12:38 PM
@Zanna you think i should answer it? ;)
 
@EliahKagan haha!
@edwinksl yes I think you should answer it. I think it's very helpful information
 
heh alright
 
I didn't realise myself how additional python versions would be handled
if you answer it, it might even prevent some people from purging (or fiddling with the symlinks of) existing versions of python 2 and 3 so they can call the shiny new version without them having to type two measly extra characters...
 
@edwinksl I agree that you should post an answer. As you say, they should just run python3.6. python3 runs the version of Python 3 that is known to work properly for parts of the system that rely on python3, which is a lot of stuff. (If for some reason they need python3 to point to that version I think they can have a conda-managed virtual environment that does that, but I don't think they will most likely want that or that you need to mention that in an answer.)
 
@EliahKagan I love this data science-y query writing stuff. I would love to find some nice resources about it
 
12:52 PM
There are some handy sites to practice querying databases, like HackerRank. And that's one way to think of the Stack Exchange Data Explorer--the announcement even said:
> The ultimate goal of all of our sites is learning, and making the Internet a slightly better place. I believe the SEDE achieves both of these goals in a rather serendipitous way — it helps us teach SQL and relational databases by querying the very posts we’re creating as we teach! Yes, maybe it’s a little geeky, but it is magical to me.
(Sorry about the delay there. I'm not a big fan of how Firefox randomly locks up for 10-20 seconds at a time. This happens to me on Ubuntu, Windows, and Android, and it doesn't happen with Chromium or Chrome. Maybe it's related to some add-on I'm using.)
...But I don't really know of any good resources for learning SQL properly.
 
I was unpacking groceries anyway haha
It's possible to learn things by seeing what other folks have done of course
but the documentation is... spare
thanks @edwinksl :)
I am annoyed with FF today because I suspect it's to blame from my GDrive pasting issue. Probably a security feature of some kind. But maybe Google are doing something they shouldn't be
 
@Zanna That's a useful, even indispensable way of learning. And I'm not convinced the "Read this book all the way through and work all the exercises in order, that's the one true way to learn {some-technology}" advice that is widely passed around is really helping people that much. (Related.)
On the other hand... seeing existing code and messing with it until it works is also how many people learn shell scripting... and then often write horrible dangerous shell scripts. Although, I suspect the main problem is not the "huh, let's see if that does it... yeah!" approach, but instead the problem that the shell scripts people are often looking at as examples of correct code are themselves horribly wrong.
 
I find it very hard to learn things just by reading, I am very slow like that. I need to try it and have a goal. But yeah, when you base your stuff on someone else's without any background knowledge, you reproduce their mistakes until something goes wrong, and then you have to painfully figure out why...
 
1:09 PM
I kinda wish Ask Ubuntu automatically performed static analysis on shell scripts as they are entered in the visual editor and showed the author/editor the suggestions. Probably it's not practical, though, because people might follow the recommendations without understanding them, removing some errors but adding others.
(Also that particular static analyzer is GPL 3.0 and probably cannot be integrated into either server-side code or client-side JavaScript on Stack Exchange, since Stack Exchange's code is proprietary and thus GPL-incompatible. I haven't looked into the specific licensing issues that pertain here though and I'm not a lawyer so this is just a guess.)
We could maybe add a Clippy icon, though. "It looks like you're writing a badly broken shell script..."
 
hahaha
commenters usually do a good job
 
They do... but sometimes posts languish for many months before anyone comments on them. (Like that post.)
 
but only if the post gets seen. If nobody edits it to have the right tags (instead of or something) the gurus might never find the terrible things
:S that's why I get frustrated by the First Posts and Late Answers reviewers not doing anything
7 deleted posts, ouch
 
I think part of the problem is that the review process often cannot easily catch such mistakes here on Ask Ubuntu. More than on Unix.SE, many reviewers here don't know the ins and outs of shell usage because, although it's still a central topic in Ubuntu (and would be involved in solving problems even if it weren't--for example, bash is a very useful tool in BeOS and Haiku even though they're not Unix-like OSes)...
...people can be very experienced Ubuntu users with lots of really valuable knowledge, numerous rightly upvoted answers, and so forth, without knowing or coming in contact with the shell all that much.
Still, the problem would be much less severe if more reviewers clicked Skip instead of No Action Needed for posts where they didn't know if editing, voting, or commenting were needed but weren't actually particularly sure.
@Zanna Oh, on that question, yeah.
The other thing is that there are plenty of books published by reputable technical publishers, including some that receive high praise from knowledgeable readers for some of their virtues, that are badly and dangerously wrong about simple things every novice has to learn.
 
1:25 PM
I didn't realise that
 
I've seen the claim that \n is translated to a newline by printf and is a substitution like %s, in C books. (It isn't. \n is part of the syntax of string and character literals and is in no way specific to the format strings passed to the printf and scanf families of library functions.)
 
So do I.
 
but I used to skip a lot more. Maybe I am learning :)
or maybe I am being more lax hahaha
 
I skip more now than I used to.
 
1:26 PM
At the beginning, I didn't skip enough
 
So in LiveCDCustomization, there are some instructions that say things like "in 9.10" but actually mean things like "after 9.04." (For others seeing/participating in this conversation, this relates to that earlier topic.)
 
some editing needed :S
 
In the Apt section, it says we must use:
dbus-uuidgen > /var/lib/dbus/machine-id
And also that we must use:
dpkg-divert --local --rename --add /sbin/initctl
ln -s /bin/true /sbin/initctl
I think the first one is still needed. The second on is specific to Upstart, and is still needed on 14.04 LTS but not any other currently supported releases. I don't know if there's anything else that needs to be done for systemd here, though.
 
:/
I have no idea
 
I'll let you know whether or not stuff seems to work on an image I make by following what I imagine to be the correct interpretation of those instructions for new releases. :)
 
1:38 PM
great!
Speaking of highly upvoted problematic answers, I don't feel good about duping things to this... I wonder if there's a better way to reliably solve that problem
 
@Zanna Indeed--that answer doesn't seem like a reasonable solution for most situations where that error occurs!
 
I'm surprised that does work... I should try it on my newly installed 16.04 system, because the first thing that happened when I tried to run my initial global package upgrade was that I got the appstreamcli error. It looked horrible; I thought it was a kernel panic for a second
 
@Zanna If the two top-voted answers there actually contained warnings explaining the potential problem then I would see them as much more appropriate.
 
I just removed libappstream3, I didn't try installing it
@EliahKagan yeah, like that one
 
Yes. That answer has my upvote. It should only very rarely be used, but it makes the problem clear.
So regarding that question, we do have this other question. It has answers--including the currently top-voted answer--that are really sketchy too, but I like this answer (written by, and linked to from, this other answer by the same author).
I don't know if there's anything to be done here but upvote the better answers. Maybe bounties. I guess really what's needed is an explanation of what can go wrong inside the dangerous answers, but that might be considered a radical change to the answer. I don't know if this would be considered a sufficiently dangerous case where editing in a prominent warning/explanation anyway would be accepted. Personally I would not oppose such edits.
 
2:05 PM
that's a very nice answer by Avinash Raj
 
Yes.
 
I would support editing a warning into those answers
 
 
2 hours later…
3:40 PM
Is this post an attempt to answer the specific question that was asked there? I cannot tell.
 
well, I don't think I would be satisfied to hear that I could use two-finger tap instead of right click if right click stopped working for me. I would want my right-click to be fixed. Especially if I wasn't using a laptop or its multi-touch functions weren't supported yet...
 
Does it even work at all, when right-clicking is broken as described in the question?
I think if it works at all then we should not delete the answer--workarounds are valid contributions--but if it doesn't actually address the situation in the question, then we could remove it.
Someone posted to criticize the answer but unfortunately the only insulted its author instead of actually saying what was wrong with it. (That's the answer deleted as rude or abusive.)
 
hmm do you think the question is clear enough to tell? I voted to close the question as too broad, but I don't know how to find out the reason why right click is broken
 
I guess it's not really clear enough to tell. What information can we request from the OP to help make it clearer? I've just cast the final too broad close vote but I still hope we can meaningfully say what information to include if they either (a) split it into multiple questions or (b) explain why the two questions are tightly related enough to really be one question.
 
Yeah exactly, I feel bad voting to close as unclear or too broad when I don't know how to advise OP on how to improve, especially when they've clearly made efforts to include what they can
 
4:19 PM
oh hmm I can't ping guntbert
I was going to ask if he agrees with my edit since he reviewed the card
I'll ping him on the card
 
 
2 hours later…
6:01 PM
I guess he thinks it's not a worthwhile question
 
6:33 PM
@Zanna Or maybe hasn't gotten around to it. I still haven't gotten around to writing and posting an answer with a more detailed version of this comment:
The part of this question that interests me most is why "running echo $ returns $"--that is, why is $ by itself is treated literally, rather than being considered a bad substitution like ${}? ($ by itself can't be expanded, and is treated literally; ${} can't be expanded, and is an error.) If this is reopened, perhaps additional answers will be posted to explain that. I can sort of address this--$x is actually a short form of ${x} where x is a valid parameter name--but I suspect others might be able to explain it from a more historical, formal, or practical perspective. — Eliah Kagan Aug 8 at 5:44
Although I think even if muru were to post the exact text of that comment as an answer that it would be good and I would upvote it.
 
I would too. But I think muru would post a very good answer explaining it properly as usual
 
Indeed. This is one of the reasons I am reluctant to post my own answer there. I suspect it would not be as good.
 
Hopefully you are right. I always check back on my comments later (I mean I check at least one final time about 3 months later. I also usually check them after a few hours and a few days, but sometimes I forget)
haha I know muru likes your answers
the first or second time I ever came into AUGR muru said something about reading an answer of yours and that you always wrote great book-like answers
 
Cool!
 
haha if muru said something good about an answer of mine I would be really happy. If I ever suspect I got a muru-upvote I feel good XD
I love that the command to make the shell say something is echo. So poetic XD
 
6:45 PM
Hi @Zanna how you been recently? :)
 
Hi @AndroidDev :) Always nice to see you. Hope all's well with you. Actually I have been a little bit sad and stressed out for various silly reasons. But I am ok :)
I'm still in the HueToYou room btw, I've pinned the tab
 
Sorry to hear that :\
I'm doing pretty well all things considered
 
I actually uninstalled Android Studio because I had a disk usage issue when trying to write a custom ISO
My SSD only has 32GB
 
O_o
32GB?
how is that enough for anything?
 
But I've got a new old laptop from my dad with, I think, 4GB RAM and plenty of disk space, so I can install on there instead
 
6:50 PM
Hmm you know you can get some sweet deals on used/refurbs on Ebay
You can get a Dell Latitude with a 3rd Gen i7, Nvidia Quadro graphics, 8GB of RAM and a 1080p display for < $300
 
@AndroidDev it's enough for my playground but it's a bit tight for storing anything other than text files
hmm well what I have is OK for me, but next time I need a new laptop, I'll remember your advice!
@AndroidDev no worries :) it will come good :)
@AndroidDev hmm good to hear that
 
@Zanna HTY is sorta dormant ATM because Nathan is swamped with work so can can't recover the cookie jar, and I started converting Zach's spaghetti mess of storing info to an SQlite database, but I was having a really hard time trying to figure out what the heck he was doing in some places (with no comments to help :) and so I dropped it for a while... I should probably have a look at it again with a fresh mind
 
hahaha sounds like a tricky task
 
Yeah because the code he wrote isn't even centralized at all!
It's all over the place
in different files
 
6:55 PM
He criticized me for wanting to move everything into it's own class, and while that does make for a lot of classes, at least you know where the stuff is!
@Zanna LOL!
@Zanna Did you ever convince your brother he needs to come and help us with it? :D
In other news, I've broken 9k
And 10k in chat
 
oh oops I think I forgot to mention it to him! Apparently the startup he's working for is having cashflow issues and he's been doing a lot of freelance work, so I'm not sure he has any free time :/
@AndroidDev congratulations ^_^
soon be hitting 10k
 
You know, the problem with Zach redoing your avatar with blue hair is that now the lipstick clashes with your hair IMHO
:D
 
@AndroidDev if you don't know where your stuff is, you may as well not have the stuff at all...
 
ikr?
In fact....
his own app (SystemUI Tuner) got so messy
that he started over from scratch!
gulp
Kaz docked him a star in his review for messy code :D
 
@AndroidDev you're right, and it's inaccurate now because my hair is basically white right now. I wanted to dye it purple, but I'm living with my mum and she keeps telling me to keep it the way it is. She also wants me to grow my hair long etc, so I'm sort of holding off on the purple temporarily since there's no way I'm compromising on anything else
@AndroidDev ouch!
so Zach should make me one with white hair (or I should do it, but it might amuse him...)
 
7:06 PM
Hmm but I'm not sure pure white would be very visible though
It would look like you're bald :D
 
oh I'll leave it with you guys then, I'm sure you'll come up with something XD
@AndroidDev haha XD
 
@Zanna Zach asked if he would revise it after he finishes the rewrite an Kaz was not committal :D
 
haha I am literally laughing out loud
 
@Zanna for the avatar, pure white or more yellow-white/cream?
 
yellow-white would work
even sort of light orange?
might be less clashy?
 
7:16 PM
hmm well just a quick & dirty swap;
You can still see bits of blue
later today I can make it cleaner if you like it
 
haha I like it! The grey background works well.
I can upload the original file somewhere if you want to use that
it's quite huge though
 
ok
as long as it's a format I can open :D
I can open PSDs and anything GIMP can open
so that's basically everything lol
 
here you go it was a png anyway
 
anything you would change while you're online so I know what to do later?
whoa that it massive
did you sketch it yourself?
 
oh I like it how it is, but I like that people want to play with it :D
Alas no, it was made for me by a charity that tries to help "disadvantaged" young folks get into the creative sector in the UK by mentoring... they asked everyone who signed up to be a mentor to send and photo and they produced a three colour image from it
(The red thing on my earring is actually green in real life for example - those earrings are pineapples)
 
7:47 PM
Seems quite answerable...
I am not giving enough time to learning Linux things these days
 
My guess is that the answer that has been posted is actually correct, and that the "low graphics" problem is not really the result of chmoding the contents of /dev.
 
that answer seemed reasonable to me
but I was too lazy to test it
 
8:02 PM
Of what?
 
Haha that's the more important question
something like how can I select which graphics card to use when playing a game
 
@Zanna agree
 
:)
 
@Zanna Well we do have an earlier question with an answer about how /dev comes back on reboot. I don't know how much testing is possible for the "low graphics" situation, without knowing more things specific to the new question's OP's situation.
 
I guess it is unclear at the moment then, if it wasn't solved by rebooting
 
8:10 PM
Well, I've requested information, but maybe there's something more than can go wrong with chmoding /dev that someone will be able to answer about. I'm not sure we should close it yet.
 
@EliahKagan nice Q & A :)
I upvoted your comment and I haven't voted to close the Q. I think it's an interesting and probably useful question
 
:facepalm:
 
8:42 PM
I'm thinking about asking a meta question about what to do with questions like this now that Ubuntu Touch is (going to be?) obsolete
hmm I'm going to do that now... If it's already been asked, people will know what to do haha
 
Well, I don't think Ubuntu Touch will ever be like Ubuntu One. It is still possible to use Ubuntu Touch, it will always be possible at least with old hardware, and other OSes that derive from Ubuntu Touch, such as UBPorts, will exist for which old information about Ubuntu Touch will continue to be useful.
My view is, there is nothing special about Ubuntu Touch questions--they will, eventually, once all official support for Ubuntu Touch ceases, be like questions about releases that have become EoL long after the questions were asked. If for some totally unrelated reason we are sure a question is totally valueless and it qualifies for closure then it can be closed and eventually deleted; the system will delete some questions automatically if they're not upvoted or answered or viewed; and that's it.
That's just my view though.
 
Yeah, it makes sense, I think it's the same kind of case as EOL versions
but people are closing as off topic
 
Already? Isn't Ubuntu Touch still supported?
 
I should say off topic #1 (not about Ubuntu)
 
I mean, people have Ubuntu phones, right? Isn't it just that there will be no new versions or feature updates? I don't actually know the official support status for sure.
Oh. Well that has never been the case. It's probably the right close reason for questions about UBPorts unless we decide to support it here (which seems unlikely!) but for actual Ubuntu Touch questions they should never be closed for that reason.
 
8:51 PM
I don't think they've been available to buy for a while but presumably yeah people still have them
 
For the "not about Ubuntu" sub-reason I mean.
 
@EliahKagan I agree... but 2 votes for that!
maybe we should eventually be voting to close them as no repro
the best option might just be to give some love to the canonical post about Ubuntu Touch support and make sure it's fully up to date
and... monitor the situation
if you don't think it's worth asking a question, I will listen to you... but I am not sure what I should be doing and I have a feeling other people don't know what to do either
 
The ones that are no repro, yes. But whether or not that is the case for a question is almost orthogonal to whether or not the question is about Ubuntu Touch.
I am not trying to discourage you from posting on meta about this. If you post on meta I will be interested to see and consider the ideas presented by you and anyone who answers.
The only reasons I can see not to ask on meta are (a) if you don't think it's actually a significant issue or (b) if you want to wait to see what happens so as to post a more complete meta question.
 
I am going to look for recent questions to see what was done with them, and if the findings are not interesting, I might leave it for now
 
So, I customized yesterday's Artful daily-live and booted the custom image in VMware.
 
9:06 PM
awesome...
 
Yesterday's official daily-live booted with both BIOS and EFI but my custom image booted only with BIOS -- VMware's EFI firmware did not see it.
I don't know if that means it wouldn't boot on physical UEFI systems but I suspect it does.
 
@EliahKagan BIOS > UEFI
IMO
 
This is not related to Secure Boot -- VMware Workstation and Player don't support that (it was a different VMware virtualization solution that did).
 
Hmm... why do you think that happened?
 
@AndroidDev I do not much like UEFI either. My goal with this is to figure out how current LiveCDCustomization is so that I can figure out if the various posts we have here based on it and parts of it need editing. (Hence my discussing it in this room.)
I believe we have a number of posts that draw, directly or indirectly, on parts of that Ubuntu wiki page, including for purposes other than ISO customization. For example, for chrooting into a different Ubuntu system, I think that page and versions of help.ubuntu.com/community/Grub2/Installing#via_ChRoot from whenever the posts were written are frequently used as the basis.
Specifically, the basis for what devices to mount, how to mount them, what order, what changes to make to get networking to work, and so forth. I've written some posts like this.
@Zanna I don't know. The changes I made were to upgrade all the installed packages and also install open-vm-tools-desktop. I fear I have missed a step, one that might not be listed on that page. But maybe it's a problem I would have with today's or tomorrow's daily-live and just related to the package upgrade.
I did not put a different kernel on the ISO and I'm not using the DKMS version of open-vm-tools.
 
9:18 PM
so difficult :/
 
Is it normal that Apport was disabled on my live ISO for Artful?
 
I think Apport usually works in a live session
 
I'm going to boot back to the official daily-live and see if I get the same problem.
 
9:43 PM
Yeah, apport isn't enabled.
Whoopsie is. Doesn't whoopsie need apport?
 
what does whoopsie do?
it doesn't say it depends on apport
Pre-Depends: sysvinit-utils (>= 2.88dsf-50)
Depends: libc6 (>= 2.14), libcurl3 (>= 7.16.2), libglib2.0-0 (>= 2.32), libwhoopsie0 (= 0.2.55.2), init-system-helpers (>= 1.18~), adduser
what is pre-depends? dependencies of earlier versions?
 
"Depends" means needs to run; "Pre-Depends" means needs to install.
10
Q: What is the difference between dependencies and pre-depends?

Bruno PereiraCan some one explain me what is meant by dependencies, pre-depends and the difference between those 2 type of package requirements when I am installing something in Ubuntu?

Hmm, does whoopsie not depend on apport in any release?
Whoopsie automatically reports crashes in stable releases behind the scenes, where the information is aggregated for statistical purposes (and I think devs might be able to see the details).
It needs apport to generate the crash dumps. Or so I thought.
5
A: How do I submit a full bug report with crash dump and steps to reproduce?

Eliah KaganA good way to report this is to configure Apport to send crash data to Launchpad. You can configure it back afterwards, if you don't generally want to do this when a program crashes. Background What you want is for Apport to collect crash data and submit it to Launchpad, so you can write and s...

 
@EliahKagan favourited, thanks :)
when you say it isn't enabled, how do you mean?
as a service?
 
10:00 PM
Yeah. The service is turned off. The package is installed and when I turn the service on it does work to automatically offer to report crashes.
 
afaik if a service is disabled it will still be started if any other service needs it
 
Regarding that answer of mine, crashdb.conf is different now (or will be different... I don't know when it changed) and doesn't have anything about problem_types: bazaar.launchpad.net/~apport-hackers/apport/trunk/view/head:/…
Well whoopsie apparently does not need it, since it's running but apport isn't.
 
I guess APT was telling the truth then
 
I should update that answer but I don't know how.
 
ugh frustrating
hmm deep in Ubuntu Touch research, I realise it's time to sleep. Later all \o
 
10:07 PM
Night!
I'll let you know what happens with the ISO customization if I make any more progress.
 
11:16 PM
This seems like it's trying to answer a different question: askubuntu.com/a/949862/22949
@edwinksl Normally if an update fixes things it would be possible to ask the OP to check what packages were upgraded and then an answer could be posted. In this case, though, it doesn't seem worth pursuing because just some websites not working is strange and suggested a temporary situation anyway. I suspect the update wasn't actually what fixed it. I've added my close vote.
 
yeah
 

« first day (1886 days earlier)      last day (812 days later) »