« first day (1096 days earlier)      last day (3021 days later) » 

12:02 AM
@slm no
I was thinking of an answer that explains all the difficulties of running a mail server on the internet, like coping with spam, with spam blacklists, with bounces, with loops, ...
it may have been on a different site, or even not on SE
 
slm
Really regretting answering this Q
http://unix.stackexchange.com/questions/94156/what-is-the-easiest-way-to-add-a-string-on-the-beginning-of-every-line-of-the-fi/94160?noredirect=1#comment142974_94160
must have a target on my back tonight, every ball buster is out giving me crap about Perl not being that ubiquitous.
@Gilles - I'll keep looking
it's probably on SF if I had to guess
 
slm
12:31 AM
@Gilles - coming up empty on the Mail server Q on U&L
 
> His computer pinged OpenDNS, so ask the computer about it
@slm it could happen with and DNS if it's chrome the culprit
any*
 
1:21 AM
0
A: Should i use $* or $@?

GillesShort answer: use "$@". The other forms are very rarely useful. "$@" is a rather strange syntax. It is replaced by all the positional parameters, as separate fields. If there are no positional parameters ($# is 0), then "$@" expands to nothing (not an empty string, but a list with 0 elements), i...

 
1:32 AM
@Gilles Great answer, very informative.
 
slm
1:45 AM
He is a bot..
 
told'ya
What do we do with this?
0
Q: Where do I get Chromium Firmware

freddydoggieI am looking for some boot-firmware for my chromium-book using the latest chromium build be hexxeh. When I start it up, I see a message that "Non-firmware boot took x number of seconds (x system, x kernel, x chrome). I am looking for firmware to increase the startup speed, because it takes about ...

 
@terdon Point him at lmgtfy.com?
 
@kurtm Yeah, I did kinda.
lmgtfy is frowned upon as being rude on SE
 
I kinda figured it would be. Even if he deserves it :)
 
151
Q: Ban LMGTFY (let me google that for you) links

John NolanI've just asked a question on Stack Overflow which was a prime candidate for googling. I admit it was a poor question and with a little bit of research I would have found the answer. It annoyed me that someone put a let-me-google-that-for-you link in the comments. It got right up my nose. I find...

I left a pointed comment, that should do
 
1:57 AM
Hopefully he isn't clue-impervious.
 
slm
2:13 AM
@terdon - some people just want confirmation, I think.
 
2:26 AM
@slm is my last paragraph correct here?
2
A: convert soft- to hardlinks with cp

terdonThe example in the info page shows you how though the example is a bit hard to follow: $ mkdir c; : > a; ln -s a b; cp -aH a b c; ls -i1 c 74161745 a 74161745 b Let's break that down into its component commands: mkdir c; : creates the directory c/ : > a; : just a quick way of creating an emp...

>Now as to how exactly it works, as far as I can figure out from playing around with it, cp --preserve=links combined with -L or -H will convert symbolic links to hard links if both the link and the target are being copied to the same directory.
 
slm
let me read the man pg, give me sec
 
You won't get much out of it. I think I've quoted all relevant sections of both info and man
 
slm
yeah it looks like that
what is cc2ter
 
oh, bugger, hang on
$ type cc2ter
cc2ter is aliased to `sed s/cchapple/terdon/g'
:)
I use cchapple on this laptop to facilitate logging in and accessing resources when I'm in the lab
Since my user name is terdon, I translate for my answers to avoid confusion
 
slm
figured as much
your description sounds right to me
showing off the : > a
it's the key to the fork bomb
 
2:36 AM
hah, yeah :)
That's where I first saw : actually
 
slm
17
Q: Where is the fork() on the fork bomb :(){ :|: & };:?

mavillanWarning: Running this command in most shells will result in a broken system that will need a forced shutdown to fix I understand the recursive function :(){ :|: & };: and what it does. But I don't know where is the fork system call. I'm not sure, but I suspect in the pipe |.

 
that or maybe while :; do ... ; done
@slm yes I remember that.
 
slm
i always forget about it but then it comes back up. It's popular for zeroing files out too
 
great thread
silly for an example in a man page though
needless obfuscation
 
slm
yeah it was rolling that night
 
2:38 AM
huh, I hadn't upvoted that one. Weird, it's a great answer.
I actually ran it :)
I had to see.
@slm it's not actually, in the fork, the colon is a function as you explain very nicely.
 
slm
@terdon - true it could just as easily been bob()
we have it written on a whiteboard at work, i was explaining to the co-workers how it works. it's so subtle b/c it looks like jibberish
 
This would work just as well wouldn't it?
:(){ : & };:
 
slm
don't think so b/c the :|: & forced the process to stay in use
: & will run and finish
god gilles really pulled this Q out of the toilet
37
A: Why is Linux's filesystem designed as a single directory tree?

GillesThis is partly for historical reasons, and partly because it makes more sense this way. Multics Multics was the first operating system to introduce the hierarchical file system as we know it today, with directories that can contain directories. Citing “A General-Purpose File System For Secondar...

it was one vote away from being closed
i didn't think it was worth hanging around here, seemed like a stupid Q
gilles A gave that guy 37 UV on the Q now
 
3:00 AM
I feel sorry for the guy...
 
@slm It was in the ho questions feed, that's why
@Braiam who was that?
 
:), 2 days straight at 200 rep, don't feel sorry for him.
 
I think he broke Jon Skeet most upvotes per answer record in a day
 
hardly
That's the best I've done
That's the accepted answer :) 300 see? Not bad!
 
 
11 hours later…
2:26 PM
I'm getting a mysql error
"sh-4.2$ mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)"
 
2:37 PM
@ThatBrazilianGuy is the mysql service running?
sudo service mysql status
 
Redirecting to /bin/systemctl status mysql.service
mysql.service
Loaded: error (Reason: No such file or directory)
Active: inactive (dead)
I have installed mysql via yum, but it installed mariadb for some reason
My situation is similar (but not identical) to this: unix.stackexchange.com/questions/63391/…
If I do create the /var/lib/mysql/mysql.sock file the number after the error message change to (111)
 
slm
@ThatBrazilianGuy - what's the distro?
 
Fedora 19
maybe I have created the /var/lib/mysql/mysql.sock with wrong permissions, I'm a bit clueless
 
slm
I know mariadb is a drop in for mysql and uses the names of paths still as mysql
so you may infact have mariadb installed only
how did you install mysql?
 
yum install mysql
 
slm
2:43 PM
$ yum search mysql|grep '^mysql'
that's the client pkg, did you install server too? mysql-server
here are steps for mariadb server btw, server-world.info/en/note?os=Fedora_19&p=mariadb
 
Hm, I tried yum install mysql-server and it is installind mariadb-server
 
slm
yeah that's what I figured before, I think they're dropping mysql server
let me see if i can find something official about it
 
now service mysqld start then mysql works
=)
Thanks! :D
 
slm
MariaDB, a community developed fork of MySQL, will be the default implementation of MySQL in Fedora 19.
do me a favor and post this as a Q and I'll provide this answer.
sure others will get tripped up by it too
 
Sure, one moment
0
Q: Can't start mysql on Fedora 19

That Brazilian GuyI'm running Fedora 19 and I have installed MySQL using yum install mysql. When I issue the mysql command, I get the following error message: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) If I do create the /var/lib/mysql/mysql.sock f...

@slm I have to wait 12min to accept an answer.
 
slm
3:00 PM
@ThatBrazilianGuy - yup, thanks for doing that
 
@slm Haha, no way, thank YOU man!
Additionally, I can't run phpMyAdmin, it asks for the MySQL password, I haven't set one. In Ubuntu IIRC it asked me for parameters when I installed it
 
slm
@ThatBrazilianGuy - glad to assist a fellow Fedora user!
 
@slm I've been using Ubuntu for a year at work, this week the whole team was told to migrate to Fedora. The differences are a bit challenging, specially for someone somewhat new to the Linux world
Oh, forget what I said earlier, now after installing mysql-server I can run mysql_secure_installation
 
slm
@ThatBrazilianGuy - the command line is essentially the same, the package mgmt is definitely diff.
wealth of knowledge here, always ask if your lost 8-)
 
I fear getting spoiled and becoming a help vampire =P
 
slm
3:06 PM
as long as you're trying that's not a prob
 
But over time I (slowly) get ideas on what to / where to look for so I think I'm improving
 
slm
that's all ppl can expect, that the help is a 2 way street
 
Haha, I think it will be a long time before I can help someone.
But one thing I don't understand (well, I do, but it pissess me off) is when in another tech community I participate on facebook, A LOT of people (help vampires mostly) ask for help, then say "oh forget it I fixed it myself" and never say what the cause and/or fix were.
"Help the community? No, why should I?"
 
meh, those people ask before investigating... a bit... that's why here we have downvotes and such
 
Yes. I'm on a strongly active local wordpress community... on facebook.
I bet you can imagine the daily frustration.
 
3:16 PM
0
Q: running a terminal programm instead of the linux terminal

SajeI would like to launch a program instead of the Linux shell, that works like a shell. An restricted working environment, with a different log in process. But not only to close the options from the original Linux shell and the access to it. It should run after boot, maybe after an automated log in...

I want world peace :)
 
yeah... voted to close
 
Sometimes it helps to have interrogation signs in the questions... it helps to see where the question is
 
@slm It's fully ubiquitous. Either a system has perl or isn't worth using.
@ThatBrazilianGuy Hah, what happens when you reply to them and ask them what the fix was? Sometimes works.
 
3:33 PM
Hi. I'm on fedora 19 and there's no flash package on yum as there was on apt. On the official Flash site it asks what kind of linux I use, I choose YUM, it directs me to a .tar.gz file, but I suspect this way I won't be getting updates?
 
adobe dropped flash support in Linux, so is expected
 
No, they still support it, security fixes only. And it's not the newest version...
 
@derobert Yeah. Sometimes. The real issue is, if a forum is much, much, much worse than the SE model, then facebook is much, much, much worse than the forum model. Imagine no topic splitting, no areas / categories, only a single sticky post, no topic listings, etc etc etc
@derobert Yeah, on ubuntu I was getting occasional security updates
 
@ThatBrazilianGuy Wow... that sucks. I wouldn't know, I'm busy avoiding having any Facebook accounts
"NOTE: Adobe Flash Player 11.2 will be the last version to target Linux as a supported platform. Adobe will continue to provide security backports to Flash Player 11.2 for Linux. " ... that's what Adobe says
 
@derobert Well done! SO am I
Well, flash is (finally!) dying anyway
 
3:36 PM
for the only thing I use FB is too keeping touch with old friends...
 
@derobert Unfortunately, both the wordpress local community and the web devs comunity all over the country are really active on facebook, much much more than anywhere else
 
there is a wordpress tag in SE... maybe webapps...
 
The only thing I use FB for is to keeping touch with old friends having a list of old friends that won't talk to me for a whole year and then come in flocks to leave single-line happy birthday messages.
 
@ThatBrazilianGuy Does fedoraproject.org/wiki/Flash help? It's what Google recommends...
 
@ThatBrazilianGuy exactly!
 
3:38 PM
@ThatBrazilianGuy The secret is to never tell anyone when your birthday is.
At least, that works offline :-P
 
I will change my birthday in FB... let's see how may people "really knows/remembers me"
 
@Braiam I did it once. The answer is: my wife and my grandmother.
@derobert Perfect! Thanks!
Other reason I'm forced to use facebook is because of a trend that started a decade ago on MSN / Live Messenger and now is standard for my generation: people don't invite others for events on a per-peron basis. They either leave a post on the most popular social network, or create an event in facebook's case. If you miss it, shame on you, "hey I did my part, how come you missed the post"?
</rant>
Let me restart the browser to check if flash works
 
3:55 PM
It does \o/
 
@ThatBrazilianGuy Suggest to them that they put it in the classifieds section of the local paper, then you'll see it :-P
 
4:06 PM
@derobert That... is overkill, isn't it?
 
@Braiam It'd get a large party, at least!
 
Fun! It'll be apt-get upgrade time soon!
 
umm... is a very small patch
 
@Braiam Indeed. And I guess compiling X is not the ordeal it once was... But I can wait for the DSA.
Since I have neither untrusted X clients (who in their right mind!) nor untrusted users using X.
 
can anyone help me with a linux question
 
depends... you have cookies to give?
 
4:37 PM
no
 
:(
 
@Chrislast I am so tempted to tell you we only answer BSD questions here... But I won't be sarcastic.
 
but it is a simple question
 
@Chrislast answering Linux (and other Unix-like OSes) questions sort of is the point of the site.
 
so i can ask you
hold on let me type it out
i have a file called numbers which has a list of numbers, i need to sort that numerically and also redirect the stdin to a file called largest but make sure it redirects only the largest number
i mean stdout
>
 
4:40 PM
sort -n will sort numbers for you. Or sort -g (they do slightly different things; check the manpage)
And head will give you the first n lines of a stream
 
actually i cant use head
it can only be tail
so it would like tail -1
 
@Chrislast sort will sort either ascending or descending, so tail works fine too.
 
sort -n numbers > largest | tail -1 doesnt work though
 
your redirect (> largest) is in the wrong place — it needs to come after the tail
 
oh......
 
4:42 PM
The shell does pipes from left to right
 
information flows ot the right side right
ah
 
sort | tail > file
 
yes that worked thanks
 
(For the record, this isn't the most efficient approach, if you care—it's running in O(nlogn) instead of O(n) time...)
 
my professor hasnt really talked about efficiency much
just the basics
 
4:45 PM
Well, if its a course in Linux administration, not computer science, I wouldn't expect it
 
well it's an introduction to linux/unix and im in the CPA, computer programming and analysis program
vi should be exterminated by the way
 
And replaced with vim?
 
does vim require you to know a bunch of commands that are inconsistent?
i havent used vim yet
 
@Chrislast vim is an improved version of vi... The basic commands are almost the same
You could try emacs, if you have at least 8 fingers per hand.
 
haha
no well, i failed the vi part of a quiz because you need to know commands that arent necessary hands on
i mean all you need is 'i" insert key
and the quit commands
 
4:50 PM
unless you want to replace large bunch of data
or look for the next instance of a word...
or spellcheck...
 
@Chrislast Well, :w is pretty useful too. Most vi commands aren't strictly necessary. They’re just useful to do things faster.
 
or.... or...
 
i mean, i wouldnt want to write C code in linux
using vi
 
@derobert can you help out with "or"'s?
 
@Braiam or jump to the end of that function, or find where that function is declared or defined, or...
 
4:52 PM
i would say visual studio is better, but microsoft.... grr
 
@Chrislast Hah, you don't have to, there are a bunch of IDEs and other editors. But you'll find out a lot of Unix veterans write C in vi (or vim) because they want to...
 
crazy people
but good for them
 
@Braiam ... or autocomplete an identifier, or ...
@Chrislast Hah, well, its quite efficient once you put in the time to learn it.
Which, admittedly, is a fair bit of time!
@Chrislast You may find vimtutor useful, at least if you have vim installed.
 
eh.. i just need to get >= 75 in the class and i should have the common knowledge that is necessary
just the basics
 
vimtutor pretty much is just the basics
You may find its approach of having you actually use the commands better than staring at a sheet listing commands, and trying to memorize them.
 
4:57 PM
yeah.. i actually spent 5 minutes looking over the basic command of vi and i forgot 80% of them when it came to a quiz
actually using it is the better approach
same goes with everything else in life..
 
And who knows, maybe you'll decide you like it... :-P
Ok. Probably not.
 
haha
 

« first day (1096 days earlier)      last day (3021 days later) »