« first day (2806 days earlier)      last day (1534 days later) » 

12:03 AM
@dessert I've had a question about that and there's actually a Google doc of users including myself who speak multiple languages and can volunteer for translation
3 hours later…
3:20 AM
Q: Doubt in Fork( )

lmaololroflIn Program 1 Hello world gets printed just once , but when I remove \n , and run it (Program 2 ) the output gets printed 8 times. Can someone please explain me the significance of \n here and how it affects the fork (). Program 1 #include <sys/types.h> #include <unistd.h> #include <stdio.h> #...

2 hours later…
5:34 AM
Xfce, x11, KDE, GNOME... any help in clarifying these 4? I'm trying to "see" a DO droplet thought VNC, and stumbled upon this. following guides I can just install xfce and that's it, but i'd love to understand more... any comment/input to help me out?
All except x11 are display environments. X11 is a X server those run atop of
X11 is a networked display server that abstracts the video hardware for client applications. When you launch a graphical application, it connects to the X11 server and communicates with it to receive input and send drawing instructions.
Ok... so the other 3 can run under x11?
5:49 AM
Got it, thanks, I'll go for the one in the guide (xfce), seems to be the most lightweight of those 3.
still pretty heavy, but easier to setup than say Twm or something
personally I think learning the CLI way of doing things is best
6:27 AM
Yeah, I have no problem with the terminal, but was running into lot of problems setting up Kodi Media server headless, there's little to no documentation.
Maybe I'll end up setting up Samba or something less time consuming.
2 hours later…
8:51 AM
@SergiyKolodyazhnyy 7.5B wow, it's insane for Github!
Is it just me or you guys have the problem too when performing apt upgrade and apt dist-upgrade? Just tried it second or third time in my life, and can't boot Ubuntu again ;__;
@JourneymanGeek that’s an interesting topic, what lightweight DEs besides Xfce and LX{DE,Qt} do you recommend? I have no problem using the CLI and actually do more and more with it, but e.g. watching films without X is difficult…
Q: How to watch films/images without X?

MatthewRockI'm wondering if there is a way to watch films or images without running X server. I'm not using login manager - I log in to tty and start X server manually. Hypothetical situation: I log in, but decide to only watch film, or maybe view few photos. I don't want to run X server and all the GUI st...

Wait, it isn’t? oO
@dessert Blackbox and Openbox. Install tint2 and a dock, and it is pretty sweet. askubuntu.com/a/600496/295286
9:07 AM
@Qback no problems here – search main for error messages and stuff, look at askubuntu.com/questions/162075/… and if nothing helps write a question (How to Ask).
I used to use Openbox and Blackbox as my daily desktops at some point for several months. Always have it installed just in case
@dessert So it looks like I'm just unlucky.. Idk why I have never done a proper apt upgrade :(
@SergiyKolodyazhnyy wow, thanks – I’ll definitely give it a try!
9:24 AM
It's lots of edge PPAs, if you do something really odd with multiple DEs mix and matching different compositors, have really modular spots in your environment that connect to the base OS and they get out of sync. Hasn't caused a failure to boot for me ever, but my environment for work broke last time (fixed it), and I had the compositor stop launching on an upgrade. It was because I threw compiz on XFCE and kwin on lxqt. The update process must have been confused.
@Qback ^^
Funny stuff: nakedsecurity.sophos.com/2018/06/04/… Cloudflare mistakes own DNS for DDoS attack
@RobotHumans Lucky you. I have no twisted dependencies in my OS. I kept it as clean as I can. Also whole upgrade was fine and without errors. I'm just frustrated it happens every single time.. :/
It seems like I have nothing to say and go dig my logs. Thanks guys for responses.
> "New GitLab users can get 75% off GitLab Ultimate or Gold for one year. GitLab Ultimate is our top-tier self-hosted offering, and GitLab Gold is our top-tier SaaS offering hosted by GitLab.com." - New users get a 75% discount on GitLab's top tier plans`
9:41 AM
@blade19899 hey now is the time to get harvesting users :=D
@Rinzwind MS buying github.com is the best thing that has happened to Gitlab xD
Sure is :X
They might be next on MS's target list now >:)
One small problem: this means Microsoft now owns Atom.
I was using ST anyway. Atom had it's merits, but I stuck with ST after trying both.
2 hours later…
12:07 PM
@RobotHumans Well, you're a better man than me: I have no clue!
1 hour later…
1:22 PM
someone is impatient :P askubuntu.com/questions/1043799/…
1 hour later…
2:35 PM
Why is nobody writing answers? oO
3:09 PM
Q: Tag synonyms: [gnome-shell-extension] and [gnome-extensions]

pomskyI just found out there's a gnome-extensions tag. I think it's just a synonym of the older and well-documented gnome-shell-extension tag. So gnome-extensions should be merged with gnome-shell-extension. I have suggested a tag synonym.

3:39 PM
Q: Ubuntu: Chrome crashes when started

GiselaSystem: Ubuntu 16.04 All was fine until today. And then: chrome crashes while watching a YT video. No addon / Plugin / Extension added recently. When trying to restart chrome via launch panel: chrome opens, I can see an empty tab and a small window (sth like chrome wasn't shut down correctly ....

4:33 PM
Q: How can I to start pc directly in persistence usb mode by skipping Kali default meny

RaakhI have windows pc but want to start pc with persistence USB directly by skipping kali linux default boot menu Please advise Best regards

5:20 PM
@dessert One did!
6:00 PM
Anybody with Ubuntu around who could help me figuring this out? I’m clueless…
@dessert net usershare info is a windows command.
6:21 PM
@Fabby what the heck…
nice, this one made it to HNQ:
Q: for loop in folders with \n character in their names

Tara S VolpeI have some folders with \n character it their names. for example: $ ls ''$'\n''Test' Thats refer to a folder with Test name and a empty line before its name. So when I run some scripts like this, in its parent directory: while IFS= read -r d; do rmdir $d done < <(find * -type d) It ...

@dessert Upvoted all answers!
I flagrantly copied steeldriver’s brilliant approach there… :P
6:48 PM
@Fabby OP yes, but I hoped to get an answer from @PerlDuck there (ping intended ;P) – he knows something!
Are you aware of the __git_ps1 function which does exactly (and even more than) what you want? Maybe look into the file /usr/lib/git-core/git-sh-prompt on your machine. — PerlDuck 8 hours ago
ok, most </usr/lib/git-core/git-sh-prompt certainly helps…
wow, that’s elaborated…
7:01 PM
@PerlDuck Do you really force me to ask a question like “I want my prompt to show information about my git repository, isn’t there a better way than parsing git commands?”
@Oli On 18.04? On 16.04 it doesn’t… ls (GNU coreutils) 8.25
7:20 PM
@dessert Arguably, yes, PerlDuck suggests better way. But also arguably OP's question is to troubleshoot their function and prompt. And that function, I think, comes from way back in time from some post on AU or SO somewhere
And arguably I've overused the word "arguably". And I don't wanna argue
@SergiyKolodyazhnyy no, it comes with git, open /usr/lib/git-core/git-sh-prompt in your preferred pager!
@SergiyKolodyazhnyy you’re probably right this question is not the place to present the whole script, but a “here’s how it’s done properly” answer is always a good thing IMO
7:42 PM
@dessert Agreed. "How's it's done properly"™ is always better
@SergiyKolodyazhnyy so we’re arguably arguing because we in fact agree :)
@dessert Apparently yes! I think that's called "having a dialog" :)
@SergiyKolodyazhnyy a dazzling experience
I know, right ? I need to get out more and interact with humans. Apparently having a conversation is actually a great experience
@SergiyKolodyazhnyy just remembered, you have and do a lot on github, are you planning to move?
7:58 PM
@dessert Not yet. I'm thinking to give Microsoft a chance. Although I do consider moving couple recent projects to gitlab
@SergiyKolodyazhnyy :D is that a french fry?
@dessert Cheetos :)
@SergiyKolodyazhnyy if it had chili at least…
I just googled, apparently there is Chili Antivirus. Hmmmm
user image
2 hours later…
9:55 PM
@Rinzwind And electron...along with electron apps
Can we have spam lazers upon this? askubuntu.com/a/1043952/367990
gone, thanks
Anybody else feel frustrated that they learned whole bunch of stuff in college, but feel most confident about stuff they learned on their own ?
10:36 PM
11:31 PM
So I don't have any man pages, what do I need to install to get them?

« first day (2806 days earlier)      last day (1534 days later) »