« first day (2830 days earlier)      last day (2161 days later) » 

2:24 AM
@PerlDuck Thank you for that by the way! I think though that really either they are one in the same person, or they know each other extremely well. The other question that is linked was getting the same 2 people on it with the same non-sense type answer getting instant upvotes. It is good that the question has been closed as a dup now. Looks like those 2 are getting a fair share of downvotes on both of those questions.
@Fabby I am thinking I need to steal that canned response. That exact thing with the comments then someone taking my comments and building their answer from the work I did happened to me over 3 years ago. Somehow people just like stealing my work and passing it off as their own. =)
3:05 AM
so what's the point of using pointers in cpp?
3:51 AM
So you can pass by reference
Q: How to compare bash variable with double quotes

MirageI have this code STATUS=`echo "test"` if [ $STATUS == "test" ]; then exit 0 fi I have tried everything and i am not able to make it true. I tried "$STATUS" == "test" eval $STATUS == "test" ${STATUS[@]} == "test" THE only thing taht worked is $STATUS == \"test\"

@Seth I don't know cpp
at all
obvs :P
lemme throw up a quick example.
if I'm reading this right though, you can pass a primitive variable like an int as *variable to a function
and if you reassign it in that function, it'll also change the original variable
kind of like changing properties of a passed Object in Java?
@TheWanderer eeek I haven't done Java in so long. Or cpp for that matter but I've done some go sorta recently and we use pointers there too.
4:03 AM
in Java you can do this
void someFunction() {
    SomeClass variable = new SomeClass();
    int theValue = variable.someField; //this will be 1

void otherFunction(SomeClass variable) {
    variable.someField = 1;
You'd need pointers in cpp to do that
ah OK
Java doesn't quite let you do what cpp can though
like I couldn't just pass the object and then reassign it in otherFunction()
think of it kinda like a scope thing right.
I told you already, Java is an island where no one plans vacations to ;P
it's not really scope but you can think of it that way.
4:06 AM
@Videonauth I use Kotlin
lambdas in JRE 7 woot woot
@TheWanderer e.g if you assign a variable in one function its scope is only inside that function
so cpp basically lets you bypass that without member variables
as well you can do math with pointers
as i told you in discord, if you have a pointer to an array of values you can give that to your function and even iterate over more values as only the first
int for example is 8 byte
so you can get the second array value by adding 8 to the pointer value
and so on
4:09 AM
oh yeah the discord exists. I should lurk there more.
no this was a DM
I need to actually learn cpp
so much of Android is written in it
ah and before someone kills me for not mentioning, the sizes of int long etc can differ on the different platforms, so better use sizeof() instead of fix values
IRRC sizeof() is in <types>
@TheWanderer I don't know any good resources unfortunately :/
Nathan might.
learncpp.com seemed decent when I was reading it before but idk. YMMV
so what's a quick diff on int32_t vs int?
4:15 AM
are int32_t s = 1 and int s = 1 the same?
@TheWanderer int32_t is typefixed
but what does that mean
while int maybe somewhen in the future longer as 8 byte
or 64 bit
maybe you have an 128 bit system
how do you know how many bits an int has?
int32 is 4 byte
or 32 bit
4:16 AM
or is?
just convert to binary?
learn your powers of two :)
1 byte = 8 bits
no I'm asking how many bits an int has
normally as far i remember on windows and linux the same size, 8 byte
so 64 bits
00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 to 11111111 11111111 11111111 11111111 11111111 11111111 11111111 11111111 in binary
in max value if unsigned
so how many bits is 1?
4:20 AM
so 1
so the answer is yes, you convert the int value to binary to see what bit count it is
no 2 is for example 000.....010 (binary shortened)
3 is 000...011
so two is only one bit too
can I just use int and not worry about the int32 and int8
well the mx possible number is differnt between those two
int8 has max 256 as value
or if you count zero 8²-1
but why would I need that?
int8 is equivalent to short
to save memory
4:24 AM
there we go
so if I know that int won't go above 8-bit, I can use int8 and save 24 bits
if you know you only have a certain value for something you can use smaller yes
you save in modern systems not only 24 bit
its 56 bits you save
I mean compared to an int32
so int is limited to your architecture
theres an int64_t which is in most 64 bit systems the equivalent of int
on an 8-bit system, int would be the same as int8?
4:26 AM
alright I get it now
this is what the sizeof function is for
that returns the bit-count?
or the int value?
the byte size
std::cout >> sizeof(int) >> std::endl
try it
should output 8
I don't actually have an 8-bit system lol
no on a 64 bit system
4:28 AM
nor do I have a cpp environment set up
why would it be 8?
8 byte == 64 bit
oh derp
it's 12:30AM lol
I'm building Android and doing chemistry
well i have to admit I'm not the best to put this knowledge into English words :)
theres one good site for cpp tho let me find the bookmark
good as refernece and their tutorials are good too
that site looks like it was made soon after the invention of cpp :p
I will send you an email with more material tho
@TheWanderer well its not nice but it has all the referneces for every cpp command
ok might now very well fit into a mail lol, give me a second
do not think gmail will accept 300 MB mails
will give you a link in discord tho
1 hour later…
5:51 AM
@PerlDuck I'm happy you found something good to eat in London! It's definitely possible to do, but significantly easier to avoid XD
also, surprised they were on German TV haha
@Terrance yeah, see a bit about that from this message.
1 hour later…
6:55 AM
Could someone please dupevote this? See my comment: askubuntu.com/q/1050599/507051
7:12 AM
done :)
7:50 AM
@Terrance It's all yours!
@dessert final vote. Closed.
thank you!
lol, I love VIM:
> Place your cursor over the first dot (in .star10) and type the following in normal mode: qa3yy3jp^Xjt;18^Xk0q
8:07 AM
It is? I thought I read about it on meta…
oh yeah?
> Don't remove the native version, just write the English translation above it with a notice so that people understand that it may be inaccurate.
A: What to do with non-English questions or answers?

OliLocalisation has been discussed before but speaking about this question right now, we really only support English. That said, this is still somebody who needs help. Closing something just because of its language should be a last resort. Ubuntu is global and we should expect that, as the best Ubu...

still your edit is totally fine though!
I only used google translate and not my superior language skills (I hate translating!), I think it’s a good thing to leave the original there in cases like that. However, if you approved of the English version that’s reason enough to remove the original IMO.
it’s very unlikely relevant information got lost after all
oh ok... I think there is another meta post saying take it out
I know some Portuguese and I know English :)
That is good advice to people who're not multi-lingual... I've translated things where the translation was actually better than the original, so leaving the confusing original in does not make any sense...
8:20 AM
is it just me, or are Ask Ubuntu questions an incredibly easy text type to translate? I can understand Ask Ubuntu posts in languages I know barely anything of. If I know the language at all, it's a breeze!
thanks @dessert for finding the post, I appreciate that :)
in 2016, I think we made a g-sheet or something of people with language skills willing to do translations
@Zanna That's because you're a genius! ;-)
Good morning :)
@cl-netbox good morning!
@Zanna I've had to translate the comments of source code to English before and there were English comments in them already and they were mostly right.
hmm that definitely can't be the reason... I assume familiarity with the material is something to do with it. I do reading comprehension in Tamil all the time and I mostly understand nothing
8:24 AM
I have to say, I really like working with all of you.
@Fabby sounds fun :)
If you know the technical terms, you can figure out 80% already.
@cl-netbox o/ Good morning!
@dessert <3
8:26 AM
@Zanna Tamil isn’t indo-european, most languages you read on AU are. ;P
so it's a bit of both: yes, you're a genius and you're also a Subject Matter Expert so you get it whatever the language is.
So if you see the command and the error, all the blah blah around it is just superfluous!
>:-) >:-) >:-)
@dessert Oh, so the Tamils are the real Atlandians???
Good morning to you too ! :) @dessert @Fabby and @Zanna of course ... I'm disappointed : I solved a problem for a guy who couldn't get his NVIDIA chip working yesterday ... he thanked me - then disappeared without accepting the answer ... and also nearly no upvotes for me (only one) ... :(
:D ;-) :D
@cl-netbox Yeah, drive-by questions.
@Fabby and yet we close every question only featuring those two as unclear, and we do it for a good reason
true, those languages feel more transparent
8:29 AM
@dessert I don't: I edit the Q and then answer
(If I can get interested enough)
@cl-netbox virtue is its own reward
@Fabby This was the thing -> askubuntu.com/questions/1050423/… he tried so many things before ... :(
@cl-netbox You should leave a comment under the question as most beginning users set up email alerts foe rverything and keep hounding them.
>:-) >:-) >:-)
@Fabby but why only 1 UV ? :(
@cl-netbox :D easily explained: no one read that far to even see your answer!!!
:D :D :D
8:32 AM
@Fabby true that
@Fabby hahaha
this question is enourmous, can’t there something be done about it? @cl-netbox maybe remove (really!) unnecessary parts so that it gets useful?
@dessert maybe I edit it later today and remove all the useless terminal outputs :)
Q: Errors While Installing Bumblebee on ubuntu 18.04

Viral ParmarYesterday I installed Bumblebee-nvidia;buut I am getting warnings as shown below: I am on Ubuntu 18.04 and I have nvidia 396.26 installed.

Thank you for the nice comment under the question @dessert ! :)
8:37 AM
Fabby you there?
@ViralParmar Maybe he fell asleep ... did you @Fabby ? :D :D :D
@cl-netbox sometimes OP needs a third party to wake up – of course you got my UV as well
@cl-netbox Yeah
@dessert Thank you for this too ! :)
@ViralParmar Please don't post images of text. Instead, paste the text directly into your question and use the formatting tools.
8:41 AM
@dessert ok! Sorry
@cl-netbox I did... :P
@ViralParmar no problem, we’re here to help :)
@Fabby oh Thank god you are here !
@Fabby Then Good morning again ! :D
Thank God Fabby is here!
8:42 AM
But I'm off back to work though!
@ViralParmar Don't thank God - thank me ! I woke him up for you ! :D :D :D
@cl-netbox thank you ! :)
Anyone here can answer that question after you've converted the screenshot to text!
@ViralParmar You're welcome ! :D
:P :P :P
this is his problem:
ll /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf
lrwxrwxrwx 1 root root 41 May 18 22:43 /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf -> /etc/alternatives/i386-linux-gnu_egl_conf
he lost a symlink.
@ViralParmar cl-netbox is our resident expert at nvidia anyway...
so he'll be able to help you better than me!
8:45 AM
I have Nvidia GeForce 940Mx Which is Cuda Supported. So Which Driver should be installed for my Graphic Card. I am running ubuntu 18.04 on my system
@Fabby Thanks Fabby ! Thank you for your help !
@cl-netbox Any Idea regarding my previous quesiton ?
I am sorry I might be posting lots of question , but I am kinda new here ..so I request you to please forgive me sometime for my behavior :)
@ViralParmar Nvidia recommends driver 390.67 available through graphics-drivers ppa see askubuntu.com/questions/61396/…
@ViralParmar which question ?
@ViralParmar The latest stable drivers from the long-lived branch are 390 ... the latest from the short-lived branch are 396 ! :)
@ViralParmar warnings usually are harmless. They can be ignored in most cases. Nothing to worry, really, if all works well.
@ViralParmar Best for you would be to stick with the drivers from ubuntu repos - which are 390 ... will most certainly match best with cuda in this case ... if you need the latest advancements you can use the drivers 396 from the GPU Drivers ppa ! :)
Good morning Mr. 100000 @Takkat ! :)
Seen my recommendations @ViralParmar ? :) No response ? Is it now you who fell asleep ? :D :D :D
morning Netty :)
9:02 AM
Q: Failover physical and virtual machine with replication. Is it possible?

NickI want to create HA cluster with 2 nodes. First node is physical machine, second is virtual (under ProxMox). Both running under Ubuntu. I know how to make HA with corosync and pacemaker. How i can make replication/mirroring of partitions? Is it possible without using NAS storage?

@cl-netbox its just student came into my lab , I am working as an asst. prof.. so yeah its my lecture time :)
boxy! :)
:) those days when I was younger students always had to wait until profs had finished whatever they were at.
Rinzy !!!
takky! don't you dare calling boxy netty :=)
Nett is nice in German :)
9:11 AM
Box is box in German. :D
so? They are also out of the worldcup >:)
South Korea played like gods !
<-- ducks away
I’d rather say Germany played like trash, but yeah.
throws a duck
All thanks to Guus Hiddinks legacy :+)
9:15 AM
@Rinzwind Rinzy ! :)
@Rinzwind Fully deserved ! :D
@dessert They did indeed ! :D
@JourneymanGeek Hi ! :)
time for groceries before it heats up around here. it is suppose to reach 32C today.
9:30 AM
I’m just sad all the German flags will quickly vanish from the streets now, unfortunately it’s only while Germany is playing in the world championship that openly displaying a German flag is socially accepted in Germany. I have yet to find a country that’s equally demure and ashamed of its flag.
9:46 AM
@cl-netbox Thank you for you help!
@ViralParmar You're welcome ! :) Everything clear now ?
@dessert Finished ... edited and improved the question ... PUH - that was hard stuff ! :D What do you think, does it look better now ?
Q: Cannot load NVIDIA graphics card on Ubuntu 18.04

Isse NurLaptop: Acer Predator with Ubuntu 18.04 LTS and Windows 10 dual boot. Specifications: Intel® Core i7-7700HQ Nvidia GTX 1060 OS-Type: 64-bit Everything is working fine so far, except that I can't switch to the NVIDIA graphics card in Ubuntu. Please help me, this is the first time that I have in...

@cl-netbox well before posting this question , yesterday night I installed Nvidia 392.12 driver. And after that I ran the command "nvidia-smi" and that showed me the details about my Nvidia Card. But then how can i verifiy that the installation has been done successfully ?
@cl-netbox wow, much better!
@ViralParmar lspci -k | grep -EA2 'VGA|3D' ... it must show -> kernel driver in use : nvidia
@dessert Thank you ! :)
@cl-netbox So I think I should Prefer 390 over 396 ?
9:53 AM
@ViralParmar depends ... as I said, the most stable drivers are the tested ones from the ubuntu repos, which is 390
@cl-netbox Is that preferable for deep learning ? I am after installing Nvidia Drivers I started Installing tensorflow-gpu version, but it ran into an endless loop
@ViralParmar if you browse the NVidia site for recommended driver for your card they spit out the 390 too
reason unclear to me but they may know
@Takkat okay!
@cl-netbox I should not ask this question here , but are you guys like on Facebook ?
@ViralParmar In this case 396 might be the better choice ... you have to test whether Cuda works as expected ... the latest drivers version is 396.24
Some years ago I thought the very newest bleeding edge driver from the manufacturer should always be the best for me too... I had to learn the hard way (box booting to black) that this is not the case.
9:58 AM
@ViralParmar Facebook ??? never ever !!!
@cl-netbox GPU Driver ppa has 396.24 ?
what is Facebook? ;)
@Takkat :D :D
@Takkat well, if you do exactly know what you're doing then everything works properly :)
@cl-netbox who knows exactly enough when on proprietary drivers.... sigh
All world to Open Source!
<-- replaced WA with Wire some weeks ago
10:01 AM
@ViralParmar are you blind ??? :D :D :D sudo apt install nvidia-graphics-drivers-396
@cl-netbox No ....Its just i thought the repo might not be having 396
the ppa has both 396 for the brave and fearless and 390 for the rest.
@cl-netbox as its the latest driver
Some cards may need 396
10:03 AM
@cl-netbox Thank youuuuuuuuuuuuuuu!!
The weird thing is that Canonical uses different package names lately ... for whatever reason ... on fedora it simply is akmod-nvidia
@cl-netbox Now things are getting crystal clear !
@ViralParmar You can find many NVIDIA solutions on my AU profile. :)
@ViralParmar You're welcome ! :)
Isn’t Facebook dying already?
@dessert dying ? it was never alive ... at least for me ! :D
10:24 AM
Any bounty hunters in here who know how to gather debugging info on suspend issues using systemd?
Q: How to debug suspend?

mlissnerI've been using Ubuntu for about five years now, and I still can't make it suspend when I want to. It's quite irritating that I can program up a storm, hack the machine in numerous other ways, and yet, and yet when I try to make it suspend or debug suspend, I fail miserably. I need help. Where...

@DavidFoerster no but systemd has only 1 log :=)
and you can never discard a broken bios :P
@Rinzwind And I have little practical experience with it because I'm still on Trusty. (Will upgrade in a month when the first point release of Bionic is ready.)
See my comment to the linked question. :-)
@DavidFoerster You should ping @WinEunuuchs2Unix ! :D :D :D Hi David ! :)
10:29 AM
@cl-netbox Hi there and thanks for the tip! He wrote an answer a few hours ago and I commented on it.
journalctl -b is the log for systemd
A: Errors before login after installing NVIDIA drivers

cl-netboxjournalctl -b "should do the trick", this will show the journal entries that have been collected since the most recent reboot. journalctl -b -1 shows the entries from the boot event before. Reference and more information : How To Use Journalctl to View and Manipulate Systemd Logs To see add...

@Rinzwind I'm relatively sure that I would be able to gather the info on my own, but I know to little about systemd to write a canonical answer that describes useful instructions of how to identify the necessary info in the log.
@Rinzwind Don't get many ... my posts seem to not attract many members ...
10:33 AM
Then there's the whole matter of systems that fail to resume from suspend. Where would one find their suspension log data?
@DavidFoerster yeah well...I hate the way systemd works. It does it all so when you want to debug you need to wade through 99% of non-related notices.
@DavidFoerster in journalctl. systemd has 1 log. Just that one.
@Rinzwind I can't understand why so many users complain about systemd ... works as it should on my systems :)
oh on mine too. but I am someone that also needs to debug OTHER systems. and it can get messy then
@Rinzwind Can't you restrict the log output to specific units or something?
you can
it's very flexible
10:36 AM
yes sure you can :)
but until recently you had to configure it to remember anything before the current boot, btw...
but you need prior knowledge and when given a problem you might not have that yet
still the case for most
11:31 AM
Does anybody know whether (CLI) mplayer has a keybinding to stop playback after the current track? I can’t find this feature anywhere, does it really miss this? oO
cmus looks awesome though, with its library filters and whatnot
12:00 PM
vi even has a POSIX standard.
@dessert The answer was accepted now ... thanks again for your comment (and your UV of course) ! :)
12:22 PM
@cl-netbox you’re welcome :)
12:55 PM
hmm gentoo github got hacked?! Link infra-status.gentoo.org/notice/20180629-github
1:08 PM
Q: How to search AU for a string containing “$”?

dessertToday I tried to search for this answer, but the only thing I could remember from it was $_, so I tried to search for this term: https://askubuntu.com/search?q=%24_ To my surprise the result page claimed to search for a single underscore only and didn’t find a single post: results found cont...

1:31 PM
@AskUbuntuMeta Wow, good question, well done!
that's your own question. you don't get to judge "good question" :P
unrelated, good morning all.
@ThomasWard oh my ;)
@ThomasWard Good morning Thomas ! :)
drifts over to the coffee maker and makes coffee
The AU search engine sucks. It just finds apparent things. Usually google with "site:askubuntu.com" is the way to go.
1:36 PM
i'm probably the only person who has a coffee maker at their desk
@dessert part of the problem is many 'search' functions treat $ as protected, indicative of a variable
No, two colleagues of mine have one too.
or just stripped out entirely to protect against invalid parameter attacks
@PerlDuck i meant at this workplace :P
and I doubt your colleagues drink 5 cups a day
... or more.
@Zanna I can definitely see it being a sock puppet. =)
@ThomasWard Oh yes, they do. Their mugs are black as hell.
@PerlDuck I know, but that needs to be changed.
@ThomasWard I think so as well, but then there needs to be a different way to enter it, and this way should be properly documented in the help pages.
brb coffee break
1:50 PM
@dessert considered using &#36; as a search parameter? that's the websafe numeric code for $
might not help but
2:13 PM
@ThomasWard good idea, but searching for &#36;_ only gives results found containing #36 _, so it just removes & and ;
i have one other potential reason to blame:
SE is an ASP-based product IIRC. Or a .NET product.
shakes fist at Microsoft
hands out pitchforks
Good afternoon @ByteCommander ! :)
@Byte And torches! Burn must it! Burn!
2:23 PM
@PerlDuck summons evil from orbit, watches the lasers fly down upon the earth
First signs are here:
Q: How to prevent screen brightness change when I move my mouse up?

Slava BorisovWhen I quickly move the mouse cursor up to the top of the screen, its brightness increases. How can I prevent this? I use Ubuuntu 14.04

Q: Search terms with dollar signs ($) are ignored

BennyBechDkWhen searching for "MON$ATTACHMENTS"" it searches for "MONATTACHMENTS". Likewise, searching for "MON$ATTACHMENTS" still searches for "MONATTACHMENTS". It seems like it is impossible to search for something with a $ (dollar sign) in it. It should have found (at least) this one.

@dessert Nice find! I see that code:"$" does work
yes, but e.g. $@ doesn’t necessarily appear formatted as code
I see it does find the $@ but also finds @
Hmmmm every link I have clicked on seems to be $@... OK
2:31 PM
askubuntu.com/search?q=%22%24_%22"$_", no results
same with q="%24_"
askubuntu.com/search?q=%24__, no results
@Terrance code: just searches in code blocks, doesn’t it?
it’s odd that it works this way
@dessert Yeah, it looks like it does, but isn't that what you are looking for?
Hey, @Terrance nice to see you ! :) How are you doing ? Hope fine :) Today I got Firefox Quantum on my RHEL 7.5 system ... nice ! Already yum upgraded ?
@ThomasWard Your eyes scare me.
2:37 PM
@Terrance it certainly helps, but not really: I want to be able to search for questions that have e.g. $@ not properly formatted. Plus, if quoting e.g. a manpage, a whole post can talk only about $_ without a single occurence of it formatted as code.
@PerlDuck me not ... harmless for the most dark and evil mod - right @ThomasWard ? :D
@cl-netbox Hey there! I am doing well! Have to get ready for work now. Ooops, spent too much time here and I am going to be late! Nice about the Firefox. I will have to take a look at that when I get to work.
@dessert Ah, OK. That makes sense.
@Terrance good to read you're doing fine ... yes, have a look : sudo yum clean all and sudo yum upgrade ... have fun ! :)
@cl-netbox =)
@Terrance I wish you a nice weekend ! :)
2:40 PM
@cl-netbox Same to you! =) I will probably be back on shortly. At least work lets me connect to here. ;)
@cl-netbox "Yum" are those Asian noodle packs, right? Pour hot water, stir, eat. I like them.
@PerlDuck side effect of the evil I channel :P
@PerlDuck in future releases that will be dnf - I'm sure : sudo transfer noodles ! :D :D :D
@Terrance Thank you :)

« first day (2830 days earlier)      last day (2161 days later) »