« first day (2569 days earlier)      last day (46 days later) » 

12:03 AM
RELOAD!
[rubberduck-vba/Rubberduck] 1 commit. 1 opened issue. 1 closed issue. 2 issue comments. 1 addition. 1 deletion.
 
 
5 hours later…
4:42 AM
@this that sounds like it’s inspection worthy. “Everything after Exit Sub Will not be executed. Consider eliminating the Exit Sub statement and everything after it up to the End Sub to make this intent explicit.”
 
 
3 hours later…
7:56 AM
The unconditional exit sub probably represents the furthest extent of the previous refactoring attempt.
 
 
2 hours later…
 
2 hours later…
12:07 PM
@this On the bright side, there is a huge swath of code you can simply delete!
Also, I'd suggest a Ctrl-F, click the All modules and search for Exit. Who knows how much other dead code is there.
 
 
1 hour later…
1:10 PM
> **Rubberduck version information**
The info below can be copy-paste-completed from the first lines of Rubberduck's log or the About box:

Rubberduck version [2.5.2.5906]
Operating System: [Windows 10]
Host Product: [Office 2016 x86]
Host Version: [16.0.5164.1000]
Host Executable: [MSACCES.EXE]


**Description**
With everything in Rubberduck I started Access crached. Don't know why

**Expected behavior**
That I get information/

**Screenshots**
If applicable
 
using git (TortoiseGit's GUI, in particular) can I create a new branch B from master if I currently have branch A checked out, or do I have to switch to master before creating B in order to start B from master's state?
 
1:38 PM
> @phoyd I don't think it was brought to Microsoft's attention (the odds of it ever being addressed are next to none, since this would be a VBA problem / not an Excel type library problem; Excel's type library is actively maintained and regularly extended, but not VBA itself), from what I recall this weird behavior was accidentally discovered and immediately treated as an oddity that Rubberduck could/should be inspecting for.
Since 32-bit works fine it appears to be a x64-only bug related to a
 
@IvenBach that would be for code path analysis to walk the execution paths and identify nodes/instructions that are never being hit - and then a CPA UnreachableCodeInspection would flag the unreachable statements (will probably need a new type of inspection result target, a "parse tree" result seems too low-level for this)
@FreeMan IDK about tortoise, but git checkout -b NewBranchName works off the current branch... there's probably a way to tell it to branch off another, but it's probably simpler to just checkout the branch you want to split off from.
 
@MathieuGuindon that's what I thought and what I did. Thanks for the confirmation.
Nice to have you stop by on occasion. ;) Hope the new gig is going well and not keeping you too busy.
 
1:53 PM
new gig starts Monday =)
@Peilonrayz thanks! I've had it ready for a little while, just gotta find it & put it up (thought I had a copy on my phone, turns out I don't)
 
@MathieuGuindon Ah, so you've been ignoring us to spend time with your family? How rude!! ;)
Hope you've enjoyed your well earned time off from both working and Ducking.
 
@MathieuGuindon NP :) I thought Feeds linked to CR so deleted my link. Here's CR's
 
As @this board's resident OASYS-SVN expert and main proponent, I've got a question for you that I'm not finding an answer to.
In my Access solution, I'm currently working in branch A and have added a couple of new modules. I need to switch to branch B, based off of master, not A, so I create a new branch using TG.
Now, I need to import all the code from my new branch B to reset the Access project's code base. I can do so, but my new modules are still in Access. What's the flag and/or setting I need to get OASYS to effectively "drop everything and rebuild from what you find on disk"?
Sadly, I believe that this has been the cause of the various git issues I've had over the last few years - my Access (or Excel) project has new bits that accidentally get checked in on an unrelated branch because whatever import method I've used isn't clearing out code that doesn't exist on disk.
(I believe RD's Replace Contents from Files does that now, but I didn't used to use it, and I had my own methods prior to that being implemented in the duck.)
ATM, I have imported all my code from the new branch B, but the .accdb also contains code from A. So, I've exported all the code, then I'm using git diff to see what files are not under VC in this branch, then manually deleting them from the .accdb (and disk) to get a clean diff. However, that doesn't seem very efficient.
@MathieuGuindon hah... just saw your response to my other message. Good on ya!
 
2:14 PM
 
@FreeMan I know a thing or two about OASIS. Not so much about OASYS.... ;-)
 
yeah, yeah, whatever... ;)
Is there a solution to my issue built into OAS*S that I'm not aware of?
 
Seriously, the answer is that you need to do something like this: 0)) verify you're using right file & right path for working folder 1) open the import dialog, 2) click on the button on the bottom that looks like a trash can. That will open a 2nd popup listing all Access objects that do not have a corresponding file in the source folder, 3) import everything and then the Access file should be in sync with what is in the working folder.
 
Ah!!!!
 
that's the biggest headache working with git with project that don't represent their source code as individual text files.
because you must deal with both the filesystem (git) and the project's structure --- deleting a file in git repository requires a corresponding delete to happen in the project's structure.
 
2:20 PM
yeah. Now that you mention it, I seem to recall that from some time in the past, but, obviously, forgot about it.
 
try forgetting it few more times. You might then remember it by then!
 
2:36 PM
Yeah, I've already forgotten plenty of times. :(
OK, now that I've already jumped the gun and I exported stuff to disk that I don't want in this branch, do I have to manually clean them up or can I stash this current, but very wrong state, pull from master to ensure I'm clean, then do a proper delete/import back into my .accdb?
i.e. what's the most effective way of deleting a dozen or more modules that shouldn't be in the current working directory?
Ah, TG has a Delete command in the diff listing. I'll just use that.
 
 
1 hour later…
3:48 PM
well... this was fun...
Somewhere between Access & OASIS, something barfed. I hit Ctrl-S to save my code, and it managed to fail at a point between deleting a source code module from disk and writing out the replacement. Now, my git diff shows that file missing.
I tried to export it again, forcing OASIS to export it and it's giving me an error. :/
I mean, on the network, OK, I can see having issues, but it's barfing trying to write it to my local drive!
exported it using the default, built in Access export, then changed the extension from .bas to .def to use OASIS' naming convention.
whew, looks like it's got everything...
OK, not good. :/ I Ctrl-S again in the VBE, OASIS tried to export again and killed the exact same file again.
 
I've never used OASIS. Have you ever compared it to this open source option?
https://github.com/joyfullservice/msaccess-vcs-integration
I am thinking that you could export from both and compare what you get out.
The open source one doesn't do importing to a live DB. It only builds complete compile from source. So each time you compile you get a fresh DB. This is great for side-stepping corruption in FE
 
4:35 PM
@HackSlash Took a quick look at it. I wonder if it does the nice things like separating forms from code-behind, like OASIS does. That way, when code changes, but the form doesn't, there aren't massive diffs to sift through for the oddball things that Office outputs in the form def portion.
 
Yeah, it does
 
that's a bonus.
Not sure I want to rebuild the .accdb file from scratch every single time, though I can see benefits to doing that, at least occasionally...
 
We are working on minimizing the noise in the diffs right now. The current discussion is colors. Themed colors change on each export so we are trying to ignore those changes while still having a text file that can build a DB with the correct colors
 
it would, of course, eliminate the "I forgot to hit the garbage can button" issue I keep using to trip myself up.
 
Yeah, I rarely use the build from source because I am a lone developer. If I was working on a team we would merge and build like any other software project
 
4:38 PM
that's my issue, too. I'm the Lone Ranger here. It's nice not having anyone criticize my approach, but it sucks not having anyone to bounce ideas off of.
ATM, I'm just trying to get a few things knocked out, so I'm not sure if I'm willing to change my approach right now.
We do have another guy who does about 0.01% coding. He can write an OK macro, but I'm sure he'll be a bit baffled by some of the OOP stuff I've added in.
curious, @HackSlash, how long does it take to build a fresh DB by importing?
 
Really depends on the physical size in bytes
 
makes sense.
 
Looking at my "big project" the last build log shows: "Done. (26.28 seconds)"
But "big" is relative and people do some stupid things in Access
I've heard some tales of people crashing RubberDuck due to Access project size
My projects are simply not that big
All told, my source folder is 2.33MB
Which sounds like a lot for text files.
Only 80kb of that is image files.
Having the source lets me see cool stats like that.
 
Mine is 5.3MB, but that includes table/report defs and the entire .git directory, too
 
So it might take a minute to build, based on WAG
oh, don't include .git
 
4:48 PM
Cool! I just discovered that TortoiseGit adds a tab to the Properties dialog box when you select it on a git repository. Nice...
seems like an option worth looking into, I'm just not sure it's worth enough for me to look into it right now.
 
I've always wondered if OASIS is worth buying but I like the open source thing. It does what I need.
 
OK, now I'm getting RD Parse issues:
2021-06-18 12:50:46.9771;ERROR-2.5.2.5938;Rubberduck.Parsing.VBA.ParseCoordinator;Unexpected exception thrown in parsing run. (thread 5).;System.AggregateException: One or more errors occurred. ---> System.UnauthorizedAccessException: Access to the path 'C:\Users\bshepard\AppData\Local\Temp\Rubberduck\e3z0k3ic.r2e' is denied.
I'm going to take that as just another sign that it's time for me to leave this job.
I modified code so that it would run off of a local drive, and now I'm working on changes to ensure that it runs locally instead of from the network in an attempt to avoid these bizarre corruption issues.
file still exists:
and I have full rights to it:
hrm, quite a number of ocurences of ERROR- in the log file. Maybe I'll post an issue for people to chew on.
 
5:45 PM
^ +2 now. Some unlovin' going for the other two that have been posted so far. Ouch!
 
How's your new job, @MathieuGuindon?
And can you share the company yet?
 
I'm starting Monday =)
Yeah the company is CGI (Montreal) - I'm not allowed to disclose the client though, but I'm sure it's going to be amazing!
@FreeMan last one ended up with 5 or 6 downvotes, and netted +55 IIRC; I'm not worried! =)
 
It's a contracting company?
 
Yeah
Kinda
 
Ok.
Looks a bit similar to what I'm doing.
Way bigger, though.
 
5:59 PM
@Hosch250 yep!
 
6:10 PM
Anything interesting going on, other than that?
 
6:27 PM
Not much, time just flies by..
Woah, we've made the threshold already!
 
 
1 hour later…
7:58 PM
Very much grumble grumble wtf today.
 

« first day (2569 days earlier)      last day (46 days later) »