« first day (3357 days earlier)      last day (34 days later) » 

5:39 AM
@bob I accidentally click "Start new session"... Help?
 
Bob
6:16 AM
@MichaelFrank ??
 
6:58 AM
@Bob In Firefox.
I did not click "Restore Session", now all my tabs are gone.
I know you are TabMaster, so please sensei, you're my only hope.
 
Bob
7:16 AM
@MichaelFrank Open your profile folder via about:profiles and go to sessionstore-backups
copy everything there to another folder
and then look for the most recent biggest file
close firefox, rename file to previous.jsonlz4, and open firefox again
(and pull from backup folder if it fails, cause it'll clobber)
what you can get back depends on whether you (a) killed firefox [via task manager] asap (recovery might not be clobbered if within 30s), (b) didn't close firefox yet (previous might not be clobbered; iirc it writes on save though it might clear when you click start new?), or (c) you can only recover from the upgrade backup from the last (minor) release upgrade
also if you want a faster resp poke me on matrix next time, I actually get phone notifications there :P
 
guess who'[s back
back again
wow that's le suck
both the sudo thing, and firefox handling of restoring tabs after accidently not restoring them
in chrome i go 'history -> recently closed and they're all there (if all in one window it'd show "14 tabs"
 
7:46 AM
What are those tools called which measure latency b/w a keypress and monitor? I saw some YouTube videos where people put the device on the display and measure the latency.
 
Bob
7:56 AM
@Biswapriyo I like to call them cameras
(seriously though, you can emulate them with a phone camera. bonus points if you have a slow mo mode)
 
morning
 
Bob
8:43 AM
@djsmiley2k Actually, now that you mention it, I haven't been asked to restore/not-restore in quite a while.
 
o_O
 
Bob
I have mine set to always restore but if that's disabled the old session seems to still be accessible via the history menu *shrug*
 
as in it auto restores?
yeah
Does it only ask, if it's on auto, when it's crashed out?
because it maybe due to a tab causing the crash?
 
Bob
@djsmiley2k good point, that's the only place it still asks
 
 
1 hour later…
10:02 AM
@Bob Yea... It seemed to be clobbered.
Oh well!
 
Ave
10:17 AM
bleh, kernelcare.
that was 2 months ago
 
Ave
10:43 AM
 
NAND endurance is a problem, and here we have an industrial application managing to wear out flash.
 
11:47 AM
@Blogbot "we got the chance to sit down with Prashanth Chandrasekar, Stack Overflow’s new CEO, to hear about how he got into computer science and his vision for this community and company." lul
@bwDraco lol
Why on earth are they logging to the firmware storage location
 
12:18 PM
Yeah. Stuff that's expected to write lots of data over the life of the system should be on a separate, readily-replaceable board.
Also, use the correct type of storage! Choose high-endurance MLC flash if you need to write dozens of gigabytes to it every day for a decade or more.
This is a freaking automotive system. There is no reason to skimp on the storage.
If MLC isn't an option, at least properly size and overprovision the storage.
People just don't get that NAND endurance is not unlimited. I would expect folks working on automotive systems to know better.
And if it's nearly full, beware of write amplification (that's probably the thing they missed).
> 8 GB eMMC
What the fuck.
Why would anyone seriously believe that such a small flash memory chip could handle dozens of gigabytes of writes each day for a decade?
Also, that chip is almost full. Write amplification will kill it.
Totally idiotic.
 
12:41 PM
@bwDraco developers are stupid in everything other than development. I'm not even joking here.
I have developers who don't understand networking, sysadmin, ops, or anything else. They just know code.
 
1:05 PM
IMO the best way to cope with the limited endurance of flash memory in a complex industrial system is to treat it as a consumable. All storage will eventually fail, but flash memory has write endurance limits that must be accounted for.
 
Bob
@djsmiley2k :<
@bwDraco Meh.
Rotating logs are the poster child for flash-optimised filesystems that deal primarily with append writes.
Just configure the right buffer size and you have exactly zero write amp.
 
@Bob not all devs obv.
 
@Bob The infotainment software shares space with the logs. The system needs to do at least some wear-leveling so there will be a nonzero amount of write amplification.
That, too, is an idiotic decision.
You can't expect all logging to happen within a mere few hundred megabytes of space, repeatedly overwrite that limited area without any amount of wear leveling, and expect the flash to last long enough for an industrial application where it needs to operate at least a decade.
 
Bob
Ahem.
See: "flash-optimised filesystems".
 
True but I'm inclined to think they just used ext4 rather than something like F2FS. It's unlikely that the problem of NAND endurance even crossed the developers' minds.
 
 
4 hours later…
5:03 PM
Does there something happen in SU? I got rep. down with "user was removed". I also see this in other >10K rep. users' activity.
 
5:43 PM
not just in SU.
 
 
2 hours later…
7:27 PM
mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm
 
nnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnn
 
lol
 
8:01 PM
o
 
 
3 hours later…
10:37 PM
Anyone here that can tell me how I can delete a system file as Administrator in Windows10? It seems something with my pending.xml in my WinSxS file is wrong and even DISM can not fix it anymore so deleting is my final option before I wipe my C:\ and reinstall the shit
 
have you tried from the cmd prompt?
 
Yes even running the cmd or powershell as administrator gives me an "Access Denied" error
How dare Windows give root an access denied error ...
 
tried stopping the services as well?
 
That would require me to know what service is accessing it
 
717
Q: Find out which process is locking a file or folder in Windows

leeand00How can I find out which process is locking a file or folder in Windows? For instance, when trying to delete a folder, Windows reports this: The action can't be completed because the folder is open in another program Happens the same with a file, but how do I find out what program or appli...

 
10:40 PM
stopping wuaserv did not work
+ Remove-Item .\pending.xml
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : PermissionDenied: (C:\WINDOWS\WinSxS\pending.xml:FileInfo) [Remove-Item], UnauthorizedAc
cessException
+ FullyQualifiedErrorId : RemoveFileSystemItemUnAuthorizedAccess,Microsoft.PowerShell.Commands.RemoveItemCommand
 
and did you check resource monitor?
 
What can I find there?
It seems the file is not locked by any process
Is there a difference in ownership from SYSTEM and an Administrator account?
 
perhaps you should ask this question on the main site now?
 
Well I rather have some interactive conversation while doing this rather than desperatly waiting for an answer on the main site
Especially as I want to go to bed soon and tell my mate to get over his installation medium again if I need to do a complete reinstall of my system
 
10:56 PM
psexec -s -i cmd.exe
can't be denied by SYSTEM if you are SYSTEM
 
psexec could not be found
 
Yea, it doesn't come with Windows by default: docs.microsoft.com/en-us/sysinternals/downloads/psexec
 
Downloaded the PSTools, running it as above with -s -i sadly only opens a cmd as "Administrator" again and I still get a "access denied"
 
run cmd as admin, then run psexec -s -i cmd.exe
then whoami
 
nt-autorität\system
 
11:08 PM
Still no luck removing the file?
 
Seems right but I still get an access denied
C:\Windows\WinSxS>del pending.xml
C:\Windows\WinSxS\pending.xml
Zugriff verweigert

C:\Windows\WinSxS>
(German here but whatever)
How hard can it be to freakin delete a file o.O
 
You're not really supposed to be touching anything in WinSxS anyway.... that's why SYSTEM owns it.
 
Well my problem is that Windows Update fails to upgrade my system to 1903 for a long time now and I want to get it done
It seems that something in the wusa.exe fails - getting logs or any information about WHAT fails was hard enough
Most guides recommend fixing the system with sfc /scannow
That fails because it says there are still system changes queued that should be resolved after a restart
problem is that nothing happens after a restart - ever
Using DISM to repair and remove all pending changes causes THAT command to also fail
THAT lead me to a solution to manually DELETE the pending.xml file
AND SOMEHOW I CANT DO IT tableflip
 
Since you downloaded PSTools, try the Handle application to see if it will tell you what has pending.xml locked
 
What name is it?
PsService?
 
11:18 PM
Should be in the PSTools zip, called Handle I think?
 
Nope
 
You could also use ProcessExplorer which you did get though.
ahh wait... maybe not.
It's all there on that site anyway.
 
Is it .\handle.exe FilePath?
 
I think so.
 
Ah it is just a string to match output against
But no, handle pending.xml says No matching Handles found
the File is not opened by ANYTHING
It just refuses to be deletad
Upgrading to 1903 via the mediaCreationTool also does not work "directly"
Creating a separate USB installation on an USB drive will allow me to do a complete reinstall of windows does it?
 
11:35 PM
@salbeira yup
Actually I think I have the same issue
Been putting off doing a rebuild
 
"Everything went to shit when I got my first Bluescreen in years while playing Sekiro" ...
in lieau of "Everything changed when the fire nation attacked"
 
Did you try takeown /f pending.xml ?
 
PS C:\Windows\WinSxS> takeown.exe /f pending.xml

ERFOLGREICH: Die Datei (oder der Ordner) "C:\Windows\WinSxS\pending.xml" gehört jetzt dem Benutzer "DESKTOP-F0N7VR7\Hauer".
PS C:\Windows\WinSxS> del .\pending.xml
del : Das Element C:\Windows\WinSxS\pending.xml kann nicht entfernt werden: Der Zugriff auf den Pfad "C:\Windows\WinSxS\pending.xml" wurde verweigert.
In Zeile:1 Zeichen:1
+ del .\pending.xml
+ ~~~~~~~~~~~~~~~~~
+ CategoryInfo : PermissionDenied: (C:\Windows\WinSxS\pending.xml:FileInfo) [Remove-Item], UnauthorizedAccessException
 
as admin?
 
I AM the Admin
Running powershell as administrator gives me that user
It is the only user on the system - me - and I am the administrator
well next to SYSTEM and some other default crap
 
11:40 PM
Yes, but you still have to tell Windows you want to act as the Admin.
 
I did
I am running the powershell as administrator (right-click etc.)
 
okay, now
cacls pending.xml /G :F
 
What does that program do?
 
modifies the ACL on a file
/G :F applies Full Control
 
Command successfull, del still returns error
Do I need to change access rights on the directory or something?
 
11:45 PM
I'd say no, but either way it seems you might be heading towards a reinstall of Windows. :|
 
OK just so I am prepared because ... well ... working with Arch Linux is WAY easier ...

When I finish creating the Windows 10 1903 installation medium on my USB flash drive and reboot my PC and make it boot from the USB drive

I will need that tool to reinstall Windows on my C:/ drive - that installation will propably wipe everything on C:/, correct? (I have the feeling under Linux simply replacing the C:\Windows directory with something that is fresh would WORK BETTER but hell if I know)
Right now I am running Windows 10 1803
All applications like video games I still have on C:/ should be moved to my different drives as they should (tm) be unharmed by a reinstall, correct?
Also backing up my home directory and simply copying all APPDATA from the old one to the new one should restore most settings of games and appliactions I use?
(Imagine it being 2010 and someone says "Installing and Administrating Arch Linux is easier than Windows")
 

« first day (3357 days earlier)      last day (34 days later) »