« first day (721 days earlier)      last day (1729 days later) » 

10:06 AM
@Zanna Have you used git push? Do you want to continue with that?
10:58 AM
not yet and not yet :/
No problem! :)
4 hours later…
3:02 PM
is it rack or rake or wreck?
rack = torture implement
wreck = terribly broken thing
haha a rake
My first thought for "rack" was "versatile rappel device for caving" followed by "thing to put coats on" but okay. :)
my mum uses it to scrape fallen leaves from the grass
@EliahKagan lol
it could be a shelf
"spice rack" is like a tiny shelf for tiny spice bottles in UK
also "rack and ruin" which is like a wreck... it is "rack" there, right?
People who rake rep points can rack everyone else by wrecking the website.
tongue twister
3:08 PM
@Zanna I don't think that's UK-specific.
also, is the reck in reckless a standalone word?
sure, but I don't know about other places
@jokerdino Apparently, but usually with a different meaning these days.
haha like, is there a word "reckful" which would mean like, really careful and thoughtful about stuff?
Also there is ruck.
3:10 PM
my math teacher would say "please do not be uncouth in my class. I would like everyone to be couth, even though it's not a word"
@EliahKagan I didn't know that
And according to that page, for some time (though humorous).
it definitely was back then too
I mean I don't know when you took that math class but "couth" was probably a word at that time too. :)
you could win at scrabble with this stuff
surely she can't be mates with Shakespeare.
3:13 PM
Well, the Scrabble rules prohibit looking things up in dictionaries while playing (except as part of a challenge to a play by another player).
do you have to give a meaning for the word you just played?
IIRC not under the official rules. Some people have house rules that demand that.
Great way to shame people with smaller passive vocabulary.
The most fun way to play IMO is where you have to use it in a sentence on request, but the usage can be totally made up and absurd, and one of your opponents still has to formally challenge if they want it looked up.
my friend Jana was allowed to use the English-English dictionary while playing because English was not her L1
she totally won every time
@EliahKagan that's a good rule :)
3:16 PM
I once tried playing lighting Scrabble, where each turn could only take like 30 seconds. That was actually not fun at all.
I take ages :(
Tournament Scrabble is timed but not with those kinds of times.
I think any time limit in Scrabble makes it less fun.
@EliahKagan I w4s thinking of scrabble-like online games where the built-in dictionary allows you to put in the word if it knows the word
yeah like a toilet break.
@Zanna Oh. Yeah.
3:18 PM
@jokerdino are you going to sneak a dictionary in there?
@jokerdino IIRC we figured out a reasonable exception for that before playing. But the game still wasn't fun.
@Zanna Oh, I thought the idea was, if you only have 30 seconds to play and you have to run off...
@Zanna I see you've found a better solution workaround to your A problem. :)
@EliahKagan haha well noticed
@EliahKagan you'd sit there uncomfortable and unable to concentrate haha
@Zanna You've really brought your... A game.
it's not much better as it still doesn't work in the terminal
at least my password doesn't have an a in it
@EliahKagan XD
@Zanna Your effective password entropy has just decreased.
3:22 PM
Unless really... it does have as in it and it's a ploy...
changes password
@EliahKagan possible
@Zanna You can probably make it work in the terminal, for 4s that appear in command names (rather than arguments), so long as the command as you typed it doesn't literally exist.
I could make aliases for all the commands with as and ds
@Zanna With a custom command not found handler I mean.
A better approach might be to make a command that runs the command you give it as its first argument with the arguments you give it as its subsequent arguments, but with 4s (and whatever else) translated.
That will work unless you build that command's arguments with shell expansions.
I mean, it will work then, too, but you wouldn't want it to.
3:29 PM
I think I need to buy a new laptop :/
Or a new keyboard.
Idk if you can replace the keyboard on that.
Or... actually, you can often buy new keys.
Or maybe if you were to pry the keys off you would be able to press on the contact and it would work more easily?
It would still not be ideal but it might be easier than hardly being able to use the key at all.
What just happened?
took it off and cleaned it a bit and it's working better :D
Oh cool!
I should have thought about it before my remove-the-key-forever suggestion. :)
3:34 PM
that suggestion was what prompted me to pull it off, so, thanks!
You're welcome. :)
But you shouldn't have said you did that. It could have been a security measure. You could have had a password with as. Intruders wouldn't know they had to take the key off and clean it to enter the password.
Only leet hackers with external USB keyboard would have been able to get in.
Or 1337, as it is said by people whose e keys do not work.
@EliahKagan hahaha
I have this little spray bottle of rubbing alcohol and it's so handy. I don't know where to buy such things here
The bottle or the isopropanol?
isopropanol - can reuse the bottle
87 messages moved from Raiders of the Lost Downboat
3:40 PM
You're welcome. I might've waited longer, but Natty stepped in to model an example of something on-topic in this room for us. :)
@Zanna If you can't find that, you might be able to use some other solvent.
What if you use a different keyboard layout like Dvorak
Impossible. You can't even type "Dvorak" without an a.
Speech to text?
I think if I ask in a pharmacy they might have it
3:45 PM
Makes sense.
@jokerdino chaos would follow
@jokerdino it won't understand my accent
@Zanna That sounds like it would work then. Chos is wht you're relly trying to sty wy from.
it's not completely fixed but an improvement
ளறைவஉாள டயலொரவள யஔன வசைநள வொ வலிந ைஔ நஔபடைளா
@Zanna This does work (subject to the caveat about expansions):
ek@Cord:~$ -() { "${@//4/a}"; }
ek@Cord:~$ - m4n 4pt
haha cool
@EliahKagan hahaha yeah. Chaos is acceptable but plz no chos
@Zanna I actually typed "switches layouts and tries to type in English", but when I put that into Google translate, I get "Absolute Dialysis Young Hairdresser"
3:59 PM
I'm not sure if this is the best way to do it for multiple substitutions, but this works:
ek@Cord:~$ -() { local -a args=("$@"); args=("${args[@]//4/a}"); args=(${args[@]//0/d}); "${args[@]}"; }
ek@Cord:~$ - git help 400
Yeah, I was wondering about that. But it works as an example: Google Translated back to English, it starts with "A".
12 messages moved from Raiders of the Lost Downboat
2 hours later…
6:09 PM
I'm not sure if 17.04->18.04 is possible in 1 step.
6:56 PM
@Kulfy When the next release is a non-LTS that is EOL, upgrading directly to the next LTS is usually supported, contrary to unfortunately widespread belief on Ask Ubuntu. In this case, though, I'm not totally sure, because not only 17.04 is itself unsupported, it's been unsupported for a while. My guess is that it will work.
Someone should test and find out. That person could be me if the 17.04 ISO download ever finishes. :)
I just moved to a place where I get some GB to use. Earlier it was unlimited :/
Otherwise I would have been downloading the ISO.
Whoa... Unity.
7:39 PM
@Kulfy It does work. I changed to the old-releases repositories, installed available updates, rebooted when asked to, and when I ran the Software Updater, it immediately offered to upgrade my 17.04 system to 18.04.2 LTS.
> Software updates are no longer provided for Ubuntu 17.04.
It means it offer upgrade to the nearest LTS version.
> To stay secure, you should upgrade to 18.04.2 LTS.
@Kulfy To the next LTS, yes.
To upgrade past that, they can just upgrade normally after the upgrade finishes (well, they should reboot first).
7:54 PM
I am still not totally sure that upgrading from Zesty to Bionic actually works. It's supposed to work, and did at one time, but I'm not sure it does now.
Clicking Upgrade... brings up a password dialog, and then after that the release notes, as expected:
But clicking the Upgrade button in the release notes gives me an error (and the error does not have much useful information):
> Can not upgrade
> An upgrade from 'zesty' to 'bionic' is not supported with this tool.
The same problem occurs running do-release-upgrade from the command line:
That's sad.
ek@Olde:~$ do-release-upgrade
Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:

Get:1 Upgrade tool signature [819 B]
Get:2 Upgrade tool [1,240 kB]
Fetched 1,241 kB in 0s (0 B/s)
authenticate 'bionic.tar.gz' against 'bionic.tar.gz.gpg'
extracting 'bionic.tar.gz'

Reading cache

Checking package manager

Can not upgrade

An upgrade from 'zesty' to 'bionic' is not supported with this tool.
What about brute force method? sudo sed -i 's/zesty/bionic/g' /etc/apt/sources.list and then update and upgrade.
I'll try it.
Is Zesty to Artful possible?
8:02 PM
Like by editing sources.list to use old-releases but with artful instead of zesty? Or with do-release-upgrade?
using do-release-upgrade.
Not that I know of. Artful has itself been moved to old-releases, so I wouldn't expect do-release-upgrade upgrades into it to work.
I think it ain't possible otherwise dialog would have shown 17.10 instead of 18.04.2
I think so too, though I could try seeing what the configuration file has.
I think brute force is the only method left. Or a complete reinstallation.
8:07 PM
/etc/update-manager/release-upgrades already has Prompt=normal, as I'd expect for a non-release.
I didn't expect an explicit -m desktop or -m server to do-release-upgrade to make a difference, but I tried it. It did not make a difference. I think you are right. I'm reluctant to recommend upgrading Ubuntu by manually editing /etc/apt/sources.list. It's never been a supported way to upgrade to a stable release of Ubuntu.
But I'll try it out and see if it works.
Q: Is editing sources.list a good idea?

KulfyThis doubt is hitting me since 2-3 days, so I decided to test it myself. What I did is I installed Ubuntu 16.04.4 in VMWare and edited /etc/apt/sources.list and replaced xenial with bionic using: sudo sed -i 's/xenial/bionic/g' /etc/apt/sources.list Then I ran sudo apt-get update && sudo apt-...

@EliahKagan Yeah. I asked a similar question an year back.
Well, I'm trying it now.
8:27 PM
@EliahKagan My upgrade attempt, in which I ran sudo apt update and then sudo apt upgrade with the intention of running sudo apt dist-upgrade (or sudo apt full-upgrade) after that, as recommended in recent Debian release upgrade instructions, did not go well.
I could try to troubleshoot that but I'm going to restore the snapshot I made before I attempted it and try running sudo apt dist-upgrade right after sudo apt update (rather than trying to run sudo apt upgrade in between).
Actually... I'll try and troubleshoot it a little bit first.
sudo dpkg --configure -a is doing a lot of stuff.
This seems to be working. After that, a couple things were broken, I ran sudo apt --fix-broken install and it succeeded, and I'm running sudo apt upgrade again. If that succeeds I'll run sudo apt dist-upgrade. If it all works, I'll still restore that snapshot and start over by running sudo apt dist-upgrade without attempting sudo apt upgrade first in case it's simpler.
9:04 PM
As far as I can tell, it worked. After runnning sudo dpkg --configure -a and sudo apt --fix-broken install (I suspect only the latter was actually necessary), I ran sudo apt upgrade again. This time it succeeded, and then I ran sudo dist-upgrade followed by sudo apt --purge autoremove, both of which succeeded. I rebooted into the new Bionic system, which appears to work all right. I've restored the old snapshot; now I'm trying it without the intermediary sudo apt upgrade step.
9:39 PM
That also worked, but not better. I ended up using the same commands to fix it in the middle so it could keep going.
sudo sed -i s/zesty/bionic/g sources.list
sudo apt update
sudo apt dist-upgrade
sudo apt --fix-broken install
sudo dpkg --configure -a
sudo apt install --fix-broken
sudo apt dist-upgrade
sudo apt --purge autoremove
sudo apt update  # showed that everything was done
@Kulfy I'll be afk for quite a while, I think. If anybody wants to use any of this for an answer or comments or to help figure out what should happen with posts or whatever, great!
Btw I don't know if these messages should be moved to the Island or not. They kind of tie in with discussion of posts in a way that may be hard to extricate, but OTOH most of them are definitely not directly about anything moderation-related. @Zanna

« first day (721 days earlier)      last day (1729 days later) »