« first day (1870 days earlier)      last day (3104 days later) » 

12:21 AM
I got the first hat!
 
1:01 AM
@egreg oh I have one as well, just in the profile page not on avatars?
 
@DavidCarlisle You can decide whether you want to wear them.
 
@egreg it doesn't suit my colour
 
 
7 hours later…
8:12 AM
@egreg Yay!
 
@egreg Lucky you
 
8:28 AM
@PauloCereda Early duck!
 
@egreg Shaking bus day. :)
 
@PauloCereda Quack
 
@PauloCereda Coin Coin ! :)
 
@ChristianHupfer Did you make any progress in designing and automated exam generation thingy? latex-community.org/forum/…
 
8:45 AM
@JosephWright Quack! :)
@RomainPicot coin coin! <3
In German, das Entenquaksound!
:)
Time to go to SP! See ya, friends!
 
@PauloCereda By the way, several hat can be earned with upvote, easy for you of course :-)
 
yo'
9:02 AM
@PauloCereda see you, and have a good trip!
@PauloCereda I hate hats solved my problems of not having any ;)
 
@yo' :-)
 
yo'
@JosephWright :)
 
@yo' System claimed I'd got one hat before I disabled it, but this did not make sense (as I went to bed at about 10 and certainly didn't vote or whatever before this morning)
 
yo'
@JosephWright I believe some of the hats can be earned without any action
(passive hats?!)
 
I got one hat without doing anything. Should I give it back?
 
9:18 AM
@FaheemMitha Which one?
@FaheemMitha I'm told I got 'Sufganiyot' but didn't do anything to earn it (and disabled hats as soon as I worked out how)
Ooh, new Skype web access
 
@JosephWright I also have earned 'Sufganiyot' on TeX.
I have no idea what that means.
 
@FaheemMitha OK, same one as me
 
yo'
@JosephWright See:
 
@FaheemMitha 'Post or vote on 14 Dec'
 
yo'
0
Q: Do not show hats to people who haven't visited the site

yo'I have seen a user who has not visited the site since Winter Bash has started, and still, his avatar shows a hat. In my opinion, this is at least disrespectful to them. Therefore I suggest that hats are shown only after the user has visited the site during the WB season.

 
9:32 AM
If they want to have a party, they should have a party. Not have lame hats.
 
yo'
@JosephWright strange that it appears to people who have not visited the site.
 
@FaheemMitha I've opted out (there's a reason that in previous years the site has not taken part ...)
 
@JosephWright Post what? I asked a question yesterday.
 
@yo' Indeed
@FaheemMitha No idea: I got the same 'hat' for no reason
 
@JosephWright Perhaps at least one question or answer.
 
yo'
9:34 AM
@JosephWright voting is enough, apparently, but this is strange. How can someone vote without visiting the site?!
 
They should have one called Mad Hatter. But they don't. Talk about missing a trick.
@yo' Telepathically?
A New Hope: post or vote on Dec 18?
 
yo'
@FaheemMitha is this the new computers inside brains thingy?
 
@yo' Got it first thing before doing anything
@FaheemMitha Star Wars
 
Oh, lame star wars reference.
Does SE work for Disney now?
 
yo'
@JosephWright that's what I speak about ...
 
9:37 AM
@JosephWright Yes, I just figured that out. Another crappy SW film being released on that date. Yawn.
Star Wars 7: The Pursuit of More Profits.
@yo' Perhaps. Ask Google.
 
@yo' Actually, I meant Google the company in this case, not the search engine. E.g. Google Glass.
 
yo'
@FaheemMitha :)
 
Can someone tell me what I'm doing wrong here if anything? I upgraded to TeX Live 2015 early this morning. This seems to have broken for some reason.
\documentclass[12pt]{scrlttr2}
\usepackage{mdframed}
\surroundwithmdframed[linewidth=2pt]{tabular}

\usepackage[T1]{fontenc}
\usepackage{fouriernc}

\begin{document}

\def\today{6th April, 2015}
\begin{letter}{Addressee}

  \opening{Dear,}

  \closing{Yours Sincerely}

\end{letter}
\end{document}
The \surroundwithmdframed bit seems to cause an error.
This didn't happen with 2014.
 
@FaheemMitha I'll try later on a system that hasn't been updated in a few days.
 
9:53 AM
@egreg Ok. To be clear, this is using the Debian binary packages, which probably aren't exactly up to date. Oddly, mdframed does not appear to have been updated for a while. Anyone else care to give it a whirl?
 
@FaheemMitha What exactly do you want to achieve?
 
@Johannes_B I don't understand the question. This is derived from an existing document which hasn't been updated in a while. When updating to 2015, compilation broke. I want to know why.
 
@FaheemMitha Probably KOMA has changed. A tabular is used to measure the width of the signature which is needed for correct placement.
 
@Johannes_B I don't follow. So you can't wrap a table any longer?
 
@FaheemMitha Not automatically without changing the \closing command.
 
10:05 AM
@Johannes_B Ok. Well, it looks like that line was not used anyway, so I'm commenting it out.
Still, I'd be interested in an answer. Should I post it as a question?
Also, can you reproduce the error?
! Missing \endgroup inserted.
<inserted text>
                \endgroup
l.158   \closing{Yours Sincerely}
 
@FaheemMitha Yes.
 
@Johannes_B Ok, good.
26
Literature

Proposed Q&A site for scholars and enthusiasts of literature.

Currently in definition.

 
@FaheemMitha vvvvvv
\documentclass{article}
\usepackage{mdframed}
\surroundwithmdframed[linewidth=2pt]{tabular}
\begin{document}
\newlength{\faheem}
\settowidth{\faheem}{%
	\begin{tabular}{l}
		lala
	\end{tabular}
}
\end{document}
 
@Johannes_B Some explanation would be helpful. Should I post a question?
 
@FaheemMitha I am not sure yet, what you are trying to achieve. You say you don't need \closing. If you don't need it, leave it out and the error will not appear.
 
10:13 AM
@Johannes_B \closing. You mean he thing that appears as part of the letter format?
That's standard usage.
 
@Johannes_B No, I answer too much questions and have to fight back complaints about style ;-)
 
@FaheemMitha Yes.
 
@Johannes_B I think I might as well ask a question about it.
 
@FaheemMitha Ok.
 
10:32 AM
\closing uses a tabular internally while measuring the width of itself. Surrounding that with a frame leads to the error message you encounter as shown in chat already. — Johannes_B 2 mins ago
Ok, but why did this work in TL2014, and why did it break now?
Just wondering about the mechanisms involved.
 
@FaheemMitha Probably, in TL2014 the \closing did not use a tabular. Markus has reimplemented and changed \closing several times in 2015 because users are doing strange stuff. I wonder what he looks like when he is made aware of your question. ;-)
 
10:52 AM
@Johannes_B Oh. Is he around here, then?
 
@FaheemMitha No, i think not. But esdd might give a hint. I don't know.
 
@Johannes_B Ok. This error occurs in only one document of mine (out of dozens of similar ones) and I don't even use the offending line. So I don't care about fixing it, as such. But I'm curious about what went wrong.
 
@Johannes_B I didn't understand your explanation, though.
Some elaboration would be helpful.
 
@FaheemMitha You cannot use an mdframe in a settowidth command.
 
10:58 AM
@Johannes_B So, to summarize, a settowidth command contains a tabular. So that \surroundwithmdframedcommand tries to wrap it? And that breaks stuff?
 
@FaheemMitha No, KOMA uses a tabular within settowidth. That tabular is surrounded by an mdframed environment, which doesn't work.
\documentclass{article}
\usepackage{mdframed}
%\surroundwithmdframed[linewidth=2pt]{tabular}
\begin{document}
\newlength{\faheem}
\settowidth{\faheem}{%
	\begin{mdframed}
	\begin{tabular}{l}
		lala
	\end{tabular}
\end{mdframed}
}
\end{document}
 
11:34 AM
@DavidCarlisle I see we are both bothering the LuaTeX list today
Who needs hats when you've got Hans to bug?
 
@JosephWright basically it's not stable enough to build latex on:-)
 
@DavidCarlisle Yup
@DavidCarlisle We really do need @HeikoOberdiek!
@DavidCarlisle Sometimes I get a bit frustrated that all of the testing seems to come down to the team's test suite, even though 'it's not our fault'!
 
@JosephWright Oh. :-D Burn
 
@Johannes_B Ok. You could add that as an answer.
 
11:50 AM
@JosephWright My new plan is to split up luatex85.sty to input shellesc.sty for write18 emulation and something like luatexpdfalias.sty for the \pdfvariable stuff, but remove all the blocking of Heiko's packages and instead put locally modified versions of ifpdf.sty etc that work, hopefully Heiko would find that easier to pick up. (especially if he answers your mod ping:-)
 
@DavidCarlisle Sounds OK: I'll mail you re. the last part
 
 
2 hours later…
1:30 PM
@FaheemMitha I tried with a non recently updated TeX Live 2015 and the error is the same.
 
@egreg Ok. I posted a question about this. @Johannes_B offered an explanation, but hasn't written an answer.
 
@FaheemMitha But it's a bad idea to do \surroundwithmdframed{tabular} to begin with.
 
@egreg Why?
I never actually used it, but I had that code in one file.
 
@egreg @FaheemMitha Agreed. tabulars are used all over the place where you don't ssuspect them. For example the author block of \maketitle uses tabular.
 
@FaheemMitha Because it's a lower level environment, used in various places where tables are not really involved.
 
1:33 PM
@egreg I see.
@Johannes_B Ok.
So if you want to wrap tables, are there better choices?
 
@FaheemMitha You can issue the \surroundwithmdframed command inside table
 
1:52 PM
@Johannes_B Pas du tout
 
@egreg :-)
 
2:10 PM
@DavidCarlisle a feature request for showkeys: the ability to whitch off the keys showing on \bibitem. Reasoning: We are preparing a multi author book (to be published by Springer). After I've edited each contribution, it is sent to the authors long side the source and a PDF copy of the book with all the labels showing, such that the authors can make cross references to the other contributions.
As each contribution/chapter has its own bibliography, those labels kinda disturb. Is there a simple method of disabling the \bibitem labels?
 
2:20 PM
@egreg Inside table? You mean taking table as an argument?
 
Of couse one can always do
\makeatletter
\let\normalatbibitem\@bibitem
\makeatother
\usepackage[notref,notcite]{showkeys}
\makeatletter
\let\@bibitem\normalatbibitem
\makeatother
 
Hi daleif.
 
@FaheemMitha Hi Faheem
 
\documentclass{article}
\usepackage{mdframed}
\begin{document}
\begin{table}
\surroundwithmdframed[linewidth=2pt]{tabular}
	\begin{tabular}{lr}
		dancing & duck \\
		busy & bee \\
		lazy & leguan\\
	\end{tabular}
\end{table}
\end{document}
@FaheemMitha ^^^^^^
 
2:36 PM
@Johannes_B Oh, I see. So if you invoke it inside a table environment, its scope remains in there?
 
@FaheemMitha Yep. Like any other environment.
 
@Johannes_B Ok. Excuse my ignorance.
 
@FaheemMitha Why ignorance? :-)
 
@Johannes_B Well, I've been using LaTeX since the 1990s. I should probably know such things.
 
@FaheemMitha If you do the very same task for twenty years, you do the very same task for twenty years. ;-)
 
2:49 PM
@Johannes_B That is undeniably true. :-)
Actually, I didn't think Tex has the notion of scope...
 
@FaheemMitha I found that in a fortune cookie once.
 
@Johannes_B Found what? That sentence above?
 
@FaheemMitha Yep.
@FaheemMitha My sentence above is not entirely true. There are always exceptions.
\documentclass{article}
\begin{document}
\begin{table}
	\def\printhello{HELLO}
	\printhello
	\gdef\printduck{DUCK}
	\printduck
\end{table}
\printhello
\printduck
\end{document}
 
3:19 PM
@Johannes_B ok
Still wondering how a macro language could have a notion of scope.
 
@FaheemMitha There's a save stack
 
@JosephWright Oh, there is? In TeX?
 
@FaheemMitha Yes, used for local assignments and popped at \endgroup, }, ...
 
@JosephWright I see.
What's with that Kek Dose guy? Weird.
Hmm, @JosephWright isn't he that attorney you pointed me to the other day?
 
@FaheemMitha Yes
@FaheemMitha What's up?
 
3:32 PM
@JosephWright Not much. He just posted a weird comment on my question.
 
@FaheemMitha Ah, found it
 
Maybe it's special legal humor or something.
 
@FaheemMitha attorney?
 
@Johannes_B Yes, see his profile. I asked the other day whether there were any lawyers on TeX SX. Joseph pointed me to Keks Dose (probably not his real name).
 
@FaheemMitha The comment was directed to @Johannes_B, not to you.
 
3:36 PM
@egreg lalala
@FaheemMitha Keks Dose is the german word for cookie jar. ;-)
 
@egreg True. Still weird, though.
@Johannes_B Oh, I see.
 
@Johannes_B I find the comment pretty useless; if he had already spent time on the topic, the fact that someone else says something about it doesn't give the time back.
 
@egreg I looked at at few old and unanswered questions today. I quickly skim the question, look at the comments and ping the user with the most suitable answer.
 
28
A: What professions use TeX/LaTeX besides CS?

Keks DoseI'm an attorney at law in Germany and writing all contracts and motions using LaTeX. Word tried to outsmart me too often; and especially while under stress working against deadlines I found that very annoying. Using LaTeX I can get printed things exactly as I wish it, which is also very important.

I wish the lawyers here would use TeX.
Though TeX can also break at unopportune moments.
Of course, one could make the case that Word is permanently broken.
@JosephWright Ooh, attorney number 2! :-)
 
Egreg, I love you! — jnrk 1 min ago
 
3:45 PM
@egreg Expanding your fan base? :-)
Shouldn't that be an answer, though?
 
3:57 PM
@FaheemMitha I'm not a machine! Leave me some time! :)
 
@egreg :-)
 
Oh, by the way! This morning my train was one hour late, but something lifted up my spirit: I received a text SMS telling me I won one million €!
 
Congratulations.
 
4:19 PM
@FaheemMitha They left an email address. Do you think I should contact them? ;-)
 
@egreg No.
I made the mistake of giving Ebay India my mobile phone number recently. Now I'm getting text message spam. Lovely.
 
@egreg If you don't want it, give it to me!
 
@DavidCarlisle Interesting discovery with the LuaTeX ini business: Hans has remove e.g. tex.pdfpageheight in v0.85 but only just added a new interface today following my mail. So there's a 'gap' with no Lua interface to set these things :-(
 
@JosephWright I'm sure all changes are fully tested
 
@DavidCarlisle I've just spend about 15 minutes wondering 'why is my Lua not setting the values' with the v0.85 release, and finally checked print(type(... from IniTeX mode!
@DavidCarlisle I can see why Hans didn't mention this plan when we were physically in the same place :-)
 
4:35 PM
@JosephWright surely you wouldn't have resorted to physical violence:-)
 
@DavidCarlisle No, but I might have resorted to talking to him (and to Heiko)
 
@JosephWright That would have been a plan, maybe we should set the delorean to 2015 not 1982
 
4:49 PM
@DavidCarlisle Nah, it's in euros and you Britons dislike them.
 
5:09 PM
Not sure what a 'good' answer is here
 
@JosephWright Too broad? ;-)
 
Wow, that's a chatty question. Clearly an accomplished procrastinator.
Have there been major changes in LuaTeX recently?
 
@FaheemMitha Yup
Writing an answer now
 
@JosephWright ok
What's the schedule for TL2016? And will that wait on LuaTeX 0.85?
 
@FaheemMitha v0.85 is 'released': the idea from Hans is to have v0.90 for TL'16. That means he's got to get it done by ~ April
 
5:26 PM
@JosephWright Wow. That sounds like a lot of work.
So TL2016 in April?
 
@FaheemMitha Testing usually gets going about then
 
@JosephWright ok
 
@daleif that's more or less best you can do at moment you can skip the first let as showkeys saves the definition as \SK@bibitem could look at it if I have any strength left after luatex updates...
@JosephWright your answer looks good and was accepted:-)
@FaheemMitha "major changes" being a polite way of saying 0.85 is incompatible with every previous version of luatex and pdftex
 
5:46 PM
@DavidCarlisle -- at ams we've been trying to test the latest version of the stix fonts with the intent of getting a decent public release in the foreseeable future. we have had to abandon any thought of testing with luatex ... just too many incompatibilities. i'm not sure whether we will have to attach a caveat to the stix release when it happens, but it seems to be looking that way.
 
Greetings
Once I've established the title of a section (that might be long), how can I reuse of refer to it without writing it again? Should I put a label?
 
@barbarabeeton I don't think the luatex 0.85 changes will affect you that much, most of the relevant changes are in the macro layer which is just broken if you try to update the engine and use existing input to build a format. but assuming texlive 2016 builds a lualatex format at all that will have been fixed more or less transparently, at which point you can then start to test if the updated font loader fixes any issues you have with stix fonts
@OFFSHARING default \label/\ref just saves the number but lots of packages provide variants that save the name as well nameref for example
 
@DavidCarlisle It disappeared now ... (only the number remained in place)
 
@DavidCarlisle -- even with the previous version there are problems that, while perhaps not intractable, consume too much time to debug to permit us to attend to the questions that have arisen with xe(la)tex.
 
Nice hat @OFFSHARING...
I like the fact that one can opt out of it on an individual basis...
 
5:59 PM
@Werner :D
@Werner I don't manage to reuse the name of a section within a book. Might you have some useful clues?
 
@OFFSHARING Please explain a little more...
 
@Werner I mean when I wanna refer to that title I don't wanna write the long name again but to use something like label and ref. However label and ref don't work.
 
@OFFSHARING Typical \label-\ref only uses numbers.
 
@Werner yeah, right ...
 
If you want to retrieve titles, you either need to use something like titleref or nameref.
 
6:05 PM
@Werner label and nameref or? OK, let me check.
 
@OFFSHARING Yes, \section{something} \label{sec:something} ... \ref{sec:something}... \nameref{sec:something}.
 
@Werner it doesn't work.
\subsection{\titleref{tapowerful}}
! Undefined control sequence.
<argument> \titleref
{tapowerful}
l.119 \subsection{\titleref{tapowerful}}
 
6:31 PM
@OFFSHARING: What about when you try with nameref? Also why do you use it directly in the title of another sectional heading?
 
@OFFSHARING Worked fine here, did you add \usepackage{titleref}?
 
@Werner This is because my table of contents contains certain chapters, then I used the same names for the section with hints, and the same names for the ones with solutions. The thing is I want to have an automatic change of the name also in the hints and solutions sections when I change the name of the chapters.
@TorbjørnT. No, I didn't. But it doesn't work in either way. I tried with nameref, but the same thing.
 
@OFFSHARING The error you showed (undefined control sequence) comes from not adding \usepackage{titleref}. Both nameref and titleref worked with my MWE though, so more info (i.e., a minimal example) would be nice.
 
6:46 PM
\section{AAA} \label{power}
\subsection{\nameref{power}}
@TorbjørnT. This should work but it doesn't. I'll try a bit later. Maybe I do something wrong.
 
@OFFSHARING Not a complete example, and exactly that worked just fine here. Had to delete the .aux file, but that was the only problem.
 
By the way, Is it OK to delete .aux files? I'm often asked to do that. Otherwise I cannot run the file.
@TorbjørnT. Thank you for your support!
 
@OFFSHARING The .aux file is used for references. If there is a problem with a previous run that deals with references, it could affect the current run as the .aux is read at \begin{document}.
 
@OFFSHARING Yes and no. They are re-generated every run, so there's no problem with deleting it if it has become corrupt. But it's needed to get cross-references to work, so you can't delete them after every run, as refs wont work.
 
So, it's okay to delete it, since it will be regenerated at the next run.
 
6:52 PM
@OFFSHARING Read my whole comment please.
 
@TorbjørnT. Got it!
@Werner OK, perfect.
I possibly make many mistakes after 16 (or more) hours of (crazy hard math) work per day, or more.
 
7:08 PM
@OFFSHARING Yes, that's a possibility. :)
 
 
1 hour later…
8:17 PM
@barbarabeeton I think a reasonable approach is to get the fonts working with xetex and if luatex does something different push that to luatex as a possible bug, anyone watching @JosephWright and me chatting here will note that there are plenty of those, but they tend to get fixed quickly.
 
@DavidCarlisle -- essentially, that's what we're trying to do. i hope we know more by this time next month.
 
8:41 PM
@DavidCarlisle I think I've got all of the .ini files (plain/LaTeX2e) sorted :-)
@DavidCarlisle lollipop is outstanding ...
 
8:53 PM
@JosephWright saw the mail, not tried it yet
 
@DavidCarlisle ok
 
9:36 PM
@DavidCarlisle You've got mail. I found some obscure characters that can be dealt with in T1.
 
@egreg thanks, will look make a nice change from luatex 0.85 :-)
@egreg thanks, more work for me!
 
@DavidCarlisle Just a few. ;-) Not sure there's actually some language that uses them.
 
@egreg the earlier plan that everyone use english has some appeal
 
@DavidCarlisle :-)
 
9:52 PM
@DavidCarlisle And steal us the niceties of the differences between “ne” and “né” (the former is a pronoun, the latter a conjunction) and between “se” and “sé” (the former is a conjunction, the latter a pronoun)? Guess the rule! Hint: there is one.
 
@egreg we British people don't need such easy hints as squiggles over letters, just use the same spelling with different meaning and use powers of deduction to distinguish the context
 
@DavidCarlisle Like Sherlock Holmes. All you need is a good magnifying glass.
 
10:30 PM
@DavidCarlisle Don't tell me you have a monocle in your pocket. :)
 
@PauloCereda I have two! (usefully joined together with a bridge over the nose and arms that extend back over each ear).
 
@DavidCarlisle what a complex scheme! Oh wait, I have one of these too. :)
 
11:28 PM
@PauloCereda Do you know that eyeglasses were invented in Veneto? en.wikipedia.org/wiki/Glasses#Invention_of_eyeglasses
@PauloCereda Glass production was transferred to Murano from Venice in the 12th century and probably they already knew how to make eyeglasses.
 
@egreg Interesting.
 
hi there, anyone still up?
 
11:46 PM
@egreg clearly nonsense, evidence of prior art:
@Rico no:-)
 
@DavidCarlisle lucky me :D @egreg already found my question
 
@egreg Do you need to use expl3 to automatically transpose a matrix?
@DavidCarlisle Still up? And egreg too.
/me wonders what a marine transpose is.
 
@Rico I get no error
 
@egreg Please check that my edit of that matrix transpose question is sensible. Thanks.
 
@FaheemMitha It's just a convenient framework
 
11:54 PM
@egreg So it can be done without?
 
@egreg I don't get an error eather, but the code won't be highlighted
 
@FaheemMitha anything done with expl3 can be done without
 
@DavidCarlisle ok
 
@Rico I guess it has to do with color management in cleanthesis
 
@FaheemMitha less efficient of the computer time more efficient of human time, is teh normal way of higher level languages
 
11:56 PM
@DavidCarlisle Ok. But expl3 is more efficient, presumably.
 
@Rico It's draft=true
 
@egreg this is what I was thinking, any ideas on how to correct this?
 
@Rico Yes, see above
 
@DavidCarlisle Yes, that's what I meant.
 
@egreg no way -.- I lost 4 hours searching for the error
 
11:58 PM
@FaheemMitha also @egreg likes to use expl3 in answers, it means he doesn't have to remember to put % at ends of lines.
 
@DavidCarlisle Exactly!
 

« first day (1870 days earlier)      last day (3104 days later) »