« first day (1170 days earlier)      last day (2397 days later) » 

12:04 AM
@Pickett Really?? What the hell, they told me, that my site will be one of the first. And I though I was special to them... :-)
 
 
2 hours later…
1:54 AM
@halirutan The email was probably meant for you, everybody else got it by mistake :S
 
 
2 hours later…
4:14 AM
I think it's not the first time I have managed to buy an upgrade considerably earlier than when WRI has cared to actually inform me it's available.
 
 
1 hour later…
5:28 AM
anyone around? i wrote a fancier version of Spelunk that i thought I should probably tell people about
 
 
3 hours later…
8:26 AM
@TaliesinBeynon Thanks for the information 2 days ago. I was just looking into JSON because some else asked a question and I was helping him find the reason.
@TaliesinBeynon Yes. Please let us know. Do you have it on GitHub as Gist or as repo? Just post the link, that would be awesome.
 
 
4 hours later…
12:49 PM
@TaliesinBeynon When or if it's ready, you could post an answer to this question:
40
A: What is the most convenient way to read definitions of in-memory symbols when we don't have the source files? (Spelunking tools)

Simon WoodsLink to the code on GitHub I have been using this. It's mostly Leonid's code from the stackoverflow question you linked to, but it uses Definition instead of DownValues. Symbol names are printed without any context, but the full symbol name is put into a Tooltip so you can always find out what...

 
1:36 PM
Hi there
 
@halirutan seconded!
 
Can someone please check me the output of these under v 10.0?
StringCases["1472", Except["0", DigitCharacter]]
StringCases["1472", Except["0", DigitCharacter] ~~ "0" ... ~~ EndOfString]
Mind: NOT under v10.1.
 
10.0.2, returns {"1", "4", "7", "2"} and {"2"}
 
Thanks blochwave!
It is {"1"} and {} under v10.1. Wonder what has changed internally...
 
@IstvánZachar It actually breaks an example from the docs for Except. I had assumed all of the doc examples were part of the automated tests.
StringReplace["1a2b3c4", Except["a", LetterCharacter] .. -> ""]
The docs say it should give 1a234 as we'd expect. However, it gives the original string when you re-evaluate it.
 
1:49 PM
@MichaelHale Hmm, yes you're right. This update seems a bit rushed: many doc.pages still have the [[EXPERIMENTAL]] tag on themcheck e.g. ToTitleCase.
 
@IstvánZachar Are you going to report this?
 
@SjoerdC.deVries Yes, just right now
 
Already sent them another bug yesterday.
@Sjoerd, You think a post should be useful here at MSE?
 
@IstvánZachar Well, it could help people pin down bugs they themselves encounter and we'll have another test case in the "bugs" tag.
Nasser had another one
1
Q: BoundaryMeshRegion::buncl error in V 10.1, that works ok in V 10.0.2

NasserThis code works ok in V 10.0.2 (from a post I was looking at here) I noticed what seems to be a regression bug. This code works in version 10.0.2 on windows 7 Clear[t] tmp = RevolutionPlot3D[{2 + Cos[t], Sin[t]}, {t, 0, 2 Pi}, PlotPoints -> 2]; tmp = GraphicsComplex[tmp[[1, 1]], tmp[[1, 2, 1...

 
1:56 PM
The problem is, I don't really see what is the problematic part - is it the internals of Except or perhaps new pattern functions are used internally (like OrderlessPatternSequence)? Anyway, I'll put up something soon then.
 
@IstvánZachar It's peculiar that it returns all cases that are preceded by a 0 or start of string:
StringCases["104702", Except["0", DigitCharacter]]
{"1", "4", "2"}
 
Wow. That is definitely strange.
 
Temporary workaround I suppose: StringCases["104702", DigitCharacter?(! StringMatchQ[#, "0"] &)]
 
2:22 PM
0
Q: String-manipulation bugs in v10.1

István ZacharThe new version 10.1 has introduced some strange (possibly buggy) behaviour compared to v10.0: StringCases["1472", Except["0", DigitCharacter]] (* v10.0 *) {"1","4","7","2"} (* v10.1 *) {"1"} Since StringCases["1472", DigitCharacter] returns {"1","4","7","2"} (all the characters) I would e...

Please consider adding your workarounds as answers!
 
 
2 hours later…
4:18 PM
@IstvánZachar The "experimental" tag isn't an indication of rushing, it's a way for us to expose functionality that we think may not be quite designed right, or that we otherwise want feedback on, without committing ourselves to it.
@halirutan so to use the new spelunker in 10.1, write Get["GeneralUtilities`"]; PrintDefinitions[symbol];
10
that will pop up a window that shows all values (down, up, sub, attributes) of symbol. as with spelunker, hyperlinks will be injected as appropriate. it also sets the cell context to try to reduce the amount of clutter from fully qualified private symbols etc.
@halirutan a nice side benefit is that the cell can actually be executed... in other words if any cell that PrintDefinitions produces can be edited and rerun to patch that definition, which is sometimes quite useful for debugging other people's code :-)
 
4:37 PM
@TaliesinBeynon Thanks for the clarification, I didn't know that.
 
@TaliesinBeynon Oh, nice. I'll give it a try as soon as WRI decides to carry out the update to Leipzig :-) Thanks a lot!
 
@halirutan I've tried it, works nicely so far, though the gray bg makes it hard to appreciate syntax highlighting.
 
@halirutan @IstvánZachar @MichaelE2 I have added an answer to mathematica.stackexchange.com/a/78898/7140 that mentions PrintDefinitions. Thanks.
 
4:54 PM
@TaliesinBeynon So, now I know that it does not accept the option Background... : )
Nice work, btw!
 
@IstvánZachar thanks. there are some other interesting new things in GeneralUtilities but maybe people will find them on their own since they have PrintDefinitions :-)
 
@TaliesinBeynon Well, I'm doing it at the moment...
 
 
2 hours later…
7:31 PM
posted on April 02, 2015 by Vitaliy Kaurov

You may have heard that on March 20 there was a solar eclipse. Depending on where you are geographically, a solar eclipse may or may not be visible. If it is visible, local media makes a small hype of the event, telling people how and when to observe the event, what the weather conditions are, [...]

 
 
3 hours later…
11:00 PM
Did you know Context was assignable? Context[x] = "foo`"
But the symbol is still found even if foo` is not in the context path.
 
11:13 PM
0
Q: Why is a symbol still found after changing its context?

SzabolcsIt seems that we can change the context of symbols: In[1]:= x = 1 Out[1]= 1 In[2]:= Context[x] = "foo`"; But then x is still interpreted as foo`x even though foo` is not in $ContextPath. In[3]:= x Out[3]= 1 In[4]:= foo`x Out[4]= 1 The behaviour is not consistent though. At other times I ...

 
when was V10.1 released? I'd assumed I'd get an email about updates
 
@MikeHoneychurch I got the email 1.5 days ago, some others got it maybe 3 days ago.
It was titled "Your Mathematica for Sites license has been upgraded"
So is it a paid or a free upgrade for those who have an individual license?
 
@Szabolcs come to think of it I never got an email for 10.02 either. Was there a release in between 10.0.2 and 10.1?
 
@MikeHoneychurch No.
 
Have anyone experienced high CPU usage in verion 10.1? I'm doing nothing but the frontend uses 100% of my CPU.
2
 
11:34 PM
@xslittlegrass what OS are you?
 
@TaliesinBeynon Mac
And I'm using a remote kernel on Linux
@TaliesinBeynon And I have tried different versions of the kernel on the remote machine. It looks like both version 9.04 and version 10.0.2 kernels give me problem.
The problem only happens on my mac where the version 10.1 frontend has a high CPU usage. I have checked that the remote kernels behave normal on the remote end (no high CPU usage).
And both 10.0.2 and 10.0.1 frontends on my mac don't have this problem.
On the remote machine, I don't have the version 10.1 kernel, so I haven't tried the new version yet.
 
11:59 PM
@xslittlegrass i have noticed this too the last few days, actually
 

« first day (1170 days earlier)      last day (2397 days later) »