« first day (13 days earlier)      last day (354 days later) » 

6:03 AM
@Caleb, @OliverSalzburg, ok, so I created accounts on opera and firefox. Are we ready to upload them or not? And if so, should we include the extension files in the release on github?
1 hour later…
7:20 AM
@benjol I'd say, go for it. Putting the packages on GitHub is nice because of the long review periods
@OliverSalzburg, ok. I'll try. Have you ever added extensions on Opera? The preview of the 'markitup' editor doesn't seem to work properly...
@OliverSalzburg, and erhm, is the xpi for opera and firefox?
7:38 AM
@Caleb, @OliverSalzburg what license?
@benjol Sorry, I'm on mobile right now. I will answer when I'm at the office
7:55 AM
@OliverSalzburg, no worries. the Firefox one is 'up'.
8:11 AM
@Benjol Yeah, I've submitted to Opera before. I don't remember any issues with an editor though. Maybe I used plaintext
@Benjol XPI is Firefox only. Opera is the same as Chrome
@Benjol I usually use MIT choosealicense.com
@Benjol Seems like the markdwown links at the bottom of the description are broken
@Benjol I'd say we could include the built extensions using GH's release thingy, but I wouldn't want them in the repo itself.
Although I'd also say it's probably not necessary. People that are worried about the long wait for new versions an use the userscript version it any of the browsers with some fiddling.
@OliverSalzburg So GPLv2 looks good to me
@OliverSalzburg Fixed
@Benjol GPL would be my default choice because I like the share-left requirement but either way works for this I think. It's your project and whatever you decide, these of us contributing code just have to be fine with. And I'm good either way.
wtfpl.net is usually the best choice ;D
8:28 AM
@OliverSalzburg, I did hesitate :)
@Benjol Unfortunately --- it installs but does not seem to function for me here.
@OliverSalzburg, I'm not even sure I'm in the right place on Opera (I haven't installed Opera in ... a long time, so I'm a bit out of date). I'm at apps.opera.com
@Caleb, I just tried, seems ok here. I've got two auto links (one from GM), but they both work
woops, except it says that it is version :(
@Benjol I've got none. I know it worked the other day for me in testing, but I removed my test build and disabled the GM one before testing.
@Benjol I tells me 1.3.3
@Caleb, no, sorry that's me: I didn't notice it had sent me to scripts page...
@Caleb, only seems to work on SO...
@Benjol Ok I can confirm that it works on SO for me too.
8:40 AM
Poor little chat reply helper, all alone :( addons.opera.com/en/search/?query=stack+exchange
I just installed built myself and it doesn't work either. What did we break?
Are you guys testing the userscript?
@OliverSalzburg No. Firefox XPI.
@Caleb I could understand it not working at all, but only working on SO is really weird.
Does it maybe only work on http*://*stackoverflow.com/questions*?
8:44 AM
The userscript build for works perfectly in FF / GM.
Could be related to the way the target sites are created for the XPI
I have to install ant here at work to see what's happening
@OliverSalzburg Are the target sites elsewhere than in the userscript inside the xpi?
btw, it makes more sense to include the .crx in the release instead of the webstore.zip
@OliverSalzburg, ok, so that works for opera and chrome? what's the webstore for then?
@Benjol Humm, I guess not. But maybe the format is more restrictive
@Benjol To upload to the Chrome Webstore ;)
8:49 AM
@Benjol webstore is for summitting to the store, not for instalaling and running.
...which doesn't accept CRX
They build a crx after you submit, but if we are distributing a package for people to use it needs to be the crx.
1.3.3 FF XPI works fine on SuperUser for me
@OliverSalzburg, weird
@Benjol The target sites are also listed in content/loader.js in the XPI, but it looks like they are all there.
8:52 AM
serverfault too
not meta.SO
@Caleb Good catch
Ok SU works for me too, se we are testing the same thing.
@OliverSalzburg, have you tested the crx on Opera ever?
@OliverSalzburg I wonder if it needs *.stackexchange instead of just *stackexchange.
@Benjol Probably once, yeah ;)
8:53 AM
I bet not having that dot is killing us.
OK, because it's asking me the question :)
@Caleb Quite possible
Testing now.
Humm, I edited both the loader and the JS with a dot, still doesn't work on meta
@Benjol Gives me a 404, probably until after review
8:56 AM
@OliverSalzburg, ok
no markup, no html, nothing for the description :(
If the XPI doesn't want to work, feel free to create an issue and assign me. I'll read up on the specs for the URL pattern
what do they want, ascii art?!
@Caleb, @OliverSalzburg, should I mark #9 as resolved, or do we need to wait for a definitive answer from @derek?
@Benjol At this point, I'd probably like it better if you simply released all the extensions :P
Yup that was it. I'll push my branch up it a sec.
@Caleb, is it worth pulling in other things too (derek's icons for example)?
9:02 AM
Worked in FF, now it doesn't work in Chrome.
@Benjol Yes.
@OliverSalzburg Well, it would be more logical, but I can't force him...
I based off of my hotfix branch, so it has all that yes.
@Caleb It works for you with the extra dot?
@OliverSalzburg Yes.
@Caleb, nice. But that breaks Chrome? Or something else was already broken?
9:04 AM
@Benjol That works in both. my first attempt had another issue.
I'm removing answers.startups too, it is closed.
@Caleb Oh, you need both?
Does that still work with the other browsers? I already have special rules for Chrome, because it doesn't like http*
@OliverSalzburg Actually it seems we need a lot of things. I haven't found the bottom of the rabbit whole yet.
@OliverSalzburg Ya that was wrong from the start. Should be https?:// anyway.
(Grease|Tamper)monkey appear to be much more lax, and FF/Chrome have different things they are picky about.
Why do I feel like it's the '90's again?
That appears to be the FF best, but chrome is not happy. I suspect that might have to do with however you hackded http* @OliverSalzburg, where do I find that?
@Caleb That would break the special Chrome rule though ;D In Chrome you either need two entries which specify http and https specifically, or you need to use *
Found it.
The build script replaces http* with * for Chrome right now
9:32 AM
Got Chrome and FF working, now the userscript doesn't work. Genius.
@Caleb, quirksmode :D
@Caleb I was already thinking about programmatically generating the list
@OliverSalzburg Not a bad idea. Lets figure out what the list needs to be for each and get it in this dot release, and then clean up the mess for next cycle.
9:48 AM
@Caleb It will require some serious ant-fu :P
Or maybe some very simple inline JS ;D
Just noticed I committed fa69c93 with my work email... :(
10:03 AM
I got FF/Chrome/Userscript all working bit I screwed up git somehow and am having trouble straightening out my commit.
@Benjol Is that bad?
@OliverSalzburg, I don't like it. OCD :)
@Benjol Well, if you didn't push it yet, you can easily revert it
@Benjol Let's wait until he gets a non-broken version submitted, which he still hasn't done.
@OliverSalzburg Too late. It's not on master, but it's pretty far up in the history of devel. Oh well... I don't think it will ever show up in master because that change is already there.
10:15 AM
@Benjol @OliverSalzburg Here is what I've got. I tested 4 cases (FF, Chrome, Tampermonkey, Greasemonkey) and half a dozen sites (SO, 2.0, metas, https) each and it seems to work. Opera not tested.
ok, I'll try building that and uploading it...
@Caleb Nice work
@Caleb It's usually pretty safe to assume that it works in Opera if it works in Chrome
...and vice versa
@OliverSalzburg That's new. Last time I used Opera it was basted on presto and was a different animal.
OK, so I've uploaded the new version to mozilla
@Caleb Yeah. Now that it's based on blink CHromium though...
10:22 AM
@Benjol Still doesn't work for me :(
@Benjol Uploading a new version resets your queue position in the review process btw ;)
@OliverSalzburg Webkit at least. So Safari / Chrom(e|ium) / Opera all have the same layout engine now. Webkit really took over.
It's a good thing to keep in mind if you ever want to get through it :P
@Caleb They actually moved to Chromium
10:24 AM
@OliverSalzburg Wow, huh. So what's the point? The suit of other stuff?
@Caleb better/worse/nochange?
@Benjol Worse doesn't even work on SO.
@OliverSalzburg, just tried uploading new crx to opera, says: There is a syntax error in manifest.json. Please correct it and try uploading again. The parser reported: Expecting value: line 17 column 9 (char 390)
@Caleb, maybe I screwed something up in the build?
My local build works perfectly, the store version does nothing.
@Benjol Does your build work for you in FF if you install it locally?
@Caleb Slightly different UI, I guess. And not being a Google slave ;)
10:27 AM
@Caleb, no
I checked out d680e6
@Benjol Hard to say. I can't easily check it right now
did ant from bash
and :(
Any useful messages?
% ./build.sh                                                                                                  12:28:46
Buildfile: /home/caleb/projects/SE-AutoReviewComments/build.xml

    [mkdir] Created dir: /home/caleb/projects/SE-AutoReviewComments/build/autoreviewcomments


     [copy] Copying 1 file to /home/caleb/projects/SE-AutoReviewComments/build/autoreviewcomments






(for comparison)
Ugh, my Java installations are a huge mess. As always on Windows!
@Benjol Try the version in my dropbox on your FF.
10:34 AM
@Benjol So, what's in your manifest.json at that position?
I have
@Benjol Installs but does nothing. So it's not the store process, it's our build process that makes a working ext for me and not for you.
@Caleb, line endings?
at a guess...
yours works for me.
Not a bad guess. Could be and ant thing processing those string replacements.
Oliver was building this on Windoze though so I'm a little surprised.
10:39 AM
@OliverSalzburg ${sites-chrome-list} :(
Was just going to point that out.
@Caleb, it's probably me. Maybe my git settings are wrong for line endings? (I thought I'd fixed them)
@Caleb, pending that, I've uploaded your version to mozilla
@Benjol Works.
Installing opera :(
@Caleb, line endings are definitely different
@Benjol Well, there's your problem :D
10:42 AM
@OliverSalzburg, thanks a bunch...
There should be some information regarding failure to replace tokens in the ant build log though
@OliverSalzburg, I'll try again
I would have to reboot to get my Java problems straightened out
aarahghg. Opera has stolen all my file extensions :(
A: Why should I use core.autocrlf=true in Git?

VonCThe only specific reasons to set autocrlf to true are: avoid git status showing all your files as modified because of the automatic eol convernsion done when cloning a unix-based eol Git repo to a Windows one (see issue 83 for instance) and your coding tools somehow depends on a native eol styl...

@Benjol I hate that feature, I always use UNIX line endings everywhere :P
10:50 AM
It looks like the Chrome store is no longer requiring money for uploads, but that might be because I had an account from way back. I'm wondering if it wouldn't be best to get you uploading that too. It's one thing to have a bottleneck at the owner of a project, it's another to have it sideways.
Like, I'm checking out a bash script from git and copy it over SSH onto a test system, and then it has CRLF endings... so annoying :P
In other news, opera crx works (if installed from local)
(that is, the one that @Caleb built)
@Caleb the last I saw it wanted me to be on Google+, which I've resisted so far :)
I guess I could always create a dummy account, but what do we do about having a duplicated extension?
@Benjol Ask Derek to withdraw the existing one I guess. I don't thing there is a transfer / upgrade path unless we give him a special EOL version that prompts users to switch.
autocrlf = false
git reset --hard HEAD
(can't remember how to do multi-line code comments)
Opera is RUDE, stole the default browser setting without asking my opinion
@Benjol Four space indent, normal line breaks (SHIFT+ENTER to avoid Send binding).
@Benjol Not cool.
10:57 AM
@Caleb thanks. OK. So where were we before all that? :)
@Benjol Not sure. I think the broken FF extension was where I got started today.
One-time developer registration fee required :(
I guess I should bite the bullet, but it irks me more than it costs me
@Benjol I must have paid my dues on that score back when ADP1 was coming out.
And it wants me to sign up to Google wallet too :(
@Benjol Welcome to the ecosystem. I feel your pain although I've been under the influence so long I hardly notice it any more.
11:08 AM
@Caleb, well I'm pretty tied in, but each extra coil make me feel worse ...
@OliverSalzburg, It's telling me "Short name: Not specified in manifest"
just in case...
@Caleb, is it rude to pinch derek's screenshots? They're very picky about dimensions
@Benjol Didn't he pinch yours and crop them? I don't see an issue with that although at some point we could probably collect a full new set for docs and store submissions.
@Caleb, I think I should ping him before submitting... though I've already parted with the $5 :(
@Benjol Probably.
In that case it's also probabaly best he does not update his version. The particular way it is broken is it has the auto-updater running pointing people back at the site home page and userscript version. That bug will actually help get people rolled over if we put an announcement on the app page about the new location.
@OliverSalzburg Your link helper comes up for me if I search for it in another browser but for the life of me I can't find it in Opera itself, which I just installed.
Aaaa, it appears to be smart enough to know it won't work with the version I installed. And how on earth is the latest Arch package for Opera 4+ major versions old?
No it's not either. I have the same version the site prompts me to download (12.16).
It appears they dropped Linux support after 12. Man I've been out of the loop.
11:31 AM
@Benjol Never seen that. Or I chose not to see it ;D
@Caleb So, that's the pre-Chromium version?
@OliverSalzburg Ya apparently.
@OliverSalzburg, that's in Chrome developer webstore setup, not Opera)
The original build script I copied (from YouTubeCenter) also had "Legacy Opera" support
@Benjol Oh. I don't know if it shows that for my own extensions. Could you show me a screenshot so I know what to look for?
Maybe even log an issue. Can't hurt to have it, if the Store complains
@Oliver It's not complaining, I don't think. Just noticing
11:46 AM
12 characters, wow
@OliverSalzburg, not really worth it then, unless I can think of a suitable long name :D
My sister just found a bonified bug in Chromium. Not sure I've even managed that!
1 hour later…
1:09 PM
@Caleb This will be an interesting task to get working ;)
@OliverSalzburg I'm not sure it's worth it. How many Linux users are using Opera 12 and actively moderating SE?
@Caleb No idea

« first day (13 days earlier)      last day (354 days later) »