2:31 PM
1
Q: Windows Routing from one ipv4 to another ipv4

jcbjoeIm currently hosting game servers on a window VM and im wanting to add multiple ips to the windows VM which I have done successfully. Now to assign my game servers(on the windows VM) to the public ips I can bind them in the specific games configs. We use ESXI 6.5 to host the VMs and a Edge route...

 
None of this post makes any sense. It could be a language thing, but you’ve mentioned multiple different things without explaining how they are related together and the description you do have doesn’t make sense. You mention a “windows box.” Then mention a “windows server” with multiple IPs, then proceed to mention an “ESXI” server. Then to confound things further, you throw in an “edge router” and a “NAT router.” I’m not sure if you understand the difference and purpose of private and public IPs and NAT. At this point I’m not even sure how many different devices we are talking about here.
 
@Appleoddity Sorry about that, I have fixed the issues should be a bit more straight forwards now
@gawity Because there is multiple public ips assigned to my WindowsVM I have to bind each game server to a public ip. However on the edge router it doesnt work if I create a destination route from my public ip to the game server the windows VM is hosting which is also using the public ip.
 
I think I understand now what you are trying to do. But what I don’t understand is why. It doesn’t sound like a problem that should exist. Your comment “you can’t route public IP to public IP” doesn’t make sense. Your ISP provides a block of public IPs, which you should be assigning directly to the Windows VM. There shouldn’t be any NAT involved. So, your statement of adding multiple IPs to the Windows VM successfully, doesn’t actually sound like we are talking about the same thing. The public IPs should literally be added to the TCP configuration on the Windows VM.
 
@Appleoddity Thanks for the reply. We have been assigned a /29 block of Ips which indeed we have assigned inside of windows. As a example we want to host minecraft which favors the port 25565 as its default. So we have multiple ips so we can run multiple minecraft servers off 25565. As we use ESXI and multiple VMs we use 1:1 nat for some of the ips. What im having the issue with is essentially portforwarding but instead of the destination being internal ip its actually external
 
Ok. So the information I just realized is that you are trying to share the same public IP address with multiple systems using different ports. If that is the case, why are you assigning public IPs internally at all? You should just be using NAT at the edge router and basically port forwarding a particular public IP:Port to a particular private IP:Port on the Windows VM. Just use multiple private IPs on the Windows VM.
 
2:31 PM
@Appleoddity The Ips are being assigned on the windows VM because the game servers need to be bound to the public ip. Im not sure if i can do what im trying to do inside of windows on the router instead. Essentially its like this: public ip => internal ip | internal ip=>public ip
 
Lets take this discussion in to chat
 
@Appleoddity Hi, Sorry It says I need 20 rep to talk.
 
You're good now. Just up voted a bunch of your stuff.
 
@Appleoddity Still not working :/ sorry Says: You must have 20 reputation on The Stack Exchange Network to talk here. See the faq.
Right working now
Sorry about that
 
There you go
So, I understand you are hosting multiple game servers that require a particular port. To work around that, you are using multiple public IPs. What I don't understand is why you are trying to take a public IP -> Private IP -> Public IP. You said the game server has to be bound to a public IP.
 
2:37 PM
Yes we use a web panel called TCAdmin it asks for public ips to assign to it and its also what the customers see
So when the server boots it binds the server(listen ip) to the public ip
 
TCAdmin is on the Windows VM hosting the game servers?
 
Yeah
Thats right
 
So, if a customer is working in TCAdmin, the IP address they see to connect their games to is dependent upon what IP addresses are assigned to TCAdmin?
 
Yes, TCAdmin has a config to add public ips to. The public ip is used in the start parameters for the server.
 
If you are behind a router/hardware firewall only the server's private IP will be imported. Do not add the public IP manually. Set the value of hostname to the public IP or a hostname that resolves to the public IP. Game servers should be configured to use the private IP. Ports in the public IP should be manually forwarded to the private IP or enable uPnP support in the server settings and in your firewall.
This seems to indicate you can use the private IPs and port forward from the public IPs on the router.
Sorry, I don't know tcadmin. I do know networking quite well. What you are trying to accomplish does not sound necessary based on my experience. It just wouldn't make any sense for the developers of tcadmin to have this requirement. Being this is a commercial product, have you tried to discuss this with their support team?
 
2:48 PM
I have not no. I will ask them
Its just if I do it how they say then the customer also only sees internal ips
I got it working kinda within windows using
netsh interface portproxy add v4tov4 listenport=25565 listenaddress=10.100.100.58 connectport=25565 connectaddress=199.180.61.140
which worked but is only for TCP and for specified ports
 
I don't think that is the case. It seems to indicate that there is a private IP setup, and a firewall/hostname setup. So, even though tcadmin and the game servers operate behind private IPs, TCAdmin will show the public IP(s).
 
which basically directs from internal to public
 
I see that. I understand this is what your original question is about. It may be A solution, but I'm not sure if it is the right solution. What you are trying to do is not generally done to accomplish what you are trying to accomplish. I would talk with TCAdmin support, I'm sure they can clear this up. Sorry, I'm not able to be of much more help.
 
No no its completely fine. Thanks for even trying :) I really appreciate it
 
No problem. The complexity of what you are asking is not easily explained in your question.
Have a nice day. I'm going to run. Sorry I couldn't be of more help.
 
2:54 PM
Thanks again, You too