« first day (82 days earlier)      last day (495 days later) » 
00:00 - 23:0023:00 - 00:00

12:24 AM
I didn't even expect Prelude to cause trouble when I added it
I blame people for adding too many lines rather than putting things on the ends of existing lines, which is typically easier
Its also because Brain-Flak added way too many parens
1 hour later…
1:44 AM
@WheatWizard Does the interpreter for python 0.9.1 work for you?
No I need to get my other computer
I like the way that we have python 3, almost immediately python 2, much later python 1, and now people are talking about adding python 0
Hmm. I think I probably added most of the unnecessary lines, and added brain-flak. :/
2:40 AM
I haven't added any lines *yay*
1 hour later…
3:50 AM
Maybe we could add Memescript, too
I wrote that when I was bored
I just clarified the README so that I'm not the only one who knows how to use it :P
4:41 AM
All right, four languages waiting. Someone ping me when another one gets added.
3 hours later…
7:20 AM
Is there any particular reason the 3rd last line is nearly empty?
also are empty lines dangerous to any of th elanguages?
I've found an interpreter for archway 2, so I'm going to have a go at trying to add it.
8:05 AM
Don't you just love errors in interpreters.
Why does this cast even exist? ((int) mem[cell])++;
This bug wasn't in the original archway either, and they have nearly identical code
Wait, I could probably use the original Archway if I don't need looping. I shouldn't for a simple print and i wasn't going to use looping anyway probably. Just means a long line of increments. Is that okay?
5 hours later…
12:57 PM
Has something changed about japt on TIO? I was trying out my next answer and noticed japt was failing with (}o+?23!@)-( as output. I checked the last few answers and they all pass if the output cache is there. But they fail with the same error if I ignore the output cache.
1:38 PM
@Potato44 Looks like an Octave block comment, which has to be on it's own line, iirc.
@SnoringFrog ended up not being able to use that line as its one of the ones where retina doesn't like +
but the line a few above that ending in s ended up being good for not breaking stuff
only problem is archway won't work unless the file ends with a newline, but adding a newline breaks Retina and SMBF
SMBF probably wouldn't be too hard to fix, but i have no idea for Retina
Retina generally wants you to add two lines if you add any
Beyond that, all I know is it's something about regex
Do we know of the languages on the last line which must absolutely be there?
I don't have the slightest clue. Chance did a detailed write up that addressed every line to some degree back in answer 47. Little outdated now, but might be a good starting point.
V/Vim probably needs to stay on the last line.
rk could be moved.
Algol could probably be moved with sufficient commenting.
Not sure about Trigger.
SMBF could, in theory, be rewritten/moved, but I think depending on the end of the file is the shortest solution.
Removing Algol would also give you some leeway to remove various padding characters that are just down there to keep Prelude happy (although the space after the initial s is needed to detokenize s<space>, afaik.
Looks like Pyth and Pip are both down there, no clue how moving them would work. Not sure what the pipes or the $// are about, or the *///~-<~-<~-<<<~-X, or our emoticon
1:59 PM
the ~-<~-<~-<<<~- thing is wise I think.
the emoticon is incident if you mean _^_^.
^ it is wise
2:27 PM
Unless someone else has an idea how to get a linefeed as the last character of the program I don't think I'l be adding archway. Here is what i got so far anyway.
1 hour later…
3:49 PM
@Potato44 actually, I think adding a linefeed to the end isn't too difficult.
looks like only Retina would be a problem.
If you add 2 lines to the end, Retina returns 198. THat should be fixable.
@fixable, but I have no idea how Retina works
@Chance ^
plus Archway must start on the second last line with the last line being empty
still probably workable.
could throw a line at the end, and a line somewhere else.
It just needs to be in pairs
Line after }<> and a line at the end works.
Can Archway's code co-exist with the other code on what is currently the last line?
@Potato44 ^
The way I've fixed Retina in the past is to kinda just guess and check at removing large chunks of code.
In this way, I whittle down the polyglot to just figure out where the output is coming from.
The 8 near the beginning of the last line is part of Retina's answer.
archway is perfectly fine in current last line, works perfectly in archway if you just add a linefeed to the end of what I shared in my last link
And the long python line was/is important to it's answer.
oh, I didn't look at that. I'll review
I swapped one of the spaces for a + to increment archways first memory cell, then it gets deflected upwards by the next /
4:01 PM
is there no BF like [] type loops?
you may be able to make a loop with reflectors though
they only reflect if current tape position is non-x=zero
oh, that's cool. sounds a lot like Minimal-2D
oh, if I haven't mentioned yet control flow starts in the lower left gong rightward
oh, right! I remember you mention that.
Just checked adding a formfeed in a random position in the code, no languages in the test driver barfed at it. We may be able to get trefunge in
4:06 PM
I see why Retina was having a problem with that location. consecutive +'s on I think odd numbered lines error out
I think I put it on that libe because it was erroring on a line of opposite parity
I swapped the lines around a little so retina would be a little more sane
still gotta figure out where the answer is coming from.
I'm gonna look into Japt's fail. probably got updated.
yeah, probably an update because it is failing in some of our current answers
I was getting different output from TIO depending on whether I used the output cache or not
we have been exploiting a bug with japt, so I've kind of been expecting this. :P
yeah, now it outpits the stuff in quotes on the first line
@Chance how you rearranged the lines is looking good, works in archway. Now just need to find out how it is breaking retina. I think cubix is broken because we went up a cube size.
4:23 PM
cool. hopfully you can figure out a retina fix.
I have to work out how retina as a language work before i can do that
maybe. I have't had to... yet. :P
Is there a pretty printer for cubix?
4:32 PM
Cubix, Hexagony, and Cardinal (or was it Fission?) all have some sort of visualizer that I know of, though I have no clue where I found the last one.
Does the IP for cubix start on the topface or the left face?
left face I think
yeah left, I just found that the webpage can run the program
so it looks like Japt is transpiling to put everythign on one line, and the java script line comment on line 1 is causing most of the JS top be commented.
My Fortran answer changes this comment to a block comment though, so maybe it will allow us to keep using the current version.
oh, nope. the parser block also got fixed.
looks like we'll have to run Japt manually from now on.
@Chance yeah, that sucks, do we know what version of japt we were using?
4:46 PM
not sure.
I suppose we'd have to check the dates.
Actually, I think I might be able to make a test abstraction for Japt.
how so?
I'll regex out all the stuff that get's removed via the parser block before feeding it into current japt.
5:46 PM
The Japt interpreter at ethproductions.github.io/japt has a versioning system
This link will use the correct version of Japt forever
@Chance ^
@SnoringFrog I'm creating a visual interpreter for Fission (2) in JavaScript now.
@Luke Good find. thanks!
This is the Japt version that was current at the time it was added to the polyglot
6:02 PM
Maybe we should pin the message with the link to the correct version...
I updated the last answer with the updated test driver and a link to the correct japt interpreter.
@Chance Thanks
1 hour later…
7:31 PM
I got some help from Martin with Retina and now we have a program that only breaks pip and the C family of languages, but it ends in a newline.
@Potato44 Yay
well actually I meant those are the only extra langauges it breaks
okay, fixed the C family by adding in a // comment
hmm. why the second to last line?
Wait so are you almost ready to add another language?
7:51 PM
I'm getting close. I'm just trying to golf now
@Chance I needed to modify the program so that the last character is a newline without breaking Retina
@Chance Actually, if you wouldn't mind posting and then golfing, that'd be great... so I can start working in one of my langs
Or just send me the TIO link
@chance yeah, i'll wait for you to be done.
@Potato44 Wait... you're waiting to add a language too?
7:57 PM
@Potato44 I'm wondering about why you have the second to last line in your code. I'm playing with C comments too.
@MDXF I'm planning on adding archway
@Potato44 I'm waiting to add three or four languages; would it be all right if I answered after Chance, and then you answer after me?
@chance if that line doesn't start with a # it breaks the some # comment languages and i need the + and / for archway
Just so we can get as many langs as possible, and I can't answer twice in a row
@MDXF sounds fair to me
8:00 PM
can you not reflect up at the first / in the current last line?
that is how i had it planned originally, but it was breaking retina only adding one extra line for the linefeed at the end
oh I see
@Potato44 Thanks :D
does anyone have any idea what would be breaking pip here, if i remove the contents of the last non-empty line pip works, but how I have it now, it breaks.
pip's line comment is double space
maybe lead that line with ` `
8:09 PM
Btw (since I opted out of seeing deleted posts), why are there 7 deleted answers?
cant have backticks i don't think, because of retina
also adding a double space before the C comment didn't fix it
i just mean lead with double space
double spacing the whole line didn't work either
might be that M near the end?
it still works fine with the M if i remove the last line
it might be the fact # means length of in pip, testing that now
yay fixed pip, but broke trigger
8:17 PM
you could probably fix trigger by moving the X222999 into you'r second to last line
I decided to take the length of the literal 5 and then put a lieral 25 for implicit output followed by a double space
moving that fixed trigger, but broke the C family, and prelude, but I know why prelude broke, vertical parenthesis
@Potato44 If you send a link, I can help with the C family
@MDXF Here you go, Reticular also broke
8:25 PM
Hm, looks like SMBF and Japt broke too
we, already knew thay were broke
Oh darn did you add the /++++++++++++++++++++++++++++++++++++++++++++++++++++++.-----. line?
japt is because of an interpreter update
What does Archway care about?
yes, that line is for archway, though i can move it up 2 or down 2
8:26 PM
i.e. if I add an extra / to the start, will it care?
And was that the only line you added?
brain fuck characters besides [] plus /\ when current tape cell is non-zero
You broke C by adding /* after the .int ...
if you add the / before the current / it would be fine
i never added a /*
I'm wrong. It was
the archway can be moved any distance further right if you want as well, as long as you move both lines it cares about
8:29 PM
What else did you add?
it only cares about the + and the next / after that in the last line
an M in the formerly last line
The //++++++++++++++++++++++++++++++++++++++++++++++++++++++.-----. isn't screwing C up
i think i changed a space to a + in the formerly last line
it was moving the trigger into the last line that screwed C up
Oh and you borked SMBF because the second-to-last character in the file needs to be 6
i know, but that should be easy to fix, I think
even if we have to change to reading the 3rd last character
8:32 PM
Okay yeah all this is what's messing with everything
#5 25 //X222999 +/#
is it completely necessary to be there?
give me a sec and i'll show you one that works for the C family buy not trigger
All right
That should be easier to fix
'cause there's no chance you're getting #5 25 to work with C and the other langs
there is a */// in the former last line. that can be moved to the new last code line
this works with the C family
@Potato44 How many other langs does it bork?
@Chance When do you plan to add your language?
@Potato44 I think that one will be much easier to fix
8:38 PM
@MDXF reticular and haystack
@Chance i'll investigate that
Well, and Cubix, and Trigger, and SMBF @Potato44
Cubix is broken because we went up a size, I think
Crud, SMBF isn't happy
I wanted to get the lower few lines sorted first
how so?
8:40 PM
@MDXF They got deleted for various reasons. Mine were invalidated, or ended up being broken when I knew I wouldn't have time to fix them. I had at least one answer that I deleted/undeleted at least 5 or 6 times before it ended up in...whichever state it's in now.
I don't think having a newline at the end will work; why is it necessary?
For archway. why don't you think it will work?
@Potato44 The second-to-last character has to be a 6 to work with SMBF, but the last character has to be a # to work with ALGOL
I'm very close
Just solving cubix
@Chance Good job
8:43 PM
How hard is the SMBF to change?
also, algol doesn't mind last character being line feed
Quite hard AFAIK
@Potato44 Well yeah, but only because the second-to-last is #
naw, SMBF can be changed
it has a private code space.
infact, it doesn't have to look at the second to last char if you dont want
@Chance Oh really?? How can we move it back to the third?
but it would ovbiously be more verbose
I wrote about it in algol
Yeah, changing it to 2nd to last was a pretty recent switch
8:45 PM
@Chance i'll take a look once i get trigger and stuff working
@Potato44 You probably also messed up Incident 'cause there are three 25's now
Also, the third character is currently 6. Is accessing the front of the program as simple as the end for SMBF?
@MDXF you're always going to mess up incident. :p
@SnoringFrog should just be a few > commands, depends more on the other languages
@Chance True
@Chance Did you mess up Incident with your new lang?
8:48 PM
i think the 25 in the old last line i ssuperfluous
OH I just added Morse and guess how many langs were borked?
OOOOh yeah
I borked zero langs
I went through the last several posts and removed all the incident de-tokenizing strings
then added back as few as I could
ok. Job's done.
feel free to build off of this answer.
I'll post it this in a few hours after I finish writeup.
gtg for now
8:54 PM
@Chance Yay! Thanks
Oh jeez you changed a lot
yeah, i'll have to rearrange mine a bit
Welp looks like mine is ready to post too
Morse is 100% compatible with everything
We literally have two answers in the queue now.
Well done
I've managed to get mine down to just SMBF and cubix broken in the wrapper, Haven't checked the other langs
@Luke I've got four languages waiting
8:58 PM
and cubix might be fixed by using chances changes
@Potato44 You know, there's really no point doing what you're doing rn...
since two more languages will be added before yours can
only somewhat true, I've worked out how to get the newline at the end we need, and the only one of the two I see messing that up is the Fortran
Ohh okay
*possibly see
Nothing will mess Morse up
You'll have to be careful about what, though
It reads three characters at a time, so if the long line of ?s and !s doesn't start on a first character, it'll bork
9:03 PM
I don't plan on moving what
What don't you plan on moving?
(*ba dum crash*)
9:19 PM
@Chance Ping me when you finish the post, I've got a meeting with a 20-minute break at 4 so I'll have time to write my post if you've done yours. Thanks :-)
@MDXF Remember we're not all in your timezone ;-)
@Luke Oh yeah :P 11:00 UTC
The whole world should just convert to UTC
woo, modified the Chance's Fortran one to be in the same state as what mine was before. Even get a bonus of not having t fix cubix myself.
now for the SMBF
9:37 PM
@Potato44 Wow, so we might have 3 langs in the queue! Nice!
Oh my, rk should be so messed up right now
what probably is too...
rk:end?(???!?!??!??!!!!???!?!??!!?!?!!!!!?!!!!?????!????????????????????!) prevents rk from ending its code
@MDXF the SMBF turned out to be trivial to fix, besides breaking cubix, which i'm working on now
@Potato44 Hmm, I've never broken Cubix so I can't help, sorry
@Potato44 Cubix is not too hard
We have a capsul
just move it around so it is executed
Use the online interpreter to get a view of how it looks
9:53 PM
yeah, found the online interpreter, forgot reading the 4060@ is movable
Cubix fixed, prelude broke, time for space shuffling
@Potato44 watch out for what
@MDXF , I have to make sure i add or remove in multiples of 3, right?
Maybe what was not a good idea
should be fun though
How come? @WheatWizard
10:07 PM
The shift by 3 rule is going to be a pain
We could probably harden it, but that would cost bytes
@WheatWizard Well hey, it's not Incident
or Prelude
or cubix
If anything was not a good idea it's those three
The funny thing is those three are really easy to break, but probably wont ever prevent us from adding a language
@WheatWizard, can you test the non-TIO langs?
10:10 PM
@WheatWizard what won't, right?
@MDXF Probably not
Okay good :P
@Potato44 Gimme a link and I'll test Moorhens, deadfish and Incident
I don't have commercial yet
here it is
and you can do SNUSP and Reng online
10:12 PM
I could probably golf off some spaces in the second last line
@Potato44 What happened to what?
I added it to the driver before
I'm using the version of the driver Chance had for his fortran
Could you use the new one? I added some useful stuff inclduing what
I think i can copy it over from the other driver i was working with before
did I miss some things?
10:13 PM
Did chance add anything to the Fortran one?
I addressed Japt
just small stuff tho
@Potato44 Incident is broken
I'll test the others
made a small change to move the 59 in the last line
I can combine the two in a sec, I'm just testing for potato rn
Moorhens outputs 60
deadfish is good
I don't have surface anymore
I updated my version of the driver.
can you test my code in moorhens/incident/deadfish?
10:17 PM
@Chance was the 59 removed or moved?
moved. only effects incident tokens. it replaces the 5 in brain-flak's space.
We need version control for the driver
lol. yep
deadfish works
moorhens works
Incident prints nothing
10:29 PM
dang. thanks. I'll fix
I just realised my rearranging at the end really does stuff to the incident tokens
that's bound to happen.
ok, whatever I did with that incident token move for 59 caused incident to misalign. reverting.
This SNUSP interpreter we are using is confusing me
@Chance change the code for running what to "/opt/tio-transpilers/brainfuck what.bf"
00:00 - 23:0023:00 - 00:00

« first day (82 days earlier)      last day (495 days later) »