« first day (3842 days earlier)      last day (48 days later) » 

5:54 AM
For those who maintain the tikz package about super heroes, don't forget to add the new one. Here it is.
 
 
3 hours later…
8:35 AM
@DavidCarlisle ooh
@DavidCarlisle quack
@Skillmon counter... ooh? I am confused
 
8:58 AM
@PauloCereda 早餐桌
 
9:18 AM
@DavidCarlisle oh no
@DavidCarlisle Joseph will learn Chinese in no time. :)
 
 
2 hours later…
11:01 AM
1
Q: Aligning ducks and their labels in a tree

Olaf MuschI'm building a tree of labelled tikzducks. An MWE would be \documentclass{scrartcl} \usepackage{tikz} \usetikzlibrary{ducks} \begin{document} \begin{tikzpicture} [level distance=4cm, sibling distance=4cm] \node { \begin{tikzpicture} \duck \node [xshift=8, y...

 
@DavidCarlisle OH NO
 
@DavidCarlisle the alias idea sounds quite good.
 
11:20 AM
@UlrikeFischer just needs Will to make it work:-)
@UlrikeFischer originally tetex came with a standard alias file so that longtabl.sty (which emtex users tended to put in documents) got aliased to longtable.sty (so it worked)
 
@DavidCarlisle and find something to build the alias file.
 
@UlrikeFischer I was thinking of finding @Marcel
 
@DavidCarlisle ooh
 
@DavidCarlisle yes I got it that you had some advantage here. Who else could know about this alias file?
 
@UlrikeFischer ooh a secret
 
11:25 AM
@UlrikeFischer everyone who read the kpathsearch documetation?
 
@DavidCarlisle ooh documentation
 
 
1 hour later…
12:30 PM
@PauloCereda :) Hi, Mr. Duck!
 
@Skillmon Hi. mr. rabbit! Miss you! <3
 
@PauloCereda Miss you, too! And thanks for the carrot. Here have one, too: <3
@PauloCereda how's it going at Overleaf?
 
@Skillmon Yay! <3
@Skillmon quacking and making a lot of noise. :)
@Skillmon It's been great! <3
 
@PauloCereda Very good to hear!
 
@Skillmon How are you, mr. rabbit?
 
12:34 PM
@PauloCereda It's weekend, so fine. My workweeks are a bit stressful lately, as I have to supervise a lot of student experiments each week.
 
@Skillmon ooh things explode in the experiment?
 
@PauloCereda if they do I did my job poorly, no. It's electrical engineering and measurement experiments.
 
@Skillmon ooh
 
12:50 PM
Hi, I try to debug why Inkscape does not render LaTeX formulas here. In the temp files I saw that the pdf which is rendered by the extension contains only Type3 fonts
when inkscape imports this pdf with the formula, it shows pixeled pictures
this is the tex file which is generated by the script to render the formula
manually rendering the tex file has the same result as the script has
I get a .pdf with Type3
improved paste: dpaste.com/3P634ZY7H
 
@JonasStein you can paste code fragments here, no need for external links. also don't use minimal class for such tests it does not set up fonts and s can cause issues that do not occur in a real class. What happens if you save the svg as pdf from inkscape and include the pdf in latex do you still get type3 fonts?
 
%% processed with pdflatex.py
\documentclass{minimal}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{amsfonts}

\begin{document}
x=$\frac{1}{E}\left(\frac{1}{T}- \frac{1}{T_{\text{MF}}} \right)$
\end{document}
@DavidCarlisle Perhaps minimal is the reason
which class should I use instead? The Inkscape Plugin uses this snipped to render and import formulas
this is how formulas look now in inkscape. However it worked months ago.
 
@JonasStein article or so, but your files compiles fine, so the class is not the reason for the wrong fonts.
 
@JonasStein try with article. Note I wrote minmal class when we were designing the latex2e class/package system to answer the question "what is the minimal set of commands that you need to add to a file to be a latex class without generating errors" It wasn't designed to make a class that did anything useful.
2
 
Oh I see.
I think the Plugin uses minimal, because we want a PDF which just renders the formula without a DIN A4 Paper and so on
this was the Bug I reported upstream, but I need more investigation before reopening the ticket gitlab.com/inkscape/inkscape/-/issues/2278
 
1:04 PM
@MarcelKrüger (@DavidCarlisle, @UlrikeFischer) I think I can switch all LuaTeX testing in 2e to use PDF mode, not just the TU tests. I'm wondering if we should (finally) bite the bullet and switch from etex to pdftex for the main tests
 
@JonasStein minimal sets sizes for US Letter, why is that better than A4 ?
 
oh... I thought it would make a page with the dimension of the plain formula
is this available too?
 
@JonasStein you can use standalone.
 
@DavidCarlisle Found me. What do you need alias files for?
 
@JonasStein standalone but that is a rather massive dependency.
 
1:06 PM
ok I will backup the extension and test different classes now in the python script
will be back in a few minutes and report
 
@MarcelKrüger long acrimonious discussion on texhax list. on the need to configure fontconfig to look in the texkive tree if you want to access fots by internal font name in xetex. I suggested an alternative that doesn't require changing teh syste fontconfig settings would be to put something like this
Alegreya-Regular.otf Alegreya
Asana-Math.otf Asana-Math
Asana-Math.otf AsanaMath
FreeSerif.ttf FreeSerif
NotoSerif-Regular.ttf NotoSerif
as aliases at the top level of texmf-dist so that kpathsearch would find the otf files given some approiximation to the internal name. This could possibly be constructed from the luaotfload cache
 
@DavidCarlisle Interesting, I'll write a draft.
 
@MarcelKrüger doesn't work currently with fontspec though as (I think) \setmainfont{Alegreya} sees there is no extension so never tries a filename lookup,
@MarcelKrüger thanks you don't have to do things just because I randomly ping you in chat:-)
 
For some reason I get a larger bounding box when using article, but the pixel result is the same
 
@PauloCereda I totally forgot to counter-ooh.
 
1:20 PM
@Skillmon <3
 
@JonasStein I don't quiote follow how you are getting pdf from that, if you get tyoe3 fonts forom that with pdflatex you don't have the type1 cm fonts or the cm map files installed, bith of which should be in any tex distribution, also the expression x=$\frac{1}{E}\left(\frac{1}{T}- \frac{1}{T_{\text{MF}}} \right)$ is very odd why is x= not in math mode? If it was all in math and you wanted a pdf clipped to that you coul do...
 
@DavidCarlisle Maybe even bigger issue (since it seems basiclly unfixable): The font won't be found with NFSS's \UnicodeFontName for non fontspec users.
 
ooh @MarcelKrüger was found
 
@MarcelKrüger yes it wasn't a fully worked solution, I was just "musing out loud" :-)
 
Inkscape ships plugins in https://gitlab.com/inkscape/extensions
here we use https://gitlab.com/inkscape/extensions/-/blob/master/pdflatex.py from the menu "extensions"
x not in math mode is just a typo. It does not influence the debugging
 
1:29 PM
 
perhaps my local latex installation is broken and the type 1 fonts are missing....
 
@JonasStein ^^
\documentclass{article}
\usepackage{amsmath}
\begin{document}

\sbox0{$x=\frac{1}{E}\left(\frac{1}{T}- \frac{1}{T_{\text{MF}}} \right)$}
\pdfpagewidth=\wd0
\pdfpageheight\dimexpr\ht0+\dp0

\hoffset=-1in
\voffset=-1in
\topskip=0pt
\shipout\hbox{\box0}

\end{document}
 
\pdfpagewidth=\wd0 sound like a good solution for the plugin
 
@JonasStein note that you can only do that for inline math display constructs like align are always \textwidth wide
 
@JonasStein do you have a vanilla or a system TL?
 
1:34 PM
I have TL2021 from the gentoo distribution plus TL2021 with tlmanager locally insalled in userspace
The systemwide TeXLIve is pulled in as dependency since some people in Gentoo thought the user should not be allowed to use the "packages.provided" feature anymore. This enabled to install TeXLive manually and tell the packagemanager that TeX is already there
 
@JonasStein Hm interesting... out of curiosity, is the issue reproducible if you run inkscape from a user shell?
 
@JonasStein ignoring inkscape to start with, if you run pdflatex on the above what fonts do you get in the pdf, it should be something like
$ pdffonts aa237.pdf
name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
MHOLNP+CMMI10                        Type 1            Builtin          yes yes no       4  0
JHYTSG+CMR10                         Type 1            Builtin          yes yes no       5  0
EJASTL+CMR7                          Type 1            Builtin          yes yes no       6  0
MAFBCJ+CMMI7                         Type 1            Builtin          yes yes no       7  0
 
@PauloCereda yes:
inkscape --export-type="svg" input.pdf

pdffonts input.pdf
name type encoding emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
[none] Type 3 Custom yes no no 4 0
[none] Type 3 Custom yes no no 5 0
[none] Type 3 Custom yes no no 6 0
 
@JonasStein hm thanks
 
@DavidCarlisle your example returns a PDF with
pdffonts test.pdf
name type encoding emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
[none] Type 3 Custom yes no no 4 0
[none] Type 3 Custom yes no no 5 0
[none] Type 3 Custom yes no no 6 0
so I should fix my TeX first
 
1:41 PM
@JonasStein any different output if you include --pdf-poppler in the inkscape call?
 
how can I check, it the fonts are built systemwide?
 
@DavidCarlisle I tried to test this aliases, but it seems not to work for me. xetex doesn't find neither \font\asmb="[Alegreya]" nor \font\asmb=["Alegreya"], and kpsewhich Alegreya doesn't output anything either (should it?). I tried by adding a file "aliases" beside the ls-R.
 
perhaps our package is broken and does not build the fonts properly
 
@UlrikeFischer worked for me on the one file I tried it on:-)
 
@DavidCarlisle what happens if you do kpsewhich on an alias name?
 
1:48 PM
@UlrikeFischer hmm not a lot. It would need a format hint but I get:
$kpsewhich --format 'opentype fonts'  Alegreya
$kpsewhich --format 'opentype fonts'  Alegreya-Regular.otf
/usr/local/texlive/2021/texmf-dist/fonts/opentype/huerta/alegreya/Alegreya-Regular.otf
@UlrikeFischer so nothing from the alias
 
@DavidCarlisle The aliases line has to include the extension. With Alegreya-Regular.otf Alegreya.otf the lookup works.
 
@DavidCarlisle this here works:
C:\Users\Nililand2020\Documents\Tests>kpsewhich blublongtable.sty
c:/texlive/2021/texmf-dist/tex/latex/tools/longtable.sty
 
@UlrikeFischer to make it easier to spot the alias in the log I changed the tex to
\font\asm=["Azzz"]\show\asm \asm a

%\font\asmb=["Alegreya"]\show\asmb \asmb b


\bye
with a line Asana-Math.otf Azzz in aliases then you ca watch kpathsea find it:
xetex finding the file:
$ xetex --kpathsea-debug=-1 amath.tex 2>a.log
This is XeTeX, Version 3.141592653-2.6-0.999993 (TeX Live 2021) (preloaded format=xetex)
 restricted \write18 enabled.
entering extended mode
(./amath.tex
> \asm=select font "[Azzz]".
l.2 \font\asm=["Azzz"]\show\asm
                                \asm a
? x
and a.log has...
kdebug:kpse_find_file: searching for Azzz of type opentype fonts (from texmf.cnf)
kdebug:hash_lookup(try_std_extension_first.xetex) => (nil)
kdebug:hash_lookup(try_std_extension_first) => t
kdebug:variable: try_std_extension_first = t
kdebug:start generic search(files=[Azzz.otf Azzz.OTF], must_exist=0, find_all=0, path=.:/home/davidc/.texlive2021/texmf-config/fonts/opentype//:/home/davidc/.texlive2021/texmf-var/fonts/opentype//:/home/davidc/texmf/fonts/opentype//:!!/usr/local/texlive/texmf-local/fonts/opentype//:!!/usr/local/texlive/2021/texmf-config/fonts/opentype//:!!/usr/local/texlive/20
@UlrikeFischer skip to the last line it finds it in the end:-)
kdebug:returning from generic search([Azzz.ttf Azzz.ttc Azzz.TTF Azzz.TTC Azzz.dfont Azzz]) => /usr/local/texlive/2021/texmf-dist/fonts/opentype/public/Asana-Math/Asana-Math.otf
 
2:27 PM
@DavidCarlisle \font\asmb="[Azzz]" works now for me. Spot the difference:
Alegreya-Regular.otf azzz # works
Alegreya-Regular.otf Azzz # fails
 
@UlrikeFischer oh sorry you mean it has to be lowercase in the alias file?
 
@DavidCarlisle no the alias file requires lowercase.
 
if I make the alias lowercase the uppercase does not work in xetex `! Font \asm=[Azzz] not loadable: Metric (TFM) file or installed font not found.
`
 
@DavidCarlisle for me both font definitions work, but probably one should then add both version to the alias file.
 
2:43 PM
@UlrikeFischer When we generate them from the luaotfload database, we get normalized names anyway. I think it makes sense to just use them and adapt fontspec to do the normalization before trying the lookup.
 
@MarcelKrüger well the main problem will be the lookup of bold font versions etc. If "Aleygreya" actually does a file lookup, fontspec can't use Aleygreya/B etc.
 
@UlrikeFischer I tried adding alias "Aleygreya/B" which didn't seem to work but maybe that can be made to work
 
@UlrikeFischer @DavidCarlisle For now I only did fontname lookups, not family lookups but I thought that we might be able to remap them to use another separator character. E.g. Alegreya-B probably could be made to work.
 
@DavidCarlisle I tried that too, but I suspect that will need larger changes in fontspec to map this.
 
3:18 PM
@UlrikeFischer luaotfload seems to have a new feature:-)
 
@DavidCarlisle ?
 
@DavidCarlisle oh ;-).
 
 
2 hours later…
4:58 PM
Welp, 2 years later (https://chat.stackexchange.com/transcript/message/50189574#50189574), figured out how to make a .torrent for MacTeX.

Could someone please verify that https://vps.mike.renf.ro/MacTeX.pkg.torrent is functional? If so, feel free to send it along to whoever manages the MacTeX download page.
 
5:40 PM
I don't understand why my posted image in this chatroom cannot be loaded. I only see spinning progress bar. It does not seem to be normal.
 
@KimJongUn mayhaps a firewall intercepts imgur? That's the case for me when I'm at work
 
@Skillmon But reposting the same image works.
 
@KimJongUn hm, I already saw your first one.
 
@Skillmon OK. Thank you for confirming.
 
6:14 PM
Something's weird in the .torrent file I made.

- I copied over a bunch of the trackers from the regular TeX Live 2021 ISO,
- I can see that I'm able to talk to at least 10 of them,
- I know I've got the right ports open on the home router since I'm currently seeding TeX Live and a few other things,

but no go on the actual MacTeX.pkg.torrent file I linked a bit ago.
 
6:54 PM
@JosephWright, @PhelypeOleinik I have found a 20% faster \group_align_safe_begin: and a 6% faster \group_align_safe_end: implementation :) And it is only marginally more cryptic :) Unfortunately it still doesn't fix our little problem that a single align safe group doesn't work in \keyval_parse:nnn.
 
@Skillmon Is faster code ever less cryptic? ;-)
@Skillmon But nice! I guess we don't need lots of code readability there
 
\group_begin:
\tex_catcode:D `\^^@ = 2 \exp_stop_f:
\cs_new:Npn \group_align_safe_begin:
  { \exp:w \if_false: { \fi: `^^@ \exp_stop_f: }
\tex_catcode:D `\^^@ = 1 \exp_stop_f:
\cs_new:Npn \group_align_safe_end:
  { \exp:w `^^@ \if_false: } \fi: \exp_stop_f: }
\group_end:
@PhelypeOleinik ^^^
biggest drawback I've found so far: Any code that normalizes tokens without expanding them will break this, because then \exp:w will see either `{ or `}, and the result will not be empty.
 
@Skillmon Hm... That could be a problem... Does the test suite run fine with that?
 
7:09 PM
@PhelypeOleinik it does, but unravel for instance will not work with anything containing these.
 
@Skillmon Not good then... Maybe ask Bruno
 
@PhelypeOleinik using \exp:w -`{ \if_false: } \fi: \exp_stop_f: wouldn't have that issue and is still faster, not as fast as the other one, though.
 
7:51 PM
 
@UlrikeFischer I was just about to ask a question, lucky I didn't
 
@DavidCarlisle thanks for being so considerate!
 
@Skillmon why is `^^@ quicker than `} ?
 
@DavidCarlisle because with `} you also have to put a minus in front of it so that \romannumeral doesn't produce any output.
 
@Skillmon sorry translation error, I read exp:w as \expandfter not romanumeral :-)
 
7:57 PM
Actually, I made a small mistake during benchmarking, it seems like \group_align_safe_end: is faster than my implementation (but the begin: part of my implementation is considerably faster, still).
 
@Skillmon so losing the extra atokens with romannumeral is faster than using \else ?
 
@DavidCarlisle in \group_align_safe_begin: losing the extra tokens with \romannumeral is faster than with a \ifnum comparison, but in end: the \ifnum comparison also acts as the \iffalse to gobble the other token, and combined \ifnum is faster than \romannumeral and \iffalse.
(during my first benchmark I didn't use \c_zero_int, but 0 in my minimal test file)
 
@Skillmon yes makes sense
 
@DavidCarlisle if comparing to a register instead of an explicit number, that is. Else the \romannumeral + \iffalse wins by roughly 1.5 % :)
 
 
1 hour later…
9:10 PM
@PauloCereda inkscape --export-type="svg" --pdf-poppler test.pdf returns
inkscape --export-type="svg" test.pdf returns
evince test.pdf shows
 
9:31 PM
pdffonts test.pdf
name type encoding emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
MHOLNP+CMMI10 Type 1 Builtin yes yes no 4 0
JHYTSG+CMR10 Type 1 Builtin yes yes no 5 0
EJASTL+CMR7 Type 1 Builtin yes yes no 6 0
MAFBCJ+CMMI7 Type 1 Builtin yes yes no 7 0
I am out of ideas what to test next
oh there is a mistake in my tests...
 
vps.mike.renf.ro/MacTeX.pkg.torrent appears to be a valid Torrent file now. Only has one tracker in it so far, but verified it's seeding from a home system to a remote one.
 
10:03 PM
Edited to add more trackers, seems to still be working, emailed mactex-support@tug.org to see if it can get published on the regular download page.
 

« first day (3842 days earlier)      last day (48 days later) »