« first day (77 days earlier)      last day (474 days later) » 

2:16 AM
@Upgoat cheddar: command not found
 
Could you please post installation log?
 
Downloading...
npm WARN engine [email protected]: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.25","npm":"1.4.21"})
npm WARN deprecated [email protected]: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm WARN engine [email protected]: wanted: {"node":">=0.12"} (current: {"node":"0.10.25","npm":"1.4.21"})
npm WARN engine [email protected]: wanted: {"node":">=0.12"} (current: {"node":"0.10.25","npm":"1.4.21"})
npm WARN cannot run in wd [email protected] grunt build --minify (wd=/home/dooku/Downloads/cdrtmp-1466043161)
 
@Maltysen restart the terminal
 
o
 
@Maltysen where are you running this?
 
2:18 AM
@Upgoat bash
 
@EᴀsᴛᴇʀʟʏIʀᴋ why would that fix it
@Maltysen but what dir
 
it does for me
 
^^ didn't work
@Upgoat ~/Downloads
 
@Maltysen okay. do chmod -R 777 ~/Downloads and see if that fix it
or try running as root
@EᴀsᴛᴇʀʟʏIʀᴋ no, I changed installation script from alias method to path
@Maltysen that reminds me, you may want to try installing with --method=alias --rcloc=~/.bashrc
 
@Upgoat no sreiously it doesn't work without that
 
2:26 AM
@Maltysen did it work when you run as root
it works on my centos server and rpi ._.
 
no
 
@Upgoat yeah, just tested again on centos machine
$ cheddar -V
0.0.317
@Maltysen do you use ubuntu, centos, something else?
 
@Upgoat kubuntu
 
can you tell me the output of npm -v
 
1.4.21
 
2:34 AM
oh god that's old. You dolphinetly need to update
sudo npm install npm -g
 
@Upgoat still not working
 
@Maltysen wtf try manual install
 
@Upgoat this install where i run though?
 
wait no theres more
 
`fatal: repository 'https://github.com/chedar-lang/Cheddar.git/' not found
`
wait you spelled it wrong
 
2:40 AM
dammit spelt cheddar wrong
git clone github.com/cheddar-lang/Cheddar.git
cd Cheddar
npm install
./node_modules/.bin/grunt build
try that much
O_O JavaScript error messages are very good
how do they even work
 
redacted@solar-sailor:~/programming/misc/Cheddar$ npm install
npm WARN engine [email protected]: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.25","npm":"1.4.21"})
npm WARN deprecated [email protected]: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm WARN engine [email protected]: wanted: {"node":">=0.12"} (current: {"node":"0.10.25","npm":"1.4.21"})
npm WARN engine [email protected]: wanted: {"node":">=0.12"} (current: {"node":"0.10.25","npm":"1.4.21"})
\
> [email protected] prepublish /home/redacted/programming/misc/Cheddar
@Upgoat ^
 
:/
try running chmod +x ./bin/install; ./bin/install
 
@CᴏɴᴏʀO'Bʀɪᴇɴ fail
 
@Upgoat finished instantly
Downloading...
Installing...
 
27 messages moved from The Nineteenth Byte
4 messages moved from The Nineteenth Byte
 
2:48 AM
@Maltysen oh no
that's not good
try sudo ./bin/install
 
17 messages moved from The Nineteenth Byte
 
 
19 hours later…
9:46 PM
how i install pleaz halp
 

« first day (77 days earlier)      last day (474 days later) »