« first day (188 days earlier)      last day (2420 days later) » 
00:00 - 13:0013:00 - 22:00

12:04 AM
nice & polite way of putting it :)
12:14 AM
@JorgeCastro i NEVER saw that on askubuntu :P
oh THOSE screens :P
12:31 AM
Ext2/3/4 is orders of magnitude faster than FAT/FAT32/NTFS at manipulating large quantities of files.
1:05 AM
@JamesGifford i was in class, but yes, i got your DM :P
@JorgeCastro according to his twitter he's out and about tonight.
1:23 AM
Q: Does Novell's Mono promote bloat in programs?

John CIs Mono and/or Mono-based software bloatware? Eg: Banshee, Moonlight, Docky, Tomboy Notes, etc. Is there anything actually wrong with software using Mono and/or Mono itself, or is it nothing more than an ethics issue?

thats a subjective question that would under normal circumstances be flagged correct?
@JorgeCastro It's all SEs Depends on your reputation
@lazypower :P
1:40 AM
@JamesGifford ^.^
1 hour later…
2:51 AM
How come I can get upvotes after a question was closed?
Mods, correct me if i'm wrong: closing a question only closes it for new answers.
3:07 AM
@djeikyb Right. (I'm not a mod, but I have been in the past.)
Q: Is it normal for nm-applet to use 1,5Gig of ram?

Luiginm-applet suspiciously uses about 1 gig of RAM on Ubuntu 10.10. Is this normal behavior?

dupe alert?
I've voted to close it....
Q: Why can't I copy a large number of files to my USB flash drive?

George EdisonI have about 7000 or so files I'm trying to copy to a USB flash drive. The total size is about 8GB. After copying about 10% of the files, the drive mysteriously aborts the transfer and unmounts itself. Results of dmesg | tail: [ 2193.272548] usb 2-1: new high speed USB device using ehci_hcd a...

I've put a bounty on that one.
@GeorgeEdison interesting problem :)
though there doesn't look to be enough of the dmesg output
3:18 AM
That's all I get from dmesg | tail.
that's because tail only displays the last 10 lines
you're using a tool that deliberately cuts the output short :P
I'll see if I can get more.
Check /var/log/syslog
nothing before that?
3:24 AM
Oh, there is... hang on.
Here are the previous lines: pastebin.com/r0Hin0Q4
That's all. The stuff before has a much earlier timestamp.
so there are some definite filesystem errors on there
& it sets it to read-only when it hits them
I can't remember what tools there are in ubuntu for checking a fat32 filesystem for consistency
fsck.vfat may help
It had FAT errors before.
I reformatted it just now, and then tried copying files.
well that's not a good sign :P
because those timestamps are from just a few minutes ago?
and they say that there are FAT errors, and that the filesystem is set to readonly
3:30 AM
Ya, that was before I reformatted it.
Maybe it would help if I explain exactly what I did.
1. I plug it in.
#Apr 4 20:20:03 nathan-laptop kernel: [10774.494718] FAT: Filesystem has been set read-only
2. It mounts without error and I try copying 2 GB of files.
how long ago was that?
3:31 AM
A few minutes ago
3. About 600MB into the transfer, it aborts and then unmounts.
4. I plug it back in and then I get FAT errors.
The only way to use it again is to reformat.
ok, put the information in the question :)
@ajmitch There. Done.
I'm really not liking the look of those I/O errors there
more rickrolling or friday? :P
@ajmitch What do you think the problem is?
@GeorgeEdison I don't know whether it's actual I/O errors due to the drive having issues, or whether something was trying to access sectors out of range, I don't know enough to decide
Is there a command to check the drive for issues?
badblocks may work for it, but that's just a maybe :)
3:51 AM
has anyone tried guake?? very recommendable!!
o.o osm?
how did I type that?
@ajmitch It's running now.
4:35 AM
heh all the interesting things happened after I went to sleep :-)
Good morning everyone (:
@StefanoPalazzo morning
mornings are evil
4:59 AM
@StefanoPalazzo hi
'ello :-)
5:15 AM
@ajmitch There. badblocks finished. Everything's fine.
A: how do I leave a comment to an answer on the Ask Ubuntu site?

Stefano PalazzoCommenting is a privilege you earn by using the site. When you reach 50 Reputation, you earn the privilege called Comment Everywhere: From the Privilege description: How do I comment? Click the add comment link under each post. Comments cannot be multi-line, so simply press enter to ...

A nice change from the usual anger about not being able to comment
Anyone know of a good place to ask for help with this?
I'm not getting anywhere with #linux on freenode.
Oh, and I have a surprise for everyone:
@GeorgeEdison have you seen this thread yet?: ubuntuforums.org/showthread.php?t=797789&page=2
5:30 AM
@djeikyb Thanks! Sounds like something that might help.
the first page involves an error -71 with a different fix and a different problem
@GeorgeEdison have you found anything about what -71 might mean?
@djeikyb Hang on... I have to reboot to try this change out.
@GeorgeEdison kay-o. also post output of smartctl --all /dev/sdX (whatever your drive is)
Device: Corsair Survivor GTR Version: 0.00
>> Terminate command early due to bad response to IEC mode page
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
oh well. was worth a shot. apparently there isn't a more permissive option than the default normal.
@GeorgeEdison i'm with @ajmitch. don't like those io errors.
5:42 AM
@djeikyb Ya... but what do they mean?
not that i'm super knowledgeable, but usually they mean the hardware is borked. my experience with io errors are mostly with tape drives
especially travan 20/40s ;p
@GeorgeEdison be nice if you had a different computer and os to try the same 2gig transfer test
or at least a different os, to rule out usb driver bugs
@djeikyb Right... I don't think I'm going to get anywhere until I try it on Windows.
@GeorgeEdison have you tried the same copy test formatted as ext2/3 ?
@djeikyb No... do you think that could make a difference?
@GeorgeEdison i dunno. but it's a good test. it'll isolate the problem to the file system, which would be a sweet development as far as bug logging
5:50 AM
@djeikyb That gives this error.
with what command? (just for posterity)
From Nautilus. (Just right-click, Format.)
Format as FAT32 still works.
oh, hm, okay. i wonder if nautilus deletes the existing partition table first
Same result from using System->Administration->Disk Utility.
Trying Ext4...
heh. this is where it would be helpful for me to use gnome
@GeorgeEdison are you explicitly deleting the partition table first? if not, do so
5:54 AM
Ext2 or 4?
ehhh, ext2 just for kicks
older, more tested. not that i know of any problems with ext4
Same error. That was after running "Delete Partitions" until the device was empty.
okay, good
so now we know this isn't a fat problem
@GeorgeEdison do you have multiple usb buses? i don't mean just multiple usb ports
well. no. that's silly. do you have any other large usb drives, like say an external hard disk?
changing buses will isolate the problem to the usb bus, but might not be feasible for you
@djeikyb Yes.
I tried changing ports, etc.
...and I have another USB external HD (1TB) that works fine.
great, fantastic info
though not so fantastic for your flash drive's prognosis
6:02 AM
by process of elimination, then, i pronounce your sweet flash drive borked
Oh no!
prolly should rma that quicklike
It was a gift :)
@GeorgeEdison dang
6:03 AM
Really, though - I should try it in Windows.
And to be fair, it does work fine for smaller transfers.
oh. haha, spoke slightly too soon
Hang on... I'll boot up Vista.
This may take a few minutes.... :)
k o
6:04 AM
I'll hopefully be back in about 5.
let's logic this out. from the driver's perspective, is there any difference between a usb connected flash drive and a usb connected sata drive?
if not, then yeah, your drive is broken
if so, there's a small chance of it just being a driver bug
hiya @KaustubhP
Vista has (sort of) finished loading.
It's slower than a turtle.
@djeikyb @GeorgeEdison hello!
6:15 AM
I'm currently waiting for the drivers to finish installing.
@KaustubhP Hello.
@GeorgeEdison lol. it took that long to boot??
It hasn't even finished yet :P I just managed to get Chrome up before it's done.
Still installing updates...
good morning all
@GeorgeEdison eheh, so i'm not missing much. i've been tempted to try win7, but i've stuck with winxp so far
evening @Takkat ;p
I'll never know why people complained about XP.
Vista was like fixing a flat tire with a sledgehammer.
6:17 AM
@GeorgeEdison because it hella sucked pre sp2
@djeikyb I heard that it was pretty bad before SP2.
Driver's loaded now.
[Waiting for Explorer to open...]
[Waiting for second explorer window to open...]
xp + cygwin + xming is..livable. i mean, for ordinary web browsing, no huge difference from linux. but start to script or analyse logs..
cgywin is awesome.
I used it before finally switching to Ubuntu.
nice. it was a lifesaver at my old job. silly it policies hating on linux
Eclipse sucks.
6:24 AM
@KaustubhP haven't used eclipse much. i've only written small perl scripts and websites. lovingly hand-coded with vim
Windows Vista - ARGH!!!
> "You must restart to.... blah blah blah."
@djeikyb Installing plugins is a PIA.
And it says I need to restart to use my USB mouse!
...which was working until a few seconds ago!
Hang on...
you're a power user right? you don't need no mouse!
I'll be back again.
6:26 AM
nods sympathetically at @GeorgeEdison
6:39 AM
in win 7 i'm happy if it's just a restart and not a "installing on shutdown, configuring on boot" craziness
@htorque eesh. all this fun stuff i'm missing out on
heh, i only can handle this much fun once a month
that's often :P
good morning :)
@Takkat @htorque morning guys!
6:47 AM
hi @KaustubhP
damn, how is it already 9am? gotta go, cya!
@htorque CEST still cu
@djeikyb just to remind you of history :P
Don't dare to leave your box...
haha, but i think i disabled auto updates. which makes me a terrible user, i know
Everytime I have to see something like that I am so glad of not having to run XP at home any more :)
unfortunately here at office it's still all contaminated. Good I don't have to admin the office boxes
7:03 AM
@GeorgeEdison Whenever you get vista going, try to wipe the entire disk and reformat ntfs. i know you don't want it long run, but try your copy test with ntfs. see what errors you get in windows syslog, for both the format and the copy test.
7:33 AM
@GeorgeEdison can you add this to your question
A: Why can't I copy a large number of files to my USB flash drive?

djeikybI'll try and sum up our chat discussion.. Is this a file system problem? No. Badblocks comes up clean. I had George try wiping the FAT partition table, then try formatting with ext2. He used Gnome's Disk Utility. Is this a usb port/bus problem? No. George tried multiple ports with this dri...

yeah, i debated whether to post as answer or edit his question. decided enough of it was me answering, but yeah, he should still work it into his question for the sake of everyone else
@OctavianDamiean hi
@djeikyb if the correct answer resulted later this anwer would be a great howto on how to debug USB issues.
@OctavianDamiean heya
7:45 AM
Hi @OctavianDamiean
I'ma link you to my SE question/answer quality improvement proposal, if you have an opinion, please share it. :)
A: How to improve quality of SO questions/answers?

Octavian DamieanI'd like to throw in an idea I had today. What would you think about some kind of mentoring program? The principle is very simple. You need one experienced user and one or more new (not so experienced) users. Mentors would get one or more trainees assigned with the aim to teach them how to ask ...

@Takkat heh, how to debug hardware issues in general
come up with failure points, test them
@djeikyb sorry for the hurry: troubleshoot of course ;)
haha, yes. triage, troubleshoot, better words
But even Hardware may have bugs (ants in @Alvar's keyboard e.g.)
7:52 AM
i know nothing of code, debugging is hardly my arena
@Takkat is that a joke with the ants in the keyboard? :D
please tell me that happened and caused errors
@OctavianDamiean no he mentioned that here some days ago when he saw an ant disappear in his laptop :D
@Takkat OH lol! :D
scary thought - that's why I remembered
Btw there are moths feeding their maggots from hardware: I've seen that - no joke
That's how they looked like
7:58 AM
that's rough. hate to be the one diagnosing those hardware failures
@Takkat no way. You serious?
damn bugs!
@OctavianDamiean they normally feed from food like flour pasta and stuff. But I've seen electronic devices crowded with dead maggots and web's from cocoons. That was scary I can tell you.
@Takkat lol
Hardware was still working fine despite that, so maybe it was only some insulation or resins they ate.
8:06 AM
maybe they just liked the temperature?
@htorque it was a not used device. Maybe they die from the heat in PCs in action.
Glad we now live in a moth-free zone
8:37 AM
wow, I just removed old kernel versions worth ~1GB of storage! :D
@StefanoPalazzo have you ever read the full circles magazine? I think since issue 19 they have a Python series fullcirclemagazine.org
they are at issue 47 now btw.
@OctavianDamiean I read it occasionally, but you might imagine the python series doesn't excite me that much ;-)
@StefanoPalazzo yea well I know, just wanted to make sure you know about it :)
thank you :-)
I always forget about it
I just noticed I've missed three issues
9:21 AM
Using IRC is a real blast from the past, when you're used to the sort of chat system we have here...
@StefanoPalazzo hehe :D
* Stefano has quit (*.net *.split)
10:10 AM
uk /websites: uptime
11:06:22 up 372 days, 16:19, 1 user, load average: 0.27, 0.32, 0.14
This is getting silly.
10:21 AM
Is this chat platform freely available / able to be used standalone on web page?
It's so nice.
@Spacecraft as far as I know it isn't
That's a shame.
@oli ;-)
@StefanoPalazzo wow that is really a sick uptime
Yeesh. 2263 days of uptime? What kind of black magic is this?
10:32 AM
This sort of thing happens when people don't dare to touch the server
NetWare came with a helpful sticker that admins could put on the server, to warn others. "Here be dragons"
o, netware..how i loathe trying to divine your commands, and shudder at your maimed excuse of a point-and-click interface
i will say, accomplishing something on netware grants much higher satisfaction than performing an equivalent windows or linux action. and i'm not talking ease of use..
Mh, I've used netware for about a year at school, found it pretty forgettable
but that's only the client-side
10:49 AM
yeah, interacting with netware as a file server isn't too bad on windows. kinda of a bitch on linux. i remember the bloody linux client timing out constantly
doing stuff on the server is where esoteria kicks in. that, or i just suck. i never trained for netware, just was thrown into it testing cross-platform software
I'm going post my answer again, maybe some of you have thoughts you'd like to share.
@Alvar yeah, it's an interesting one. that answer is a dead end though. it for sure is not a file system problem.
I thought if you reset everything in it and then it will show if it's a fake or not..
A: Why can't I copy a large number of files to my USB flash drive?

djeikybI'll try and sum up our chat discussion.. Is this a file system problem? No. Badblocks comes up clean. I had George try wiping the FAT partition table, then try formatting with ext2. He used Gnome's Disk Utility. Is this a usb port/bus problem? No. George tried multiple ports with this dri...

10:57 AM
sorry I din't read it enough! :(
if the drive is a fake, filling it up should spit out messages like "wtf, i can't take any more data! stuff it elsewhere!". it shouldn't roll over and die.
Q: Unity keyboard/mouse shortcuts

htorqueIn Compiz-based Unity, are there any pre-defined shortcuts, e.g. to open the dash or unhide the launcher?

hehe, that's going to get me the Famous Question badge ;P
@htorque lol. is that why you're posting it in chat?
is it a hardware problem like something is broken?
10:59 AM
@htorque that's a useful question though. nice clearinghouse
@djeikyb actually it was JorgeCastro's idea, so thanks for the gold badge :P
@Alvar i'm pretty sure the drive is broken. the vista test will help confirm this, but george never made it back. vista ate him
@djeikyb hehe, too bad really...
but still he has 600 mb to use ;)
@Alvar haha, i was wondering if maybe he can make a bunch of 600 mb fat partitions...don't know the nature of the brokenness.
"Oh my God, Vista killed George! ... You b*tards!" >:D
11:03 AM
@htorque don't swear! :D
@Alvar i didn't - it was just a quote :P
@djeikyb that would be awesome, but I think that only 600 mb is working that might be the problem...
@htorque of who? :O
@htorque gasp
@Alvar an alternate reality cartman.
@Alvar that's a quote from south park :)
11:05 AM
aha... neards.....
@Alvar meme. "omg, X killed Y! You Z" where x is offender, y is victim, z is epithet towards x
i think i've seen two episodes, but the meme is everywhere
and people say that I have to much spare time!
@djeikyb lol
@Alvar btw, your website is down. followed the link in your profile: alvarberglind.se
11:12 AM
I know
I had to restart the router last night will make a fixed ip when I have the time...
but thanks to rmeind me! :D
will try to fix it now :D! :D
@Alvar good times : ) i looked at a google cache, and it looks like i won't be able to read any of it anyhow. i'm more or less monolingual
not that your page shouldn't be swedish(?)..
@djeikyb what?
@djeikyb the server is a power mac g3 with ubuntu 8.04 :D
@djeikyb oooh, I'm planning on making a english version for people with not a swedish ip, still on my to do list
the page is just very very basic, it works that's it kind of..
trying to connect to a server is haaaard work! :D
ssh: connect to host port 22: Connection refused what should i do?
@djeikyb google translate! ;)
11:30 AM
@Alvar is your local lan server?
@Alvar add verbosity! ssh -vvv although maybe just start with one
OpenSSH_5.3p1 Debian-3ubuntu6, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host port 22: Connection refused
hm. maybe the ssh_config on the server is messed up
11:33 AM
or the ssh service isn't started
well I don't have a screen on it just a keyboard, so im a bit blind..
@marcoCeppi any ideas?
umm, service ssh start
or, sshd
on the remote machine, then retry
what is the first you see if you rebote a server? (ubuntu server 8.04)
is it a login screen?
typing blind
11:37 AM
on server edition, it should be a login prompt
unless you marred a perfectly good interface with gdm ;p
lol I can connect o my own laptop from my laptop by using ssh LOL
@djeikyb not likely...
@Alvar and with good reason :-)
gah! typing blind is VERY hard
nothing works...
hmmmm, what to do?
I could just pick up the server and plug it into a screen that would work.. but it's messy...
12:02 PM
o_o Why would xorg use up more than 30% of 2GB of RAM?
filesystem has failed :D
Posted by Jeff Atwood on April 5th, 2011

In A Recipe to Promote your Site, Robert provided a great set of guidelines for organically growing your Q&A community. Buried within was this observation:

Reach the right kind of publications and bloggers. Make sure that the key experts in every field know about the site; not just the “Martha Stewart” big names; we want to talk to the people who go to these conferences.

But how do you reach writers, bloggers, and other notable experts in the field?

Help them get answers to their questions, too!  …

/dev/hdc3/ contains errors
12:29 PM
I got my server working but now I can't login!
the maps doesn't exist
hey @htorque
My ubuntu 8.04.4 LTS Server is dead! :( It might work to reinstall... sad
12:44 PM
@JorgeCastro quick status update on the blekko thing: It's slooooooooow :-) But I don't know anything else yet. I'll test it properly once I'm done with my day's work
sounds good
I got up early do do some questions today
nice :-)
Oh, that means you'll pass me in the all-time-reputation ranking
I saw you passed me last week!
it's mostly editing
I've been really slow these last two weeks, rep wise. I've got so many new projects and things...
Now I'm thinking about writing python bindings for pulseaudio
@JorgeCastro Can you give the upstream question for this duplicate a bit of love? Reading the duplicate question's body, the answer on the original won't work because the shortcut is bound to Expo. I know nothing about Unity and I class you as our Unity guy.
Q: what will the new Session Menu keyboard shortcut be in Unity? --the current one is redesignated in Unity

Chad Possible Duplicate: Is there a way to access Session Menu with keyboard shortcut? I've always used the keyboard shortcut "Super + S + Up-Arrow" to activate the Session Menu's Shut Down option in the 10.04/10.10 panel. When reading this list Unity keyboard/mouse shortcuts I noticed tha...

12:50 PM
@Oli it's currently a bug, I'm trying to find out which key for sure will be the shortcut
that was duped like twice yesterday or something
it's on my list!
@JorgeCastro Thank you!
I'm just going to play with a few settings here. Please forgive me if I destroy the room.
00:00 - 13:0013:00 - 22:00

« first day (188 days earlier)      last day (2420 days later) »