« first day (4616 days earlier)      last day (277 days later) » 

12:48 AM
me when the java is unsure
 
 
5 hours later…
6:02 AM
hmm, new posts seems to be offline
 
(cc @RydwolfPrograms)
Seems to be just rydwolf's bots that are down
Not his server
Yeah seems like everything on the rto hosted stuff is functional
 
Beep beep, I'm @SandboxPosts
0
A: Sandbox for Proposed Challenges

BubblerDo you win a Numeric Mahjong? code-golf games decision-problem self-validating restricted-source Background Numeric Mahjong is a hypothetical variation of Japanese Mahjong, played with nonnegative integers instead of Mahjong tiles. Given a list of nonnegative integers, it is a winning hand if it ...

 
heh
 
RIP 4-month uptime or something
 
@mousetail new bot just dropped
 
6:13 AM
Apr 1, 2022 at 8:52, by New Posts
I tried.
 
6:38 AM
@lyxal Holy hell
 
7:02 AM
@thejonymyster ties are allowed
I think there might be a linear time solution to my fastest-code challenge !
 
7:25 AM
hi @mousetail
 
 
4 hours later…
11:35 AM
@mousetail actual compilation failure
 
12:19 PM
@emanresuA photoshop?
 
You can create these types of things much faster and more realistically with inspect element than with photoshop
 
@mousetail ah yes. true
 
imagine needing inspect element and/or photoshop
😎
 
@lyxal Imagine saying Imagine with a lowercase i
 
Yea I just release a butterfly to shift the air currents to focus cosmic rays exactly at the part of your brain so you think you see a certain message
4
(using the emacs builtin of course)
 
12:29 PM
@mousetail Oh, I only need to click my fingers to do all that.
 
y'all that's way too much work I just count to 11 and the messages change themselves globally :p
> Congratulations to Stack Overflow user macxpat, whose answer to How to install Linux packages in Replit earned a Lifeboat badge.
thanks SE very cool
 
@mousetail those who control bits and men rule this land
 
A politician in NL just accused the king of using chatGPT to write his speech
 
ಠ_ಠ
okay, those last 4 messages
 
is that a universal ಠ_ಠ at all the messages or something specific?
 
12:33 PM
effectively the last 3 messages before it by you and mousetail
 
@mousetail The king thinks it is unholy to use ChatGPT. Why would anyone think that?
 
20 secs ago, by Ginger
effectively the last 3 messages before it by you and mathcat
> mathcat
 
brain failure, sorry
 
this is joe biden's america
@lyxal anyhow, the funny here is that macxpat did not get a lifeboat badge at all
 
@TheEmptyStringPhotographer Caroline (the politician) did acknowledge that the king doesn't write their own speeches so it might be the writing team
 
12:35 PM
me on my way to check the King's speeches against the strong and weak heuristics
 
I listened to the speech and I think it's very unlikely myself
 
@mousetail I just accused a politician in NL for wrongfully accusing the King for using ChatGPT for their speech.
 
one day you're just minding your own business then all of a sudden on the BBC the king says "regenerate response"
 
@lyxal I am mousetail confirmed
 
> One of the most pressing challenges we face is the global issue of climate change. The science is clear, and the evidence is undeniable. We must take urgent action to protect our environment and ensure a sustainable future for generations to come. I commit to working tirelessly to reduce our carbon footprint, promote renewable energy, and support innovative solutions to combat climate change.
the AI has perfected the art of empty text :p
 
12:42 PM
any extra feedback on this?
0
A: Sandbox for Proposed Challenges

UndoneStudiosDigits of Infinity (computing A206636) code-golfmath In this PDF, https://www.vixra.org outlines a way to find the last \$ n \$1, 3 digits of infinity and a method to do so. Let us define the infinity sequence2, taking the function \$ f(n) \$. \$ f(1) = 2^2 = 4\$ \$ f(n) = 2^{f(n-1)}\$ Starting f...

 
1:32 PM
hey @pxeger
 
tomatoes
 
how'd you go about making the legal stuff for ATO? I'm working on a project and I'm not sure what I need to do legally for it
 
iirc a lot of it is copied from githubs tos
 
IDK if I need a TOS tho
I'm sure I do for some legal reason ofc :/
 
surely
 
1:35 PM
@Ginger TOS stands for "terms of service" and dictates what users can and cannot do with your application.
 
I know that
 
@Ginger But whether you need a TOS depends on whether you want to let users do whatever they want with your application.
 
@TheEmptyStringPhotographer what? I thought it meant tomatoes or sauce??
 
@mathscat aww i wont get my tomatoes and sauce now :(
 
me on my way to make an area 51 bug report because the whole system is just yikes
0
Q: Attempting to ask a question on Area 51 changes my profile picture

lyxalEvery time I click the "Ask Question" button on Area 51 Meta (https://area51.meta.stackexchange.com/), it changes any profile picture I have to a default gravatar. Further clicks of the "Ask Question" button just generate a different default gravatar. I can't upload a video of it directly to SE, ...

 
1:41 PM
@lyxal lol what
 
good lord
 
@mathscat no clue why it's doing this
I found it by clicking "discuss proposal" on PLDI on normal A51 just to see what it would do
(the thinking being that it's not a proposal as so much a private beta site)
 
@Ginger frankly idk if I need one either
there's just a small part of me that thinks writing in lawyer-speak makes me sound cool
or something like that
 
@lyxal wtf
 
@Bubbler Seems it tried to log in and got 403'd on the login page ten times in a row
 
1:44 PM
@Bbrk24 this is peak Area 51 efficiency
 
@RydwolfPrograms ruh roh
might that have something to do with the login flow changes?
lemme check if sechat still works...
 
...and it's been doing that constantly for hours it seems
Every two minutes for at least six hours yeah lol
 
might want to kill it before it locks you out
 
@Ginger why wouldn't it?
 
Okay perhaps a user agent issue?
 
1:46 PM
seems to still be working for bots currently signed in. do you mean logging a bot out?
 
It's logging in that seems to be the problem
 
seems fine
 
@lyxal ain't no way it got reproduced on another machine
 
Is Unit Tester one of your bots or someone who just happened to show up
 
i love accidentally finding area 51 bugs :p
 
1:46 PM
that's me lol
you can kick it
 
@Bbrk24 it's a ginger (tm) bot :p
@Ginger actually you can't
 
@RydwolfPrograms sechat still works fine, so it's an issue on your end
 
Hang on I may have found the issue
 
 
> <title>Just a moment...</title>
 
1:47 PM
Unit Tester is literally unkickable
 
Seems some sort of redirecting stuff is happening
> Enable JavaScript and cookies to continue
 
ohh might it be due to the fact that SE is changing its ips?
 
@lyxal that's a new one lol
 
@RydwolfPrograms Ruh roh
 
I'm really not sure how your bots are logging in fine
They're doing full logins right, and not restoring from stored creds?
 
1:49 PM
I think?
lemme verify, one seccy
 
fair warning that this could be an SE problem
that's not something you would expect to be broken
and a similar thing could be happening to the bots
 
@RydwolfPrograms yup
 
full logins work fine
 
Okay this must be some sort of anti-spam thing or something
Because I get something different if I curl on the server vs. use FF on my own machine
Lemme try curling from my machine to see if it's IP based or useragent based
 
1:52 PM
did NP get IP-banned
 
frick, curl works fine from my IP
 
oof
 
try FF from your server
 
Wait hang on...sock² routes through the same server as NPSP
So I actually can do that :p
 
@RydwolfPrograms I'm using your server tho?
does my VM have a different IP?
 
1:53 PM
@Bbrk24 doesn't seem to have
 
@Ginger My home server, not my cloud droplet
 
ah
 
Oh it would help if I tested this with the proxy enabled lol
Yep, fails now
 
it'd be interesting if it were UA-based, since sechat doesn't use a standard UA
so they'd have to be specifically blocking curl or smth
 
It's not, it's IP-based
 
1:56 PM
so NP got IP-banned?
 
wait no my proxy's just borked lol
 
oh :p
 
> locsalhost
Might be it
 
1337.0.0.1
 
Cloudflare
It took me to a cloudflare DDoS protection thingy
 
1:57 PM
@Ginger at least not on main sites
 
Hopefully now that I've done it on this IP NPSP will be fine?
 
NP DDOS confirmed?!
 
Okay it's still failing, hmm. Might be IP+UA based?
I could either try to manually do the cloudflare thing via curl, or somehow change my user agent to NPSP's in chrome
Okay I think I'm gonna have to work fast but I'll try to do it with curl
SOCKS works at too low of a level for me to be able to crack open the HTTPS to change the user agent
@RydwolfPrograms Okay nope that's not happening
 
2:21 PM
Too bad SE's probably already in my browser's HSTS
 
hyperspaghetti transport system
 
I wonder what would happen if I tried a different site on the network as the login site
That'd mean I need to recompile tho, ugh
 
imagine using a compiled language, couldn't be me
 
I'll just run it on rtowolf for now
 
2:34 PM
wtf and now it's still getting 403'd on my home IP
And now curl from my home IP doesn't work
VyxalBot may run into issues soon
 
hmm
I wonder what's causing this?
 
Cloudflare
 
since when has SE used Cloudflare?
 
Since whenever NPSP broke
 
someone at SE dun goofed while setting up Cloudflare?
but if that's the case, and this is a permanent thing, it doesn't look very good for chatbots
 
2:39 PM
I think this is intended behavior, just dumb behavior
The bots are, after all, indeed not humans
 
@Ginger ah, is SE doing stuff without informing anybody again?
 
so it would seem
@RydwolfPrograms the question is if SE's actually trying to kill chatbots or if this is collateral damage from something else
ah, I found the post
 
that's from 9 years ago
@Ginger this is definitely collateral damage
 
@Ginger Could you try relogging VB?
 
@pxeger huh, so it is
 
2:42 PM
Ideally a second instance of it
 
SE chat does not even cross the mind of the anyone at SE at the moment
 
Since if you try the primary one and it fails it's locked out for the time being
 
I've never actually tried running two instances of VB at once, but ok
wdym by "relogging", btw?
 
Like having it log in from scratch
No stored cookie jar/fkey
 
I can try, just a sec
does it have to be VB itself, or can I use a test program running under VB's account?
 
2:44 PM
@pxeger we need a representative at SE for chat [riot]
 
@Ginger Either
 
I'm going to use a test program
in Sandbox, 20 secs ago, by Vyxal Bot
eggs
seems to be working
 
1
Q: New cloudflare protection breaking important bots

Radvylf ProgramsSomething about SE's DDoS protection or human verification must have changed, which has caused several important chatbots to no longer be able to log in. At first, curling /users/login from my home IP worked, and a bot hosted there could log in just fine, while a bot of mine running on a cloud se...

 
> also taking down VyxalBot, another bot run on my home server.
uh, no?
VB's fine
 
I wrote that before that turned out to be the case
I'm really not sure how VB's still good tho
What's its UA?
 
2:48 PM
you know what happens when you assume
Mozilla/5.0 (compatible; automated;) sechat/2.0.0 (logged in as user 296403; +http://pypi.org/project/sechat)
 
Have you actually got confirmation any actually imporant bots (like smokey) are effected? I wouldn't call your bots important
 
Smokey's fine
 
They're important to CGCC and PLDI
 
^
 
No, we could always get the posts a few minutes later
not worth drama
 
2:51 PM
I'd call an important bot one that serves a serious moderation purpose. An unimportant bot would be like Snowpaw
It's not "drama"
 
what's it matter to you?
 
I object to the term "important bots"
none of these bots are important
 
Again what's it matter to you
Importance is subjective and a half
If this gets more attention on the issue being fixed what's the harm
I know you like to take every opportunity to argue with and cast doubt on the things I say but this really isn't anything you need to be concerned about
 
Apologies for this - I've escalated it internally and we're investigating what's going on. Thanks for bringing this to our attention! — Catija ♦ 16 mins ago
 
well, at least things are happening
uh-oh
SE OAuth seems to be broken
 
3:21 PM
does logging into metasmoke work for yall?
I'm getting a 400
...and now it works :|
of course right when I ask about it it fixes itself
ok, time to switch on the bot
oh wait, gotta make an account first
actually nah I'll use a testing one for now
 
3:37 PM
bot is online
and now we wait
hey @RydwolfPrograms how does NPSP handle credential expiration?
I'm going to need to add something similar to sechat if I want it to really be bulletproof
actually, does it even have to?
I'm not sure fkeys expire
 
4:17 PM
CMC Output all decimal integers except the number that comes immediately before a multiple of 10 should appear after instead (swap spaces). Eg. 1, 2, 3, 4, 5, 6, 7, 8, 10, 9, 11, 12, 13, 14, 15, 16, 17, 18, 20, 19...
 
4:44 PM
@Ginger They can
@Ginger Two hours is what I went with
It only really needs to be long enough that you don't need to relog for a quick restart
We've got a fix for your specific case coming soon but this fix won't necessarily prevent others from having similar issues - which may require some discussion internally. Thanks for the report! — Catija ♦ 1 hour ago
Whoa does this mean they're specifically special-casing NPSP (for now)?
 
:O
special-case me too!
 
@mousetail for some reason this isn't trivial
 
CMC bash challenge. Make a random binary string of length 12 in bash
 
5:00 PM
printf doesn't have a "binary" format specifier or else this would be a lot easier
 
yes!
cat /dev/urandom | tr -dc '0-1' | fold -w 12 | head -n 1 is my best go
 
@Simd Bash, 17 bytes: echo 111111111111 (Chosen by fair dice roll, guaranteed to be random.)
 
@Simd Instead of fold + head, just do head -c 12
 
@TheEmptyStringPhotographer :)
@Bbrk24 ah!
 
-n is lines, -c is characters
 
5:03 PM
thanks!
I hardly understand fold
 
well strictly speaking -c is bytes but that doesn't matter for this purpose
 
echo £ | head -c 1
 
or, since this is code golf, cat /dev/random|tr -dc 0-1|head -c12
 
@Bbrk24 better!
 
5:19 PM
(111 bits with vyncode)
 
Not sure if this is the shortest approach in Swift, but (0...).lazy.flatMap{($0*10)..<($0*10+9)+[$0*10+10,$0*10+9]}.dropFirst() works
 
@mathscat separates the integers into two lists, shifts one and interleaves them together. wonder if there's a shorter approach.
 
Nope, that stalls. Is dropFirst() being eager here?
 
YES MY BOT WORKS!!!
 
it stalls even without dropFirst(), so bad that ^C doesn't even stop the repl
 
5:27 PM
CMegaC: Make a programme that continues running even when the SIGKILL signal is sent to it.
 
Okay it's the + in the callback that stalls it
 
isn't that impossible
 
it stalls the type checker, not the runtime
let x = (0...).lazy.flatMap { $0 ..< ($0 + 10) + [$0, $0 + 1] }.dropFirst()
error: repl.swift:8:5: error: the compiler is unable to type-check this expression in reasonable time; try breaking up the expression into distinct sub-expressions
 
I thought SIGKILL couldn't be ignored or blocked and the kernel would just immediately kill the process with that signal
 
That's why it's CMegaC
 
5:29 PM
what.
 
> CMegaC: Chat Mega Challenge; usually a challenge posted jokingly in chat due to it being very involved or outright impossible.
 
I'm just double checking if I remember correctly lol
 
@Bbrk24 ah right
 
Can you SIGKILL the kernel itself?
 
5:51 PM
I don't think the kernel has a PID
 
Kernel is the thing that handles signals
There might be a command to uninstall kernel modules at runtime though which is kinda the same thing
@mathscat Nice
 
6:14 PM
Commenting trilangle "assembly" like
; <13>
    PSI #7
    DUP
    ADD
    DEC
; </13>
 
 
4 hours later…
9:45 PM
@mousetail Pip, 18 bytes: W UiPi+(9=Yi%t)-!y
Fun version using the swap operator, 22 bytes: Y\,ty@8::y@9W1P*y+t*Uv
 
10:23 PM
@mousetail A first stab at it in FunStack: Flatten Plus Times 10 compose table #N Consr 9 Consr 10 From1 9
Better idea: Plus Consr 9 Consr 10 From1 9 flatmap Times 10 #N
Disappointingly, Concat From1 9 Pair 10 9 is the same length as Consr 9 Consr 10 From1 9, although I suppose it's more readable
 
10:38 PM
@mousetail Haskell, 31 bytes: (+)<$>[0,10..]<*>[1..8]++[10,9]
awkward first stab at it in Jelly, 13 bytes: ‘µ‘%⁵=Ø.Iạ¹Ṅß}
 
10:59 PM
7.5 bytes encoded
 
11:23 PM
CMC: 3D Print "Hello, World!"
 
It has 3 D's in it just like you asked
 
11:56 PM
CMQ: Of the following Greek letters, which do you think is the most important/useful in a math/CS context likely to come up in TNB?
(I have one extra slot for a greek letter in CIMJ's shortlist of greek letters)
Γ (big gamma), η (eta), Θ (big theta), ϑ (vartheta), κ (kappa), ϰ (varkappa), Λ (big lambda), ν (nu), Ξ (big xi), ξ (xi), ϖ (varpi), ρ (rho), ϱ (varrho), Σ (big sigma), Υ (big upsilon), υ (upsilon), Φ (big phi)
I'm thinking probably big theta for big theta notation right?
Rho could also be useful
Or big lambda
 
what's upsilon?
 
But the rest don't really seem like contenders
@lyxal Similar to updog I think
 

« first day (4616 days earlier)      last day (277 days later) »