« first day (144 days earlier)      last day (3202 days later) » 

12:09 AM
0
Q: svn command to see a tally of my changes

Amir AfghaniIs there an SVN command that I can run to see a tally of all of my contributions? Something like: added 1800 deleted 15

 
 
1 hour later…
1:18 AM
0
Q: GNU Screen makes Vim ESC key slow

bryan_ruizScreen makes my ESC key wait for more commands I beleive, and if it does not get those commands, it sends it to my terminal Session (which I am running VIM in). ESC is used alot in VIM and currently I do not make any use of the ESC key in Screen. How would I go about changing the timeout? I h...

 
2:00 AM
0
Q: Can I make scripts use aliases instead of commands?

phuneheheI have an alias for a command (I'm setting up a Python development environment) alias python=~/virtualenv/bin/python so that I can run ~/virtualenv/bin/python by just typing python. Now in my project there is a shell script that goes, for example: #!/bin/sh python run-project.py Can I make ...

 
 
3 hours later…
4:45 AM
0
Q: Is it possible in bash, to start reading a file from an arbitary byte count offset?

fred.bearI want to locate a date which is somewhere in an 8 GB log (text). Can I somewhat bypass a full sequential read, and first do binary splits of the file (size), or somehow navigating the filesystem inodes (which I know very little about), to start reading from each split point, until if find a ...

 
 
1 hour later…
6:06 AM
0
Q: How do you rename root?

yxkbNot that its a very good idea to change it, but for fun. According to this post, there are still some problems even after changing entries in etc/passwd and etc/shadow(and sudoers). Any suggestions?

 
 
2 hours later…
8:06 AM
0
Q: squid configuration

WolfyHello, I would like to configure squid in such way, so that only specific (public) ip, could connect to the server, but I don't know how... can someone tell me how to do this?

 
8:24 AM
0
Q: How to send mail ?

Erkan HaspulatHi, I'm trying to send mail from shell(GNU bash, version 3.2.25(1)-release (x86_64-redhat-linux-gnu)) using; mail foo@bar.com After I complete the command, the mail won't show up in the mailbox. What could be wrong, how can I check is my configuration is correct. Thanks.

0
Q: Unable to locate package xinetd

ShiraHi! i tried to install xinetd- by the command "sudo apt-get install xinetd" & got this error message "Unable to locate package xinetd" - why? isn't it supposed to be under init.d folder??? thank you all- it's pretty urgent.....

0
Q: Read Microsoft Excel File

chanchal1987How to read XLS File (Microsoft Excel) using unix Bash / Corn shell script?

 
9:24 AM
0
Q: Installing php on Debian (newbie question)

Kevin DukeI have a vps with Debian Linux on it. I'm trying to install a php file manager so that people could access it and download stuff into a directory. I don't have anything in my /bin about php so this is probably the issue I installed php with this command apt-get install php5 php5-cgi php5-cli...

 
10:09 AM
0
Q: What to do about [install] tag?

TshepangSome ideas: Rename the install tag, to something like installation? If applicable, get rid of it in favor of package-management or something more specific (apt or yum)? If not, limit it to OS installation and installations not involving a package manager?

 
10:23 AM
interesting what happened with Physics design; probably the first that was reverted after being applied?
5
Q: New Design Launched

JinHi all, As you can see the new design is live, which means Physics-SE has been officially launched, and is no longer a Beta site! Congratulations! Also, thank you for the feedback on the design. I decided not to use the handwritten font as much I did in the mockups. I agree with you that they'...

here's what it looked like
13
Q: Design for Physics-SE

JinHi all. I'm Jin, and I'll be working on the designs for the Stack Exchange sites as they graduate from the beta phase. Each site will have its own unique theme that will reflect its topic. However, all sites will share quite a bit of common elements so they feel like they're part of the Stack Exc...

 
11:07 AM
@MichaelMrozek what do you think of the post I have left flagged?
 
 
1 hour later…
12:33 PM
this rather comprehensive answer hasn't received the honor it deserves
2
A: monitoring activity on my computer.

GillesIs the other guy on to you? If he has physical access or root access, he can erase all his traces and even plant a bug to spy on you. On the other hand, some traces are a pain to erase, and it's hard to think of everything. Various things are already recorded in the system logs, typically in /va...

 
0
Q: Remove alias from current session

chanchal1987How to remove a alias from current session without closing that session?

 
1:04 PM
@xenoterracide let's remove our comments on this: unix.stackexchange.com/q/2770/688
they r outdated
 
0
Q: Can't connect to internet in Ubuntu 10.10

Richard CalahanI'm having trouble getting Ubuntu connected to the internet in vmware fusion. Every other Linux distro has no trouble... Ifconfig shows that eth0 is up and running, has been assigned an ipv4 address (DHCP) as well as an ipv6 address. I can ping localhost, but nothing else. It just stalls out. I'...

 
1:54 PM
0
Q: russian letters in gentoo console as '?'

valyaHello, I managed to get russian language working in my Gnome apps, but neither in the console (Alt-Shift-F2 and such) nor in the Gnome Terminal valyagentoo va1en0k # locale LANG=ru_RU.UTF-8 LC_CTYPE="ru_RU.UTF-8" LC_NUMERIC="ru_RU.UTF-8" LC_TIME="ru_RU.UTF-8" LC_COLLATE="ru_RU.UTF-8" LC_MONETAR...

 
2:21 PM
0
Q: kill a parent process without killing its child

valyaHello, sometimes I run an app in the gnome-terminal, but then I suddenly have to restart gnome or something. I guess the answer to the question is also useful then I want to disconnect from SSH where something is happenning. Gnome's terminal tree looks like this: gnome-terminal bash ...

 
2:36 PM
@Tshepang I wish you wouldn't do that, it makes comment threads completely unreadable
 
@MichaelMrozek not when the other guy is willing to delete their comments
why do you want comments there when they are at times useless/outdated?
EG, xeno's referred to a time when we were still in Beta
that will confuse any one coming to the site, wondering what the hell is Beta
but I guess I must delete my comments, only when the other guy is willing to delete theirs
 
I think people probably know what betas are. I guess if you delete them all it's fine, but it's really unusual; normally you just leave old threads alone
 
normally? advantage of SE sites is we can get rid of no-longer-relevant stuff
in terms of posts, we edit them
since we can't edit comments, we might as well delete them
esp because they r second class
a comment should ideally be incorporated into a post (question/answer)
 
Yes, but you keep doing things like trying to get commenters to delete their comments after you've updated your posts, which seems rude to me -- if they found a problem, let them get the credit for pointing it out
 
if it's that useful
@MichaelMrozek I thought the main bodies (posts) is where the action should take place
if commenter suggests corrections, I should edit the question
 
2:44 PM
Yes, but that doesn't mean they need to delete their comment afterwards
 
sometimes, maybe when the already r answers, I should add an update note
@MichaelMrozek is the issue here credit, or what?
 
Yes; if somebody points out something in a comment, they're the one who pointed it out; they shouldn't need to delete that
 
it's kool if they insist their comments should remain there, but I don't know what for
yes, but if I edit the question to incorporate their suggestion, then their comment is outdated
someone reading it will wonder what is she talking about
 
No they won't, they'll see that you edited the post and assume that it was in response to that question
You can leave a "thanks, fixed" comment if you want
 
someone who is unaware about edited date for one
 
2:48 PM
Then they should learn
I point all this out because I don't want you to become a mod and go on comment-killing rampages
 
no, I wouldn't do that
I would ask permission first
 
Ok. Anyway, I have to go; I'll be on later
 
ok
 
3:09 PM
@Tshepang in this case it was ok though I think unnecessary. But there were some cases where the comment conversation was relevant, and you deleted it... I don't agree with that. If the conversation is in any way relevant to the question/answer it should probably be left alone. if it's relevant to the previous comment, leave it alone, unless it's a way offtopic asside... which is basically what that side convo was, which is why I deleted it.
 
I am posting this to meta
 
0
Q: mv failed halfway through - is source directory intact

RichI ran mv a-folder /home/me on a machine and half way through the move the destination device filled up. a-folder was made up of folders and files in various subdirectories. Does mv leave the source folder intact until the move has successfully completed? The source and destination folders were...

0
Q: Is there an analog of apt-pinning in Fedora?

SIOApt pinning is a feature that allows to set install priority for a group of packages, determined by a number of attributes, such as package version, repository, distro version, etc. See man apt_preferences for more (http://linux.die.net/man/5/apt_preferences) Quote: APT then applies the fol...

 
0
Q: Regarding 'no-longer-relevant' Comments

TshepangI recently discussed the merit of keeping no-longer-relevant Comments around with Michael Mrozek. Scenarios: OP follows a suggestion by a commenter, something like add output of the exact error message when you... A commenter mentions some info that is outdated, like Squeeze is still in freeze...

 
3:29 PM
that was an easy 45 rep
3
A: Remove alias from current session

TshepangSupposing that your alias to python is py, do: $ unalias py (via)

it was the first result from Google :)
 
 
1 hour later…
4:39 PM
0
Q: Alias in cygwin bash doesn't seem to run in the right order.

dj_segfaultI am trying to create an alias to use in my Cygwin shell to determine if the Mercurial-managed directory I'm currently in has outstanding changes. The command "hg st -m" lists all modified files. Unfortunately it doesn't set an exit value based on whether there are changes or not. So I have tr...

 
5:33 PM
1
Q: How to get a notification when my commands are done

Amir AfghaniI'm running a series of commands on the command line that takes approximately twenty minutes to complete. I'd like to see some sort of notification on my Mac when these are finished so I don't need to monitor the terminal for when it finishes. Is there a way to do this? $svn update . &&...

0
Q: How to cache or otherwise speed up `du` summaries?

Ian MackinnonWe have a large file system on which a full du (disk usage) summary takes over two minutes. I'd like to find a way to speed up a disk usage summary for arbitrary directories on that file system. For small branches I've noticed that du results seem to be cached somehow, as repeat requests are muc...

 
6:25 PM
AU is a great SE success
it's no. 5 in terms of traffic: stackexchange.com/sites?sort=traffic&expand=true
we r no. 18
 
6:42 PM
0
Q: backup MSSQL server using a mysqldump-like tool

drizzleI'm trying to backup a MSSQL server from linux. I'm able to connect to the server using tsql (from the freetds project), and I'm even able to backup the database on the server using the backup database command, but I haven't been able to download this backup onto the machine I'm using to connect...

0
Q: I can't remove a recursive copy of /proc as normal user

kisplitThis seems very strange to me. I'm running kernel 2.6.37.2 and ran: ~]$ cp -r /proc/ here ~]$ rm -rf here I get some permission denies when copying as expected and I eventually hit Control-C. I get Permission denied on a lot of files when trying to remove the new directory and files. As a not...

 
7:05 PM
@MichaelMrozek @anyone user etiquette question
@UnixandLinux The asker just closed this question
But it's a useful question, I'm sure other people have wondered the same thing
Should I vote to undelete?
Repost a similar question? (doesn't seem fair on the original asker)
 
@Gilles Yeah; most of my undelete votes on SO are questions the asker deleted that were actually good
 
Just forget about it? (but I have an answer ready)
 
He actually edited in the answer before deleting the post; he should've just self-answered
 
@MichaelMrozek He did?
Oh, I now have the question in three tabs opened at different times
Tab 1: original question, live
Tab 2: original question, deleted 53 secs ago
Tab 3: edited question, edited after it was deleted
 
Oh, it was after; I forgot users can do that
(Because of my bug report, comically)
 
7:11 PM
@MichaelMrozek Anyway I voted to undelete, which is an empty gesture since the other potential undeleters are all mods
 
I undeleted it, I was just waiting for you to vote since you noticed it :)
 
0
Q: exim4 on debian: why does this ACL work when testing with -bh but not in actual use?

jcomeau_ictxI've got local_acl_check_data to reject the typical spammer tactic of using the same address as From: and To:, but since some less-spammy sources, such as Yahoo Groups, do this, I'm using a whitelist as well. Here is the ACL: # block spammers who use the same "from" and "to" address accept ...

 
When the question deletion notification bar appears, the “Post your answer” button is disabled and the answer saver stops running. That's not nice (but I admit it's a rare scenario).
@UnixandLinux Is there some kind of law that all database engines must be called /^m.*sql$/i (msql, mysql, mssql)? I had to read this question three times for it to make sense, and yet it's as clear as it should be
 
8:14 PM
@xenoterracide u mind reading ur answer again
2
A: mv failed halfway through - is source directory intact

xenoterracideNo your source folder is not intact... I'm not sure how mv. on the same file system all it does is adds and removed directory entries. But on a different filesystem... I'm not sure at what point it unlinks the file, and whether it removes data as it goes... but once a file is moved, it is unlinke...

there's a grammar problem or 2
 
 
1 hour later…
9:26 PM
@Tshepang Nothing that would make the post unclear. If you're really bothered, you can edit it.
 
0
Q: How do I determine the make & model of my storage devices?

Stefan LasiewskiI'm running a CentOS 5.5 system. This system has 4 disks and a 3ware RAID controller. How can I determine the make and model of my drives? /proc/scsi/scsi and parted --list shows the RAID controller (3ware 9650SE-4LP): # cat /proc/scsi/scsi Attached devices: Host: scsi0 Channel: 00 Id: 00 Lun:...

 
10:06 PM
@Gilles Really? I have no idea what "No your source folder is not intact... I'm not sure how mv. on the same file system all it does is adds and removed directory entries." is about
 
@MichaelMrozek Oh, right, there's a fragment that doesn't belong, I skipped it on first reading. I've gone and edited it.
 
\o/
@Tshepang You can always fix grammar problems in posts; you earned 2k, go to town
 
10:22 PM
Heh, so you can exceed the rep cap and have less than 200 rep for the day
(I'm waiting for the right to do unsupervised tag wiki edits. Not that I intend to have much time for that soon. But I'm impressed that one thing SFF is actively doing is tag wikis.)
 
10:54 PM
0
Q: How is the octal 2-byte output calculated from od

theconnorpowerHi, I'm struggling to work out what the octal 2-byte output from the od command is. I understand the octal output (-b flag) but the octal 2-byte is a mystery to me (-o) Can someone shed some light on how the -o result is calculated from ASCII? Here is an example: [root@localhost lpi103-2]# ca...

0
Q: Is it possible to find the path of a running program?

WolfI have a xmms2d process running, but two possible executable files (in different directories, both in the executable path) that could have spawned it. I suspect that one of those is corrupted, because sometimes this program works and sometimes it doesn't. The process running now works, so I want ...

 
11:11 PM
1
Q: I can't remove a recursive copy of /proc as normal user

kisplitThis seems very strange to me. I'm running kernel 2.6.37.2 and ran: ~]$ cp -r /proc/ here ~]$ rm -rf here I get some permission denies when copying as expected and I eventually hit Control-C. I get Permission denied on a lot of files when trying to remove the new directory and files. As a not...

Why did 6 people vote for my answer and not for the question‽
 
I upvote questions if I think they're likely to help other people, and answers if I think they helped the asker
That problem seems unlikely to happen to other people
 
@MichaelMrozek Ok, so here you should upvote the question and not the answer
 
The answer clearly helped him, he even commented to say so. The question I don't think is likely to help anyone else, people don't generally make copies of /proc to begin with
 
@MichaelMrozek He'd figured it out, so I don't think I actually helped him. Few people copy /proc, but I've seen the misconception that rm -rf can delete everything before, and that's what the question is really about, /proc is just an example
Maybe the title could be generalized
“I can't remove a directory tree with rm -rf even though I own it” (too long but you get the idea)
 
That's not a bad idea; you could leave off "even though I own it"
 

« first day (144 days earlier)      last day (3202 days later) »