« first day (136 days earlier)      last day (3532 days later) » 

12:24 AM
Q: Alternative to Miro Video Converter for Linux?

penyuanBack in the Windows/Mac days, I used the wonderfully easy to use Miro Video Converter to convert videos I have into either the more open and Freerer Theora or WebM formats. Two problems: (1) No Linux binary that I could use. (2) No advanced options that let me control the conversion process, su...

2 hours later…
2:00 AM
Q: Is dpkg available for Cygwin?

andrewsomethingI don't use Windows all that often, but I've found my self in a position where I'm stuck in front of one quite a bit temporarily. So I've been investigating Cygwin. My question is dpkg available for Cygwin? My Google searches seem to show that it was at least at one point, but I can't find a pack...

2:21 AM
1 hour later…
3:39 AM
Q: How to make functions created in normal bash script not persist like those in .bashrc

John BerrymanMy .bashrc was getting a little long, so I decided to break it up into smaller files according to topic and then call these files from within .bashrc as so #my long .bashrc file bash .topic1rc bash .topic2rc but, within one of these sub-scripts, I had created a bash function. Unfortunately it...

2 hours later…
5:25 AM
Q: Linux distribution for the AMD Geode LX 800 (i586)

r1xThe manufacturer recommendfs RH9 (ugh) and many of the google search hits come up with comments from 2006/7 which detail xorg problems with the amd driver and I'm hoping someone here has had recent experience. I have two questions: 1) Which Linux distribution (I'm going use gtk/boost/wxwidgets/c...

2 hours later…
7:33 AM
Q: How many entries are created when you make a new directory in *nix?

DeuteriumAs per the question I am thinking it is either two or three. mkdir ~/a 1 entry for the dir it sits in (~/a) 1 entry for itself (cd a && ls .) and/or 1 entry for itself again (cd a && ls ..) Could someone clarify if this is two or three? Thanks

Q: Wifi working after running Live Cd

Chandru1I have been using UBUNTU 10.10 and the major problem was the wifi which was not working at all. It worked in Ubuntu 9.10. So after many futile attempts i decided run a 'Live CD'of UBUNTU 9.10. The Wi-Fi worked. Then after restarting i was amazed to see that the Wi-fi was even working in ubuntu 10...

8:24 AM
Q: how to find out which wifi driver is installed?

apoorv020How can I find out which wifi driver is installed and running on my system? I know about lsmod, but how do I figure out which driver does what? I am running ubuntu 10.04.

9:13 AM
damn, only 7 ppl nominated themselves for AU mod elections: askubuntu.com/election/1?tab=nomination
9:34 AM
do pending edits get bumped to the front page?
9:48 AM
Q: Unix command that takes no arguments

anonDon't ask why, but is there a Unix command that takes no arguments?

10:31 AM
@UnixandLinux since this is a trivia question, maybe should be made CW?
10:48 AM
Q: Compiling code from vim

debianloverNew to vim and and I want to be able to compile code from within vim without running a new terminal and calling the compiler. How do I go about doing this? Note that this requirement is not restricted to gcc only, I sometimes need to call python also on the current script I am working on, so you...

11:18 AM
Q: Extracting tokens from a line of text

JasHow can I split a line matching a known pattern with a single character delimiter into an array, e.g. convert "token1;token2;token3;token4" into a[0] = token1...a[3]=token4. ?

Q: rsync via ssh from linux to windows sbs 2003 protocol mismatch

Indigo ClothingHi, I am trying to backup my linux webserver to our local windows sbs 2003 server in the office. I have set up ssh and cwrsync on the windows server and have confirmed that the linux server can reach the windows server via the command: ssh RemoteUser@xxx.xxx.xxx.xxx It asks for a password and ...

12:18 PM
Q: date, get current 15 minute interval

nosIs there any way I can get the current 15 minute interval using the date command or similar ? e.g. something like date %Y.%m.%d %H:%M will give me 2011.02.22 10:19 , I need something that yields 2011.02.22 10:15 in the time span from 10:15 to 10:29.

Q: su and aliases confusion

user4979I create an alias as my current user in the bash shell, which I can see using the alias command. When I switch user without the '-' i.e. su testuser the alias is not carried into the new users environment. Any idea why ??? Thanks

12:48 PM
@tshepang I don't know if you noticed but people get updates (or at least I do) on chat if you say my username when I'm not in here
and you can then use that to go read the archive
and you can then use that to go read the archive - what this means?
also, I'm aware, but if u take a while to log in, I don't get auto completion of ur username
1:39 PM
@Tshepang oh no... you have to type the username out? that must be horrible
and I don't get notifications unless you do @name
I basically get a little messages saying someone highlighted me in chat, and it gives me a link tot eh chat archvie
2 days ago, by Gilles
@xenoterracide My general guideline is that if it's a topic that non-developers might be familiar with, it's ok here
like that
2 days ago, by Gilles
@xenoterracide My general guideline is that if it's a topic that non-developers might be familiar with, it's ok here
idk if I can give a link to the general transcript
I'm aware about this feature. All I said is I don't get the convenience of usrname auto-completion, if it's been a while since u logged in.
1 hour later…
2:48 PM
Q: Write to a file without redirection?

zoulHello! I am writing an application that needs to create a special file and write a magic cookie into it. I can’t write the file directly from the application, the system security model requires me to launch a helper tool with elevated privileges to do the trick. I can supply any number of argumen...

3:08 PM
@Tshepang If the completion isn't working then it also won't alert them even if you type their name manually (Edit: apparently they're not completely connected; it's possible to have no autocomplete but still be able to alert them. They do have to have been in the room recently for alerting to work though, it doesn't work for all time. See here)
4:03 PM
Q: Customized XDM-based login screen

amphetamachineI am in the process of creating a lightweight yet full-featured Linux disto and don't want to include a whole bunch of unnecessary or bloated software. It is supposed to run off a USB flash drive. I want to have it be somewhat user-friendly, hence the necessity of a graphical login. I really hop...

2 hours later…
5:33 PM
Q: Multiple Users on a Desktop Environment

SauronThis is probably a REALLY stupid question. But anyways, lets pretend we had a *nix rather powerful system... Now Obviously I know you can set up multiple users to login to a system.......but how exactly do you do that? Like....how would all the monitors connect and such, or would you need a small...

2 hours later…
7:31 PM
@MichaelMrozek pls dont edit this now, for I need it for testing
in Chat feedback, 37 secs ago, by Tshepang
@badpDr set ur screen to 1680 x 1050, log into http://chat.stackexchange.com/rooms/26/unix-and-linux, and look at @MichaelMrozek's latest post, and then try to click on the link he added.
Q: Keymapping problem when working with emacs and openbox

chrisI have an apple keyboard and I had to do some remapping of the keys to make the mod-4 key the first key to the left of the space bar for when working with Emacs. The below script worked fine when I was using the dwm window manager, but after switching to openbox I have found that instead of swap...

7:54 PM
@UnixandLinux Even I find this question pointless
Is command-line the junk tag?
@Gilles it's interesting trivia
8:55 PM
Q: Euphemisms for unix

GillesIs/does using *nix, un*x, etc, as a euphemism for unix: purely a matter of personal taste, let'em call it “John” if they like purely a matter of personal taste, it's perfectly comprehensible a quaint historical tradition, why not preserve it hurts legibility (and newbies might not get it) and s...

@Tshepang Are there any questions you don't like?
@MichaelMrozek unclear and poorly-formatted ones
maybe there's more, but that's just top of my head
also, how come u guys didnt downvote that question if u didnt like it?
9:14 PM
I generally don't downvote things unless they're wrong or terrible
well, I think u should add pointless to the list, if that's also how u feel :)
Q: How to check how a long a program has been running?

TshepangIs there a way to check how long a program has been running, short of running it from a monitoring app?

I also don't like questions that have a lot of noise (i.e. extra info that doesn't add value)
this includes greetings, apologies, political statements, ...
if it's useless info, then it should at least be humorous, or interesting
All the questions you don't like are fixable; so far everything you've said can be dealt with via editing
9:29 PM
yeah, and that's what I do
@MichaelMrozek it's quite strange BTW to see u answer a non-meta question
@UnixandLinux like this one
u hardly ever answer them, that's why
@UnixandLinux someone retag this one for me; I'm not sure if is enough
interesting one
Q: Which is bigger?

NathanIn my classes I sometimes have a contest concerning who can write the largest number in ten symbols. It almost never comes up, but I'm torn between two "best" answers: a stack of ten 9's (exponents) or a 9 followed by nine factorial symbols. Both are undoubtedly huge, but I haven't been able to p...

I really like the font there. It gives the site a very authoritative look.
9:55 PM
Q: Flat binary compatability between Mac OS X and Linux, Implications for converting a Linux binary to work on Mac OS X?

JBaileyBrace yourselves, this question will likely appear naive and/or foolish, seeing as I am relatively new to the inner workings of unix like systems, and programming in general. Ready? Ok! I will go through about 3 levels of ludicrosity, increasing as I go along. We have two systems with similar h...

2 hours later…
11:33 PM
Q: Odd problem regarding 'apt-get update'

TshepangI was having some serious network troubles, and now running sudo apt-get update gives this error: ... Hit ftp://ftp.is.co.za experimental/contrib i386 Packages Reading package lists... Error! E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/apt/lists/ftp.is.co....

@Gilles thanks for the quick answer; I was working on the problem and din't realise u had already answered
we r 6s apart :)

« first day (136 days earlier)      last day (3532 days later) »