« first day (3352 days earlier)      last day (1273 days later) » 

3:09 AM
I'm new to LUbuntu, and I need to mess around with a policy kit so that I can change my wifi adapter. I don't know how to use VIM and on top of that it doesn't work. I can see the file and open it in the GUI, but can't save it because leafpad was not opened with root privileges. The root account is disables, and I need to add "atomicpi" to the list
featherpad, not leafpad, my bad
 
@YetAnotherRandomUser This is not through the same mechanism you're asking for (it doesn't involve Polkit) but you can use sudoedit with any almost any editor, including graphical editors (and I've used it with featherpad).
VISUAL=featherpad sudoedit FILE
Replace FILE with a path to the actual root-owned file you want to edit.
 
ok, I will add that to my notes.
in another IRC channel, someone reminded me I can just sudo featherpad to launch the editor as root
 
sudoedit makes a temporary copy of the file, runs an editor as your user (i.e., the editor does not itself have to run as root) to edit that temporary copy, and then it copies it back to the original file. Only the copying is done as root.
@YetAnotherRandomUser Yes, that will also work -- though if you're using an Ubuntu release earlier than 19.10 (i.e., 19.04 or earlier), then you should use sudo -H featherpad rather than just sudo featherpad. (In 19.10 and future releases, either is fine.)
 
I need about 9001 more XP and a few more levels in Linux to appreciate all of that.... usually I just rage that tit's easier on Windows. In this case, I'm working with LUbuntu 19.....disco?
 
3:25 AM
Disco Dingo is 19.04.
So if you want to run featherpad as root with sudo, you should make sure to pass the -H option:
sudo -H featherpad
Or, with FILE replaced by the file you want to edit:
sudo -H featherpad FILE
 
it worked without the -H
 
This -H business does not apply to sudoedit, since that doesn't run the editor itself as root..
 
Yes, it does usually work without -H. The problem is that things start not working when you don't run them as root.
 
I thought half of linux had to run itself as root to do anything
 
3:44 AM
0
Q: How to disable VMware service on startup?

zer09I am just rarely use VMware, so I want to disable it services, and just start it manually if I need to run the VMware. But executing systemctl disable vmware.service wont do anything, after I reboot the service still there running. this is the output of the service status ‚óŹ vmware.service - LSB...

 
 
3 hours later…
6:55 AM
why does git adds file in two step process( first using git add and then git commit )
why not in a single command
 
 
1 hour later…
8:18 AM
Becauce "commit" only tracks existing files.
And the single command would be possible with an "alias".
 
8:45 AM
if a user wants to add a file then he'll have to first do git add and then git commit. My question is that why git makes it a two step process. Whats the benefit of keeping add and commit as separate commands
 
9:08 AM
@AkashKarnatak How would it work? You would do "git add -m 'commit message' file"? OK, and how about when I want to add the file, because I want it to be tracked, but I don't want to commit it yet because I'm still working on it? For instance, I might want to add it because I need to stash my changes, then checkout another branch, then keep working. If add auto-committed, it would just clutter up my commit history.
 
@AkashKarnatak because those are 2 distinctly different actions :) ^^
 
@Kulfy yep, I did
 
9:37 AM
@terdon ok
 
@terdon no topic on meta? :-(
 
@Rinzwind Not yet. I'll post something as soon as I find a bit of time.
 
10:15 AM
done
 
0
Q: Stepping down as moderator

terdonThe time has come for me to step down and put my diamond aside. I have had the privilege of being an elected moderator on Ask Ubuntu since June 2016. I have enjoyed it immensely, but I am afraid the current state of the SE network means I just can't continue. Until yesterday, I was a moderator ...

 
@terdon Honestly, I would miss bothering you in general room. :/
You were like the most helpful mod out there since I joined the site.
4
 
10:36 AM
@Kulfy Aww, thanks :)
I'll still be around though, maybe I can still help.
4
 
But you can't handle my flags. jk
 
Only chat flags :)
 
I just saw that you changed your name on MSE
 
@Kulfy you're a stalker :D
 
10:53 AM
naahh. I just observe things closely and faster..
 
11:15 AM
0
Q: getent only shows some of the users from ldap

SteseI've a couple of Linux servers, one setup as a SAMBA AD (ubuntu 18.04), the other as a member server (ubuntu 16.04) setup as a file server. It was working for a time, but now newer users created (successfully) on the AD server via users and computers (on a windows machine), are not able to use t...

 
 
1 hour later…
12:37 PM
0
Q: sandbox skype,spotify on ubuntu

redoI am trying to sandbox applications such as Skype/Spotify on Ubuntu 18.04. Both are installed under snap, which limits their access to system folders (although skype is installed using '--classic' flag, which seems to circumvent this limitation to some degree). To limit the access to home, I see...

 
1:18 PM
0
Q: Windows Subsystem for Linux (WSL) not actually saving $DOCKER_HOST

Joshua SchlichtingThe situation: I develop on a windows VDI that uses the WSL to run docker, and I'm actually using a remote docker daemon running on a Red Hat server. Locally, I have the DOCKER_HOST variable set to the correct path to my docker daemon (tcp://<userid>@<my server running the remote docker daemon>)...

 
1:58 PM
why do we prefer to use the B (byte) instead of o (octet)?
I didn't find which one is prefered in International System of Unit (I just know that the bit - b - is one of them)
or probably this question is more suitable for Meta?
 
2:15 PM
@damadam Why meta? Are you specifically asking which should be used in posts on Ask Ubuntu?
I don't think the abbreviation "o" is widely recognized. There's nothing wrong with talking about octets though -- at least so long as it's clear they're octets of bits.
 
no, I would like to understand reasons why we used byte unit instead of octet unit (I usually used octet instead of byte, notably due to the confusion with bit)
the "o" is just for Mo, Go, To ... where it's MB, GB, TB ... with byte
 
Yes. I'm not saying the "o" is wrong, just that I don't think it's widely recognized.
 
0
Q: Blocking all outgoing traffic of a process using process id?

Nicholas OlsenLooking for a method to block all outgoing traffic on the fly while the process is running, then later unblock the traffic. Is this possible?

 
I don't think bits or bytes are themselves SI units. If I'm correct about that, then that's probably why you haven't found information about what SI says about them. I think the IEC publishes a standard that covers bits and bytes (and their use with SI prefixes and with the "binary" prefixes like "Ki", "Mi", "Gi", etc.) though.
 
that's why I should probably ask a question, in order to learn each reason for this choice
 
2:22 PM
Yes. That question wouldn't be on-topic for meta, though, unless it's asked specifically as a question about the site. I feel like there is probably a Stack Exchange site on which that question would be a good fit, but I am not sure which one.
If the question were asked in a detailed way -- explaining about how you observe that "byte" is more widely used than "octet" even in circumstances where both apply, and showing research into the matter -- then I think it would be well-received on Software Engineering, though I am not 100% sure.
 
I just ask that, notably because it affect my way to improve post
when I say Meta, it could be also on the general SE Meta
 
The general SE meta is still only for questions that are about the Stack Exchange network. If you want people's input on what units you should use when writing and editing posts on Ask Ubuntu--and your question is really about that rather than about the units and their abbreviations in general--then that would be on-topic for Ask Ubuntu Meta. (It might still be off-topic for Meta Stack Exchange, since questions that are about a specific site and not other sites are off-topic for Meta Stack Exchange.)
 
thanks for advice, I will ask it on Ask Ubuntu Meta
 
@Kulfy Not very fast. It's been changed for weeks ;)
 
2:48 PM
0
Q: Why do we used byte instead of octet as data size unit?

damadamI would like to understand why we prefered to use the byte unit instead of octet unit (because I used more commonly the octet unit at work, at home, ...). Please give as many reasons as possible, and you can also give some good reasons to use the octet unit too. NB : Answers given must described...

 
2:59 PM
@terdon I was absent from MSE for weeks :P
 
@damadam Thanks. But right now your question doesn't look like it's asking for advice about writing or editing posts or any other contexts that are about the site and thus within the scope of Ask Ubuntu Meta. I think your meta question is likely to be closed in its current form, and maybe even should be closed. It has one close vote so far (though I have not voted to close it).
This is what I had feared: it seemed to me that your question might really be a general one about technical communication, rather than a specific one about Ask Ubuntu, which is why I had been reluctant to suggest posting it on a meta site. I recommend that you edit the question to refine it so that it is asking something specific about Ask Ubuntu.
If you're asking why something is commonly done, you can include information about search results (or SEDE query results) that support the claim that it is commonly done. If you're asking what you should write, or when you should edit things to say one thing instead of another, then you can make it specifically a question about that.
(Also, I see @Kulfy has some good ideas about where the more general, not AU-site-specific question, could be asked.)
 
I know there are some old schools on Super User and Retrocomputing who know the history very well.
 
The lonely thing that would made it specific to AU would be to include some example
 
Once I tried to make a list when you should go to meta. I don't see how your question is related to meta. I believe it's more related to the history of computing. There are many terms out there which should be used but they aren't. For example, nowadays we use app for every piece of software which IMO is vague.
*by related to meta, I mean related to community or main site that should be posted on meta.
@ThomasWard You here?
Why did you lock terdon?
Asking just out of curiosity.
 
3:18 PM
I had few example (it's hard to find good examples with all edits I had done recently x)
add*
 
@Kulfy Obviously I'm not Thomas Ward and what I am saying here is not an official reply from a moderator, just my thoughts as a 10k user who can read deleted posts. Also obviously I'm biased, as is everyone, but I'll try to describe this as evenhandedly as I reasonably can.
The lock is not, as far as I can tell, related to anything terdon has said or done.
Instead it relates to an answer that was posted that wasn't really about terdon's moderatorship, that was political in nature yet simultaneously proposed a ban on politics (so hard to engage with seriously, whether or not its author was well meaning or had a more coherent idea in mind).
A long comment thread developed on this answer, in which terdon was pinged repeatedly in comments even after expressing a desire not to participate anymore.
I think the lock is reasonable, and I think Thomas Ward's goal is to prevent the whole thread from turning into a broad discussion of contentious issues, in which viewpoints might be projected (or continue to be projected) onto people who don't actually share them. Under these circumstances, I personally agree with the lock. (Though I hope the lock might eventually be lifted, since some people may want to post answers conveying their sentiments and experiences with terdon's moderatorship.)
(Sorry about the huge wall of text.)
 
spam + off-topic + forcing someone to participate at a discussion : isn't it suffisant to ban the user, or raise a warn at least?
 
ban, no. issue warning, no.
 
To clarify, when I said "projected onto" I mean "attributed to" or "made to look like they are the opinions of".
 
they weren't "forcing" someone to chat
Terdon was simply responding to notifications
so what I did
and locked it
was deleted the Offtopic post
the lock on the question was what the phone let me do
the lock on the answer that is now deleted i can do from the computer :P
overall lock was temporary, second lock was different.
@Kulfy and it wasn't locking terdon so much as locking the post temporarily
the 'refresh' button will help you there.
also i haven't had coffee in four days so im' grumpy :P
 
3:35 PM
I agree with these actions. Sorry if my above thoughts were more confusing than helpful.
 
> The absence of ideology is an ideology. It's just a conservative ideology, and everything you see has it
 
@damadam Is it okay with you if I do an edit to make it clearer that you are specifically asking about how best to write and edit posts on Ask Ubuntu?
 
@EliahKagan no problem, I know that my question isn't really good asked, I would correct your edit if I think it's not really what I'm asking
 
You would then likely want to re-edit it so it says exactly what you want it to say. Or even roll back my edit entirely (which would not prevent you from using some of the ideas in it in a subsequent revision). I'm not sure if your question is best asked on meta, but I think I can edit it in such a way as to make it clearer and to invite more answers.
@damadam Yes, you should definitely re-edit (unless I somehow manage to say just want you want, which I most likely won't quite manage to do).
I'll submit an edit shortly.
Okay, edited.
 
4:07 PM
Yeah, thanks, nothing to say :)
 
@ThomasWard woah, woah, what? Did I miss the apocalypse or something?
 
@Kulfy Well, then you have a lot of catching up to do depending on what you mean by "absent from MSE for weeks". I've been spending quite some time lurking there.
 
0
Q: Install Fedora & Arch Linux on system already with Windows & Ubuntu

utakerHow to dual-boot Fedora & Arch Linux with system already with Windows & Ubuntu installed? Which OS should I install first?

 
4:27 PM
@EliahKagan I see. (Really??)
@EliahKagan I'm habitual of this whenever I read your answers and messages :)
 
@ThomasWard Mobile site is just -_-
@ThomasWard Hmm... unlocked after 3 minutes
On a lighter note, I need to get those 800 points to see deleted posts ASAP.
 
@Kulfy The question lock was replaced by a lock on just the deleted answer.
 
@JusticeforMonica I have been absent from their since 15 days I guess. I'm not sure if anything big happened meanwhile.
 
@Kulfy You should do 400 (high quality) tag wiki edits! :)
 
4:32 PM
@EliahKagan Aren't deleted answers automatically locked just as questions?
 
No.
 
@EliahKagan Or someone (please) award bounty :P
@EliahKagan I see.
Thanks for the info
:)
 
Yo Shinobis o/
Any alternative of MobaXterm for Ubuntu?
 
@Kulfy Deleted posts are only automatically locked in a few situations. The most common is when the Community bot deletes a post due to spam or rude or abusive flags. Then the Community bot also locks it. There are other situations but I don't think I know them all; I think that when a migration is rejected, a question and all its answers (rather than just the question) are locked, but I'm not sure if that always happens.
Most of the time, activity (such as edits by the post owner) are possible on deleted answers.
 
15
Q: Is there a program like MobaXTerm for Linux systems? (SFTP GUI browser & terminal)

The Fluffy RobotI am coming from Windows, where I ran the program MobaXTerm. Essentially I used it as an SSH client (though it has other uses). It has a great feature of showing the files and directories on the left hand side, while showing the terminal on the right side of the screen. This let me execute Linux ...

@EliahKagan And merging too locks the source.
@TheLittleNaruto Brush up your googling skills kiddo....
 
4:37 PM
@Kulfy Don't you think I would have looked into that question link already?
 
@Kulfy Yes, but I don't think merging locks answers. The answers get moved to the merge target.
 
@TheLittleNaruto Nope.
 
@Kulfy *Slow claps*
 
@EliahKagan Yeah..
@TheLittleNaruto Did you escape *? Wasn't * supposed to format fonts in italics?
 
@TheLittleNaruto If you can say specifically what things about MobaXTerm you want (and what things are not important), including information about why the suggestions in the question Kulfy found are not sufficient, then you could post a question here on Ask Ubuntu.
@Kulfy I think even deleted answers are merged into the target.
 
4:39 PM
@EliahKagan That seems to be a nice question.
 
@Kulfy Chat message edit history reveals all. :)
Even for messages that have not been edited, it shows the Markdown.
 
TIL chat history shows markdown of a message.
 
@Kulfy Which one?
 
That deleted answer are merged into the target (if you aren't sure).
 
Oh.
Well, I can probably look into it and find out, by looking at some big merge targets and their deleted answers.
 
4:43 PM
May be JDK questions?
 
Yeah, that's probably case where the source of a merge had deleted answers at the time of the merge.
 
Yeah..
 
@Kulfy Yes -- and as with posts on the site, the Markdown of each revision, and the result of formatting it as HTML, are separately stored.
For posts on the site, this can be verified by looking at what information is available in the data explorer, or it may be observed in practice by noticing that a URL to a question on the same site is linkified to the question title at the time of the most recent revision of the post that contains it, and when the linked post's title changes, the post that refers to it still has the old hyperlink text.
I don't think there's anything like SEDE (available to us) for chat. But there are various ways to observe that the Markdown of a message does not contain the full information of the message. This is especially clear in oneboxing, where it oneboxes a post or page as it existed at the time the chat message was posted or edited.
9 secs ago, by Eliah Kagan
Also, that is why recursive oneboxes are possible.
 
@EliahKagan Oneboxing doesn't work for deleted messages.
 
(I didn't see your recent messages before you deleted them.)
23 secs ago, by Eliah Kagan
You can onebox a message and then delete the message you oneboxed, though, right?
 
4:51 PM
That makes sense. Because it is now "hardlinked".
 
I don't think it's the link to the deleted message that causes it to correctly display the deleted message's contents, though. Instead, it's simply that the content of a onebox is actually part of a message, even though it is not part of the Markdown of any revision of the message.
 
@terdon I dropped a meteor on your post lol
then i reverted the meteor strike with the Infinity Stones
then I stole your soul. But that last one isn't well known ;)
 
5:16 PM
@ThomasWard No, no, no, look at what I was replying to.
2 hours ago, by Thomas Ward
also i haven't had coffee in four days so im' grumpy :P
You haven't had coffee in days? You can see why I assumed the apocalypse had come and gone while I was sleeping.
 
@Kulfy it might be worth mentioning that, although deleted posts that are not locked can be edited, they do behave like locked posts in other ways, in that they can't be voted or commented on. In the case this came up in relation to, that might even be sufficient
 
5:32 PM
@terdon ah
ran out of coffee
broken coffee maker at work
E:BERIWEHREWRINWERWOERWERER THE END IS NEAR
 
@ThomasWard I don't understand. You've been out of coffee for four days? How do you get up in the morning? The few times this has happened to me, I just stumble down to the nearest store and buy some coffee. I mean, OK, I'm a bit extreme: I order unground beans online, usually have some decent pre-ground stuff as backup and also keep a jar of instant.
But even if you don't go that far, how in the world can you go 4 days without coffee?
 
@terdon 10+ hours of sleep every night
@terdon evilly
like the world could end if we aren't careful
... also mountain dew but...
 
Dude. Buy some coffee already!
 
E:PAYDAYNOTARRIVED
 
Think of the children.
 
5:41 PM
siphons off @terdon's lifeforce as sustenance
 
@ThomasWard And yet, you are buying food? You need to sort out your priorities!
 
@terdon nope
free food from parents
mom cooks like for ten people each night
 
Who aren't coffee drinkers?
 
i ship the leftovers home weekly
OMNOMNOMS?
anyways me without coffee is NOT the worst thing in the world
me without food? Well, then we have a problem
:P
 
Any ufw wizards here?
Cant seem to whitelist my ip using ufw? Already tried this: askubuntu.com/a/525337/36315
> ufw insert 1 allow from 192.168.0.0/24 ...
 
5:45 PM
VPS?
 
Yeah
 
EC2? GCE? Need more info about the system where it is
 
Its on digitalocean
Ubuntu 16.04
 
DO might have its own firewalls in their control panels
you might want to check that
 
already whitelisted am IP
 
5:46 PM
first
 
OW YEAH
Cmopletely forgot about that
Thanks!
 
though 192.168.0.0/24 is a private IP that will never reach your VPS over the internet so I mean...
:P
you need to whitelist your external IP address ;)
 
@ThomasWard It's an excerpt from the AU Q link I posted
;)
 
 
4 hours later…
10:09 PM
0
Q: iptables: All SSH connections for range of DPT

MountainXiptables rules are denying connections on my server and these connections should be allowed. They are SSH clients that should be allowed to connect. syslog shows: Dec 3 16:22:49 server kernel: [4125974.777012] iptables denied: IN=eth0 OUT= MAC=<...> SRC=<...> DST=11.22.33.44 LEN=60 TOS=0x00 PR...

0
Q: How to troubleshoot a bash script called by a python script called by a program?

SiderealI have to troubleshoot this bash script called by a python script called by a program, all run in Ubuntu 18.04. The python script and the program are black boxes. The only information I have is that they work fine, and the python script only fails when it calls the bash script because the scrip...

 
 
1 hour later…
11:10 PM
0
Q: Fixing and utilizing 4/8 locked out phisical cores in ubuntu linux kernel, Overclocked values also not seen in OS

user3645480let me explain my question for help: I've activated (original 0 1 2 -> 3 cores) 3-7 -> 8 cores where 4 are currently getting registered and the last 4 are not being utilized. The CPU is an AMD Athlon II X3 450 Processor originally and when the last cores are activated in the bios it becomes a...

 

« first day (3352 days earlier)      last day (1273 days later) »