« first day (2824 days earlier)      last day (454 days later) » 
00:00 - 23:0023:00 - 00:00

12:45 AM
is there a way to do defaults for input variables in BASH?
like have $1 be something if there's no input?
 
12:59 AM
@TheWanderer mhmmmmm you could check if it is empty or "" and if not use $1 otherweise user a default value into a variable
 
I was just wondering if there was a built in way
like in Kotlin you can have fun someFunction(someVariable: Boolean = true)
 
don't think so
 
you can call someFunction() and the argument will be true
or you can say someFunction(false) to change the behavior
 
god tomorrow it will finally arrive :)
long time for express shipment
 
well it got there quickly
 
1:02 AM
I do not want to know how long it would take if not sent express
 
express or not express, it's customs taking up most of the time :p
 
well it was sitting on a parking lot for almost 5 days
then customs took one day
lets hope it is still in one piece :)
 
1:45 AM
@TheWanderer Most programming languages support but, but a programming language bash is not ;)
 
feh
 
also I still start to type @zacharee1 before realizing that won't work
 
1:56 AM
o0
what happened to them?
 
2:22 AM
eh?
 
ugh
KMix seems to have changed the config location
but there's nowhere that says where the new one should be
and I can't read C++ worth a damn
so now I'm trying to use find, which is taking forever and probably won't return anything
 
 
3 hours later…
5:51 AM
@TheWanderer locate?
 
is it faster?
 
yup
way faster... it uses a database
 
what's the syntax?
I want to find kmixrc
 
sudo updatedb
locate -b kmixrc
if you get nothing, try without the -b (no need to re-run updatedb, that's just to... update the database, obvs)
 
still updating the DB lol
 
6:00 AM
hahaha
 
6:21 AM
0
Q: How to mount disk unremovable in Ubuntu/Linux Mint

BookSwordThis might be unnecessary to some extent, however, I hope to make things as seamless as possible. So the question is like this: I have edited the /etc/fstab to mount two windows partition automatically at my Linux startup. However, the partitions are mounted "Removable", which means that there is...

 
 
1 hour later…
7:29 AM
@Zanna thanks! It found it!
no more 5% volume steps
 
7:43 AM
@TheWanderer kmixrc is in the kernel? you use to compile Ubuntu?
 
 
4 hours later…
11:19 AM
@TheWanderer sweet!
 
11:41 AM
0
Q: Is there an advanced hemorrhoid simulation software available for Ubuntu?

Dr. Marcus Chelmsford Phd.My daughter plans to enroll in medical school and wants to specialize in Proctology. A hemorrhoid simulator would help a great deal in her studies, but I can't find anything to fulfill this need in the Ubuntu Software Center. It's a pity, because I convinced her to start using Ubuntu, but she may...

weirdest q ever :=)
 
lol
I would really like to see a simulator like that. Oh wait, maybe not…
> I can not find similar software for Windows to download either
@Rinzwind looks funny in your browser history now :)
 
I always go private mode :=)
 
 
1 hour later…
12:56 PM
askubuntu.com/questions/1049067/… @pomsky @cl-netbox if you agree please reopen :=)
 
Mint is off topic
 
and the information that this is on Linux Mint may very well be crucial – I disagree with the removal of this information from the question
 
The problem is NOT about the desktop; it is about samba
He needs a method to edit /etc/smb.conf
 
doesn't matter imho
 
it -really- does
 
user136984
1:01 PM
Generally if it's not actually Linux Mint specific then we should reopen it.
 
nope
 
Y E S
 
in Raiders of the Lost Downboat, Oct 18 '17 at 15:45, by Eliah Kagan
@DavidFoerster I have no problem with the change to the close reason, but I don't follow your argument at all. Our actual policies, summarized in the help and established by community consensus on meta, say what to do with questions that are not about Ubuntu because a different distro, and not Ubuntu, is being used.
@GreatUncleBulgaria that is not the policy
that's the policy for EOL
not for other distros
 
user136984
@Zanna: But that is what we have been doing, and was the general mod concesus last time checked with them...
 
when you say "that is what we have been doing" I don't know who you mean
 
user136984
1:04 PM
Well since being around here, seen a lot of it.
 
please read the posts linked by Eliah Kagan and points made after the message I linked to ^
I am busy working right now. Please refer to the message I linked to and the meta posts. Feel free to ping me, but I might not be able to reply for a while
 
user136984
.Ask on Meta, then we can all agree on how to move forwards with this sort of thing because it has been rather informal so far.
 
already been asked on meta
 
user136984
Ok, how about we just migrate it then to U&L.
 
awesome
 
1:09 PM
ah
here is a dupe
7
A: How can I create a samba share from the command line?

happyskepticUse Samba's net usershare command to share directories from the command line, IMHO this is less clunky and much safer than fiddling around in the main smb.conf file: net usershare add share_name /home/user/somefolder "Share description" everyone:F guest_ok=y To make these shares permanent (i.e...

dupe answer that is ;)
 
:)
 
now HERE Is an offtopic question :=)
0
Q: Ubuntu performs better than Windows

Timothy SharpHow come Ubuntu functions better than windows? For example, when I run Minecraft on Ubuntu, flawless. When I run Minecraft on Windows, it lags

(and this is accompanied by a LOL)
 
I’m with Zanna there…
 
@Rinzwind done Rinzy ! :)
 
:X
 
1:23 PM
@Rinzwind wasn't it a minty Q before ? :D
 
facepalm
@dessert if it's about moderation, I'm probably with Eliah Kagan
:)
 
@GreatUncleBulgaria agree ... Hi my uncle ! :D Good afternoon to you ! :)
Hi @dessert @Zanna ! :) Good afternoon to you too ! :)
 
afternoon :)
 
1:52 PM
@cl-netbox you did not read what was posted after that did you :+)
 
2:13 PM
@Rinzwind correct ... I didn't ... I just saw mint and as I know that our close hunters wnat to remove such posts as fast as lightning, I thought I'd help them (this time) ! :D :D :D
 
2:24 PM
@Benny wat
 
2:59 PM
@TheWanderer, Never mind =)
 
@Rinzwind guy changed his mind :P
0
Q: Ubuntu 18.04 painfully slow

Timothy SharpUbuntu Bionic Beaver is so slow. Games run slow and so fourth. It's not my pc because I tried 17.10 before and it was fine

 
@ByteCommander wtf :D
I bit >:=D @ByteCommander
for some reason I am not happy with my answer but can't seem to pinpoint why. anyone got something to say that might trigger that? :X
4
A: Why proprietary software in Ubuntu Software Center?

Rinzwind However the Software Center is full of proprietary software. How come? I thought Ubuntu is all about Open Source Definition of "universe": Universe – Community-Maintained, Open-Source Software The vast majority of the software in the Ubuntu Software Center comes from the Universe repo...

 
3:33 PM
@Rinzwind “painfully slow” and “faster than Windows” actually doesn’t contradict each other :)
 
that's true :P
 
#roasted
 
and since windows is crap anyways even expected >:)
 
@dessert does the possessive of tu in Portuguese follow the same rules as você?
Like teu, tua?
 
@TheWanderer er… which rules are you referring to?
 
3:36 PM
next message
Teu cachorro, tua casa
is that correct?
 
yes, that’s correct
 
OK thanks
 
@ByteCommander Now I get a feeling that this person is troll who's trying to trigger the community into a heated debate or something.
 
Duolingo started to teach tu, but it's still not giving a lot
 
@dessert and who's upvoting those posts and why?!
pity-upvotes?
 
3:38 PM
achievement hunters
 
@pomsky doesn’t every question get one automatic upvote?
 
no o_O
 
@dessert Really?! I'm not aware of that
 
@dessert lol
 
trolls around
 
3:41 PM
@Rinzwind :D :D :D
 
it was not me that upvoted :=)
I -1'd both >:)
0
Q: Could alias python=python3 in my bashrc cause problems?

lemdanI would like to use python3 as my default python when working with the terminal. If I added the line alias python=python3 in my ~/.bashrc, could that cause problems with other programs?

that reads as trouble
 
0
Q: Why does ^C on netcat client close the server whereas ^C on server doesn't close the client?

juhistI tested on Ubuntu 18.04 LTS the venerable netcat. The netcat comes from OpenBSD: $ dpkg -l|grep netcat ii netcat-openbsd 1.187-1 amd64 TCP/IP swiss army knife When I use nc -v -v -v -l -p 1234 to open the server and subsequently...

 
See? One automatic upvote!
1
Q: Could alias python=python3 in my bashrc cause problems?

lemdanI would like to use python3 as my default python when working with the terminal. If I added the line alias python=python3 in my ~/.bashrc, could that cause problems with other programs?

 
@dessert duped it >:)
OH DAMN
my gold kicked in >:)
but it seems safe to do :)
 
@Rinzwind yes it does
 
4:44 PM
so just taking a break from work... since the question has no less than 4 reopen votes...
it seems to me totally unreasonable to make reviewers responsible for knowing exactly how Ubuntu differs from any other distro
questions about other distros are off topic, and there are really really good reasons for that
there are some people who edit distro info out of questions because they have such awesome knowledge they know the problem isn't specific to the other distro, but I think it's a big problem to set a precedent for doing that or a policy for doing that. If non-super knowledgeable people who just had the vague or wrong idea that something was the same on Ubuntu and Mint were doing that, it would be a really unmanageable situation for reviewers and probably affect the site quality badly over time
4
we don't close questions that are specific to EOL versions and that makes sense because we know what has changed between Ubuntu versions - that information is easily available, and somewhat embodied on the site
but the differences between even similar distros are subtle, myriad and not documented in any accessible way anywhere
ok, back to work
 
5:07 PM
indeed holy this opinion is -^
 
5:29 PM
@dessert (whispers) I have no idea what particular post she is talking about but it sounds reasonable.
Hi @Rinzwind. Did you know that your nick always reminds me of Rinspeed, a car tuner specialized in Porsche?
 
I'm not against it being closed (if it's the why is linux better than windows question). Basically there was a comment about it being opinion based and needing to understand lots of intricacies.
So, while Ubuntu, for example, could be more performant in some circumstances due to the way things are written and some performance hungry optimizations (I'm thinking things like being able to run a distro straight from ram most of the time) vs Windows that loses all but basic functionality when using an ERD - vs the other side of the argument where we have
Why does linux gaming suck - because people write to directX not openGL. If you open the door, you have to allow both. So, I'm of the mind to keep it out of bounds, if it's the question I'm thinking of.
 
@PerlDuck I am a wizard! :=D
 
5:49 PM
@Rinzwind I figured that already. :-D Btw, driving in the NL is a real pleasure for me, especially with my underpowered Station Wagon: everything goes smooth and people are chilled. totally different from German "Autobahn".
 
6:33 PM
0
Q: How to rescue Ubuntu Server 16.04 which is getting shut down by systemd script?

h_uatI wrote a program which automatically shuts down a Raspberry Pi 3b (Ubuntu Server 16.04) as soon as a button is pressed. It's nothing than a small bash script which reads a GPIO pin of the Pi every second and shots down the device if the button is pressed. However, I did a mistake and the condit...

 
6:58 PM
@PerlDuck this minty question, see its edit history
 
@dessert OK, thank you. To be honest: whenever I read NFS, SMB and similar things, then I'm out. I hate all of them coz I never get them configured properly and eventually give up and resort to something not that picky. Like scp.
 
isn't Mac's BASH different from POSIX?
 
it's very very old
oh no, I actually meant the Stack Overflow Bash tag wiki
sorry
@SergiyKolodyazhnyy maybe that one? Left open & out of queue now :)
 
8:21 PM
@Zanna Yepz, that one. And there was another one, but I voted to reopen and David Foester ,too, so probably soon will be reopened
 
oh it got closed?
was it the one about a mac though?
 
@TheWanderer POSIX is standard, and bash has --posix flag or set -o posix. Idk about bash on mac, but if we're taking about POSIX as standard, bash on any OS has extra features such as arrays and here strings that aren't meant for /bin/sh
@Zanna Nah, I was talking about this thing:askubuntu.com/q/1048935/295286
 
@SergiyKolodyazhnyy ... on a mac
so, off topic
 
-_____- Oh, I see it now
Eh, still bash,though
and non-Mac specific
 
still off topic though!
 
8:28 PM
Eh, but applicable to Ubuntu
 
We really need a meta discussion about that. Being applicable to Ubuntu in any way doesn’t make a question on topic!
 
@SergiyKolodyazhnyy Maybe. How would I or any other reviewer know that? In any case, who needs that question? DF wants to close as dupe of ultra generic q.
Do people want to totally change our scope and policy on other distros and force reviewers to learn about every distro to decide if something on another distro is about Ubuntu?
can folk read meta please... it is all there!
 
@dessert There's been plenty of such questions already, and there won't be a single, final one. I personally have stopped worrying about it.
 
> can folk read meta please... it is all there!
That's the problem. It's all there. All and much more.
 
Praise POSIX and though shall reach Nirvanna !
 
8:33 PM
Nobody "just reads" that
 
@ByteCommander And too much more, too
 
posix is boring
way too much more, actually
 
@ByteCommander Boring doesn't keep servers running. Portability does :)
 
Or just staying with the same system or another one that isn't incompatible
 
@ByteCommander Yeah, what if you inherited the environment after the last sysadmin left ? And no accountant will let you spend hardly earned company money ( there's sarcasm somewhere ) on getting rid of old outdated system to replace with new shiny Ubuntu.
 
8:36 PM
kk, not in arguing mood...
 
Who said we're here to argue ?
I've left all that behind, personally. I'm now so zen
 
aware wolf? :D
user image
4
 
8:56 PM
@ByteCommander Yessir. In fact, I'm migrating to wolf OS very soon XD
Wolf OS has no cowsay, only moonmoonsay
 
why not wolfhowl?
 
@ByteCommander howl command is replacement for echo. Would be confusing
 
I should alias it! :D
 
Good idea !
 
user136984
9:24 PM
Any ideas anyone?
 
user136984
4
Q: How to limit resource usage for a given process?

Great Uncle BulgariaI have a process for an application which needs to run, but ends up using far too much IO usage for what it does. And really crashes my computer, making it impossible to do anything else whilst it is running. So I was wondering if there is a way to limit IO usage, Memory and CPU for a given proc...

 
reading...
@GreatUncleBulgaria ionice...
@GreatUncleBulgaria How much CPU does the application ise.
 
user136984
@Fabby: No, that's just for the "nice".
 
can you give an example?
 
user136984
Like all of it.
 
9:35 PM
@GreatUncleBulgaria No, it limits too.
 
@GreatUncleBulgaria I think you should ask a single question – is it about IO usage, memory usage or CPU usage?
 
@GreatUncleBulgaria Ah than it's easy: cpulimit
 
user136984
@dessert: It's about resource usage.
 
Isn’t that a bit broad? I think both ionice and cpulimit would make for good (if not perfect) answers, but nobody writes an answer. :(
 
user136984
Given that it's the one subject and quite specific, think not.
 
9:42 PM
It's not too broad, but it's just a matter of combining 3 commands, and that's it,IMHO.I don't see what's so complex about this question
 
@GreatUncleBulgaria Answered... Refining...
 
user136984
@Fabby: Yes, however, the RAM part is not covered.
 
did you mention that?
lemme read again.
adding that
 
@Fabby grep szMyProgram | grep -v grep equals grep [s]zMyProgram
 
9:59 PM
@dessert Please edit
@GreatUncleBulgaria RAM is now covered.
512M of RAM and 1024 of swap... You can set those to anything you want.
@GreatUncleBulgaria refining...
 
user136984
@Fabby: Great! Thank you!
 
@Fabby please fix the switching caps in “MyGroup” vs. “myGroup”
great answer btw
 
@dessert Please read again...
@dessert if error still there, please edit as I can't see anything anymore
@dessert Ah!
 
@Fabby ;)
 
user136984
:) :) :)
 
10:04 PM
good answer, but if I may suggest @Fabby , pgrep -f myProgramName may save you on plumbing
 
@GreatUncleBulgaria Try now...
Haven't tested yet...
@GreatUncleBulgaria STOP!
@SergiyKolodyazhnyy Please edit...
 
user136984
:D
 
Shall do in a jiffy
 
@Fabby and in the cgexec line? is that supposed to be memory:/szMyGroup as well?
 
@dessert Checking
 
10:07 PM
is it really /sys/fs/cgroup/memory/szMyGroupmemory.memsw.limit_in_bytes or rather /sys/fs/cgroup/memory/szMyGroup/memory.memsw.limit_in_bytes?
 
@dessert Damn! Thanks!
I'm going to test now...
 
would edit it myself if I had any idea what you’re doing there ;D
 
:D
 
but just adding a slash to a path without any knowledge about it just feels wrong
 
@GreatUncleBulgaria OK. Lemme first use ffmpeg to start a videoencode normally
 
10:15 PM
@Fabby How's that ?
 
1G VMemory, 50% CPU, 100M RAM
Now going to limit it
 
@dessert damn! Slash missing
 
we four should work together more often :)
 
nods agreeably
 
user136984
10:19 PM
Yes :D
 
:D
I'm running into an issue while testing. Please be patient.
editing
 
I still need to wrap brains around breaking the ARG_MAX limit
 
it needs a sudo tee
continuing testing
@SergiyKolodyazhnyy Huh?
You can't sudo echo, so you need to echo | sudo tee right???
 
@SebastianStark I think you‘ll find that interesting as well: askubuntu.com/a/1049163/507051
@Fabby you’re doing it right :)
 
10:34 PM
I'm an idiot!
@GreatUncleBulgaria another error removed. Please hold.
 
user136984
:D
 
adding sudo commands as it's not obvious without running as root
 
@Fabby well, it’s late ;) didn’t see that as well, and it was so obvious…
 
@dessert :D
Good to know I'm not the only one...
;-)
 
@Fabby Basically, I'm working on this unix.stackexchange.com/q/451486/85039 and an answer on related askubuntu question. getconf ARG_MAX gives the size in bytes, so I need to somehow make an array of words or numbers what in total byte-size (not array length) will be just below or just above what getconf ARG_MAX gives
 
user136984
10:42 PM
Anyway
 
user136984
Thanks folks!
 
@dessert hey, I didn't know what the [s] in grep does, but it doesn't work any more
axf | grep [s]ffmpeg | awk '{print "sudo ionice --class 3 --pid " $1}'
no output
 
@Fabby it’s just a regex
 
ps axf | grep ffmpeg | awk '{print "sudo ionice --class 3 --pid " $1}'
sudo ionice --class 3 --pid 14248
sudo ionice --class 3 --pid 14249
sudo ionice --class 3 --pid 14304
 
you can enclose any character, I just usually use the first one
ps axf | grep [f]fmpeg | awk '{print "sudo ionice --class 3 --pid " $1}'
 
10:44 PM
ah, goddit
 
user136984
And goodnight! :)
 
@GreatUncleBulgaria sleep well!
 
@GreatUncleBulgaria OK, test tomorrow and leave feedback
Do you still have my skype name?
 
user136984
See you tomorrow!
 
user136984
Nope
 
10:45 PM
@GreatUncleBulgaria Skypename?
Mine... Do you still have it?
 
user136984
And don't use Skype.
 
user136984
;)
 
Do you still remember my full name
 
user136984
No
 
ping me on hangouts then if I don'rt respond here...
 
user136984
10:46 PM
Ok
 
goddit?
 
user136984
Got it!
 
@dessert I'm going to remove the [s]: it's confusing...
(sorry)
 
user136984
Bye
 
@SergiyKolodyazhnyy As Great-uncle is going to sleep looking at yours first.
 
10:48 PM
@Fabby haha, it’s ok, just remember to pipe through grep -v grep again then
 
@dessert hold on... Why???
 
@Fabby to remove the grep process itself from the list, that’s what it does
 
Oh... Well, it can be ioniced too. Who cares?
 
lol
 
it makes for a better readable command
I know what you're trying to say, but it doesn't matter in this case...
anyway, back to Serg's question.... I've read the first sentence 3 times now and nothing of the rest!
:P ;-) :P
 
10:52 PM
@SergiyKolodyazhnyy ulimit -s times 256 gives getconf ARG_MAX
 
@SergiyKolodyazhnyy so you want to break stuff?
to test your error validation or so?
you can do a wc, take the third column-1 set that as a limit and you won't have enough.
@SergiyKolodyazhnyy there is an answer (only saw now)
Doesn't that work?
Back to Great-uncle's answer
 
@Fabby Basically, yes. I want to find ways to reliably reproduce error, and then play with a few ways to handle it. And yes I wanted to go with wc first, but that didn't quite give me what I need and was running to long
@Fabby The answer gives a way to reproduce the error but not generate enough filenames that they adhere to bytesize. I'm testing something else now
i=1; while /bin/true {1..$i} || { echo $i; break;} ; do ((i++)); done
Also, somebody please slap me before i start ranting about people being very cheap and doing stupid things instead of actually using the money to do things properly instead of sh!tf4ckery
 
00:00 - 23:0023:00 - 00:00

« first day (2824 days earlier)      last day (454 days later) »