« first day (2762 days earlier)      last day (1138 days later) » 
00:00 - 18:0018:00 - 00:00

6:15 PM
@bertieb read my answer foo'
tho i dont actually give the command
so sec and ill add it
bash -i <<< 'some_program with its arguments; exec </dev/tty'
dear lord it's full of stars
17 hours ago, by Bob
turns out you can't really cool a 90*C heatsink with 80*C air :P
you can.... just not much! :D
 
6:37 PM
Mxem mxem mxem the center will not hold he comes
!!zalgo @
 
@allquixotic @̲̳̖̙͚͈̹͒
 
HE comes
 
2.1 comes, in your case
2.1 probably has more chat lines on RA than you do yourself
 
@djsmiley2k I did, but missed the last sentence
 
6:49 PM
He's also got more time sleeping per day than me.
 
I've tried things to that effect, but couldn't get it to work
 
@djsmiley2k which is why he makes up for that by being super active participant in chat when he is awake
 
:D
he's asleep right now
first time in ~2 weeks he's got to sleep at the correct time
 
Is he roughly cat sized or bigger?
Maine Coon cat maybe?
 
around maine coon yes
 
6:52 PM
How does his size compare to the baby in Who’s Your Daddy the Steam game? And does he constantly crawl around trying to make a mess and hurt himself?
 
maybe slightly bigger
 
My idea of how babies work is that they’re the most competitive Who’s Your Daddy player imaginable, more or less
 
@bertieb use screen -S something cmd; bash
if you want to preserve the something's env, make it not exit
 
@djsmiley2k I'm sure I tried something like that, but I could give it another go
 
it's either ; bash, or && bash
hmmm screen -S something "someThing; bash" btw
k, no worky, wtf
 
7:19 PM
Don't worry about it- I was using it to recreate some common byobu'd windows on startup, but the machine I was doing it on has uptime of nearly a year so I'm not too fussed now :P
 
byobu?
 
frontend to screen/tmux
Has a fair few quality-of-life improvements
> Byobu is a GPLv3 open source text-based window manager and terminal multiplexer. It was originally designed to provide elegant enhancements to the otherwise functional, plain, practical GNU Screen, for the Ubuntu server distribution. Byobu now includes an enhanced profiles, convenient keybindings, configuration utilities, and toggle-able system status notifications for both the GNU Screen window manager and the more modern Tmux terminal multiplexer
 
7:43 PM
Anyone have any experience with smart TVs? (Samsung and Sony)
I took photos for a friend and put them on a USB drive and he's now asking if they'll show up on a smart TV
And I have no idea
I formatted the drive NTFS but perhaps I should redo it as FAT32?
 
@bertieb I have little experience with the "smarts" of TVs, but I typically see requirements like "Must be FAT formatted" (whether it's FAT32, FAT16, or even exFAT). I haven't seen any that support NTFS, yet
So, I'd give that a try first. You can always run convert from Windows to change a FAT device to NTFS without data loss
 
@CanadianLuke Cheers, will try
 
Good luck
 
Cheers!
I think some of the newer models support NTFS but FAT32 is probably a safer bet
I'm just hoping I can re-rsync them all to the drive before he gets here :P
 
If it supports exFAT, and the drive is larger than 4GB, I'd try that
 
7:49 PM
No idea what it supports
More likely to support exFAT than FAT32?
 
FAT32 can support drives up to 2 TB, provided you set the cluster size high enough.
 
This is a wee 8GB usb drive to share ~500 photos witha friend this evening
I'm not worried about bumping into limits, only support from smart TVs, since he asked :P
 
exFAT is nothing like fat32 btw - a driver for fat32 won’t work for exFAT
 
My feeling is that FAT32 is more widely supported, since it's been around longer.
 
Which would you recommend?
 
7:54 PM
A dumb tv is unlikely to support exFAT
 
That was my feeling
 
I would definitely avoid NTFS
 
but I also wondered about TVs running Android or Linux under the hood, and formatting their own root partitions exFAT (for some reason that's in my head)
Aye, fair enough
One quick reformat later, the files are transferred
Wait no what
rsync complained at the end of the transfer about permissions
Drive, y u do this
incoherent grumbling
 
You know you live in the first world when you have to copy files to your TV.
 
8:30 PM
@bertieb Why would rsync care about file permissions against a FAT32 device?
It should automatically make every file/folder rwxrwxrwx, and owned by root:root, right?
 
@CanadianLuke shrug
possibly it's some quirk of filesystem mounting
 
... Very weird...
 
NTFS driver is userspace or somesuch so I could write there as my user
But FAT32 was mounted so only root could read it? I dunno
I mean either way it's grand
What I don't understand is why rsync did the whole thing with a transfer rate and everything, and then failed, writing nothing
The upshot is the transfer didn't complete so I sent my friend away driveless
At this point I am tempted to buy a new USB drive as the ones I have are old and creaky and doing weird things anyway
 
What mount options were set?
 
Gah! I have a user that accepted some Exchange meeting invites from his iPhone and now there's many many responses being sent to the organiser... :|
 
8:37 PM
No mount options, just mount /dev/sdXN /tmp/usb/
 
Output of mount?
 
No output
 
@CanadianLuke rsync can't write permissions to fat32
yet it doesn't care that it can't, only that it fails.
It's just a warning, the files have likely worked?
 
That seems... So weird...
 
df said no space was used
and the directory listing was empty
So I think it really did fail in the least helpful manner
Scratch getting a new drive, earliest delivery date is Friday
Thank, beast from the east blizzard
...I think the ghost of the Windows File Transfer dialog is possessing my copy of rsync
Estimated completion time is between 4 minutes and 2 hours
angrish
This is why I don't bother with USB drives, as a rule
 
8:41 PM
oh
did u rsync as root?
sudo mount /dev/blah ./meh
 
I am now, yes
 
sudo rsync ./moo/* ./meh/
 
But when the drive was formatted ntfs it didn't need root to complete the copy
 
yeah, mounts are rwxr-xr-x by default
 
Except FAT32? :P
Besides, surely there should be some error/warning either before it begins or at the very least, after the first file if rsync can't write to the target?!
 
8:42 PM
no, all
the mount POINT
so inside the mount is ./
that will have rwxr-xr-x by default
So if you mounted aas root
 
I mounted both as root; only one then needed root to copy files to the drive
Which is odd
 
God I'm in a bad mood
Turning in for the night
 
But then if ntfs3g is userspace (or something) maybe that explains it?
 
Goodnight
 
8:44 PM
'night!
Permissions notwithstanding; surely there should be some warning either before it begins or at the very least, after the first file if rsync can't write to the target?!
 
@bertieb did you create a mount point, as root?
 
Nope, user
 
:/
oh ntfsgg is screwed
can't.... create/change file sizes etc
 
I dunno
Wrote all the files themselves fine
At this point I'm just hoping the file transfer completes to the FAT32-formatted drive
Because it is getting slower and sslloowweerr and ssslllooowwweeerrr
I found another drive, which I'll try
I mean, it didn't want to format at first, but after a couple of tries and asking nicely, it seems to have taken
I swear my equipment is cursed sometimes
If this doesn't work both drives are going in the bin, via a Universal Reconfiguration Device (hammer)
 
9:01 PM
@bertieb lol
@rahuldottech I was very tempted to flag that. Given the recent mass shootings, it's insensitive and hurtful to victims and their families.
 
Copy #2 is catching up!
gif, y u no animate?!
 
How do you fix something that is already apparently "fixed"?
 
Fix it harder
Either that or more duct tape, according to the "if it moves and it shouldn't" principle
What's fixed/'fixed' that needs fixin'?
 
9:17 PM
iOS user accessing their Exchange account through the Mail app on their iPhone. They're up to date with iOS version, and from everything I can see this issue has been fixed by Apple/Microsoft... but whenever they accept a meeting from their phone it generates heaps of accepted response emails in the organisers inbox.
 
Ah
 
It was fixed in iOS 9.3. Yet, this 11.2.6 user is experiencing the exact same issue.
 
Regression maybe?
(Exchange and iOS are so far out of my range of expertise that if I tried to help I'd probably be hit with a whole raft of UN sanctions)
(joke topicality: solid 5/7, delivery: ★★☆☆☆, overall grade C-)
 
9:33 PM
Possibly, although I'm sure I would have seen a few more results online about it if that were the case.
It must be an Exchange issue on our end.
 
Ah yeah, could be
Good luck tracking it down, either way!
 
I'm not Exchange admin, so I don't care!
 
👍 :D
 
I'll just tell the user that they need to accept invites from their laptop. thumbsup
 
Fair enough :P
Both of my file copies completed to both USB drives, seemingly successfully (!)
I have a bottle of champagne in the fridge I've been saving for just such a celebration
 
9:41 PM
I rsync'd about 2TB of data the other day. That was exciting. :)
 
10:38 PM
rsync is bae
 
10:49 PM
Rsync is life.
 
rsync is wife-material
 
Bob
11:06 PM
morn
 
If any of you are on mobile, can you see this: 🆂🅴🆁🅴🅽🅳🅸🅿🅸🆃🆈?
@bertieb I can't legally drink for 9 years
@bwDraco it's a mockery of how the government is reacting to the situation. I sent that message out if spite and disgust for how the situation is being treated. It was sarcastic.
 
11:22 PM
@rahuldottech I don't really drink tbh
 
@bertieb lol. I don't really plan on doing so either, but it's nice to know that I can
 
Empty calories and I enjoy sobriety shrug
Aye true
If somebody told me I couldn't drink for 9 years, I'd be irked
 
But only mildly inconvenienced
That said, I'd be more inclined to drink if I was banned, just out of contrariness
 
@rahuldottech I stopped drinking once it became legal
 
11:24 PM
@FMLCat you started drugs though so... Meh :P
 
It's tricky getting the tone right on highly-politicised events
Sometimes it's better to speak your mind / state your opinion plainly rather than being facetious or using irony
 
@bertieb true. Very valid.
 
@rahuldottech I'll stop taking those iff/when they become legal too
 
Meh... Drinking is over-rated anyways
 
I share your sense of frustration though
Alcohol is a drug :P
(a facile statement, I know)
But really, it does a huge amount of harm to a good chunk of the population
And yet it's... glorified? embraced? not quite the right words
We'll see if the minimum alcohol pricing decreases consumption, or (more likely), increases trips to Carlisle
 
11:30 PM
@bertieb it's not really something I care about, I just like to complain about restrictions which are imposed on me ;P
 
It's strange that the money raised by the levy goes to the retailer though; I guess it was about the only bone that they could throw to forestall a coalition of legal challenges, and not jst from the manufacturers
 
@FMLCat did hookah yesterday. Was very meh.
I felt "high" for like maybe 2 or 3 minutes, and I'm pretty sure that not what really being high even is
 
@rahuldottech dude... Not cool.
 
@rahuldottech Aye, restrictions are... irksome
 
@JourneymanGeek sorry, I was just very pissed with how the whole thing is being handled
And then all these people in India are treating Trump like god without knowing anything about him whatsoever
Idiots
 
11:33 PM
@rahuldottech Did your mom yesterday. Was very meh.
 
@FMLCat -.-
Do you not like live in Europe or something
 
That... remains to be seen
 
A hookah or ḡalyān (Persian: قلیان Urdu: حقّہ (Nastaleeq), IPA: [ˌɦʊqqaː]; also see other names) is a single or multi-stemmed instrument for vaporizing and smoking flavored tobacco (called Mu‘assel), or sometimes cannabis or hashish, whose vapor or smoke is passed through a water basin—often glass-based—before inhalation. Health risks of smoking hookah include exposure to toxic chemicals that are not filtered out by the water and risk of infectious disease when hookahs are shared. There are two theories regarding the origin of the hookah. The first is that it originates in Safavid dynasty of Persia...
 
@FMLCat also not funny
 
So you smoked a lame cigarette or did weed?
@JourneymanGeek I'm so hot I'm uncool
 
11:35 PM
@FMLCat not weed. Friends do weed, idk, might try it. Apparently super easy to get a hold of
 
We don't consider regular tobacco "doing drugs"
I prefer to refer to it as "Giving yourself cancer"
 
@FMLCat it wasn't tobacco either
It's some non-addictive thingy
Probably has nicotine tho
 
> A hookah or ḡalyān (Persian: قلیان Urdu: حقّہ (Nastaleeq), IPA: [ˌɦʊqqaː]; also see other names) is a single or multi-stemmed instrument for vaporizing and smoking flavored tobacco (called Mu‘assel), or sometimes cannabis or hashish
Your options there are tobacco or cannabis or cannabis
Anything else and you're using your hookah for a non-approved non-wikipedia listed purpose
 
@FMLCat Wikipedia knows nothing
 
@rahuldottech Says the teenage schoolkid who hasn't even got drunk yet
 
11:43 PM
@FMLCat wtf does that have to do with knowing Wikipedia can be incomplete?
 
@rahuldottech You know nothing Jon Snow until you've drunk edited Wikipedia
 
Apparently, bash.org is blocked in my organization
 
00:00 - 18:0018:00 - 00:00

« first day (2762 days earlier)      last day (1138 days later) »