« first day (2644 days earlier)      last day (508 days later) » 

12:21 AM
@DavidCarlisle Seems so
 
@egreg now you've started you can fix all the gnats issues
 
cfr
12:53 AM
@samcarter If you insist, yes. But I've already been had it twice, so I'm not sure you should. But if it is OK to, then, yes, thank you and I would be honoured in that case.
@samcarter Also, I still haven't produced a working version of chronos, which I half promised to do if nominated last year. Though I have made some progress. (I got stuck. I don't know how it should be. :()
 
 
1 hour later…
1:56 AM
@DavidCarlisle Oh, I thought it would be simply "zz" ;-)
 
 
5 hours later…
7:01 AM
 
7:51 AM
@DavidCarlisle did you update the oberdiek bundle? tex.stackexchange.com/questions/412216/…
 
8:22 AM
@StefanKottwitz oh no
 
Good morning @PauloCereda
 
@Sebastiano Ciao
 
@PauloCereda I not understand this question tex.stackexchange.com/questions/411987/… Can you see if it is a spam?
@PauloCereda Ciao!!!!!!
 
@Sebastiano The OP is probably talking about hyperref.
 
9:11 AM
@UlrikeFischer define "did"
 
Dec 2 '17 at 22:30, by Joseph Wright
@DavidCarlisle Blame Joseph?
 
@DavidCarlisle Upload to ctan. But I just checked, there is nothing. Also the chinese seems to be at the place where the out-file is loaded, so it is probably related to the file name.
 
@UlrikeFischer on about 50 attempts with 60 different browsers and from 3 different IP addresses I have clicked "submit" and watched it upload "100%" of the submission only to be returned to the form with the "zip" file field saying "no file selected" It's with Gerd at ctan.org now but no progress so far..... So I "did" something but whether or not I "uploaded to ctan" I am not sure.
@PauloCereda excellent plan.
has anyone updated a ctan package in last few days?
 
@DavidCarlisle Must, there are few announcement and as far as I can see there are in texlive.
 
@StefanKottwitz: I was thinking that, in the unlikely hypothesis of an hecatombe (in case IMPA not offering a infrastructure), is there a free online service that I could use to live stream the conference?
 
9:26 AM
@UlrikeFischer it may be a file size thing (the zip is a bit big) , although Chrome shows a 404 error for some javascript that's supposed to be served from ctan.org. However Gerd says the actual submission doesn't show in their logs at all. He was looking last night, if it doesn't get resolved today I'll ask if I can give them the zip by some other means.
 
9:38 AM
@PauloCereda I don't know such an online service. Perhaps Facebook live or such newish nonsocial networks :-o
 
@StefanKottwitz That's exactly what I was trying to avoid. :) They require people to have an account.
I was looking a Twitch.tv, but the thing has to be gaming-related.
 
@PauloCereda Show them the tikzduck talk abstract.
@PauloCereda Make a TeX.SE question with voting for talks. Then it's gaming.
 
@StefanKottwitz :D
 
@PauloCereda Gaming related how? People stream creative on Twitch (as in making stuff), social eating... There might be rules with conferences though.
 
@daleif Really? I don't follow Twitch that much... I will take a closer look, thanks!
 
9:56 AM
@UlrikeFischer browser failed again but I just tried with ctan-o-mat and it says it succeeded, we'll see if ctan got it.
@JosephWright ^^^ I'd have used l3build but....
Actually wasn't @PauloCereda supposed to be adding that?
 
@DavidCarlisle Yes, my bad.
 
@PauloCereda YouTube?
 
@TorbjørnT. Hmm YouTube has a Live option...
 
10:34 AM
@DavidCarlisle :)
@DavidCarlisle That issue is assigned to @PauloCereda ;)
@DavidCarlisle Seriously, it would be good to integrate this (or perhaps simply point to ctan-o-mat)
 
@JosephWright better to integrate and have the config in lua I think, calling a pseudo-latex config file from l3build wouldn't really fit the style, although I suppose you could get l3build to write the ctan-o-mat config
 
11:18 AM
0
Q: using a TrueType font

AlexGI don't seem able to use a TrueType font shipping with TeXLive, such as DejaVu. Compiling with lualatex fails on this example input: \documentclass{article} \usepackage{fontspec} \begin{document} \fontspec{DejaVu Serif} DejaVu Serif Test \end{document} What am I doing wrong (vanilla TeXLive-...

Could someone confirm this issue on Linux?
 
Guys, don't get me wrong, but I believe we are indicating too much people for the TUG thingy... We have only 2 nominations out of 10 that are not indications... And there's only 8 slots.
@AlexG It works for me with TL 2017 on Fedora.
 
@PauloCereda @AlexG same here, Ubuntu 16.04, using upstream TL2017
@PauloCereda There are some Canadians I follow, who stream various things, games, cooking, a live variety show, etc. I often don't catch them live, bu then there are the Twitch VOD (if enabled).
 
@daleif Ah interesting, thank you! Only glance Twitch once in a while, mostly because of the AGDQ events which I love.
(AGDQ = Awesome Games Done Quick. It's a speedrun marathon for charity purposes)
@daleif: do you enjoy gaming, Lars?
 
11:42 AM
Thank you for your replies to my TTF issue. Nevertheless, it is weird since I have a full and up-to-date TL-17 installation. Curiously, OpenType fonts work.
 
@AlexG Perhaps the font name in your system? I had something along those lines in the past...
Also, does it work with XeLaTeX?
 
@DavidCarlisle Sure
 
@DavidCarlisle, @JosephWright: deeply sorry friends, I need to finish a chapter before the end of next week... :(
 
@PauloCereda Oh quite understand
@PauloCereda I need to sort out setversion and the idea of using a different main()function, plus there is the entire 'should we make an executable' business
 
@AlexG works for me on cygwin (which is more like linux than windows as far as texlive goes)
@PauloCereda s/chapter/thesis/
 
11:55 AM
@PauloCereda I don't play games any more (haven't got the need for the hardware). I did follow some playthroughs.
 
12:05 PM
@PauloCereda AGDQ = Awesome Gurus Do Quack, no?
 
@paulo What would the file name be of the font in question? Maybe there is a faulty duplicate somewhere on my system.
 
@AlexG I would try deleting ` /home/grahn/bin/texlive/2017/texmf-var/luatex-cache` and let it rebuild
 
@DavidCarlisle Not that deadline, but will happen soon.
@daleif I follow some playthroughs as well!
@mickep Quack! :)
@AlexG Oh I cannot remember which font was causing me trouble...
 
@PauloCereda Here is the replay channel for the people I follow in Canada. Check the "watch and play" series at some point. That is one host subjecting the other to a variety of "strange" and often broken games.
 
12:21 PM
@daleif Ah cool. :)
 
@PauloCereda I forgot the link: youtube.com/user/loadingreadylive
 
@daleif Cool!
 
@DavidCarlisle. Perfect. Deleting the cache solved the problem. Thank you a lot!
@paulo @ulrike deleting the cache, as David suggested, did the trick! Thank you all!
 
@AlexG Yay!
As always, @DavidCarlisle saves the day. :)
 
@AlexG I suspected that is has gone weird. The error looked as if you didn't have a luc (or more than one ...).
 
12:36 PM
@UlrikeFischer Use the force, Luc? :)
 
12:48 PM
@PauloCereda Maybe you're thinking of the Obi-Wan Stallman method of software documentation? “Use the source, Luke!”
 
@ulrike You did have the same idea as David! So many thanks to you as well!
 
@HaraldHanche-Olsen Or Mark Hamill to Homer Simpson: "Use the fork, Homer!"
 
1:32 PM
You had one job!
@cfr ^^ :)
 
@PauloCereda I think you will find that's been posted previously:-)
Jul 8 '17 at 10:44, by David Carlisle
@PauloCereda how's your welsh ^^
@PauloCereda ^^^^^^^^^^^^^^^^^^^^
 
@DavidCarlisle ooh sorry
 
@PauloCereda I am sure you were too busy concentrating on your thesis to be paying attention to pictorial postings at the time.
 
1:48 PM
@DavidCarlisle oh
 
1:59 PM
@DavidCarlisle How much brain power does it take to contemplate the empty set?
 
@HaraldHanche-Olsen quite a lot (too much for a duck)
 
@DavidCarlisle ooh
@DavidCarlisle: we could make @egreg mad by using \varnothing instead of \emptyset. :)
 
@PauloCereda and celebrating with a pizza with chocolate sauce
 
@DavidCarlisle ooh
 
@PauloCereda I just made that up, but I wonder...
 
2:09 PM
@DavidCarlisle I ate a chocolate pizza 2 years ago, it was very good! :)
Sweet pizzas are very common in Brazil.
 
I think even @CarLaTeX would rather have pineapple:-)
 
Yummy!
 
@PauloCereda @egreg will be so looking forward to his trip
 
@DavidCarlisle I will take the guys to a fancy pizza place!
I might need to teach @egreg how to swear in Portuguese. :)
 
@PauloCereda same as Italian, but without the "o" at the end of every word isn't it?
 
2:13 PM
@DavidCarlisle No, there are few differences. :)
 
2:25 PM
@PauloCereda Is your thesis about plumbers?
@PauloCereda Penitentiagite
 
@egreg LOL
 
@PauloCereda This is good for a palačinka
 
@egreg yummy!
 
2:53 PM
Sweet pizza is not pizza!
 
@CarLaTeX Swizza. Possibly originating in Switzerland. ;-)
 
@egreg Bravo, digli qualcosa a quelli là! ;)
 
3:05 PM
@CarLaTeX looks like pizza with nutella is something italian accept (grudgingly): quora.com/Do-Italians-actually-eat-sweet-pizza ;-) @DavidCarlisle
 
@egreg I would not be surprised if this would have been invented in the US. The Swiss are much more responsible and less cruel.
 
Also, do not annoy the Swiss!
 
@PauloCereda We could invade Switzerland, so they can react and invade us, then we'll surrender.
 
@egreg ooh
 
3:27 PM
@UlrikeFischer I'd call it focaccia con la Nutella, not pizza :)
 
3:49 PM
@UlrikeFischer it's installed at ctan now:-)
 
@manooooh For the tikzduck fan from Argentina: i.stack.imgur.com/27OYn.pngsamcarter 21 mins ago
@CarLaTeX Added a duck :)
 
@DavidCarlisle Good. So a number of hyperref issues can be closed ;-).
 
@samcarter A Maraduck? :)
 
@UlrikeFischer nope, I just sent oberdiek not hyperref (I could do that as well now I have found a way to get uploads to work)
 
@DavidCarlisle oh. I thought hyperref is in oberdiek ;-(.
 
4:01 PM
@UlrikeFischer no I uploaded 35Mb of packages you don't want:-)
 
@samcarter Yay!!!
 
@samcarter the latter. :)
 
@DavidCarlisle There are quite number of package in it I do want (like zref), and probably quite a number I use without really noticing. I was wondering about the 35 MB, but for over 100 packages is not so much ;-).
 
@PauloCereda Then the stripes orientation is wrong:)
 
4:09 PM
@samcarter Football is sacred in Argentina (if we think we are fanatic, you've seen nothing), so I won't comment. :)
 
@UlrikeFischer given I just added two b to get binary file reading, taking half an hour to rebuild and 2 days to upload to ctan, seems like it's big enough without combining it with hyperref:-)
 
@DavidCarlisle Yes, looks really as if it would be a good idea to split it up a bit.
 
cfr
4:55 PM
@PauloCereda ;) (I can't see the image here for some reason, but can on twitter itself.) Interesting legal implications.
 
@cfr ooh :)
Cwac!
 
5:07 PM
@UlrikeFischer It's tricky because of the hobsub package stuff which ties them together and hidden cross link requirepackage{fooo}[same date as this] which means that there are bunches of packages that you need to update together, and the build dependencies are not over-documented:-)
 
5:22 PM
I compile in Texstudio with latexmk (lualatex) and get somewhere in the logs "tput: No value for $TERM and no -T specified" I could not find the source of this message. Is tput a lualatex warning, or where does this come from?
$TERM looks more like a bash thing to me
I would not expect that lualatex would be bash specific, because it probably works on windows too.
------------ Running 'lualatex --halt-on-error --output-format="pdf" --shell-escape --synctex=1 --interaction=nonstopmode -recorder "test"' ------------
tput: No value for $TERM and no -T specified
Latexmk: Found input bbl file 'test.bbl'
looks like Latexmk warnings would have Latexmk: in the beginning.
 
@JonasStein Certainly latexmk, $thingy looks like a Perl variable.
 
that is a good hint
 
@JonasStein also, you are running with shell-escape so the document could be running any shell commands, are you sure it is not coming from one of those
 
ah perhaps from minted...
I think you point me to a good path. Thank you.
 
@JonasStein To be fair, there is a TERM variable in Linux systems, but it's usually populated and not empty/unset, hence my suspicions...
 
5:31 PM
If I run xterm it is $TERM=xterm, but I am not sure what happens, if texstudio evokes a shell command.
 
@JonasStein Env vars are usually inherited.
Anyway, it does look like an issue to me. :)
 
6:03 PM
I have a file where I have converted powerpoint slides to PDF and included the PDF... WHat I would like to do is squeeze two slides onto a page though, as the moment each slide is on its own page
is this something that I can handle within latex / the includepdf thing?
 
@baxx You could use \includegraphics as well.
You could use two minipages or the columns thingy in beamer and put the two slides side by side. :)
 
I'm currently just using \includepdf[pages={-}]
so that the entire pdf is included - i think handling each page with a mini page would be too much work
there are often about 20 pages
 
@baxx Check the nup option of pdfpages then.
 
@baxx There is the forloop package to do the automation for you. I done (approximately) what you want once.
 
I'm not sure what you mean with nup , i don't want to include any less if that's what you mean though
i don't want to micro manage each page, so if this is what needs to be done then i'll just leave it
 
6:09 PM
@baxx you could take a look at the manual too see what is this nup option I am talking about. :) Since I am not sure what you want to achieve, this might help you somehow.
 
why would you suggest something without being sure what you were suggesting it for?
but no worries, if there's not something known I can live with it as it is
 
@baxx I know what's for. I don't know what you want to achieve.
I am done. Good luck. Just trying to help.
 
i know, thanks. I'm just saying that i was asking on the chance that it's something obvious
 
@baxx That's why I asked to check the nup option of pdfpages. It includes more than one page in some fashion you specify.
 
thanks - i'm thinking that I might have the wrong problem now, as there will be a lot of dead space around the slides. Instead - I should write two pages of the power point to the pdf when the soffice command is initially run. Cheers though
 
6:23 PM
@baxx I don't remember the option name, but I think there's a noscale thingy that gives you more control on the included PDF.
Then you can exploit the size by adding scale=1.2 or other factor to your included PDF.
Also, add a frame option too, so you can see the exact space your PDF is taking (if your slide is white, of course). :)
 
@PauloCereda I would have to not only scale - but crop too. Because the PDF file ( with the slides ) has one slide on it and dead space about it
hrm frame, ok maybe that could work
 
@egreg I wonder why people write y^{''}. In what manual did they find that? :)
 
@mickep No idea. I get goosebumps whenever I see that.
 
@egreg Goosebumps indeed. I'm surprised they don't seem to look at the result.
 
@egreg Did you ever try to add a figure or a table with the automatic button of Verbosus? That explains many things...
 
@CarLaTeX What's Verbosus?
 
@samcarter Great!!! Another user joined the Duck Side of the Force!
 
@PauloCereda that worked really well actually, \includepdf[pages={-}, nup=2x3, frame=false, scale=1.0]{pdf} ... thanks
 
@baxx Glad to hear!
 
6:43 PM
@egreg I use their app when I'm on the shaky bus with my smartphone
 
@baxx If I recall correctly, Paul Erdős once said people should trust in The Book, so the same applies to manuals in general. :)
 
My erdos number is probably about 938475394857 ;)
 
@baxx I probably don't have one. :) @egreg, on the other hand, has 3, I guess. :)
 
@CarLaTeX The start is not very promising
\documentclass{article}

% Allow the usage of graphics (.jpg, .png, etc.) in the document
\usepackage[pdftex]{graphicx}
% Allow the change of line spacing
\usepackage{setspace}
% Allow the usage of umlauts and other non-ASCII characters
\usepackage[utf8]{inputenc}
 
Jul 10 '15 at 1:12, by Paulo Cereda
@cfr -> World domination by ducks. :)
 
6:56 PM
@PauloCereda oh, i thought everyone had one? I think I've misunderstood the number :')
 
@egreg The pre-defined figures and tables are even worse :)
 
@CarLaTeX Yes, I saw that. And there is also \bf somewhere.
 
@egreg That explains many things :):):)
 
cfr
@JosephWright @DavidCarlisle @egreg @anybody @everybody Has something about l3keys2e changed? How do I recover values with the current version?
0
Q: How can I recover option values with the current l3keys2e?

cfrMinimal-Compiling-But-Not-Working Example: \begin{filecontents}{\jobname.cls} \ProvidesClass{\jobname} \RequirePackage{l3keys2e} \ExplSyntaxOn \keys_define:nn { job / doc } { doc~name .tl_set:N = \l_job_doc_name, } \ProcessKeysOptions { job / doc } \ExplSyntaxOff \PassOptionsToClass{10pt...

This affects code which was working - at least, certainly this bit worked. I'm not saying there weren't bugs, but I would have noticed if the document title was always missing. So I may be missing the obvious, but, if so, the unobvious used to work, too.
I guess it is the space. Does l3keys no longer accept key names with spaces? Eek.
 
7:33 PM
@cfr No, rather the opposite
@cfr We used to normalise out spaces entirely, but there were some issues so that's been dropped. The recommended form hasn't changed: use-dashes-as-required
@cfr Your problem is that the kernel zaps spaces before l3keys2e gets anywhere near the data: in the past that didn't matter as we also normalised out spaces, but now it does show
 
7:58 PM
Evening all
 
 
1 hour later…
8:58 PM
@PauloCereda There is no need to guess:
Aug 22 '17 at 17:42, by barbara beeton
@yo' -- no, i'm sure @egreg will be happy to learn that his erdős number is 3! see http://www.ams.org/mathscinet/collaborationDistance.html?group_source=76705
@baxx It makes sense to say that your Erdős number is infinity if there is no collaboration path between you and Erdős. But it makes equal sense to say you have no Erdős number in that case. Take your pick.
All of which makes me wonder: What is the largest (known) finite Erdős number? I'll bet it is not very large at all.
 
@DavidCarlisle I'm sorry to inform you that align can be nested inside gather: read the paragraph just before subsection 10.3: Explanation: The structures align, alignat, etc., are designed for top-level use and for the most part cannot be nested inside some other displayed equation structure. The chief exception is that align and most of its variants can be used inside the gather environment.
 
9:38 PM
Sep 29 '11 at 15:02, by egreg
@PauloCereda My Erdős number is 3.
 
9:49 PM
@egreg but do you have an Erdos-Bacon number?
 
@StrongBad I'd find more interesting a Lamarr number ;-)
3
Hedy Lamarr (; born Hedwig Eva Maria Kiesler, November 9, 1914 – January 19, 2000) was an Austrian-born American film actress and inventor. At the beginning of World War II, Lamarr and composer George Antheil developed a radio guidance system for Allied torpedoes, which used spread spectrum and frequency hopping technology to defeat the threat of jamming by the Axis powers. Although the US Navy did not adopt the technology until the 1960s, the principles of their work are arguably incorporated into Bluetooth technology, and are similar to methods used in legacy versions of CDMA and Wi-Fi. This...
 
@egreg me eeading the doc, don't be silly. I guess I'll delete the comments then, still seems wrong to me
 
@DavidCarlisle Well, I guess you should fix the bug. ;-)
 
@egreg the bug that it works or the bug that label does something odd?
 
@DavidCarlisle :)
 
10:00 PM
@DavidCarlisle :)
@DavidCarlisle By the way, notwithstanding the error message, the labels are correctly absorbed, it seems.
 
@HaraldHanche-Olsen The largest known finite Erdős number is 13 or bigger (Arturo Robles has an Erdős number of 13)
 
 
1 hour later…
cfr
11:16 PM
@JosephWright Not that it helps much at this point, but recommended where exactly? I couldn't see anything in the l3keys2e doc. If I remove the space in the class, will documents using the space work correctly? That would be less unnice.
 

« first day (2644 days earlier)      last day (508 days later) »