« first day (2184 days earlier)      last day (1172 days later) » 

12:48 PM
So uh . . . . what else is new ?
 
Sorry @serg, that was for your own good. . .
(I just kick-muted him)
 
@terdon heh, the last time someone asked me, I said "no"
 
Oli suspended him once.
 
@JourneymanGeek Hey, whatever the customer user wants, right?
 
@terdon not always
 
12:51 PM
We should be far more boring to avoid such things.
 
We have the most boring chatroom name.
 
well . . . i am on the train right now, so kick muting wasn't necessary . . .but I'll take it :)
 
The least boring people hide behind their most boring name. :P
 
So, here's my issue. We're not your parents. We shouldn't be helping you with self control issues. Its also not what suspensions are for ._.
 
i know
 
12:54 PM
We need more mods in here.
 
@JourneymanGeek Agreed. I don't think I'd actually suspend anyone on request.
@Serg :P
 
now If you asked that on meta...
 
If only mods would talk all other user would feel a bit off
 
Guess that's why no one else is saying a word right now.
 
c
o
m
e

o
n

e
v
e
r
y
b
o
d
y
,

b
u
i
l
d

a

b
l
u
e

w
a
c
h
a
t

w
a
l
l
!
 
12:56 PM
I know :)
 
Oh hey, I just noticed I'll be hitting 200k network-wide soon. Cool!
 
<-- pretends to leave now
 
<-- resists the urge to kickmute @Takkat
 
<-- totally leaving right now
 
still. . . resisting. . .
 
12:57 PM
I have always been here
2
For certain values for always
 
<!-- this is a comment on the state of this room -->
 
See, I am not asking for others to help me with self control actively. i only ask in extreme cases. and yes, terdon is right - if customer wants it, give it to them. Worst case is that they won't come back. I,however, will. And i don't hold grudges
 
@Serg it goes against what suspensions are for tho
 
@Serg Actually, if we're being serious, I wouldn't suspend someone if they only wanted to get suspended to stop spending too much time here. I'd just tell them to grow up.
I don't want to have to go through the various clicks needed to suspend someone just because they can't manage to turn off their computer.
 
@JourneymanGeek yes, i know. I had this discussion with Oli before
@terdon it's a bit more complicated than just turning off computer
but anyhow . . .
 
1:00 PM
If you don't want to come here, stop coming here. I admit that I would prefer you kept coming here so we can enjoy your great contributions, but if you don't have the time, stop doing it.
 
I enjoy coming here, in all honesty.
Like i said, it's a combination of things, plus fallout from previous days
one thing for sure: today will be interesting. I'll see how well i know this material. Today I've an exam im control systems
D&A communication will be a problem, but I'll survive, not the first time
And luckly we're doing a lab today in datacomm class. so yay, more wireshark
i might start doing wireshark questions soon too
 
heh. I leave my PC on all day, and just respond to pings ;p
 
@edwinksl just installed it!
 
me too
 
wishbi was living close to campus. commuting every damn morning is painful sometimes
 
1:11 PM
Me too just installed it or me too leaves my computer on?
 
all of the above
 
@Seth both
I installed Alo.
 
Cool! Let me try to add you..
Well that's lame. Looks like you can only add people by phone number?
 
Yes
 
That will make this a lot less used...
 
1:20 PM
Also yes.
 
i wonder if Starbucks is open . . . .but then again, i can't bring drinks into lab
 
TLDR
lim f(yawn) as t -> infinity = infinity
maybe i should get another coffee
all my attempts to quit everything don't work out too well
 
Hello everybody ! :)
 
1:40 PM
hi
 
@Serg Hey my friend - how are you doin' ? :)
 
not too good
no sleep
exam today
but i got some coffee and sandwich
 
@Serg not very nice to read this ... :(
@Serg solution : go to bed ... now ! :)
@Serg good luck for best success ! :)
@Serg so not everything is bad ... :D
 
boxy don't pm serg 5 times :(
people got kicked from chat for doing that
 
@Rinzwind hmmm ... okay :)
@Rinzwind really ? what a great reason :(
 
1:55 PM
It is. It is very annying getting 5 sounds quickly in a row
 
i personally don't mind :)
@cl-netbox can't go to bed now, i have class in 5 mins. I have 4 hour break after that so maybe I'll sleep for 2 hours but i can't right now
 
@Rinzwind Noted.
 
@jokerdino that I missed an o? :X
 
One easy trick to annoy Rinzwind. You wouldn't have expected it!
 
@Rinzwind knock knock knock @Rinzwind knock knock knock @Rinzwind knock knock knock
3
 
2:34 PM
I'm tempted to star that >:p
 
following your example ;-)
 
if command that compares date, and delete files that are 24 hours older then the current date... no find!
That is harder than I thaught!
 
Even with "find" it's still complicated enough... I have no idea what exactly "find"'s definition of time is.
 
@ByteCommander Yeah, fudge me.
 
wait, I think I almost have something
test "$((86400+$(date -r="$file"+%s)))" -lt "$(date +%s)" && rm -- "$file"
@blade19899 something like that? ^
You can easily transform it into an if statement if you want to.
 
2:47 PM
@ByteCommander Show me how xD
 
file="~/testfile
if test "$((86400+$(date -r="$file"+%s)))" -lt "$(date +%s)" ; then
    rm -- "$file"
fi
You can also say if [ ... ] ; then or if [[ ... ]] ; then instead of if test ... ; then, but I personally prefer the version with as few brackets as possible. Not sure if there is any notable difference.
 
can I block users in chat?
 
You are missing a " in there? syntax coloring shows me that
 
@blade19899 You mean find -mtime 1 -delete?
 
The missing " is in the 'file=' line.
 
2:53 PM
Or do you need to not use find for some reason?
 
for the next week terdon is on ignore (...)
 
Sorry, couldn't resist.
And I really shouldn't have. I really don't like needless pinging. Still, you have to admit you asked for that one :)
 
@blade19899 Oops, sorry. Yeah, it's missing at the end of the first line.
 
@ByteCommander You also don't want the =, use -r file or --reference=file
 
Meh... :-/
 
2:57 PM
$ date -r=file
date: '=file': No such file or directory
 
file="~/testfile"
if test "$((86400+$(date --reference="$file"+%s)))" -lt "$(date +%s)" ; then
    rm -- "$file"
fi
 
> date: =/root/testfile+%s: No such file or directory
./test.sh: line 12: 86400+: syntax error: operand expected (error token is "+")
 
yah yah... you're right
 
@blade19899 That's because of the =, try his edited version.
But why aren't you using find for this?
 
He said not to use find. For whatever reason.
 
2:58 PM
@terdon What does the date format need to be in testfile?
 
If you're on a non-GNU system, the date won't work either.
@blade19899 There's no date there. That's your target file.
 
@terdon Don't have findas an option on that server. Can get a list of files, and their timestamps
 
@blade19899 What OS? You need GNU date for the other solution too, I think
 
@terdon Linux CentOS 7.2
 
And hasn't find a very special definition of when something is older than a day and when not? I believe to have read something strange in the manual there...
 
2:59 PM
@blade19899 Then why don't you have find?
@ByteCommander Yeah. It counts in 24h.
   -atime n
          File  was  last  accessed n*24 hours ago.  When find figures out
          how many 24-hour periods ago the file  was  last  accessed,  any
          fractional part is ignored, so to match -atime +1, a file has to
          have been accessed at least two days ago.
 
@terdon It's a project I was tasked with, the server we have files on, need to be monitored. Meaning the deleting 24 hours and older files need to be removed.
 
@blade19899 OK, but I still don't understand why you don't want to use find. CentOS has find and find is the right tool for the job.
 
We are aware of issues on Stack Overflow right now. We are investigating.
 
@terdon yeah, but the files are not on CentOS, but on an external server, which is only allowed to use some basic tools like ls, which is why I can get the dates for those files.
 
3:03 PM
How can a program use 119% CPU?
 
multi-core system.
 
So it maxes out one core and uses 19% of another core?
 
Or 59.5% on two cores...
 
@grooveplex with a loadbalancer it would be 2x 59.5 on 2
@ByteCommander >:)
 
okay thanks
 
3:05 PM
 
@grooveplex Are you checking it in top?
You can turn Irix mode off by pressing I (Shift + i)
Then it shows total the percentage of all cores, instead of 100% representing one core.
 
@blade19899 Ah! Now it starts making more sense. But do not use ls|!
Why not post a question on U&L giving all the details and we can figure something out?
 
@ByteCommander time :O
 
@Rinzwind placed some rude comment flags and a downgoat...
When noobs ask something but still think they know better than any expert answering them... Tsk tsk.
 
Stack Overflow appears to be stable again. We are keeping an eye on it.
 
3:14 PM
Aha. So what happened?
 
VTDed
 
3:26 PM
@ByteCommander another one: askubuntu.com/questions/827856/… (not about ubuntu, nor about a service provided by Canonical)
 
3:39 PM
welp, that was uneventful wireshark lab
our university firewall blocks everything so we got same info for all nslookup queries
 
@Serg .......
:(
that must have been boring
 
eh, at least we don't have to write a report for this one
what's interesting though is that windows caches dns queries, Linux doesn't . dnsmasq does but I'll have to ask a question where is that cache stored
at least I'm happy that in this class we do something close to what i enjoy
i.e. computer stuffs
 
next lesson would be to trick the firewall...
 
:D
 
```
➜ dart man dart
No manual entry for dart
See 'man 7 undocumented' for help when manual pages are not available.
➜ dart man 7 undocumented
No manual entry for undocumented in section 7
```
What the ....?
 
3:54 PM
they have no man pages shipped with it
try dart -h or dart --help
also why dart man dart ?
man dart is usually the way it's done
 
@Serg I use zsh. the first dart is my current working directory
 
4:12 PM
uuuuuuuuuuugh
how do I install a Vim color scheme, like for a language?
 
i think you save it into ~/.vim folder
 
@Serg and then? :$$$$
 
0
Q: Adding color scheme to Vim

RajeshwarI would like to add this color scheme to Vim any suggestions on how I could accomplish that ?

 
man, it's hard to install Remix succesfully but I GOT IT!
had to edit grub.cfg and stuff
standalone install
you have to manually copy remix files to new part of hdd then install grub
then adapt grub.cfg
 
what remix?
 
remix os
 
oh.
 
sorry
 
4:36 PM
i thought you were talking about some ubuntu remix out there
 
sry
brb
 
0
Q: concurrent curl could not resolve host

cwhsuI try to run cocurrent curl but it can easily report "Could not resolve host". To run curl parallel, I use "parallel". parallel :::: ./a.sh ./a.sh from api server % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Tota...

 
@grooveplex and then i dunno, because i only use basic color schemes that come with vim by default
 
5:03 PM
gosh is am getting tired. But i can't nap, not right now
 
5:24 PM
0
Q: How to create a shared folder between windows OS and ubuntu 14.04 installed on VmWare.?

user6858628I have windows 7 OS installed in my laptop. In Windows I installed VmWare Workstation 10.0.1 , in which i nstalled Ubuntu OS 14.04 . I want to create a common shared folder between Windows OS and Ubuntu, how can i do that? In setting for ubuntu OS in VMWare Workstation i have updaed the path fo...

 
6:17 PM
Anyone know if you can fake your MAC address from Ubuntu?
 
(Yes it's for Arch, but I imagine most commands are identical for Ubuntu.)
 
Okay cool need to reboot pc into Ubuntu
@NathanOsman I dont think 'ip' is a command on Ubuntu
 
nathan@nathan-desktop:~$ ip
Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }
       ip [ -force ] -batch filename
#worksforme :P
 
huh
that's so weird
 
It's in the iproute2 package.
 
6:20 PM
Ah so I need internet to do it?
 
You'll need that package installed.
 
That could be a small problem
Oh nvm
It's installed :D
 
which ip
...will tell you where it is.
There should be one in /bin.
 
@NathanOsman
I love you
 
6:30 PM
You should know, I just got past school admins computers XD
 
@NathanOsman :D
 
@NathanOsman My erm "mean" Dad decided to put a schedule time on my internet, and recently completely disabled it, he went to China for 7 days today, so I routed my PC to be the master owner of the router lmao
@NathanOsman Got any recommendations for Desktop Interfaces? ubuntu is nice but the icons are kinda messy
 
You can change the icon theme without changing desktop environments.
 
6:41 PM
I want the icons to behave like they do in Windows, a very linear grid
 
wb @KazWolfe
 
Hola Kaz! @KazWolfe
 
@DavidCole-GrammarPolice Oh, that. Yeah, that's a good question.
 
I wonder if @KazWolfe knows of anything.. Kaz I'm looking for a way to make icons grid-formation-locked, like Windows
 
o.o
right click on desktop.
There should be a Keep Aligned
 
6:45 PM
I have that checked
 
can't check rn because idiot school blocks SSH.
 
still doesnt work
 
Doesn't do what you think, @KazWolfe.
 
did you actually snap them to the grid?
 
The grid is too small.
 
6:45 PM
there should be some organize command or something
 
The grid should be the same size as the icons.
 
oh. er...
let me get home and on my linux box.
or at least to somewhere that allows SSH
 
That's whats happening currently
 
I think CCSM has a grid value thingy somewhere
on an aside:
how to scare anybody in your computer lab.
1. Open a console
2. Set to black background and green text
3. Open Python
4. Type at anything over 20 WPM
 
6:49 PM
when you can hit 70-80 in the Python environment, people will go get the lab supervisor
 
MATE's terminal cant change color
will gnome-terminal?
 
ok
I'm intsalling it
 
Hello all
Is this too broad or is it just me? askubuntu.com/questions/825262/…
 
@KazWolfe so what about that? just did it
@KazWolfe @NathanOsman @DavidCole-GrammarPolice who wants to volunteer to help me get my wifi working?
multiple = ok
ethernet-available=true
 
6:54 PM
i'm about to get into class soooooo..... sure!
 
ok.
ubuntu based (xubuntu base) modified GUI though
wifi does not work
doesnt work on ubuntu unity either
 
@ElderGeek hehe I edited that :3 But yeah no its broad
 
lspci?
 
lspci????
 
6:56 PM
yes. run lspci and give us output pls
 
ok
gah let me connect to this room fromthat computer
 
0
Q: Arrange Icons In Better Grid

David Cole - Grammar PoliceI've recently come to find all my desktop programs and icons thrown askew about the place, and while rearranging, I noticed that the grid system Ubuntu uses by default is (in my eyes) miserable. On Windows for example there is a large grid, and icons are far enough from each other to read, but ...

 
ok
connected from the hp
james@james-tablet:~$ lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (re
 
0
Q: Minimal Install of Ubuntu Server 14.04 using Oracle VM VirtualBox & Command Line Only

Michael S.I am a freshman computer science major, and I am trying to figure out how to build a minimal install of Ubuntu Server 14.04 using Oracle VM VirtualBox and command line only, on MAC OS X. The command line only part is very important. I have downloaded VirtualBox, but I don't know where to go from ...

another HW question
 
7
Q: How to get my Intel Wireless 3165 to work?

Edward van KuikI have installed Ubuntu 15.04 on my new Intel NUC However the wifi does not work. It complains (in dmesg) that the iwlwifi module was unable to load the firmware code because iwlwifi-3165-10.ucode could not be found. I've tried installing newer versions of iwlwifi (from backports), but that s...

@JamesTobin
 
7:03 PM
k...
@KazWolfe do I run the wireless info script first?
 
yep
actually first...
sudo modprobe iwlwifi
what's the output?
 
@KazWolfe
You'll be proud of me
 
WHY ALL THE PINGS ;-;
 
I was able to bypass my router, apparently sudo convinces a router to do anything, it's so strange
 
7:08 PM
sudo modprobe iwlwifi runs with no output
 
david@david-desktop:~$ ip link set dev eth0 up
RTNETLINK answers: Operation not permitted
david@david-desktop:~$ sudo ip link set dev eth0 up
[sudo] password for david:
david@david-desktop:~$
It's so WEIRD
Why would sudo convince the router?!?!?
 
because it's not convincing the router.
it's convincing your local system to bring up the interface.
 
RTNETLINK answers: Operation not permitted
that's my router
 
No... it's not.
 
Then something's wrong
 
7:09 PM
those are the kernel routing tables
 
@KazWolfe james@james-tablet:~$ uname -r
4.4.0-28-generic
 
Any way I could trick my router to bring up its GUI @KazWolfe ?
 
@KazWolfe if you dont reply in 1 min I'm getting fedora (jk)
lol
 
group assignment sorry
gimme a minute
 
7:18 PM
Okay so it seems the router will occasionally ping my computer, at which point the MAC address goes back to default, can I prevent this? @NathanOsman
 
@DavidCole-GrammarPolice No.
Welcome to ARP
@JamesTobin, try unblacklisting your wifi card with rfkill
 
@KazWolfe what, rfkill unblock all?
 
@DavidCole-GrammarPolice ARP routing will update the MAC periodically. You could add a static ARP route, but I don't know if you can move your box to a different nework.
@JamesTobin Sure.
2: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
also, off topic because ChaletOS is not ubuntu. :P
 
@KazWolfe it is xubuntu
modified xubuntu
 
> Description: ChaletOS 16.04.2 LTS
 
7:25 PM
Chalet OS is modified xubuntu
hardly even a distro
but anyway this is chat room :P
@KazWolfe ok I ran cmd yet its still soft blocked
GAH
you suck stackexchange
 
agin team project
erm... it looks like drivers are loaded
 
Damn intel card doesn't support changing MAC from Windows :I
 
it does
but not default
 
No
Wait
How duz I do it :o
 
no, it does. if you can change it in unix, you can change it in windows, but maybe not in Device Manager
 
7:37 PM
True, but idk how D:
 
I'm afraid I don't know how to do that.
I'm admittedly very dumb when it comes to configuring network adapters.
 
Okay
brb gonna try
 
user136984
Yay! Just got another "Famous Question" gold badge awarded! :D
 
hmm. @JamesTobin, I don't see anything out of the ordinary
 
7:40 PM
@KazWolfe work with a will or I'm going toward debian/fedora or their derivatives
 
except for that rfkill entry
k
8
Q: How to unblock something listed in rfkill?

Pipan87I think I may have found the cause of my problems with connecting to wifi in Ubuntu 11.10. I type this in Terminal: peter@peter-AO531h:~$ rfkill list all 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 1: acer-wireless: Wireless LAN Soft blocked: yes Hard blocked: no pe...

 
user136984
This article thinks that Linux is just software!
 
well they're technically right
 
user136984
@KazWolfe: No they're not, it's an Operating System. Software runs on an OS.
 
user136984
I haven't actually ready the article yet though.
 
7:47 PM
well, it's not hardware so it's still software
 
an operating system is software
 
it's not the right term, but it's still technically software.
 
user136984
I still don't like how they put it, most people are going to think that it's just some odd software to be installed on Windows or Mac (as some people I have found here worryingly think).
 
yeah, not the best terminology, but it is software.
 
user136984
Then so is Windows and Mac, but they would refer to them as OSs.
 
user136984
7:52 PM
I've never seen these news sites refer to them as software, only Linux.
 
Windows and Mac are both software too.
poorly-used terminology is not incorrect terminology
 
user136984
But it can mislead.
 
that's why poorly-used means :P
 
user136984
And they should at least be consistent with it otherwise it makes it sound like Linux is less of a proper OS than Windows or Mac.
 
user136984
I'm just saying I don't like how I see people treating the poor old penguin! :D
 
7:54 PM
anyway, where exactly does that article say that Linux is "software"?
 
well linux isn't a proper OS
It's just a kernel for the GNU operating system.
Hence why it should be GNU/Linux, or more properly
<every linux contributor ever>/GNU/Linux
/s
 
@KazWolfe should I get another distribution?
 
are you sure your wifi card is enabled?
 
works on other OS's
 
the network manager applet should have an "Enable WiFi" thing, I'd check it just in case because I see nothing else wrong.
 
7:57 PM
works on windows and android-x86
 
echo blacklist acer-wmi | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf and reboot.
 
I've done that but I need to wait 6 minuts for my copying to finish
 

« first day (2184 days earlier)      last day (1172 days later) »