« first day (1901 days earlier)      last day (1313 days later) » 
00:00 - 15:0015:00 - 00:00

12:00 AM
@RecycleBin: ESXi is a pain unless your hardware is on the HCL ;p
Realtek cards typically don't work even if you add the drivers
 
and it only likes specific disk controllers.
 
its an intel N7260
 
I'd go with KVM if you want a hypervisor, on fedora.
 
disk controller is an Intel ICH8
ethernet NIC is realtek i think
 
12:01 AM
yup
wait. wifi?
 
wifi is the intel
 
You don't run wifi on a hypervisor typically ;p
2
 
there may be a secondary sata controller too
ok
 
Basically
unless you're running server grade hardware or an all intel hardware stack (and I don't know how AMD faires) this is gonna be painful.
Well or you pick out hardware someone else has used before
apparently the NUCs with proper processors work well
 
its an X64 cpu
the only thing that isnt intel is the Ethernet, and the GPU though the i7 has integrated graphics
and obvioustly drives and stuff arent intel
it says ATA channel 2 and ATA channel 4 as well as intel ich8 so idk if there just attached to the intel or not
or if they have their own controller
USB controller is intel
 
12:18 AM
Ethernet's the big pain in the ass here
I've tried this
and of course random failures
those are just mean
 
hmm ok
It should ask if you want to skip it and set it up later really
instead it just says hit f11 to reboot
ram and PCI controller is intel
what are NUC's
 
!!/tell 24812505 wiki Next Unit of Computing
 
Next Unit of Computing (NUC) is a small form factor PC designed by Intel. Its first generation is based on the Sandy Bridge Celeron CPU. Its second generation CPU is based on the Ivy Bridge Core i3 and Core i5 processors. Its third generation is based on the Haswell architecture. Its motherboard measures 4 × 4 inches (10.16 × 10.16 cm). The barebone kits consist of the board, in a plastic case with a fan, an external power supply and VESA mounting plate. Intel does offer for sale just the NUC motherboards, which have a built-in CPU, although (as of 2013) the price of a NUC motherboard is very close...
 
ok thats out of the qustion until xmas
I have a desktop but need a good laptop that can run XP
I dont know if this one can
before I can try again I have to fix my BCD record
 
12:46 AM
I've been doing many tests to get a sense of what to expect throughout the day. Speeds have proven to be very consistent, although there is some variation in ping.
Again, not the fastest connection, but much better than DSL.
 
1:02 AM
@DragonLord That can't be better by much... surely not.
 
Yeah, DSL just sucked. We used to get a full 1 Mbps downstream on DSL. The performance has progressively degraded as time went on, likely due to degrading wiring and equipment (both on the premise and at the telco's), while the price has gone up to nearly $30.
The upstream bandwidth eventually became extremely low (144 Kbps, anyone?) and that made any sort of multitasking on the network unbearably slow.
By the time we turned off the DSL modem, downstream speeds dropped to as low as 700 Kbps.
Pretty much unusable for our purposes.
Inferior service at an excessive price.
This cable Internet service costs $15 a month, and that's a stable price.
We've had enough with DSL.
 
We still have POTS service, though.
 
I see
 
virginmedia is british no?
 
1:14 AM
either that or worldwide, not sure
 
I sort of inherited them as an ISP
(Basically in the 2 years I was in the UK, my ISP was acquired twice)
 
2 days ago, by DragonLord
user image
This was the last speed test I ran before we took the DSL modem offline.
 
@DragonLord That's not even worth $30, let alone an increase in $30. :/
 
the best ive got is 72 MBPS on certain days at certain times
download speed
 
@RecycleBin Yea, I got about 40-50Mb/s down on my VDSL. Can't wait for fiber in our area!
 
1:18 AM
upload speed is 6.12 roughly
 
2 days ago, by DragonLord
Verizon High Speed Internet is anything but "High Speed".
 
yeah
 
I'm a New Yorker. We don't have these options.
The only choices are Verizon or Time Warner Cable.
There's fibre where I live (Verizon Fios), but it's too expensive.
 
Midcontinent Communications is like the dakota area but its lke 90$
its rated number 1 though like everywhere
 
The natural answer was Time Warner Cable, which has a low-priced plan that, while slow, is still miles away from Verizon's crappy "High Speed" DSL service, proving to be 5x as fast under practical conditions.
 
1:23 AM
does it matter what state youre in? im not familar with this
 
@RecycleBin Different regions are served by different ISPs.
 
oh right
 
Even a 3.5 Mbps downlink is a godsend after having put up with slow and unreliable DSL service.
 
Wow, I get 100 flags/day now!
 
@CanadianLuke I've had 100 flags a day for a long time.
 
1:26 AM
@CanadianLuke FLAG ALL THE THINGS
 
I haven't noticed... Lol
 
@HackToHell A kitten under that wolf hat. Cute :-)
I happen to have that same hat and I wear it as my usual winter hat when things get really cold. It's surprisingly warm.
 
@HackToHell: One of these things is not like the other.
 
@JourneymanGeek HOW CAN YOU TELL ??!!!??
 
1:36 AM
@HackToHell Dogs shouldn't have little cat faces for chins. That's how.
 
1:52 AM
Apparently that's where our Service Desk works... Nice.
 
"Day 34. The natives have accepted me as one of their own. I will soon have dominion over these simple beasts and my foes will rue the day they denied me the gushyfood"
@MichaelFrank: That its all cg renderings concerns me.
 
@JourneymanGeek Yea slightly haha.
Google Maps shows it all as just construction...
 
(many indian BPOs are essentially sweatshops... )
 
 
1 hour later…
3:29 AM
Yea, well tell me a better way to test for a gas leak? , phhht don't use a lighter what a wimp.
 
...
 
and those eyebrows will grow back.
 
Bob
@tereško Nah, we have trouble here too :P
(different states have different dates for Labour Day)
 
soap water and a sprayer.
 
i tried soapy water, the only bubbles came out of my nose.
 
Bob
3:40 AM
@Psycogeek try turning the bottle 180 deg before spraying ;)
 
On the feed I see posts modified by 1 rep users. But when I look at the post, there's never any modifications. Why is that?
 
Bob
@Clearquestionwithexamples Can you link an example?
 
superuser.com/questions/957830/windows-10-green-checks that's present on the feed right now
Ohh I believe that means the answer was deleted
 
Bob
@Clearquestionwithexamples Yea, there's one deleted from an hour ago.
> Just refresh your desktop that seemed to work for me!
 
4:46 AM
@Bob: @Clearquestionwithexamples that was me ;p
 
5:04 AM
Oh look, google alerts me when there's a hangout scheduled while I'm in gmail
 
 
2 hours later…
6:36 AM
mountainduck.io this looks handy
 
hnng.
so annoyed at VBA right now
stupid macros
Do Until IsEmpty(Range(ActiveCell.Value, ActiveCell.Offset(5,0))) doesn't work :<
 
It's VBA, it's not supposed to work
It's supposed to annoy you. So it actually is working. Wow
 
I just want to check if the next 5 cells are empty :/
if so, stop the macro
but noooooo
 
For a simple check, If should suffice
And, IsEmpty doesn't do what you think it does
Or it doesn't do what I think it does...
 
6:47 AM
basically I'm just looping a macro over cells to replace chars
but there are several empty cells between
so I just want it to continue over those
it worked fine when there weren't any empty cells there
hm. gonna have to read up on Do Until
also, Excel reaaaaally loves scientific notation in places where I really don't want them
YES EXCEL, I REALLY WANTED ALL THE PHONE NUMBERS IN SCIENTIFIC NOTATION, THANKS
 
lol
of course
 
it's not a problem while the phone numbers are less than 15 digits
 
Bob
@Leathe yknow how you fix that? set the cell format to text. yes, really.
(which also makes sense because phone numbers aren't really numbers in hte programmer's sense of the word. they're IDs.)
@JourneymanGeek It sounds great, until you realise it's generally a bad idea to pretend remote storage is really local.
 
@Bob it still puts them in scientific notation :P
 
@Bob: People do much worse things.
 
Bob
7:02 AM
@Leathe No it doesn't...
 
but
it
does
it SHOULDN'T
 
Bob
You have to make sure it's set as text prior to entering the data.
 
yeah, but I'm editing data :P
 
Bob
So?
If your original data is incorrectly stored, go complain to whoever created it.
 
that's not really feasible right now :P
and it's not really that big of an issue anymore
was with a few earlier files
 
7:23 AM
Pro Tip: Start your input with ' to make it automatically format as text
 
@OliverSalzburg yeah I have a macro that does that
since I have to have a + infront of the phone numbers
 
7:50 AM
well, this code is ugly af, but it works
Do Until ActiveCell = "" And ActiveCell.Offset(1, 0) = "" And ActiveCell.Offset(2, 0) = "" And ActiveCell.Offset(3, 0) = "" And ActiveCell.Offset(4, 0) = "" And ActiveCell.Offset(5, 0) = "" And ActiveCell.Offset(6, 0) = "" And ActiveCell.Offset(7, 0) = "" And ActiveCell.Offset(8, 0) = "" And ActiveCell.Offset(9, 0) = "" And ActiveCell.Offset(10, 0) = ""
 
Bob
Detecting JVM PermGen support...
PermGen switch is supported. Setting to 384m
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=384m; support was removed in 8.0
 
8:36 AM
ooo
 
8:51 AM
hm. Might drop by my old workplace to pick up my avengers swag.
 
9:24 AM
unrelatedly
 
10:15 AM
Can someone tell me how to recover deleted keystore file from ubuntu?
few days before I accidentally deleted the android keystore file
 
I suppose you can try to recover it like any other deleted files and use a data recovery tool
but if it's been a few days you might've overwritten the data by now
 
I tried some of the tools but none of them seems to support .keystore format
Scalpel
Foremost
 
22
Q: I lost my .keystore file?

eportermdOk folks.. long story short, I was developing on a computer that I no longer have access to. I was able to retrieve the source code, but not the .keystore file used to sign and publish my application to the market (with several updates). Am I, and my poor users, out of luck if I ever want to upda...

According to the answers there, it's not really possible
:/
 
Are you saying keystore file will not be registered in system recovery like image or other files
I assume all the files should considered same for recovery system right?
 
Don't know
 
Bob
@Gowri Generally, the answer to "can I recover deleted files" is NO.
Unless you're very lucky and it's very recent with light usage, or you have some form of constant backup (e.g. shadow copies in Windows).
Sorry, but that's just about how it goes.
 
(and you realize to unmount the drive right after deletion)
to prevent overwriting
 
Bob
@Leathe Normally that comes with pulling the power, especially if it's a system drive.
Even initiating a shutdown can overwrite your data.
 
true
but unmount -l /home ;P
 
Bob
Anyway, several days and your chances of successful recovery hover somewhere between "zero" and "impossible".
 
10:34 AM
@Bob: That's really sad, I feel lost here. I spend few days on it.
 
wait no, it's sudo unmount -l /home
 
I think I need to move on with new app id
 
which isn't even recommended
 
Bob
@Gowri That might be the best path forward.
 
Seems like it
 
Bob
10:36 AM
You can still attempt recovery if you want, but it's often a waste of time.
 
@Leathe Yeah true, I don't wanna risk my other data
 
Bob
Depends how important this data is to you.
Simply, as soon as you delete a file the filesystem is free to write anything on top of the area that previously held that data. Whether that's happened or not depends on how much activity there has been since the deletion, how big the deleted file was, whether it was relatively close to the 'start' of the drive (or however else the FS picks where to write to, basically sums up to luck), etc.
 
@JourneymanGeek Hmm. This user is spamming superuser.com/users/511726/bareband918 and the avatar is bordeline NSFW.
 
killed.
 
Bob
@DavidPostill Now I'm curious what the avatar was :P
 
10:42 AM
@Sathya Thx
 
:)
 
@Bob Sorry I didn't screen grab. Basically a lady with a very well developed upper body and her top raised to just below ...
 
Bob
Ah.
 
who needs pictures when we have @DavidPostill :P
 
@DavidPostill @Bob: I missed that too ;p
 
10:54 AM
@JourneymanGeek - @Sathya was just too fast ;)
 
@DavidPostill: Oh, I was gaming at the time ;p
 
I wonder if the image is my browser cache? ;)
 
lol
I'm not that interested ;p
 
A C programmer is one who, when told not to run with scissors, responds "it should be 'don't trip with scissors.' I never trip."
 
 
1 hour later…
12:46 PM
@tereško: "OW MY SPLEEN"
 
@JourneymanGeek More spam this one contains rude words ... superuser.com/questions/989231/…
 
@DavidPostill: man... you guys don't give a dog enough time.
 
already gone.
 
Nuked the user. Users got the post like a pack of rabid russian squirrels.
 
ramhound did a vtc offtopic :/
 
12:59 PM
lol
 
wtf. Why is cloud.hartwig-at.de resulting in a redirect loop? The Apache config is driving me nuts :(
<VirtualHost *:80>
        Redirect / cloud.hartwig-at.de
</VirtualHost>
That is my first virtual host configuration
<VirtualHost *:80>
        ServerName cloud.hartwig-at.de
        Redirect / cloud.hartwig-at.de
</VirtualHost>
That is my second one
Now I would assume that all hosts that aren't cloud.hartwig-at.de get redirected to cloud.hartwig-at.de, which then redirects to HTTPS
 
Bob
@OliverSalzburg And what's your host for :443?
 
<VirtualHost *:443>
        ServerName cloud.hartwig-at.de
</VirtualHost>
That the next configuration after that
With all the SSL stuff as well, of course
 
Bob
shrug
 
And that part works great. cloud.hartwig-at.de has no problem. Only the HTTP redirects aren't working at all
Something is really fishy here :P
When I remove the default config, cloud.hartwig-at.de works. But that is only because I get send to the first found configuration, not because the name matches
Because when I rename the config so it appears later in the list, I get send to some customers site instead
Humm, I guess, because the first config doesn't have ServerName, Apache deduces it via IP reverse lookup. So that is implicitly the configuration for cloud.hartwig-at.de, as that is the name of the host
 
1:46 PM
@OliverSalzburg Why do you apache :O
 
@HackToHell Mainly because we serve a lot of PHP on that host and because that's how it has always been on that host
 
Oh well, time to switch perhaps ? ;p
 
We use nginx in other areas of our infrastructure
@HackToHell To gain what?
 
You could make it nginx everyhwere, instead of having to deal with a lone Apache install .
 
We use nginx for completely different use cases. We serve several PHP websites based on TYPO3 CMS, which, to my knowledge, is only supported on Apache. So, moving that to an unsupported infrastructure without any clear benefits would not be a smart decision IMHO
Also, I've never set up PHP with nginx, but I was told that it is a pain compared to Apache
 
1:52 PM
Oh no, php + nginx pretty much works out of the box.
Well if it's tied down to old code, i don't think anything can be done.
 
@HackToHell Good to hear a different opinion in that regard :)
I rarely ever touch any of the Apache configs on that host. We've been hosting the sites on that host for ages. All of our FairManager product stuff uses nginx and Node
Luckily, I don't have to deal with PHP anymore. I'm not a fan :P
And, well, I still use that host to serve critical web content like cloud.hartwig-at.de ;P
 
Where's the garlic and silver bullets? I think I've been bitten by a help vampire :/
 
Bob
@OliverSalzburg IIRC a fairly common setup is to have nginx serve as a reverse proxy and then use apache purely as an appserver.
So SSL termination, etc., happens at the nginx layer
 
0
A: Getting a log of all the assets copied from one folder to another in .txt format

DavidPostillI want to log name of all those copied assets in a .txt file. This .txt file should be saved in the form of "currentDate.txt". Use the robocopy /log:<LogFile> option. You might also want to use the /tee option Writes the status output to the console window, as well as to the log file. E...

 
@DavidPostill: 0_0
I suppose you mean the comments ;p
 
2:07 PM
GRRRRRRRRRRRRRRRRRRRRRRRRR.... fucking god damn companies that have software license fees but have a MANUAL system for processing orders... and of COUUUUUUUUUUUURSE whenever you need the software you need it NOW and they're offline for another 12+ hours. ALWAYS. ALWAYS.
 
@JourneymanGeek Yes. I think I've managed to ward him off ;)
 
I hate this stupid shit. How hard can it be to automatically generate a license key?! Jesus
 
o0 Why do you need one so urgently
 
because I have to do some magic operations on a bunch of PDF files and images
 
Bob
@HackToHell "I need to do X. Oh hey Y program will do it."
Do you want to wait in that situation?
@allquixotic Sounds like pdftk/imagemagick stuff
 
2:08 PM
have to do it for work and then get TO work
@Bob not flexible enough that I could see
 
Bob
:\
Can you be more specific? Or is this sensitive?
<== currently fighting jira
 
lol
@Bob: I emphatise.
 
argh I cannot make an OR gate
 
Bob
@JourneymanGeek Ha. I'm trying to get this JIRA Agile stuff to do... something remotely sensical. It refuses, of course.
And of course once you've done something there's no going back.
 
Of course.
 
Bob
2:10 PM
Because humans never make mistakes.
 
anyway, feel free to nix my ranty messages, I'm not special because I've been around a while
 
Bob
So now I'm deleting the board and rolling back server-time to redo everything.
:S
 
@allquixotic: ranting is fine
 
Bob
@allquixotic I'm ranting right now! :P
 
If its sensitive then yeah, I can make it go away ;p
 
2:11 PM
@Bob :D
nah not sensitive
 
Bob
I currently have a server that thinks it's the 16th of September.
 
@Bob Yeah, that's what we do with our Node stuff. But, as said before, that wouldn't give us any benefit with our existing setup
 
(hey, what's the point of being a mod if you can't use the powers for evil use those powers for good)
 
Just changing stuff for the sake of changing it is not a smart business move ;P
 
google drive wont embed my images
WHY !!!!!!!!
 
2:11 PM
i think you had it right before the strikethrough
 
Bob
root@metis:~# timedatectl set-time '2015-09-15 14:00:00'
root@metis:~# timedatectl set-time '2015-09-16 14:00:00'
root@metis:~# timedatectl set-time '2015-09-16 16:00:00'
root@metis:~# timedatectl set-time '2015-09-19 20:00:00'
root@metis:~# timedatectl set-time '2015-09-16 20:00:00'
root@metis:~# timedatectl set-time '2015-09-18 20:00:00'
root@metis:~# timedatectl set-time '2015-09-19 20:00:00'
root@metis:~# timedatectl set-time '2015-09-21 20:00:00'
root@metis:~# timedatectl set-time '2015-09-22 20:00:00'
This has been my life for the last 5 hours.
 
Dogs are never evil.
I mean look at that face <-----
 
wolves are
 
links must be crap
 
naw
Wolves are actually lazy gits with poor PR
 
2:14 PM
well that was unexpected
Foxit's trial software will willingly uninstall the trial expiration data from the registry or whatever with a checkbox in the uninstaller, so you can reinstall it and get another 30 day trial.... !!meme okay
and the trial is fully functional with no stupid backgrounds or anything
 
Bob
When I look at a SU or SO Q&A I see useful answers.
 
oh, foxit.
Used to be my PDF software of choice.
 
Bob
When I look at an Atlassian Q&A I see a massive list of previous times someone's asked the question, with zero answers and no official response.
ugh.
 
(went to tracker software's pdf xchange viewer, then sumatra)
 
Anyone here uses Firefox on Linux? This is driving me crazy.
0
Q: Firefox tries to open application/octet-stream with gedit

That Brazilian GuyI'm using Firefox 41.0.1 on Fedora 22. When I click a link and the response headers contains the application/octet-stream mime type, Firefox offers me to open the file using gedit, stating it's the default application. If I download the file (in this case, a PNG image) and double-click on it...

 
2:18 PM
@Bob: clearly the system is flawd somewhere
@ThatBrazilianGuy on windows?
oh
I have a fedora box too
 
also, shouldn't Firefox and Foxit be @Bob's favorite software?
 
Bob
@ThatBrazilianGuy You need to ask a question in your question :P
What do you want it to do?
Always open with <specific program>? Always open with <default program>?
 
@allquixotic: I did a fresh install on 2 of my boxes. I basically only throw 6-7 extra bits of software on em now.
 
Bob
>

Sprint:
Sprint 1, Sprint 2, Sprint 1, Sprint 1
urk.
>

Future Sprint:
Sprint 1

Completed Sprints:
Sprint 1 ended 23/Sep/15
Sprint 2 ended 30/Sep/15
Sprint 1 ended 23/Sep/15
ow.
 
@JourneymanGeek my Add/Remove Programs only gets to the "Ba"s in the list of software with a maximized window :D
I must have hundreds of programs
 
2:20 PM
@allquixotic: oh these boxes are 'disposable'
my gaming box has a load
these are essentially the bare essentials.
Firefox (no chrome since I don't need it, and its horrible about keeping old update downloads) 2 media players (cccp and VLC), foobar2K (optional) paint.net, sumatrapdf, putty, sublime text, 7zip and cyberduck
 
I'd like chrome
but its a space hog
also, windows 10 seems ok on the r61
its certainly snappier than my dad's old laptop (of the same specs, almost)
 
I noticed this behaviour when I was trying to open a PNG image link on a GitLab site. The server replies with `"Content-Disposition:"inline; filename="logo.png"` and `Content-Type:"application/octet-stream"`.

I want it to either display the image on the browser, or offer me to open it on the system default image viewer.
I will copy the above paragraph to the question.
 
@ThatBrazilianGuy: got a link so we can science it?
Assuming its globally accessible
 
Bob
> 119.24 MB (06.32%) -- window(https://www.facebook.com/messages/conversation-xxxxxxxxxx)
│ │ │ │ ├───73.72 MB (03.90%) -- js-compartment(https://www.facebook.com/messages/)
 
2:28 PM
@JourneymanGeek Try entropymine.com/jason/testbed/mime and click on "application/octet-stream [D] (data looks like GIF file)" in the "file.gif" column.
What does the (fire)fox say? ;P
 
it tries to download it in windows
 
But does it asks if you want to either save or open in notepad?
Or does it just show the file save dialog?
 
i.stack.imgur.com/jEpIl.gif (waaait. That may be a huge gif)
 
Bob
@JourneymanGeek 400kB
I've seen 92MB from imgur
 
imgur.com/71vJENc Windows 7, Firefox 41
 
2:37 PM
@JourneymanGeek Yeah, I want that but on Linux
 
Bob
/usr/share/applications/mimeapps.list
in fact, search for all occurrences of mimeapps.list
there may be many
 
@ThatBrazilianGuy: just a moment
 
~/.config/mimeapps.list
~/.local/share/applications/mimeapps.list.old ;P
/usr/share/gdm/greeter/applications/mimeapps.list
 
Bob
Check all of them.
 
AHA!
$ cat ~/.config/mimeapps.list

[Added Associations]
application/octet-stream=org.gnome.gedit.desktop;
application/javascript=org.gnome.gedit.desktop;
application/x-wine-extension-vbs=org.gnome.gedit.desktop;
 
2:47 PM
 
After ignoring the first line:
 
@ThatBrazilianGuy: I'm on 39.03 for some reason tho
 
Much better now
 
Bob
0
A: Firefox tries to open application/octet-stream with gedit

Bob I have also removed the ~/.local/share/applications/mimeapps.list file and the issue still persists. There is likely another mimeapps.list elsewhere on the system. You can go through the list here, or search through your system with locate mimeapps.list or find / mimeapps.list. Check for any...

:P
 
@ThatBrazilianGuy: If you need the proper behaviour in fedora ^
amusingly that's a box I'm remoted into
 
00:00 - 15:0015:00 - 00:00

« first day (1901 days earlier)      last day (1313 days later) »