« first day (1458 days earlier)      last day (1929 days later) » 

slm
12:00 AM
8-)
We also show you how to contain it for testing purposes
 
@slm should we merge that one with this?
21
Q: Where is the fork() on the fork bomb :(){ :|: & };:?

mavillanWarning: Running this command in most shells will result in a broken system that will need a forced shutdown to fix I understand the recursive function :(){ :|: & };: and what it does. But I don't know where is the fork system call. I'm not sure, but I suspect in the pipe |.

 
slm
9
Q: Difference between executing multiple commands with && and ;

Zach LattaWhat's the difference between executing multiple commands with && and ;? Examples: echo "Hi\!" && echo "How are you?" and echo "Hi\!"; echo "How are you?"

 
Is it limited by setting the limits in /etc/security/limits.conf file? I want to answer without googling :)
 
slm
@terdon - nah 2 different Q's
 
@slm Oh, yeah, we went over that once already.
 
slm
12:03 AM
twice now 8-)
 
blush
 
The worst Q's are pattern matching.
What a waste. It's an answer that will probably only help the user asking it... except in certain context.
 
@TylerMaginnis Yeah, they're very hard to generalize.
But, they do show some general principles. I've seen people take my answers and apply them elsewhere.
 
I use awk, sed, grep... head and tail... but I try mostly to use sed.
 
I use perl for sed usually. Unless it's very short. I;ve been meaning to really learn sed but I have never really needed to. Perl can do anything that sed does.
 
12:09 AM
My favorite grep is... $> grep -of \{0,0\} $match\{0,20\}
Matches chars before and after pattern
** grep -o
I get my hands dirty with systems that do not have perl.
POST compatibility through using only standard she'll utils.
Posix**
 
@terdon I use it generally from your canonical question/answer :)
 
slm
@TylerMaginnis That's partially true. They need to be written as if you're teaching someone how you went about doing it. Also explaining the method of how it works is extremely useful. I've searched for things and many times have found those same Q's and the A's have been very helpful in understanding something that had nothing to do with the specific Q.
 
@Ramesh Ah, cool, I'm glad that's useful.
 
slm
@TylerMaginnis terdon and I have tried to take those Q's too on several occasions and provide as many methods as we can conceive of. It's basically a programmers game of tying 1 hand behind your back and trying to do X
 
I made a monstrosity of regular expressions a few days ago...
 
12:13 AM
Will calculating subnet mask/gateway be a good topic for our site?
 
30 $env variables parsed by 4 to 16 pipes of regexp.
 
slm
@TylerMaginnis You should also fancy yourself a purveyor of many paths to a single solution.
 
the theory was that if I um.. do things in little steps... it'll be more accurate.
 
I feel if I understand the basics more, I can understand the network setting up in KVM and things.
 
@Ramesh
 
12:14 AM
Actually, is there a collective term for all these things? ;,&,>, >>, | etc. I'd call && and || operators but what of the others?
 
@Ramesh faikvm.com/?g=machines/vmlist this is an implementation of our "FaiKVM"
It's interesting from a feature-perspective. Enables Fully-Automatic-Install KVMs.
 
slm
I was trying to find the term I saw them called the other night. There are 5 that are considered X. Terminators? It was on the bashwiki (one of them)
 
Kinda like Docker in that you can build recipes.
 
slm
I think it has SC's hand on it too
@TylerMaginnis what's this referring to?
 
KVM and networking @Ramesh.
 
slm
12:15 AM
be sure to reply to a specific line in chat, so others can hover and know what you're referring to.
 
@slm The implementation of FaiKVM is a software project based on KVM that is deprecated because it is not something that the maintainers have time to work on anymore... But networking is a part of it, as well.
 
slm
KVM doesn't necessarily have recipes, you configure things in an .xml file or via virsh or virt-manager.
 
@TylerMaginnis Thanks. I saw the Iptables rules construct site from one of your comments too. It's good.
However, I want to understand the basics first :)
 
@slm @Ramesh linuxpmi.org/trac/wiki/FaiKvm This is the page for the FaiKvm. It's pretty tricky to track down a DVD-iso of it, but I'm sure it's out there somewhere still.
 
I sort of know things but do not know like know things.
 
12:17 AM
FaiKvm is not the same as KVM. It's extended features to deploy KVMs on-the-fly.
So it's a whole "distribution" oriented method to extend features of KVM.
I'm still waiting on IPTables-Next.
^^ By that I mean IPv6 implementation of IPTables by netfilter team to be really stable.
 
@slm, @terdon is sub net mask and networking concepts on a broader perspective be on topic here?
 
slm
I think they can be
 
Well, if it is a question about the implementation of the Linux Network Stack, I think so.
I have been pretty deep into the stack used by the Open-Source Provider R&S suite, StarOS.
 
slm
as long as you're showing examples using ip dig etc. then it's perfectly fine
 
@slm, thanks. I will try to frame it in a decent understandable Q/A format so that it will be useful.
 
slm
12:23 AM
@TylerMaginnis not familiar with those. What are they?
 
@slm StarOS implements Quagga, the Open-Source implementation that includes Routing Protocols.
Internet Service Providers use it. Particularly smaller, backwater ones that operate in the country. They run it on their tower-boxes.
It is syntactically, 90% similar to Cisco IOS.
 
slm
ah
 
I'm not even sure what the state of the project is these days.
I was just as surprised as you when I found it.
 
slm
@terdon - the bash cheatsheet is where I saw these mentioned
 
@slm I found out they're all operators of one sort or another.
 
slm
12:33 AM
@terdon - yeah but I seem to remember an actual name for 5 of them
 
slm
; | & were definitely called something
I think they're part of the subshells
or sub commands
 
This is from the bash manual:
> A list is a sequence of one or more pipelines separated by one of the operators ‘;’, ‘&’, ‘&&’, or ‘||’, and optionally terminated by one of ‘;’, ‘&’, or a newline.
 
slm
since you're running in a different process when you do cmd1 & cmd2 or cmd1 | cmd2
 
@slm:
> control operator
A token that performs a control function. It is a newline or one of the following: ‘||’, ‘&&’, ‘&’, ‘;’, ‘;;’, ‘|’, ‘|&’, ‘(’, or ‘)’.
 
slm
12:39 AM
ah it's in the bash man page, forgot to look in there 8-)
in the definitions section
good call
@terdon
and yet more home work
0
Q: How to match a number in one file to a name in another file?

ShaneOkay, I hope this is the right place to ask. I have 2 files. The first file has 4 fields: class CRN #, Instructor ID #, Class Section #, Number of Students. Example.) 0002 T00005 006 15 0004 T00004 012 26 . . etc The second file has 6 fields (as best as I can tell): Instructo...

 
12:53 AM
@slm ahhh.... September...
 
Seriously?
Must you do that in a shell script? You could do that in about 5 lines of a real programming language such as Python. — Greg Hewgill 5 mins ago
He should know better. 5 lines for that is ridiculously long.
Well, not if it's also doing the HTML I guess.
Argh, never mind, I completely misread the question. I thought he just wanted this:
$ echo "XSAMPLE" | fold -w 1
X
S
A
M
P
L
E
 
slm
WTF, this is getting ridiculous
@jasonwryan - I concede you were right 8-). Best not to help them.......
 
I'm not sure what to do with this one:
1
Q: How to write this pseudocode where condition

MasiThis question is extension of this question about listing questions of directories. I get a problem that I need to understand the original section of the text. Current output where you see the second question does not make sense. It was included in the subsection Takayasu arteritis in the ...

He has tried. And is playing by the rules. I don't think he's a vampire as such.
 
slm
@terdon tex.se.com?
 
@slm Nah, it's a parsing problem, his tex is fine.
 
slm
1:02 AM
k
 
I'll answer. It's just that what started as a simple little bash thing is getting more and more complex.
 
slm
yeah I hate when that happens. That's how every perl program I've ever written starts out...as a Bash script 8-)
 
And guess what I've decided to do as an answer :)
I think this type of Q is still OK. Borderline but OK:
2
Q: To write this Pseudocode with Regex

MasiI am doing a Makefile which I run regularly by Crontab every day at 0230 crontab -e; 30 2 * * * /bin/thePseudocode Python-like Pseudocode directories = ["Cardiology", "Rheumatology", "Surgery"] for directory in directories files = directory.files(); % not sure if such a parameter exists ...

He put a lot of effort into it, not just "CODEZ NOW".
 
slm
yeah those are ppl you wanna help
 
I used to do a dozen other people's jobs randomly for an hour a month in exchange for $75.00/hr.
((75*12))=$900
 
1:07 AM
Great. Now I feel like an idiot. @slm do you realize that he was getting paid for this kind of shit?
 
Sometimes I look back on that and I think how inappropriate it was to be running around other people's enterprises.
They'd give me direct RDP, SSH, etc.
 
slm
@terdon the pseudo guy, or tyler?
 
Tyler.
2 mins ago, by Tyler Maginnis
I used to do a dozen other people's jobs randomly for an hour a month in exchange for $75.00/hr.
 
It's tricky to find good clients anymore. I might have a gig on the horizon, but it's just reshipping parcels from a factory in Thailand, because I have a U.S. address, and I know the guy well enough to where I know it's not a scam.
Part of me is hoping that by contributing this site, I will eventually receive a request to solve problems in exchange for currency, but I am sure that rarely happens, if at all.
 
@TylerMaginnis I got headhunted by google based on my account here.
So you never know.
Goes to show how much big brother really knows. I'm a biologist FFS!
 
1:12 AM
Just one more place to showcase what you can do is never really a bad thing.
My favorite subject in biology is comparative morphology.
 
slm
Yeah I wouldn't do those types of jobs if I were you. Better to build yourself an actual reputation as a solid community member and provide solid answers. Employers will snap you up if you're qualified and have a proven track record.
 
there you go, answered a question on AU :(
 
slm
Just be sure to vent in here and not so much on the comments of newbies that are asking Q's.
 
I couldn't resist seeing everyone using the wrong approach
 
slm
which Q?
 
1:15 AM
@slm if I want to verbally berate people, SDF's, "pcom," mode has a couple 14 year olds that talk some serious smack to me, and I bring it right back to them.
 
slm
I'm stuck trying to decide if I want to help george w/ another 1 sentence Q.
 
one in the hot list
 
slm
@Braiam - nice
 
guy want to imitate nautilus unmount/safety eject behavior yet all the answers needs root permissions
 
slm
On a positive note, the site should be breaking 50k Q's sometime this week.
that's nice milestone
 
1:20 AM
Speaking of milestones, you should be hitting 100k sometime this week too. Or shortly thereafter, yay!
 
slm
yeah...looking forward to that. Curious to see what SE sends you if anything.
 
@slm lets hope nothing breaks when we reach 50k Q's
 
slm
@Braiam - that's pretty funny. Notice our buddy there too: meta.stackoverflow.com/users/128967/naftuli-tzvi-kay
 
2:18 AM
Phew, OK, done.
0
Q: What do all these symbols (|, ||, &, &&, >, >>, etc) mean after shell commands?

terdonI often see tutorials online that connect various commands with different symbols. For example: command1 | command 2 command1 & command2 command1 || command2 command1 && command2 Others seem to be connecting commands to files: command1 > file1 command1 >> file1 What are these things...

 
slm
you want to run all those others into this one as dups now?
@terdon^^^
 
Maybe, what do you guys think?
I'd let it simmer for a while, get some votes on it, just in case I'm missing anything obvious.
If everyone agrees, then yes, I think that one collects pretty much everything all those others were asking.
 
2:37 AM
(ow ow ow) the new display managers always cause me great anxiety. This is easier to use. Undecorated windows.
Hotkey-controlled window control. I don't even need a mouse.
^ mistakes like that in my grammar tell me it's time to go to bed.
tldp.org/LDP/abs/html Have any of you run across this before?
 
slm
@TylerMaginnis yeah, all the references to S.C. in it are the #3 user here.
 
I notice that a lot of users I recognize from other spaces Online aggregate here.
I spend a lot of time on LWN.Net, as well. It's my morning coffee companion reader.
0
Q: Ubuntu Software Center Problems

user261233had Ubuntu 12.04 LTS running completely well on my x-64 system. Last week I upgraded my OS to 14.04 LTS. Since then my Ubuntu Software Center is not running. Even I am not able to download packages from the terminal. Can anyone help me out with that?

facepalm why is anyone running 12.04 LTS? ohhh, it's because Ubuntu incentives deprecated versions, because they "support" binary blob drivers from graphics vendors.
so you get your old'buntu with an old'kernel. but when you dist-upgrade... oooooooh
I wonder why so many things break when you go from 12.04 to 14.04
^^ mocking the obvious. I'm telling him to reinstall.
 
3:11 AM
0
A: How can I get difference ratio using “diff” or other command?

Tyler MaginnisHm... I actually want to help you today. #!/bin/bash # File 1 contains 1,2,3,4,5 on new lines # File 2 contains 1,2,3,4,5,6,7,8,9,10 on new lines. diff -y 1 2 > diff # Compare differentials side-by-side sed 's/[ ]/d' diff > MATCHES # Print lines to file which do not contain ">" prefix. sed '/[>]...

ahahahaha, @slm
@slm
Everything is a file, right?
is a Ratio a thing? Like a "0.40"?
Am I just dumb at math?
 
 
2 hours later…
5:28 AM
@terdon Sorry about that. I have had that quite a few times, seeing that a new answer got posted before I was finished with something too similar to post. Strange thing is that that upvote only got me +3 points, maybe because I was over 200 rep gain?
 
 
5 hours later…
10:09 AM
@Anthon yup
 
 
1 hour later…
slm
11:10 AM
@Anthon yup welcome to the diminishing returns @ 200. See if you can get to 300 now 8-) in a day. You have to do it with all accepts after 200
@jasonwryan - asking in the AU chatroom if they want this Q migrated.
-1
Q: Ubuntu Software Center Problems

user261233had Ubuntu 12.04 LTS running completely well on my x-64 system. Last week I upgraded my OS to 14.04 LTS. Since then my Ubuntu Software Center is not running. Even I am not able to download packages from the terminal. Can anyone help me out with that?

 
@slm The "problem" maybe went away as one of the questions I answered got moved to SO getting my points for the day below 197
 
@slm don't, the question as it poses is unclear
 
slm
11:48 AM
@Braiam Yeah I didn't want to since it's a not overly well written Q, but I asked them anyway.
 
 
2 hours later…
slm
1:59 PM
everyone else get kicked out of the site?
 
nope
 
slm
weird one system I cannot login to site, other is fine
 
2:52 PM
@slm Why do you say that?
 
slm
@FaheemMitha - my one browser is unable to login, seems to be a caching issue.
@FaheemMitha - had to clear all my cookie data from the beginning of time to get back in
I use verisignlab's pip openid. Not sure if that was the issue, oh well.
 
0
A: Propagate multi touch events to applications

Tyler MaginnisLWN.Net Xinput Multi-Touch History This is the history of the xorg-multitouch extension. It touches on gestural programming, and references the uTouch Gestural Programming project. These two informative articles are good source material, and should give you the momentum you need to get started....

Acceptable Answer or not?
 
@TylerMaginnis do I need to click the links for the howto?
 
Those aren't how-tos.
Those are 10~ page historical documents on the state of the art for what the user is asking which will give clarity I cannot.
 
slm
@TylerMaginnis - it's a good start, is there a command that you can provide him that will let him see the events as they're seen by UDEV or the kernel? That sounds like what he's really after.
 
3:05 PM
do you explain why?
 
Hmmm. I think I might have that up my sleeve. Editing now.
 
slm
@TylerMaginnis - as it stands this is borderline a link A
If you look at Gilles, Stephanes, or Mine or Terdon or any of the other front page users' answer you'll see fairly long form "tutorials" on a subject matter. We generally strive to have this type of content here.
It's def. not for the faint of heart but we try and discourage 1-2 sentence A'ers.
or links. There are times when these are all that's relevant, but on a Q like that there's a lot of room to provide guidance to this user, since they don't know what directions to go, you're essentially the tour guide, showing him the path as you'd take as the developer
 
@TylerMaginnis a good answer to that question could be: no, standard linux libraries do not have multitouch event capabilities, because X and Y reason, for that you need foo library, but such library do not have Java equivalents because bar
note: I have no idea of what was said above
 
Yay! I just replaced Chris Down as the 4th top rep user today! Watch out @slm you're next! Right after I plow over Stéphane.
 
slm
3:10 PM
Yes Braiam's point is an excellent one too. Often times ppl don't have the foggiest idea how to approach a solution so they're throwing many things at the wall, some relevant some not, so you can negate things that they've listed and explain why w/ references as an A and then provide the path but not necessarily spell the full solution out tooo.
 
I revised it.
 
@Ramesh Yup. Done.
 
slm
ah terdon beat me to it, @Ramesh - yeah that's crap
 
@terdon Thanks.
 
man, I'm not even in the quarters page... only in the yearly
 
3:12 PM
@terdon, you use Ubuntu 14.04 right?
 
@Ramesh nope
 
slm
@Braiam get on the A horse 8-)
 
@Ramesh Huh? No!
 
I think only Gilles does
 
I have one in a VM though.
 
slm
3:12 PM
gilles has overtaken me in every category except year
I'm hanging on by a thread
 
@Braiam I like your reccomendation, and added a paragraph to describe how I will deliver.
 
How do you connect to the network in the VM?
 
slm
@terdon I"ve been so busy with learning new stuff myself that my time has dwindled here.
@terdon - but I'll have a whole new source of material to dump soon enough 8-)
 
@Ramesh Bridged mode, I'm using VirtualBox and it worked pretty much out of the box.
 
slm
@Braiam what's this in response to?
 
3:15 PM
@slm my previous line "nope"
 
@terdon ok. I should have phrased the question better. Is your host machine's connection wireless or wired?
 
slm
ok back to learning more about ruby, solider on
 
Hard to drill down on an answer when there are 4 type of commands and 6ish commands per type that could be useful, depending on what dist someone is using.
 
@Ramesh wireless.
 
@terdon Thanks. Do you face any connectivity issue with Ubuntu? I mean, getting disconnected every half an hour or so?
 
3:19 PM
No, but I don't really use it either. I only have it to answer questions on AU.
What you describe is a classic issue though. It is usually fixed by using a different driver for your card.
 
@Ramesh my Debian unstable has been having iface connectivity issues... It drops, hard. Are you talking about Wireless or Wired?
@terdon
is right. it's usually the driver.
 
I tried that. But unfortunately it did not work.
I had posted it in AU as well.
@TylerMaginnis It's wireless.
 
$> dmesg | grep wlan
Find out if you have a 'RealTek' 'BroadCom' 'Atheros' Chipset
To find out why this is happening, generally if you can correlate your chipset to what driver you are using, you can find out what exactly is going wrong.
 
@Ramesh add the output of ` lspci -nn | grep 0280` to your question. What is the VM using as a wireless device?
 
@terdon It is a host machine not on VM.
 
3:24 PM
ohh. I misunderstood.
 
@Ramesh please, do not crosspost
 
Will the connectivity issue occur because I configured the network using /etc/network/interfaces rather than using network manager?
@Braiam I have not cross posted.
And I know the rules of SE.
 
@Ramesh ah, ok, I read that as "I posted here and in AU as well"
btw, when you get disconnected, add the output of dmesg | tail
 
@Braiam curse my poor english skills :)
@Braiam sure. I will just wait for it to get disconnected now.
 
@Ramesh OK, but the hardware details will be needed to answer your question.
 
3:30 PM
Should I recommend a hexeditor?
0
Q: Add codes to vmlinuz

mohammadWhen i use vi editor to add some codes to /vmlinuz I see it in a bad format.It seems a binary file. I am going to improve security and add extra steps for checking password. How can i edit vmlinuz?

 
@terdon added the details to the question.
 
Or better a disassembler and assembler?
:-)
 
Um. I would recompile and rebuild vmlinuz.
 
@TylerMaginnis exactly my point
@Anthon those questions reeks to XY problem
 
Sounds like getting the old hands too dirty . One he away from never rebooting again.
Hex
 
3:34 PM
@terdon, should I use inxi command to get the hardware details or lscpu is fine?
 
ok, is official, I hate my country educational system, from top to bottom
 
@Ramesh May as well show both. The inxi will show the driver you're using and the name of the card but lspci will show the code (e.g. 14e4:4353).
 
or just lspci -d 8086:008a -k
 
Replace 8086:008a with your card's ID.
Or just use:
lspci -d $(lspci -nn | grep 0280 | grep -oP '\[\K[^]]*:[^]]*') -k
 
@terdon pasted the output.
 
4:32 PM
@Ramesh What's wrong with that one? We've never decided that software requests are off topic here.
 
0
A: Efficient todo / project / task manager application

Tyler MaginnisTracWiki: Project Management System TracWiki is a light-weight project management wiki-portal which runs over HTTP ports. Install Guide Light-Weight Easy Setup Modular (Multiple Projects) Hot-Copy Backups On-The-Fly Non-Invasive (Standard Wiki Formatting, similar to StackExchange Markup) Ti...

I'm surprised nobody suggested a Lightweight Wiki Platform, like Trac, for this requirement.
 
@terdon Actually, it's because it would be primarily opinion based.
 
"once you go tracD, you never go back"
 
@terdon Agree with @Ramesh, opinion based
 
Hmm, yes. I guess it is at that.
 
4:39 PM
@slm I see. Which caused confusion, I guess. Unlikely everyone would have gone away at once, though.
 
slm
@Ramesh Agreed, VtC.
 
4:58 PM
Ever consider recursively scraping the forum for opinion based questions?
Nevermind. Harder than it sounds to identify keys.
 
@TylerMaginnis yes, there are people that does
yep, a simple question in AU yet 3 wrong* answers
 
5:18 PM
@Braiam 3? All 4 look wrong to me.
 
@Patrick note the "*"
I know muru's A has something fishy but I don't know what
 
There's no footnote. I do not know what '*' means
 
Cool, I got a perfect sequence of rep:
Almost perfect anyway.
 
@Braiam It, and all the others claim load is the # of procs waiting on CPU. Load is the number of procs waiting on hardware resources, not just CPU.
you can't just say "if load > X * nCPU then your system is overloaded"
 
slm
I think they're confusing the ready to run queue w/ load, which is where the load # comes from.
 
5:24 PM
@Patrick yep, that was it
 
@terdon No "+15 accepted" :-)
 
slm
boo
 
boo indeed :(
 
slm
So now see how many +15's you can get before 8pm EDT.
I think the best I've ever been able to do is 9
maybe 10, I forget
 
5:50 PM
@Patrick Happy now? That totally screwed up the nice ordering :P
 
@terdon If I upvote, you won't get those points now?
 
@Ramesh Yup. No more rep today except for bounties and accepts.
 
@terdon ok, I will wait till tomorrow then :)
 
Thanks :)
 
6:01 PM
Many actually
Try looking for "john" on Stack Overflow for example.
 
Wow page 5 has all johns with 0 rep.
oops, that was weekly.
Sorry all johns.
 
6:28 PM
@Braiam Did you spend much time in it?
And what is the context?
@derobert ever considered going to a ComicCon?
 
slm
@terdon gotta have at least 1 accept 8-)
@ramesh - Yeah you can change your name too, as goldilocks found out when they were doing the hats thing
 
6:43 PM
@slm should probably change it to stephane, the man who found shellshock :)
 
slm
I don't think he cares for bragging rights too much.
 
Note that you can only change your name once per month (if you change your name, after a few minutes, your choice becomes locked for 30 days)
 
I am not a fan of changing name though. I have made the U & L user account as my home page in my LinkedIn profile.
 
slm
@Gilles yes that was the oops that goldilocks made
 
@Ramesh it doesn't matter, it just take your ID
 
7:04 PM
Would anybody be able to help me out with a regex in java
 
@ryekayo would you just write your question and then we can decide?
 
Well its not exactly Unix/Linux related, it will be migrating to the LINUX after I am done though
the project willl that is
 
slm
@ryekayo If it's java put it on SO
If there is anything Linux related to it you can ask that as a separate Q later on and link the 2 so they're shown to be related.
 
ok
 
8:12 PM
@terdon I edited your answer. I'm not sure if classifying ; & && || | according to their syntactic category is the right thing here, maybe it should be the sequential operators ; && || vs the parallel ones & | ?
 
@Gilles Yes, thanks. I think that's a clear improvement. I like the list terminators being separate from the rest for example.
I don't think that ! is a control operator though. At least, not according to the bash manual.
 
@terdon technically, it's a reserved word, but I don't think the distinction matters here
 
Yeah, I didn't really want to go into fine details. I was aiming for a cheat sheet.
 
9:08 PM
I missed the starting gun. Are we submitting questions that might be duplicates of the new “What are the shell's control and redirection operators?” canonical question? Here’s one that popped up just a few days ago: When is 'if' not necessary?
 
slm
@G-Man - no starting gun was fired. Use the normal methods of flagging it as a potential duplicate and then let it run it's course through the review queue. You can always mention it here too to help get more eyeballs on it as well.
 
4
Q: Canonical question about shell operators

terdonA few of us were discussing the fact that information on the various shell operators is spread across multiple Q&As. For example: Is there a difference between `;` and `&&` and `|`? redirection and pipeline Confusing use of && and || operators Difference between > and | with /dev/tty How can on...

 
anyone sees something missing in the btrfs question?
 
10:10 PM
Don't we have a good duplicate of this?
0
Q: find files in folder newer than

rubo77I searched through man find but it doesn't give me the answer to a simple task: I want to list all files inside a folder that were modified during the last 5 hours. I tried find ~/.purple/logs -type f -mmin 1000 to show modified files during the last 1000 minutes, but no hits. Maybe it's m...

The best I can find are this:
5
Q: Find files which are created a certain time after or before a particular file was created

teenOmarI need a shell script which finds files which are created 1 hour before or 1 hour after a particular file (test.txt) was created. If I go with find -newer, that means I'd have to create a temporary file, use touch to change the time on that 1 hour before the creation time of the test.txt file, ...

But that's with respect to another file and this one:
14
Q: How to list files that were changed in a certain range of time?

clampHow can I list recursively all files that were changed between 22.12.2011 and 24.12.2011?

But that asks for a range. Don't we have a nice find -mtime answer?
 
10:36 PM
0
Q: moving files to a folder and zip the folder

Boo NaI used to zip a few files induvidually and move them to a different folder which included lots of steps. So I thought of moving those files to a new folder and move it to the intended folder after zipping the new folder. Is it possible to do it with few commands? suggestions are welcome

 
11:08 PM
Is it possible to borrow points from one of my SE profile to use it in another SE profile?
I want to award bounty in askubuntu but I do not have enough rep over there.
 
@Ramesh nope
 
oh bummer!!
I have no other clue for this one.
 
@Ramesh report a bug...
 
@Braiam, sure but before that I still have one suspicion. Will it be because of some router setting?
 
Do you have an /etc/sysconfig/selinux file?
do a $> diff -y selinux_config_1 selinux_config_2
 
11:15 PM
@TylerMaginnis, I have /etc/selinux/semanageconf file.
 
How many lines is it?
Big, right? SELinux has a lot of options.
 
41
 
not that big
I would use stream editing to make changes to semanageconf
18
Q: Insert a line at specific line number with sed or awk

ashokI have a script file which i need to modify with another script to insert a text at 8th line. String to insert : Project_Name=sowstest in to a file called start i tired to use awk and sed but my command is getting garbled please help me out Thanks in advance

 
@Ramesh no, that is the driver fault, router has nothing to do with it
 
Insert lines into the file and refresh the config. Use the $> diff -y file_1 file_2 output to determine which lines are different, as I understand you only want to borrow specific lines.
 
11:17 PM
I am downloading policycoreutils to have the sestatus command.
I probably will disable it. But still not sure why that might be an issue.
sestatus: disabled
I believe selinux might not be an issue.
 
11:29 PM
@terdon: Find a file which is 30 minutes old and Finding a file which created X minutes back (without GNU/BSD find) (which were asked one week apart by the same user) both discuss fine-grained time-based searches in find.
 
@G-Man Thanks, the first one is perfect!
 

« first day (1458 days earlier)      last day (1929 days later) »