« first day (1306 days earlier)      last day (3501 days later) » 

1:35 AM
For those looking for a more structure intro to the linux command line, I came across this book which is free. linuxcommand.org/tlcl.php
2:04 AM
happy International Day Against DRM, all!
and with that, I'm off to hand out fliers
3 hours later…
5:31 AM
any python folks here?
@Webby don't ask questions in chat
ask them on Unix & Linux
and in any case, saying "any python folks here" is absolutely useless. don't ask to ask. just say your question if you must ask in chat.
sorry I should have been more clear
Are we allowed to paste question here?
I guess not, so that is the reason I didn't pasted here
@Webby ah, good thing you asked. no. we don't allow pasting questions, ever. it's annoying.
if you do I will probably shout at you.
sure. I won't do that
then.. Sorry about that.
mostly because I'm getting tired and cranky about doing it so much :)
@Webby no worries
wow, I was thinking I should black out faces in that picture
and then I realized it would be public anyway, except now I've already deleted it
2 hours later…
7:25 AM
2 hours later…
9:06 AM
I know that I can't get an honest answer out of the admins but. doing nothing is not an option. Guys don't know so they hold or close the question. and it is not the first time. abit of common sence. either I am wrong and You tell me the thing you want to do is not possible and that is the end. or if it is you give an example.
but to wide to answer and such is not really an option for A=>B question. by doing that you insult that person's intelligence
*too wide
2 hours later…
10:40 AM
Hi Folks, one of the shell script i'm running throws the error "bash: /home/udhay-dev/work/udhay/bin/apache: Is a directory"
And here is the line throwing the above error,
echo 'sudo /usr/sbin/apachectl graceful' > /home/udhay-dev/work/udhay/bin/apache
What is this line means and what could be the error?
11:33 AM
@Udhayakumar It means just what it says. You are attempting to write to a directory instead of a file.
@r004 what are you talking about?
@Udhayakumar You want to change that line to something like:
echo 'sudo /usr/sbin/apachectl graceful' > /home/udhay-dev/work/udhay/bin/apache/some_file.txt
12:17 PM
@slm why're you closing this?
2 hours later…
2:17 PM
@terdon It was unclear to me what he wanted to do.
@slm He's using Arch in Iran where, apparently, the AUR servers are blocked so he wants to install using a .deb file and bring in the dependencies while on arch and not a Debian-based distro
By the way @slm, did you see this?
2:49 PM
Q: Background Clock with tty-clock and urxvt

r004I was thinking of ways I could have a nice background clock for my Linux desktop and I started tweaking with tty-clock and urxvt. urxvt -tr +sb -borderLess -override-redirect -geometry 36x9+1388+28 -e tty-clock -C 6 but still compton makes shadow for it. (that is fine!) The main problem is the ur...

... I think that's what he's talking about\
@derobert I know, I found it and left a message there. Thanks.
Yeah. It didn't help that OP isn't able to write clear postings.
anyone know the current state of read-only bind mounts?
It seems like the two step process and patch have been around for a while lwn.net/Articles/281157
am I missing some easy command?
3:17 PM
@StrongBad Not that I know of. But, "if you have a question, see unix.stackexchange.com/questions/ask" ... you probably want to ask on the site.
@derobert I am not sure it is a good question and parts of it are duplicates.
3:49 PM
I asked it any ways though. Will see what happens
morning everyone!
4:51 PM
Q: Why doesn't mount respect the read only option for bind mounts?

StrongBadOn my Arch Linux system (Linux Kernel 3.14.2) bind mounts do not respect the read only option # mkdir test # mount --bind -o ro test/ /mnt # touch /mnt/foo If, however, I remount the mount then it respects the read only option # mount --bind -o remount,ro test/ /mnt # touch /mnt/bar touch: ca...

... That's @StrongBad 's question. Save everyone else the effort of going through your Expatriates profile, to your network profile, finally to your Unix & Linux profile, to find it.
/me wonders if there is an easier way, keeping in mind that usernames can be different on different sites.
hello everyone
@derobert I don't understand why they let you have different names for different sites. It is made worse by the chat username being global. I need to fix them all.
Is it normal to be up to pts/35 on a single-user desktop? :-\
@StrongBad Because they started out as largely independent sites.
Its also why you have to create a new account for each SE site you visit, etc.
And chat username isn't fully global. It's just that there are only a few (3?) chat sites.
@derobert sure, but once the accounts are linked, they should be linked (or at least there should be that option).
5:00 PM
@StrongBad Yeah. I'm not sure, copy to all other profiles might do that (as well as everything else...)
@derobert huh? Everything is served on a single one chat.stackexchange.com isn't it?
@terdon No. Meta.SE has its own chat. SO might as well.
huh, OK
But they share the same rep and username.
@derobert I missed that option. All my profiles seem to be the same now ... Thanks
@terdon Not sure, do they? Guess its easy enough to find out...
5:03 PM
@derobert When you get a chance will you try mount -o bind,ro instead of mount --bind -o roon your Debian systems.
@derobert Yeah, I have the same account on the tavern and here for example, and same rep
Well, it looks like on chat.SO your parent user has to be the SO one. So that'd be different.
Same with chat.meta
So if your Unix & Linux username were different, you'd have a different name here than you do on SO chat. Or if you linked your chat.se with a different site's account
`root@Zia:/home/anthony# mount -o bind,ro /tmp /mnt/tmp`
`mount: warning: /mnt/tmp seems to be mounted read-write.`
... that was on the one with upstream kernel. Let me try with a Debian kernel
Watt:/home/anthony# mount -o bind,ro /tmp /mnt/tmp
mount: warning: /mnt/tmp seems to be mounted read-write.
... that is with a Debian kernel.
@StrongBad so it'd seem Debian lost or dropped that patch.
@derobert so it looks like they dropped the patch.
But there are still doing something since on Arch it fails silently.
@terdon I have +10k in chat.se, 1.~k in chat.SO and +2k in chat.mse
@Braiam Oh. Huh, OK then.
5:10 PM
Tested on a Wheezy box, doesn't work there either.
Tested on a Lenny box, it fails silently there.
@StrongBad so, I don't think it ever worked in Debian. Guess I need to find a squeeze box
Ok. Tested on a squeeze box, fails with warning there.
@Gilles Odd. This did not work on the Debian Lenny and Squeeze boxes I tried it on just now. On Squeeze, it gave a warning; on Lenny, it failed silently. — derobert 8 secs ago
6:11 PM
@terdon my take on that Q
A: List out strings which are substrings of other strings in the list

slmA hacky way to do what you want. I'm not sure if all your examples will include a underscore or not but you could key off of that and use sort -u to produce a unique list of substrings that are present within a given file, using the actual file itself as a list of fixed strings to grep, via the -...

@slm Sneaky! I like it.
@terdon Did you want me to vote to reopen that arch Q?
I already did so. It seemed quite clear if not very well written to me and I felt sorry for the OP. I thought jason came on a bit strong.
If you think it worth reopening, do so, but I'm not asking as such.
There's already an accepted A and the OP hasn't made any attempt to "fix" it so I'm inclined to leave it as such
but obviously my arm can be twisted if ppl really want it
6:28 PM
Nah, if he's accepted, sod it. Any ideas here? I have no idea about csh syntax:
Q: Shell script condition for if string contains a newline character

2rs2tsI'm not sure how to express this using the csh string matching syntax. I want to test whether a csh variable contains a newline. I'm basically looking for: if ($mystr !~ <pattern for strings which contain a newline character>)

m.... 3 upvotes in 3 of my answers in AU
@Braiam ?
that I may hit votes reversal today
anyones knows what's the drill with and ? I saw this meta Q but I still don't understand where I have to use them
A: How can I download all usernames?

Andreas WieseOn Linux systems there's the getent program, which utilizes the standard get*ent(2) functions (getpwent() being the one to use here). What you want to retrieve are the contents of the passwd database (try man nsswitch.conf for a further understanding): $ getent passwd root:x:0:0:root:/root:/bin...

wow, major creepy:
"It is not homework. There is a new foreign very hot female student (I'm foreign student too, anyway), I don't know her name. So, instead of manually checking the last 5000 accounts I thought that it would be better to build a database, check the last 7000 accounts, sort them by unique given names (like where a given name appears only once), and then concentrate on the departments in the Business Administration building. Then it would be easy to spot her"
What happened to social interaction?
Hi. How are you? What's your name?
@Patrick "How can I download the internet using Python?"
6:44 PM
@Patrick That has to be one of the most pathetic things I've ever heard.
@Braiam Python newb, but import internet?
just... don't google that ^
@Braiam Oh for fuck's sake man, I really did not need to know that.
please tell me you didn't google
At least not while at work. Otherwise corporate security will be showing up any moment...
Yes. I did. I was in a state of blissful ignorance about this particular meme until 30 seconds ago
6:57 PM
that's why I always go to explain-xkcd first :/
7:25 PM
@terdon What meme? If the girls/cups thing, I still have no idea what it is about.
@FaheemMitha just don't google it!
well, not anywhere were you don't have ssl
btw @terdon, don't you use https everywhere?
@Braiam I did. This is India. Nobody cares. Well, they have some anti-porn squad or something. Nothing better to do, probably.
Oh, coprophilia. How delightful. I think I'll skip watching the video.
7:43 PM
@Patrick Electronic stalking. Huh.
7:54 PM
@Braiam no. Why?
2 hours later…
9:29 PM
@terdon I presumed you did
10:23 PM
heh, was just looking at the top users & their tags:
linux, shell, bash
bash, shell, linux
shell, linux, bash

« first day (1306 days earlier)      last day (3501 days later) »