« first day (1152 days earlier)      last day (2920 days later) » 

4:26 AM
Hi all, what are all the topics that are allowed here?
 
Thnx...Do I gain or loose reputation on chatting here?
 
slm
@RubanSavvy - you neither gain nor lose anything by chatting
 
Thanks :)
Can you (slm) suggest any book for learning advanced linux server management ?
 
slm
4:47 AM
what do you mean by advanced?
 
5:00 AM
Advanced: Not installation and basic configuration, but even more than that, nuts to soup.
 
5:23 AM
@RubanSavvy you may get a lot of bang for your buck out of things that aren't specifically for system administration - e.g. Classic Shell Scripting
(I'm not saying that's what you should do/get, just noting)
 
Do I have to learn shell scripting to be a Server Admin?
 
you don't have to if you don't want to, but it will really help
it will let you automate things in your system much better. shell scripting is really powerful if you use it right.
 
Hmm they I should get a dive into it..
 
@RubanSavvy you don't really have to start with a book, though. try man bash.
and then learn about the bash builtins. man bash-builtins. that will help you learn to control your shell better
and will thus help you write scripts later.
if you really want a book on system administration, though, I've heard that the UNIX and Linux System Administration Handbook is really good: amazon.com/Linux-System-Administration-Handbook-Edition/dp/…
I'd get @slm to back me up on that last part, though. I'm not exactly an expert in system administration
 
slm
That book is fine.
I would start w. everything that's free though
 
5:33 AM
@strugee Ok man pages doesn't cover on scenarios on using shells besides it is very monotonous, that;s why I prefer books to man pages.
 
@RubanSavvy yes, I understand that
@slm beat me to it :P
 
slm
The best way to learn is to make up things you want in your house and then set them up
cups, dns server, web servers, ldap servers, dhcp servers, etc.
nfs server
these are all the things you'll need to do to be an admin
a book is actually the worst place to learn this stuff imo
 
Hmm tldp.org I've already been to this page but driven crazy on that site. What is that site anyway? does it have any books or what?
 
slm
i actually own very few admin books, i have many programming books and only like 3 admin books that are more unix than anything else, i used them probably 10-15 years ago, not much after that
tldp is a project to create howtos
 
5:36 AM
yeah, I was never able to really sit down and read literature (which is why I still have yet to read my shell's manpages, despite recommending them above). I think books are still valuable, though, to fill gaps in your knowledge
 
slm
learning admin is more of a bottom up than a top down thing
 
@slm What are those three books?
 
tldp tends to be a little outdated, though
 
slm
unix for the impatient is one, the other is a vax manual i got in college and some unix shell book i got, they actually suck, but was all i had pre internet
i have all the perl programming books and lots of ruby
yeah tldp is old but free and still relevant
 
@slm Oh gosh! perl and ruby what are those for?
 
slm
5:38 AM
everything i know i taught myself, and it all started with picking a weekend type of project to do something i could use at home
programming languages
 
+1 for free things.
@RubanSavvy Perl is traditionally a "classic UNIX language" but people are using Python, Ruby and others more and more nowadays
 
slm
ruby has koans, which are little situations where you have to either code something or fix some broken code
those are fun to learn things
yes i would go w/ python if i was starting out
but respect perl because of it's age and it has cpan libraries w/ modules that you'll ultimately want to use some day as admin
 
Hmm how python, shell and perl differs ?
 
slm
i use perl daily at work and i'm a developer
i use bash daily too
sed/awk/grep etc. too
 
yeah a bunch of stuff is written in perl so it will be useful to know
@RubanSavvy Python and Perl (and Ruby) are real programming languages
shell is a nice way to put something together quickly but you shouldn't write real projects in it
 
slm
5:42 AM
7
A: Guided tour at the console?

slmman & info This is too complicated to pull off, IMO. I get your idea but I've been working with Linux/Unix for the better part of 30+ years and continue to learn things everyday that leave me wondering how I hadn't learned this bit yet. I will leave you with this though. Most of the help that o...

 
sed, awk and grep are utilities that can be used interactively and in shell scripts
 
slm
you have to contain the learning to something specific or concrete otherwise it's like trying to stand at the beach w/ the waves crashing into you.
4
 
@strugee why real projects shouldn't be written in shell?
 
slm
the syntax of shells isn't the greatest for long form programs
they're typically not good for reusing pieces of functions that you built up, which is the cornerstone of programming
they (shells) can be very unforgiving and fragile when changes are made
 
@slm Hmm thanks its crystal clear now.
 
slm
5:46 AM
i just wrote a program in Bash mainly b/c it was easy to start, but you have to write them in a specific way so they are easier to maintain, this is only obvious after you've coded in them for years
 
and, shells are ambiguous. for example, a number in bash: 1. a file descriptor for a file called "1": 1. a string: 1. in real programming languages these types of variables are differentiated
 
slm
do you have linux system setup now?
 
@slm Yup ubuntu and centos
 
slm
what do you use them for? just desktops?
 
Nope I use Ubuntu for NIS, NFS, SAMBA, and SQUID server.
 
5:48 AM
@RubanSavvy I'm a bit hesitant to recommend this, but when you feel up to it, you may want to try a command-line focused distro like Arch. the barebones way that Arch is set up will force you to learn a huge amount about your system, and it will probably help you understand a lot more about what's happening underneath
but don't do it before you're at least moderately comfortable with the commandline.
 
slm
there are many projects to undertake there
 
@strugee Sry to ask this, What is Arch?
 
slm
i would stay away from that to start
 
@RubanSavvy it's a power user distribution. its full name is Arch Linux; I was abbreviating. and yeah like I said, you need to be OK with the console before you do it
 
slm
there is another distro called gentoo which is similar, you basically build everything yourself is kind of the idea
 
5:51 AM
@slm Why so?
 
slm
linux from scratch is another thing to explore
b/c many ppl like to see how everything works from the bare metal of the system up to the GUI
 
YES. this. I'd say do that even later though.
 
slm
same reasons wood workers make their own jigs and tools etc
more control
same reason ppl build their own hotrod cars
 
@slm I'm comfortable with console, for training purpose shall I use that in a VM?
Arch in VM
 
slm
sure, which vm technology are you using?
virtualbox?
 
5:54 AM
Vmware workstation.
 
slm
you might want to try using KVM
only to be familiar w. another tech.
often there are many ways to do things, knowing the general method (not tech. specific) can be very enlightening too
 
@slm Hmm I like Virtualization n cloud. Arch is free eh?
 
slm
free
i do not understand your comment?
virt. n cloud?
 
haha ok sidebar for a quick story:
 
@slm Thats great.
@strugee I did anythin wrong?
 
5:57 AM
so I was attending a talk at a conference about problems with the GNU/Linux ecosystem and the speaker was talking about package formats
@RubanSavvy no your comment about free just reminded me of something funny
and so the speaker goes, "someone tell me what you can do with Red Hat and RPM that you cannot do with Debian and DEBs."
and so someone from the audience goes, "pay for it?" and we all cracked up
 
@slm I'm in a thought of studying open stack.
 
slm
openstack would be a worthwhile endeavor
 
@slm I'm really searching for a tutorial to start with.
 
slm
ppl mock RH but people forget that w/o them much of the Kernel development and support of ppl using opensource would likely never happen w/o them
about openstack?
 
@slm Yup.
 
6:02 AM
yeah that's true. and it's pretty impressive that Red Hat is still prospering with CentOS
 
and, they contribute a lot of stuff to GNOME.
 
slm
yeah. and realize i don't pay for any of their products either
 
@slm Thats very true. I got their distro freely shipped.
 
slm
they generally are good from a community perspective
 
6:03 AM
Red Hat is, IMHO, a model free software company
 
slm
agreed
no company is perfect but they try
 
mutters bitter comment about Canonical and the Mir graphics stack
 
slm
yes canonical on the other hand is a dilema
they tend to feel like it's their way or the highway
 
yeah and honestly, I wouldn't really mind that attitude if it didn't end up screwing over the rest of the ecosystem as well. like, I wouldn't care about Mir at all if I wasn't worried that it would bump Wayland drivers lower on the list of graphics vendors. except for Intel. <3 Intel.
 
slm
upstart and systemd
that is going to waste everyones time
 
6:10 AM
Upstart and systemd:
Upstart's event system doesn't even make sense
systemd's way of thinking is: oh, you want to start Apache? that means we gotta bring up the network. hold on a sec while I do that.
Upstart's way is: OK, we've brought up the network. that means that we're now able to (and will) start up Apache.
and I am now really regretting pasting a gif into this room, because now it's going to be flashing like that for all eternity.
 
slm
@strugee - what's wrong with my A to the rpm/deb Q?
 
@slm oh, should have mentioned the reason I said that.
I'll reply as a comment, for context on the question
 
slm
yeah I'm looking and this Q is turning into a nightmare
thanks
 
6:25 AM
maybe it will become the new gui-mounting-under-the-hood
or, more optimistically, maybe we can try to combine all the answers into yours and get a canonical "what is a package manager" question
 
slm
yeah that gui mounting, i hate these 5 Q's in one. They make the site messy
but ppl love them, b/c they're often these innocent looking 1-2 sentence kinds, which usually is a indicator that they're overly broad, but they're perceived easy to answer so ppl can't resist
 
yeah I'm with you. they're terrible for the SE model
but I'm more optimistic with this one. I think it's just a little broad, not a "closed because OP is OP" candidate
 
6:51 AM
the new Nginx room under this site seems to be spam
 
 
2 hours later…
9:05 AM
@slm thanks for approving my edit, but I missed a really important letter in the edit suggestion. In the title, I meant to capitalise the letter "i". If I edit it now, it will be too little for a suggestion. unix.stackexchange.com/questions/103621/…
 
slm
@Kevdog777 - it's OK I fixed it.
 
9:20 AM
@slm Thanks :)
 
 
3 hours later…
12:39 PM
@strugee what doesn't make sense about that? It's the same thing, just looking at it from the other side. Some things are easier to express in one representation or the other, of course.
 
1:22 PM
For the record, increasing the amount of disk allocated to a VM turns out to a PITA. At least the way mine are set up.
1. lvextend the logical volume on the host. 2. Reboot guest. 3. gfdisk on guest, delete and recreate both extended partition, and logical partition. 4. Reboot guest, again. 5. pvresize on guest. 6. lvresize on guest. 7. resize2fs on guest
Now I get to install an Oracle client! Fun!
 
slm
@derobert what tech are you using for virtualization?
 
@slm This is a home-grown KVM setup
 
slm
We use KVM too
 
Newer stuff here at least uses libvirt to manage it... this one doesn't.
 
slm
what version?
 
1:30 PM
qemu-kvm 1.1.2+dfsg-6
 
slm
yeah when we moved to a newer ver. we were able to extend the VMs easier. Before that we used to have to concat a empty 10GB file to extend them 10GBs.
 
ouch
our guest disks are logical volumes on the hosts... so resizing those is easy, at least.
 
slm
4
A: How do you increase a KVM guest's disk space?

slmThese serverfault questions are similar but more specific, KVM online disk resize? & Centos Xen resizing DomU partition and volume group. The 1st asks the question of how to increase a KVM guest while it's online, while the 2nd is XEN specific using LVM. I'm asking how to accomplish this while th...

instead of using files you use actual lvm's on the host for the guests?
 
yep
Giri:~# lvs
  LV                VG   Attr     LSize  Pool Origin        Data%  Move Log Copy%  Convert
  portal-dev-backup Giri swi-a-s-  5.00g      vm-portal-dev  56.31
  root              Giri -wi-ao--  5.00g
  var-lib-mysql     Giri -wi-ao--  8.00g
  vm-cp-newauth     Giri -wi-ao-- 10.00g
  vm-lenny-64       Giri -wi-ao-- 10.00g
  vm-lenny-base     Giri -wi-ao-- 10.00g
  vm-portal-dev     Giri owi-aos- 10.00g
  vm-portal-test    Giri -wi-ao-- 10.00g
  vm-squeeze-32     Giri -wi-ao--  5.00g
  vm-squeeze-64     Giri -wi-ao--  5.00g
 
slm
how does the space show up to the VMs like this?
I've never tried it like this
 
1:38 PM
@slm as /dev/vda or /dev/hda
or /dev/sda or whatever
I realize now I could have run gfdisk from the host and saved a few guest reboots
kvm uses the LVs as raw images
so, e.g.,:
Giri:~# fdisk -l /dev/Giri/vm-wheezy-64

Disk /dev/Giri/vm-wheezy-64: 16.1 GB, 16106127360 bytes
255 heads, 63 sectors/track, 1958 cylinders, total 31457280 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006bc90

                  Device Boot      Start         End      Blocks   Id  System
/dev/Giri/vm-wheezy-64p1   *        2048      499711      248832   83  Linux
/dev/Giri/vm-wheezy-64p2          501758    31455269    15476756    f  W95 Ext'd (LBA)
its actually fairly easy to access the guest disks from the host.
 
slm
What does the mount show up like inside the VM?
 
root@wheezy-64:~# gfdisk -l /dev/vda
GNU Fdisk 1.2.4
Copyright (C) 1998 - 2006 Free Software Foundation, Inc.
This program is free software, covered by the GNU General Public License.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.


Disk /dev/vda: 16 GB, 16105098240 bytes
255 heads, 63 sectors/track, 1958 cylinders
 
2:00 PM
INFO: Start output from spawned process:
INFO: ----------------------------------
INFO:

INFO: /opt/oracle/oracle/product/11.2.0/client_1/bin/genclntsh

INFO: /
INFO: usr
INFO: /
INFO: bin
INFO: /
INFO: ld
INFO: : cannot find /usr/lib64/libpthread_nonshared.a inside

INFO: collect2: error: ld returned 1 exit status
INFO:

INFO: genclntsh: Failed to link libclntsh.so.11.1

INFO: make: *** [client_sharedlib] Error 1
UGH. Another $#@!)#)(!# RedHat-ism.
 
slm
@derobert - what Debian doesn't have any -isms either? WTF's w/ /etc/network/interfaces. And don't get me starteed w/ the whole apache virtual domains crap.
BTW, oracle sucks
wrt setting it up
it's like a friggin OS install
 
@slm Oh, yeah, if I was trying to install software on RedHat, and it kept expecting things in Debian locations, I'd complain about #@#(*!@# Debian-isms
Thankfully, I only need to get the instant client installed...
 
slm
sqlplus? or the library?
 
I need the C library, so I can build DBD::Oracle against it.
 
slm
yeah been there
worked for me, but i wasn't on debian 8-)
 
2:08 PM
Yeah, I have a build script for Debian 7. First time trying on 8, I think.
root@wheezy-64:/opt/oracle/oracle/product/11.2.0/client_1# cat lib/stubs/libpthread.so
/* GNU ld script
   Use the shared library, but some functions are only in
   the static library, so try that secondarily.  */
OUTPUT_FORMAT(elf64-x86-64)
GROUP ( libpthread.so.0 /usr/lib64/libpthread_nonshared.a )
I bet that's where its coming from.
Easy enough to edit and retry.
Hmmm. Still fails. Coming from somehwere else.
Wait, nevermind, different library this time.
genclntsh works now. Slowly getting further...
 
2:29 PM
#$(@!*()#* ORACLE INSTALLER.
You can't do anything else while it's running.
Because even when minimized on a different desktop, it'll manage to pop up a dialog and steal keyboard focus.
And of course its default to the install failing is "ignore it, and continue anyway". Which it took an undetermined number of times.
 
2:44 PM
Anyone have time/patience for a newb question about iptables?
 
@slm, hey. I have just asked a question why my edit suggestion was rejected after it was approved, rejected and edited all at once. meta.unix.stackexchange.com/questions/2540/…
Really confusing
 
@Kevdog777 well, the simple answer is Anthon didn't check the 'suggested edit was helpful' box
 
3:00 PM
@derobert If he did check the box, could he still have edited it again afterwards?
 
When you have enough rep on the site (I forget how much exactly, 3k or 5k, probably), you get three options when reviewing suggested edits: approve, reject, improve
If you click improve, it lets you edit the question/answer, starting with the suggested edit as a base
There is a checkbox on that page for whether the suggested edit was helpful or not
If you check it, Community will approve the suggested edit. If you don't check it, Community rejects the suggested edit.
Either way, your improved edit shows after that.
 
Ah ok, that makes sense now, thanks for that.
 
Ok.
I copied it to an answer on meta. Anyone who wants to is free to clean it up. Or to post their own answer which is less lazy :-P
 
haha thanks. Was about to ask if you could put it as the answer
 
 
1 hour later…
4:08 PM
How do I record audio in Gnome / Fedora 19?
 
@ThatBrazilianGuy from what source?
 
@ThatBrazilianGuy sounds like a good question for the main site
 
@terdon audio mixer
I have gnome-sound-recorder running, but it shows only "capture"
 
and does it capture?
 
well
i dont know
i have no mic
 
4:14 PM
Umm, so what are you expecting to record?
 
system audio
not mic in
is that even possible?
 
Should be, yes but I've never tried it
You mean you want to play sound from one program and record it in another?
 
Sounds like XY, why would you need this?
If you already have your sound in digital form, are you just trying to change formats?
 
I want to record a live webinar
I do not have the source file
Because, well, there's none
 
4:20 PM
Ah, OK, gotcha
Wvat are you watching it with? I would guess that vlc can do this natively
 
Flash player embedded on a web page
 
@terdon I am using it but doesn't record audio :(
I had no time to test it properly
It already started
I will test better later
Maybe create a Q&A
 
OK, sorry, never tried it either so I can't really help.
 
@derobert what were you referring to when you said this?
 
4:27 PM
@ThatBrazilianGuy have you tried something like the youtube downoader plugin for firefox? There are various addons that allow you to save flash videos.
 
10 hours ago, by strugee
Upstart's way is: OK, we've brought up the network. that means that we're now able to (and will) start up Apache.
@strugee you can click the little arrow to the left of the message to see what it refers to
 
@terdon It is a live streaming. Don't think it will work.
Thanks for the suggestion
 
@terdon ohh. my point was that just because I brought up the network doesn't mean that I want to bring up Apache. the problem with Upstart is that it doesn't ask.
with systemd you have to explicitly enable the Apache service in order to have it brought up.
 
@ThatBrazilianGuy OK, but try watching it through vlc, that's probably your best option. This link suggests it should be easy to point vlc to the stream and save the output:
@strugee I guess you were talking to @derobert?
 
@terdon haha it is a RTMP link!
 
4:30 PM
Ah. I haven't actually used upstart, at least not seriously. Nor systemd.
 
@ThatBrazilianGuy vlc can deal with that:
 
@terdon yes. facepalms
 
@derobert 0pointer.de/blog/projects/systemd.html is good reading. search "upstart" in the page
 
Debian.SE, really?
 
4:40 PM
@Braiam wow, why???
Well, not your proposal...
read that yelling out to the universe, demanding an answer
 
Debian.SE, REALLY?
 
I wonder what the proposer's justification is for the overlap with us. I mean, I genuinely cannot imagine a reason.
 
I guess there are some Debian questions that'd be off-topic here. E.g., maybe we wouldn't take a question about how one becomes a Debian Developer, or other Debian project stuff...
But I don't think I've ever seen such a question asked here.
 
yeah. any technical question, though, is on-topic IMO. even Debianisms are fully on-topic, because of Debian's size.
 
Anyway, its lunch time now!
 
4:49 PM
well, maybe is about "debianization" and development in debian like the guy in this comment said
 
 
2 hours later…
6:38 PM
@slm you lose time. But you don't gain a date (if there's one thing that's inappropriate for SE chat, it's that).
@Braiam <distro>.SE proposals come up every couple of months or so
I've written several posts on D.A51 to explain why Ubuntu is a special case and others aren't warranted. Which get deleted with the associated proposal :(
 
@Gilles do you have a template by now?
 
@strugee no, I didn't keep a copy
 
ouch.
 
SE sets whatever header it takes not to appear in the web archive, so deleted posts disappear from the web
 
@Gilles what's the reasoning for that? is there a meta question about it?
 
6:45 PM
 
@strugee the rationale is that each new proposal gets its chance, a failed proposal can be deleted and restarted afresh
this is a good reason to delete proposal, but not the associated discussions
we've never managed to get Robert to grasp the difference
 
@Gilles I meant the archive header. deleting old proposals makes perfect sense (except for the associated discussions bit).
helpful information from the newbs: "I think I'm using UNIX." unix.stackexchange.com/questions/103570/…
 
@strugee which he isn't. I don't think there are any UNIX hosting providers (maybe Solaris?)
 
yeah. it's obviously a drive-by question
 
@strugee ...
 
6:59 PM
@Braiam indeed.
 
Do KDE and Gnome still have the .desktop extension?
I mean exploit
 
@Ufoguy ?
the .desktop file format is a standard from freedesktop.org
it's used in both KDE and GNOME, for e.g. defining applications in /usr/share/applications
@Ufoguy and what do you mean "exploit"?
 
slm
7:24 PM
@strugee - this link didn't work 0pointer.de/blog/projects/systemd.html
 
@slm it isn't working for me either, but it was working a couple hours ago.
I think Lennart's site is down.
 
@slm speaking of tags, I try to enforce the distinction between (after the unix OS is loaded, i.e. the kernel is running) and (getting the unix OS to load, i.e. the bootloader and kernel configuration)
I'm not sure what the exact boundary is: are initrd and such since they are running under a (restricted) unix OS, or since while they have a unix kernel, like Android, they don't have a unix userland
 
@slm web.archive.org/web/20131104092908/http://0pointer.de/blog/… works. search for "upstart" if you're there to read about the event system madness
 
@Gilles that's too difficult to happen, IMHO
 
10
Q: /boot vs /startup

GillesThe distinction between the tags boot and startup isn't very clear. The tag wiki excerpt for boot reads This tag covers both bootloader issues (what happens before the operating system starts) and the starting up of the operating system. However, I think since this excerpt was written almos...

@Braiam I enforce vs , and vs not-linux-specific, and vs ...
 
7:29 PM
@Gilles personally I'd vote for the initrd to be [boot], since it's a transient part of the boot process (like the bootloader, it doesn't stick around)
 
@strugee how did you mess did that with the markdown
 
@Braiam what? I tried -dashes like this-, and then <strike> tags. does it need to be -per- -word-?
 
nope
I can strike entire walls of text like this
 
how?
 
the trick here it's that you need 3 dashes ---
 
7:32 PM
@strugee ---like this---
 
hmm
ah. clearly I need to brush up on my Markdown
 
 
1 hour later…
8:42 PM
10
Q: Is there any reason why I get ^[[A when I press up arrow at the console login screen?

Ruban SavvyWhenever I'm at the console login, I press up arrow intentionally to see the previously typed commands. But I see this ^[[A. But when I press Ctrl Alt Print Screen Scroll Lock Pause Break Page Up Page Down Win keys doesn't echo any characters. What might be the reason behind? Does ^[[A sort of...

^^^^ did this question get multicollided or something? it has a lot of upvotes for a mediocre answer and a completely wrong one
 
slm
@Gilles - what's multicollided?
agree on the Q & A's I thought we had this already on the site too. I looked last night and could only find Q&A's that kind of matched it
I was searching for combinations of "weird characters" "escape characters" and even "^[". couldn't find one though
 
@slm appeared in the “hot questions” list in the going-away-tonight multicollider (the 4-in-1 dropdown menu at the top left)
@slm I must have written half a dozen posts on the subject, possibly one of them is a dupe
 
slm
@Gilles - I know, that's why I didn't even bother writing an answer, seemed like it was already covered here, if not directly there are at least several dozen that discuss strange characters and what they are and why.
@Gilles Ah, I don't think I've ever pulled that hot questions tab before today.
 
 
2 hours later…
10:24 PM
so I wanted to post on meta regarding the new top bar. Oops, no more meta link
 
slm
no chat either
oh they're under the stackexchange pulldown
next to the U&L site
 
10:47 PM
@Gilles meta.stackoverflow.com/questions/207420/… says to post problems on meta.SO with a top-bar tag
 
11:38 PM
@Gilles is my answer wrong?
 
11:59 PM
@strugee “representation of the raw character code of the Up key” is at best misleading
 

« first day (1152 days earlier)      last day (2920 days later) »