12:42 PM
0
Q: Netbeans 8.1 won't make it past "Turning on modules" screen

Manos KounelakisThis week I installed netbeans 8.1 in my fresh ubuntu 18.04 installation.Prior to that I have installed jdk,jre and configured the JAVA_HOME variable.After trying to open netbeans I get the netbeans loading screen.However when the loading screen writes "Turning on modules" after a while netbeans ...

 
Netbeans 8.1 doesn't work in Ubuntu 18.04 by Netbeans 8.2 can be installed by ubuntu-make with umake ide netbeans and it works in 18.04, but I don't think it's worth installing in Ubuntu 18.04 because the Eclipse snap package (eclipse Extensible Tool Platform and Java IDE) is a much better IDE for Java than Netbeans in 18.04.
 
I'am a student and my professor want us to use netbeans :(
 
Your professor and you will be happy to know that Netbeans 8.2 works in 18.04.
 
I will try it and will let you know
but why isn't it working on 18.04?
 
Netbeans 8.2 doesn't have any problem recognizing openjdk-11-jdk automatically in 18.04. Netbeans 8.1 does not recognize openjdk-11-jdk automatically in 18.04, and it does not recognize openjdk-8-jdk either, even when openjdk-8-jdk is selected as the default java.
 
12:42 PM
I don't have jdk 11
 
openjdk-11-jdk isn't Java 11, it's just a funny package name in 18.04. I uninstalled it and tried opening Netbeans 8.1 with only openjdk-8-jdk installed and it didn't recognize openjdk-8-jdk either.
 
I tried umake ide netbeans but it throws segmentation fault
 
Oh no, umake is so weird. It worked on mine a few weeks ago. I think your professor wants you to download the JDK 8u171 with NetBeans 8.2 bundle from the official Oracle website and install that. I feel sorry for you because the Eclipse Extensible Tool Platform and Java IDE snap package is much better than Netbeans. It's a fun IDE.
 
I have downloaded netbeans 8.2.sh.I will try that.If that doesn't work I will try your link
 
This is a screenshot of my Netbeans 8.2 in 18.04. You can click on the screenshot with the middle mouse button to view it as a larger image in a new browser tab. umake is so weird that if you didn't see it maybe you wouldn't even believe that I installed Netbeans 8.2 with umake in Ubuntu 18.04, but I did.
 
12:55 PM
I finally installed it using the latest .sh script from netbeans
and it works
 
This isn't just an 18.04 thing. Netbeans was buggy in 16.04 too.
 
I hate netbeans
 
I'm done with Netbeans.
btw PyCharm Community Edition was crap in 16.04 but it works real good in 18.04.
 
I can't create a new project
The button gets pressed but does nothing
 
I had that bug with Netbeans in 16.04 too. Netbeans 8.2 works alright in 18.04 including creating a new project, but the problem is getting umake to install it.
 
1:04 PM
I press the button but nothing happens :(
 
That was a crazy bug in 16.04. The way I fixed it was to manually edit the Java path inside Netbeans IDE. I followed the instructions that I found on Stack Overflow. Sorry, I can't remember the SO link.
 
Jesus Christ
You were right after messing with the config file I get it to work
 
1:20 PM
I'm glad that you got it sorted. You can post an answer to your own question if you want to share what you did.
 
1:48 PM
I will post it later as an answer with the link I found