5:02 PM
Q: Can't SSH into a PC

Nikola PantelicI have a laptop with Linux Mint and Windows 10. I can SSH into both Windows and Linux from both my Windows and Linux systems, but neither Linux nor Windows can SSH into this PC, no matter what OS is in the current use. This OS can't be pinged too (no matter what OS sends pings, and no matter wha...

What does your LAN look like?
C type IP, star topology, with 5-10 devices connected to it. Other PCs on this network work normally (no matter the OS), the problematic is only one laptop.
"C type IP, star topology" is this some kind of device?
Yes, this is an Asus laptop. Those descriptions refer to the network itself.
I'll try it another way: how are the systems connected to each other?
5:02 PM
Phones and laptops through Wi-Fi, desktop computers with UTP cables. They are all connected to the (and only to the) central switch/router.
Can you identify the switch? Is the switch providing DHCP? Do ALL connected devices use DHCP?
With nmap? Yes.
No, I want to know the brand and model of the switch.
Is this it: ZXHN H168N V3.1? Also, it says ZTE on the label.
All devices use DHCP, and I have no problem with it.
Finally. I'm checking the manual. Can you verify the DHCP, no duplicate IP addresses?
So, maximum four devices through UTP? The ZXHN has a firewall that provides "local security". No luck with the manual so far, it's in Tsjech
5:02 PM
There are no duplicate addresses.
I couldn't find that option in settings.
What is the IP address of the system you cannot reach, and an IP address of a system you can reach?
I can't reach, I can reach
There is no firewall configured on the itself? What is the route configuration on the system that tries to connect to the I'd like to see "netstat -rn".
What is the Linux equivalent of that command? I can't use any machine with Windows right now.
I would never issue a Windows command. netstat exists on Linux. route is good too. You may need to be root. "route -n"
Also, from the system you can't reach, you do an ssh to another system, and there you execute "who". It should show the IP address you come from.
5:02 PM
who in SSH does return the correct IP address.
I'm grasping at straws. Can you try to restart the ZTE?
Already tried that.
If it matters, I can detect that PC with command nmap -sL nmap -sn is the one that can't detect it.
nmap manual says -sL is not really a scan. When you run "arp" on one of the other systems, do you see the Is its mac address correct?
If the ARP table is correct, there's only this left: On the main page of the ZXHN H168N, select Internet > Security > Firewall Check all the rules if you find anything concerning
arp shows no output.
I only have Port Forwarding: imgur.com/a/GYPv6.
arp should at least show the, your gateway / switch ?? You can ping the, can't you?
5:02 PM
It's completely empty.
On the ZTE status page, can you see the devices connected via WiFi?
Yes. Via Ethernet too.
And the is there?
Yes. Also, arp for some reason now does show my gateway.
Looks like my NIC needs first to communicate with the gateway to be able to get some information. When I run arp a moment ago, I just booted the system. But if I first go to or ping some website, arp does detect my gateway.
OK, but that is normal for arp. Could it be that the wifi on the goes to sleep if it's not in use?
5:02 PM
Hardly. Only if it goes to sleep for 10s of non-use, because many times I was using the PC at the same time I tried to SSH into it/ping it/detect it.
Have you verified the arp after pinging the from another system
5:29 PM
After pinging, arp shows an entry with with correct hostname but incorrect MAC address (only one hexbit is wrong).